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TECHNICAL BULLETIN

DataCAD Estimator
This technical bulletin will teach you how to use DataCAD, its EstLink and FrameIt macros, and the Estimator to
accurately estimate materials and labor costs. You will begin by importing price book information from DataCAD
Estimator into DataCAD. You will then learn how to assign this information to entities in DataCAD using the
EstLink or FrameIt macros. This assigned information will then be exported to DataCAD Estimator for estimation
purposes.

Setting Up a Drawing for Estimating

Create a new DataCAD drawing by following the steps outlines below. We will use this drawing through the rest
of this Technical Bulletin.

1. Open DataCAD and type Test as your new drawing filename.

2. In the new file, go to the Utility/Layer menu and use NewLayer to create three new layers, so that there are a
total of four layers in your drawing.

3. Name these layers Walls, Win, Doors and Est-1.

4. With the Walls layer set as the active layer, draw a  16’-0” square room, using the 2LnWalls and CntrWall
options in the Architct menu.

5. Press [Tab] to set Win as the active layer and insert a 3’-0” window into each wall.

6. Press [Tab] to set Doors as the active layer and insert two 3’-0” doors into two of the walls.

7. Press [Tab] to set Est-1 as the active layer.

Exporting Estimator Price Books for DataCAD’s EstLink Macro

1. Open the Estimator program by double-clicking on the Estimator icon on your desktop or by choosing
Start\Programs\DataCAD Estimator\Estimator.

2. If this is the first time you are running the program you will be prompted to select the industry price book,
which best suits your needs.  Please select the Const: CAD/Construction Tutorial and click OK. The First
Time Help Message is displayed. Please read this carefully. If this not the first time running DataCAD
Estimator, choose File\New Bid.  Select the CAD/Construction Tutorial for the Price Book, and type Test for
the New Bid Item.

To learn to use your new Estimator program go to the Help pull-down menu and choose “How To…” then use the tutorials.

3. Choose Transfer\Export Price Book to CAD from the File menu. A dialog box displays, telling you where the
ESTLINK.EDB file will be written (Datacad\Estwin\Data\const\Estlink.edb).

4. Click Yes to export the price book.

Assigning Bid Information in DataCAD Using the EstLink Macro

1. Choose Toolbox from the Edit menu.



2. Select ESTLINK.DCX in the Macro Filename dialog box and click Open.

For more information on this macro, see Estimator Link in your DataCAD 8 Reference Manual or look in the online
DataCAD Help file.

3. You must now import into DataCAD the price book you exported above. Choose Database from the Est-Link
menu, and then choose Select from the Database menu. The Select Database File to Use dialog box displays.

4. Change directories to your Datacad\Estwin\Data\const\ directory; select the ESTLINK.EDB file and click
Open. The price book is loaded into DataCAD.

5. Right-click to return to the Est-Link menu.

6. Next you must assign a carpentry cost for the exterior walls. Choose Wall from the Est-Link menu.

7. Choose AddWall from the Wall menu. You are prompted to “Enter name for this wall:”.

8. Type ExtWall1 for exterior wall 1 and press [Enter]. You are prompted to “Enter first point of wall
‘ExtWall1’”.

9. Make sure Closed is toggled on.

10. Snap to the outside upper-right corner of our room. Continue snapping around the outside corners in a
clockwise direction.

11. After selecting the 4th corner of the room, right-click to close the space. The Wall menu now shows ExtWall1
as a button.

12. Choose ExtWall1 from the Wall menu, and then choose AddMatl to add a material. You will see the
following:

The menu options 0.000, 1.000, 2.000, etc., correspond to the options displayed in the Drawing Window. For
instance, 0.000 is No Division assigned, 2.000 is General requirements, and so on.  These options, also known as
divisions, are defined in the price book and contain the items that we will be estimating with.



13. Choose 5.000 for Metals & Carpentry.

14. Choose 5.800 Rough Carpentry, as shown below.

Notice that the last three options displayed in the Drawing Window in the screen shot below are actually option in the Metals
& Carpentry menu mentioned in step 13. The EstLink macro simply displays the current menu over the previous one. So
when the current menu is shorter than the previous menu, the last few options continue to show through. This issue will be
addressed when EstLink is updated.

15. Choose 5.811 Ext. Walls to 8’ –Carp LF. You are now prompted to choose a method to calculate the area.

16. Since we want LF (Linear Feet), choose Perimetr for perimeter calculation. Right-click until you are back in
the Est-Link menu. You have just defined an area and told the estimator that it should have its perimeter used
to calculate the linear feet for carpentry costs.

17. Just as you assigned carpentry costs for walls, you must now assign costs for the windows. Choose Window
from the Est-Link menu.

18. Choose AddWndw from the Window menu. You are prompted to “Enter name for this window:”.

19. Type Win3ft for Window, 3’-0”, and press [Enter]; Win3ft will be displayed as a button in the Window
menu. However, before you’re able to see this menu, you are first prompted to “Choose an option, or position
the label”. This label will be used by EstLink to calculate the window type information for estimating. If you
have more than one type of window then you will have more than one window label. There is one label for
each window type in the file. You can also configure how you would like the label to look, changing such
things as the font and shape of the label.

20. Position the Window label on screen, and click to place it in your drawing.

21. Choose Win3ft from the Window menu, and then choose AddMatl to add a material.

22. Choose 8.000 for Doors & Windows.

23. Choose 8.900 for Window- Anderson.



24. Choose 8.903 for the ANDSN 3/0x3/0 D/H SG. You are now being prompted to Enter quantity (EA.).

25. Type 4 and press [Enter].

26. Right-click to exit back to the Est-Link menu.

27. Next you must assign carpentry costs to the doors. Choose Door from the Est-Link menu.

28. Choose AddDoor from the Door menu. You are prompted to “Enter name for this door:”.

29. Type Door3 for Door, 3’-0” and press [Enter]. The Door3 will be displayed as a button in the Door menu.

30. Position the Door label in your drawing, and click to place the label.

31. Choose Door3 from the Door menu, and then choose AddMatl to add a material.

32. Choose 8.000 for Doors & Windows and 8.000 again for Exterior Doors.

33. Choose 8.025 EXT. Door-Right hinge 3’. You are prompted to “Enter quantity (Un):”.

34. Type 2 for the quantity and press [Enter].

35. Right-click until you are back in the Est-Link menu.

36. Lastly, you must assign costs to flooring materials. Choose Space from the Est-Link menu.

37. Choose AddSpac from the Space menu. You are prompted to “Enter name for this space:”.

38. Type Floor1 and press [Enter]. You are prompted to “Enter first point of space ‘Floor1’”.

39. Make sure Closed is toggled on in the Add menu.

40. Snap to the inside upper-right corner of the room, and continue snapping around the inside corners in a
clockwise direction.

41. After selecting the 4th corner of the room, right-click to close the space.

42. Choose Floor1 from the Space menu, and then choose AddMatl to add a material.

43. Choose 9.000 for Finishes.

44. Choose 9.200 for Tile/Marble/Formica.

45. Choose 9.203 Ceramic 4x4 Tile in Mud SF. You are prompted with “How should the material be measured”.

46. Since we want SF (Square Feet), select HorzArea to measure the horizontal area.

47. Right-click to exit back to the Est-Link menu.

48. Save your drawing file.

Using FrameIt to Export Lumber Takeoffs

1. To begin, you must use FrameIt to define a wall. Go to the Edit/Toolbox menu.

2. Select FRAMEIT.DCX in the Macro Filename dialog box and click Open.

3. Choose Walls from the Frame-It menu.

4. Draw a 16’-0” x 16’-0” polyline box.

5. Choose Build from the menu and then select the polyline you have just created. An Isometric view of the
framed room will be displayed.

6. Right-click to exit back to the Frame-It menu.

7. Choose Extract From the Frame-It menu.



8. Choose Yes when prompted with, “Ready to begin framing member takeoff?”. The following will appear on
screen:

9. Choose ToDC-Est to save the file in .csv format.

10. Change directories to your DataCAD\Estwin\Data directory.

11. Save the file as Frame1.csv.

We will see below how to import the Frame1.csv file into Estimator.

Exporting takeoff material from DataCAD into Estimator

To export the materials that we assigned in EstLink:
1. Choose Toolbox from the Edit menu. Select ESTLINK.DCX in the Macro Filename dialog box and click

Open.

2. Choose Takeoff from the Est-Link menu.

3. Choose Yes to confirm that you would like to do a takeoff now. The “Select Estimator File to Save to:” dialog
box opens.

4. Change directories to your DataCAD\Estwin\Data directory.

5. Type Test1.csv for the filename, and click Open.

6. Save the drawing, and minimize DataCAD.

To import the data into Estimator:
1. Open Estimator.

2. Choose New Bid from the File menu. The New Bid dialog box opens, as shown below.

3. Select Const: CAD/Construction Tutorial in the In Price Book drop-down box. (Note that it matches the price
book that we used in DataCAD.)



4. Under Bids in Const, select Template: Use as a Template, and click OK. You now have a blank new bid.

5. Choose Transfer\Import CAD Drawing from the File menu. The Import from Drawing dialog box opens.

6. Click the Directory for Drawing Files button and change to the DataCAD\Estwin\Data directory. Click Select.

7. Click the Drawing Interface File Name button; select the Test1.csv file and click Use.

8. You can now choose to put CAD items in either the Item Selection Worksheet or the Bid Item List. Importing
items into the Item Selection Worksheet will allow you to view the data and make any changes, such as
switching the right-hand doors to left before putting the data into the Bid List.  Keep this selected.

9. Click Import. A dialog box opens, reporting on the results of the import.

10. As instructed, press any key to continue. The Item Selection dialog box opens, as shown below.



11. Click Move Items to Bid, and then choose Cancel to close the dialog box. The information is now in
DataCAD Estimator and can be edited or reported on.

12. Now we will import the framing materials into our current bid. Choose Transfer\Import CAD Drawing from
the File menu. The Import from Drawing dialog box opens.

13. Click the Directory for Drawing Files button and change to the DataCAD\Estwin\Data directory. Click Select.

14. Click the Drawing Interface File Name button; select the Frame1.csv file and click Use.

15. As before, keep Item Selection Worksheet selected under Put CAD Items In.

16. Click Import. A dialog box opens, reporting on the results of the import.

17. As instructed, press any key to close this dialog box. The Item Selection dialog box is displayed. You will
notice that none of these materials have any cost data associated with them.  This is because they are not
linked to the price book yet. In the top three windows of the Item Selection dialog box is the price book. It is
built with Items (right-most column) put into groups called Subdivisions (center) put into Divisions (left-most
column). As you can see, each Division covers a broad area. Also note the Item Worksheet in the bottom half
of the dialog box. Items are displayed here before you bring them into your bid. You can modify these items
here.

18. You must now link the imported FrameIt data to the price book. Click on the first item in the bid: Wall B.
Plate 2x4. Take note of this; you are going to replace it with an item from the price book.

19. Select Framing Lumber. Notice that the Subdivision and Item numbers now begin with 6, which is the
Division number of Framing Lumber.

20. Select 6.0 Plates, PT & HF in the Subdivision column.

21. Select the Item number 6.001  2x4 –Random/L-HF (LF) to highlight it. This is the item that will replace Wall
B. Plate 2x4.

22. Click on the Transfer button.



23. A dialog box displays asking if you would like to replace Wall B. Plate 2x4 with 2x4 –Random/L-HF or add
it as a new item.

24. Click Replace. The Item will be transferred down to the Item Worksheet.   Notice that all of the fields will
automatically update to reflect the price for the lumber.

25. Click on the second Item in the Bid, Wall Spacer 2x4, and select an item from the price book to replace it
with. Repeat these steps for the remaining 2 items.

26. There are two ways to move our Item to the current bid. The first way is to click on the Move Items to Bid
button on the bottom left side of the Item Selection dialog box.  This will move the Item(s) back to the Bid
Item List, while you stay in the Item Selection dialog box. The second way is by clicking on the Done button
on the bottom right side of the Item Selection dialog box. This will move your Item(s) to the Bid Item List
and close the Item Selection dialog box. Let’s use the second method now to move our Item back.  Click on
the Done button.

You have now added the framing data to your bid.

Adding an Item to the Price Book

Another very important task is adding items to the Price Book for future use.

1. With the Bid Item List window showing in Estimator, click on Add New at the bottom of the list.

2. Type 12x12 Ceramic Tile

3. Click in the Bid Qty column in the same row and type 20.

4. Click in the Unit column and type SF.

5. Click in the Unit Cost column and type 7.25.

6. With one of the fields in this line selected, right-click and select Update Cost or Whole Items to/from Price
Book. The Update Items dialog box displays.

7. Under Direction, select Update Price Book Items from Bid.

8. Under Update Based on Which Bid Items, select Highlighted Bid Item Only.

9. Set Update What to: Whole Items: Descriptions, Budget, etc.

10. Click OK. A message displays, telling you how many bid items were added or updated in the price book.
Press any key, as instructed.

11. Choose Select Items from Price Book for Bid from the Bid menu. When you add an item to the price book,
that item is assigned a blank code and is stored in Subdivision 0 of Division 0. You can later move that item
under the correct Subdivision by changing its item number. Estimator will automatically move the item to its
new position in the price book.

12. Highlight 12x12 Ceramic Tile in the Price Book Items column and right-click.

13. Choose Add or Edit Price Book Items in a List. The Price Book Item List dialog box opens.

14. Type 9.204 for the Code and press [Enter].

15. Press [Esc] to close this dialog box.

It’s best NOT to change Item numbers once you have Bids with Items in them, since they will reference the original Item
number.

Once back in the Item Selection dialog box, select Division 9 Finishes and then Subdivision 9.2
Tile/Marble/Formica; you will see 9.204 12x12 Ceramic Tile has been added as a Price Book Item.


