
The Drawing Board 
A user-oriented menu system makes DataCAD easy to learn 
and convenient to use. Because it was developed by architects 
for architecture, the program focuses on design, not computer 
technology. Even draftsmen and designers with no previous 
computer experience can learn DataCAD quickly. 

DataCAD’s dual menu system combines familiar Windows 
menus in the Menu Bar with a comprehensive, nested menu 
structure in the Menu Window. This unique system, along with 
toolbars and numerous keyboard shortcuts, allows constant 
access to the tools you use to draw, instead of covering your 
drawing area with menus that are only temporarily visible. 

From your initial design work, massing studies, and interior 
perspectives to your final set of construction drawings, 
DataCAD provides you with the tools you need to produce 
quality work quickly, accurately, and with greater flexibility 
than ever before. 
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Opening a Drawing 
DataCAD has four options for opening a drawing: 

• opening an existing DataCAD drawing 

• creating a new DataCAD drawing 

• creating a new DataCAD drawing using a default drawing 

• importing a DWG or DXF drawing file 

If DataCAD does not start, review Chapter 1 to make sure you meet all system 
requirements. You have 30 days of free installation support; see the first page of 
Chapter 1 for details on how to contact us.  

When you open a file, you may see “Attention! The drawing file ‘xxx’ is currently 
marked “In Use.” Continuing will result in data loss. Are you sure you want to 
continue?” This happens if someone on your network has the file open or if the 
file was exited abnormally the last time it was used. If somebody else is currently 
working on the file, click No to cancel.  

If nobody else is working on a file and you get the “Attention . . .” message, what 
should you do? That depends on what happened to the file in an earlier drawing 
session. Often, there is an autosave (.ASV) copy of the drawing.  For more 
information about autosave files, see “More About Recovering Lost Work” near 
the end of this chapter. If you get the “Attention . . .” message but cannot find an 
autosave (.ASV) copy of the drawing, try opening the drawing and using Save 
As in the File pull-down menu to give it a new name.  

Opening an Existing Drawing 
You can open a DataCAD drawing when you first start DataCAD or while you’re 
working on another DataCAD drawing. 

 To open an existing DataCAD drawing: 

1. Start DataCAD. If DataCAD is already running, click Open in the File 
pull-down menu. A dialog box opens, listing all files in the current folder.   

2. Select the type of file you want to open from the Files of Type drop-down 
box. You can open any DataCAD, DataCAD Plus, backup, or autosave 
files.  

3. Click on the drawing you want to open to highlight it. If the Show 
Preview option is checked, this drawing will be displayed in the preview 
window on the right side of the dialog box. 

4. Click on Open or press (Enter) on your keyboard. The drawing is opened. 
If a message displays alerting you to orphaned reference files, see the 
“Referencing Drawings” section in this chapter for instructions on 
resolving these orphaned files. 
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Working with Folders in DataCAD’s Save and Open Dialog Boxes 
You’ll probably want to store your DataCAD drawings for each project in 
separate folders. If you have two projects, you might, for example, create two 
folders named PROJECT1 and PROJECT2 in DataCAD’s \DWG folder. 

 To create a new folder in DataCAD: 

1. Start DataCAD or click on New in the File pull-down menu. 

2. Click on the Create New Folder icon in the “Enter name of drawing file to 
edit” dialog box.  The Create New Folder icon is at the top of the dialog 
box. A new folder is displayed in the dialog box. 

3. Type the name of the folder and press (Enter). 

A new folder, of course, has nothing in it when you create it. Only after you save 
drawings to that folder will the drawing filenames appear in the dialog box. 

You’ll also want to save files to or open files in a different folder than what’s 
displayed in the dialog box. To do this, you’ll first have to change folders. 

 To change folders in a dialog box: 

1. Click on the arrow for the “Look in:” drop-down box and select a new 
folder; or 

2. Click on the Up One Level icon and select a new folder from the list; or 

3. Double-click on a folder to open it. 

Creating a New Drawing 
You must name your new drawing before DataCAD will open it. 

 To create a new drawing: 

1. Start DataCAD; if DataCAD is already running, click on New in the File 
pull-down menu. A dialog box is displayed with the title “Enter name of 
drawing file to create”. 

Shortcut: Press (Ctrl) + (N) to start a new drawing. 

 
2. Type a name for your new drawing in the Filename input box. The 

drawing name can be up to 80 characters long and consist of spaces, 
letters, numbers, and any other characters except the following: + / \ [ ] ; 
: . , 

3. Click on Create or press (Enter). The new drawing is opened. 

The minimize button in the upper-right corner of every drawing window is disabled. But 
you can minimize the DataCAD program window. 
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Creating a New Drawing Using a Default Drawing 
A default drawing is used as a template for creating a new drawing. Simply 
choose the default drawing, and then create your new drawing. Or you can use 
the Default Drawing setting in Program Preferences to automatically use a 
selected default drawing every time you start a new drawing. All DataCAD 
drawings have a .DC5 file extension. 

 To create a new drawing using a default drawing: 

1. Start DataCAD; if DataCAD is already running, click on New in the File 
pull-down menu. A dialog box is displayed, prompting you to “Enter 
name of drawing file to create”. 

2. Click on the Default button. A dialog box is displayed, prompting you to 
“Choose new default drawing name.” This Default button is not available 
if the Use Default Drawing option is not checked. This option is checked 
(on) by default. 

3. Click on the default drawing you’d like to use, and then click on Open. 
The dialog box closes. You’ve just told DataCAD which default drawing 
to use to create your new file. Now you must create the new drawing file. 

4. Type a name for the new drawing you’d like to create in the Filename 
input box of the “Enter name of drawing file to create” dialog box. 

5. Click on Create. Your new drawing is created, with all the settings of the 
default drawing chosen in step 3. 

If no default drawing is specified in the Program Preferences dialog box or 
through the File/New dialog box, DataCAD uses its internal default settings for 
the new drawing. To use these settings, either toggle off Use Default Drawing on 
the Misc. tab in the Program Preferences dialog box or toggle off “Use default 
drawing” in the Create New File dialog box. Also, make sure the Use Default File 
option is unchecked in the File/New dialog box. 

 To automatically use the same default drawing for every new drawing: 

1. Open any drawing file. (The Tools pull-down menu is not available 
unless a drawing is open.) 

2. Click on Program Preferences in the Tools pull-down menu. 

3. Click on the Misc. tab. 

4. Choose a default drawing from the Default Drawing File drop-down box. 

4. Click on OK to save your new settings and close the dialog box. The 
default drawing you chose will now automatically be used each time you 
start a new drawing, unless you specify a different default drawing using 
the Default button in the File/New dialog box, as described in the 
instructions above. 
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More About Default Drawings 
Default drawing files are really just regular DataCAD drawing files that are 
stored in your \DATACAD\DEFAULT folder and used in a different way than 
your regular drawing files. A default drawing contains predefined information 
and settings and is used much like a template for creating new drawings. You 
can create your own default drawings with system settings, layer names and 
colors, text font and size, dimension settings, display options, scale type, object 
snap settings, linetype spacing, and more already set; so using a default drawing 
can save you time in setting up each new drawing. 

Setting up a system of default drawing files at different scales and for different 
types of work can significantly reduce production time for drawings and provide 
consistency in work done by different designers in your office. 

 To create a new default drawing: 

1. Create a new drawing as described earlier in this chapter. 

2. Set whatever options you’d like your new drawings to have, including 
grid settings and layers. See the “Before You Draw” chapter for more 
information about many of these settings. 

3. Save the file in your \DATACAD\DEFAULT folder. It’s ready to use 
whenever you need to create a new drawing. 

Importing a DWG or DXF Drawing File 
DataCAD’s drawing translator can import DWG and DXF files compatible with 
AutoCAD 12, 13, and 14 as well as AutoCAD 2000. You can choose an automatic 
translation or an interactive one, where you can decide how each linetype and 
font should be translated and displayed in DataCAD. 

 To import a DWG or DXF file and open it in DataCAD: 

1. Create a new DataCAD drawing, as described in “Creating a New 
Drawing” earlier in this chapter. 

2. Click on Import in the File pull-down menu. The Import dialog box is 
displayed. 

3. Look at the options in the Files of Type drop-down box. Select Supported 
File Formats to display all DWG and DXF files, select DWG to display all 
DWG files, or select DXF to display all DXF files. 

4. Select a file to import from the list or type the name of the file to import in 
the File name input box. By default, DataCAD looks for DXF and DWG 
files in your DATACAD\XFER folder. If your DXF or DWG files are in a 
different folder, change to that folder and then click on the file you want 
to import. 

5. Click Open. The DWG Import Entity Assignments dialog box is displayed 
if the Import section of the DXF/DWG tab of the Program Preferences 
dialog shows that “Interactively assign . . .” is toggled on.  The options in 
the DWG Import Entity Assignments dialog box allow you to choose how 
DataCAD will translate linetypes and fonts. 
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6. Look at the options in the Line Type Assignments box; this lists each 
AutoCAD linetype used in the file and suggests a DataCAD equivalent. 
To change any of these assignments, click on the linetype to change. 
Immediately below the Assignment list box, your selection is reproduced, 
with the translation linetype in a drop-down box. Choose a new linetype 
from the drop-down box; your selection is changed in the linetype list 
box. 

7. Repeat step 6 for the Font Assignments. 

8. Click on OK to close the dialog box and begin importing the file. Progress 
is noted in the Message Area. Or click on Cancel or press (End) to cancel 
the import and close the dialog box. 

 
Figure 2.1: The Import Entity Assignments dialog box 

More About Importing Files Into DataCAD 
The settings and assignments that are displayed in the Entity Assignments dialog 
box are contained in a file called TRANSFER.INI in your DATACAD\SUP 
folder. If you change any of the settings in the Entity Assignments dialog box, 
you have the option to save those settings in a new .INI file to use when 
translating other files. This new .INI file is saved in the \SUP folder. You can 
affect how importing files and the Entity Assignments dialog box work through 
settings on the DXF/DWG tab in the Tools/Program Preferences dialog box. 

This could be useful if, for instance, you normally exchange files with several 
different offices. If you change the settings and save a separate .INI file for each 
office, then you can easily switch between .INI files without having to go 
through entity assignments over and over again. 
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 To save entity assignments: 

1. Change settings and assignments in the Entity Assignments dialog box as 
described in the step-by-step instructions on importing DWG files. 

2. Click on Save As. The Save Settings As dialog box is displayed. 

3. Type a filename for the new .INI file and click on Save. Or click on Cancel 
to cancel the save. When you save the .INI file, the setting for the 
Translator Settings File on the DXF/DWG tab of the Preferences/Options 
dialog box is changed to that file. 

4. Continue with step 8 in the instructions for importing a DWG or DXF file 
and opening it in DataCAD. 

A Brief Tour 
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Provides immediate 
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Figure 2.2: The DataCAD screen 

The Menu Bar 
The Menu Bar is located along the top of the DataCAD screen and contains the 
File, Edit, View, Insert, Create, Tools, Macros, Window, and Help pull-down 
menus. These menus give you quick access to standard Windows functions as 
well as many of DataCAD’s most used features. 

Notice that some menu options have keyboard shortcuts associated with them. 
For instance, the Open option in the File menu has (Ctrl)+(O). Instead of using the 
mouse to choose a menu option, you can simply press the keyboard shortcut to 
quickly do the same thing. 

 To choose an option from the Menu Bar: 

1. Click on the menu name in the Menu Bar. The menu will drop-down, 
displaying all the options in it. 
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2. Move your mouse down the menu to the option you want. Notice that 
each option highlights as your mouse passes over it. 

3. Click on the option you want to select. 

Toolbars 
Toolbars are displayed across the top of the DataCAD window, between the 
Menu Bar and Drawing Area. It gives you a quick way to access a variety of 
DataCAD functions, no matter where you are in the program. Icons, representing 
various DataCAD options, make up the toolbar. If you move your cursor over an 
icon, a description of that icon, called a ToolTip, pops up near the icon; the 
description is also displayed in the top line of the Message Area. DataCAD’s 
standard toolbars are anchored above the Drawing Area; you cannot move them 
to a different screen position. 

Notice that as you click on different icons, the menu for that function is 
displayed in the Menu Window. Accessing menus using the toolbar instead of 
the Menu Window reduces the number of steps to get to a menu and thus saves 
you time. 

For more information on how to turn off display of the toolbar or how to choose 
which toolbar is displayed, see “Customizing DataCAD” in this chapter. There 
are even icons in some toolbars that let you switch to a new toolbar. 

Because a toolbar can contain more icons than will fit on the screen, left and right 
arrow icons are available at the far left of the toolbar for easy scrolling through 
the toolbar icons. The maximum number of toolbar icons is 100.  

In addition to the standard DataCAD toolbars, you can also use an undo/redo 
toolbar and context-sensitive viewing toolbars. You can activate the viewing 
toolbars by choosing Viewer Toolbar from the View/Toolbars pull-down menu. 
A different toolbar is displayed depending on the view of your model: you can 
use the orthographic view toolbar, the parallel view toolbar, or the perspective 
view toolbar. 

   
Figure 2.3: Parallel views toolbar  Figure 2.4: Undo/redo toolbar 

 

     
Figure 2.5: Perspective view toolbar  Figure 2.6: Plan view toolbar 
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The Menu Window 
While DataCAD’s Menu Bar has menus that contain shortcuts to many of 
DataCAD’s most used functions as well as basic Window options, the majority of 
DataCAD’s menus are displayed in the Menu Window. The name of the menu 
shown in the Menu Window is displayed at the left end of the Message Area. 

There are two main menus in the Menu Window: the Edit menu and the Utility 
menu.  To switch between these two menus, click on the menu option in the 
Menu Window or simply right-click anywhere in the DataCAD window. Open a 
drawing in DataCAD, and try right-clicking a few times; notice the menu 
selection changes between the Edit and Utility menus. 

Both 2D and 3D menus are displayed in the Menu Window, but these menus are 
not interchangeable. The Move command in the Edit menu, for instance, should 
not be confused with the Move option in the 3D Edit menu. 

Menus in the Menu Window are nested; as you can see in Figure 2.2, there are 
many submenus available from the Edit and Utility menus. Each of these 
submenus may, in turn, contain additional submenus and menu options. When a 
submenu is being displayed, right-clicking exits the submenu and displays the 
previous menu in the Menu Window. 

Shortcut: Press (PgUp) and (PgDn) to scroll forward and backward through menu lists. 
This only works when you’re in a menu with ScrlFwrd and ScrlBack options. At all other 
times, these shortcuts are used to change your drawing display scale. 

The Menu Window lists the options in the currently selected menu. If a menu 
contains more items than can be shown in a single list, a scroll forward option 
(ScrlFwrd) is displayed at the bottom of the menu and will be available until you 
reach the end of the list. Once you scroll forward in a list, a scroll back option 
(ScrlBack) will also be available. As you move through DataCAD’s menu 
structure, the selections in the Menu Window change to reflect the different 
commands associated with each option. 

Some DataCAD menu options are toggles, switches that can be turned on or off. 
When a toggle is on, the button appears depressed and the button name is green. 
When a toggle is off, the button appears raised and the button name is red. 
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Figure 2.7: The Edit menu (left) and Utility menu 

Choosing Menu Options 
There are three ways to choose a menu option: 

• click on it using your mouse 

• press the corresponding function key 

• use a keyboard shortcut or command line alias 

Many of the most productive DataCAD users use keyboard shortcuts to enter 
values and choose menu options while using the mouse to draw and enter other 
drawing information. With one hand on the keyboard and the other on the 
mouse, you can draw in DataCAD very efficiently and quickly. 

 To choose a menu option using the mouse: 

1. Move the cursor over the option in the Menu Window that you’d like to 
use. The menu option highlights as the mouse cursor passes over it. 

2. Click the left mouse button. 

3. Right-click (click the right mouse button) when you are finished using the 
function; this lets you exit the menu. 

Notice that immediately to the left of each menu option in the Menu Window is a 
label corresponding to the function keys on your keyboard. Function keys are 
usually located across the top or on the left side of your keyboard and are labeled 
as “F1”, “F2”, “F3”, etc. To choose a menu option, simply press the 
corresponding function key. If a menu option’s function key label is S1 through 
S0, press (Shift) + (F1) through (Shift) + (F10). 
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Keyboard shortcuts let you access a variety of functions quickly just by pressing 
one or two keys. For example, you can press (A) on the keyboard to open the 
Architect menu from anywhere in DataCAD instead of using the mouse to choose 
the option from the icon toolbar or Menu Window. 

In this manual, all keyboard shortcuts are described exactly how they should be 
executed. If a shortcut requires a lowercase letter, you will be instructed to press 
only that letter. If a shortcut requires an uppercase letter, you will be instructed 
to press (Shift) and that letter simultaneously. For instance, the snap grid can be 
toggled on and off by pressing (X) (a lowercase “x”); however, to open the Object 
Snap menu via the keyboard, you must use an uppercase “X”, so you must press 
(Shift) + (X). 

There are several shortcuts that will be particularly useful to you as you draw: 
SHORTCUT FUNCTION 
(Home) Centers a drawing or view on the screen at the cursor’s current position. To 

reposition a drawing, move the cursor to the new center and press (Home). 
(,) Deletes only the last entity you drew 
(<) Deletes the last group you drew; you can also use Undo in the Edit pull-down menu 
(.) Restores only the last entity you deleted. This shortcut does not undo your previous 

actions; it just restores the deleted entity. 
(>) Restores the last group you deleted; you can also use Redo in the Edit pull-down 

menu. This shortcut does not redo your previous actions; it just restores the deleted 
group. 

(Esc) Redraws the screen to display the most recent version of the drawing 
(End) Terminates the screen refresh on the active layer only. To terminate the screen refresh 

on additional layers, press (End) once for each additional layer. (End) does not affect 
the drawing file, only that portion of it which is displayed. Save time on large 
drawings. Once the part of the drawing you want to edit is redrawn, press (End) to 
cancel the rest of the refresh.  

(Delete) Terminates the screen refresh on all layers simultaneously 
(PgUp), (PgDn) Changes the display scale in increments specified in the ToScale menu. To zoom 

out, press (PgUp); to zoom in, press (PgDn). 
(P) Restores the previous view and returns to the previous scale in one keystroke. 

DataCAD remembers up to 25 previous views. 
 

Some keyboard shortcuts can yield unexpected results if you don’t clearly 
understand what the command does. For example, there’s a difference between 
Undo/Redo and Restore commands. The results you get with the keyboard 
shortcuts (,), (<), (.), and (>) are not the same as what happens when you use 
Undo or Redo. The keyboard shortcut for Undo (which negates the last 
command you used) is (Ctrl)+(z); this produces the same results as selecting 
Undo from the Edit pull-down menu or clicking the Back button on the 
Undo/Redo Toolbar. The keyboard shortcut for Redo (which reinstates the last 
command undone by using Undo) is (Ctrl)+(y); this produces the same results as 
selecting Redo from the Edit pull-down menu or clicking the Forward button on 
the Undo/Redo Toolbar. 

The Appendix has a complete list of all keyboard shortcuts in DataCAD plus 
instructions on how to program your own shortcuts. 
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Using the Command Line Alias 
The Command Line Alias lets you assign a keyboard shortcut to a single or 
multi-character shortcut. You can have unlimited multi-keystroke shortcuts. 

 To use a command line alias: 

1. Press (Ctrl) + (Spacebar). You are prompted to enter the alias you want to 
use. 

2. Choose an alias in either of these two ways: 

• Type the alias you want to use and press (Enter). 

• Press (?) and then (Enter) to see the list of available aliases. Highlight 
the alias you want to use and press (Enter), or simply double-click on 
the alias. 

Customizing the Alias Browse Box 
The number of lines shown in the list as well as its width can be adjusted in the 
[Alias] section of the DCADWIN.INI file. 

 To customize the alias list box: 

1. Look in the Windows folder  (normally located on your C:\ drive) and 
locate DCADWIN.INI and open it in a text editor, such as Notepad. 

2. Find the Alias section, as shown below: 

[Alias] 
Popup Width=300 
Popup Lines=4 

 
3. Change the width and lines values as necessary and then save the file. 

Making an Alias 
Aliases are stored in a text file in your SUP folder called DCADWIN.DCA.  
Aliases use the same shorthand as custom keyboard macros.  An item in the 
Alias file looks like this: 

[cr] 
comment=draw circle by radius 
alias=^;^S5^S1^ 

 

 To make an alias called “ep” that will take you to the Erase, Partial menu: 

1. Press (Ctrl) + (Spacebar). 

2. Click on Settings; the Alias Manager appears. 

3. Go to the Alias input box; type the shortcut you want to use, in this case 
ep. 

4. Go to the Comment box; type a hint to describe the alias: Erase Partial 
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5. Go to the Sequence box; type the required keyboard sequence for the 
command: ^;^F7^F9^. Note that the format for a Command Line Alias is 
the same as a Keyboard Macro. You must separate each function with a 
carat [^]. 

6. Click on Add to add the new alias to the list. 

7. Click on OK to close the Alias Manager. Your alias is now ready to use. 

The Navigation Pad 
The Navigation Pad is displayed below the Menu Window and provides an easy 
way to view your model, recalculate extents, and access the 3DViews, Identify, 
and WindowIn menus. 

Both the Navigation Pad and the Projection Pad appear under the menu buttons 
if there is enough room. If the menu buttons require too much space for both 
pads to appear, only the Navigation Pad will be displayed. You can still access 
projection options from the View pull-down menu in the Menu Bar. The menu 
buttons may take up so much room that neither pad can be displayed. Or the 
menu buttons themselves may be cut off at the top of the DataCAD window. To 
make more room to display the pads, choose a smaller font for the menu buttons 
using the Interface Settings tab in the Tools/Program Preferences dialog box. 
You can also choose a higher screen resolution; see Windows Help for more 
information on this. 

 

Displays the WindowIn (zoom) 
menu in the Menu Window 

Displays the drawing at its most recently 
calculated extents; no recalculation is done, 
so this is usually much faster than using R on 
this pad; however, your most recent changes 
may not be displayed 

Displays the 3DViews menu in 
the Menu Window 

Recalculates the extents of a 
drawing; use after you’ve 
made a major change, such as
deleting part of your drawing Displays the Identify menu in

the Menu Window 

 

Figure 2.8: Some of the Navigation Pad’s buttons can be used to change your 
view of your drawing. 

The Navigation Pad also includes arrow keys to pan, or move the observer 
around the model on the screen. 
 
 

 

 

 

 Observer looks or steps to the 
right of the model 

Observer looks or steps down 

Observer looks or steps to 
the left of the model 

Observer looks or steps up 

Figure: 2.9: Click the arrow buttons on the Navigation Pad to easily change the 
view of your model. 
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You can also use the keyboard arrow keys in the same way you use the 
Navigation Pad arrows. The pan distance, or how much the display shifts each 
time you use one of the arrow keys, can be set to any value by using the ScrlDist 
in the Settings menu. See “Setting the Scroll Distance” in the “Settings” section of 
the “Before You Draw” chapter. 

The Projection Pad 
The Projection Pad is a set of nine buttons located directly under the Navigation 
Pad. These options are also available from the View pull-down menu on the 
Menu Bar. 

Both the Navigation Pad and the Projection Pad appear under the menu buttons 
if there is enough room. If the menu buttons require too much space for both 
pads to be displayed, only the Navigation Pad will appear. You can access 
Projection options from the View pull-down menu in the Menu Bar. The menu 
buttons may take up so much room that neither pad appears or the menu 
buttons may be cut off at the top of the DataCAD window. To make more room 
for the pads, choose a smaller font for the menu buttons using the Interface 
Settings tab in the Tools/Program Preferences dialog box. You can also choose a 
higher screen resolution; see Windows Help for more information on this. 
 
 

 

 
 

 

Figure 2.10: The Projection Pad has nine options to change your view of your 
model. 
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The Status Area 
The Status Area is located in the bottom left corner of the DataCAD window. 
When you are working on a drawing, this area provides information on the 
current settings. See “Customizing Display” in the “Before You Draw” chapter 
for more information on Display menu options. 

Status of display toggles 

Current selection set

Current linetype 

Current display scale 

Active layer (layer entities will be drawn on) 

Activity light displays 
green when DataCAD 
is ready for the next 
task; red means it is 
processing 

Layer search toggle 

Active layer’s color  
 

 

 

 

Figure 2.11: The Status Area lets you quickly know information about the active 
layer and the status of various other settings in DataCAD. 
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SWOTHLUDFB settings affect how a drawing is plotted as well as how it 
appears on the screen. 

Hotspots 
The Status Area gives you one-click access to the Color, Layer, Scale, Linetype, 
and Selection Set menus. In the Status Area, just left-click on the item (text, color 
swatch, or square) you want to change. DataCAD instantly takes you to the 
appropriate menu or dialog box so you can make your new selection. For 
example, if you click on the active layer’s name, the Layer Manager dialog box 
appears. Clicking on a hotspot in the Status Area has the following results: 

Active layer’s color swatch – the Color Palette appears 

Active layer’s name – the Layer Manager appears 

Current display scale – the ToScale selection menu appears 

Current linetype – the LineType menu appears 

Current selection set – the EditSets menu appears 

Changing the Active Layer 
In a drawing with multiple layers, pressing (Tab) changes the active layer by 
scrolling through all the layers that are on. You’ll see the active layer name in the 
Status Area change each time you press (Tab). Press (Shift) + (Tab) to scroll 
backward through your drawing’s layers. 

Toggling Layer Search On or Off 
You can click on the layer search toggle in the Status Area to quickly toggle layer 
search on or off. If the toggle button is depressed and the “L” is green, layer 
search is on; if the toggle button is raised and the “L” is red, layer search is off. 
We’ll discuss DataCAD’s layer search option in “Selection Menus” later in this 
chapter. 

Shortcut: Press the apostrophe key (‘) to toggle the LyrSrch option on or off. 

Using SWOTHLUDFB 
SWOTHLUDFB in the Status Area lets you know at a glance whether these 
toggles are on or off. Each letter represents a particular feature in DataCAD. 
When the letter is in uppercase, the feature it represents is on or active. When the 
letter is lowercase, the feature is off or inactive. Specific SWOTHLUDFB settings 
are: 
S Snap grid is on. Your cursor will move along the X and Y axes in increments specified 

by the SetSnap option in the Utility/Grids/ GridSize menu.  
s Snap grid is off. Your cursor is not restricted to incremental movement; you can draw 

entities at any point in the Drawing Area. 
Shortcut: To toggle snap grid on or off, press (X). 

W Walls mode is on.  
w Walls mode is off.  

Shortcut: To toggle wall mode on or off, press (=). 
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O Ortho mode is on. Your cursor will move at angle increments specified by the 

SnapAng option in the Utility/Grids menu.  
o Ortho mode is off. Snap angle settings are not used; you can draw entities at any 

angle. 
Shortcut: To toggle Ortho mode on or off, press (O). 

T Text in your drawing is displayed on the screen as entered. 
t Text in your drawing is represented by appropriately sized boxes. 
H Hatch patterns are displayed. 
h Hatch patterns are not displayed. Drawings refresh faster. 
L Lines are displayed at the weight (thickness) that you drew them. 
l Lines are all displayed with a line weight (thickness) of 1. Drawings refresh faster. 
U Linetypes, or “user-defined lines”, are displayed. 
u Linetypes, or “user-defined lines”, are all displayed as solid. Drawings refresh faster. 
D Associative dimensions are displayed. 
d Associative dimensions are not displayed. Drawings refresh faster. 
F Fills are displayed 
f  Fills are not displayed 
B Bitmaps are displayed 
b  Bitmaps are not displayed 
 

 To change the status of SWOTHLUDFB toggles: 

1. Click on Display in the Utility menu. 

2. Click on the appropriate menu option to toggle it on or off. 

The Message Area 
The Message Area displays information about your drawing. It includes the 
current coordinate entry mode, the cursor’s position, the menu you are using, 
program and error messages, the Z-base and Z-height, and program prompts 
and data entry area. 

 

 

 

 

 

 

Program and error messages plus 
current Z-base and Z-height 

Prompts and data entry

Name of menu being displayed 

Coordinate display (current cursor position) Current coordinate entry

Figure 2.12: The Message Area is located along the bottom of the DataCAD 
window. 

The values of the coordinate display can be shown in architectural, engineering, 
or metric units. See “Setting Scale and Angle Types” in the “Customizing 
Settings” section of the “Before You Draw” chapter for more information on how 
to display values in a different unit of measure. 
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The Drawing Area 
The Drawing Area, the largest in the DataCAD window, displays drawing 
contents. Lines, arcs, walls, fixtures, and anything else you design are displayed. 
Although drawings in DataCAD are drawn at full scale in an infinite field, you 
can display any portion of a drawing at any scale. In other words, you can zoom 
in and out on your drawing, as needed. To do this, you can use the ToScale and 
WindowIn options in the Utility menu. See “Viewing Drawings” later in this 
chapter for more information on zooming in and out on your drawing. 

 
Figure 2.13: The Drawing Area is the largest part of the DataCAD window. 

Customizing DataCAD 
The Program Preferences dialog box, available from the Tools pull-down menu, 
lets you customize folders for each DataCAD file type, how the DataCAD screen 
looks, how the DWG/DXF translator works, and the macros available in the 
Macros pull-down menu, as well as several miscellaneous settings. 

Customizing Pathnames 
The Pathnames tab in the Program Preferences dialog box lists the default folders 
that files are stored in. 

To reset all folder names to their defaults, click Defaults in the bottom right 
corner of the Program Preferences dialog box. 

 To change a path: 

1. Choose Program Preferences from the Tools pull-down menu. 
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2. Click in the input box of the folder path you’d like to change, and type a 
new path; or, click on the folder icon at the right of the path to be changed 
and browse for a new path.  

3. Click on OK to save your changes and close the dialog box; click on 
Defaults to reset all paths to their DataCAD defaults. 

If you enter a folder name that doesn’t exist, clicking on OK will simply highlight 
the incorrect folder. 

 
Figure 2.14: The Pathnames tab on the Program Preferences dialog box 

DataCAD tries to resolve invalid reference file paths. It does this by checking the 
current drawing file folder for valid references. If a valid reference file is found in 
the current drawing file folder, it will be used instead of the file designated in the 
original path; however, the original path will be retained. 

Customizing DataCAD’s Interface 
The Interface Settings tab on the Program Preferences dialog box contains an 
interactive copy of the DataCAD window. Using your mouse, move your cursor 
over the different areas of this image to see Tool Tips. Click on any part of the 
image to make changes to that part of the interface. 

Warning: Make sure the DataCAD window is maximized before you attempt to customize 
the interface, or erratic behavior may occur when using the program. 
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Figure 2.15: The Interface Settings tab on the Program Preferences dialog box 

The toolbar is anchored above the Drawing Area; you cannot move it to a 
different screen position. 

 To turn the toolbar on or off: 

1. Click on Program Preferences in the Tools pull-down menu. The Program 
Preferences dialog box is displayed. 

2. Click on the Interface Settings tab, if it’s not already showing. 

3. Position your cursor over the toolbar in the interface image or, if the 
toolbar is already off (not being displayed), above the Drawing Area 
where the toolbar is normally displayed. 

4. Click to toggle the toolbar on or off. 

5. Click on OK to close the Program Preferences dialog box. The toolbar 
display is changed. 

You can also turn the toolbar on by checking On/Off in the Default .KEY file 
section on the Misc tab of the Program Preferences dialog box. Turn the toolbar 
off by unchecking the On/Off option. 

 To change the color of the Drawing Area: 

1. Click on Program Preferences in the Tools pull-down menu. The Program 
Preferences dialog box is displayed. 

2. Click on the Interface Settings tab, if it’s not already showing. 
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3. Position your cursor anywhere over the Drawing Area in the interface 
image. 

4. Click to open a Color Palette dialog box. 

 
Figure 2.16: The Color Palette dialog box lets you select a new background color 
for your drawings 

5. Choose a new color for the Drawing Area background and click on OK. 
The Color Palette dialog box closes, and the Drawing Area background 
color is changed in the Program Preferences Interface Settings display. 

6. Click on OK to close the Program Preferences dialog box. The Drawing 
Area background color is changed. 

 To move the Menu Window, Navigation Pad, Projection Pad, and Status 
Area to the opposite side of the DataCAD window: 

1. Click on Program Preferences in the Tools pull-down menu. The Program 
Preferences dialog box is displayed. 

2. Click on the Interface Settings tab, if it’s not already showing. 

3. Position your cursor over any part of either pad or the Status Area, or any 
part of the Menu Window except the menu options. 

4. Click to move these parts of the interface to the opposite side of the 
DataCAD window. 

5. Click on OK to close the Program Preferences dialog box. The Menu 
Window is moved to the other side of the window. 
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 To change the font used on the menu buttons in the Menu Window or the 
font used in the Message Area: 

1. Click on Program Preferences in the Tools pull-down menu. The Program 
Preferences dialog box is displayed. 

2. Click on the Interface Settings tab, if it’s not already showing. 

3. To change the font in the menu buttons, position your cursor anywhere 
over the menu buttons in the Menu Window of the interface image. To 
change the font in the Message Area, position your cursor anywhere over 
the Message Area of the interface image. 

4. Click to open a Fonts dialog box. 

5. Choose a new font and click on OK. The Fonts dialog box closes. 

6. Click on OK to close the Program Preferences dialog box. The menu 
button font is changed. 

Customizing File Translation 
The DXF/DWG tab on the Program Preferences dialog box (Tools pull-down 
menu) lets you choose an import method, translator default settings, and 3D 
entity export method. DXF/DWG supports solid fills, TrueType fonts, polylines 
with voids, and complex hatch patterns (such as StoneCAD). 

 
Figure 2.17: The DXF/DWG tab on the Program Preferences dialog box 
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You can choose between two import methods: the first method allows you to 
interactively (manually) assign linetypes and fonts, while the second makes these 
assignments automatically, according to the Translator Default Settings in the 
Program Preferences dialog box. The interactive option is the default method and 
uses the DWG Import Entity Assignments dialog box. The DWG Import Entity 
Assignments dialog box is displayed during the import process only if the 
interactive option is checked. 

There are several Translator Default Settings you can change as well. Set the 
default font, linetype, base unit, and translator file to use during import. These 
defaults will be used as assignment suggestions when using the interactive 
import method; with automatic translation, however, they will be used when 
DataCAD has no equivalent for an existing entity in the DWG or DXF file. To 
change any of these settings, click on the arrow to the right of the drop-down box 
and select another setting.  You can also check the “Move drawing to origin” 
option to move drawing geometry to absolute 0 during import. This option is 
unchecked (off) by default. 

During export, the line definitions and shape codes for DataCAD linetypes are 
stored in a .SHX file. If you export a DataCAD drawing named 
MYDRAWING.DC5, the translator will create two files: MYDRAWING.DWG 
and MYDRAWING.SHX. In order for the linetypes in the DWG file to display 
properly, the .SHX file must be placed in the \SUPPORT folder in the AutoCAD 
folder. The AutoCAD user may also place the .SHX file in the same folder as the 
.DWG file. A .SHX file is only created if line types other than Solid, Dashed, 
Dotted or Dot-Dash are used. 

If you’re not concerned with linetypes displaying exactly as you drew them, 
check the Export Linetypes toggle in the Tools/Program Preferences dialog box 
to convert all user-defined linetypes (any linetype except Solid, Dotted, Dashed, 
and Dot-Dash) to Continuous when exporting a DataCAD drawing to a DWG or 
DXF file. In this case, a shape file will not be created because none is needed; 
instead, all user-defined linetypes in MYDRAWING.DC5 will be permanently 
translated to the Continuous linetype. The Export Linetypes toggle is off by 
default. 

Both DataCAD and AutoCAD define colors in terms of their place in each 
program’s internal color list. For instance, in DataCAD's code, Color 1 = White, 
Color 2 = Red, Color 3 = Green, etc. While we see white, red, and green colors on 
screen, DataCAD recognizes these only as Color 1, Color 2, and Color 3, 
respectively. AutoCAD works similarly, except AutoCAD displays Color 1, 
Color 2, and Color 3 as red, yellow, and green, respectively.  

So if you don’t have the Import/Export Color Translation toggle checked when 
you export a DataCAD file, the resulting DWG/DXF file will only associate 
“Color 1,” “Color 2.” etc., with each entity. When the file is displayed in 
AutoCAD, the program recognizes “Color 1” and displays the entity as red, 
instead of white as it was drawn in DataCAD. With the Import/Export Color 
Translation toggle on, the table file corrects for this, so that white entities in 
DataCAD are displayed as white when exported to a DWG/DXF file and vice 
versa. 
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The Import/Export Color Translation toggle, which is on by default, tells 
DataCAD to use a table (.TBL) file so that colors translate properly when 
exported to or imported from a DWG/DXF file. An easy way to create a table file 
is to simply save DEFAULT.TBL under a new name that matches the custom 
RGB file. You can select Generate TBL File from the Tools pull-down menu to 
create a TBL file to match the currently selected RGB file. You must create this 
file for each custom RGB file. It should be given the same filename as the 
currently selected RGB file and saved in the DATACAD\SUP folder. 

The 3D Entity Export option, located near the bottom of the DXF/DWG tab, is 
unchecked (off) by default. Any 3D entities in a DataCAD (.DC5) file will be 
translated as a polyface mesh when exported to a DXF or DWG file; this polyface 
mesh is a single entity. However, by checking the “Decompose 3D entities as 3D 
faces” option, each facet of a 3D entity will be turned into an individual polyface; 
thus, a single sphere in DataCAD can be translated into many separate entities 
arranged in a sphere shape in a DWG or DXF file. 

Checking the Decompose option can make translation faster and the translated 
entities will look the same after a shade or hidden line removal. However, 
editing may be more difficult since these translated 3D entities are made up of 
many smaller and separate entities. 

Check the “Automatically export reference files” option in the Reference Files 
section of the DXF/DWG tab to export any XREFs you’ve used in your drawing 
at the same time you export the drawing itself. Each reference file is exported as 
a separate .DWG file. This option is checked by default; if you uncheck it, XREFs 
will not be exported along with your drawing. If you send your drawing to a co-
worker or client, be sure to send all of the exported reference files as well so your 
drawing will be viewed as you intended. 

You can toggle on “Expand exported stamps to values” in the final section of the 
DXF/DWG tab. When this box is unchecked, the stamp will export in its raw 
token format (i.e., @PLTTIME). When this box is checked, the stamp will export 
as it appears in DataCAD (i.e., 12:00 P.M.). 

Customizing the Macros Menu 
The Macros tab in the Program Preferences dialog box (Tools pull-down menu) 
lets you choose which macros you want to be displayed in the Macros pull-down 
menu. To add macros to the menu, click on the macros in the Macros Available 
list box, then click on the Add button. To delete macros from the menu, click on 
the macros in the Macros in Menu list box and then click on the Remove button. 

The Macros Available list box contains all macros that you have installed 
(normally found in the DATACAD\DCX folder). It is possible to add macros 
that are located in other folders: click on the file folder button above the Macros 
Available list box to browse different folders and select macros to add to the list. 

You aren’t uninstalling macros when you remove them from the Macros pull-
down menu. Macros removed from the Macros in Menu list simply won’t be 
displayed as options in the pull-down menu. 
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Figure 2.18: The Macros tab in the Program Preferences dialog box 

Customizing Miscellaneous Settings 
The Misc tab on the Program Preferences dialog box (Tools pull-down menu) has 
several settings to customize DataCAD’s functionality. You can set a default 
drawing to be used automatically when you create new drawings, select a 
default toolbar to use, and select a default font for text that you enter into your 
drawing. Simply click in the appropriate drop-down box and choose a file. 

You can activate the Display List to increase display speeds in DataCAD. The 
display list is a sort of internal list that DataCAD keeps of all entities in your 
drawing. The speed of redrawing the geometry in the Drawing Area when you 
pan, change views, or press (Esc) to update the drawing is increased when this 
option is checked. Display List is toggled on by default. 

Shortcut: Press (U) at any time to update the Display List. Note that this is different than 
pressing (Esc) in that (Esc) simply redraws the geometry in the current display list while 
(U) updates the display list itself and then redraws all entities. 

To find out how many entities and line segments are in the Display List, as well 
as how much memory is being used to maintain the Display List, choose Status 
in the Utility / Display / DispList menu. 
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Although the Max Acceleration toggle next to Display List is unchecked (off) by 
default, you can check this to increase display speeds even more. To accomplish 
this, DataCAD takes a few minor shortcuts when redrawing your geometry. For 
instance, arcs may appear segmented and object snap points may appear 
enlarged when you zoom in on them. Please note that your geometry has not 
actually been changed in any way; it is merely a display shortcut. To avoid any 
display shortcuts, keep Max Acceleration toggled off. 

 
Figure 2.19: The Misc tab in the Program Preferences dialog box 

The DC Render Material Assignment section allows you to export .RAY files in 
which you can assign materials by color, by layer, or by color and layer. 
Assigning materials by color means you assign one material to all entities of a 
specified color. Similarly, assigning materials by layer means you assign one 
material to all entities on a specified layer. And assigning materials by both color 
and layer means you assign one material to all entities of a specified color on a 
specified layer. For instance, all red entities on the Walls layer would be assigned 
one material, all white entities on the Walls layer would be assigned a different 
material, and all white entities on the Doors layer would be assigned yet a 
different material. 

The Copy to Clipboard section has three options, “Copy entity color,” “Copy 
entity line weight,” and “Expand exported stamps to values.” The first two 
options are both checked (on) by default. When you select a DataCAD entity to 
copy, these options cause the entity’s color and line weight to be copied as well. 
Then when the entity is pasted into another document, the entity displays as it 
did in the original drawing. 
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The “Expand exported stamps to values” option lets you determine the format of 
stamps when they are either copied to the clipboard or exported via DXF/DWG. 
When this box is unchecked, the stamp will export in its raw token format (i.e., 
@PLTTIME). When this box is checked, the stamp will export as it appears in 
DataCAD (i.e., 12:00 P.M.). 

Normally, pressing (Page Up) and (Page Down) changes your drawing scale. If 
you have PgUp/PgDn in Text Menu checked on the Misc tab and TxtScale is 
toggled on in the Text menu, pressing (Page Up) and (Page Down) will not only 
change the drawing scale but also the plotting scale. With TxtScale on in the Text 
menu, text is always inserted at a size relative to the current plot scale. If the 
toggle is on in Program Preferences, then you can change the current plot scale 
by pressing PgUp\PgDn rather than selecting the PltScale button in the Text 
menu.  The PltScale button only appears when the option is OFF in Program 
Preferences and TxtScale is ON in Text menu. 

DataCAD can remember up to 25 previous views (at set scales) of your drawing. 
If you’d like Free Zooms and pans and scrolls to be included in these previous 
views, check Remembers FreeZooms and Remembers Pans/Scrolls on on the 
Misc tab. 

Shortcut: Press (P) to return to the previous view. 

There is also an option to display the boundary of a clip cube. Check Display On 
in the Clip Cube section of the Misc tab. See the “Viewing Your Model” chapter 
for more information on using clip cubes. 

The AndCopy Toggles option determines whether the status of the AndCopy 
toggles in such menus as Move, Rotate, Enlarge and Mirror is remembered by 
DataCAD. By unchecking Remember On/Off Status, the AndCopy option in the 
menus will always be toggled off when the menu is opened. 

DataCAD displays a preview of selected symbols when you insert symbols using 
the Insert pull-down menu. Using the Symbol Preview setting on the Misc tab, 
you can choose to display this preview in orthographic or isometric view. You 
can also change this setting on the Insert Symbol dialog box; check the Isometric 
View option below the preview window to display symbols in isometric view, or 
uncheck it to display them in plan view. Symbol previews are displayed in 
orthographic view by default. 

When “Inherits current setting” is unchecked in the Nested XREF Highlighting 
section, the nested XREFs will retain their highlight settings if you insert them in 
another drawing file. If the box is checked, the drawing file’s current settings will 
be used for XREF highlighting.  

You can change the color of Tooltips by clicking on the box in that portion of the 
Misc tab. This brings the Color Palette dialog box to the screen so that you can 
select the color you prefer. In addition, you can control the delay speed for 
Tooltips with the slider on the Misc tab. 

The Scroll Wheel Zoom section of the Misc tab controls how you zoom in and out 
using your mouse wheel. As a default, “Requires Ctrl key” is checked. This 
means that you must press (Ctrl) while you move the mouse wheel to zoom in 
and out on your drawing. The zoom factor is +/- 25%. 



COMMON MENUS IN DATACAD  |    31 

Common Menus in DataCAD 
There are several types of menus that appear frequently as submenus throughout 
DataCAD, including selection, value, and color menus. 

Selection Menus 
Selection menus appear frequently in submenus throughout DataCAD. Selection 
refers to the way you mark drawing entities for editing purposes. There are three 
primary ways to select drawing entities: by Entity (one at a time), by Group 
(when multiple entities have been associated with one another), or by Area (an 
editing box stretched around entities). 

 
Figure 2.20: From left to right, examples of Entity, Group, and Area selection 

Along with Entity, Group, and Area, selection menus include several other 
methods for selecting parts of the drawing to edit. All of the options are not 
available in every selection menu; selection menus are tailored for each editing 
option. Selection menu options can include: 
Entity Select drawing entities one at a time; this is the default selection method 
Group Select entities that are associated as a group 
Point Select entities by a single point; available only when using Stretch 
Area Select geometry wholly contained within an area that you define with a rubberband 

box 
Fence Select geometry wholly contained within a fence that you define with a temporary 

polygon boundary 
Crossing Select any entity that crosses an area or fence boundary 
SelSet Select entities that are associated in a selection set 
LyrSrch Editing operations search all layers that are toggled on 

More About Selection Menus 
An entity is a straight or curved geometric element defined by two end points. A 
line, a circle, an ellipse, and an arc are all entities. A B-spline or Bezier curve or a 
line of text is also an entity, as is a symbol, associative dimensions, and 
associative hatching. There are also 3D entities, such as slabs, spheres, and 
cylinders. Entities can be edited alone or as a group.  

A group is a set of any number of entities, linked together logically but not 
necessarily graphically. Entities that do not touch may be part of the same group, 
and entities that are contiguous may be part of different groups. 
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Entities are linked as a group in a number of ways. A group of entities drawn in 
succession without disconnecting the cursor are linked as one group. Similarly a 
series of lines of text entered at the same time are linked as one group. You can 
link entities or groups of entities using the LinkEnts option in the Edit menu. 
Entities are also grouped when they are created at the same time with the Copy 
option. If the AndCopy option is toggled on when you use Move, then the copies 
will be a single group. When an existing entity is edited, with the Change or 
Move options for example, it retains the same group associations.  

The grouping together of entities in DataCAD allows you to edit many related 
items without affecting other entities in the same portion of a drawing. Because 
groups are also easily redefined, the designer can organize a drawing as a series 
of elements composed of logically related pieces or entities. 

You can also select entities by area or fence. Area selection uses a box, which is 
temporarily drawn around the entities you want to select. All entities and groups 
enclosed completely within this area box are included in the area selection. Any 
entities and groups partially enclosed or not enclosed within the area box are not 
included in the area.  

Similar to an area but allowing more flexibility, fence selection uses a polygon 
with up to 36 sides, which is temporarily drawn around the entities you want to 
select. The fence polygon can be concave or convex and must be closed to 
complete the selection process. 

Crossing is a toggle available during area and fence selection that you can enable 
after selecting the first point of the rubberband box. Using Crossing, you can 
select any entity that crosses the rubberband box, along with any entities fully 
within the box. Crossing works with all editing commands except Stretch. 

A selection set is a user-defined set of entities and/or groups. Selection sets 
provide increased efficiency during editing by reducing the time required to 
select entities or groups, or define areas or fences. A selection set may contain 
any number of entities or groups, and up to eight different selection sets may be 
defined. You can only edit active selection sets. Add or remove entities from 
selection sets with the EditSets option in the Edit menu. See “Working With 
Selection Sets” in the “Editing Drawings” chapter for more information on using 
selection sets. 

Press (Alt) + (1) through (Alt) + (8) to change the active selection set when 
editing. While in an edit command, such as Move or Erase, press (Alt) + (2), for 
example, to switch to selection set 2. 

Layer Search controls whether or not DataCAD scans all layers during selection 
operations. If you toggle LyrSrch on, you can select entities on all layers that are 
on (being displayed). When the LyrSrch toggle is off, you can select entities only 
on the active layer (the layer you’re currently working on). We’ll cover layers in 
more depth later in this chapter. 

Shortcut: Press the apostrophe (single quotation mark) key on your keyboard to toggle 
layer search on or off. 
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In addition to the button in the Menu Window, a Layer Search Status Toggle is 
located in the Status Area of the DataCAD window. If the “L” on the toggle 
button is green, layer search is on; if it’s red, layer search is off. Click on the 
toggle button to turn LyrSrch on or off with a single mouse click. 

The green and red colors on the layer search toggle come from DataCAD’s 
default screen color palette. If you change the palette DataCAD uses, different 
colors may be displayed. See “Customizing Colors” in the “Before You Draw” 
chapter for more information. 

More About 3D Selection Menus 
The 3D selection menu options are identical, with a few exceptions for Area and 
Fence. When using Area and Fence for 3D entities, most entities are selected 
when all the end points of each displayed line segment and all displayed 
markers (such as center points for cylinders) lie within area or fence boundaries. 

When using 3D Fence selection, however, it’s possible to select some 3D entities 
by enclosing their end points but not enclosing other parts of these entities. If 
your fence polygon is concave, for instance, you could enclose the end points of a 
slab and still have the middle part of the slab lie outside the polygon. The entity 
is still considered in the fence if the end points lie within the fence. But if any end 
point of an entity lies outside the fence, the entity is considered outside the fence 
and is then not selected. 

Selection by Area and Fence is independent of the current Z-base and Z-height 
settings. You can think of the region enclosed by the area or fence as going back 
into the screen infinitely. If you can see the region and it falls inside the 
boundary, the region is selected when you enclose it with an area or fence. 

The following list includes the portions of an entity that must lie within the 
boundaries of the area or fence to be selected: 
3D Lines  Entire line 
Polygons  End points of all displayed edges, including end points of void edges 
Blocks  End points of all edges which directly determine the shape of the block 
Slabs  End points of all displayed edges, including end points of void edges 
3D Arc  Entire arc 
Cylinder  Entire cylinder 
Symbol  The symbol reference point 
Cone  Entire cone 
Truncated Cone Entire truncated cone 
Sphere  Entire sphere 
Torus  Entire torus 
Mesh Surface  Any control points; the surface and the control grid are ignored 
Surface of Rev. Entire surface of revolution 

Value Menus 
Some DataCAD functions require you to enter a numerical value. When you 
choose one of these functions from a menu, a list of values appears in the Menu 
Window, followed by these options: 
Match Matches an existing value, entity, or angle; click on Match, then click on the entity to 

match 
Add/Subtract Adds or subtracts one or more values from a given value; click on the option and 

then the number to add or subtract 
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Clear Returns the given value to zero and starts again (Clear does not, however, function 

like Undo); choosing Clear and then pressing (Enter) will accept a value of 0 
To Layer Puts an entity on more than one layer or on a different layer than you are currently 

working on; available when you have more than one layer in the drawing 
 

You can select a value from the list, use the options on the previous page, or type 
any value and press (Enter). The total is displayed in the prompt line in the 
Message Area but is not entered until you press (Enter). 

The decimal separator for all displayed dimensions and numbers is determined 
by the value of the Windows Decimal Separator. To set this value, click on 
Control Panel in the Start/Settings menu on your Windows desktop. Double-
click on Regional Settings. On the Number tab, set the Decimal symbol value. 

DataCAD’s Online Calculator 
DataCAD’s online calculator is available anytime you need to enter a value, such 
as a distance or angle. Any time DataCAD prompts you to enter a value, you can 
simply type = and your equation, and DataCAD will automatically calculate the 
value.  The online calculator supports pi; you can type pi in any equation. 

Distances must be entered in decimal units. The results, however, will be 
displayed according to the Scale Type setting. For instance, the default setting, 
Architectural (Imperial) units, will display in feet/inches/fractions of inches. See 
“Customizing Settings” in the “Before You Draw” chapter for more information 
on the Scale Type and Angle Type options. 

The online calculator assumes angles are entered in radians, but you can enter an 
angle in degrees simply by typing d immediately after the value. Results for 
angle calculations will be displayed according to the Angle Type setting, with the 
default being Normal (in degrees/minutes/seconds). 

The calculator can do the following kinds of operations: 
OPERATION  EXAMPLE CALCULATED VALUE 
Addition   =4.5+5  9.6 (9’-6”) 
Subtraction   =7-2.5  4.6 (4’-6”) 
Multiplication  =6*4.5  27.0 (27’) 
Division   =45/3  15.0 (15’) 
Parenthetical   =(4+3.5)*(8/2) 30.0 (30’) 
Square   =SQR(3)  9.0 (9’) 
Square Root   =SQRT(16) 4.0 (4’) 
Cosine   =COS(35d) 0.9.27/32 (9 27/32”) 
Sine   =SIN(35d) 0.6.7/8 (6 7/8”) 
Tangent   =TAN(35d) 0.8.13/32 (8 13/32”) 
Arc Tangent   =ATAN(12,16) 0.6435 radians (36.87°) 
Natural Logarithm =LN(9.3) 2.23      (Base 2.71828) 
 

Following are two examples to illustrate how to use the online calculator to 
quickly figure scales and angles. 

 To define a new plotting scale: 

1. Click on EditDefs in the Settings menu. 

2. Click on Scales in the EditDefs menu. 
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3. Click on Change to modify an existing scale. 

4. Select the scale to change from the menu. 

5. Look at the prompt to “Enter new string for this scale.” Enter 1/32 for the 
menu button name. 

6. Respond to the prompt to “Enter new scaling value for this scale” by 
typing =(1/32)/12 and pressing (Enter) to get the result 0.002604167. 

7. Press (Enter) to accept this value as a new scale factor. 

 To calculate an angle:  

1. Respond to the prompt to enter an angle by typing =ATAN(6,12), where 
6 is the rise and 12 is the run. 

2. Press (Enter) to calculate an angle of 26.33.54, or 26° 33’ 54”. 

Color Menus 
When an option requires you to assign a color, a list of colors is displayed in the 
Menu Window along with the options Custom, Match, and NoChange.  

 
Figure 2.21: A sample color menu 

Custom opens the Color Palette dialog box so you can change a color by 
adjusting its red, green, and blue (RGB) and hue, saturation, and brightness 
(HSB) values. To work properly, it requires a 256-color driver. 

Warning: When you make a change to a color menu, you must save this new color 
palette, or the colors will revert back to their original RGB values when you close 
DataCAD, even if you save the drawing. See “Customizing Colors” in the “Before You 
Draw” chapter for more information on how to save palettes. 

 To change the color of one or more entities in your drawing: 

1. Click on Custom in any color menu. The Color Palette dialog box 
appears. 
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Figure 2.22: The Color Palette dialog box 

2. Choose a color swatch, excluding the ones in the top row. (The top row 
contains the 15 standard colors DataCAD uses.) If you are satisfied with 
one of the colors in the dialog box, double-click on the swatch to activate 
that color and dismiss the Color Palette. If you want a color that is not 
shown on the Color Palette, continue to step 3. 

3. Click on Edit. The Color Picker dialog box appears. 

 
Figure 2.23: Color Picker dialog box 

4. Adjust the RGB and HSB values for the current color (shown in the Old 
Color box) until you see the color you want in the New Color box. 
Alternatively, you can enter a new value for Red, Green, or Blue as well 
as for Hue, Saturation, or Brightness to adjust the color. You can click 
Cancel to close the Color Picker and Color Palette dialog boxes without 
saving your changes. Click OK to change the color. You return to the 
drawing where you are prompted to “Select entity to <CHANGE>.” 
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5. Click on the entity whose color you want to change. DataCAD substitutes 
the new color for the old one. 

 To change the color of one entity to match that of another entity: 

1. Click on Match in the color menu. 

2. Select the entity whose color you would like to match. 

3. Select the entity whose color you would like to change. You can select 
multiple entities or groups without repeating steps 1 and 2. Click on 
NoChange to exit the color menu without making a change. 

Planning Your Project 
Much of your work will be editing drawings under design development, and 
DataCAD is a flexible program in terms of allowing you to change what you 
have drawn. Nevertheless, the more information you have when you first draw 
something, the less time you’ll spend making revisions. 

With traditional manual design development, you first do a rough sketch of the 
project and then gradually refine this idea into a drawing that is dimensionally 
and materially specific. Computer-aided design (CAD), however, produces a 
drawing with precise dimensions the first time it is drawn. 

This suggests that the ideal process of CAD development might be the opposite 
of manual design development. With CAD, it’s important to know such things as 
the exterior wall construction before you start to draw, so your drawing will be 
accurate from the beginning. If you finalize your floor plan, however, before you 
decide on exterior wall construction materials, you’ll have to go back and change 
the thickness of all exterior walls in order to do automatic dimensioning or wall 
sections and details. This wall thickness change would in turn impact the interior 
dimensions of rooms and may affect the modular grids of ceiling and floor tile, 
lighting, etc. Some well-thought out planning before you start to draw can save 
you valuable time. 

Gathering Project Information 
Practically speaking, it’s impossible to predict the exact dimensions and 
materials of everything in the building before you finalize the design. A 
realizable goal, however, is to gather as much information as possible about the 
construction of the building before you begin the design development or 
construction documents phases of the project. This keeps time-consuming 
changes to a minimum and allows the building to be drawn and dimensioned 
accurately. 

You need to have as much information as possible on the following: 
Scope of Work How much do you need to draw? In what detail? What information can be 

reused for several drawings? 
Dimensions What are the basic dimensions of the structural grid, columns, and load-

bearing partitions? What size are the interior partitions? Doors and windows? 
Sill and jamb conditions? Floor and ceiling heights? Joist sizes? 

Materials What are the walls and foundation made of? What floor and roof systems are 
you using? 
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Existing Elements Which parts of the drawing can be used to create other drawings for this 

project? Which templates or typical details can be used for this project? Which 
drawings from the schematic design phase can be reused? 

Planning Layers 
The concept of layering drawings has been used in designing, drawing, and 
drafting long before computers. In the past it was referred to as overlay, or pin 
register, drafting. 

With overlay drafting, drawings were developed in layers on trace paper, each 
aligned with the others. Each sheet contained related information that you could 
separate and reproduce individually or in any combination. You could also use 
this layering of drawings during the design process, to overlay and quickly trace, 
change, and rework drawings. This same procedure is easily accomplished using 
DataCAD, to form a highly productive drawing process. 

The key to efficient CAD is the well-planned use of the almost unlimited number 
of layers available in each drawing file to isolate related entities, details, and text. 
By organizing the information displayed on each layer according to type or 
content, you can perform editing functions on one building component without 
affecting components on other layers. 

There are many layering methods; however, it is important to devise a well 
thought out strategy based on office standards for the type of work you do. A 
drawing file with a good layer structure could and probably should contain all 
the drawings for a single project.  

Just as your drawing can contribute to the drawings of others, what others in 
your office have already drawn can help you. As you plan your drawing layers, 
make a note of where you can get some of the basic information needed for your 
particular task. There’s no need to redraw all those toilets for the third floor if 
they’ve already been drawn for the first floor, or if you already have an 
appropriate toilet symbol on a plumbing template. 

Before you begin drawing, it is a good idea to sit down and make a list of all the 
layers you intend to create, noting what you expect each layer will contain. 
Although creating layers is easy with DataCAD, you will find it helpful to have a 
reference list as you draw to help you prioritize and chart your drawing process. 
See “Layers” in the “Before You Draw” chapter for more information on how to 
set up layers in DataCAD. 

In DataCAD, you can toggle each layer you create on or off at any time; only 
layers toggled on will be displayed, and only one of these layers is active. To 
continue our parallel with overlay drafting, the active layer can be thought of as 
the top piece of trace paper; it is the layer you’re currently drawing on. The 
remaining layers of trace paper in the overlay stack are all the layers toggled on. 
Existing layers not currently in the stack are all the layers toggled off (not 
displayed). 
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The process of drawing from the most general to the most specific is opposite the 
process of gathering information to prepare for drawing. You want to 
understand the building in the greatest detail possible before you draw it. But 
once you start drawing, you want to document all that information gradually, 
arriving at the most specific drawing (the detail) only after you have graphically 
described all the general conditions. 

 
Figure 2.24: The image on the left is how your drawing is organized using layers. 
On the right is how you see your drawing in DataCAD. 

Prioritizing Drawing Tasks 
In addition to making a list of all your layers, make a flow chart of your drawing 
process: what you will draw first, second, third, etc. In order to keep drawing 
redundancy to a minimum, you will want to draw those parts of your drawing 
which are the most general first, then proceed to detail your drawing, gradually 
making it more specific. Along the way, make copies of those parts of your 
drawing that can be used for other drawings. 

Drawing Efficiently 
A drawing will, of necessity, contain many entities. The idea behind CAD is to 
have the computer automatically draw as many of those entities as possible. 
DataCAD incorporates several functions that make this automation possible; 
entities may be copied or mirrored, for example, and symbols and linetypes may 
be added as well. 

Any entity, group, or area in your drawing can be copied one or several times 
automatically or flipped and copied at once to produce a mirror image next to 
the original image. For example, you only need to draw one side of a corridor of 
rooms, if you use Mirror to create the opposite side. For more information on 
using Mirror, see “Mirroring Entities” in the “Other Ways to Draw” chapter. 

Any entity, group, or area in your drawing can be stored in a template as a 
symbol. You can draw a tree once, save it as a symbol in a template, then place 
trees all over your site plan just by selecting with the mouse all the places in your 
drawing where you want the trees to appear. 
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Many material symbols shown in sections and details can be drawn 
automatically by selecting the proper linetype, or by creating one of your own. 
DataCAD has linetypes for materials like insulation, brick, plywood, and roof 
shingles. You could produce, for example, a line of insulation running up a wall 
just by choosing the Insul linetype and entering the two end points of the line. 

DataCAD’s Edit menu provides you with many ways to modify anything you 
draw without redrawing it, including moving or stretching entities, or changing 
their attributes. 

Use Stretch to select an area or point and move it to a new location, automatically 
stretching or shrinking everything attached to what you are moving. For 
example, you can move a window to a new place in the wall, and the wall will be 
stretched to match the new position of the window. For more information on 
using Stretch, see “Stretching Entities” in the “Editing Drawings” chapter. 

Move is different from Stretch in that only the entity, group, selection set, or area 
you select is moved to a new location in the drawing; everything connected to 
those items stays where it is. So if you have two cased openings, one of which 
contains a door, you can move the door to the other cased opening without 
moving all the wall and jamb lines attached to the door. For more information on 
using Move, see “Moving Entities” in the “Editing Drawings” chapter. 

Use Change to alter the characteristics or attributes of any entity, group, area, or 
selection set you’ve created. For example, you can change a wall from double-
weight solid lines to single-weight dashed lines, alter its height from 8 to 10 feet, 
change its color from green to blue, etc. For more information on using Change, 
see “Changing Entities” in the “Editing Drawings” chapter. 

Sample Project 
This is an example of how to use DataCAD by outlining a detailed strategy for 
completing a project; it is not intended to be a tutorial or replace DataCAD 
training. The drawing files for this sample project are on your DataCAD CD-
ROM. 

If you do a Typical installation, the files for this sample project will not be 
installed. To install them after doing a Typical installation, insert your DataCAD 
CD in your CD-ROM drive, select Custom installation, and then select Sample 
Drawings. 

Scope of Work 
Following is a summary of what is known about the building for which you will 
produce working drawings: 
Description A 12,300 s.f. YMCA facilities building, two stories, flat roof, sloping site, with 

parking for 34 cars. 
Materials Structure: Clear-span metal frame with steel column grid, 25’ x 20’, lightweight 

steel floor and bar joists @ 2’-0” O.C. 
 Exterior Walls: Metal panel over metal framing with batt insulation, CMU block 

veneer wall with metal framing, batt insulation and GWB interior. 
 Interior Walls: Metal studs with fire-rated GWB. 
Dimensions Plan: 100’ x 68’-8” exterior limits of building.  
Elevation Hgts Lower Level Floor @ 83.00’  
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 Lower Level Ceiling @ 91.00’  
 Upper Level Floor @ 95.00’  
 Upper Level Ceiling @ 106.75’  
 Top of Roof @ 107.00’ 
 Top of Parapet @ 108.75’ 

Summary of Available Personnel and Drawings Needed  
PERSONNEL DRAWINGS 
Job Captain  Site Plan 
Draftsman 1  Foundation Plan 
Draftsman 2  Lower Level Plan 
  Upper Level Plan 
  Four Exterior Elevations 
  North/South Building Section 
  Lower Level Electrical Plan 
  Upper Level Electrical Plan 
  Lower Level Plumbing Plan 
  Upper Level Plumbing Plan 
  Door, window, and Finish Schedules 
  Door and Window Types 

Planning the Drawing Time 
1. Summarize drawings needed; plan final sheet layout. 

2. Draftsman 1 develops base plans while Draftsman 2 begins work on typical 
details. 

3. Draftsman 1 gives Draftsman 2 the plan information. Draftsman 2 begins 
developing elevations and sections. 

4. When plans, elevations, and sections have been developed, develop 
schedules and details on both workstations using completed drawings as a 
base for detail drawings. 

5. When all drawings have been completed, assemble individual drawings into 
“sheets” for plotting. 

How Draftsman 1 Drew the First Floor Plan 
Draftsman 1 first spent some time with the Job Captain, learning what the project 
involved and the assigned tasks. Then Draftsman 1 sat down and prepared two 
outlines: 

• an outline of the layers required and their names 

• a strategy of what to draw first, second, third, etc. 
LAYER NAME  DESCRIPTION 
A2-BLK   Lower Level Conc. Block 
A2-COL   Upper Level Columns 
A2-DIM   Upper Level Dimensions 
A2-DRS   Upper Level Doors 
A2-FND   Upper Level Foundation 
A2-HCH   Upper Level Hatch 
A2-LAV   Upper Level Lavatories 
A2-LBL   Upper Level Labels 
A2-NOT   Upper Level Notes 
A2-ROM   Upper Level Room Numbers 
A2-STR   Upper Level Stair 
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A2-TIL   Upper Level Tile 
A2-TXT   Upper Level Text 
A2-WIN   Upper Level Windows 
A2-WLS   Upper Level Walls 
 

Draftsman 1’s drawing process outline is as follows: 

1. Create drawing file YMC-MSR1.DC5. 

2. Create and name drawing layers listed above. 

3. Load sheet border from template file. 

4. Input all existing site information. 

5. Draw Columns, Column Grid, Perimeter, and building elements on 
appropriate layers. 

6. Separate drawing layers needed for first floor by saving them out to the hard 
disk on separate layer files. 

7. Create a detailed elevation drawing called YMC-ELV1.DC5. 

8. Create and name the required drawing layers. 

9. Load basic first floor plan drawing layers from layer files. 

10. Draw interior partitions. 

11. Place windows in perimeter wall. 

12. Save modified plan layers to a layer file called YMC-PLN1.LYR. This layer 
will become the exterior wall for the second and third floors, which have 
identical windows to the first floor. 

13. Place doors and windows in perimeter wall and in interior partition walls. 

14. Zoom in on lobby area and draw lobby details. 

15. Zoom in on restroom area and draw fixture layout and details. 

16. Draw reflected ceiling plan. 

17. Add dimensions, labels, and notes to drawing. 

18. Create a new detail elevation file for the Second Floor Plan called YMC-
ELV2.DC5.  

Notice that Draftsman 1’s outlines do not detail how to best draw each part of 
the drawing. This strategy simply gives an outline of what to do next while 
leaving Draftsman 1 free to choose the best drawing method for each part of the 
drawing. Copy, Mirror, and Stretch will be used to produce, respectively, the 
column grid, two halves of a symmetrical parking layout, and two handicapped 
parking spaces that are larger than the other parking spaces. 
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Basic Drawing and Editing 
DataCAD is ready to draw lines immediately upon opening a drawing; notice 
that in the Create pull-down menu, Line is checked by default. You can even 
draw with custom linetypes to represent such things as insulation, telephone and 
electrical lines, and siding. And editing lines, or anything else you draw, is easy 
with DataCAD’s many editing features. 

Drawing Using the Mouse 

 To draw a line by selecting two points: 

1. Move the cursor anywhere in the Drawing Area and click. You’ve just 
selected the first end point of your first line. In addition to simply clicking 
to select a point and begin drawing, you can snap to a point on another 
entity and begin drawing from there. See “Object Snapping” in the 
“Drawing Tools” chapter for more information. 

2. Move the cursor to the point where you want the line to end and click. 
The line is drawn. Notice, however, that if you move your cursor, it is still 
connected to the end of the line. This allows you to continue drawing 
lines, using the end of the previous line as the beginning of the next line. 

3. Repeat step 2 to continue drawing lines until your last end point meets 
the first end point you selected in step 1. 

4. Right-click to disconnect the cursor from the last line. 

Drawing Using Coordinate Entry 
Coordinate entry lets you draw lines more precisely by entering the exact 
coordinates of each end point of a line. In DataCAD, you have a choice of five 
coordinate entry methods, or input modes: 

• Relative polar requires that you enter a distance and an angle relative to the 
last point entered. 

• Absolute polar requires that you enter a distance and an angle from absolute 
0. 

• Relative Cartesian requires that you enter an X and Y distance relative to the 
last point entered. 

• Absolute Cartesian requires that you enter an X and Y distance from 
absolute 0. 

• Distance-Direction requires that you indicate the direction with the mouse 
and then enter a distance relative to the last point entered. 
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Figure 2.25: Polar and Cartesian coordinate entry methods 

Once you select a coordinate entry method, it remains active until you choose a 
different entry method. The coordinate entry method you’re using is always 
displayed in the Message Area beside the coordinate display. (Coordinates are 
only displayed when your cursor is in the Drawing Area.) 

Four additional coordinate entry methods are available only while in the 
3DViews/Controls menu: relative and absolute cylindrical (enter distance, angle, 
and Z coordinate) and relative and absolute spherical (enter distance, plan angle, 
and rise angle). These methods provide additional variables to the Z component 
of coordinate entry, which may be helpful in specialized modeling applications 
like entering a 3D line that represents a solar angle. 

 To choose a coordinate entry method, either: 

• press (Insert) until the name of the method you want appears in the 
Message Area at the bottom of the DataCAD window, or 

• click on Input Mode in the Tools pull-down menu and select a coordinate 
entry method from the list. 

 To draw a line using relative or absolute polar coordinate entry: 

1. Click in the Drawing Area to select the line’s first end point. 

2. Press (Spacebar). 

3. Type the length of the line (the distance from the end point you entered 
in step 1 to the next end point) and press (Enter). 

4. Type the angle of the line from the X axis and press (Enter). The line is 
drawn, with your cursor still attached to the end point of the line. 

5. Continue drawing lines by repeating steps 2-4. Right-click to disconnect 
the cursor from the line. 

 To draw a line using relative or absolute Cartesian coordinate entry: 

1. Click in the Drawing Area to select the line’s first end point. 

2. Press (Spacebar). 

3. Type the relative or absolute X distance from the first end point and press 
(Enter). 
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4. Type the relative or absolute Y distance from the first end point and press 
(Enter). The line is drawn, with your cursor still attached to the end point 
of the line. 

5. Continue drawing lines by repeating steps 2-4. Right-click to disconnect 
the cursor from the line. 

 To draw a line using direction-distance coordinate entry: 

1. Click in the Drawing Area to select the line’s first end point. 

2. Drag the cursor in the direction you want to draw the line. 

3. Press (Spacebar). 

4. Type the length you want the line to be, and press (Enter). The line is 
drawn, with your cursor still attached to the end point of the line.  

5. Continue drawing lines by repeating steps 2-4. Right-click to disconnect 
the cursor from the line 

More About Coordinate Entry 
You can enter distances and angles either by typing a value or by using a value 
menu. See  “Value Menus” earlier in this chapter for more information on how to 
use them. Depending on the scale type you are using, there may be several 
different methods you can use to enter coordinates. See “Setting Scale and Angle 
Types” in the “Before You Draw” chapter for more information. For instance, in 
the architectural scale type, which is DataCAD’s default, you must enter 
distances as feet.inches.fractions of inches. 
TO ENTER: TYPE: 
4’ 4 
6” 0.6 or .6 or (Spacebar)6 
3/16” 0.0.3/16 or ..3/16 or ..3.16 or (Spacebar)(Spacebar)3(Spacebar)16 
4’-6” 4.6 or 4(Spacebar)6 
4’-6 3/16” 4.6.3/16 or 4.6.3.16 or 4(Spacebar)6(Spacebar)3(Spacebar)16 
 

Notice in this example that 3/16” is entered as 0.0.3/16, indicating 0 feet, 0 inches, 
and 3/16 of an inch. Notice also that you can leave out the zeros when you enter 
distances, as long as the decimal points remain as placeholders; so you could 
type ..3/16. Further, slashes, decimal points, and spaces are interchangeable, so 
you could, for instance, replace the slash with another decimal point and type 
..3.16. 

Angles are entered in a similar fashion, except the (Spacebar) method can’t be 
used. For instance, using relative polar coordinate entry, angles are entered as: 
degrees.minutes.seconds 
TO ENTER: TYPE: 
38° 38 
12’ 0.12 or .12  
30” 0.0.30 or ..30 
38°-12’-30” 38.12.30 
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Drawing with Linetypes 
DataCAD has four standard linetypes and 21 custom linetypes. You cannot 
redefine the four standard linetypes -- solid, dashed, dotted and dot-dash -- 
although you can change some of their attributes. You can, however, create your 
own linetypes, adding up to 175 custom linetypes such as special symbolic lines 
for site plan utilities, center lines, and highlighted lines for review. See “User-
Defined Linetypes” in the Appendix for a list of available custom linetypes and 
their settings. 

 To draw a line using a linetype: 

1. Go to the Edit menu in the Menu Window; click on LineType. A list of 
available linetypes is displayed in the Menu Window, along with options 
to modify a chosen linetype’s weight, color, size, factor, or overshoot. 

2. Look at a preview of a linetype before you use it by moving the mouse 
cursor over the linetype option in the Menu Window. Click on ScrlFwrd 
and ScrlBack to scroll forward and backward through the list of linetypes. 

3. Click on a linetype in the Menu Window to use that linetype. 

4. Click on the Factor, Spacing, LineWgt, Color, or OverSht options to 
change the settings for the linetype you chose. See “Linetype Settings” 
below for details on changing linetype settings. 

5. Begin drawing lines as described in “Drawing Lines By Selecting Two 
Points” or “Drawing Lines Using Coordinate Entry” earlier in this 
section. 

Linetype Settings 
All custom linetypes enter building materials at actual size, and they appear at 
the display scale you specify. You can use the following options to customize a 
linetype: 
Factor Toggle that lets you quickly switch between using the default spacing factor (Factor 

toggled off) and the spacing factor set by the Spacing option described below (Factor 
toggled on). 

Spacing Changes the size of the linetype pattern. Keep in mind that DataCAD defines units in 
absolute world coordinates. For example, to set dashed lines to repeat every 1” on a 
1/4”=1’-0” scale drawing, set the spacing to 4’-0”. To set line spacing, click on a value 
in the value menu or type a spacing value, and press (Enter). 

LineWgt Sets the thickness of a linetype. The most common line thickness is 1. To set the line 
weight, click on a line weight in the value menu or type a line weight value, and press 
(Enter). For line weights to display, ShowWgt must be toggled on in the Display 
menu. 

Color Changes the color of a linetype. Any new lines that you enter into the drawing appear 
in the new color.  

OverSht Displays extensions, or punch, at line intersections, giving drawings an architectural 
look. DataCAD always dimensions to the actual length of a line, ignoring any 
displayed overshoot. To set the overshoot, click on OverSht, and then choose or type 
an overshoot distance and press (Enter). For line overshoots to display, OverSht must 
be toggled on in the Display menu. You can change the overshoot distance for 
existing lines with the OverSht option in the Edit/Change menu. 
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Basic Editing Tools 
DataCAD’s Edit pull-down menu provides easy access to most editing functions, 
including primary editing menus such as Move, Copy, Rotate, Mirror, Stretch, 
Enlarge, Erase, Change, Partial Erase, Line Cleanup, and Wall Cleanup. Choose 
any of these editing options to display that menu in the Menu Window. See the 
“Editing Drawings” chapter for details on these options. 

The Edit pull-down menu also includes unlimited, global undo/redo options 
and cut, copy, and paste. The Undo option reverses the last action, including any 
drawing or editing, changes made using macros, or the deletion of layers. The 
Redo option restores the last action.  To undo an action, click on Undo in the Edit 
pull-down menu or press (Ctrl) + (Z); to redo an action, click on Redo in the Edit 
pull-down menu or press (Ctrl) + (Y). You can also use the Undo/Redo toolbar; 
click on Undo/Redo Toolbar in the View pull-down menu to display the toolbar.  

Cut, Copy, Paste, and Paste Special are four more Edit pull-down menu options 
you can use to edit drawings or share parts of drawings between documents. Cut 
removes entities from the drawing to the clipboard, Copy copies entities in the 
drawing to the clipboard, Paste adds entities previously cut or copied to the 
active drawing, and Paste Special lets you choose the format (metafile, text, etc.) 
for entities previously cut or copied and then adds them to the active drawing. 
To cut or copy DataCAD entities, you must first use the Clipboard Select option 
in the Edit pull-down menu to select the entities to be cut or copied. You can 
choose whether to copy just the entity or the entity with its current color and line 
weight. Check the Copy to Clipboard options on the Misc tab of the Program 
Preferences dialog box as appropriate. 

 To move or copy entities from one drawing to another: 

1. Click on Clipboard Select in the Edit pull-down menu. A selection menu 
is displayed in the Menu Window. See “Selection Menus” in this chapter 
for more information.  

Shortcut: Press (Ctrl) + (E) to access the Clipboard Select selection menu. 

2. Toggle InsPoint on to enter an insertion point for the entities. This point 
can then be used to paste the entities into another drawing. Toggle 
InsPoint off to enter entities relative to absolute zero. 

3. Choose a selection method by clicking on one of the selection menu 
options. 

4. Select the entities to be moved or copied. 

5. Click on Cut in the Edit pull-down menu to remove the entities from the 
drawing, or click on Copy to simply copy them. If InsPoint was toggled 
on in step 2, you are prompted to “Select reference point for clipboard 
cut/copy”. If InsPoint was toggled off, skip to step 7. 

Shortcut: Press (Ctrl) + (X) to cut entities, or press (Ctrl) + (C) to copy entities. 

6. Click in the Drawing Area to select a reference point. Your cursor will be 
attached to this reference point when you paste the entities into another 
drawing. 



|  CHAPTER 2: THE DRAWING BOARD  48 

Shortcut: Press (Ctrl) + (V) to paste entities. 

7. Paste them into another DataCAD drawing or into a document in another 
application: 

• Open the drawing you’d like to add the entities to and click on Paste 
in the Edit pull-down menu. Toggle ByCenter on to paste the entities 
by the center of their extents; toggle it off to paste the entities by their 
insertion point (if InsPoint was toggle on) or at absolute zero. 

• Open the drawing you’d like to add the entities to, click on Paste 
Special in the Edit pull-down menu, and select a format for the 
entities. 

• Open the Windows application document that you’d like to add 
entities to and use that application’s paste function. 

You can preserve the exact position of an entity (as measured from absolute zero) 
when copying it from one drawing to another. For example, if a marker was 
placed at x=16’, y=16’ (as measured from absolute zero) in the original file, then 
pasting it into a new file using AbsZero will place the marker at x=16’, y=16’ 
from absolute zero in the new file. 

Referencing Drawings 
You can reference, or link, an unlimited number of DataCAD drawings to your 
current drawing. These referenced drawings, also called XREFs, are displayed in 
your current drawing and will even print as though they were part of your 
current drawing; however, they are not actually added to your current drawing, 
allowing you to keep file size as small as possible. Reference file geometry can be 
moved, copied, mirrored, or enlarged just as any other entities can be, and 
reference files can be rotated into any plane in space. 

 To insert a reference file: 

1. Click on Reference File in the Insert pull-down menu. A dialog box is 
displayed, prompting you to “Enter name of reference file to insert”. 

2. Select a drawing from the list box and click on Open. The dialog box 
closes and a box representing the extents of the referenced drawing is 
displayed, attached to your cursor. The InsX-REF menu is displayed in 
the Menu Window. 

3. Enlarge the referenced drawing before inserting it by clicking on Enlarge 
in the InsX-REF menu. A value menu is displayed and you are prompted 
to “Enter XREF enlargement factor.” 

4. Use the value menu to enter the enlargement factor you want to use and 
press (Enter).  

5. Decide if you’d like to dynamically rotate the reference file geometry into 
place when you insert it into your drawing. If you want to do this, toggle 
DynamRot on. The DynamRot option has no effect if you use AbsZero to 
place the reference file geometry. 

6. Select one of these ways to insert the reference file: 
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• To insert the referenced drawing relative to absolute zero, click 
AbsZero in the Menu Window. The referenced file is inserted into 
your current drawing.  

• To place the referenced drawing by its center, toggle ByCenter on in 
the Menu Window. Move the cursor to position the referenced 
drawing and click to insert it. If you toggled DynamRot on in the 
previous step, you are prompted to “Position XREF on drawing”. 
Rotate the geometry into place and click to insert it. 

• If the ByCenter toggle is off, your cursor is attached to absolute zero 
in the referenced file. Move the cursor to position the referenced 
drawing and click to insert it. If you toggled DynamRot on in the 
previous step, you are prompted to “Position XREF on drawing”. 
Rotate the geometry into place and click to insert it. 

• To use the active clip cube(s) in the referenced file, toggle on UseClip. 
You are prompted to “Position XREF on drawing.” DataCAD inserts 
the active clip cube(s) into the current drawing. 

You can also use coordinate entry to select the point to position the reference file 
geometry. See “Using Coordinate Entry” in this chapter for more information. 

Self-referencing XREFs are supported. You can place an XREF for drawing A into 
drawing A. “Circular” XREFs are no problem since endless-loop swap files are 
not created. Self-referencing XREFs are automatically redefined to reflect the new 
drawing filename when you use the Save As function.  

Referenced files may have unique clipping boundaries. You can have multiple 
Clip Cube definitions active simultaneously. You can also enter text and 
dimensions outside of the XREF Clip Cube. 

 To use XREFs with unique clipping boundaries: 

1. Select Reference File Management from the Insert pull-down menu. 

2. Select Clip Cube from the extended menu. 

3. Choose the XREF for which you want to define a new Clip Cube. 

For information about using clip cubes from referenced files, see “Viewing 
Selected Entities in Your Model” in the “Viewing Your Model” chapter. 

Reference File Manager 
You can use the Reference File Manager to manage reference files in your current 
drawing. When you click on Reference File Management in the Insert pull-down 
menu, you can refresh or reload reference files, resolve orphaned reference files, 
or open the Reference File Manager.  
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Figure 2.26: The Reference File Manager dialog box 

You can also redefine loaded reference file names within the Reference File 
Manager by clicking on the Redefine button. This allows you to redefine XREF 
files that were renamed. Redefined XREFs retain the previous XREF’s position, 
scale, and rotation. 

Displaying Reference File Layers 

 To display only selected layers: 

1. Click on Reference File Management in the Insert pull-down menu. A 
submenu is displayed. 

2. Click on Manager in the submenu. The Reference File Manager dialog 
box is displayed. All the reference files in your current drawing are listed 
in the Reference Files Loaded list box. 

3. Click on a reference file in the list to select it. If necessary, you can use the 
horizontal scroll bar for reference file names that extend beyond the 
dialog window. All the layers in the reference file are listed in the Layer 
Control list box, with a checkmark next to the ones that are on 
(displayed). 

4. Click on the checkboxes next to the layers to turn layers in the reference 
file on or off. 

5. Click on Apply to apply the changes you’ve specified. The checked layers 
are displayed, and the unchecked layers are not displayed. 
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6. Click on OK to close the Reference File Manager dialog box when you’re 
finished. 

Refreshing and Reloading Reference Files 
You can refresh and reload reference files. Refresh will incorporate any changes 
you’ve made to the reference file, such as editing the drawing, but will not 
update any changes to layer status. Reload will update any changes you made to 
the reference file geometry as well as the reference file’s layer status, such as 
which layers are toggled on and which are off. 

 To refresh reference files: 

1. Click on Reference File Management in the Insert pull-down menu. A 
submenu is displayed. 

2. Click on Manager in the submenu. The Reference File Manager dialog 
box is displayed. All the reference files in your current drawing are listed 
in the Reference Files Loaded list box. 

3. Click on a reference file in the list to select it. Press (Ctrl) or (Shift) and 
click to select multiple files. 

4. Click on Refresh. The reference file name is copied into the Marked for 
Refresh list box.  

5. Click on Apply to apply the changes you’ve specified. The selected 
reference files are refreshed. 

7. Click on OK to close the Reference File Manager dialog box when you’re 
finished. 

Double-clicking on a file listed in the Marked for Refresh, Marked for Reload, 
Marked for Bind, or Marked for Delete list boxes will remove the file from the list 
and return it to the Reference Files Loaded list box. 

 To reload reference files:  

1. Click on Reference File Management in the Insert pull-down menu. A 
submenu is displayed. 

2. Click on Manager in the submenu. The Reference File Manager dialog 
box is displayed. All the reference files in your current drawing are listed 
in the Reference Files Loaded list box. 

3. Click on a reference file in the list to select it. Press (Ctrl) or (Shift) and 
click to select multiple files. 

4. Click on Reload. The reference file name is copied into the Marked for 
Reload list box. 

5. Click on Apply to apply the changes you’ve specified. The selected 
reference files are reloaded. 

6. Click on OK to close the Reference File Manager dialog box when you’re 
finished. 
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Double-clicking on a file listed in the Marked for Refresh, Marked for Reload, 
Marked for Bind, or Marked for Delete list boxes will remove the file from the list 
and return it to the Reference Files Loaded list box. 

Binding Reference Files 
XREFs and nested XREFs both bind, based on the On or All toggle in the XREF 
Manager. 

 To bind reference files: 

1. Click on Reference File Management in the Insert pull-down menu. A 
submenu is displayed. 

2. Click on Manager in the submenu. The Reference File Manager dialog 
box is displayed. All the reference files in your current drawing are listed 
in the Reference Files Loaded list box. 

3. Click on a reference file in the list to select it. Press (Ctrl) or (Shift) and 
click to select multiple files. 

4. Look beside the Bind button where there are two small toggles: All and 
On. Click on All to bind all layers in the reference file to the current 
drawing, regardless of whether they’re on or not. Click on On to bind 
only the layers in the reference file that are on (displayed). Before you use 
the On toggle to bind layers of the reference file, use the Layer Control list 
box to check those layers you want toggled on. 

5. Click on Bind. The reference file name is copied into the Marked for Bind 
list box. 

Warning: The drawing file size may increase substantially when you bind 
referenced files. Binding too many files may cause the drawing file size to exceed 
the 128MB limit. DataCAD cannot provide a warning when this occurs. Check the 
Directory (available from the Tools pull-down menu) to monitor the current 
drawing file size. 

6. Click on Apply to apply the changes you’ve specified. The selected 
reference files are bound, and their geometry is copied into the current 
drawing. Once a reference file is bound to the current drawing, it ceases 
to be a reference file. So, if you choose to bind only a few layers of a 
reference file, the entire reference file  -- even those layers you didn’t bind 
-- is no longer linked to your current drawing. 

6. Click on OK to close the Reference File Manager dialog box when you’re 
finished. 

Highlighting is lost when an XREF is bound because it is no longer an XREF. 

Deleting Reference Files 

 To delete reference files: 

1. Click on Reference File Management in the Insert pull-down menu. A 
submenu is displayed. 
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2. Click on Manager in the submenu. The Reference File Manager dialog 
box is displayed. All the reference files in your current drawing are listed 
in the Reference Files Loaded list box. 

3. Click on a reference file in the list to select it. Press (Ctrl) or (Shift) and 
click to select multiple files. 

4. Click on Delete. The reference file name is copied into the Marked for 
Delete list box. 

5. Click on Apply to apply the changes you’ve specified. The selected 
reference files are deleted. 

7. Click on OK to close the Reference File Manager dialog box when you’re 
finished. 

Double-clicking on a file listed in the Marked for Refresh, Marked for Reload, 
Marked for Bind, or Marked for Delete list boxes will remove the file from the list 
and return it to the Reference Files Loaded list box. 

Highlighting Reference File Geometry 
You can use color, linetype, or a combination of the two to highlight reference 
file geometry. Highlighting is lost when an XREF is bound because it is no longer 
an XREF. 

 To highlight entities from a reference file: 

1. Click on Reference File Management in the Insert pull-down menu. A 
submenu is displayed. 

2. Click on Manager in the submenu. The Reference File Manager dialog 
box is displayed.  

3. Click on the reference file in the Reference Files Loaded list box to select 
the reference file you want to highlight. 

4. Click on the On/Off checkbox in the Highlighting section to turn 
highlighting on. 

5. Choose a highlighting color and linetype/line spacing from the drop-
down boxes. 

6. Click on Apply to apply the changes you’ve specified. The highlighting is 
applied to the geometry for that reference file. 

7. Repeat steps 3 – 6 to highlight the geometry from other reference files. 

8. Click on OK to close the Reference File Manager dialog box. 
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Resolving Orphaned Reference Files 
Reference files can be orphaned if you move the file to another folder on your 
computer or if you delete the referenced file. You can resolve the broken link 
between your current drawing and the referenced file by either deleting the link 
or by redefining the path to where you moved the reference file. Clicking on the 
Redefine button allows you to redefine XREF files that became orphaned when 
they were renamed. Redefined XREFs retain the previous XREF’s position, scale, 
and rotation. 

The path between the current drawing and the reference file is limited to 160 
characters. This allows you to use the full pathname that includes Drive + Path + 
Filename. 

 To resolve orphaned reference files: 

1. Click on Reference File Management in the Insert pull-down menu. A 
submenu is displayed. 

2. Click on Orphans in the submenu. The Orphaned Reference Files dialog 
box is displayed, listing all the orphaned reference files in your current 
drawing. 

3. Click on a reference file in the list to select it. 

4. Resolve the orphaned file in one of these two ways: 

• Click on Delete to delete the reference file from your current drawing. 

• Click on Redefine Path to reestablish the link between your current 
drawing and the reference file. A dialog box is displayed, allowing 
you to browse for the file; find the referenced file and click on OK. 
The dialog box closes. Click on Done to close the Orphaned Reference 
Files dialog box.  

Viewing Drawings 
Viewing is simply the way you look at your drawing when you work on it. 
Compare viewing a drawing on the computer with looking at a drawing on your 
drafting board. As you draft on the board, your eyes are always moving and 
refocusing, allowing you to concentrate on small details or view the entire 
drawing sheet quickly and easily. At the computer, you need to consciously 
decide what you want to focus on and to what degree. To say this in CAD terms, 
you will zoom in on an area of your drawing when you have to focus on a detail; 
and when you want to see the entire drawing, you will zoom out to the extents, 
or outermost edges of the drawing. 

Go-to-views, hyperview linking, and multi-view windows are three additional 
viewing features that allow you to jump quickly to preset views of your drawing. 
See the “Viewing Your Model” chapter. 
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Zooming In and Out 
The WindowIn menu in DataCAD lets you zoom in on an area by displaying the 
drawing in a larger scale. When you zoom out, you are actually looking at your 
drawing in a smaller scale, which allows you to see more of your drawing. The 
scales that the WindowIn menu uses are predefined in the Utility/ 
Settings/EditDefs/Scales menu. 

 To zoom in on your drawing: 

1. Click on WindowIn in the Utility menu, or click on the W in the 
Projection Pad.  

2. Click above and to the left of the area you want to scale. 

3. Move the mouse down and to the right to stretch the box around the area 
you want to zoom in on. 

4. Click to complete the box. The drawing rescales automatically. 

Shortcuts: Press (/) to display the WindowIn menu in the Menu Window.  

To return to the previous view (essentially undoing the  zoom), press (P). 
DataCAD remembers up to 25 previous views.  

Press (PgUp) and (PgDn) to quickly zoom in and out on your drawing. To use 
PgUp and PgDn on your numeric keypad, make sure NumLock is off first. 

 To zoom to your drawing’s extents: 

1. Click on WindowIn in the Utility menu, or click on the W in the 
Projection Pad. 

2. Click on Extents in the WindowIn menu. Your drawing is displayed at 
the largest scale possible while still displaying the drawing in its entirety. 
If you’ve made significant changes to your drawing, click on Recalc 
instead of Extents. DataCAD will review your drawing and update the 
extents of the drawing accordingly. 

Shortcut: Click on the E in the Projection Pad to view the drawing at its extents; 
click on R to recalculate the extents. 

 To zoom in on your drawing and display the area to its extents: 

1. Click on WindowIn in the Utility menu, or click on the W in the 
Projection Pad. 

2. Toggle FreeZoom on or off in the WindowIn menu, depending on your 
preference. When it is toggled on, DataCAD can show a nonstandard 
display scale. When it is toddled off, DataCAD can only use the 
predefined display scales from the Utility\ToScale menu. 

3. Click at one corner of the area you want to zoom in on and move the 
mouse diagonally to stretch a rubberband box around this area. The area 
is displayed at its extents. 

Shortcut: Press (Home) to center your drawing at the current cursor position in 
the Drawing Area.  
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Figure 2.27: Zooming in on your drawing. 

Changing Your View Using the Keyboard 
In addition to zooming in and out on your drawing, you can use the arrow keys 
to scroll, or pan, in different directions around the screen. Your view of your 
drawing changes each time you press an arrow key. Pressing the up arrow key lets 
you look up towards the top of your drawing by moving the drawing down. The 
scroll distance, or the distance that the drawing moves each time you press an 
arrow key, is defined using the ScrlDist option in the Utility/Settings menu. See 
“Setting the Panning Distance” in the “Before You Draw” chapter for more 
information on setting the scroll distance. 

Saving Drawings 
It is a good idea to save your drawing periodically, especially when you walk 
away from the computer or when you’ve made several changes. There are four 
ways to save your drawing in DataCAD. 

• Press (Shift) + (F) (if Caps Lock is on, just press (F)). This shortcut is a great 
way to quickly save your drawing with minimal interruption. 

• Click on Save in the File pull-down menu.  

Shortcut: Press (Ctrl)+(S) to save your drawing. 

• Click on Save As in the File pull-down menu to save your changes under a 
different drawing filename. 

• Click on Save All in the File pull-down menu to save changes to all open 
drawings. 

Warning: If you close your drawing without saving it, any changes you’ve made since 
you last saved it will be lost. If it’s a new drawing that has not yet been saved, all 
references to the drawing in DataCAD will be erased. 
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More About Recovering Lost Work 
At regular intervals, DataCAD automatically saves the changes you’ve made to 
your drawing to a temporary file, called an autosave (.ASV) file. The autosave 
file exists only until you save the drawing. When DataCAD updates your 
drawing’s autosave file, you’ll see the message “Automatic save in progress” in 
the user prompt line in the Message Area. See “Automatically Saving Your 
Drawing” in the “Before You Draw” chapter for information on how to set the 
automatic save interval.  

The autosave file is located in your DATACAD\TEMP\ folder and has the same 
name as your drawing file but with an .ASV extension; so if your drawing file is 
named HOUSE.DC5, your autosave file will be HOUSE.ASV.  

An autosave file is different from a backup (.BAK) file in that it is a temporary file 
that exists only during your work session in DataCAD. If you save your drawing 
or close DataCAD, the autosave file is DELETED. It does not overwrite or update 
your drawing or backup files in any way. 

If you experience a power interruption caused by an electrical failure, hardware 
problem, or other error, any changes you made to your drawing since you last 
saved it are lost. Fortunately, the temporary autosave file is not disturbed, and 
you can recover your drawing to the point of the last autosave. There is also a 
.SWP file that is a copy of the drawing you’re working on. If you exit DataCAD 
abnormally, you can simply rename the .SWP file with a .DC5 extension to 
recover your work. 

Warning: Keep in mind that SWP files can be corrupt or invalid. You should use them 
only if the ASV or BAK file is either not available or is corrupt as well. If an ASV file exists, 
it should be your first choice for recovering a file. 

It’s always a good idea to rename your old drawing file to something like 
HOUSE.OLD before renaming the autosave file. That way you keep a copy of the 
original drawing file but have your newly renamed autosave file to work on. 

 To recover changes made to your drawing since you last saved it: 

1. Start DataCAD and open your drawing (.DC5) file. The message “File 
[drawing name] is already marked in use. Continuing with this file will 
result in data loss. Are you sure you wish to continue?” is displayed. 

2. Click on Yes. The message “An autosave (.ASV) file for this drawing 
exists. Are you sure you want to continue?” is displayed. 

3. Click on Yes to continue. 

4. Click on Yes to rename the autosave file. 

5. Type a new name for the autosave file and press (Enter). This name must 
be different from the name of the original drawing. Consider naming this 
file with a generation letter or number: DRAWING1.DC5, for instance. 

6. Press (Enter) to confirm the new filename. You now have two copies of 
the drawing; the new file is the most current. 
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8. Notice that the new filename is displayed in the Enter Drawing File to 
Edit dialog box. Click on the new file and click on Open. Your drawing 
opens in the Drawing Area. 

A swap (.SWP) file is also created when you’re working on a drawing. If you 
have a power interruption, for example, the swap file remains in the 
DATACAD\ TEMP folder and can also be renamed to recover your work. 

 To recover drawing changes without starting DataCAD: 

1. Do not start DataCAD again. Instead, in Windows Explorer, change to the 
folder, \DATACAD\TEMP\. 

2. Click on the autosave file to highlight it; you do not need to open it. 

3. Click on Rename in the File menu in Windows Explorer. 

4. Type a new name for the file, changing the extension to .DC5. So if your 
autosave file is named HOUSE.ASV, rename it to HOUSE.DC5. 

 To open your drawing without recovering changes in the autosave file: 

1. Start DataCAD and open your drawing (.DC5) file. The message “File 
[drawing name] is already marked in use. Continuing with this file will 
result in data loss. Are you sure you wish to continue?” is displayed. 

2. Click on Yes. The message “An autosave (.ASV) file for this drawing 
exists. Are you sure you want to continue?” is displayed. 

3. Click on Yes to continue. 

4. Click on No; you won’t rename the autosave file. The autosave file is 
deleted and your drawing opens. 

Another way DataCAD helps guard against loss of work is by automatically 
creating a backup (.BAK) file every time you save your drawing. Suppose you’re 
unable to open your drawing because of a disk failure or file corruption. By 
replacing your drawing (.DC5) file with the backup file, you can recover your 
previous drawing version and prevent a loss of your work. 

 To recover your work using a backup file: 

1.  Start DataCAD. 

2. Go to the Enter Drawing File to Open dialog box. Change the Files of 
Type drop-down box to Backup Files (*.BAK). 

3. Click on your backup file to highlight it and click on Open. Your drawing 
is displayed in the Drawing Area, and automatically renamed with a 
.DC5 extension. 

4. Click on Save in the File pull-down menu. We recommend renaming and 
keeping your original file instead of overwriting it. 

You can run the Layer Utility to clean up the recovered file. 
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More About Naming Your Files 
Naming your drawings is an important step to meaningful and efficient file 
organization. Ideally, the names of your drawings and the folders you store them 
in will reflect the contents of the file as well as the project they pertain to. 

Identifying your drawings and layers with names like “florplan” or “bricks” or 
“dmension” becomes confusing and redundant. Which floorplan? What kind of 
bricks? Dimensions of what? 

Despite the fact that everyone would rather read names than numbers, a naming 
system based on numbers can eliminate confusion between files. How you 
structure this numbering system is up to you  only you know the specific 
needs of your office. 

In the sample project outlined earlier in this chapter, we used a different naming 
system. In the filename YMC-MSR1, “YMC” is the job name abbreviation, “MSR” 
is the drawing type, and “1” is the drawing version number. A similar 
convention is used for naming layer files in that project. 

The system described below is a typical numbering system that has worked well 
in several architectural offices. 

• The first three characters of the filename = the last three digits of the office 
job number. 

• The next two characters of the filename = the letter and number of the type of 
drawing. (See the following drawing type list.) 

• The last two characters of the filename = the chronological revision number 
of the drawing. 

A suggested system for identifying types of architectural drawings follows: 
A0 = General (index, symbols, location plan, 3D views) 
A1 = Existing and temporary conditions, site work, demolition 
A2 = Plans, detail plans, roof plan 
A3 = Exterior elevations, detail elevations 
A4 = Building sections, wall sections 
A5 = Interior elevations, toilet elevations 
A6 = Reflected ceiling plan, floor patterns, furnishings 
A7 = Schedules, door and window types 
A8 = Details 
A9 = Alternates 
 

Structural, mechanical, HVAC, and civil drawings can be identified by type in a 
similar fashion. Under the above system, for example, the drawing of the fourth 
elevation in job number 85236 would be named 236A304.DC5. 
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Exporting Files 
It may often be necessary to export your DataCAD drawings to other file 
formats, so they may be used in other applications by you or other offices or 
consultants you work with. You can export both DWG and DXF files compatible 
with AutoCAD releases 12, 13, and 14 as well as AutoCAD 2000. You can also 
export a DC Render (.RAY) file or an o2c object. It’s generally a good idea to run 
your drawing file through Layer Utility before exporting it. For details, see 
“Layer Utility” in the “Drawing Tools” chapter. See “DXF/DWG Translation” in 
the “Appendix” for more information about how entities are translated during 
export. 

During export, line definitions and shape codes for DataCAD linetypes are 
stored in a .SHX file. If you export a DWG file of the DataCAD drawing 
MYDRAWING.DC5, the translator will create two files: MYDRAWING.DWG 
and MYDRAWING.SHX. For linetypes in the DWG file to display correctly, the 
.SHX file must be placed in the \SUPPORT folder in the AutoCAD directory. 

DataCAD models can be exported to web-friendly VRML 1.0 (Virtual Reality 
Markup Language). This means that any of your customers who have a VRML 
viewer can see your 3D model.   

 To export your drawing to a DXF or DWG file: 

1. Save your drawing before starting the export function. This is especially 
important if you’ve made any changes to your drawing. 

2. Click on Export in the File pull-down menu. A submenu is displayed. 

3. Click on DWG or DXF in the submenu. Two export options are displayed 
in a submenu: All Layers and On Layers. 

4. Click on All Layers to export all the layers in your drawing. Click on On 
Layers to export only those layers that are toggled on, or currently being 
displayed. The Export dialog box is displayed. 

5. Go to the File name input box and type a name for the file. 

6. Choose a file type from the Save As Type drop-down box. If you chose 
DWG in step 3, the default file type is R14-DWG file (*.dwg); if you chose 
DXF in step 3, the default file type is R14-DXF file (*.dxf). 

7. Click on Save; the export begins. The export’s progress is displayed in the 
Message Area. To cancel the translation, press (End). If the filename you 
entered in step 4 already exists, a dialog box will be displayed, giving you 
the choice to overwrite (replace) the existing file. Also if the DWG/DXF 
file you’re attempting to overwrite is open, a message explaining that the 
file is currently in use will be displayed. By default, DataCAD saves all 
exported files to the DATACAD\XFER folder. 

Exported .RAY files include eight light sources: one sunlight and seven 
spotlights. 

 To export to a DC Render (.RAY)  file: 

1. Click on Program Preferences in the Tools pull-down menu. 
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2. Click on the Misc tab in the Program Preferences dialog box. 

3. Go to the DC Render Material Assignment section. Select By Color to 
export a .RAY file in which you can assign a different material to all 
entities of each color; select By Layer to export a .RAY file in which you 
can assign a different material to all entities on each layer; or select By 
Layer and Color to export a .RAY file in which you can assign different 
materials to all entities of each color on each layer. By Layer and Color is 
the default selection and is the most comprehensive. 

4. Click on OK to save your changes and close the Preferences dialog box. 

5. Click on Export in the File pull-down menu. A submenu is displayed. 

6. Click on RAY in the submenu. A dialog box is displayed. 

7. Type the name of the .RAY file that you’d like to export. 

8. Decide what folder you want to use for the .RAY file. DC Render files are 
saved to your DATACAD\RAY folder by default. If you’d like to save 
your .RAY file to another folder, use the Save In drop-down box or the 
Up One Level icon button to change to another folder. To change the 
default folder that DC Render files are saved to, choose Program 
Preferences from the Tools pull-down menu and change the pathname 
for DC Render Files. 

9. Click on Save to export your drawing to the named .RAY file. 

 To export an o2c object: 

1. Click on Export in the File pull-down menu. A submenu is displayed. 

2. Click on o2c in the submenu. A dialog box is displayed. 

3. Type a name for the o2c object that you’d like to export. 

4. Decide what folder you want to use for the o2c object. By default, o2c 
objects are saved to your DATACAD\RAY folder. If you’d like to save 
your o2c objects to another folder, use the Save In drop-down box or the 
Up One Level icon button to change to another folder. 

5. Click on Save to export your model as the named o2c object. 

 To export a 3D model to VRML 1.0: 

1. Select Export from the File pull-down menu. 

2. Click on VRML in the extended menu. A dialog box appears. 
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Figure 2.28: Save VRML file format for export 

3. Supply a file name for the VRML file that you want to create. Then, click 
on Open or press (Enter). 

More About o2c Objects 
You can export your DataCAD model as an o2c object. o2c, an acronym for 
Objects to See, is a highly compressed 3D format that is optimized for Internet-
based communication.  

Simply export your DataCAD model as an o2c object and then either distribute it 
to your client as an e-mail attachment or embed it into one of your web pages. 

Using the easy-to-use o2c player, your clients can freely rotate or walk through a 
fully rendered architectural model. They can view models in wire-frame, hidden-
line, flat-shaded, textured, or ray-traced modes. The o2c objects can even contain 
animated elements that can be played in conjunction with the 3D viewing 
commands. And because you can generate a high-resolution, photorealistic 
rendering of the model right in the o2c player, you don't need to transmit 
excessively large images via email; your clients can simply create their own. 
While the o2c player provides comprehensive and powerful viewing controls, 
objects can’t be modified. 

For more information about o2c, see the chapter on “Viewing Your Model.” 
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