
Drawing Walls, Windows, & 
Doors 

The Architct menu in the Edit menu combines the three most basic 
drawing elements under a single menu. Architct includes options for 
drawing 2-line, 3-line, and 4-line walls as well as windows and six 
different door styles, all with a variety of customizable options. 

With a single choice from the Architct menu, you can begin 
drawing walls whose intersections can be cleaned 
automatically. Windows, doors, and other wall openings can 
then be inserted with just a few clicks and, if necessary, 
removed just as easily. 
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Drawing Walls 
Walls can be drawn by simply toggling on the Walls option in the Architct menu. 
DataCAD automatically cleans wall intersections, including the last intersection 
where the first and last walls drawn meet. 

You can draw 2-line walls using the 2LnWalls option, 3-line walls using the 
3LnWalls option, or 4-line walls using the 4LnWalls option. Two line walls draw 
an inside and an outside line, 3-line walls add a centerline, and 4-line walls add 
two cavity walls. The 2LnWalls, 3LnWalls, and 4LnWalls toggles are mutually 
exclusive; when one is toggled on, the others are automatically toggled off. 

Outside wall

Center line

Cavity wall

Inside wall with Hilite

2LnWall

3LnWall

4LnWall  
Figure 8.1: DataCAD’s wall types 

You can also use the Walls option in the DCAD_AEC macro to draw walls. This 
Walls option works the same way that Walls in the Architct menu does, although 
it does have fewer settings to customize wall display. 

 To draw walls: 

1. Make sure Ortho is toggled on. Walls can only be drawn in orthographic, 
or plan, view; if you’re not already in plan view, click on Ortho in the 
Projection Pad or click Orthographic in the View pull-down menu. 

2. Go to the Edit menu in the Menu Window and click on Architct. 

Shortcut: Press (=) to quickly toggle Walls on or off from anywhere in DataCAD. 

3. Click on Walls in the Architct menu to toggle it on; Wall is checked in the 
Create pull-down menu, and you can now draw walls instead of lines. 

4. Click on 2LnWalls to draw 2-line walls, click on 3LnWalls to draw 3-line 
walls, or click on 4LnWalls to draw 4-line walls. 

5. Set the wall attributes using the Hilite option along with Width for 2-line 
walls, CntrLine for 3-line walls, and Exterior, Interior, and Cavity for 4-
line walls. See “More About Setting Wall Attributes” later in this chapter. 
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6. Select two points to draw a wall. When you do this, the line connecting 
those two points becomes the outside wall, inside wall, center of the wall, 
or center of the wall cavity, depending on whether Outside, Inside, 
CntrWall, or CntrCvty is toggled on, respectively. Click on Outside to 
define walls by the outside of the wall, click on Inside to define them by 
the inside of the wall, click on CntrWall to define them by the center of 
the wall, or click on CntrCvty to define them by the center of the wall 
cavity. When drawing 2-line walls or 3-line walls, CntrWall and CntrCvty 
work the same way. You can choose either option to create walls based 
on the wall center. 

7. Click on Clean to automatically clean wall intersections as you draw your 
walls; click on Cap to cap wall ends as you draw your walls. You are 
prompted to “Select first end point of new line/wall”. For more 
information on using Clean and Cap, see “More About Finishing Walls” 
later in this chapter. 

8. Click anywhere in the Drawing Area or use coordinate entry to start 
drawing your walls. You are prompted to “Select next end point of new 
line/wall”. 

9. Move the cursor using your mouse and click again or use coordinate 
entry to specify the end of the first wall. 

10. Click anywhere on the inside or outside of the wall, depending on what 
you did in step 6. If you chose Outside, CntrWall, or CntrCvty in step 6, 
click anywhere on the inside of the wall; if you chose Inside in step 6, 
click anywhere on the outside the wall. 

11. Notice that your cursor is still connected to the end of your first wall. You 
can continue selecting wall end points, as you did in step 9; all 
intersections will be automatically cleaned. 

12. Finish drawing walls by right-clicking to disconnect your cursor from the 
wall, or clicking near the first endpoint of your first wall to close your 
wall plan. Your cursor is automatically disconnected. 

Sometimes, you may need to fix wall intersections that didn’t clean properly 
when they were drawn. Use the Cleanup menu’s TIntsct, LIntsct, and XIntsct 
options to clean wall intersections. Use the Cleanup menu’s WeldLine and Weld 
Wall options to mend openings in walls. See “Cleaning Wall Intersections” and 
“Welding Lines and Walls” in the “Editing Drawings” chapter. 

More About Setting the Width of Walls 
When toggling on the Walls option in the Architct menu, you are prompted for a 
new wall width. A wall width is the distance between the inside and outside wall. 
You can also change wall width anytime while drawing 2-line or 3-line walls. 

 To change the width of walls to be drawn: 

1. Go to the Edit menu in the Menu Window and click on Architct. 
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2. Click on Width in the Architct menu. A value menu is displayed in the 
Menu Window. The Width option is not available when 4LnWalls is 
toggled on 

3. Use the value menu to enter a new width, or type a new width and press 
(Enter). DataCAD sets the new wall thickness and subsequent walls will 
be drawn with that thickness. For more information on using value 
menus, see “Value Menus” in “The Drawing Board” chapter. 

More About Setting Wall Attributes 
You can assign different attributes to outside or inside walls, including colors, 
linetypes, and line weights by using the Hilite option in the Architct menu. Other 
attribute options apply only to 3-line or 4-line walls. 

 To draw walls with either the outside or inside wall in a different color, 
linetype, or line weight: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Hilite in the Architct menu. The Hilite menu is displayed in the 
Menu Window. You can only set Hilite options for either the inside wall 
or the outside wall; for example, you can’t assign a color to the outside 
wall and a linetype to the inside wall. 

3. Click on Outside in the Hilite menu to highlight the outside of your walls. 
Click on Inside to highlight the inside of your walls. 

4. Click on Color to choose a highlight color, click on LineWgt to choose a 
line weight to highlight your walls with, or click on LineType to choose a 
linetype as a highlight. 

5. Right-click to return to the Architct menu. 

6. Begin drawing your walls. Notice that the color, linetype, or line weight 
attributes you set are applied as walls are drawn. 

 To set attributes for the center line when drawing 3-line walls: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on CntrLine in the Architct menu. The CntrLine menu is displayed 
in the Menu Window. The CntrLine option is only displayed when 
3LnWalls is toggled on. 

3. Click on Color to choose a highlight color, click on LineWgt to choose a 
line weight to highlight your walls with, click on LineType to choose a 
linetype as a highlight, or click on Spacing to set the spacing for the center 
line. The Spacing setting lengthens both the lines and the spaces in a 
linetype, so that the aspect ratio of the linetype is preserved. 

 To set the distance from the exterior wall to the exterior cavity wall when 
drawing 4-line walls: 

1. Go to the Edit menu in the Menu Window and click on Architct. 
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2. Click on Exterior in the Architct menu. A list of width values is displayed 
in the Menu Window. 

3. Use the value menu, or type a new value and press (Enter) to set the 
exterior wall thickness. For more information about how to use value 
menus, see “Value Menus” in “The Drawing Board” chapter. 

 To set the distance from the interior wall to the interior cavity wall when 
drawing 4-line walls: 

1. Click on Architct in the Edit menu. 

2. Click on Interior in the Architct menu. A list of width values is displayed 
in the Menu Window. 

3. Use the value menu, or type a new value and press (Enter) to set the 
interior wall thickness. 

 To set the attributes for the cavity wall when drawing 4-line walls: 

1. Click on Architct in the Edit menu. 

2. Click on Cavity in the Architct menu. The Cavity menu is displayed in 
the Menu Window. 

3. Click on Width to set the width from the exterior cavity wall to the 
interior cavity wall; click on Color to choose a color for cavity walls; click 
on LineWgt to set the line weight of cavity walls; click on LineType to set 
the linetype for cavity walls; click on Spacing to set the spacing for cavity 
walls. 

More About Finishing Walls 
As you saw in the tutorial in this manual, DataCAD always cleans the 
intersections of walls as you draw them, as long as you don’t disconnect your 
cursor from the last wall you drew. For T intersections, you can toggle on Clean 
in the Architct menu to automatically trim the interior wall lines as you draw the 
walls so that your walls look continuous, without internal lines at corners. 

Sometimes you may need to fix wall intersections that didn’t clean properly 
when they were drawn. Use the Cleanup menu’s TIntsct, LIntsct, and XIntsct 
options to clean wall intersections. Use the Cleanup menu’s WeldLine and Weld 
Wall options to mend openings in walls. 

Shortcut: Press (\) to toggle Clean on or off. 

The Cap option in the Architct menu can be toggled on to insert a wall cap or 
closure on the end of a wall. When you draw walls, wall ends are automatically 
capped instead of remaining open. 

The Clean and Cap toggles are mutually exclusive; when one is toggled on, the 
other is automatically toggled off. 
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Using Wall Styles 
You can save wall styles for 2-line, 3-line, or 4-line walls with the wall attributes 
you use most often, and then use them in any drawing file. The following 
attributes are saved in a wall style: 

• line color, linetype, line spacing, and line weight of wall lines. The Spacing 
setting lengthens both the lines and the spaces in a linetype, so that the aspect 
ratio of the linetype is preserved. 

• whether you want to highlight the inside or outside line of your walls using 
color, line weight, and linetype. 

• wall widths and center line and cavity wall attributes. 

 To save a new wall style: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on WallStyl in the Architct menu. The Wall Style Manager dialog 
box is displayed. 

3. Click on SaveAs in the Wall Styles Available section at the bottom of the 
dialog box.  Another small dialog box is displayed, prompting you to 
enter a new wall style name. 

4. Type a name for your new wall style, and press (Enter) or click on OK. 
The wall style is saved and now appears in the drop-down list in the 
bottom left corner of the dialog box.  

5. Click on OK to close the dialog box. 

 To save changes to a wall style: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on WallStyl in the Architct menu. The Wall Style Manager dialog 
box is displayed. 

3. Using the drop-down list in the Wall Styles Available section at the 
bottom of the dialog box, select the wall style you want to save changes 
to. 

4. Change wall settings as necessary. 

5. Click on Save in the Wall Styles Available section at the bottom of the 
dialog box. The wall style is saved with any changes you made to wall 
settings. 

 To use a wall style: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on WallStyl in the Architct menu. The Wall Style Manager dialog 
box is displayed. 

3. Use the drop-down list in the Wall Styles Available section at the bottom 
of the dialog box to select the wall style you want to use. Wall settings in 
the dialog box are changed to those of the wall style you selected. 
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4. Click on OK to close the dialog box. 

 To delete a wall style: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on WallStyl in the Architct menu. The Wall Style Manager dialog 
box is displayed. 

3. Use the drop-down list in the Wall Styles Available section at the bottom 
of the dialog box to select the wall style you want to delete. 

4. Click on Delete. The selected wall style is deleted. 

5. Click on OK to close the dialog box. 

 To display the settings for a wall style: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on WallStyl in the Architct menu. The Wall Style Manager dialog 
box is displayed. 

3. Use the drop-down list in the Wall Styles Available section at the bottom 
of the dialog box to select the wall style whose settings you want to view. 
Wall settings in the dialog box are changed to those of the wall style you 
selected. 

4. Click on OK to use those wall style settings and close the dialog box, or 
click on Cancel to close the dialog box without changing wall settings. 

Cutting Walls 
You can use CutWall in the Architct menu to remove sections of walls. 

 To cut openings in walls using the mouse: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on CutWall in the Architct menu. The CutWall menu is displayed. 

3. Determine which layer your walls are on. If your walls are on a layer 
other than the active layer, click on LyrSrch to toggle it on. If LyrSrch is 
already on, toggle it off and then back on again to choose your walls 
layer. The layers in your drawing are listed in the Menu Window. 

4. Click on the layer your walls are drawn on. 

5. Select one side of the opening by clicking on a point on the wall or using 
coordinate entry to specify the exact coordinates. To choose a coordinate 
entry method, use the Input Mode option in the Utility pull-down menu. 

6. To select the other side of the opening, move the mouse along the wall 
and click on any point or use coordinate entry. The wall is cut and the 
wall ends are capped automatically. 

If the wall opening is a result of adding a door or window when Cutout was 
toggled off, you must use Erase in the Edit menu to erase the framed opening. 
You will then need to use WeldWall in the Edit/Cleanup menu to weld the wall. 
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 To remove an opening from your drawing: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on CutWall in the Architct menu. The CutWall menu is displayed. 

3. Determine which layer contains your walls. If your walls are on a layer 
other than the active layer, click on LyrSrch to toggle it on. The layers in 
your drawing are listed in the Menu Window. 

4. Click on Remove in the CutWall menu. 

5. Click to one side of the opening and move your mouse diagonally to 
stretch the rubberband box around it, completely enclosing all elements 
of the opening. You can stretch the box around multiple openings to 
remove them all at once. 

6. Click to complete the box. DataCAD removes the opening and welds the 
wall. If any remnant of the opening remains, click (Esc) to refresh the 
drawing. 

Drawing Doors 
Not only can you draw walls using the Architct menu, you can also use it to 
draw doors, complete with door swings, in a few quick steps. DataCAD places a 
jamb into the wall, erases the wall between the jambs, draws the door at the 
specified thickness, and draws the door swing at the specified direction and 
angle. 

You can draw doors by selecting the sides of the door or by selecting the center 
and strike side of the door. When toggled on, the Sides option lets you draw 
doors by indicating the door sides (doorjambs). When Sides is toggled off, doors 
are drawn by indicating their center and strike side. 

If LyrSrch is not toggled on or you have not selected the layer your walls are on, 
you may see the error message “No walls found to cut. Please check search 
layer”. Toggle LyrSrch on (if it’s already on, toggle it off and then on again) to 
display the layers in your drawing. Click on the layer your walls are drawn on in 
the list in the Menu Window. 

 To draw a door using the mouse: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on DoorSwng in the Architct menu. The DoorSwng menu is 
displayed. You can also access the DoorSwng menu in the Edit/ Architct 
menu using the Doors option in the DCAD_AEC macro. 

3. Set the door jamb, angle, style, thickness, head height, and swing style as 
necessary. See the following pages for more information on setting these 
door options. 

4. Look at the Sides toggle switch. If Sides is toggled on, you are prompted 
to “Select hinge side of door.” If Sides is toggled off, you are prompted to 
“Select center of door.” To enter the point you’re prompted for, click on a 
wall or use coordinate entry. You are prompted to “Select strike side of 
door.” 
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5. Click on the wall or use coordinate entry to enter the strike side of the 
door. You are prompted to “Select direction of door swing.” See “More 
About Coordinate Entry” in “The Drawing Board” chapter. 

6. Click either inside or outside the wall, to indicate which direction the 
door should swing. You are prompted to “Select any point on the outside 
of the wall.” 

7. Click anywhere outside the wall. The door and doorjamb are drawn. 

 
Figure 8.2: Drawing a door 

More About Door Styles 
The DoorStyl menu allows you to choose from six door styles: single, double, bi-
fold, sliding, pocket, and overhead. See Figure 8.3 for examples of door styles. 
Single creates single-leaf, hinged doors of any size. This is the default setting for 
the DoorStyl menu. Click on Double to draw two opposing doors hung on a 
single frame. Bi-fold creates simplified folding doors, while Sliding creates 2-
panel sliding doors, and Pocket creates pocket doors. Click on Overhead to create 
overhead garage doors. A dotted line representing the overhead door in a raised 
position will be drawn, with the dimensions equaling the width and head height 
of the door. 

Single

Sliding Pocket Overhead

Double Bi-Fold

 
Figure 8.3: Door styles available in the DoorStyl menu 
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More About Door Jambs 
Some of the DoorSwng menu options affect how the door is drawn in the wall. 
Click on DrawJamb, InWall, or Cutout to toggle the option on.The DrawJamb 
option draws door jambs for each wall opening, while InWall precisely centers 
door openings between the two wall faces, and Cutout removes the wall segment 
between the two jambs. An added benefit to drawing doors with Cutout toggled 
on is that the walls will automatically weld themselves if you use Remove to 
erase the door. You may need to use LyrSrch with Cutout if you’re drawing 
doors on a different layer than your walls are on; click on LyrSrch and then click 
on the layer your walls are on.  

JambIn is a toggle that determines whether the door will be drawn by rough 
opening or finished opening. Rough opening means that the door jamb is drawn 
inside the opening specified; finished opening means the door jamb will be drawn 
outside the opening specified. By default, JambIn is toggled off, meaning the 
door will be drawn by finished opening. When JambIn is toggled on, DataCAD 
draws the door by rough opening. 

To explain further, when using Sides to draw a door with JambIn off, the two 
points you select mark the inside of the finished opening; therefore, the jamb will 
be drawn outside the two points specified. If you toggle JambIn on and draw 
another door, the two points you select mark the rough opening in the wall, and 
the jamb is drawn inside the two points. 

You can also change the jamb width for your doors. 

 To set a new jamb width: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on DoorSwng in the Architct menu. The DoorSwng menu is 
displayed. 

3. Click on JambWdth in the DoorSwng menu. 

4. Choose or type a jamb width value and press (Enter). 

MtchWall in the DoorSwng menu is toggled on by default, causing jamb depth to 
automatically match the wall width. When MtchWall is toggled off, the 
JambDpth option becomes available; you can use JambDpth to set the jamb 
depth independently of the wall width. JambDpth is only available from the 
menu when MtchWall is toggled off. 

More About Door Angles 
Click on Angle in the DoorSwng menu to determine the door opening. An angle 
set to 0-0’ will result in the doors being drawn closed, while a 90-0’ angle will 
result in the doors being drawn fully open. For bi-fold doors, a 90° angle creates 
a right angle at the intersection of each door. When an angle between 0-0’ and 90-
0’ is entered, DataCAD will draw single and double doors open to varying 
degrees.  
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DataCAD will draw sliding and pocket doors open to varying degrees when an 
angle between 10-0’ and 90-0’ is chosen. When any angle 90-0’ or greater is 
chosen, sliding and pocket doors will be drawn fully open. When fully open, 
sliding doors will be drawn to one side and at the first point chosen for the door 
opening, making the opening at the second point. When doors are drawn closed, 
the door overlap is equal to double the door thickness. The Angle setting does 
not affect Overhead doors; they are always drawn the same, regardless of angle. 

 To set the angle of the door opening: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on DoorSwng in the Architct menu. The DoorSwng menu is 
displayed. 

3. Click on Angle in the DoorSwng menu. 

4. Use the value menu to enter a new angle or type an angle value and press 
(Enter). An angle of 0-0’ draws doors closed. An angle of 90-0’ draws most 
doors fully open. See “Value Menus” in “The Drawing Board” chapter for 
more information on how to use them. 

More About Door Swing 
The SwngStyl option in the DoorStyl menu lets you choose the type and color of 
the door swing. You can choose to draw either a line or arc swing style or to have 
no door swing drawn at all. The Line option draws a straight line from the corner 
of the doorjamb to the corner of the open door to represent the door swing. The 
Arc option draws a curve from the corner of the jamb to the corner of the door. 

With both Line and Arc, you can toggle MtchDoor on in the SwngStyl menu to 
match the door swing color to the door color. This option is toggled on by 
default. When MtchDoor is toggled off, the SwngColr option is available in the 
menu. Click on SwngColr to choose a color for the door swing, independent from 
the door color. 

More About Other Door Settings 
Regardless of which way you draw a door, you can use CntrPnt to add a point in 
the center of the door. Then you can use the automatic dimensioning feature to 
find and dimension to this center point. See “Drawing Linear Dimensions” in the 
“Dimensions” chapter. 

The DrwMarks option in the DoorSwng menu is another helpful, visual drawing 
aid. With DrwMarks toggled on, DataCAD draws small crosses on the screen 
where you’ve selected points in the Drawing Area. These marks are a temporary 
visual reference only; they disappear when you press (Esc) to refresh the screen. 
They don’t plot, and you can’t object snap to them. 

This DrwMarks option is independent of DrwMarks in the Utility/Settings menu 
and affects only doors and windows. See “Setting Display Options” in the 
“Before You Draw” chapter for more information on the Settings menu’s 
DrwMarks option. 

The DoorSwng menu also has options to set the door thickness and head height. 
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 To set the door thickness: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on DoorSwng in the Architct menu. The DoorSwng menu is 
displayed. 

3. Click on Thicknss in the DoorSwng menu. A value menu is displayed in 
the Menu Window. 

4. Use the value menu to enter a door thickness, or type a thickness value 
and press (Enter). See “Value Menus” in “The Drawing Board” chapter for 
more information on how to use them. 

 To set the door head height: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on DoorSwng in the Architct menu. The DoorSwng menu is 
displayed. 

3. Click on HeadHgt in the DoorSwng menu. A value menu is displayed in 
the Menu Window. 

4. Use the value menu to enter a door thickness, or type a height value and 
press (Enter). 

Removing a Door 
You can quickly remove any door from your drawing and automatically weld 
the wall with the Remove option in the DoorSwng menu. Keep in mind, 
however, that Remove only erases the door if Cutout was toggled on in the 
DoorSwng menu when the door was drawn. If you didn’t use Cutout when you 
drew the door, use Erase to erase the door as a group. You will then need to use 
WeldWall in the Edit/Cleanup menu to weld the wall.  See “Erasing Entities” 
and “Welding Lines or Walls” in the “Editing Drawings” chapter. 

 To remove a door from your drawing: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on DoorSwng in the Architct menu. The DoorSwng menu is 
displayed. 

3. Click on Remove in the DoorSwng menu. You are prompted to “Select 
first point of box around door or window to remove.” 

4. Click above and to the left of the door to be removed. 

5. Move your mouse diagonally, completely enclosing all elements of the 
door, and click. DataCAD removes the door. You can stretch the box 
around multiple doors to remove them all at once. 
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Drawing Windows 
The Windows option draws windows with cased openings in walls, either by 
selecting the sides of the window or by selecting the center and strike side of the 
window. You can customize the detail of the windows by changing basic 
window components, including jamb size, sill projection, glass thickness, sill 
height, and head height.  

 To draw a window: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Windows in the Architct menu. The Windows menu is displayed 
in the Menu Window. 

3. Set the window jamb, exterior and interior sill projections, thickness of 
glass, and sill height and head height as necessary. See the following 
pages for more information on setting window options. 

4. Toggle Sides on to draw windows by selecting the window sides (jambs); 
toggle Sides off to draw windows by selecting their center point and one 
side. If Sides is toggled on, you are prompted to “Select one jamb of 
window.” If Sides is toggled off, you are prompted to “Select center of 
window.”  

5. Click on a wall to enter one side of the window jamb or the center of the 
window. You are prompted to “Select second jamb of window” or “Select 
one jamb of window”, depending on the status of the Sides toggle. 

If LyrSrch is not toggled on or you have not selected the layer your walls 
are on, you may encounter the error message “No walls found to cut. 
Please check search layer”. Toggle LyrSrch on (if it’s already on, toggle it 
off and then on again) to display the layers in your drawing. Choose the 
layer your walls are drawn on from the list in the Menu Window. 

6. Click on the wall to enter the side of the window jamb. You are prompted 
to “Select any point on the outside of the wall.” 

7. Click outside the wall. The window is drawn. 

 
Figure 8.4: Drawing a window with Sides toggled on 
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More About Window Jambs 
Some of the Windows menu’s options affect how the window is drawn in the 
wall. The DrawJamb option draws window jambs for each wall opening, while 
InWall precisely centers window openings between the two wall faces, and 
Cutout removes the wall segment between the two jambs. Click on DrawJamb, 
InWall, or Cutout to toggle the option on. An added benefit to drawing windows 
with Cutout toggled on is that the walls will automatically weld themselves if 
you use Remove to erase the window. You may need to use LyrSrch with this if 
you’re drawing windows on a different layer than your walls are on; click on 
LyrSrch and then click on the layer your walls are on. 

JambIn is a toggle that determines whether the window will be drawn by rough 
opening or finished opening. Rough opening means that the window jamb is 
drawn inside the opening specified; finished opening refers to the window jamb 
being drawn outside the opening specified. By default, JambIn is toggled off, 
meaning the window will be drawn by finished opening. When JambIn is 
toggled on, DataCAD draws the window by rough opening. 

To explain further, when using Sides to draw a window with JambIn off, the two 
points you select mark the inside of the finished opening, and the jamb will be 
drawn outside the two points specified. If you toggle JambIn on and draw 
another window, the two points you select mark the rough opening in the wall; 
the jamb is drawn inside the two points. 

MtchWall is toggled on by default, causing the jamb depth of the window to 
automatically match the wall width. When this option is toggled off, you can use 
JambDpth to set the jamb depth independently of the wall width. JambDpth is 
only available from the menu when MtchWall is toggled off. 

You can also change the jamb width for your windows. 

 To set a new jamb width: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Windows in the Architct menu. The Windows menu is displayed 
in the Menu Window. 

3. Click on JambWdth in the Windows menu. 

4. Use the value menu to enter a jamb width, or type a jamb width value 
and press (Enter). 

More About Sill and Glass Settings 
Other Windows options you’ll want to set include distances for the exterior and 
interior sill projections, the thickness of the glass, and the sill height and head 
height.  

 To change the distance of the exterior sill projection: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Windows in the Architct menu. The Windows menu is displayed 
in the Menu Window. 
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3. Click on OutSill in the Windows menu. A value menu is displayed in the 
Menu Window. 

4. Use the value menu to enter a new exterior sill projection, or type a sill 
projection value and press (Enter). 

 To change the distance of the interior sill projection: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Windows in the Architct menu. The Windows menu is displayed 
in the Menu Window. 

3. Click on InSill in the Windows menu. A value menu is displayed in the 
Menu Window. 

4. Use the value menu to enter a new interior sill projection, or type a sill 
projection value and press (Enter). 

 To change the thickness of the glass: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Windows in the Architct menu. The Windows menu is displayed 
in the Menu Window. 

3. Click on GlassThk in the Windows menu. A value menu is displayed in 
the Menu Window. 

4. Use the value menu to enter a new thickness, or type a new value and 
press (Enter). If you enter a thickness of 0”, DataCAD draws a single sheet 
of glass. 

 To enter a new window sill height relative to the current Z-base elevation: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Windows in the Architct menu. The Windows menu is displayed 
in the Menu Window. 

3. Click on SillHgt in the Windows menu. A value menu is displayed in the 
Menu Window. 

4. Use the value menu to enter a new exterior sill projection, or type a new 
height value and press (Enter). 

 To enter a new window head height relative to the current Z-base elevation: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Windows in the Architct menu. The Windows menu is displayed 
in the Menu Window. 

3. Click on HeadHgt in the Windows menu. A value menu is displayed in 
the Menu Window. 

4. Use the value menu to enter a new exterior sill projection,  or type a new 
height value and press (Enter). 
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More About Other Window Settings 
Regardless of which way you draw a window, you can use CntrPnt to add a 
point in the center of the window. You can use DataCAD’s automatic 
dimensioning feature to find and dimension to this center point. 

The DrwMarks option in the Windows menu is another helpful, visual drawing 
aid. With DrwMarks toggled on, DataCAD draws small crosses on the screen 
when you select points in the Drawing Area. This DrwMarks option is 
independent of DrwMarks in the Utility/Settings menu and affects only doors 
and windows. These marks are a temporary visual reference only; they 
disappear when you press (Esc) to refresh the screen. They don’t plot, and you 
can’t object snap to them. 

Removing a Window 
You can quickly remove any window from your drawing and automatically 
weld the wall with the Remove option in the Windows menu. Keep in mind, 
however, that Remove only erases the window if Cutout was toggled on in the 
Windows menu when the window was drawn. If you didn’t use Cutout when 
you drew the window, use Erase to erase the window as a group. You will then 
need to use WeldWall in the Edit/Cleanup menu to weld the wall. 

 To remove a window from your drawing: 

1. Go to the Edit menu in the Menu Window and click on Architct. 

2. Click on Windows in the Architct menu. The Windows menu is displayed 
in the Menu Window. 

3. Click on Remove in the Windows menu. You are prompted to “Select first 
point of box around door or window to remove.” 

4. Click above and to the left of the window to be removed. 

5. Move your mouse diagonally, completely enclosing all elements of the 
window, and click. DataCAD removes the window. You can stretch the 
box around multiple windows to remove them all at once. 

Drawing Linear Bays of Windows 
With the Windows menu in the DCAD_AEC macro, you can draw 2D linear bays 
of windows. Click OneWindw in the Windows menu in the DCAD_AEC macro 
to access the Window menu in the Edit/Architct menu. 

 To draw a linear bay of windows: 

1. Click DCAD_AEC in the Macros pull-down menu. If DCAD_AEC is not 
listed in your Macros menu, click Configure in the Macros menu and add 
DCAD_AEC to the Macros in Menu list. 

2. Click Windows in the DCAD_AEC menu. The Windows menu is 
displayed. To model 3D windows, use the Windows menu in the 
AEC_Modl macro. 
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3. Click HeadHght in the Windows menu. A value menu is displayed, and 
you are prompted to “Enter new window header height” in the Message 
Area. 

4. Type a new header height or use the value menu to enter a new height. 

5. Press (Enter) or right-click to accept the new value and exit the menu. The 
Windows menu is displayed again. 

6. Click SillHght in the Windows menu. A value menu is displayed, and 
you are prompted to “Enter new window sill height” in the Message 
Area. 

7. Type a new sill height or use the value menu to enter a new height. 

8. Press (Enter) or right-click to accept the new value and exit the menu. The 
Windows menu is displayed again. 

9. Click LinrWndw in the Windows menu to display the linear windows 
menu. 

10. Decide if you want to draw a set quantity of equally spaced bays, as 
many bays of a set size that can be fit into a space, or a set number and 
size of bays. In the Linear menu, click Eq Bays to draw equally spaced 
bays, click FitBays to fit bays into a space, or click SetBays to specify the 
number and size of the bays. When using the SetBays option, the opening 
length is determined by the number and size of the bays, as you specify. 

11. Set bay and window options as necessary. See “Linear Window Bay 
Options” on the following pages for more information. You are prompted 
to “Enter starting point of window wall”. 

12. Use the mouse or coordinate entry to select a starting point for your bay 
of windows. You are prompted to “Enter ending point of window wall”. 
For more information on using coordinate entry, see “Drawing Using 
Coordinate Entry” in “The Drawing Board” chapter. 

13. Use the mouse or coordinate entry to select an ending point for your bay 
of windows. You are prompted to “Enter a point on the outside of the 
wall”. 

14. Click anywhere outside the wall. The bays of windows are drawn. 

Linear Window Bay Options 
Bay Qty Set the number of window bays you want drawn; not available when using FitBays 

because bay quantity is automatically calculated 
Bay Size Set the width of each window bay, which will be multiplied to create the window 

wall; not available when using Eq Bays because individual bay size is automatically 
calculated 

WallWdth Set the width of the wall, which in turn determines the depth of the sills; not available 
when Cutout is toggled on because the wall width, and therefore the sill depth, is 
calculated automatically 

Cutout Toggle on to automatically calculate the wall width and cut an opening; of the three 
options Cutout, CntrLin, and InnrEdg, only one can be toggled on at any given time. 
When you use Cutout, the window wall opening will be cut from Z-base to Z-height 
(from the bottom of the wall to the top), just as it is with the Cutout option in the 
Architct menu. 
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CntrLin Toggle on to center the depth of the wall along the starting and ending points you 

enter; of the three options Cutout, CntrLin, and InnrEdg, only one can be toggled on 
at any given time 

InnrEdg Toggle on to draw the inside face of the wall along the starting and ending points you 
enter; of the three options Cutout, CntrLin, and InnrEdg, only one can be toggled on 
at any given time 

By Ends Toggle on to draw a window wall by selecting the starting and ending points of the 
wall; of the two options By Ends and By Cent, only one can be toggled on at any 
given time 

By Cent Toggle on to draw a window wall by selecting the starting point and the center point 
of the wall; of the two options By Ends and By Cent, only one can be toggled on at 
any given time 

Mullions The width, depth, and offset for window mullions are set using value menus. For 
more information on value menus, see “Value Menus” in “The Drawing Board” 
chapter. Customize the dimensions and position of window mullions; following are 
the Mullions menu options: 
DoMulln Models mullions; toggle this option off to draw windows without 

mullions 
Width Sets the width of mullions; the width is the mullion dimension along the 

face of the wall 
Depth Sets the depth of mullions; the depth is the mullion dimension through 

the wall 
Offset Sets the distance from the inner edge of the wall to the inner edge of the 

mullion 
DoMarks Toggle on to display a snapping point to the center of each mullion 
No Ends Toggle on to draw windows without mullions at either end of the 

window wall; of the three options No Ends, HalfEnd, and FullEnd, only 
one can be toggled on at any given time 

HalfEnd Toggle on to draw mullions of half-width on either end of the window 
wall; of the three options No Ends, HalfEnd, and FullEnd, only one can 
be toggled on at any given time 

FullEnd Toggle on to draw mullions of full-width on either end of the window 
wall; of the three options No Ends, HalfEnd, and FullEnd, only one can 
be toggled on at any given time 

Color Sets the color of mullion lines. For more information on using color 
menus, see “Color Menus” in “The Drawing Board” chapter. 

Linetype Sets the linetype of mullion lines 
LineWdth Sets the line width of mullion lines; make mullion lines wider by 

increasing this value 
LinSpcng Sets the line spacing of window mullion lines, The LinSpcng setting 

lengthens both the lines and the spaces in a linetype, so that the aspect 
ratio of the linetype is preserved. 

Glass Customize the dimensions and position of window glass; following are the Glass 
menu options: 
DoGlass Models glass; toggle this option off to draw windows without glass 
Thicknss Sets the thickness, or distance between the panes, of the glass; this 

setting has no effect when 1-Line is toggled on. The thickness and offset 
for window glass are set using value menus. For more information on 
value menus, see “Value Menus” in “The Drawing Board” chapter. 

Offset Sets the distance between the inner edge of the wall and the inside face 
of the glass pane 

1-Line Toggle on to model glass as a single line between mullions; of the three 
options 1-Line, 2-Line, and 3-Line, only one can be toggled on at a time 

2-Line Toggle on to model glass as a double line between mullions; of the three 
options 1-Line, 2-Line, and 3-Line, only one can be toggled on at a time 

3-Line Toggle on to model glass as a triple line between mullions; of the three 
options 1-Line, 2-Line, and 3-Line, only one can be toggled on at a time 

Color Sets the color of glass lines. For more information on using color menus, 
see “Color Menus” in “The Drawing Board” chapter. 

Linetype Sets the linetype of glass lines 
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LineWdth Sets the line width of glass lines; make glass lines wider by increasing 

this value 
LinSpcng Sets the line spacing of window glass lines. The LinSpcng setting 

lengthens both the lines and the spaces in a linetype, so that the aspect 
ratio of the linetype is preserved. 

Sills Customize the dimensions and position of inner and outer window sills. The inside 
and outside sills, header depth, and sill depth for window sills are set using value 
menus. For more information on value menus, see “Value Menus” in “The Drawing 
Board” chapter. Following are the Sills menu options: 
DoSill Models sills and headers; toggle this option off to draw windows 

without sills and headers 
Insill Sets the distance from the inner edge of the window wall to the edge of 

the inner sill 
Outsill Sets the distance from the outer edge of the window wall to the edge of 

the outer sill 
HeadDpth Sets the depth of the window header 
SillDpth Sets the depth of the window sill 
Color Sets the color of sill lines. For more information on using color menus, 

see “Color Menus” in “The Drawing Board” chapter. 
Linetype Sets the linetype of sill lines 
LineWdth Sets the line width of sill lines; make sill lines wider by increasing this 

value 
LinSpcng Sets the line spacing of window sill lines 

Drawing Curved Bays of Windows 
With the Windows menu in the DCAD_AEC macro, you can draw 2D curved 
bays of windows. Click OneWindw in the Windows menu in the DCAD_AEC 
macro to access the Window menu in the Edit/ Architct menu. 

 To draw a curved bay of windows: 

1. Click DCAD_AEC in the Macros pull-down menu. If DCAD_AEC is not 
listed in your Macros menu, click Configure in the Macros menu and add 
DCAD_AEC to the Macros in Menu list. 

2. Click Windows in the DCAD_AEC menu. The Windows menu is 
displayed. To model 3D windows, use the Windows menu in the 
AEC_Modl macro 

3. Click HeadHght in the Windows menu. A value menu is displayed, and 
you are prompted to “Enter new window header height” in the Message 
Area. 

4. Type a new header height or use the value menu to enter a new height. 

5. Press (Enter) or right-click to accept the new value and exit the menu. The 
Windows menu is displayed again. 

6. Click SillHght in the Windows menu. A value menu is displayed, and 
you are prompted to “Enter new window sill height” in the Message 
Area. 

7. Type a new sill height or use the value menu to enter a new height. 

8. Press (Enter) or right-click to accept the new value and exit the menu. The 
Windows menu is displayed again. 
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9. Click CircWndw in the Windows menu to display the Circular windows 
menu. 

10. Decide if you want to draw a set quantity of equally spaced bays, as 
many bays of a set size that can be fit into a space, or a set number and 
size of bays. You can draw a set quantity of equally spaced bays, as many 
bays of a set size that can be fit into a space, or a set number and size of 
bays. In the Circular menu, click Eq Bays to draw equally spaced bays, 
click FitBays to fit bays into a space, or click SetBays to specify the 
number and size of the bays. When using the SetBays option, the opening 
length is determined by the number and size of the bays that you specify. 

11. Set bay and window options as necessary. See “Curved Window Bay 
Options” below for more information. You are prompted to “Enter center 
point of window wall arc”. 

12. Use the mouse or coordinate entry to select a center point for the arc of 
your bay of windows. You are prompted to “Enter starting point of 
window wall arc”. 

13. Use the mouse or coordinate entry to select a starting point for the arc of 
your bay of windows. You are prompted to “Enter ending point of 
window wall”. For more information on using coordinate entry, see 
“Drawing Using Coordinate Entry” in “The Drawing Board” chapter. 

14. Use the mouse or coordinate entry to select an ending point for the arc of 
your bay of windows. The bay of windows is drawn. 

Curved Window Bay Options 
Bay Qty Set the number of window bays you want drawn; not available when using FitBays 

because bay quantity is automatically calculated 
BayAngle Set the separation angle between individual window bays, which will be multiplied 

to create the total curvature of the window wall; not available when using Eq Bays 
because individual bay angle is automatically calculated 

WallWdth Set the width of the wall, which in turn determines the depth of the sills 
CntrLin Toggle on to center the depth of the wall along the starting and ending points you 

enter; of the two options CntrLin and InnrEdg, only one can be toggled on at a time 
InnrEdg Toggle on to draw the inside face of the window wall along the starting and ending 

points you enter; of the two options CntrLin and InnrEdg, only one can be toggled on 
at a time 

Clckwse Toggle on to model windows in a clockwise direction; toggle off to model windows 
in a counterclockwise direction 

Averagd Available only when FitBays is toggled on; toggle on to slightly increase or decrease 
the separation angle of each bay to fit the number of bays you specified precisely into 
the defined opening, leaving no extra space at one end of the window wall; if 
Averagd is toggled off, any leftover space at either end of the curved window wall is 
filled with bays of a smaller width. Increasing or decreasing the separation angle of 
each bay will increase or decrease, respectively, the width of each bay. 

Mullions Customize the dimensions and position of window mullions. The width, depth, and 
offset for window mullions are set using value menus. For more information on value 
menus, see “Value Menus” in “The Drawing Board” chapter. Following are the 
Mullions menu options: 
DoMulln Models mullions; toggle this option off to draw windows without 

mullions 
Width Sets the width of mullions; the width is the mullion dimension along the 

face of the wall 
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Depth Sets the depth of mullions; the depth is the mullion dimension through 

the wall 
Offset Sets the distance from the inner edge of the wall to the inner edge of the 

mullion 
DoMarks Toggle on to display a snapping point to the center of each mullion 
No Ends Toggle on to draw windows without mullions at either end of the 

window wall; of the three options No Ends, HalfEnd, and FullEnd, only 
one can be toggled on at any given time 

HalfEnd Toggle on to draw mullions of half-width on either end of the window 
wall; of the three options No Ends, HalfEnd, and FullEnd, only one can 
be toggled on at any given time 

FullEnd Toggle on to draw mullions of full-width on either end of the window 
wall; of the three options No Ends, HalfEnd, and FullEnd, only one can 
be toggled on at any given time 

Color Sets the color of mullion lines. For more information on using color 
menus, see “Color Menus” in “The Drawing Board” chapter. 

Linetype Sets the linetype of mullion lines 
LineWdth Sets the line width of mullion lines; make mullion lines wider by 

increasing this value 
LinSpcng Sets the line spacing of window mullion lines. The LinSpcng setting 

lengthens both the lines and the spaces in a linetype, so that the aspect 
ratio of the linetype is preserved. 

Glass Customize the dimensions and position of window glass; following are the Glass 
menu options: 
DoGlass Models glass; toggle this option off to draw windows without glass 
Thicknss Sets the thickness, or distance between the panes, of the glass; this 

setting has no effect when 1-Line is toggled on. The thickness and offset 
for window glass are set using value menus. For more information on 
value menus, see “Value Menus” in “The Drawing Board” chapter. 

Offset Sets the distance between the inner edge of the wall and the inside face 
of the glass 

1-Line Toggle on to model glass as a single line between mullions; of the three 
options 1-Line, 2-Line, and 3-Line, only one can be toggled on at a time 

2-Line Toggle on to model glass as a double line between mullions; of the three 
options 1-Line, 2-Line, and 3-Line, only one can be toggled on at a time 

3-Line Toggle on to model glass as a triple line between mullions; of the three 
options 1-Line, 2-Line, and 3-Line, only one can be toggled on at a time 

Color Sets the color of glass lines. For more information on using color menus, 
see “Color Menus” in “The Drawing Board” chapter. 

Linetype Sets the linetype of glass lines 
LineWdth Sets the line width of glass lines; make glass lines wider by increasing 

this value 
LinSpcng Sets the line spacing of window glass lines 

Sills Customize the dimensions and position of inner and outer window sills. The inside 
and outside sills, header depth, and sill depth for window sills are set using value 
menus. For more information on value menus, see “Value Menus” in “The Drawing 
Board” chapter. Following are the Sills menu options: 
DoSill Models sills and headers; toggle this option off to draw windows 

without sills and headers 
Insill Sets the distance from the inner edge of the window wall to the edge of 

the inner sill 
Outsill Sets the distance from the outer edge of the window wall to the edge of 

the outer sill 
HeadDpth Sets the depth of the window header 
SillDpth Sets the depth of the window sill 
Color Sets the color of sill lines. For more information on using color menus, 

see “Color Menus” in “The Drawing Board” chapter. 
Linetype Sets the linetype of sill lines 
LineWdth Sets the line width of sill lines; make sill lines wider by increasing this 

value 
LinSpcng Sets the line spacing of window sill lines 
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