
Tutorial: Drawing a 
Schoolhouse 

In this chapter, you’ll learn how to customize both DataCAD 
and your drawing before you ever draw a line. Then you’ll 
draw the exterior and interior walls of the schoolhouse and add 
doors and windows to it. 

3 
In this chapter: 

� Drawing walls 
� Drawing windows 
� Drawing doors 
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Setting Up a New Drawing 
DataCAD contains many options for customizing the way your system operates. 
In this tutorial, you will make only two modifications: adding layers to a new 
drawing and changing the snap grid setting.  

To begin this tutorial, start DataCAD and start a new drawing, as described in 
“The Drawing Board” chapter. 

Setting the Snap Grid for the Tutorial 
First, you’ll need to change the snap grid setting. 

Î To set the snap grid: 

1. Press (S) on your keyboard. Make sure Caps Lock is off. In the Message 
Area, you are prompted to “Enter X-snap grid.” 

2. Type .1 and press (Enter). You are prompted to “Enter Y-snap grid.” 

3. Type .1 and press (Enter). 

You just set the accuracy of the cursor movement to one inch. Move your cursor 
around the drawing screen and look at the X and Y snap grid values in the 
Message Area. 

Creating New Layers for the Tutorial 
When you start a new drawing in DataCAD, it contains only one layer (called 
Layer1), which is also the active layer. Any settings in the active layer will 
automatically be used in new layers when you create them. For example, the 
snap grid setting you entered above will be assigned to each layer you add to 
your drawing; so you won’t have to set the snap grid in every new layer. 

Î To add layers to this drawing: 

1. Right-click to return to the Utility menu from the previous exercise. 

2. Click on Layers in the Utility menu. 

3. Click on NewLayer in the Layers menu. 

4. Type 8 and press (Enter). You’ve just added eight layers to the drawing 
for a total of nine layers. 

Naming Layers for the Tutorial 
You’ll be given the layer names for this exercise, but you should develop your 
own plan for naming layers based on the type of work you do. To verify which 
menu is displayed in the Menu Window, check the Message Area. See Figure 3.1 
to locate the menu name display. 

Î To rename your layers: 

1. If you aren’t in the Layers menu, click on Layers in the Utility menu. 
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2. Click on Name in the Layers menu. A list of all your layers is displayed in 
the Menu Window. 

3. Click on Layer1. You are prompted to “Enter new name.” 

4. Type Walls and press (Enter). Look at the list of layers in the Menu 
Window; notice that Layer1 has been changed to Walls. 

5. Click on Layer2. You are prompted to “Enter new name.” 

6. Type Doors and press (Enter). Notice that Layer2 is now named Doors in 
the layer list in the Menu Window. 

7. Rename the rest of your layers as follows:Layer3 to Windows, Layer4 to 
Plumb, Layer5 to Dim, Layer6 to Hatch, Layer7 to Notes, Layer8 to Misc, 
and Layer9 to Border. 

8. Right-click twice to return to the Utility menu. 
Coordinate display
System and error messages

User prompts and data entry
Menu name  

Figure 3.1: The Message Area display 

Moving Between Layers in the Tutorial 
Now that you’ve created and named your new layers, you can move among 
them. To draw walls on the Walls layer and doors on the Doors layer, you have 
to change to the corresponding layer before you begin drawing. In DataCAD 
terms, before you place a wall on your drawing you will make the Walls layer 
the active layer. 

The Status Area shows the active layer, or the layer that you are drawing on. As 
you change active layers, the Status Area is updated with the corresponding 
layer name. You can only draw on the active layer. 

Displays the name of 
the active layer entities 
will be drawn on. Press 
(Tab) to change the 
active layer. 

Displays the 
active layer’s 
color. Press (K) 
to change the 
current color. 

 

Figure 3.2: Check the Status Area for active layer name and color. 

Î To change the active layer: 

1. Press (Tab) on your keyboard. Notice that the active layer name in the 
Status Area changes. 
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2. Keep pressing (Tab). Eventually you’ll return to the beginning of the layer 
list. Pressing (Shift) + (Tab) cycles backwards through your layers. 

Assigning Colors to Layers in the Tutorial 
You can assign different colors to layers, so that any entities you add to a layer 
will be drawn in that layer’s color. You’ll be able to tell at a glance what layer an 
entity is on simply by its color. That color is the active color for that layer until 
you change it. 

Î To assign layer colors: 

1. If you’re not in the Layers menu, click on Layers in the Utility menu. 

2. Press (Tab) until the Doors layer is the active layer. Check the Status Area 
to see which layer is active. 

3. Click on Color in the Layers menu. 

Shortcut:  Press (K) to change the color of the active layer. Pressing (K) will 
cycle through the colors; pressing (Shift) + (K) cycles backwards through the 
layers. 

4. Click on Green. The color assigned to the Doors layer is now Green, and 
you can see the layer color box in the Status Area is also displaying green. 

5. Press (Tab), so that the Windows layer is active. 

6. Click on Color in the Layers menu. 

7. Click on Cyan. The color assigned to the Windows layer is now Cyan. 

8. Use this same procedure to assign colors to the rest of your layers. Make 
the Plumb layer Lt. Grey, the Dim layer Lt. Grey, the Hatch layer Brown, 
the Notes layer Lt. Red, the Misc layer Red, and the Border layer Lt. 
Green. 

9. Right-click to return to the Utility menu. 

Drawing Walls, Windows, and Doors 
This part of the tutorial introduces you to using DataCAD as an architectural 
tool. You will learn how to use the wall menu options to begin drawing 
architectural plans. This tutorial uses Imperial units. See  “Customizing Drawing 
Settings” in the “Before You Draw” chapter for more information on how to 
change drawing units. 

Drawing the Schoolhouse Walls 
Each wall that you draw will have two or more lines, rather than just one. In the 
following exercises, you will draw walls using both the mouse and the keyboard. 
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Figure 3.3: Examples, from left to right, of 2-line walls, 3-line walls, and 4-line walls 

The Architct menu is used for drawing walls as well as doors and windows. 

choose type of multi-line wall:
2, 3 or 4 lines

Turn walls function on/off. Draws parallel
lines when on, single lines when off.

Set wall thickness (the distance between
the parallel lines).

Automatically cleans T-intersections as you draw walls.

Enters the Door Swing menu to insert doors in walls.
Enters the Window menu to insert windows in walls.

Exits the Architect menu.You can also click the right
mouse button to exit.

Menu Title

 
Figure 3.4: The Architct menu is used for drawing walls, windows, and doors. 

Drawing the Schoolhouse’s Exterior Walls 
Before you draw the exterior walls of the schoolhouse, you should make sure 
your wall settings are correct. 

Î To set up for drawing exterior walls: 

1. Continue with the drawing you started in the previous section of this 
tutorial. 

2. In the Edit menu in the Menu Window, click on Architct. The Architct 
menu is displayed. 

3. Click on Walls in the Architct menu to toggle it on; walls will be drawn 
instead of single lines. Notice that the “w” in SWOTHLUD in the Status 
Area is now uppercase. This indicates that you will draw walls instead of 
single lines. 

4. Click on 2LnWalls in the Architct menu, if it’s not already toggled on. 
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5. Click on Width in the Architct menu to set the width of the wall. A value 
menu is displayed in the Menu Window, and you are prompted to “Enter 
wall width.” For more information on using value menus, see “Value 
Menus” in “The Drawing Board” chapter. 

6. Click 1’-0” in the value menu and then right-click; or type 1 and press 
(Enter). 

7. Click Outside in the Architct menu; any walls you draw will be defined 
by the outside line of the wall. 

8. Right-click to return to the Edit menu. 

9. Before you begin drawing the exterior walls, look at the Status Area to see 
that Walls is your active layer. If it’s not, press (Tab) until it is. 

Active layer name.

Each letter deignates a drawing setting
and indicates if it is active. The capital
"W" shows that the Wall option is on.

 
Figure 3.5: You can check both the active layer and the status of the Walls toggle 
in the Status Area. 

Now you are ready to draw the exterior walls. 

Î To draw exterior walls: 

1. You’ll draw the first wall using the mouse. Notice that the prompt in the 
Message Area reads “Select first end point of new line/wall.” Move the 
cursor to the lower left of the Drawing Area and click to enter the first 
end point of the new wall. You are prompted to “Select next end point of 
line/wall.” 

2. Move the cursor to the right until the coordinate readout shows an X 
measurement of 28’-0” and a Y measurement of 0, and click. This defines 
the exterior line of the wall. You are prompted to “Select a point to define 
the inside of the wall.” 

3. Move the cursor to a position anywhere above the displayed line and 
click. The wall is immediately drawn. You are prompted to “Select next 
end point of line/wall.” 

 
Figure 3.6: Drawing the first wall 
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Leave the cursor
connected to the wall
line.

 
Figure 3.7: The wall is drawn. 

4. Now you’ll draw a second wall using coordinate entry. Press (Insert) until 
the Message Area reads “Current input mode = relative polar (distance, 
angle).” You can also use coordinate entry to enter points. See “Drawing 
Using Coordinate Entry” in “The Drawing Board” chapter to review 
coordinate entry methods. 

5. Press (Spacebar) to activate coordinate entry. You are prompted to “Enter 
relative distance.” 

6. Type 40.6 and press (Enter). (40.6 means 40 feet 6 inches in architectural 
units.) You are prompted to “Enter relative angle.” 

7. Type 90 and press (Enter). The wall is drawn and the corner is 
automatically cleaned. If the new wall extends beyond your view of the 
Drawing Area, use the arrow keys to move your drawing into view. 

The cursor is connected to the outside
corner.

The corners automatically clean up as
you draw.

 
Figure 3.8: The second wall is drawn and the corner is cleaned. 

8. Click W on the Navigation Pad to go to the WindowIn menu. The 
WindowIn menu is displayed in the Menu Window. 

9. Click on FreeZoom in the WindowIn menu to toggle it off. 

10. Click on Extents in the WindowIn menu to zoom out to the extents of the 
drawing. 

11. Right-click to return to the Edit menu. 

12. Press (Spacebar). You are prompted to “Enter relative distance.” 

13. Type 28 and press (Enter). You are prompted to “Enter relative angle.” 

14. Type 180 and press (Enter). 

15. Move the cursor close to the inside line of the corner where you originally 
began and click. The last corner is cleaned, leaving a clean outline of the 
schoolhouse exterior walls. 
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Bring cursor close to the inside wall line.

 
Figure 3.9: Ending your exterior wall 

The final corner is automatically cleaned up.

 
Figure 3.10: The exterior walls are complete. 

Drawing the Schoolhouse’s Interior Walls 
Now you will draw the interior walls. You’ll change the wall thickness for the 
interior walls to four inches. 

Î To set up for drawing the interior walls: 

1. In the Edit menu in the Menu Window, click on Architct. The Architct 
menu is displayed. 

Shortcut: Press (A) to access the Architct menu at any time. 

2. Click on Width in the Architct menu. You are prompted to “Enter wall 
width.” 

3. Type .4 and press (Enter). 

4. Click on Inside in the Architct menu to define the wall by the inside line. 

5. Click on Clean to toggle on automatic T intersection cleaning. Walls and 
2LnWalls should still be toggled on. 

6. Right-click once to return to the Edit menu. 
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Î To draw interior walls: 

1. Click W on the Navigation Pad to open the WindowIn menu. You are 
prompted to “Select first corner of the Zoom window.” 

2. Position your cursor outside the lower-left corner of the plan and click. 
You are prompted to “Select second corner of the Zoom window.” 

3. Move the mouse diagonally, stretching the rubberband box until it 
encloses the lower half of the plan as in the figure below and click. Your 
drawing now appears larger. 

2
Click the left mouse button to start the
rubberband box.

3
Click the left mouse button to close the
rubberband box.

 
Figure 3.11: Zooming in on the lower half of the plan. 

4. Right-click to return to the Edit menu. 

5. Press (`) on the keyboard to set X and Y to 0. You are prompted to “Select 
reference point.” The accent key ( (`) ) is located in the upper-left corner of 
your keyboard, just below (Esc) and to the left of (1) on most keyboards. 

6. Move the cursor close to the inside left corner of the bottom wall and 
either click the middle mouse button or press (N) on the keyboard. This 
sets this corner as the new reference point to work from. Steps 6-9 are the 
equivalent of placing one end of an architect’s scale at a corner and 
marking a point at 10’-2”. 

6
New reference point

 
Figure 3.12: Setting a reference point 

7. Press (Spacebar). You are prompted to “Enter relative distance.” 

8. Type 10.2 (the inside dimension of the office) and press (Enter). You are 
prompted to “Enter relative angle.” 

9. Type 0 for the relative angle and press (Enter). Notice that your cursor is 
now attached to the wall exactly 10’-2” to the right of the corner you used 
as your reference point. This will be the first point of the interior wall. 
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Cursor still attached to a point.

Referenced corner

 
Figure 3.13: Starting your interior wall 

10. Press (Spacebar). You are prompted to “Enter relative distance.” 

11. Type 10.8 (the inside dimension of the office) and press (Enter). You are 
prompted to “Enter relative angle.” 

12. Type 90 and press (Enter). You are prompted to “Select a point to define 
the Outside of the wall.” 

13. Move the cursor to the right of the displayed line and click to indicate the 
outside of the wall. 

You remain connected to the wall.

13
Click the left mouse button.

 
Figure 3.14: Defining the outside of the wall 

14. Move the cursor close to the inside line of the left exterior wall and click.  

14
Click the left mouse button close to the inside line
of the exterior wall.

 
Figure 3.15: Drawing the last office wall 

15. Right-click to disconnect from the line. The office area is complete and all 
intersections are automatically cleaned. 

Î To draw the remaining interior walls: 

1. Press (`) on the keyboard. You are prompted to “Select reference point.” 

2. Move the cursor close to the inside right corner of the bottom wall and 
click the middle mouse button. Remember, if you don’t have a three-
button mouse you can also press (N) on the keyboard. 
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2    

New reference point

 
Figure 3.16: Selecting a new reference point 

3. Press (Spacebar). You are prompted to “Enter relative distance.” 

4. Type 10.2 and press (Enter). You are prompted to “Enter relative angle.” 

5. Type 180 and press (Enter). The cursor connects to a point on the inside 
line of the exterior wall. 

6. Press (Spacebar). You are prompted to “Enter relative distance.” 

7. Type 10.8 and press (Enter). You are prompted to “Enter relative angle.” 

8. Type 90 and press (Enter). You are prompted to “Select a point to define 
the outside of the wall.” 

9. Move the cursor to the left of the new wall and click to define the outside 
of the wall. 

10. Move the cursor to the right just before the inside line of the exterior wall 
and click. 

11. Right-click to disconnect from the wall line. The wall is drawn and your 
intersections are cleaned. 

T intersection cleaned up automatically

 
Figure 3.17: The wall is drawn and the intersections are cleaned. 

12. Press (`). You are prompted to “Select reference point.” 

13. Move the cursor near the inside corner of the wall you just drew and click 
the middle mouse button. 

13
New reference point

 
Figure 3.18: Selecting a new reference point 

14. Press (Spacebar). You are prompted to “Enter relative distance.” 

15. Type 5.2 and press (Enter). You are prompted to “Enter relative angle.” 

16. Type 270 and press (Enter). The cursor connects to a point on the inside 
line of the exterior wall. 
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17. Move the cursor to the left, close to the inside line of the wall, and click. 
You are prompted to “Select a point to define the Outside of the wall.” It 
is important in step 17 to select a point closer to the inside, not the 
outside, line of the room you just drew so that the correct wall line will be 
cleaned. 

18. Move the cursor below the displayed line and click to define the outside 
of the wall. 

18
Click mouse here to define outside
of wall.

17
Click mouse closer to the
inside line of the room just
drawn.

 
Figure 3.19: Drawing the dividing wall between the bathrooms 

19. Right-click to disconnect from the wall. 

20. Click on E on the Navigation Pad to view the drawing extents. 

 
Figure 3.20: The walls of the schoolhouse floor plan 

21. Press (Ctrl) + (S) on the keyboard to save the drawing. This is a good habit 
to get into. You should do it after you enter several items or make a lot of 
changes to your drawing. 

You have now completed all the walls of the schoolhouse plan and saved your 
drawing. If any of the walls did not clean, and your drawing doesn’t look like the 
figure above, the next section will help you straighten up your plan. 
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Cleaning the Schoolhouse’s Wall Intersections 
As you insert walls, DataCAD automatically cleans intersections. If you right-
click by accident and disconnect from a wall prematurely, or your intersections 
clean at the wrong wall line, you will need to clean them. 

1
If you disconnected from a wall and
reattached to continue the remaining
walls, the corner you reattach to will not
clean.

3
If you were too close to the outside line of
this wall when drawing the dividing wall,
the wrong line will clean.

2
If you become disconnected from a wall,
when you attempt to complete the last
intersection, the “L” intersection will not
clean up properly.

 
Figure 3.21: Examples of wall intersections that were improperly drawn 

If an L intersection doesn’t clean properly, despite Clean being toggled on when 
you drew the walls, it may be because you disconnected your cursor from the 
end of one wall and then started drawing the next wall. In such a case, you may 
have to use 2LnTrim in the Cleanup menu so the wall lines intersect properly, 
and then use Erase to remove any unwanted lines within the intersection. 

Î To fix the error shown in example 1: 

1. In the Edit menu in the Menu Window, click on Cleanup. 

2. Click on LIntSct in the Cleanup menu. You are prompted to “Select 1st 
corner around L intersection (wall lines only).” 

3. Click above and to the right of the intersection. 

4. Diagonally drag the cursor to the lower left of the intersection, stretching 
the rubberband box, and click. 
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Place a rubberband box
around the corner to

clean.

The corner is
automatically

cleaned.

 
Figure 3.22: Cleaning an L intersection 

Î To fix the error shown in example 2 on the previous page: 

1. In the Edit menu in the Menu Window, click on Cleanup. 

2. Click on LIntSct in the Cleanup menu. You are prompted to “Select 1st 
corner around L intersection (wall lines only).”  

3. Click above and to the right of the intersection. 

4. Diagonally drag the cursor to the lower left of the intersection, stretching 
the rubberband box around the intersection, and click. 

Place a rubberband box
around the corner to
clean.

The corner is
automatically
cleaned.

 
Figure 3.23: Cleaning an L intersection 

Î To fix the error shown in example 3 on the previous page: 

1. In the Edit menu in the Menu Window, click on Cleanup. 

2. Click on 1LnTrim in the Cleanup menu. You are prompted to “Select first 
point of line to clip to.” 

3. Click on Entity in the 1LnTrim menu. You are prompted to “Point to line 
to trim to.” 

4. Click on the inside wall line, shown in Figure 3.24. The line you select 
becomes dashed. You are prompted to “Point to outside.” 

5. Click to the left of the dashed line. You are prompted to “Select entity to 
trim.” 

6. Click on the two wall lines to select them as the lines to trim. The lines are 
trimmed. 
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4
Click the left mouse button
to define this line as the line
to clip to; the line becomes
dashed.

5
Click the left

mouse button to
define the outside.

6
Click the left mouse button to select
these two lines as the lines to trim.  

Figure 3.24: Completing a 1-line trim 

7. Right-click once to return to the Cleanup menu. 

The lines are trimmed to the
correct wall, but there is still a

break in the wall.

 
Figure 3.25: Trimming wall lines to the correct wall 

8. To fix the break in the outside wall, click on WeldLine in the Cleanup 
menu. You are prompted to “Select first line to weld.” 

9. Click on one of the lines of the broken wall to select it; it becomes dashed. 
You are prompted to “Select second line to weld.” 

10. Click on the other line of the broken wall to select it. The line mends and 
becomes a single entity. 

9
Click the left mouse button to
define the first line to weld. It
becomes dashed.

10
Click the left mouse button to
define the second line to weld.
The line is mended.

 
Figure 3.26: Selecting lines to be welded 

11. Right-click once to return to the Cleanup menu. 
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The lines are
trimmed to the

inside wall.

 
Figure 3.27: The wall line is welded. 

12. To clean up the T intersection in the wall, click on TIntsct in the Cleanup 
menu. You are prompted to “Select 1st corner around “T” intersect (wall 
line ends only)”.  

13. Click at the lower left of the intersection you want to clean. You are 
prompted to “Select 2nd corner around “T” intersect (Wall line ends 
only).” 

14. Move the cursor above and to the right of the intersection to enclose the 
corner to clean and click. You are prompted to “Point to a wall line to 
trim to.” 

15. Click on the inside line to select it as the line to trim to. 

16. Right-click twice to return to the Edit menu.  

13-14
Place a rubberband box

around  the corner to clean.

15
Click the left mouse button to
define this line as the line to

trim to.
 

Figure 3.28: Completing a T intersection 

The wall is cleaned and
the T intersection is

complete.

 
Figure 3.29: The wall intersection is cleaned. 
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Drawing Countertops in the Schoolhouse 
While the 3-line walls function is usually used for drawing walls, we’ll use it 
here to quickly draw parallel lines representing countertops.  

Î To set up to draw countertops: 

1. Click on Architct in the Edit menu. 

2. Click on 3LnWalls in the Architct menu to toggle on the 3-line wall 
option. This allows you to draw three parallel lines at once. The two outer 
lines will define the edges of the counter and the centerline will be a 
dashed line to represent the upper cabinets. Walls should still be toggled 
on. 

3. Click on CntrLine in the Architct menu to set the attributes of the 
centerline of the two parallel lines. This will represent the upper cabinets. 

4. Click on LineType in the CntrLine menu. All available linetypes are listed 
in the Menu Window. 

5. Click on Dashed in the LineType menu to make the centerline dashed. 

6. Right-click once to return to the Architct menu. 

7. Click on Width in the Architct menu. You are prompted to “Enter wall 
width.” 

8. Type 2 and press (Enter). This sets the width of the countertop at two feet. 

9. Click on Outside in the Architct menu; the wall will be defined by the 
outside line. 

10. Click on Cap in the Architct menu to automatically cap the end of the 
parallel lines, or in this case countertops. 

11. Right-click to return to the Edit menu.  

 

Now you are ready to draw the countertops. 

Î To draw countertops on the plan: 

1. Click W on the Navigation Pad to open the WindowIn menu. You are 
prompted to “Select first corner of the Zoom window.” 

2. Click near the lower-left corner of the bottom wall. You are prompted to 
“Select second corner of the Zoom window.” 

3. Diagonally move the mouse until the rubberband box encloses the lower 
half of the plan and click. The plan now appears larger. 

4. Right-click once to return to the Edit menu. 

5. Move the cursor to the corner marked 6 in Figure 3.30 and click the 
middle mouse button to select it as your first reference point. 
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6
Click the middle mouse
button to connect to this
point.

 
Figure 3.30: Selecting the starting point of the countertop 

6. Press (Spacebar). You are prompted to “Enter relative distance”. 

7. Type 10.2 and press (Enter). You are prompted to “Enter relative angle”. 

8. Type 180 and press (Enter). 

9. Move the cursor above the displayed line and click to define the other 
side of the counter. 

7-8
The length of the countertop
is defined.

9
Click the left mouse button to
define the other side of the
countertop.

 
Figure 3.31: Drawing the countertop 

10. Right-click to disconnect from the counter. The countertop lines are 
drawn and the end is capped. 

 
Figure 3.32: The first countertop is drawn. 

11. Repeat steps 5 - 10 for the counter on the opposite side. Remember that 
the relative angle for this counter will be 0. 
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Figure 3.33: The second countertop is drawn. 

12. Click E on the Navigation Pad to view the extents of the drawing. 

13. Press (Ctrl) + (S) to save the drawing. 

Drawing the Schoolhouse’s Doors and Windows 
Now that you have drawn the walls for the schoolhouse plan, you are ready to 
insert doors and windows. 

Î To set up to draw a door: 

1. Before you begin to draw doors, press (Tab) until the Doors layer is the 
active layer in the Status Area.  

2. In the Edit menu in the Menu Window, click on Architct. 

3. Click on DoorSwng in the Architct menu. 

Adjusts settings that determine
what doors will look like.

Door entry method. By sides (jambs) when on, by
centers when off.

Removes doors and cut-outs in walls.
Draws temporary marks to aid in door placement.
Exits the Door menu. You can also click the right
mouse button to exit.

Menu Title

 
Figure 3.34: The DoorSwng menu 

4. Click on DrwMarks in the DoorSwng menu to toggle the Draw Marks 
option on.  
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5. Click on LyrSrch to toggle it on. (If LyrSrch is already toggled on, click on 
it to toggle it off; then toggle it back on again.) You are prompted to 
“Select layer to search for walls”, and a list of your layers is displayed in 
the Menu Window. 

6. Click on Walls. DataCAD now knows where to find your walls when it 
needs to cut them for doors and windows. 

There are two methods to draw a door: by defining both of its sides and by 
defining one side and its center. You’ll draw the first door by sides. To position 
and begin drawing a door, you need to reference and measure from an existing 
point on the drawing. 

Î To draw a door by sides: 

1. Click W on the Navigation Pad to go to the WindowIn menu. You are 
prompted to “Select first corner of the Zoom window.” 

2. Click at the lower-left corner of the bottom wall. You are prompted to 
“Select second corner of the Zoom window.” 

3. Diagonally move the mouse until the rubberband box encloses the lower 
half of the plan and click. The plan now appears larger. 

2
Click the left mouse button to
start the rubberband box.

3
Click the left mouse button to close the
rubberband box.

 
Figure 3.35: Zooming in on the plan 

 
Figure 3.36: The result of zooming in on your drawing 
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4. Right-click once to return to the DoorSwng menu. 

5. Press (`) on the keyboard. You are prompted to “Select reference point”. 

6. Click the middle mouse button near the upper-right corner of the first 
room you drew, as shown in Figure 3.37. Stay close to the inside of the 
corner. This will be your reference point. You are prompted to “Select 
hinge side of door”. 

6
Click the middle mouse button to set this corner
as the reference point.

 
Figure 3.37: Setting a reference point. 

7. Press (Spacebar). You are prompted to “Enter relative distance”. 

8. Type .3 and press (Enter). You are prompted to “Enter relative angle”. 

9. Type 270 and press (Enter). You are prompted to “Select strike side of 
door”. 

10. Press (Spacebar). You are prompted to “Enter relative distance”. 

11. Type 3 and press (Enter). You are prompted to “Enter relative angle”. 

12. Type 270 and press (Enter). You are prompted to “Select direction of door 
swing”. 

13. Click anywhere inside the office (on the left side of the wall); this defines 
the direction of the swing. The wall is cut,  and you are prompted to 
“Select any point on the outside of the wall”. 

14. Click to the right of the outside wall to define the non-printing snap point 
location. The door is drawn. 

7-9
The hinge side of the door.

A non-printing center
snap point.

14
Click the left mouse button to define the
outside of the wall.

10-12
The strike side of the door.

13
Click the left mouse button to define the
direction of door swing.

.

 
Figure 3.38: Drawing the door 
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Î To draw a second door by center: 

1. Click on Sides in the DoorSwng menu to toggle off the Sides option. Now 
you can define doors by entering their center and strike side. 

2. Move the mouse to the location shown in Figure 3.39. Click the middle 
mouse button to snap to the midpoint of the inside front wall. You are 
prompted to “Select strike side of door”. 

2
Click the middle mouse
button to connect to the
midpoint of the line.

 
Figure 3.39: Defining the center of the front door 

3. Press (Spacebar). You are prompted to “Enter relative distance”. 

4. Type 1.6 and press (Enter). You are prompted to “Enter relative angle”. 

5. Type 0 and press (Enter). You are prompted to “Select direction of door 
swing”. 

6. Click inside the hall (above the wall) to define the direction of the door 
swing. The wall is cut. You are prompted to “Select any point on the 
outside of the wall”. 

7. Click anywhere on the outside of the exterior wall where you want to 
locate the non-printing snap point. The door is drawn. 

6
Click the left mouse button to define the
direction of the door swing.

2
The center of the door.

3-5
The strike side of the door.

7
Click the left mouse button to define the
outside of the wall.  

Figure 3.40: The front door is drawn. 

8. Click on Sides to toggle on the Sides option. 

9. Press (`) to set a new reference point. 

10. Click the middle mouse button near the upper-left corner of Room A, 
shown in Figure 3.41. You are prompted to “Select hinge side of door”. 
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Room A

Room B

10
Click the middle mouse button to
define the new reference point.

 
Figure 3.41: Locating the next door 

11. Press (Spacebar). You are prompted to “Enter relative distance”. 

12. Type .3 and press (Enter). You are prompted to “Enter relative angle”. 

13. Type 270 and press (Enter). You are prompted to “Select strike side of 
door”. 

14. Press (Spacebar). You are prompted to “Enter relative distance”. 

15. Type 3 and press (Enter). You are prompted to “Enter relative angle”. 

16. Type 270 and press (Enter). You are prompted to “Select direction of door 
swing”. 

17. Click anywhere inside Room A (on the right side of the wall) to define the 
direction of the swing. The wall is cut. You are prompted to “Select any 
point on the outside of the wall”. 

18. Click inside the hall to define the outside of the wall. This defines the 
non-printing snap point location. The door is drawn. 

19. Now repeat steps 9-18 to create a door for Room B.  

20. Right-click twice to return to the Edit menu. 

 
Figure 3.42: The remaining schoolhouse doors are drawn. 

21. Click R on the Navigation Pad to recalculate the extents of the drawing. 

22. Press (Ctrl) + (S) on the keyboard to save the drawing.  

You have now completed entering all the doors for this exercise and saved them 
to your drawing file. 
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Î To set up to draw windows: 

1. Before you begin to draw windows, press (Tab) until the Windows layer 
is the active layer in the Status Area. 

2. In the Edit menu in the Menu Window, click on Architct. 

3. Click on Windows in the Architct menu. The Windows menu is 
displayed. 

Adjusts settings that determine
what windows will look like.

Windowentry method. By sides (jambs) when on,
by centers when off.

Removes windows and cut-outs in walls.
Draws temporary marks to aid in window placement.
Exits theWindow menu.You can also click the right
mouse button to exit.

MenuTitle

 
Figure 3.43: The Windows menu 

Î To draw the first window by sides: 

1. Click W on the Navigation Pad to open the WindowIn menu. You are 
prompted to “Select first corner of the Zoom window”. 

2. Click at the lower-left corner of the bottom wall. You are prompted to 
“Select second corner of the Zoom window”. 

3. Diagonally move the mouse until the rubberband box encloses the lower 
half of the plan, and click to zoom in on your plan. 
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2
Click the left mouse button to start the rubberband box.

3
Click the left mouse button to close the
rubberband box.

 
Figure 3.44: Zooming in on the lower half of your drawing 

4. Right-click once to return to the Windows menu. 

5. Press (`) on the keyboard. You are prompted to “Select reference point”. 

6. Click the middle mouse button near the lower left corner of the interior 
wall shown in Figure 3.45. This will be your reference point. You are 
prompted to “Select one jamb of window”. 

6
Click the middle mouse button
to set the reference point.

 
Figure 3.45: Setting a reference point 

7. Press (Spacebar). You are prompted to “Enter relative distance”. 

8. Type 3.7 and press (Enter). You are prompted to “Enter relative angle”. 

9. Type 0 and press (Enter). You are prompted to “Select one jamb of 
window”. 

10. Press (Spacebar). You are prompted to “Enter relative distance”. 

11. Type 3 and press (Enter). You are prompted to “Enter relative angle”. 

12. Type 0 and press (Enter). You are prompted to “Select any point on the 
outside of the wall”. 

13. Click anywhere on the outside of the exterior wall. The window is drawn. 
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7-9
First window jamb

10-12
Second window jamb

13
Click left mouse button for the outside of the wall.  

Figure 3.46: Drawing the first window 

14. Move the cursor to the bottom right corner of Room B and repeat steps 6 - 
14 for the window on the opposite side. Remember that the relative 
angles will now be 180. 

15. Click E on the Navigation Pad to view the extents of the drawing. 

Î To draw multiple windows: 

1. Click on Sides in the Windows menu to toggle Sides off; you can now 
define windows by the center and one side or jamb. 

2. Click W on the Navigation Pad to open the WindowIn menu. You are 
prompted to “Select first corner of the Zoom window”. 

3. Click at the upper-right corner of the top wall. You are prompted to 
“Select second corner of the Zoom window”. 

4. Diagonally move the mouse until the rubberband box encloses the upper 
half of the plan, and click to zoom in on the plan. 

4
Click the left mouse button to close the
rubberband box.

3
Click the left mouse button to start the
rubberband box.

 
Figure 3.47: Zooming in on the upper half of your drawing 

5. Right-click once to return to the Windows menu. 

6. Press (`) on the keyboard. You are prompted to “Select reference point”. 

7. Move the cursor to the top left corner of the interior wall, as shown in 
Figure 3.48, and click the middle mouse button to set the reference point. 
You are prompted to “Select center of window”. 
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7
Click the middle mouse button to set the
reference point.

 
Figure 3.48: Setting a reference point 

8. Press (Spacebar). You are prompted to “Enter relative distance”. 

9. Type 7.8 and press (Enter). You are prompted to “Enter relative angle”. 

10. Type 270 and press (Enter). You are prompted to “Select one jamb of 
window”. 

11. Press (Spacebar). You are prompted to “Enter relative distance”. 

12. Type 1.6 and press (Enter). You are prompted to “Enter relative angle”. 

13. Type 270 and press (Enter). You are prompted to “Select any point on the 
outside of the wall”. 

14. Click anywhere on the outside of the exterior wall. The wall is cut and the 
window is drawn. 

8-10
The center of the window

11-13
The window jamb14

Click the left mouse button
to define the outside of the
wall

 
Figure 3.49: The wall is cut and the window is drawn. 

15. Press (`) on the keyboard. You are prompted to “Select reference point”. 

16. Move the cursor to the center snap point of the window you just drew 
and click the middle mouse button to set the reference point. You are 
prompted to “Select center of window”. 

17. Press (Spacebar). You are prompted to “Enter relative distance”. 

18. Type 5.6 and press (Enter). You are prompted to “Enter relative angle”. 

19. Type 270 and press (Enter). You are prompted to “Select one jamb of 
window”. 

20. Press (Spacebar). You are prompted to “Enter relative distance”. 

21. Type 1.6 and press (Enter). You are prompted to “Enter relative angle”. 
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22. Type 270 and press (Enter). You are prompted to “Select any point of the 
outside of the wall”. 

23. Click anywhere on the outside of the exterior wall. The wall is cut and the 
window is drawn. 

17-20
The center of the window

21-23
The window jamb24

Click the left mouse button to
define the outside of the wall

16
Click the middle mouse button to set this point as
the new reference point

 
Figure 3.50: The wall is cut and the window is drawn. 

24. Repeat steps 15 - 23 for the last window on this wall. 

25. Repeat these steps to create the windows on the other wall. 

26. Click E on the Navigation Pad to view the extents of the drawing. Your 
plan should look like Figure 3.51. 
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Figure 3.51: The Schoolhouse floor plan. 

28. Press (Ctrl) + (S) to save the drawing. 
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