The DataCAD Developer Network (DDN) is an online resource for information and support for DCAL® (DataCAD Applications Language) developers as well as anyone interested in creating fonts, toolbars, hatch patterns, or linetypes for use in DataCAD.

Moderator: pjdixit

#72072 by dhs
Fri Aug 11, 2017 10:58 pm
Hi,
I'm trying to use GetPoly. As far as I can see the init field in the getPolyArg record should control how it behaves in a re-entrant call. But the routine appears to re-initialise itself regardless of the value of init.

This looks like a bug to me. Am I missing something ?

In my code GetPoly breaks out of its processing when a key that it does not handle internally is pressed (as expected). All I am doing is setting a Boolean flag based on this keypress and then GetPoly gets called again without modifying anything in the getPolyArg record, but it is discarding the already input points and prompting for the 1st point again no matter how many points had already been entered (I have used the debugger to confirm the init field is set to false and npnts is correctly set immediately before the re-entrant call to GetPoly).

It is going to be very hard to write my own 'GetMode' without this proc (not impossible, but I'm close to giving up the idea of seriously using D4D).
#72073 by David A. Giesselman
Sat Aug 12, 2017 7:13 am
David,

I can't see why this would not work if "Init" is truly false. If you like to send me a compiled test macro, I'd be glad to watch what happens within DataCAD through the debugger.

Dave

Who is online

Users browsing this forum: No registered users and 1 guest

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984