Support on o2c files (Objects 2 See) and o2c Interactive!
#56519 by jimgoodman
Mon Jan 16, 2012 11:24 am
Since we are now using DataCAD 14 exclusively, I uninstalled DataCAD X3 on one of our machines and am no longer able to open an O2C file by double clicking on the file name. O2C files are still fully functional in DataCAD 14 and O2C Interactive.

How do I re-establish the file association?
#56521 by Mark Toce
Mon Jan 16, 2012 1:15 pm
I'm not sure if this will work...

When you double-click the file, Windows should display a message indicating that it doesn't know what program it should use to open the file. Choose the option to select a program and then choose the file "o2cPlayer.ocx." This file would be in the C:\Windows\System32 folder or in the C:\Windows\SysWOW64 folder, depending upon the operating system.

If that doesn't work, you can also try reinstalling the latest update. I'm not sure if it repairs file associations or not, but it's worth a try.

If that doesn't work, and you already have the current update installed, you'll need to download the current version of the DataCAD 14 full installer and run it. Choose the "Repair" option to repair your current install.
#56523 by jimgoodman
Mon Jan 16, 2012 5:30 pm
I wound up reinstalling from the full installer but the file association is still broken.

I was reading other posts on the issue and ran across this:
Mark F. Madura wrote:If you install the 'Universal' edition (o2c Player version, you can use Start, Run, "regsvr32 o2cplayer.ocx" (without the quotes) to re-register the ActiveX control that ships with DataCAD (o2c Player version With this configuration, you should be able to display embedded o2c objects in Internet Explorer, Firefox, Chrome, Opera, and Safari using o2c Player version In DataCAD, you will be using o2c Player version When you double-click on an o2c object, it should launch in o2c Player version
which is from the announcement message in this part of the forum. I think that regsvr32 was the wrong command for Windows 7 64 bit installation.

I am now getting "not a valid Win32 application" error message. What is the correct command to re-register the ActiveX control in Windows 7x64?

Last edited by jimgoodman on Mon Jan 16, 2012 5:58 pm, edited 1 time in total.
#56524 by David A. Giesselman
Mon Jan 16, 2012 5:57 pm

Under Windows 7 64bit, regsvr32 is still the correct utility for registering. The only difference is that the OCX needs to reside in the C:\Windows\SysWOW64 folder. You might try using the fully-qualified name:

Code: Select all"regsvr32 C:\Windows\SysWOW64\o2cplayer.ocx"

#56525 by jimgoodman
Mon Jan 16, 2012 6:22 pm
I ran the code and received a message indicating that the DLLRegisterServer for o2cplayer.ocx successed.

The ocx file is residing, very happily, in hte SysWOW64 directory as well.

When I double click on an O2C file, I am told that it is not a "valid Win32 Application"

What would you suggest as a next move?

#56586 by Karl Griffith
Fri Jan 20, 2012 8:55 am
I can't open o2c files directly either, only since I attempted it, I am now having problems in DataCAD. When I try to assign a new material to a layer, DataCAD shuts down and I can't restart it without rebooting my computer. This seems to happen when I assign a material, and then try to click on another layer - the o2c image doesn't not regenerate for the different material, then DataCAD shuts down.

I tried reinstalling DataCAD to repair it, and I have installed the update, but the same thing still happens. Not sure what to do next.

#57444 by gregg kett
Sun May 27, 2012 11:23 pm
Hi guys similar topic different problem.
The problem is NOT with dcad, it is with Wundows, (yea i meant to misspell it :( )

Every thing was working just fine untill My client upgraded their all new computer with the latest version of windows and now having trouble with o2c.
they installed the player from the o2c web site (they say) and now every time you click on an o2c file it comes up with the o2c installation program.
when you try to reinstall it it says version already installed.

I removed the osc player .ocx from the win-sytem wow folder and tried a reinstall, same issue, it installs then says already installed.

All the o2c file icons show the little black floppy disc logo as it would if it was an installation program.

control panel doesnt show the player program so you cant uninstall properly from there.

any suggestions, the client does not have or need DACAD installed on their computer.

i assume its a file association issue but have no idea what to do about it

thanks in advance for any imput
cheers Gregg
#57450 by Karl Griffith
Tue May 29, 2012 8:14 am
I have not dealt with o2c on client computers, so have not encountered that issue, but I am quite certain that o2c has unresolved issues with Windows 7 64bit.

I find I need to keep a copy of the o2cplayer.ocx file on hand as periodically o2c stops working in DataCAD. I then have to copy in the clean player file and every is good until the next time.

I also have other (non-DataCAD) software that uses o2c, and o2c doesn't work at all in that program (again, in Windows 7, 64 bit).

So I suspect it is Windows 7 that is causing your problem, and I also suspect that the fix needs to come from o2c.

#57460 by gregg kett
Tue May 29, 2012 6:33 pm
thanks for your comments and reply, ill check what version of Win 7 the client is using.

i had vista 64 bit on an old laptop and it worked fine, i also have win 7 on a laptop and it works fine but not sure wether its 32 bit ot 64 bit. ill check.

it would be good if someone knew how to uninstall the o2c player so we could a complete reinstall to see if that works.

#57476 by gregg kett
Thu May 31, 2012 9:24 pm
HOT News flash
my client who was having o2c problems opening the file and/player in Win 7, 64bit, is very excited now we have a solution.

Very simple,, i just copied the o2c file, of their model and pasted it straight onto a word document, (blank page). i then emailed the word document to them as an attachment, they opened the attachment in word and double click the o2c logo on the page and it works as you would expect it too.

the o2c (logo) file on the page doenst look like it would do any thing,,, it just looks like a graphic pasted on the page.

im not sure as to which versions of WORD they are using but i assume its the most recent as in microsoft office 2010.

this saves sending the client a separate letter with notes and attached model , its all on one page.

hope this helps anyone else out there in this techo world.
#62434 by Mark F. Madura
Fri Nov 15, 2013 5:38 pm

Did you ever get this straightened out? There are three places you might find O2CPlayer.ocx.

C:\Program Files (x86)\Eleco\o2c Player

I have manually copied O2CPlayer.ocx v1.9.9.149 to each of these folders to resolve errors.


Who is online

Users browsing this forum: No registered users and 1 guest

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for Architects Since 1984