Ask questions about DataCAD 17, DataCAD LT 17, or previous versions here.
#79290 by stephen11962
Thu Jan 21, 2021 11:22 am
DC 17, Windows 7. For 10 years, only occasional use of DC 17. Now problems with new files created for old project. In the beginning everything worked and then after modifying things these problem:

Opened file, did some lines, inserted symbols, edited some symbols and then the drawing receded into a point. Zoom extents works, Page up, down works, Home works. I can edit/add entities but using mouse wheel to zoom either in/out collapses drawing to that tiny point. Saving file and reopening results in same result. Exiting DC and restarting allows new editing but not for long before the same behavior restarts. And mix in a DC crash or 2.

HELP! I have tried to repeat the steps and locate the precipitating instant but cannot narrow anything down.

#79294 by MtnArch
Thu Jan 21, 2021 2:19 pm
Sounds like one of the symbols you inserted has a point/line/something WAY out in NeverNeverland.
#79303 by stephen11962
Sat Jan 23, 2021 7:40 pm
Back again.

I checked for outlying 'things' in outer space and think I found nothing, but who knows? I was working, revising symbols (ever more taxing my memory) and I think something there may have introduced 'things.' I deleted many exploded symbols, cleaned up the drawing and may have coaxed better behavior, but created more questions:

The old symbols were created in a prior version of DC. The path (showing up in the Symbol Browser) for the old symbols no longer exists. I have modified some of those old symbols and would like to delete/purge those old symbols. I find the explanation of Purging in the manual confusing: At one point the manual seems to say that the Symbol Browser is a newer/better way to manage symbols but for purging symbols it says to use Templates which I did not use originally. Using the Symbol Browser on Drawing, right clicking there on a symbol shows a delete option which is grayed out. Trying to use the Templates/delete symbol refers back to the Template. I tried Purge several times and the symbols still show up in the Symbol Browser. I suspect I am missing something, what?

Each symbol in the Symbol Browser has a check mark in the upper right corner which is/means what?
Now, going back to the drawing itself I find a grid on the far right. In Templates there is a Option for Divisions for template display which is empty of anything.

I will leave it that, dinner time.

My gracious thanks to whomever replies!

Who is online

Users browsing this forum: Google [Bot] and 16 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for Architects Since 1984