Ask questions about DataCAD 17, DataCAD LT 17, or previous versions here.
#80351 by stephen11962
Sat Oct 23, 2021 7:41 am
I have been working on a file with symbols and a lot of details. The .aec file, recovered, is 860kb. The .arb file is 5688kb. I am not an expert here, but that seems like an awesome difference. There is something wrong here and I wonder if the size difference is meaningful in my attempt to find the cause.

I have purged the file but that doesn't fix the problem. It doesn't take long before the crash occurs again.


#80352 by stephen11962
Sat Oct 23, 2021 12:38 pm
Me again.
Tried to rectify the problem without success but with this added bit: I was zooming in the file and poof, the file disappeared without warning. This repeated earlier problems. The .aec = 758kb while the .arf and .arb files were 2752kb. So, a zooming problem?

#80354 by Roger D
Sun Oct 24, 2021 12:09 pm
The .aec files get compressed when saved, otherwise you would have very large drawing files on your harddrive.

Here are a couple things I would try:
(1) Open a new blank file, not using any default file, and import the file you are having the problem with.

(2) open the file, using the Layer manager, turn on only the 1st half of the layers (say layer 1-100), then zoom, if it crashes, the open the again and open the 1st 1/4 of the layers (say 1-50), slowly narrowing down the layer that might be causing the issue. If you can determine the layer, save that layer out, delete from the file, close the file. go back to item (1) and import the file again. This way any bad definitions in the file header should not be entered in the new file. save file and see if it helps. Save it as a backup and try to import the saved layer in, if you still have the problem after the layer import, go back to the backup file without issues, and you might have to manual recreate that layer, hopefully not to much.

Hope this might help.
#80355 by stephen11962
Sun Oct 24, 2021 2:47 pm
Hi Roger

Thanks for responding.
I tried doing what you suggested and found no joy. I have only 23 layers. I turned on (almost) half and zoomed in and out as far as possible and did the remaining layers, zoomed with nothing untoward occurring.

I was working on the file earlier this AM for a while and it crashed again but this not by zooming - leaving me wondering about the real cause. Before posting I tried finding comments that might aid in my plight. The only thing I saw that might have a bearing was a comment about symbols in the drawing that might have a wayward element way out in left field. I did not find any like that but two that were modified by me that were not correct. One had a symbol embedded in a symbol. If that is a potential problem then maybe I fixed it - but not very optimistic. Will revert to the drawing after my answer here. Just one thing; I wonder if this is a file or program corruption?

If still no works, will go tomorrow to DataCad, pay money, and move on. Too much time lost.

I am pretty much out of using CAD these days but am always amazed by the generosity of this community. Many thanks.

#80356 by Roger D
Sun Oct 24, 2021 5:04 pm
Another crazy idea I have done in the past when something is wrong with a file is that I exported to a DWG and then import that back into a blank file.
#80358 by stephen11962
Mon Oct 25, 2021 10:40 am
Back again

Found some symbols with dark gray dots that turned out to be centers of arcs of small length but 8' or so from the center of the symbols, arcs so tiny that do not show up at typical scale. I edited the symbols, erased the arcs and saved the symbols. I have no idea why this should cause crashing. My hope is that my ignorance is not material in this matter. In any case, no probs after working in the file for a while.

I'll try your last suggestion if the next time arrives.

Until the next time, thanks

#80360 by stephen11962
Mon Oct 25, 2021 1:36 pm
The next time

I sent the file to Clay at DataCad and quickly got back what I hope is an error free file (+an audit file).

The symbols came from a window manufacturer via .dwg. So I suspect the problems of symbols and lines occurred during the translation to .aec.

Haven't started working on it yet.
#80361 by MtnArch
Mon Oct 25, 2021 1:54 pm
Clay has always recommended that you import ANY Acad DWG file into a new, blank AEC file and then save that as an AEC, and use the AEC file to create your new symbol (or as an Xref if you're trying to use it in your regular drawing). This way it doesn't corrupt your drawing.

Glad Clay was able to get it back to you so quickly!

Who is online

Users browsing this forum: No registered users and 15 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for Architects Since 1984