Ask questions about DataCAD 16, DataCAD LT 16, or previous versions here.
#51525 by rgleason
Sat Dec 18, 2010 9:55 am
New install on Win 7 x 64 of Datacad x3. Hardlock failure.

Actions taken.
1. Uninstall Dcad X3.
2. Insert key and reinstall Dcad
3. Failure still occurs when trying to start Dcad.

Actions then taken.
Refer to: ... CAD_QA.htm

1. With key plugged in, go to "Start" or "Windows" lower left icon, then Computer > Sytem Properties (top bar) > Device Drivers and scrolll to bottom and remove any hardlock keys under USB drivers.
2. Unplug the DataCad USB Lock Key.
3. Shut down and reboot.
4. Download the key here
5. Save to download directory. Then click to run it.
6. It will show "HLDRV32" or "HLDRV32.exe" not "HLVDD.DRV". Since it is executable, click on it and install. You may have a prompt to over write a newer file, go ahead and overwrite the driver (Datacad won't load unless you do this.) Also the driver says it is for "WinXP, Vista and Vista 64 bit" with no mention of Win 7 or Win 7 x64 which was a bit of an unknown for me.
7. Then install the USB lock and wait for additional drivers to load before starting DataCAD x3. The USB drivers that then load on top of the ones you downloaded are "SafeNet Inc USB Key" and "SafeNet Inc Hardlock Key". Once these are loaded, start Datacad.

#51533 by rgleason
Sat Dec 18, 2010 12:14 pm
There's a bit of a problem. Now when I shutdown and reboot with the Hardlock Key in the USB port, the computer HANGS UP!. I have to hard shutdown using the button. Then REMOVE the USB KEY, and reboot.

Then I can put in the USB Key and use DataCAD.

SO, I guess for now, the rule is:
LEAVE THE DATACAD USB HARDLOCK KEY out until you have fully booted!!!
THEN plug it in.

I am now wondering if the USB driver should be put into Win XP compatibility mode or perhaps we need a different driver.

If anyone knows more about this I would appreciated a response with the details.

Also DataCAD x3 seems to be working in native Windows 7 x64 without having Windows XP compatibility set to run, Is this correct?

#51537 by Neil Blanchard
Sat Dec 18, 2010 4:59 pm

You need to email Tech Support and ask them for the hardlock DLL file. The 64bit version of Win7 "protects" you from the Installer, for some reason. Once you get the DLL, you need to manually copy it in the Windows subfolder -- Mark will tell you the name of it.

I had to do this last week at a client's office, and if you need it before Tech Support can get it to you, I will try to get him to forward me the file; and I'll forward it on to you.
#51538 by joshhuggins
Sat Dec 18, 2010 5:32 pm
Hmmm, I didn't have this issue but maybe it's because I always disable UAC after I install windows? But now that I think about it my co-workers systems with Win7 64 bit who do have UAC on didn't either. Might be worth a shot and try shutting off UAC. Click Start, type UAC, and select Change User Account Control Settings, drag the slider to the bottom & reboot), install Datacad to the C:\ and then re-enable UAC. UAC is a handy feature to leave on as it will help stop some of the sneaky stuff out there.
#51540 by MtnArch
Sat Dec 18, 2010 6:49 pm
I'm with Josh on this - I didn't have any problems when I installed X3 on my new Win7 box. I also disabled the UAC - I can't stand it! At least Win7 allows me to turn it off and not remind me every time I turn the computer (like Vista does)!
#52500 by WizArtist
Sat Mar 19, 2011 10:43 pm
I just had to format and reinstall with a replacement disk of W7Pro/64 with SP1. Prior to this X3 was working fine, now there is NOTHING I can finagle that will make this read the hardlock. I have done everything listed above and even copied the DLL file to anyplace that I thought it might read it, yet it keeps telling me that I have an "Unknown Hardlock Error". when I unplug the USB dongle and plug it back in it gives me a failure. See attached. I have the UAC turned off, I've unistalled/reinstalled/deleted the driver software/reinstalled and it still keeps coming back with this? HELP.
Capture001.PNG (56.86 KiB) Viewed 25629 times
#52501 by MtnArch
Sun Mar 20, 2011 12:17 am
Not the best advice, but wait for V13.06 and the Softlock key?

Until then ... a few "no-brainer" suggestions (forgive me if you've tried them):
- Make sure you are logged in with a User Account that has Administrator rights
- Make sure that DC is installed under the root directory ... NOT the /Program Files/ subdirectory
- Try plugging the dongle into another USB port

I'm not sure if these will make any difference at this point, but they can't hurt.

Good luck!
#52512 by WizArtist
Sun Mar 20, 2011 4:33 pm
tried them all before. I swear W7/64 is possessed. I have had NOTHING but trouble with it. I bought X3 because my new system didn't have onboard parallel ports for v.11's dongle and W7 refused to accept ANY card. I'm just hoping that I don't HAVE TO make any changes on stuff I have out right now.
#52528 by Mark Toce
Mon Mar 21, 2011 9:51 am
Is there any possibility that you're logged on to Windows with an account other than the administrator?

Try manually removing and then reinstalling the drivers for the hardware key.

Disconnect the key from the computer. Open the Windows Control Panel and select "Uninstall a program." Pick the "Hardlock device drivers" and click "Uninstall." On the first page, make sure to pick the "Custom" removal option. Click on "Select All" and then "Next" each time those buttons are shown, until the process is complete. When you have finished uninstalling the drivers, restart Windows.

Next, go to and click "Download Hardlock Device Drivers (4.88MB)" in the middle of the page. Save the installation file into a folder on your hard drive, such as My Documents, and then double click on it to install.

When that is finished, use the link below to download a copy of the file "hlvdd.dll." ... /hlvdd.dll

Save the "hlvdd.dll" file into the C:\Windows\SysWOW64\ folder. Windows may prevent you from saving directly to that location. If that happens, save it to a temporary folder first, such as C:\Temp\ and then copy and paste it into C:\Windows\SysWOW64\.

You may now connect the hardware key to the computer. Windows will display a message indicating that it has found new hardware and will install the drivers. When it says that the hardware is ready to use, shut down and restart the computer once again. When it is finished,
you should be able to run DataCAD.

Please let me know whether or not this solves the problem.
#52590 by WizArtist
Thu Mar 24, 2011 12:10 am
Actually ended up having to reformat the hard drive yet again. The problem it seems is my backup program (Acronis True Image 2011) which seems to prevent windows from being modified. I kept the hard lock in while installing W7 again and it automatically picked it up and brought in an update and installed it. Once I got Datacad reloaded it worked. So much for Acronis' claims to be "Windows 7 Ready". Now to get Office and everything else reloaded. Been a REAL fun week.
#52605 by Dave
Fri Mar 25, 2011 5:18 pm
WizArtist wrote: The problem it seems is my backup program (Acronis True Image 2011)

Yes I had that problem with Acronis on Win 7 Pro. This machine does not run DCAD. I had to reinstall win 7. I have ended up using win 7 's own backup software.

#53785 by WizArtist
Sun Jul 24, 2011 2:24 am
WELL a final update on this note. I kept having problems and it turns out that my ASUS M4A785-M Mobo was BAD. I picked up a nice MSI board from Newegg and the thing runs like a charm with NO glitches whatsoever.

Who is online

Users browsing this forum: No registered users and 8 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984