Ask questions about DataCAD 17, DataCAD LT 17, or previous versions here.
#68071 by Richard Mauser
Tue Jan 19, 2016 2:10 pm
Hi Cognocenti,

A funny thing happened yesterday, or I just noticed yesterday because I hadn't the need to revise a symbol in a while. When I clicked on the "redefine" button in the template menu, instead of getting the "entity, area, group" etc buttons, it kicked me back to the "template" menu. It seemed to be specific to the one template, and to every symbol in that template (there could be other templates behaving the same way; I haven't checked them all). I loaded a couple other templates, clicked the "redefine" button, and it worked correctly in those templates. After a period of frustration, I did a little cap letter editing in that template (clutching at straws here, or procrastinating, not sure...) and tried to save it, but I couldn't because it was tagged "read only" so I opened the "file properties" menu and unchecked "read only". Now I can redefine the symbols in that template. It turns out the other templates that were not a problem were not "read only" protected. So my question is, if I am not actually changing the template file (not adding a symbol) why does a "read only" tagged template file not let me update a symbol when the referenced symbol path and the symbol name is already in the template? I'm not actually changing the template!

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984