Ask questions about DataCAD 15, DataCAD LT 15, or previous versions here.
#70730 by dmartens
Tue Jan 31, 2017 2:36 pm
I have a drawing of a condo bldg. that contains 8 xref's of the plans that make up this unit. When I create a new drawing and xref in the condo bldg. file my xref's are now nested and show up no problem. When someone else in our office tries the same thing not all the nested xref's display (2 are missing). When someone else does the same thing no nested xref's display. When they don't display there is only an 'x' on the screen instead of the xref. All the settings for xref's in the .ini files are the same for everyone. All xref's insert at 0,0,0. No clip cubes in the files. All display options in preferences are the same. Cannot for the life of me figure out what is going on. I have to send these files to a consultant (who thankfully uses Datacad) who never uses xref's and I am fully expecting problems now that I see what is happening here. Any ideas what could be causing this? I have tried everything I can think of. Thank you for any help.

Dan

P.S. I need to work on the boss to upgrade now that I see we are relegated to the Legacy forum.
#70744 by Mark Bell
Thu Feb 02, 2017 5:59 am
Hello Dan,

Have you tried Pak'n'Go to share the source files with other systems for consistency?

I had one of my staff have the same issue you describe with only an 'x' shown. I had them do a screen shot for me. Check the paths are correct for each of the xrefs and see if that makes any difference. Doing a Purge should automatically carry forward the xref path but I found in some instances on one of the PC's which had very low disk space, the source drawing file included over 80 xrefs and the swap file was close to 1GB. We found the new purged AEC file hadn't rebuilt all the xref paths - I put it down to insufficient disk space for the purge to copy across all the information whilst it created the new drawing. Also check your hard disk space on the PC's.
#70745 by dmartens
Thu Feb 02, 2017 8:44 am
Thanks for the reply Mark. The person in my office was getting the 'x' because a nested xref was not showing. The path for the xref (which contains 8 xrefs) was correct. The swap file was less than 100k. And he has plenty of disk space. Interestingly he was not getting 2 nested xref's showing so I went into those 2 files and just opened them, went to a GTV and closed the file. Then when I opened the master file only 1 nested xref didn't show. I will play around a little more as it will drive me crazy until I (or someone else on the forum) figure it out. Thanks again Mark.

Dan
#70746 by Paul Nida
Thu Feb 02, 2017 10:12 am
This has been a problem for us for years. It seems to be random and unpredictable. I have not been able to figure out a cause, thankfully it doesn't happen often. Sometimes if you place the missing xref in the final drawing, the missing nested xref will then show up as it should.
#70747 by dmartens
Thu Feb 02, 2017 10:38 am
That's interesting Paul. And since I know you are probably on the latest release that upgrading wouldn't fix my problem either. Not sure why some of these thing get swept under the rug if you will.
What's even more interesting is I went over to the computer having this problem armed with your new advice and when I opened the drawing all nested xref's appeared correctly. Still have another computer to try all this on. We'll see what happens. Thank for the reply Paul.
#70750 by joshhuggins
Thu Feb 02, 2017 11:48 am
Shooting in the dark here, could the file server or network (router/switches) be under high loads and not able to serve up the file quick enough for Datacad in that instance so Datacad can't find it and doesn't load it? One thing to maybe try is on the box that's having the issue is in Windows File Explorer open the folders where the xrefed files live so Windows makes the connection to the path and then open the main drawing and see if the xrefs load ok.
#70758 by Paul Nida
Thu Feb 02, 2017 2:23 pm
Actually I am not on the latest version yet. We are in the process of upgrading all of our office computers and are planning on moving to v.19 when that is complete. It is taken longer than we had anticipated.
#70759 by dmartens
Thu Feb 02, 2017 4:26 pm
Thanks Josh. I will try that as soon as I get a chance.
Paul, I knew you were way ahead of us. Though if it was up to me and not strictly money driven we would be up to date. I was worried that being so far behind I would get overlooked here in the legacy forum. Instead I get replies from some of the heaviest hitters on the forum. I greatly appreciate all your responses gentlemen. Have a great day.

Dan
#70763 by dmartens
Fri Feb 03, 2017 11:34 am
Thanks again Josh. Tried what you said about going to the folder containing the drawings in windows explorer and everything seemed to work fine. I just hope this fixes any problems our subs may have. This forum and the people that lend their assistance here are invaluable. Thanks everyone.

Dan

Who is online

Users browsing this forum: No registered users and 11 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984