Ask questions about DataCAD 17, DataCAD LT 17, or previous versions here.
#71909 by MichaelB
Tue Jul 25, 2017 2:58 pm
I will be grateful for some help here - I use Datacad 16.

While working on a drawing, it closed on me - I just cannot reopen it.

I have tried using the .dbk files - no luck.

I have rebooted - no go.

I can open other drawings in the same folder, but not this one - the file just does not respond.

I cannot purge the file because I cannot open it.

Any ideas? - will be really grateful for advice.

#71914 by MichaelB
Tue Jul 25, 2017 3:44 pm
Maybe this is a Dropbox issue - when I try to open the file I get "A201-Rev D, Floor Plans 1.100, A1.u$r added" and thereunder it says "You added A201-Rev D, Floor Plans 1.100, A1.u$r to your Dropbox". Then I get "A201 - Rev D, Floor Plans 1.100, A1.u$r deleted" and thereunder "You deleted A201-Rev D, Floor Plans 1.100, A1.u$r from your Dropbox"

The "A201-Rev D, Floor Plans 1.100" is the name of the drawing file.

If this is an issue, how come my other files are OK?

Maybe a glitch while working on the drawing...........?? If so, how to resolve or recover?
#71915 by Aaron Ben-Avraham
Tue Jul 25, 2017 4:12 pm
Maybe try shorting the file name and eliminate the comma's and periods. I remember a long while back periods causing some problem, but I can't recall the exact circumstance... And maybe move the file to a short name folder in c: drive to eliminate any path/length filename issue... Something really simple like c:\test\test.aec

Just throwing it out there to see if it makes a difference.
#71916 by David A. Giesselman
Tue Jul 25, 2017 5:25 pm
May I ask why you are using a comma in a file name? Just because Windoze tolerates it doesn't make it good practice.
#71917 by Aaron Ben-Avraham
Tue Jul 25, 2017 6:03 pm
You mentioned DropBox. I don't use it, but I am wondering if it has "versioning"? I use Google Drive to back up my current work to "The Cloud" (tm) :D because it has versioning, so I can go back to a point in time and pick up an older version of a file if necessary. Also with a service that has "versioning" ransomware is a less of a threat, or at least I hope so. That is why I also keep a copy of my stuff on a USB drive unplugged from the server as well!

I also do the same on my LAN with Windows 10 "File History" app. Problem with that is that if you get whacked with Ransomware that spreads over the network, the server hosting the File History share could well be infected also...
Last edited by Aaron Ben-Avraham on Tue Jul 25, 2017 6:22 pm, edited 3 times in total.
#71918 by joshhuggins
Tue Jul 25, 2017 6:13 pm
Aaron Ben-Avraham wrote:I remember a long while back periods causing some problem, but I can't recall the exact circumstance...
Datacad's built-in PDF generation choked when trying to output the PDF's if the file or folder had a period in the name. Not sure if this is still the case or not.
#71922 by Dave
Tue Jul 25, 2017 8:49 pm
How's about copying the file to a new location and rename it to something like test.aec and see if that works. I'd create a test folder on c drive call it AEC then the file name will be c:\AEC\Test.aec. this will pull the file away from your google drive and versioning problems. Just to test. If it opens then recopy the file without renaming and see if that opens.

#71930 by MichaelB
Wed Jul 26, 2017 11:22 am
Thank you for the responses to my problem and I address accordingly:

Aaron and DaveR:
I did try the option of shortening the file name and eliminating the commas and periods as suggested, and moved the file to the c: drive - it did not work, I still cannot open. It was worth the try

David: I have used commas in file names as a matter of convenience - and I know my file names are lengthy but the names do briefly describe the files which helps me. Question, and excuse the naivety, but why is this considered not good practice? And what should I be doing for it to be good practice? Would appreciate the feedback.

Meantime, I will redo the drawing - fortunately I have a previous revision in an archive folder - it is just the time factor that is the hassle to redo.

Thanks again
#71933 by Roger D
Wed Jul 26, 2017 1:44 pm
I usually use an hypen "-" or underscore "_" for spacers.
#71940 by MichaelB
Thu Jul 27, 2017 10:45 am
Hi again

Just to advise how the problem has been solved and to close out this post.

Before coming onto the Forum, I had forwarded the problem file to Datacad SA for help.

They could not open it, so they forwarded it to Datacad Tech Support USA.

They were able to solve the problem by removing some "funnies" in the file, one of which was a huge circle that was causing the file to crash.

I think that while I was working in the file - and I was working with circles at the time - my finger slipped on the keyboard and caused the entry of this problem circle.

Anyway, the file is back up and running, and I do not have to redo the work.

Thanks for the interaction - I learned things - and thanks to Datacad Tech Support!!

Who is online

Users browsing this forum: MSN [Bot] and 43 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984