Ask questions about DataCAD 17, DataCAD LT 17, or previous versions here.
#72668 by Richard Mauser
Thu Nov 09, 2017 6:24 pm
Hi all,

I've set up some sheets to plot, and when I go to Plotter/Sheet, the colored line image of the multiscale plot used to show, but now when I go to a sheet I've already set up, nothing shows. But when I click plot, the preview white background 'PDFish' image does shows what is there to be plotted. I just can't see anything on the screen prior to that. It looks like a totally blank sheet - nothing on it.

When I go to the Sheet menu, two or more sheets are highlighted. If I click on a non-on button, 2 sheets stay on. So I cleared those two sheets. Now, when I click on a sheet, only that button lights up, but nothing shows in the screen. Its as if it is blank. What did I do wrong?

I opened some older drawing files and they work fine. How should I go about making this right? Export all layers and rebuild the drawing file, and then the plot sheets?

Update: That is what I did. Now its a new drawing file with the original layers. I had to rebuilt the plot sheets. It took a while to do this.
I'm wondering if there is a macro that would automatically export all layers, and then automatically import them to a new drawing file, once one is opened.
#72679 by Richard Mauser
Sat Nov 11, 2017 10:03 am
Hi Mark,
Thanks for your reply. I just tried what you suggested on a sheet that has only one image being plotted to it (in my brand new reconstructed drawing file). 'Show all' is off, and when I click on the one button for an image that is shown on that sheet, it closes the drawing file. Improperly too! I'm not a CAD wizard by a long shot, but it seems like that is the wrong response for the program to do. I haven't tried that with a sheet that has more than one image being plotted on it.

I also checked the 'messed up' drawing file. 'Showall' was lit up, so that wasn't turned off, and yet no image is being shown. And (drum roll) TWO sheets are still highlighted as selected to be shown! (cymbal noise!) Again, I ain't no CAD wizard, but that don't seem right. Like crossing a horse with a donkey, and yet that actually works.

So, I'm not going back to that messed up file - no mo', no mo', no mo', no mo', hit the road jack... which loops this back to donkeys. Its a stubborn drawing file.
#72689 by Richard Mauser
Mon Nov 13, 2017 7:37 am
Hi Mark,

In the Layer menu, I see (but have never used) "Lyr Sets". In the DataCAD Manual, it says "Layer Sets replaces the layer utility macro from DataCAD versions 10 and prior." So this is the Layer Utility macro incorporated into the program. I had a sort of a Dorothy discovers the ruby slippers moment. Sort of...
I guess (haven't tried yet) that would automate the layer saving process (see excerpt from the manual below). Apparently I could save "GoToViews" too, and "multiscale plot details" too. I'm wondering what would happen by reconstructing the file a) with, and b) without the plot views, to find out whether that is the culprit, or if there is some other bug in the drawing file. I would be nice to save all those settings and only have to fly the mulitviews into the sheets once again, rather than reconstructing them. I guess I'll leave that test for another time.

Thanks again for your comments.

Using Layer Sets
In the Layers menu, Layer Sets replaces the layer utility macro from DataCAD versions 10 and prior. Layer Sets controls settings on a per drawing basis and retains them with the drawing file.
To create a layer set:
1. Select Layers from the Utility menu. Then choose Layer Sets from the Layers menu. The Layer Sets menu appears.
2. Click on Create and toggle on the options you want in the current layer set.
All Layers - Creates a layer set with all layers.
On Layers - Creates a layer set with only the layers that are on.
Views - Includes saved views in the layer set.
Details - Includes multi-scale plot details in the layer set.
3. Click on Begin. A dialog box appears so that you can enter the name of the layer set you want to create.
4. Click in the File name input box, supply a name, and click Open or press (Enter).
#72692 by Mark Bell
Mon Nov 13, 2017 5:52 pm
Hi Richard,

Another way to copy your drawing including the Layers, GTV's, MSP's, MVW's is to use the File/Purge from the pulldown menu to purge the drawing and copy everything selected to a new drawing. This also reduces the file size and 'cleans' it up in the process and may fix the problem you've had in the plot sheets?

In the File pull down menu (top left of screen), move down to pick Purge which opens a Purge Drawing menu. Pick Layers then what you want (ie. select all), and repeat for the other tabs moving left to right, then tick the 6 boxes at the bottom of the menu to removed unused entities as noted, then pick File / SaveAs AEC and enter a new drawing name to copy everything into. Once done, exit the current drawing and open the new one.
#72694 by Richard Mauser
Mon Nov 13, 2017 6:07 pm
Hi Mark,
I gave it a try. In one file I purged everything. In another I only purged MSP. Neither one fixed the bugaboo. Whatever it is, it exists somewhere in the murky depths of the file.
But you pointed out and explained a tool that I'm not using. Thanks for that insight and advice.
There are a lot of useful things in the program that could fill a book. Wait a minute .. It does, in the user manual!
#72696 by David A. Giesselman
Mon Nov 13, 2017 6:42 pm

I can't promise to fix your file (I reserve that for Priority Support subscribers or users of the latest version), but I'd love to have a look at it. If you wouldn't mind sending it to me (, I'd like to see what's going on here.

#72697 by Mark Bell
Mon Nov 13, 2017 6:48 pm
Okay, the only other ideas I can think of to check are:

1. Check the B is selected in swothludfbk so Bitmaps are set to display,

2. Ctrl-right mouse click over the bitmap to open the menu, then pick Polyline Properties / Fill Settings Change / check the Bitmap Fill is ticked (or in American terms, check that the check box is checked~!), pick the folder icon to re-select the bitmap image, then okay to close etc.

3. Create a new layer and re-insert the bitmap(s) again,
#72699 by Richard Mauser
Mon Nov 13, 2017 9:03 pm
Hi Dave,
You are welcome to have damaged file. I've already saved and loaded all of the layers into a new file, so I don't need it fixed. Luckily I wasn't too far into the project. But I am curious about what happened, being that it is file-specific and not a corruption of the program itself. If you can find out what caused it and can explain it to a layman, I'd appreciate if you could post the explanation here.

Hi Mark,
I checked the file. B is and has been highlighted. I don't think that's it.
At this point, I'm ready to blame the Russians. They're everywhere, with their encrypted Trojan worms. Dam U, Vlad!

Who is online

Users browsing this forum: Google [Bot] and 11 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984