Ask questions about DataCAD 17, DataCAD LT 17, or previous versions here.
#74446 by dmartens
Wed Jul 25, 2018 9:06 am
Thought I'd try using smart entities on a small project. All was working fine and then I noticed all my flush wood doors no longer appear in o2c. in the door manager I can see the frame, stop and handles but no door. opened the symbol of the door and it is there with the proper material. It says in the manager the door is there but can't see it. Start a new file, insert the same exact door and works no problem. Tried importing the drawing into a new file and doors still did not appear. I had loaded some more doors after the missing door but that should not have been a factor. Any ideas. This is why I still don't use smart entities even after all these years! When I get time I will try and go thru all the steps and see when I lose that door. Thank you.

Dan
#74468 by Mark Bell
Tue Jul 31, 2018 5:18 am
Hello Dan,
Have you checked to see the [Include] is ticked in the Door tab of the Door Type Manager and that the door Thickness is not at zero? The DTM has an O2C preview so if it's not showing then it's not loaded and you need to re-check some of the settings and tick the appropriate boxes.
You can also try a different 3D symbol by ticking the [Use Symbol 3D] box and then selecting another door symbol and see if that works. Generally, the smart entities work fine, it's usually something has been unticked by accident or a value is set to a small/zero number etc.
#74480 by dmartens
Wed Aug 01, 2018 7:43 am
Hi Mark,
Thanks for the response. I have the include toggle checked. Thickness is 1 3/4". All parameters have been checked. If I start a new drawing and use the same door it works fine. It's just in this file. I had loaded other doors along the way and somewhere, something changed and my door disappeared. I even checked my texture to make sure it hadn't been overwritten. I will have to go back thru step by step and see if I can determine when the door disappeared. It's a real shame smart entities have been pretty much left out in the cold. This was as simple a project as we get in this office so if I can't figure out the problem I will probably never use smart entities again. That is a real shame.

Dan
#74481 by Roger D
Wed Aug 01, 2018 7:51 am
have you tried reloading that smart door?
Is it set to a non printing color?
#74490 by Mark Bell
Wed Aug 01, 2018 8:35 pm
Hello Dan,

I wouldn't let this one issue dampen your use of smart entities. I use them on almost all projects and wouldn't not use them given the productivity we get.

Some other thoughts:
1. If you Identify one of the smart doors in a drawing it will display the path at the bottom of the screen - make a note of this,
2. Do a drawing file purge of the problem file and tick all boxes, then in the new file insert the door again and see if it remains there,
3. Check the symbol definitions in the browser and view iso as well to ensure all's displaying correctly,
4. It may require redefining the door symbol again or saving a new copy of the door and updating the smart door type to reference the new symbol. If you're substituting a parametric door for a symbol then it usually comes down to paths and ticking the right boxes in the DTM,
5. I've uploaded some screen shots - the first shows a standard parametric door (3D) using a 3D symbol for the the door handle, but references a 2D custom symbol for the display in plan. The second shows both 2D and 3D referencing custom symbols. The last image shows a custom 2D symbol associated with the first image, the next doors are standard parametric door types, the middle one being saved with only the door frame and no door.
Hope this helps.

080218a.jpg

080218b.jpg

080218c.jpg
#74491 by dmartens
Thu Aug 02, 2018 7:24 am
Thanks Mark. I will try all this when I get a chance. Had to revert to 2d so I could get the project done. And if it was only this one issue life would be good. I have posted before about problems with smart entities that have kept us from using them in our office. And as has been stated before in this forum it has been a while since any improvements have been made with smart entities. For basic exterior models they may work well, but many of our projects are renovations of existing buildings with many different wall types. And the cleaning of different wall types is one of the problems. I would love to be able to use smart entities as it would make my life a lot easier but it generally causes more headache than it is worth. This is still the best software around for the money and I love using it. I would just like upgrades to apply to all aspects of the program and not just pushing ahead with the latest feature. Thanks again for your reply.

Dan
#74493 by dmartens
Thu Aug 02, 2018 1:13 pm
Hi mark,
1. An identify on the door gives no path just the door type.

2. Purged the file, inserted new doors in new walls and still no door shows.

3. Interestingly when I view the doors in my browser, they only show in plan view not iso. So I ctrl-rt click on symbol, edit symbol and then the door file opens. This shows in o2c with the correct material. I can insert the door manually from the SB and it shows in plan view but not o2c. If I view the drawing in isometric the doors don't show.

Seems to have something to do with viewing in isometric. Bottom line is when I start a new drawing and use the exact same settings, walls and doors everything shows up fine. Will just chalk this up to another corrupt file and be done with it.

I appreciate all your help on this matter Mark.

Dan
#74497 by David A. Giesselman
Thu Aug 02, 2018 2:36 pm
Or just check the View pull-down menu and see if View Dependency is checked. If it is, try un-checking it.

view dependency.JPG
view dependency.JPG (24.04 KiB) Viewed 3276 times

Dave
#74499 by dmartens
Thu Aug 02, 2018 2:52 pm
OK you both win a prize! Tried Dave's 1st. turned it off and the doors showed. But this seemed counterintuitive. Then I checked the door symbol and somehow 3D was not checked. I never used that in making these doors and as far as I know these are DataCad symbols. Any way after I updated the symbol I had to turn view-dependency back on for the doors to show. Not sure how the 3d button got toggled off but at least I now know what the problem was. Thank you both for the help.

Dan
#74501 by David A. Giesselman
Thu Aug 02, 2018 3:47 pm
dmartens wrote:OK you both win a prize!

Yay, I like prizes! :D

Dave
#74503 by Mark Bell
Thu Aug 02, 2018 7:24 pm
Hi Dan,
Good to hear you got it sorted. I agree that more could be done to progress smart entities but they are still usable in their current format. You can always add a solid fill (white, black etc.) to camouflage any difficult wall cleanups so they at least print legibly - just a suggestion.
#74505 by dmartens
Fri Aug 03, 2018 9:48 am
Thanks again for everyone's help. It was frustrating but all worked in the end. And I am trying them again on another project today. Fingers crossed! Have a fabulous weekend all.

Dan

Who is online

Users browsing this forum: Google [Bot] and 15 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984