Ask questions about DataCAD 17, DataCAD LT 17, or previous versions here.
#757 by paccairns
Fri Mar 04, 2005 7:11 am
Has anyone tried to run DCAD on a MAC using virtual PC.
I tried DCAD 10 using Virtual PC 7 on a new MAC running OS 10.3 and it failed. It said there was a particular .dll file missing and then wouldn't even uninstall.

Anyone successfully tried this?

I got DCAD11 Test Drive to run fine.
#769 by Daniel Kaczor
Fri Mar 04, 2005 12:19 pm
I don't have a Mac, but, as I recall from previous posts the problem with running DataCAD on a Mac or Linux machine is the the hardlock won't/can't be recognized. I recall DataCAD LT and the demos would work because they do not use a hardware lock. You may want to search the archives at
#807 by paccairns
Sun Mar 06, 2005 8:29 pm
That's interesting you say that as I was worried that might be the case. However, the problem seems to occurs prior to the installation completing. Before the final screen saying everything was installed correctly, it crashes and reboots windows. When it fires up again the DCAD logo is there but won't run as it comes up with the missing .dll file. When you try to uninstall, it has a missing uninstall file.

Perhaps it crashes when it is trying to install the hardlock drivers.

Hopefully someone may have come across this before.
#808 by Neil Blanchard
Sun Mar 06, 2005 10:03 pm

If the trial version works and the full version crashes right at the end of the installation then it has got to be the hard lock driver.

In Linux, which is running a similar kind of Windows emulation, it is the HL driver that is the snag. I have gotten DataCAD 11 LT (with no HL) to run in Linux, though it has some video anomalies, and it a bit slower than in a real Windows installation on the same machine. I would imagine that it would be similar on a Mac.
#826 by paccairns
Mon Mar 07, 2005 6:24 pm
I think you're right on the money. I downloaded the latest hardlock drivers from DataCAD and tried installing them alone prior to the program and Virtual PC went into orbit. It rebooted itself, loaded, rebooted, loaded and son on and so forth. There was little choice but to uninstall Virtual PC and reinstall it. In doing this I discovered that it was actually version 6.1 not 7. I will get 7 and try again. Otherwise I have no idea. :x

Who is online

Users browsing this forum: Google [Bot] and 6 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984