Ask questions about DataCAD 15, DataCAD LT 15, or previous versions here.
#12523 by GuyS
Tue Jul 04, 2006 10:25 am
I use the "move" function a lot. By pressing the "m" key on the keyboard I don't have to use the mouse therefore much faster. Problem is if the caps function is turned on the "M" key now takes me to the macro function. I know that I can shift M back to m but I would prefer if the key were dedicated to the move function only. Is there a way of doing this?
#12526 by Miguel Palaoro
Tue Jul 04, 2006 1:15 pm
Hello Guy,

I'd suggest you to take the most care about this change that you will be making.
This is because the change is purposedly not documented, because the risk is really high. If you change what you shouldn't, you can perhaps cause a misfunction on your DataCAD installation.

First move: Please, get the file "DCADWIN.MSG" on the '\Sup' sub-folder inside DataCAD installation root and back it up with a safe name;
You wil have it available for an emergency back-up.

Second move:
Open this file with 'notepad.exe' or other unformatted text editor.

Go to the line number "1140 and 1141". You will have this string below:
Code: Select all140| npozuds,<.i\+qQ=f/xXh`~|-_wWjJkKmcregalv;:t!@#$%^&*()b{?[]'"SAyYVFIM}ª      |

Code: Select all141| NPOZUDs,<>i\+qQ=f/xXH`~|-_wWjJkKmCREGaLv;:T!@#$%^&*()B{?[]'"SAyYVFIM}ª      |


If you pay attention to the characters, you will start to understand how do work the short-cut keys in DataCAD.

In line '1140' the 'm' char is the key to call 'Move' command, and the 'M' char is to call the 'Macro' menu.

The line '1141' means the 'Shift+char' key press.

What to do to have your wish satisfied:

a) Replace the 'M' char on line '1140' by another, like a numeric char, for example;
b) On line '1141' replace the 'm' char by 'M', and the 'M' (at the end of the string) by the same character choosen in the first line;

Please attention:
Don't extend the line length and don't shorten it. The vertical character at the end must remain at the same place.

Your code lines would appear like this here:
Code: Select all140| npozuds,<.i\+qQ=f/xXh`~|-_wWjJkKmcregalv;:t!@#$%^&*()b{?[]'"SAyYVFI7}ª      |

Code: Select all141| NPOZUDs,<>i\+qQ=f/xXH`~|-_wWjJkKMCREGaLv;:T!@#$%^&*()B{?[]'"SAyYVFI7}ª      |


Just close & save the file and restart DataCAD.

Check the result. It should be working as you wish.
The numeric character you have chosen to replace 'M' ('7' in the example) is the new short-cut key to open Macros menu.

If for some reason occurs a break on the system operation, you have the option to uninstall DataCAD and install it again, since the beginning.

Note: This option to use a numeric char in the place of 'M' will function only until DC-X. From DC-XI you should look for another character.

Hope it helps.
Miguel
#12527 by GuyS
Tue Jul 04, 2006 1:37 pm
Thanks Miguel

I have a couple of urgent projects I am working on. Given your forwarning I'll get them done and try what you suggested. Thanks for your reply.
#12548 by Dick Eades
Wed Jul 05, 2006 10:44 am
Hold on a second, Miguel. In v11 we have the ability to input distances directly without first pressing the spacebar. If you replace a key command with the number 7, what happens if you want to input a distance without the spacebar and that distance begins with 7?
#12550 by GuyS
Wed Jul 05, 2006 10:54 am
The version I am using is V10. I looked at the /SUP folder and could not find the file or code Miguel is talking about. Perhaps Miguel your instructions are for V11 and above?
#12555 by joshhuggins
Wed Jul 05, 2006 11:15 am
Are you using the LT version of 10? The MSG file should be in there for the full version, not sure on LT though. Also if you have a program installed like outlook, it might have associated the file with that other program. And if your using a newer version of windows, it might not be showing file extensions of known file types.

To show all file extensions.

Double-click on the My Computer icon. Select the Tools menu and click Folder Options. After the new window appears, select the View tab. Remove the checkmark from the checkbox labeled "Hide file extensions for known file types". Press the Apply button and then the OK. Now your computer is configured to show file extensions.
#12564 by GuyS
Wed Jul 05, 2006 12:58 pm
Josh
I am using the full version 10 not the LT version. Josh, I tried your suggestion and the file did show up as you instructed. However, I don't think that I have access to the code as described by Miguel. My line 140 (140| doesn't show up) refers to a snapping point or something like that. And yes it does call it an Outlook file.
#12565 by Tony Blasio
Wed Jul 05, 2006 1:18 pm
Search for another line 140, there are two lines 140 in this file.
#12574 by Dick Eades
Wed Jul 05, 2006 5:00 pm
When I first started messing with this file, my trick for finding those lines was to do a search for "npozuds".
#12586 by GuyS
Thu Jul 06, 2006 9:34 am
Ah ha!

I found the line of code...thanks Josh. and I made the changes...thanks Miguel. And all others for persisting.
#12591 by Neil Blanchard
Thu Jul 06, 2006 11:29 am
Hello,

I tried changing both the M's to 0 -- and only the m takes me to move? (M does nothing...) I thought that it was possible to have both M and m take you to the Move menu?

Code: Select all140| npozuds,<.i\+qQ=f/xXh`~|-_wWjJkKmcregalv;:t!@#$%^&*()b{?[]'"SAyYVFI0}ª
141| NPOZUDs,<>i\+qQ=f/xXH`~|-_wWjJkKmCREGaLv;:T!@#$%^&*()B{?[]'"SAyYVFI0}ª
#12592 by GuyS
Thu Jul 06, 2006 11:34 am
If you follow Miguels instructions precisely you will find that both "m" and "M" will launch the move command. Sounds like you didn't follow his instructions accurately.
#12593 by GuyS
Thu Jul 06, 2006 11:37 am
I just noticed that you did not change the small to a cap M on line 141

Who is online

Users browsing this forum: No registered users and 10 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984