Use this forum to ask questions about DataCAD 17 and DataCAD LT 17.
#66813 by Neil Blanchard
Thu Jul 16, 2015 3:24 pm
I have been working with the GTV Link a fair bit lately, and here's the situation: it is a hotel project, and the room plans are XRef'd into the building floor plans. On many of the floors, the rooms repeat on every other floor, so I have two layers, each with the XRef's of the rooms for that floor layout.

One the top most floors, these layouts are similar, except where the Concierge Lounge and Presidential Suite are; so I copy the XRef's for the floor to a new layer, and then erase the rooms that are not used.

The issue is that even though I have GTV Link toggled on, the XRef's on the new layer are shown with different layers shown in some, from those that were shown the last time they were used.
#66849 by joshhuggins
Tue Jul 21, 2015 4:30 pm
Roger D wrote:When I erase a xref by mistake, and then ctrl-z to udo, the GTV link is turned off, but when turned back on, all the GTV liniks work.
I am seeing this with the Nesting option also in the 17.03.00.11 release build.
#66850 by David A. Giesselman
Tue Jul 21, 2015 4:40 pm
joshhuggins wrote:
Roger D wrote:When I erase a xref by mistake, and then ctrl-z to udo, the GTV link is turned off, but when turned back on, all the GTV liniks work.
I am seeing this with the Nesting option also in the 17.03.00.11 release build.

Really?
#66852 by David A. Giesselman
Tue Jul 21, 2015 7:24 pm
Dayum! I know I tested this!!! :evil:

Back to the drawing board/keyboard.

PS: One of these days, I'll grow-up and be a real programmer and only have to fix things once! (Maybe twice) :oops:

Regards,
Dave
#66853 by MtnArch
Tue Jul 21, 2015 9:00 pm
But if you do that, what would Josh do with all of his free time? :twisted:
#66858 by David A. Giesselman
Wed Jul 22, 2015 1:25 pm
joshhuggins wrote:
Roger D wrote:When I erase a xref by mistake, and then ctrl-z to udo, the GTV link is turned off, but when turned back on, all the GTV liniks work.
I am seeing this with the Nesting option also in the 17.03.00.11 release build.

Okay, got this one squashed for the next release.

Dave
#66886 by Neil Blanchard
Fri Jul 24, 2015 11:16 am
Another minor (but annoying) XRef issue is, the first time you Control-Right Click on an XRef to open the RFM - it fails to highlight the XRef.

It works every subsequent time you do this. This has been around a while, and it is not hard to work around.
#66888 by David A. Giesselman
Fri Jul 24, 2015 12:47 pm
Neil Blanchard wrote:Another minor (but annoying) XRef issue is, the first time you Control-Right Click on an XRef to open the RFM - it fails to highlight the XRef.

It works every subsequent time you do this. This has been around a while, and it is not hard to work around.

I'll post the same thing I did last time. This is due to a bug in the RTL (Run Time Libraries) of the development environment that we use. It will, hopefully, become a non-issue when we get around to updating our development software. It is not something that I can easily fix.

Dave
#66901 by Neil Blanchard
Wed Jul 29, 2015 10:59 am
As I showed at the DBUG meeting last week, I am working with a file that has lots of XRef's, and I am using GTV Link.

I have layers that have 20 XRef's and when I make one of those layers active only - it reverts to layers in some of the XRef's that are not what they were last set to, and some are. What is toggling some to show the "wrong" layers, but not all of them?

I then set each to show the correct layers by selecting the GTV in the RFM. I then copy those XRef's to another layer (I will change a few around) - and the same XRef's that were wrong, revert back to the wrong layers.
#66905 by joshhuggins
Thu Jul 30, 2015 12:18 pm
I don't have Datacad with me to double check but I think that the xref has it's main set of layers that are set at insertion time. I think you have to turn off GTV Link for that xref. Apply the layers you want to be for the non-GTV Link setting, then re-enable the GTV Link. So it's kind of like a remembered state for the xref when not being set by a GTV Link remembered state.

Who is online

Users browsing this forum: No registered users and 1 guest

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984