Use this forum to ask questions about DataCAD 17 and DataCAD LT 17.
#69688 by RBCA
Sun Aug 28, 2016 3:16 pm
Novice to Toolbar macros. Trying to create some macros that do multiple commands but want to start by setting a layer to active.
Started with A=^:^F3 This got me to Layer Menu.
Then A=^:^F3^F3 Datacad crashed.
Tried multiple times, checked for dcad updates.
What am I doing wrong?
#69689 by REX PEET
Mon Aug 29, 2016 5:52 am
If it is a Keyboard macro you want, lose the = sign
//layer on off


If you use F3, F3, you should get to the set active option, but I find it easier to scroll through the on layers with the TAB key.
#69695 by joshhuggins
Mon Aug 29, 2016 10:43 am
What you have RBCA should work. Might be some type of layer corruption in your file. Also might want to check for any orphaned temp files. With Datacad closed, delete any left over files in your Datacad\Temporary Files folder. Than test your macro in a new default file by adding about 20 layers or so. Should work there. If it still doesn't work maybe something else is not configured correctly.
#69719 by RBCA
Fri Sep 02, 2016 11:35 pm
Thanks for the comments. Read other threads similar. One said it may need to update dad. That worked.

Who is online

Users browsing this forum: No registered users and 2 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984