Use this forum to ask questions about DataCAD 18 and DataCAD LT 18.
#68307 by jimgoodman
Thu Feb 25, 2016 2:35 pm
Is it possible to redefine a Sketchup XRef with another Sketchup file from the reference manager? I have tried several times. It appears that everything is working but the new file isn't substituted.
#68308 by Roger D
Thu Feb 25, 2016 3:10 pm
Sometimes I forget to hit the "Apply" button at the bottom.
#68309 by jimgoodman
Thu Feb 25, 2016 4:25 pm
Not the case here. I even get the message asking if I want to maintain the layer, highlighting and clip cube settings

I tried this using both the reference manager and context menus. The Sketchup file is fairly large, so that could be the issue.
#68310 by joshhuggins
Thu Feb 25, 2016 5:31 pm
I wasn't going to report this because I thought it was just a weird fluke, but maybe it's related?

I had a file yesterday that I was trying to redefine an xref from one folder to another. It looked like it was working with the expected messages, but it was still showing the old drawings info and still listed the old path when I identified the xref. Here are the paths.

Working File Path
M:\Residential\2016\R16003 GMH 5848 - Lot 12 Tract 5273\5848.aec

Original Xref File Location
M:\Residential\2015\2015 Gary McDonald Base Files\30x42 Sheets.AEC

File Using for Redefine
M:\Residential\2016\2016 Gary McDonald Base Files\30x42 Sheets.AEC

So I moved the original xref file in the 2015 folder from it's location to another drive completely. I hit U in the drawing because I have the ini setting XRefs Auto-Refresh on Regen=True set and figured Datacad would see that the drawing was now orphaned and that I could redefine it, but nothing changed. The old info still remained, when I identified the xref it still pointed to the 2015 path file.

I closed Datacad completely, verified that the temp files folder was empty, restarted Datacad, opened the drawing and the file was now orphaned and I was able to redefine it where I wanted. I had to redefine the same file xrefed file for another working file later and it as expected. The working file is pretty new base file so didn't think to try a purge. Like I said not sure if it's related, but figured I toss it out there in case it is. FWIW.
#68312 by MtnArch
Thu Feb 25, 2016 5:51 pm
This is a long shot, but check to make sure that the layer that the xref is on isn't locked. I've had this happen a couple of times where I'd forgotten I'd locked the layer.

Who is online

Users browsing this forum: No registered users and 1 guest

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984