Use this forum to ask questions about DataCAD 18 and DataCAD LT 18.
#70302 by rlmorton
Tue Nov 29, 2016 8:42 pm
Loaded 19 on my laptop and the 'ctrl z' doesn't work - any suggestions? and it does work in other programs.
thanks
#70305 by MtnArch
Tue Nov 29, 2016 11:06 pm
Hmmm ... works on my V19 desktop as expected.

What were you trying to undo - a line? text? inserting a BMP? or ...?
#70307 by rlmorton
Wed Nov 30, 2016 11:24 am
thanks for your comments - seems to work fine today, guess all I needed to do was reboot the computer.
#70308 by Mark F. Madura
Wed Nov 30, 2016 11:50 am
If the [Ctrl] + Z and [Ctrl] + Y shortcuts do not seem to work, look at the Undo / Redo icons in the Standard Toolbar. If they are grayed out, there might not be anything to undo or redo.
UndoRedo.png
Undo / Redo Icons
UndoRedo.png (12.25 KiB) Viewed 3058 times
#70362 by Jim Allen
Wed Dec 07, 2016 1:50 pm
I have been finding that Ctrl z stops working a few times each day in version 19. Enough so that I have gone back to 18 today. The "undo/redo" are greyed out in the Edit menu when this happens. That is not because there isn't something to undo. I wouldn't be looking for it to work if I wasn't undoing something. This has happened in version 18 before, but not as often. Usually when I have 3 or more files open in DataCAD. Which makes it more of a nuisance to shut DataCAD down and reopen it to restore the Ctrl z to functioning. I thought maybe it was a memory issue with my computer. But it seems to be happening every day with version 19.
#70364 by jimgoodman
Wed Dec 07, 2016 2:02 pm
Jim Allen wrote:I have been finding that Ctrl z stops working a few times each day in version 19. Enough so that I have gone back to 18 today. The "undo/redo" are greyed out in the Edit menu when this happens. That is not because there isn't something to undo. I wouldn't be looking for it to work if I wasn't undoing something. This has happened in version 18 before, but not as often. Usually when I have 3 or more files open in DataCAD. Which makes it more of a nuisance to shut DataCAD down and reopen it to restore the Ctrl z to functioning. I thought maybe it was a memory issue with my computer. But it seems to be happening every day with version 19.


I had this happen this morning as well - I was fiddling around with Self XRefs at the time.
#70365 by Mark F. Madura
Wed Dec 07, 2016 2:21 pm
Undo_Redo.png
Undo/Redo Menu
Undo_Redo.png (5.22 KiB) Viewed 2978 times
Are the undo/redo items in the Edit pull-down menu disabled also?
#70366 by Mark F. Madura
Wed Dec 07, 2016 2:36 pm
I would be curious to know if the Undo Buffer is getting cleared when the Undo / Redo icons stop working.

You can enable the Undo History by setting the key, ShowUndoHistory, to TRUE in the [DEBUG] section of DCADWIN.ini.

[DEBUG]
ShowUndoHistory=TRUE

When set to TRUE, you'll find a new menu item, Show Undo History, on the Edit pull-down menu. You can then select this menu option to display a modeless dialog of the Undo History. So I'd like to know if this history gets cleared when the Undo / Redo shortcuts 'break.'

Show_Undo_History.png
Show Undo History
Show_Undo_History.png (6.83 KiB) Viewed 2974 times
Undo_History_Dialog.png
Undo/Redo History Dialog
Undo_History_Dialog.png (19.09 KiB) Viewed 2974 times
#70368 by Jim Allen
Wed Dec 07, 2016 3:54 pm
Here is what I could capture after the Ctrl z stopped working. This is in version 19. What should I look for in the Undo History to see if the undo buffer is clearing if it is not shown in the image.

I didn't realize this thread is in the 18 forum. I did a search before to see if the issue came up and this is where I landed.

Capture.PNG
#70371 by Mark F. Madura
Wed Dec 07, 2016 5:09 pm
Dave has found and corrected the error that can cause the undo system to get suspended after you open then close the Layer Manger or set a perspective view. The fix will be available in the next update to DataCAD 19.00.01.

Sorry for the inconvenience,

MFM
#70372 by Jim Allen
Wed Dec 07, 2016 5:16 pm
We will see. I don't think I do either of those two things before the undo stops working. I open the layer manager and very rarely ever close it. No reason to unless it's blocking what is under it. And I haven't set any perspectives in a long time. But I hope it gets fixed. Undo just stopped again about a half hour ago right after I turned all the layers on in a drawing to see where an entity belonged.
#70373 by David A. Giesselman
Wed Dec 07, 2016 5:28 pm
Jim Allen wrote:We will see. I don't think I do either of those two things before the undo stops working. I open the layer manager and very rarely ever close it. No reason to unless it's blocking what is under it. And I haven't set any perspectives in a long time. But I hope it gets fixed. Undo just stopped again about a half hour ago right after I turned all the layers on in a drawing to see where an entity belonged.

Jim:

It's not the closing of the Layer Manager that triggers the loss of Undo. If you use the persistent Layer Manager, merely turning layers On and/or Off can do it. In the non-persistent Layer Manager, clicking Apply can do it. Essentially anything that causes the Layer Manager to force a Redraw to the drawing window can trigger it.

I'm pretty confident that the problem I found is the cause for the loss of Undo.

I too am sorry for the inconvenience.

Dave
#70374 by Jim Allen
Wed Dec 07, 2016 5:31 pm
That sounds likely. When I'm jumping from one view to another a lot, that would trigger it.
#70375 by jimgoodman
Wed Dec 07, 2016 5:44 pm
Jim Allen wrote:That sounds likely. When I'm jumping from one view to another a lot, that would trigger it.


That is consistent with what I saw this morning.

Who is online

Users browsing this forum: No registered users and 2 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984