Page 1 of 1

Rounding Error? ...or just a setting?

PostPosted: Sun Sep 17, 2017 12:53 am
by Ted B
I have a large drawing file of an office building's roof that I'm laying-out a mega-watt PV Panel array on. Typically in an Architectural-scale Datacad file the precision minimum is 1/32". For a reason I don't understand it's dimensioning only in 1/2"-increments. Under other conditions I would love to be able to limit large-scale drawings to the nearest 1/2", but in this case I need atleast 1/16" or my typical 1/32" precision; which is the file's "setting".

I'm trying to dimension symbols I created for the array components. In a clean file the symbols dimension correctly, but inserted into the file they only dimension to the 1/2". I can work around this, but I'm wondering why. And can I recreate this for other large-scale drawings in the future where I really only need 1/2"-precision or even a larger increment. (If it's just this file, I might just purge it and save it for a future-use template. A bad habit of mine reusing old drawing files as templates...)

The building's outline originated as a Datacad file drawn in Engineering-scale with compass angles. (decimal feet to 2 significant numbers.) I just file-copied the original file and deleted the unnecessary parts and changed the setting to Architectural and angle-degrees CCW. That way I preserve the layer's and their individual settings and colors.

I haven't tried edit-copy the entire drawing contents and paste into a new clean blank file yet. That may be my first work-around...

Re: Rounding Error? ...or just a setting?

PostPosted: Sun Sep 17, 2017 12:40 pm
by Roger D
Have you checked the dimension rounding setting?

Re: Rounding Error? ...or just a setting?

PostPosted: Mon Sep 18, 2017 2:23 am
by Ted B
I have already tried changing the Scale-Type to Engineering and back to Architectural. And I tried changing the 1/32"-1/64"-1/128th setting in Architectural, and the Significant-Digits in Engineering. I also tried dimensioning on other layers, it seems to be global to the file. I can work around it, and in other-ways dimensional rounding to the 1/2"-increment would be desirable. I'd just like to be able to control it. If I really need to, I'll copy-paste the drawing file's contents into a clean file.

Could it be related to I'm dimensioning inserted symbols? ...And the distance between them?

Re: Rounding Error? ...or just a setting?

PostPosted: Mon Sep 18, 2017 6:35 am
by David A. Giesselman
As Roger wrote, check the Rounding toggle in the Dim Style menu.

rounding.JPG (19.81 KiB) Viewed 4433 times