Use this forum to ask questions about DataCAD 19 and DataCAD LT 19.
#71763 by Mark Wilhelm
Fri Jun 30, 2017 11:21 am
I've been having trouble with ctrl-rtclick on Xrefs: doing it - repeatedly - fails to bring up the menu, which mainly means I can't set, change or turn on/off Xclips, or the other functions available only through that menu. This tends to happen more in drawings with a lot of Xrefs than in those with few, but has happened in drawing files with only a single Xref. Even closing/saving the drawing, exiting and restarting Dcad, doesn't solve the problem. Any help, here?

#71764 by joshhuggins
Fri Jun 30, 2017 11:42 am
Not seeing anything like that here. Do you continue to hold Ctrl while waiting for the menu to appear or do you just tap and release it right after the right click? Do you have nesting turned on, that can slow down the response time.
#71765 by Mark Wilhelm
Fri Jun 30, 2017 11:53 am
I've done it both ways, and more. Even tried holding down both Ctrl keys. Sometimes it works, just as expected. Sometimes, like just before I posted this, I do it twelve, fifteen times, using every variation of pushing, holding, clicking I can think of. Then, right after posting, it worked. Go figure. I have a site plan, created 14 years ago, with AS-Built surveys from the civil engineer added as Xrefs, and also Xrefs of outline plans of the many buildings, so there are a lot of Xrefs. But the function should work every time, shouldn't it?

Thanks, Josh,
#71767 by Mark Wilhelm
Fri Jun 30, 2017 12:16 pm
David, hi, I probably could dig one up somewhere, but please, the control keys work fine both in DataCad and in other software. Ctrl-rtclick on other entities always brings up the appropriate menus, no fails there - unless, of course, I'm not positioning the cursor correctly. :oops: But I'm pretty sure this is neither a keyboard problem or user error.

#71768 by David A. Giesselman
Fri Jun 30, 2017 12:25 pm
Sorry Mark, I didn't see in your previous posts that the [Ctrl]+Right-click was functioning properly for other entities.
#71921 by ORWoody
Tue Jul 25, 2017 8:16 pm
If you are wanting access to the "new clip or clip On/Off" choices, just go to DCADWin.mnu and put some rarely used key linked to the control key in the line for ClipCubes. Use something like [Ctrl+q]. That way, you'll go directly to the function that you need and won't have to make several drop down selections.
I use that several times each day and really like clip cubes better than I would if I had to pick and pick to get there.
Good luck,
#71923 by Mark Bell
Tue Jul 25, 2017 9:00 pm
Hello Mark W

I have also had this issue in the past with opening the XRM. Same description as you and eventually I could get it to open. I recall sending a post or two about it (maybe v17-18?). It's rare and hard to trace the cause. A reboot of the pc may help?

Who is online

Users browsing this forum: No registered users and 2 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984