Use this forum to ask questions about DataCAD 19 and DataCAD LT 19.
#72661 by DavidBergman
Thu Nov 09, 2017 3:35 pm
I suspect this question has been answered before, but I couldn't find it in a search just now. I'm trying to draw on top of an imporrted bitmap (a jpg), and the lines/objects keep disappearing under the bitmap. Not all of them, and I can't figure out a pattern to it. I've drawn the lines on a separate layer as well as trying it on the same layer as the bitmap. I've tried playing with Layer Order in the Display menu as well as in Layer Manager. Typically, when I draw on top of the bitmap, the lines are visible until I hit Esc/Regen. Then SOME of them will disappear.

Thanks.
#72663 by melina
Thu Nov 09, 2017 4:04 pm
I can only give advice for the following setting: Display>Layer Order>Last

The trace lines have to be drawn on one of the layers after the layer the bitmap is on. For example:
Layer 15 - bitmap
Layer 16 (or 17, 18, etc.) - lines

If the lines are on a layer before the bitmap layer (in this example, say, Layer 13), the lines will only be visible if that layer is the active layer.
#72669 by REX PEET
Fri Nov 10, 2017 1:36 am
I have tried with different layer orders and come undone every time. I find the easiest way is to draw on the same layer as the bitmap and then move the work to its final layer
#72674 by DavidBergman
Fri Nov 10, 2017 12:42 pm
So far, I think Rex's reply is the one that works. Per the other suggestions, I've tried every variant of layer ordering and layer management, and none of them yield anything like a consistent result. The odd(er) part is the inconsistency. Sometimes entities on other layers will appear and sometimes they won't. Then they may re-appear after fiddling, only to disappear again. This happens even with objects on the same layer.
#72677 by Ted B
Sat Nov 11, 2017 3:03 am
I've usually placed the bitmap's layer "below" the active-layer when drafting-over a bitmap. Often the line-color on the active-layer inverts in-contrast-with the bitmap below it. Also after zooming-in, I typical regen <shift-u> to reset the the display-list's screen-image to place the active-layer on-top-of the bitmap's layer.
#72682 by DBrennfoerder
Sun Nov 12, 2017 4:35 pm
One of the first things I do in any project is make sure "display-layer order" is set to "in order". That makes DataCAD to the regen in layer order sequence. Then I make sure that I insert any images on low-number layer ("top of the list"} so that they are put on screen first, and my work, especially my active layer, is drafted later, and always appears on top of the image.
#72811 by artmanvt2000
Mon Dec 04, 2017 3:52 pm
It works for us to do it the way DBrennfoerder recommends.

Who is online

Users browsing this forum: No registered users and 2 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984