Use this forum to ask questions about DataCAD 19 and DataCAD LT 19.
#72944 by Clay Rogers
Wed Dec 20, 2017 8:25 pm
Last week we received troubling reports from several DataCAD firms who were unable to open any of their drawings without an immediate crash. The temporary file ($WP) was being created, but the drawing would only flash on the screen for a split second before crashing. There was no error message displayed. In one case, the customer couldn't even create a new drawing. Each customer is running a different version of DataCAD (15, 17, & 18).

They all shared a couple of things in common: Each firm has multiple licenses on DataCAD and access their drawing files from a file server, and they all are running Windows 7 on their workstations.

What we discovered is that they all started experiencing the problem after installing a recent update to Windows 7.
https://support.microsoft.com/en-us/help/4054518

After backing off the Windows 7 update, their DataCAD operation returned to normal.

If you are running DataCAD on Windows 7 and you suddenly are unable to open any of your drawings, check your recent Windows updates to see if "December 12, 2017—KB4054518 (Monthly Rollup)" or "December 12, 2017—KB4054521 (Security-only update)" was installed. If so, remove the update and see if your DataCAD returns to normal operation.
#72951 by artmanvt2000
Fri Dec 22, 2017 8:41 am
Clay,

Thanks for finding a solution. Please note that one needs to follow the steps below after the uninstall.
1) Uninstall the update.
2) Reboot
3) Go to the Start Menu and type in "Windows Update".
4) Search for updates.
5) Locate the updates referenced in Clay's post.
6) Uncheck the updates, then right click on the update and select "Hide".
7) Close the Windows Update.

If the "Hide Update" is not done the update will only re-install later.
#73054 by Neil Blanchard
Wed Jan 10, 2018 2:26 pm
Alrighty then - there was another update - and I decided to try installing that - and it now works! No crash with the Symbol Browser. This last update is:

Microsoft .NET Framework 4.7.1 for Windows 7 and Windows Server 2008 R2 for x64 (KB4033342)

Update type: Recommended

The Microsoft .NET Framework 4.7.1 is a highly compatible, in-place update for all the previous versions of .NET Framework 4.X. After you install this update, you may have to restart your computer.

More information:
http://support.microsoft.com/kb/4033342

Help and Support:
http://support.microsoft.com


The previous update that caused the crash - until the NET update:

2018-01 Security and Quality Rollup for .NET Framework 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 on Windows 7 and Server 2008 R2 for x64 (KB4055532)

Update type: Important

A security issue has been identified in a Microsoft software product that could affect your system. You can help protect your system by installing this update from Microsoft. For a complete listing of the issues that are included in this update, see the associated Microsoft Knowledge Base article. After you install this update, you may have to restart your system.

More information:
http://support.microsoft.com/kb/4055532

Help and Support:
http://support.microsoft.com
#73056 by artmanvt2000
Thu Jan 11, 2018 8:35 am
Neil,

Thanks for the information. It appears the Microsoft has fixed the conflict with the previous KB405____ updates. I re-installed the previously removed updates, after installing all the recent updates. Datacad has be working fine since.
#73059 by artmanvt2000
Thu Jan 11, 2018 11:43 am
Update, my Datacad also started crashing with the opening of the Symbol Browser. Removed Windows Updates KB4056894 and KB4051034. After the removal of the updates and several restarts, Datacad is opening fine.
#73069 by Neil Blanchard
Fri Jan 12, 2018 1:20 pm
Things are unsettled, for sure. I was in a drawing, and opened the SB - and the drawing crashed. I then reopened the drawing (leaving the SB open) and it opened fine, without any error message. I had just saved (thankfully) and lost only one thing.

Since then, it has been fine.
#73072 by joshhuggins
Fri Jan 12, 2018 6:45 pm
Maybe you have some funky symbols going on? Maybe try setting
Code: Select all[DEBUG]
Audit Symbol Files=True
And browsing around your symbol folders to clean things up?

Who is online

Users browsing this forum: No registered users and 2 guests

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.

DataCAD

Software for AEC Professionals Since 1984