Use this forum to ask questions about DataCAD 18 and DataCAD LT 18.
#68841 by David Porter
Sun May 08, 2016 6:40 pm
Call me "Old school" but I use DCAD with on-screen line weights instead of using colors and pens to determine line weights. Just found with the latest version of 18 that there is less definition of the on-screen line weights. I don't know if this is a Windows 10 issue or a DCAD issue. Sure would like to get the line weights to show up on the screen again like they used to.

Below is a screen shot of what I am seeing on screen. Line weights 1 and 2 appear exactly the same. When I do a plot preview, line weight 2 does show up slightly heavier than line weight 1 (as should be noticeable on the screen and it is not).
#68844 by Paul Nida
Mon May 09, 2016 8:57 am
There is a line in the DCADWIN.INI file for Old Line Weights=True or False. You might want to check that, I am not sure what it does since I have never played with it.
#68845 by David Porter
Mon May 09, 2016 9:47 am
Change the ini setting to TRUE and that seems to have fixed the on-screen lineweight showing.

Thanks, guys.
#68861 by ROBERT PENN
Tue May 10, 2016 7:39 pm
I am finding the inverse problem.

I don't use line weights, but since updating to the latest version of Datacad some of my lines are printing line weights - even though line weights are turned of in the swothlud menu.
#68862 by ROBERT PENN
Tue May 10, 2016 7:53 pm
To clarify my above comment. I don't normally assign line weights, as I always have them switched of in the display. However I have just checked and some of my lines do have a weight assigned to them and even though the display is turned of, they are coming up in the print view (and plotted sheet) in the latest Datacad update.
My simple solution was to change all line weights within my drawing to the value of 1 and that solved my problem, although not the reason why it is happening in the first place.
Sorry this doesn't help you David with your problem.
#68868 by ROBERT PENN
Tue May 10, 2016 10:39 pm
A fix will be needed for this problem!
While it is easy for me to turn all layers on and change all entities to a line weight of 1 globally, this obviously doesn't extend down into the lineweights of the symbols!!
I have to go into each and every symbol to change the line weight to 1. (and this would be in every file as the symbols are embedded into each and every drawing)

It is probably a switch in an ini file or something that has changed in the latest upgrade that now prints these line weights when previously they didn't print, even when the lineweight is turned of on the screen.
#68873 by Roger D
Wed May 11, 2016 7:21 am
might be part of the change to program preferences Misc tab. Go there and uncheck the Line Weights under Print/Plot Options.
#77659 by joeferguson
Thu Feb 27, 2020 11:44 am
Is this the correct forum to start a new thread with the same concern?

Using DC 21 since Dec 2019. Easy conversion from 17, everything worked fine, including line weight display right up to Jan. 22 near as I can figure.

In my latest project, (which is due today) I went to change a few line weights to give certain objects a little better definition and the weights do not display on screen, or on the printed page. When I do an alt-I, the weight is indicated as changed (from 1 to 2 and/or 5) but doesn't display on screen. I opened my Jan 22 project and line weights display just fine on screen.

I have checked Display and Line Weights are toggled on. I have not been near the .ini files with the new DC.

What could have possibly changed in a month? What could I have possibly toggled inadvertently?



Who is online

Users browsing this forum: No registered users and 1 guest

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984