Use this forum to ask questions about DataCAD 20 and DataCAD LT 20.
#74052 by ROBERT PENN
Tue Jun 05, 2018 8:38 pm
Hi all,
I'm having trouble with my symbol attribute editor.
I'm not getting the prompt column to the left of value column. So I can add the values that I need, but I can't see the prompt to see where I am adding those values.
There is a vertical scroll bar to move the table up and down, but no horizontal scroll bar to move left to see the prompt.

I suspect its a display problem on my computert and not Datacad per se, but I have no idea how to fix this.

Can anyone point me in the right direction?
Screenshot 2018-06-06 11.32.07.png
#74054 by ROBERT PENN
Wed Jun 06, 2018 12:35 am
Hi Josh,
Thanks for that feedback.
I just tried that to no avail. If I stretch the right side it just adjusts the width of the Value column.
I can't stretch the left side of the value column as it is right on the left hand side of the dialogue box.
I can only left stretch the dialogue box which in turn stretches the value column with it.
Nothing "snapping" into place!! :(

Thanks for feedback anyway! :D
#74065 by ROBERT PENN
Wed Jun 06, 2018 6:00 pm
Hi David,

Thanks for the suggestion.
I have already tried this and no, it doesn't make any difference!
Seems like I have tried everything I can think off and nothing works.

This has sort of been happening for months. Prior to the last update the dialogue box would open like the image above, but there was a scroll box to move to the left to see the prompts, but since the last update the scroll bar has disappeared. This happens on both my desktop (Win 7 Pro) and laptop (Win 10 Home), so i don't think it is computer problem. Prior to the last update I could scroll to see the prompts, but as soon as I started typing in the attribute, the prompt column would disappear again and I'd have to scroll across to see the next prompt for the next entry.

Weirdly, on a different symbol, prior to the update, the attribute box will open and there is only one attribute available to amend in the symbol, the top menu will be visible, but the amendable attribute line would not be visible and I couldn't pull the bottom of the dialogue box down to see it. So I'd type in the attribute blindly, close the dialogue box and see the symbol on the screen with the correct information. I've been able to persevere with that one when there is only one input I have to make. Since the latest update however, this particular symbols attribute box opens up the same, but now I can pull down the bottom of the box to see what I am writing! So the inverse of the symbol above!

It seems that depending on the symbol picked, the type of problem is different!
#74066 by joshhuggins
Wed Jun 06, 2018 6:30 pm
Give this a whirl. With Datacad closed, locate your ..\Support Files\User Interface\DcadwinDialogs.gui file. Cut the file and Paste it to your Desktop. Restart Datacad and test it out. Datacad should create a new fresh copy of the DcadwinDialogs.gui file once you open/close a new dialog window like the symbol attribute dialog. If it works, your Datacad windows will default back to their original locations for the first time they are used and then will remember their states going forward . This is probably the simplest fix (if it works for you).
#74067 by ROBERT PENN
Wed Jun 06, 2018 7:04 pm
Thanks Josh,

I just tried that and no difference :(
Interestingly though my file was not at:
Support Files\User Interface\DcadwinDialogs.gui

I don't have the "User Interface" directory. My file was at:
Support Files\DcadwinDialogs.gui

Would this be creating a problem?
#74068 by joshhuggins
Wed Jun 06, 2018 7:16 pm
Hmmm could be. In the Program Prefs, on the Pathnames tab, at the bottom of the list, see what User Interface Files (.GUI) shows for the path. If it's set to Support Files\ it should be fine I would think using that as I think that was the original path several major versions ago but somewhere along the line the User Interface folder was added. Maybe it's hard coded in somewhere now and causing that issue? Maybe not. The big boss man would have to chime in on if that path is still valid. Might want to create the User Interface folder and set the GUI path to that location. The 3 files currently living in my ...\Support Files\User Interface folder are.

#74069 by ROBERT PENN
Wed Jun 06, 2018 7:28 pm
Thanks Josh,
As always your thoughts and ideas are helpful, at least we are exhausting all options!

However, just tried setting up the User Interface directory and moved the 3 files to there.
Amended the Pathname in the Program Pref's and still no change! I might leave the new "user interface" directory in place and see how I go in the future.

So still looking for a solution!

Can the big boss at Dcad shed any light or options to try?
#74070 by ROBERT PENN
Wed Jun 06, 2018 7:46 pm
Ok. I am trying to figure out why this is happening!
Thought I'd try and recreate the symbol from scratch - sort of!
I exploded the old symbol and then re-created a brand new symbol from the entities (ie I didn't redefine the old one!)
No difference to the attribute box. This symbol has multiple text attributes attached to it. If I recreate it with only the one attribute it reverts to the other example I had above with only one attribute, ie I can see the prompt and attribute columns, I just need to pull the bottom of the box down to see the entry row to enter my info.

So in summary it seems if there are multiple text attributes attached to the symbol I don't see the prompt column, but when there is only one text atribute I can see the prompt coloumn but need to pull the dialogue box down to enter info.

Does that make sense?
#74071 by joshhuggins
Fri Jun 08, 2018 1:02 am
Well I just did a fresh install and the default install had the GUI files in the Support Files folder the same as you had so I must have created that User Interface folder sometime back myself, sorry. Not sure what else to try to get you fixed up.
#74087 by ROBERT PENN
Mon Jun 11, 2018 5:49 pm
Thanks Josh,

I don't know what the answer is either.
Guess I just gotta persevere!
#74089 by ROBERT PENN
Mon Jun 11, 2018 7:14 pm
Aah great,

I must've missed that chapter. I knew Dave mentioned a bug in my xref problem but not this one!

Who is online

Users browsing this forum: No registered users and 1 guest

About DataCAD Forum

The DataCAD Forum is a FREE online community we provide to enhance your experience with DataCAD.

We hope you'll visit often to get answers, share ideas, and interact with other DataCAD users around the world.


Software for AEC Professionals Since 1984