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DataCAD Plus vis helps you to visualize and present drawing 
projects you created using 3D models or ZAC.  

You can furnish your project, select different surface treatments 
and colors, and experiment with different materials. Using drag-
and-drop, you can take items from an extensive catalog, 
reposition and resize them, and put them into your project. You 
can even install landscaping features to complete your project. 

DataCAD Plus vis allows you to see how your project will look 
during different hours of the day or night. You can also control 
interior light fixtures. 

You can walk through your project, videotape the tour, and play 
it back later. 

 

In this chapter: 

± Start vis 

± ArCon+ and ArCon-
Explorer windows 

± Icons 

± Sounds 

± Preview window 
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Starting DataCAD Plus vis 
The DataCAD Plus vis program is a scaled-down version of ArCon. It allows you to 
see your project come to life on the screen. However, since DataCAD Plus vis does 
not use the complete ArCon program, some icons do not function and appear as 
inactive or gray on your screen. To work with DataCAD Plus vis, you need to 
display a 3D model or ZAC project. 

DataCAD Plus vis can only be started from within DataCAD Plus. You cannot run DataCAD 
Plus vis as a stand-alone program. To access an existing (saved) DataCAD Plus vis project, 
start a new (or existing) drawing and launch DataCAD Plus vis from within DataCAD Plus. 

Before leaving DataCAD Plus and entering vis, it is a good idea to place a large slab 
beneath your structure. For convenience, you may want to put the slab in a separate 
layer in DataCAD Plus. In the vis program, the slab will serve as the ground level 
for your project. This ground slab will be useful for shadow studies and serve as a 
base for landscape objects (such as fences, trees, and swings). 

è To start DataCAD Plus vis: 

1. Display a 3D model or ZAC project. 

2. Select DataCAD-plus vis from the View pull-down menu. 

3. Choose Start. DataCAD Plus vis is loaded and prepares the 3D view of your 
drawing. This may take more than a minute if you are working on a complex 
project.  The project appears in an ArCon+ Visual Architecture screen. 

You can treat each active layer as an independent component or you can see the 
entire project as a group. This allows you to experiment with the entire project or 
individual components and make changes (such as selecting different colors or 
textures or relocating things) without altering your actual DataCAD Plus drawing. 
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The ArCon+ and ArCon-Explorer Windows 
Two ArCon+ windows appear when you start DataCAD Plus vis. The main 
ArCon+ window lets you view the project; the ArCon-Explorer window displays a 
catalog of objects, textures, and materials. 

The main ArCon+ window includes a pull-down menu bar and three icon bars that 
let you control the views. The icons in the top horizontal bar pertain to the entire 
project. Those in the lower horizontal bar can be used to adjust the settings for the 
window; change viewpoints, directions, and daylight; and control animation and 
sounds. The icons on the vertical bar let you work with your furnishings and lights. 

You can access the context-sensitive, on-line help by selecting topics from the pull-
down menu bar or by clicking on  in the upper horizontal icon bar. The icon adds 
a question mark to your cursor and gives you a detailed description of any menu 
item, icon, or window area you select. 

You can separate the ArCon-Explorer window from the ArCon+ window and place 
it anywhere on your screen. To show or hide the ArCon-Explorer window, click on 
the  icon. 
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The DataCAD Plus vis ArCon+ Window 

Message Display 
At the bottom of your ArCon+ window, there is a message bar. It displays 
information about the icon or menu option your cursor is over. 

Icons 
By clicking on the icons, you can perform various operations. As you pass your 
cursor over each icon, the Message window at the bottom of the ArCon+ window 
explains how that icon will perform. You can only click on active icons; inactive 
icons appear gray and cannot be used. 

There is a small black triangle in the lower right corner of some icons. When you 
click on the triangle or rest your cursor on these special icons, several more icons 
appear. These extra icons give you more options. Simply click on the icon that 
performs the operation you want. 

When you right-click on some icons, a dialog box appears. You can fine-tune your 
display by making selections or adjustments in these dialog boxes and clicking on 
OK to implement them. 

If the resolution of your screen doesn’t allow you to display all the icons, you can relocate 
them by positioning your cursor between two icons. When the cursor changes to a hand, you 
can reposition those icons with your mouse. DataCAD Plus vis offers this option only when 
the complete icon bar cannot be seen. 

Upper Horizontal Icon Bar 
The icons in this bar never change. However, some of the functions they initiate are 
not available if an icon is gray. The functions the icons in the upper horizontal menu 
bar initiate include: 

• working with files – this includes opening , saving , printing to paper  
or file , and changing the view  

• using undo/redo  – this takes you backward or forward step by step 

• zooming – this lets you enlarge  or shrink items or display everything  
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• showing/hiding things – this applies only to the landscape  in DataCAD 

Plus vis. The grayed icons (including transparencies from other file types , 

wall shadings , the interior arrangement , inscriptions , dimensions 

, and cuts ) are not available in the DataCAD Plus vis version of ArCon. 

Showing the landscape  is helpful when you are placing objects. When you use a 3D 
plan elevation view, you can easily check the relative height and position of objects. 

Lower Horizontal Icon Bar 
The icons in this bar let you work with and experience your project. If an icon has a 
black triangle in the lower right corner, you can select from the pull-down options 
offered. The functions these icons initiate include: 

• working with views – 2D , colored 3D , 
or perspective  view 

• displaying several versions of wire frame viewing modes or colored textures 
 

The various display options affect not only the quality of your viewing mode, but also the 
processing speed. The wire frame mode is the quickest and most abstract display, while the 
high-quality colored version takes the longest. 

• raytracing  – simulates lighting conditions, including shadows, reflections, 
and refractions 

• walking through  a project 

• adjusting for time of day  

• playing and recording the show or creating still images  

• going up  or down  one floor 

• changing the observer’s viewpoint  - you can click and release (slow motion) 
or continue to hold down (rapid movement) each arrow to move your drawing 
in a certain direction 

• defining the viewpoint  - this lets you save a viewpoint 
with a particular name so that you can use it again later 
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Vertical Icon Bar 
The icons in this menu give you access to editing functions: 

• selecting , grouping , or ungrouping  items 

• copying  

• deleting  

• rotating around the X axis  

• rotating around the Y axis  

• rotating around the Z axis  

• rotating freely around the Z axis  

• restoring selected objects and/or groups to their original position  

• reflecting or mirroring objects  

• aligning objects  

• turning the lamp on or off  

• calculating an optimal color palette for a colored view  - this icon only 
appears if your computer is set up to handle 256 or fewer colors to save 
processing time and memory 

When you run Windows in 256-color mode (indexed color), DataCAD Plus vis reduces the 
colors for the rendered pictures in the view. This technique (called dithering) produces 
something like a newspaper picture. It calculates images very quickly; however, the 
appearance is seriously degraded. If you’re running Windows in High Color or True Color 
mode, this icon doesn’t appear. 

If this icon appears on your vertical bar, you can calculate an optimal color palette for a 
specific colored view. This affects only the current view in the window. All other views and 
Windows applications may appear with distorted colors. You can find out more about 
upgrading your color display in the reference material that came with your Windows software 
or your video card. 

Pull-down Menu Bar 
DataCAD Plus vis supplies pull-down menus that you can use instead of clicking 
on icons. Some options are available only from the pull-down menus. Many of the 
dialog boxes you see when you right-click on an icon are available from the 
Program pull-out menu under Options. 



The DataCAD Plus vis ArCon+ Window 

 Introduction to DataCAD Plus vis /  7

Keyboard Shortcuts 
Many DataCAD Plus vis capabilities are just a keystroke away for those who are 
most comfortable using their keyboards. Throughout this manual, we refer to 
keyboard shortcuts you may use to accomplish certain tasks. For your convenience, 
a list of the keyboard shortcuts appears in the Appendix. 

Toggle Switches 
Some icons act as on/off toggle switches. This is particularly true for the show/hide 
icons located on the upper horizontal bar, the recording/playback options on the 
lower horizontal bar, and the light on/off switch at the bottom of the vertical bar. If 
a toggle option is unavailable or inactive, its icon will be gray. 

Sounds 
DataCAD Plus vis can make sounds if your PC has a sound card. For example, you 
can hear doors open and close or footsteps during walk-through. But you can 
disable these sounds if you don’t have a sound card, if they are distracting, or if you 
want to increase speed during walk-through. Generating sounds requires CPU 
cycles and can slow down the graphics; turning off the sounds assures the fastest 
possible display and rendering speed. 

è To turn sounds off: 

1. Select Options from the menu bar. 

2. Slide your cursor to display the Program options. 

3. Choose Sounds to display a dialog box. 
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4. Click in the circle beside “without sound effects” to turn all sounds off; select 
“with sound effects” and click in the appropriate check box to turn off some 
sounds but still hear others. 

5. Click OK or press [Enter]. The choices you made are now in effect. 
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Working with Files 
DataCAD Plus vis allows you to use icons, selections from the menu bar, or 
keyboard shortcuts to manage your project files. 

è To open a file: 

1. Click on the  icon, select Open from the File menu, or use the keyboard 
shortcut [Ctrl] + [O]. The Project load dialog box appears. 

2. Double-click on the file with an .acp extension that you want to open. If 
necessary, you can look in other folders or use an extension other than .acp. 

è To save a project file: 

1. Click on the  icon, select Save from the File menu, or use the keyboard 
shortcut [Ctrl] + [S]. The Project save dialog box appears. 

2. Select the folder where you want to store this project. 

3. Supply a file name. DataCAD Plus automatically adds the .acp extension. You 
can use long (up to 256 characters) file names. 

è To change save options: 

1. Right-click on the  icon. Alternatively, from the Options menu, select 
Program, then choose Save. The Save dialog box appears. 

 

2. Select the exit option that suits your needs. DataCAD Plus recommends that 
you select the Always ask option. 
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3. Change the automatic save time by using one of the increase/decrease arrows. 
To remove the automatic save feature, click in the box until the checkmark 
disappears. DataCAD Plus recommends that you use the automatic save 
feature since it is very fast and will not interrupt your work. This feature gives 
you added security in case of a power outage.  

If you didn’t exit the DataCAD Plus vis program properly (for example, because of a power 
outage), you are given the option to restore your project and rename it. Saving your project 
with a new name is recommended just in case you experience another power outage and the 
vis program ends abruptly once more. 

4. Check or uncheck the Create backup copy (with the .bak extension) when 
saving box. 

This lets you revert to a previous copy of your project if you have done something drastically 
wrong. Of course, you should immediately rename the *.bak file. 

5. Click OK or press [Enter] when you are finished. 

è To automatically print a paper copy of a file: 

1. Click on the  icon. This sends your project directly to the printer. 

è To control print options: 

1. Right-click on the  icon. The Print options dialog box appears. 
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2. Click in the circle in front of print options you want. 

3. Choose Printer setup to change your Windows printer/plotter, control paper 
size and source, and select the correct orientation. If further fine-tuning is 
necessary, click on the Properties button. For detailed instructions on setting up 
your printer, refer to the manual that came with your machine. 

4. Click OK to accept the decisions you made for each dialog box. 

This changes your print options and/or printer setup; however it does not send a copy of your 

project to the printer. To print your project using the new settings, left-click on the  icon. 

è To print your project using two other methods: 

1. Select Print from the File menu or use the keyboard shortcut [Ctrl] + [P]. These 
options bring the standard Windows Print dialog box to your screen. 

2. Make appropriate selections in the Print dialog box. If necessary, make further 
changes by clicking on the Properties button and working with the options 
presented in the printer’s tabs. 

3. Click OK to accept changes you made on each dialog box and print the file. 

è To save a picture to a bitmap file: 

1. Click on the  icon. The Picture save dialog box appears. 

2. Select the folder or computer/network drive where you want to store your 
picture. 

3. Give the picture a file name.  

4. Select Save or press [Enter]. 

è To change the Save picture options: 

1. Right-click on the  icon or select the Options pull-down menu, then Program, 
and Save picture. The Save picture dialog box appears. 

The options in the Sketches (2D Views) box are not available in DataCAD Plus vis. 



Working with Files 

 12 / DataCAD Plus vis 

 

2. Select the appropriate 3D Views size options. (“Same as view” is self-
explanatory; “arbitrary, same aspect ratio as view” means that if you change the 
width, the height will adjust automatically to the maintain the correct 
proportions; “Arbitrary” lets you control both the pixel width and height ). 

3. Change the Color table options if necessary. (The “Indexed color” option is 
good if you want to send your picture to a client via the internet or www.)  

4. Change the Oversampling options if necessary. For the best results, DataCAD 
Plus vis recommends that you use oversampling and click to enable Edge 
filters. 

Oversampling internally measures each pixel against its neighbors, adapting the display and 
colors accordingly. This improves the quality of your picture and intensifies colors. 

Enabling Edge filters tries to smooth out jagged edges in your picture. It takes little computer 
time to do this. You get the best results by using both Edge filters and Oversampling. 

5. Enable Raytraced if necessary. This lets you render the saved picture using 
raytracing. 
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Enabling Raytraced can significantly increase processing time since it simulates shadows, 
reflections, and refractions. For example, if the normal display is so fast that you can walk 
through your dwelling in a "real-time" manner, calculating a raytraced picture will require 
several minutes or even hours. The very realistic view of the scene makes up for the time 
disadvantage. 

6. Click OK or press [Enter] to accept and activate these options. 

è To open a new view: 

1. Click on the  icon. The new view appears immediately. 

è To control the New view options: 

1. Right-click on the  icon. The New view dialog box appears. 

 

2. Select the appropriate options by clicking in the circles or boxes to control the 
type of window, view, and lighting. 

3. Click on OK or press [Enter] to accept and implement these changes. 

è To update your project in vis based on changes you made in DataCAD Plus: 

1. Start with a project that you want to change in your DataCAD Plus vis window. 

2. Switch to DataCAD Plus. 

3. Make changes (deletions, additions, etc.) in the project. 
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4. Select DataCAD Plus vis from the View pull-down menu and click on Start. 
The following dialog box appears: 

 

5. Click “No” to incorporate the changes you made in DataCAD Plus to your vis 
project. These changes or updates will be visible when you return to the vis 
program. 

6. Make additional changes or updates by repeating steps 2 through 5 until you 
are satisfied with the way your project looks in the vis program. 

Undo/Redo Options 
The Undo/Redo  depth (how many changes you can reverse and restore) 
is limited only by available memory (RAM). Fortunately, each Undo/Redo step 
requires very little memory and the amount reserved for these operations is large. 
So you may be able to cancel all operations up to and including the first. 

The Undo/Redo buttons are gray (inactive) if you made no additions or deletions. 

è To undo or redo your previous operation, you have several options: 

• click on the appropriate curved arrow  icon 

• use a keyboard shortcut for undo: [Ctrl] + [Y] or [Backspace] or [Delete] 

• use a keyboard shortcut for redo: [Ctrl] + [Z] or [Alt] + [Backspace] or [Alt] + [Delete] 

è To undo or redo several operations at once: 

1. Use the pull-down list to the right of the curved arrows to reveal your 
undo/redo history. 

2. Mark as many steps as you want to cancel or reinstate. 

Zoom 
There are several ways to get a closer look at an area: 
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• use the Zoom  icon 

• select ZoomIn from the View menu 

• press [Ctrl] + [+] keys 

There are several ways to shrink the item: 

• use the icon Zoom  + [Ctrl] 

• select ZoomOut from the View menu 

• press [Ctrl] + [-] keys 

There are several ways to display the entire project: 

• use the icon Show-all  

• select ShowAll from the View menu 

• click the [Home] key 

è To increase or decrease the zoom increment: 

1. Right-click on the icon Zoom  or select from the pull-down menu Options, 
Program, and Zoom factor. The Zoom dialog box appears. 

 

2. Select the Enlargement factor option you prefer. 

Window (free) Varies, depending on the size of the box you draw. Select  ; 
move your cursor to the area you want to enlarge; press and 
hold down the left mouse button and drag to draw a box around 
the area you want to zoom in on; release the mouse button. 

Window (centered) Similar to Window (free), except the box is drawn outward from 
the focal (center) point where you press the left mouse button 
and hold it to drag the box until it encloses the area you want to 
enlarge; release the mouse button. 
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1.414, 2.0, or 4.0 Fixed zoom factors. Select ; click the left mouse button on the 
area you want to enlarge. To zoom out, press [Ctrl] as you click. 

Arbitrary Type a value between 1.00 and 20.00 or use the arrows next to the 
input field to designate the zoom factor you prefer. 

 
3. Click OK or press [Enter]. The enlargement factor you selected in step 2 affects 

both zoom-in and zoom-out operations. This factor stays in effect until you 
change it. 

You can also use the numeric keypad to adjust zoom levels and move windows. 
The following keys have certain effects: 

[0] Show everything 
[1] Move the window downward and to the left 
[2] Move the window downward 
[3] Move the window downward and to the right 
[4] Move the window to the left 
[6] Move the window to the right 
[7] Move the window upward and to the left 
[8] Move the window upward 
[9] Move the window upward and to the right 
[+] View window is zoomed in, around the center 
[-] View window is zoomed out, around the center 
[*] View window is zoomed in, centered around the mouse cursor 
[/] View window is zoomed out, centered around the mouse cursor 

You may find these keys useful for navigating around your DataCAD Plus vis project. Laptop 
users who don’t have a numeric keypad can hold down the [Ctrl] key in conjunction with the 
numbers and symbols shown above. 
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The DataCAD Plus vis ArCon-Explorer 
Window 

In this window, DataCAD Plus vis allows you to keep a catalog of the objects, 
textures, and materials used in your project. You can detach this window from the 
ArCon+ window to leave more room for your drawing project. 

You can toggle off the icons on the left margin of this window by using the View 
pull-down menu and selecting the Toolbar option. When the Toolbar option is 
checked, the icons appear in the left margin; when it is not checked, only the pull-
down menu is visible. Similarly, you can toggle on and off the detailed information 
about your objects and textures by selecting Details from the View pull-down 
menu. 

You can move the icon bar and reposition it above the catalog list as in this 
illustration. The icons stand for Folder (go up one level), Details (display or hide), 
Objects, Textures, Loaded Textures, and Materials. 

 

There are over 1,000 objects, including furniture for baths, kitchens, and living 
rooms. To successfully work with all these objects, they are grouped and organized 
into folders of related objects in the object and texture catalog. These folders can 
contain additional subfolders or individual objects. 

In either the plan view or perspective view, you can drag and drop items from the 
catalog into your drawing. At the same time, you can resize items. 

è To move something from the catalog into your drawing using drag-and-drop: 

1. Click on the item you want in the ArCon-Explorer window. 

2. Keep your finger on the left mouse button while you drag the item into your 
main ArCon+ window. The cursor changes to let you regulate the size of the 
item. 

3. Release the left mouse button when you are satisfied with the size of the item 
and its position in your drawing. 

In perspective view, the cursor changes to ; in plan view, it becomes . 
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è To place an object or group of objects from the catalog into your drawing with the 
menu: 

1. Select Object from the menu bar in the ArCon+ window. 

2. Choose Load Group or Load Object. The Object dialog appears. 

 

3. Select the group and/or object you want. You may need to browse through 
several folders until you find the group or object you need. The object may 
appear in a preview window (see details about the preview window in this 
chapter) so that you can look at it from all angles. 

4. Click on Open or press [Enter] to place that group and/or object into your 
drawing. The cursor changes to let you regulate the size of the item. 

5. Release the left mouse button when you are satisfied with the size of the item 
and its position in your drawing. 

Further details about controlling the objects, dimensions, location, and relative 
placement (for example, furniture falls to the floor, but light fixtures may move 
toward the ceiling) are included in the chapter Working with Catalog Items. 

Once an object is in your ArCon+ window, you can click on it, drag it to a new position, and/or 
resize it. 

You can select an object by quickly clicking on it and releasing the left mouse button. This puts 
a frame around the object. You can select several objects (using [Shift]-click) to form a group 
that DataCAD Plus vis puts in a frame. You can then delete, mirror, rotate, and/or realign them 
using the icons in the vertical bar. 
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Preview Window 
Sometimes, dialog boxes contain preview windows to show you an object from any 
viewpoint before you insert it in your project. Any changes (such as dimensions or 
textures) you make in the dialog box fields are immediately shown in the preview 
window. If a dialog box contains a Preview option, clicking on the icon in the lower 
right corner lets you make mathematical changes that affect an object’s appearance 
in the preview window. For most objects, the preview window appears 
automatically when you input changes. When you click OK, the image moves from 
the preview window to your current project file.  

When you work in the preview window, the cursor changes to . 

è To turn an object in the preview window: 

1. Put your cursor in the preview window. The cursor changes to . 

2. Keep the left mouse button depressed. 

3. Move your mouse to view the object from all angles. 

è To zoom in or out in the preview window: 

1. Move your cursor to the lower right corner of the preview window. 

2. Click on the “+” to zoom in (enlarge) or the “-“ to zoom out (shrink). 

è Here’s another way to zoom in or out in the preview window: 

1. Position your cursor in the preview window. 

2. Press the right mouse button and continue to hold it down. 

3. Move the mouse downward to enlarge the object; move the mouse upward to 
shrink it. 

è To reposition the object in the preview window: 

1. Find the scroll bars on the right and bottom sides of the preview window. 

2. Click on the arrow at either end of the scroll bars until you are satisfied with the 
object’s position in your preview window.  

3. Click on the “a” in the bottom right corner of the preview window to display 
the complete object. 
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Animated Objects 
Some objects that appear in a preview window can be animated. For example, an 
animated cabinet can have doors and drawers that open and close. 

è To move an animated object in the preview window: 

1. Click the Play button to show the animation in sequence. 

2. Click the Stop button to halt animation. 

3. Move the slider to control the pace and position of the object that is being 
animated. 

If there is an animated object in your project, the cursor changes to  when you 
move the mouse over it. 

è To move an animated object in your project: 

1. Position the cursor on the object. 

2. Right-click to display a menu that controls the object’s movements. 

3. Select the animation options you want from the menu. 

Arbitrary time  Object changes based on selected time 
Restore initial position Object returns to original state 

4. Right-click again to display a slightly different menu that offers further 
animation options. Select the one you want. 

Some independent movements of animated objects can last quite a while. If you want to abort 
the animation, simply press [Esc]. The object will immediately stop moving and will assume 
the position it would be in at the end of the animation. 

è To control arbitrary time (the last item in the pop-up menu when you right-click on 
an animated object): 

1. Select arbitrary time. The Animation dialog box appears. 

 

2. Move the slider to position the object where you want it and click OK.  


