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In DataCAD Plus vis, you can drag and drop objects into your 
project. Then, the fun begins. 

 

In this chapter: 

± Placing objects 

± Selecting objects 

± Deselecting objects 

± Moving objects 

± Saving objects 

± Selection frames 

± Collision detection 

± Rotation 

± Alignment 

± Multiple views 
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Placing Objects and Groups 
DataCAD Plus vis lets you place objects individually or as a group into your 3D 
plan or perspective view by dragging them from the catalog into your drawing and 
dropping them into place. In both views, the cursor acquires the form and function 
of a 3D cursor, allowing you to control the placement and height of objects. Once 
you release the mouse button, the cursor returns to normal.  

You can show or hide the catalog by clicking on  in the upper horizontal icon bar. 
If necessary, you can reposition the catalog or take it out of the ArCon+ window 
entirely. To move it from the ArCon+ window, just remove the checkmark from 
Dock catalog to window in the pull-down View menu. 

Catalog folders have yellow backgrounds; objects (the items you actually place) 
have gray backgrounds. Double-clicking on a catalog folder displays the individual 
objects within that group. For some categories, subfolders appear (for example, the 
Office folder contains subfolders for Desks, Chairs, etc.). Use the  icon to move up 
to the next level of folders. 

You can open a traditional Windows Explorer directory pane by selecting the thin 
vertical line to the right of the window. Keep depressing the left mouse button while 
you drag toward the right to open the Explorer window. This lets you select folders, 
subfolders, and files using traditional Windows procedures. 

 3D Plan View  
In this view, the cursor functions as a 3D mouse cursor, allowing you to place your 
objects precisely in the X, Y, and Z directions.  

è To load objects from the Catalog into your 3D plan: 

1. Select Objects from the Catalog pull-down menu in the ArCon-Explorer 
window or click on  in the icon bar. 

Individual objects are located in file folders by categories (such as Bath and Cellar). You can 
toggle back and forth between large icons and a more detailed list (including the file name) by 
selecting Details from the View menu or clicking on . Currently, only “fantasy” objects are 
shown; therefore, the Manufacturer, Article number, and Price columns display “Unknown.” 

2. Locate the individual item or group of objects you want from the catalog. 

3. Drag the object(s) into your project by keeping the left mouse button depressed 
until you are satisfied with its position and size. The object’s size appears in the 
message bar at the bottom of your DataCAD Plus vis screen. You can also 
control an object’s size by double-clicking on the item after placing it in your 
project. 
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By pressing the left mouse button alone, you place the item in the X- and Y- directions; 
pressing left and right mouse buttons together places the item in the X- and Z- directions. 

4. Release the left mouse button to place the item.  

The cursor changes to a cross . The selected object is not displayed as long 
as you keep the left mouse button depressed and the cursor is moving over the 
view window. Only after you release the left mouse button will you see the object 
within a green selection frame. (After you place an object, it remains selected until 
you click elsewhere in the ArCon+ window to free your mouse or you drag another 
item from the catalog into your project.)  

è To load an object or group with the menu: 

1. Select Load group or Load object from the Object pull-down menu. The Group 
load or the Object dialog box appears. 
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In comparison with the Windows file selector dialog box, the vis program includes a preview 
window. This lets you see an object before you actually load it into your project. To appear in 
the preview window, the object must have a valid file extension (.aco).  

After you highlight a file in the Object dialog box but before you actually load it, you can rapidly 
preview other items in the same folder by pressing the up and down arrow keys. This only 
works if you put a check in the Automatic preview box. 

2. Select an object or a group of objects from the menu by double-clicking your left 
mouse button. Alternatively, you can select the object or group by highlighting 
it in the menu and pressing [Enter]. 

3. Move your cursor to bring the object(s) into your project, but do not press the 
mouse button. The cursor changes to give you an aerial view of the object(s).  
Keep moving your mouse until the item is in the proper place in your 3D plan. 

Moving the mouse without depressing a button moves the object or group in the X- and Y- 
directions. You can place the item in the X- and Z- directions by pressing the right mouse 
button while moving the mouse. 

4. Click the left mouse button to place the object or group in a certain position in 
your project. The selected item appears in the view window and is enclosed in a 
selection frame. 

When placing items, you can enable the collision detection function by pressing [Ctrl]. Collision 
detection prevents you from placing an item on, over, or otherwise in the same space as an 
existing object. 

Perspective View 

In perspective view, the cursor looks and functions like a 3D mouse cursor , 
looking like a spatial red cross hair (with six arrows) and a “shadow jet”. This 
allows you to place your objects in all three (X-, Y-, and Z-) directions. The choices 
you make in the General settings dialog box, combined with the left and right 
mouse buttons, affect the cursor’s movement and function in the project. 

è To select settings that affect the 3D mouse cursor: 

1. Select Program from the Options pull-down menu. 

2. Choose General…The General settings dialog box appears. 
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3. Make changes in the Movement while pressing right mouse button section of 
the General settings dialog box. (See Chapter 2 for detailed information.)  

è To load objects from the Catalog into your perspective view: 

1. Select Objects from the Catalog pull-down menu in the ArCon-Explorer 
window or click on  in the icon bar. 

Individual objects are located in file folders by categories (such as Bath, Cellar, and 
Decoration). You can toggle back and forth between large icons and a more detailed list 
(including the file name) by selecting Details from the View menu or clicking on . Currently, 
only “fantasy” objects are shown; therefore, the Manufacturer, Article number, and Price 
columns display “Unknown.” 

2. Locate the individual item or group of objects you want from the catalog. 

3. Drag the object(s) into your project by keeping the left (or both left and right) 
mouse button(s) depressed until you are satisfied with its position and size. 

The decisions you made in the General settings dialog box affect the object’s position, size, 
and behavior, depending on whether you press only the left mouse button or if you press both 
left and right mouse buttons simultaneously.  

By pressing the left mouse button alone, you place the item in the X- and Y- directions; 
pressing left and right mouse buttons together places the item in the X- and Z- directions. 

4. Release the left mouse button to place the item.  

The cursor changes to . The selected object is not displayed as long as you keep 
the left mouse button depressed and the cursor is moving over the view window. 
Only after you release the left mouse button will you see the object within a green 
selection frame. (After you place an object, it remains selected until you click 
elsewhere in the ArCon+ window to free your mouse or you drag another item 
from the catalog into your project.)  

è To load an object (or group of objects) into your perspective view using the menu: 

1. Select Load group or Load object from the Object pull-down menu. The Group 
load or the Object dialog box appears. 

2. Select an object or a group of objects from the menu by double-clicking your left 
mouse button. Alternatively, you can select the object or group by highlighting 
it in the menu and pressing [Enter]. 
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3. Move your cursor to bring the object(s) into your project, but do not press any 
mouse button. The cursor changes to give you a perspective view of the 
object(s).  Keep moving your mouse until the item is in the proper place in your 
perspective plan. 

The left mouse button has no function. With the right mouse button, you can control the depth. 

4. Click the left mouse button to place the object or group in a certain position in 
your project. The selected item appears in the view window and is enclosed in a 
selection frame. 

When placing items, you can enable the collision detection function by pressing [Ctrl]. Collision 
detection prevents you from placing an item on, over, or otherwise in the same space as an 
existing object. 

è To control where an object lands in your project: 

1. Double-click on the object that is positioned incorrectly. The Object settings 
dialog box appears. 
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2. Deactivate (remove the checkmark) from Set height after free placement. 

3. Insert the value 0 (zero) in the Height above floor field and click on OK. The 
object is now positioned on ground level. 

If you want to position an object on top of a table, you can enter a value that equals the height 
of the table. 

4. Position the object where you want it to appear in your project. 

Since it is easy to nudge an object out of place, you may want to use these four steps again 
after you move things in the vicinity of an item. This way, you can make sure the object rests 
on the ground or on top of the table. 
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Selecting and Deselecting Objects 
To work with an item or group, you must first select it. In both plan and perspective 
views, the selection method is the same. Only the selection frames differ in 
appearance, depending on the type of view. 

Remember that your building is also considered an object in the DataCAD Plus vis 
program. You can select it and work with it the same way you do other objects in 
your project. 

è To select or deselect a single object: 

1. Click on the object with the left mouse button. The object appears in green 
selection frame. 

2. Click in an area where there are no objects to deselect an object. Or deselect the 
first item by selecting another item. The green selection frame disappears. 

è To select or deselect multiple objects: 

1. Put your cursor on the first object. 

2. Press [Shift] while you click the left mouse button to select the first object. A 
selection frame appears. Do not release the [Shift] key. 

3. Keep the [Shift] key depressed while you click on the second item. 

4. Select additional items if necessary with [Shift]-left mouse button. 

5. Deselect an object that is surrounded by a selection frame by clicking on it once 
with the left mouse button while pressing [Shift]. The deselected object’s frame 
disappears; however, the object remains. 

è To select all objects in your project: 

1. Left-click on . Alternatively, choose Select all from the Edit pull-down menu. 
Selection frames surround all the objects. 

è To select an item that is beneath another object: 

1. Position your cursor over the item that is covering (either partially or totally) 
the object you want to select.  

2. Hold down the [Ctrl] key while you click with the mouse on the desired object. 

This may be a little tricky since you have to click on an edge of the hidden object. Use the 
zoom feature to enlarge the items and make it easier to find the edge of the hidden one that 
you want to select.  
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Moving Objects and Groups of Objects 
You can move only the objects and groups of objects enclosed in selection frames. 
Movement differs somewhat, depending on the type of view (3D plan or 
perspective). The selection frames also vary, depending on the type of view. While 
you move an object or groups of objects, DataCAD Plus vis temporarily hides its 
selection frame(s). The cursor's form and function depends on whether you are 
using 3D plan or perspective view. 

To prevent setting objects atop one another or hitting a wall, press [Ctrl] when 
moving objects. That toggles on collision detection. Now, you can easily place the 
object(s) (e.g., directly beside another object or at the wall’s edge) without any 
conflict. 

Moving Objects in Plan View 

è To move objects in width (x) and depth (y): 

1. Move the cursor into an individual object’s selection frame or within the 
group’s frame area. 

2. Press the left mouse button and hold it down while you move the objects or 
groups. When you release the left mouse button, the item is in its new place.  

The selected objects and groups can be moved only in the X- and Y- directions. Movement in 
the Z-direction is not possible using only the left mouse button. 

è To move objects in width (x) and height (z): 

1. Place the cursor into an individual object’s selection frame or within the group’s 
frame area. 

2. Move the object(s) or group(s) by pressing both the left and right mouse 
buttons. When you release the mouse buttons, the item is repositioned. 

The selected objects and groups can be moved only in the X- and Z- directions. You cannot 
move in the Y-direction by depressing the left and right mouse buttons simultaneously.  
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Moving Objects in Perspective View 
In perspective view, the 3D mouse cursor contains a “shadow jet.” This shadow jet 
appears under the selection frames; it indicates the connection between the floor 
level and the object(s) you want to move. You can use this shadow jet to measure 
where the object will land (if it is set to fall to the floor) after you release the left 
mouse button. 

You can control how the right mouse button affects moving objects in the General 
settings dialog box (see Chapter 2). 

è To move objects in width (x), depth (y), and height (z): 

1. Select the way you want to control the right mouse button in the General 
settings dialog box. (See detailed instructions in Chapter 2.) 

2. Experiment with the settings to determine which works best for you. 

To move objects easily, you can open a second view window for the project. The first window 
could show the plan view and the second could show the perspective view. You might find that 
it easier to place objects this way, using multiple and different views.  

In the plan view, you can easily move objects in the X- and Y- directions; the perspective view 
is best for moving objects in the Z-direction. If you use a plan elevation view, you can visually 
check the height and vertical position of objects in your project. 

Positioning Hint 
The landscape toggle can help you correct the position of your building relative to 
the site. This works especially well with the plan elevation views. 

è To position your building on the site: 

1. Toggle landscape on by clicking on the  icon. 

2. Select an elevation view from the 3D plan views . 

3. Double-click on your building to activate the selection frame. 

4. Set the height above floor to 0. If your building has floors (such as a basement 
or parking garage) below ground level, use a number such as –8 (or another 
appropriate value) to position it properly.  
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Saving an Individual Object 
You can save an object via the Object pull-down menu. If you open a new folder, 
you can create your own group, containing objects that you use frequently. For 
example, if you are designing several houses for the ABC subdivision, you may 
want all of them to use the same exterior lighting fixtures and fences.  

è To save an individual object: 

1. Select one object in your project. A selection frame surrounds the object. 

If you do not select any objects or if you select more than one item, the Save object… option 
will appear in gray as an inactive function. 

2. Select Save object… from the Object pull-down menu. The Save object dialog 
box appears. 

 

3. Give the object a meaningful File name and click on Save or press [Enter]. 

Object Settings 
All objects have pre-defined characteristics. The Object settings dialog box appears 
when you double-click with the left mouse button on an object. This object does not 
need to be selected beforehand. In this dialog box, you can modify an object’s 
characteristics. For example, you can adjust the lighting settings for lamps or the 
size of a sofa.  
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è To control setting for objects: 

1. Double-click on an object. A selection frame appears around the object and the 
Object settings dialog box opens. 

2. Make changes to the object by activating (checkmark) or deactivating (no 
checkmark) options or entering values in the fields on the left side of the dialog 
box. (See details in the following paragraphs.) 

3. Observe the effects of your changes on the object by checking the preview 
window. 

4. Click OK or press [Enter] when you are satisfied with your changes. If you 
decide not to implement your changes, click on Restore defaults or the X (close 
button) in the upper right corner of the Object settings dialog box. 
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The name of the object you double-clicked on appears at the top of the Object 
settings dialog box. On the left side of the dialog box are characteristics you can 
change. The preview window is in the lower right corner.  

Many options in the Object settings dialog box can be toggled on or off. If a box has 
a checkmark, it is on or activated. To deactivate a checked (activated) option, click in 
the box to remove the checkmark.   

Dimensions Section 
In this area, the object’s current dimensions are displayed numerically. These 
include the object’s length (x), width (y), and height (z). You can change these values 
by clicking on the up and down arrows to the right of each field or by entering a 
numerical value with the keyboard. 

If you activate “,” the object’s dimensions are no longer dependent on one another. 
Then, you can change them independently (for example, you can change the length, 
but keep the height and width at their original values). If scale distorted is inactive 
(the default), the object's proportions remain intact; therefore, if you change one 
value, the others change accordingly. 

You can interactively modify the dimensions of an object by clicking and dragging on the 
corners of its selection frame in the ArCon+ window.  When you interactively change an 
object's size in this manner, its dimensions depend on whether you activated the scale 
distorted option in the Object settings dialog box. If scale distorted was activated before you 
interactively modify an object, its dimensions will vary based on your dragging on the corners 
or sides of the selection frame. If scale distorted was deactivated, pulling on a corner of the 
selection frame will affect all the dimensions of the object. You can see these new dimensions 
when you double-click on the object you’ve modified interactively. 

If you activate the scale distorted option, the normal green selection frame will include blue 
circles and you can pull on the green sides of the frame as well as the red corners to change 
the object’s shape. If scale distorted is inactive (the default), there will be no blue circles and 
you can pull on the selection frame’s red corners only to change the object’s dimensions 
proportionately.  

You can activate the “reflect” option in the Object settings dialog box. This mirrors 
the object you selected. Activating this option has the same effect as clicking on the 

 icon. 

Height, Movement, and Shadow Section 
In the central section of the Object settings dialog box, several toggle switches help 
you modify an object by controlling height, adapting to areas, moving with the 
building, and casting shadows with raytracing. 
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If you activate the “Set height after free placement” option, objects fall automatically 
into your project when you place or move them. When you activate this option, 
“Height above floor” is grayed out and inactive; however, you can still see the 
height above floor value. 

If you deactivate the Set height option, you can specify how high the object should 
be above floor level. In the field for Height above floor, you can enter a value. Some 
items (such as wall-hung sinks) should be placed at a specific height above the floor. 
If you want to place an item directly on the floor, enter the number 0 in the Height 
above floor field. 

DataCAD Plus vis considers your building, itself, an object. You can double-click on it to bring 
it into the Object settings dialog box. Make sure that you deactivate the Set height option and 
enter the number 0 in the Height above floor field. This means that your building will rest at 
ground level, not below or above it. 

When the “adapt to areas” option is activated, the selected object is always adapted 
along its longest axis. DataCAD Plus vis calculates the height of an area at the 
beginning and end of the object and automatically adjusts the distance between 
them. For example, this assures that fences will have symmetrical contours.  

When moving property lines all objects are automatically adapted to the area if this option is 
active. For example, automatically adapting objects (or groups of objects) to areas when 
shifting property lines makes sense for fences, but not for trees, which should remain in their 
original position and state. If you select a group of trees, you can turn off this adjustment for 
the entire group in the Group settings dialog box. 

If you do not move a fence manually over the property edge, you must activate the adapt to 
areas option (which is deactivated by default) to adapt the fences to the area. 

When you move or mirror a building, the objects it contains are generally moved or 
mirrored, too. This also applies to objects that are outside of the building, but were 
placed when the building was active. (In this case, the objects still “belong” to the 
building, even though they may be outdoors). If an object should be fixed in its 
location and not moved or rotated along with the building, make sure that the “do 
not move with building” option is activated (checked). 

DataCAD Plus vis automatically activates this option for edges of areas. If you move a 
building, you cannot move the land under the building; therefore, the area edges are not 
moved. 
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The option “cast shadow with raytracer” lets you specify how an individual object 
will be rendered. If you do not want some objects (for example, gutters) to cast 
shadows on your building, you can deactivate this option. By default, this option is 
activated for all objects. 

Light Source Section 
This section applies only to lamps; otherwise, it is inactive (grayed). You can control 
the light’s “cone” size and brightness as well as the color of the light bulb. All 
changes in this section take effect only in the night view. 

The “Influence range”  option controls the size of the light cone. The farther to the 
right you move the slide, the larger the lamp’s cone and the more light it projects. 

Moving the “Intensity”  slider changes the light’s brightness. The brighter the light, 
the higher the contrast of shadows cast by nearby objects which that lamp 
illuminates. For raytraced pictures, if you set a lamp’s intensity too high, the 
rendered image will be overexposed. 

You can control the color of the light shed by lamps in your project. When you click 
on the Define… button, the Color selector dialog box appears.  

 

Adjusting the lighting color lets you mix light effects by assigning various colors to 
different lamps. Since each lamp operates independently, you can create interesting 
effects in raytraced pictures.  
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If you activate the “cast shadow with raytracer”  option, each object this lamp 
illuminates will throw a shadow. Basically, objects that you set to cast shadows will 
do so if they are illuminated by a lamp that has activated the “cast shadow with 
raytracer” option. 

Each object affected by the lamp must have the “cast shadow with raytracer” option activated. 
The lamp is the source of the shadows. The contrast of the shadow depends on the settings 
you make using the sliders that control Influence range and Intensity. You can also control the 
lighting effects on objects illuminated by multiple lamps. By adjusting the parameters for 
individual lamps and objects, you can achieve interesting effects with the raytracer. 

You may deactivate this option if you simply want to hang a lamp and see how its light affects 
the overall light level, without regard to shadows. 

The “with lighting”  option is just like a light switch. When this option is 
deactivated (unchecked), the lamp has no effect on the lighting of your project in the 
night view. This has the same effect as clicking on  when the lamp is selected. You 
can switch individual lamps on or off to see how they affect the illumination of your 
project. 

Animated Objects 
Some objects (such as a cabinet with doors and draws that open or shut) supplied 
with DataCAD Plus vis can be animated. For details, see Chapter 1.  
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Defining Groups 
You can define groups of individual objects, save these groups in your own catalog, 
and use them later in different projects. This helps you save time because you will 
not need to load individual objects. For example, you can create and save a 
complete dining room with table, chairs, and china cabinet. 

è To create a group of objects: 

1. Keep the [Shift] key depressed while you click on each object you want to include 
in the group. Each item’s selection frame appears. 

2. Click on  in the vertical icon bar or select Group from the pull-down Edit 
menu. The Group designation dialog box appears. 

 

3. Supply a name for the group you created and click OK. The objects you selected 
now constitute a group that is surrounded by a large selection frame. 

è To dissolve a group and make each object a separate entity: 

1. Click on the group you want to dissolve into separate objects. 

2. Click on  in the vertical icon bar or select Ungroup from the Edit pull-down 
menu. The group is dissolved and each object is surrounded by its individual 
selection frame. 

è To save a group of objects that you've created for later use: 

1. Hold down [Shift] and select each object you want in the group. 

2. Select Save group from the Object pull-down menu. The Group save dialog box 
appears. 
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3. Supply a file name for the group and place it in a folder. DataCAD Plus vis 
automatically supplies the .acg file extension. You may want to create your own 
folder to contain all your groups. 

4. Click on Save or press [Enter]. The Group designation dialog box appears so 
you can enter a name (see previous description). A large selection frame 
surrounds the group of objects. 

You can also draw the group of objects into a file in the object and texture catalog. 

è To load a saved group: 

1. Select Load group from the Object pull-down menu. The Group load dialog 
box appears. 
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2. Double-click on the group you want to load into your project. The cursor 
contains the group you selected. 

3. Place the group where you want it to appear in your project and click the left 
mouse button. The group appears in your project surrounded by a large 
selection frame. 

è To delete a saved group: 

1. Open the folder where you saved a group. 

You can either open the appropriate folder in the Windows Explorer or select Group load from 
the Object pull-down menu. 

2. Select the file name for the group you want to delete. 

3. Press the [Delete] key. The group file and its contents are deleted. 

4. Click Yes to confirm that you want to delete the file or press [Enter]. 

Group Settings 
Once you have combined several objects (or groups) into a group, you can adjust its 
settings. Since a group is surrounded by a large selection frame, it is treated like an 
object. 

è To control a group’s characteristics: 

1. Double-click on the group. The Group settings dialog box appears. This is 
similar to the Object settings dialog box. Many options are the same, so you can 
review those details in the previous paragraphs in this chapter. The different 
options are discussed in the following steps. The information in this dialog box 
refers not to an individual object (like the object settings), but to all objects in the 
group. 
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2. Supply a name for the group in the input field at the top of the dialog box. The 
default name is Unnamed group. 

3. Change dimensions for the group if necessary. This controls the size of the 
entire group, not the size of an individual object in the group. 

4. Decide whether you want to activate the option “do not move with building.”  
In the example above, you would not want this grove of mature trees to move 
along with the building; therefore, you would click in the input box to activate 
this option. 

5. Adjust the specifications in the light source section if your group includes 
lamps. Remember that these specifications will be used for all lamps in the 
group. 

6. Click OK or press [Enter] when you are satisfied with your changes. 
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Collision Detection 
When you are placing objects in your project, you may inadvertently put things 
where you hadn’t intended. For example, you could accidentally place a chair 
under a cabinet or position a table so that part of it goes through a wall. 

To prevent problems like this, you can use the collision detection function. While 
you are placing objects (or groups of objects), this function internally calculates if it 
would collide with any other existing objects. Since collision detection requires a lot 
of computing time, it is switched off by default. Also, you generally don’t need it 
(for example, if you're just moving a cabinet from one corner of a room to another). 

è To use collision detection: 

1. Press [Ctrl] while you're placing or moving an object or group of objects. 

While you're pressing [Ctrl], an object can be adjusted only in free space. For instance, 
DataCAD Plus vis would prevent the chair from going under the cabinet or keep a table from 
plunging through a wall. 

Collision detection is very helpful when you’re placing objects in the 3D plan view. 
It is also helpful when you want to combine several items (for example, building a 
shelving system by combining several individual cabinet sections). 

è To combine items to form a larger object such as a shelving system: 

1. Select a cabinet section already placed in the room and move it while pressing 
[Ctrl] up against a wall, until you cannot move it any further. The cabinet section 
is now as close as possible to the wall. 

2. Move the second cabinet section as close as possible to both the wall and the 
first cabinet section, until it likewise cannot be moved any further. The cabinet 
sections now are side by side, directly against the wall. 

3. Make adjustments if necessary. Press [Ctrl] and move the cabinet in the desired 
direction so it’s flush with the wall and the other cabinet. 

4. Continue adding cabinets until your shelving system is complete. 

5. Save the shelving system as a group. 

You can also use this procedure for placing furniture freely in a room, to control the 
distances between objects, and to ensure that no unnatural placements occur. 
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The Selection Frame 
If you are in 3D plan or perspective view, the selected objects or groups of objects 
are enclosed with a three-dimensional selection frame. The edges and corners as 
well as the middle areas of this frame are colored. These colored markings mean 
you can change the object's dimensions independently (with distorted scale). 

Colored markings on selection frames signify different things: 

Red corners Change all three dimensions (width, height, and depth). The 
diagonally facing corner remains unchanged. 

Green edges Change two dimensions (width + height, width + depth, or height + 
depth). The diagonally facing edge remains unchanged. 

Blue circles Change a dimension (width, height, or depth) independently in the 
center of the selection area. The opposite area remains unchanged. 

If the cursor is over one of the colored markings, its form changes to a cross. You can 
change the size or dimensions of the object by moving the mouse while pressing the 
left mouse button.  

If distorted scaling is inactive, you can scale the object only at the red corners and 
only symmetrically in width, depth, and height. If a blue circle appears in the center 
of a selection frame, distorted scaling is active. This lets you scale any one of the 
object’s dimensions independently of the others. 

In the Object settings dialog box, you can activate the “scale distorted” option. In 
your project, you will see blue circles in the selection frame of these objects. 

Any modifications you make to objects and groups of objects can be reversed. 
Simply open the Object settings dialog box and clicking on the Restore defaults 
button. This will restore an object or group to its original size. 
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Using the Vertical Icon Bar to Control 
Objects and Groups 

You can use these icons to change the position and status of items already placed in 
your project. However, you cannot directly modify an object’s dimensions with 
these functions. 

Group Functions 
The top three icons in the vertical bar help you group or ungroup objects. 

 Select All places selection frames around all objects and groups, including the 
ones on the floor (even if they are not visible). You can also do this by choosing 
Select all from the Edit pull-down menu. 

 Group is available as an option when you select at least two objects or groups 
that you want to combine into a collection of objects; otherwise, it is grayed or 
inactive. Once you have selected several objects, you can click  to surround them 
with a large selection frame. (For details, see sections in this chapter about groups.) 

 Ungroup is available when you select a group of objects that you want to 
separate into individual items. (For details, see sections in this chapter about 
groups.) 

Copy 
 Copy is activated when you have selected at least one object or group. When 

you click on , the object or group is copied (with the same characteristics as the 
original) and put into a selection frame. You can change the position of the copy (in 
relation to the original object or group) by making changes in the Copy dialog box. 

You open the Copy dialog box by right-clicking on the  icon. 

To copy an object, you can also select Copy from the Edit pull-down menu. 
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Delete 
 is active only if at least one object or group is selected. When you click on , the 

selected object of group is eliminated. You can also delete objects by pressing the 
[Delete] key or selecting Delete from the Edit pull-down menu. 

If you right-click on , the Delete dialog box appears. 

 

You can activate or deactivate the option to ask for confirmation when DataCAD 
Plus vis deletes multiple objects. This is a recommended safety mechanism. If you 
activate this, you'll get a warning dialog box whenever you attempt to delete 
multiple objects or groups. You can cancel the operation if you made an error or 
changed your mind. 

If you activated the confirm function, the Confirm delete dialog box appears when 
you selected several objects or groups that you want to eliminate. It gives you a 
chance to change your mind. 

 

The name of the object or group is displayed. This dialog box goes through each 
object or group one at a time. You can click on Yes to delete the object whose name is 
shown; selecting No saves the object named and continues to the next object 
scheduled for deletion. Delete all eliminates each selected object and group and 
closes the dialog box. Clicking on Cancel or pressing [Esc] closes this dialog box 
without deleting any more objects or groups. 
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Rotation Functions 
You can rotate objects or groups around any axis and reset the degree of rotation (if 
required) until you return to their load positions. If you select one or more groups, 
the rotation icons are active; otherwise, they are inactive or grayed out. You have 
three basic rotation functions: rotating around the X, Y, or Z axis, arbitrary rotation, 
or reset to the original. 

Rotate Around the X, Y, or Z Axis 

Rotate around the X , Y , or Z 
 axis lets you rotate the object or group over all directions of the 

three-dimensional room. You can use a fixed angle or an arbitrary, free rotation 
angle. Basically, all objects and groups always rotate around their centers, around 
the upright central axis of the selection frame. Positive angles specify a rotation in 
the clockwise direction; negative angles specify a rotation in the counter-clockwise 
direction. 

è To rotate around the X, Y, or Z axis: 

1. Select an object or group that you want to rotate. 

2. Choose the desired axis by clicking on one of the three variable icons. 

3. Specify the coordinate system by right-clicking on one of the three icons. The 
Rotate dialog box appears. 

  

Before you rotate an object or group around one of the axes freely or by a fixed angle, you 
must determine whether you want to use the model or world coordinates. This distinction is 
important if an object or group has already been rotated. If it has, you modified the axes in the 
rotation. If the object axes and the world axes no longer correspond, you must specify the 
axes system around which to rotate. When you first load an object, the difference is 
insignificant because the object is placed with regards to both axes systems. 

If you select model coordinates, the object or group rotates around its own axis or around 
itself. With world (absolute Cartesian)  coordinates, the object's position in the "world" will 
change accordingly. This corresponds to the rotation you typically use for rotating the view. 
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4. Rotate by a fixed angle by selecting the appropriate angle around the desired 
axis with the icon. You can also do this by selecting Rotate over from the Edit 
pull-down menu, sliding to the axis and angle you want. 

With the predefined fixed angles, you can rotate an object or a group over any axis by 90°, -
90°, 45°, -45°, 30°, and -30°. If you want to rotate an object 30 degrees around the X-axis, 
select the specific icon. If you now click on the icon in the vertical icon bar, the selected object 
or group is rotated 30 degrees around the X-axis. If you click again on this icon, you'll rotate 
the object another 30 degrees around the X-axis. 

5. Rotate freely around an axis by selecting the ruler icon from one of the three 
axis groups. The Rotate dialog box appears. Use the slider or input a specific 
angle to control rotation. Click on OK when you are satisfied. 
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By inputting a specific angle numerically, you can align an object precisely to a wall, which 
was rotated within the room.  

If you click on Reset, the rotation angle changes to zero. The object or group is again in its 
original position, where it was before you accessed the rotation function. You can also abort 
free rotation by pressing [Esc], which also returns the object or group to its original position. 

Arbitrary Rotation 

Arbitrary rotation  lets the object or group rotate freely, depending on which 
icon you selected, around the perpendicular axis and independently of a specific 
axis or angle. You can move, shift, and twist the object. As soon as you click on 

, the cursor changes to . This cursor lets you rotate the object or group in 
all directions, independent of any axis or angle. 

è To use arbitrary rotation: 

1. Select an object or group that you want to rotate. 

2. Click on . The first icon lets you rotate freely around the perpendicular 
axis (similar to freely rotating around the Z axis) to let you align the object or 
group without opening the Rotate dialog box or the slider control. 

3. Use the  cursor to rotate your object or group. 

Use the [Esc] key to abort the rotation and restore the item to its original position. 

Reset Rotation 

Reset rotation  lets you cancel all rotations previously executed. This resets the 
object or the group into its original, load position. 

The Reset button in the Rotate dialog box only restores the object to its orientation before you 
began rotating it within the dialog box. This position may or may not be the same as the 
object's original position. 

Mirror Function 
If you select one of more objects or groups, this function becomes active; otherwise, 
it is unavailable or grayed out. 
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è To mirror an object or group: 

1. Select the object or group you want to mirror. 

2. Click on the  icon or select Mirror from the Edit pull-down menu. All objects 
are mirrored over their central shaft, so the sides of the objects are interchanged. 
For objects with in a group, not only are the sides interchanged, but also the 
object’s position within the group. 

Aligning Objects 
The align icon  is active only if you selected at 
least two objects or groups; otherwise it is unavailable or grayed out. 

è To align objects or groups: 

1. Select two or more objects or groups. 

2. Click on the appropriate align icon of select Align from the Edit pull-down 
menu. 

With the align icon, you select the type of alignment; with the menu item, you don't have this 
control.  

There are many align icons to let you position objects or groups in specific ways. These 
options are: left-justified; right-justified; horizontal centrally; horizontal by the same distance to 
a central point; above each other; below each other; above or below, centrally, or by the same 
distance to a central point; by height; by height centrally or by the same distance to a central 
height point. 

For the perspective view, you can orient yourself to the specification of the left and right (this 
does not change whether you're looking at your project from the front or the rear). The 
specification to the rear and forward is relative to your position. If you select to the rear, the 
objects are always aligned in the direction running away from you (the function is 
independent, regardless of how you look at your scene). The specification for Z-direction 
always concerns the height, vertical to the floor, and upward in your project (which may not be 
evident in your display). 

If you selected at least three objects or groups, you can move them so that the 
distance between them is the same. For example, if you select four objects and then 
click on the icon Align selected objects by same distance (in x), the positions of the 
first and last (fourth) objects remains unchanged. The intermediate objects move to 
the left or right, so the resulting distances between the individual objects are equal.  

Aligning objects and groups requires practice. Once you have a basic understanding 
of how it works, you’ll find it a practical tool. 
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Displaying Multiple Views 
You can see several views of your project on the monitor at the same time. For 
example, you can show the plan view, front entrance, and various 3D views on the 
monitor so your client can have a quick overview of the project. 

è To see multiple views of your project on the monitor: 

1. Change something in the current view of your project. 

2. Select New view from the Windows pull-down menu. The unaltered view is 
placed in a new active window in the foreground of your monitor while the 
view that you made changes to (in step 1) remains in the background in an 
inactive (the title bar is gray) window on your screen. 

3. Repeat step 2 as often as necessary to create more views. 

4. Choose Tile from the Windows pull-down menu to show all views on your 
screen at the same time. 

As you add more views, the individual tiles become smaller. You can also select Cascade 
from the Windows pull-down menu; this puts the current (active) window on top, followed by 
the other inactive (grayed title bar) views. 
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