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GRANT OF LICENSE
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or transmission.
LIMITED WARRANTY
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the duration of an implied warranty, so the above limitation may not apply to you.
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either 1) return of the price paid less shipping and handling charges if applicable or 2) repair or
replacement of the software that does not meet DATACAD's Limited Warranty and which is returned to
DATACAD with a copy of your receipt. This Limited Warranty is void if failure of the software has
resulted from accident, abuse or misapplication. Any replacement software will be warranted for the
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Chapter 1 Up & Running
Getting DataCAD up and running is a simple matter with its
flexible and interactive setup program. Use the "System
Requirements" and "Pre-Installation Checklist" in this chapter to
make sure you're ready to begin installing the program. The
setup instructions that follow take you step-by-step through the
installation process.
To get the most from this manual, please refer to “How to Use
This Manual” in this chapter.
DATACAD LLC offers 30 days of free technical support on the
current version of DataCAD. If you have any questions about
installing DataCAD, you can contact DATACAD LLC Technical
Support Monday through Friday, 8:00 a.m. – 5:00 p.m. Eastern
Time, except during normally observed holidays, via phone at
+1 (860) 217-0567, or via e-mail at help@datacad.com.
For more information about the technical support options we
offer, please refer to the DataCAD Support Page on our website
at www.datacad.com/support.

In this chapter:

 How to use this
manual

 System requirements
 Pre-installation
checklist

 Installing DataCAD
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How to Use This Manual
This manual begins with two chapters introducing DataCAD to you. “The Drawing Board” chapter
covers such topics as opening and saving drawings, using coordinate entry, and common menus in the
program.
Following this introduction, four additional chapters guide you through a basic tutorial, designed to
quickly teach you how to use DataCAD’s basic functions to produce a plan drawing. These exercises
focus on a single project.
The remainder of the manual gives detailed explanations as well as step-by-step instructions on how to
use each DataCAD function and menu to complete drawing tasks. These instructions may include typing
words or characters, using keyboard shortcuts, selecting entities, and choosing menu options.
Words or characters to be typed are printed in bold; type them exactly as they appear. Keys to be pressed
are shown just as they appear on your keyboard, with parentheses around the character(s), as shown
below:
Press (Enter).
Press (Ctrl) + (M).
Combinations like the second example above should be executed by pressing and holding down the first
key, pressing the second key, then releasing both simultaneously.
Some instructions ask you to "click" or "right-click" on a button or icon. To click on a button, move your
mouse until your cursor arrow is over the button and then press the left mouse button once. To rightclick, press the right mouse button once. Right-clicking generally doesn't require specific placement of the
cursor arrow; it must, however, be somewhere over the DataCAD window.

Getting Help in DataCAD
DataCAD includes online help, accessible by pressing (Ctrl) + (F1) or using the Help Menu in DataCAD.
The online help contains the Reference Manual in PDF format. To use the Reference Manual, you need
the Adobe Reader. If you do not already have the Adobe Reader installed on your computer, you can
download a free copy from the Adobe website at www.adobe.com.
You can also access the online help from outside of DataCAD. Use Windows Explorer to open the
DataCAD\Help folder and then double-click on DataCAD_19_Manual.pdf.

Installing DataCAD
To install DataCAD on your computer, first review the "System Requirements" and "Pre-Installation
Checklist" sections below to make sure you have everything you need to install the program. Then follow
the instructions in "Running the Setup Program" on the next page.
Information in this section requires you to be familiar with your computer hardware and your computer's
operating system (Microsoft Windows XP/Vista/7/8/10).
To check available free hard disk space prior to installation, double-click on the My Computer icon on
your Windows desktop. Right-click on the drive you want to install DataCAD on, and select Properties.
The hard disk space already in use will be displayed as well as the amount that is still free.

System Requirements (Minimum)
Make sure you have the following minimum requirements to install and run DataCAD:


Processor
Intel® Pentium® 4 or AMD™ Athlon processor

INSTALLING DATACAD |


Operating System
Microsoft® Windows® XP, Vista™, 7, 8, or 10 operating system

Note: DataCAD will run on 64-bit versions of Windows, but it will run as a 32-bit application.


RAM
512MB for use on XP, 1GB for use on Vista, 7, 8, or 10



Hard Disk
1GB of free disk space recommended for a complete installation of DataCAD

To check available free hard disk space prior to installation, double-click on the My Computer icon on your
Windows desktop. Right-click on the drive you want to install DataCAD on, and select Properties. The
hard disk space already in use will be displayed as well as the amount that is still free.


Optical Drive
(Not required for Internet download)



Video
Display adapter with driver support for OpenGL® version 1.6 or higher
SVGA (800x600) monitor and display adapter capable of 16-bit color or higher

Note: The Sun Shader’s performance relies heavily on the display adapter driver and its ability to support
OpenGL 1.6 or higher.


Pointing Device
Microsoft-compatible mouse (3-button mouse recommended)



Internet
An active Internet connection is required for product activation and license validation.
Once activated, an Internet connection is not required to run DataCAD.

Before You Begin Upgrading from DataCAD 8 - 10
DataCAD 19 includes significant enhancements. If you are upgrading from DataCAD 8, 9, or 10, you will
also need to be aware of changes to the drawing file format, directory structure, file and folder names,
and program default settings. Please refer to the Before You Begin document located in DataCAD’s Help
directory.

Pre-installation Checklist


Do you have the minimum system requirements for DataCAD?



Have you made a copy of your DataCAD folder to back up all your files? This is simply a precaution
against losing any of your drawing files or customized settings.

Running the Setup Program
The DataCAD setup program guides you step-by-step through installing DataCAD. Please exit all
Windows applications completely before running the DataCAD setup program. You must have
Administrative Privileges to run this setup program.
DataCAD is now delivered as a single, downloadable file with a universal installer. It can be run in demo
mode for 30 days, or activated as DataCAD LT, DataCAD Professional Edition (PE) or DataCAD
Subscription Edition (SE).
1.

Double-click on DataCAD19Setup.exe; the setup program will start automatically. To cancel the
installation at any time, press (Esc) or click Cancel.
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2.

The setup program begins. Simply follow the instructions on the screen. This version of
DataCAD must be installed in a new program folder. Because of the many changes, you cannot
install it in the same folder as a previous version of DataCAD.

3.

Once setup is complete, you can view the RevHist file, which contains important information
about changes to DataCAD that are not documented anywhere else. Click Finish to complete the
setup program and open the RevHist file.
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Chapter 2 The Drawing Board
A user-oriented menu system makes DataCAD easy to learn and
convenient to use. Because it was developed by architects for
architecture, the program focuses on design, not computer
technology. Even draftsmen and designers with no previous
computer experience can learn DataCAD quickly.
DataCAD’s dual menu system combines familiar Windows
menus in the Menu Bar with a comprehensive, nested menu
structure in the Menu Window. This unique system, along with
toolbars and numerous keyboard shortcuts, allows constant
access to the tools you use to draw, instead of covering your
drawing area with menus that are only temporarily visible.
From your initial design work, massing studies, and interior
perspectives to your final set of construction drawings,
DataCAD provides you with the tools you need to produce
quality work quickly, accurately, and with greater flexibility
than ever before.

In this chapter:

 Creating drawings
 Opening drawings
 Importing and

exporting drawings

 The DataCAD screen
 Common menus
found throughout
DataCAD

 Planning your

drawing project

 Basic drawing and
editing

 Viewing your project
 Referencing
drawings

 Naming and saving
files
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Opening a Drawing
DataCAD 11 and later drawings have an AEC file extension. When you create a new drawing, DataCAD
adds the AEC extension automatically. When you open a DC3 or DC5 file for the first time, it is
automatically converted to an AEC file. This conversion process takes a few moments longer than usual.
In the process, the drawing file is cleaned up and purged of unused entities and the database is converted
from single-precision to double-precision.
DataCAD 11 and later use double-precision floating point math to calculate and store values in the
drawing database. Versions of DataCAD prior to 11 had an effective accuracy of ~7 decimal places.
DataCAD now has an effective accuracy of ~14 decimal places. That means DataCAD is as accurate as
AutoCAD® and you can work on much larger projects without running into rounding issues, especially
when importing large drawings.
DataCAD has five options for opening a drawing:


opening an existing DataCAD drawing



creating a new DataCAD drawing



creating a new DataCAD drawing using a default drawing



importing a DWG or DXF drawing file



double-clicking on DataCAD drawing files in Windows Explorer

If DataCAD does not start, review Chapter 1 to make sure you meet all system requirements. Please see
the first page of Chapter 1 for details on how to contact technical support.
If someone on your network is still using the file that you want to open, DataCAD can determine whether
it is “in-use.” Every time you open a drawing, DataCAD records the date, time, username, and
workstation name in a corresponding user (.U$R) file. If you try to open a drawing file that is “in-use,”
DataCAD will only allow you to open a copy of the file.
If you exit a file abnormally, DataCAD will automatically try to recover the most recent version of your
file without prompting you with unnecessary warnings and options.
For more information about file formats, see “More About Working with Files” near the end of this
chapter. For more information about recovery files, see “Backing Up and Recovering Files” near the end
of this chapter.

Opening an Existing Drawing
You can open a DataCAD drawing when you first start DataCAD, while you’re working on another
DataCAD drawing, or after you exit all drawings on your screen.
 To open an existing DataCAD drawing:
1.

Start DataCAD. If DataCAD is already running, click Open in the File pull-down menu. A dialog
box opens, listing all files in the current folder.
Shortcut: Press (Ctrl) + (O) to open an existing drawing file.

2.

Select the type of file you want to open from the Files of Type drop-down box. You can open any
DataCAD (DC3, DC5, AEC), DataCAD Plus (DC+), backup (DBK), or autorecover (ARF) files.

3.

Click on the drawing you want to open to highlight it. If the Show Preview option is checked, a
bitmap version of this drawing will be displayed in the preview window on the right side of the
dialog box. If you don’t want to see a preview of an existing drawing, simply click in the Show
Preview box to remove the checkmark.
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Figure 2.1: preview window displays a bitmap version of the drawing
4.

Click on Open or press (Enter) on your keyboard. The drawing is opened. If a message displays
alerting you to orphaned reference files, see the “Referencing Drawings” section in this chapter
for instructions on resolving these orphaned files.

Working with Folders in DataCAD’s Save and Open Dialog Boxes
You’ll probably want to store your DataCAD drawings for each project in separate folders. If you have
two projects, you might, for example, create two folders named PROJECT1 and PROJECT2 in DataCAD’s
\Drawings folder.
 To create a new folder in DataCAD:
1.

Start DataCAD or click on New in the File pull-down menu.

2.

Click on the Create New Folder icon in the Enter name of drawing file to edit dialog box. The Create
New Folder icon is at the top of the dialog box. A new folder appears in the dialog box.

3.

Type the name of the folder and press (Enter).

Obviously, a new folder has nothing in it when you create it. Only after you save drawings to that folder
will the drawing filenames appear in the dialog box.
You’ll also want to save files to - or open files in - a different folder than what’s displayed in the dialog
box. To do this, you’ll first have to change folders.
 To change folders in a dialog box:
1.

Click on the arrow for the “Look in:” drop-down box and select a new folder; or

2.

Click on the Up One Level icon and select a new folder from the list; or

1.

Double-click on a folder to open it.

Creating a New Drawing
You must name your new drawing before DataCAD will open it.
 To create a new drawing:
1.

Start DataCAD; if DataCAD is already running, click on New in the File pull-down menu. A
dialog box appears with the title Enter name of drawing file to create.
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Shortcut: Press (Ctrl) + (N) or press (Alt) + (N) to start a new drawing.
2.

Type a name for your new drawing in the Filename input box. The drawing name can consist of
letters, numbers, spaces, and any other characters except the following reserved characters: < > : "
/\|?*

3.

Click on Create or press (Enter). The new drawing is opened.

(Pro) Creating a New Drawing Using a Default Drawing
A default drawing is used as a pattern for creating a new drawing. Simply choose the default drawing;
then create your new drawing. Or you can use the Default Drawing setting available through
Tools/Program Preferences to automatically use a selected default drawing every time you start a new
drawing. DataCAD 11 and later drawings have an AEC file extension; default drawings created using
earlier versions have a DC5 file extension.
 To create a new drawing using an existing default drawing:
1.

Start DataCAD; if DataCAD is already running, click on New in the File pull-down menu. A
dialog box appears, prompting you to Enter name of drawing file to create.

2.

Make sure there is a checkmark in the “Use default drawing” box. If there is no checkmark in this
box, the Default file information is greyed out and the Default button is disabled.

3.

Decide if you want to use the suggested default drawing or prefer another one.


If you want the suggested default drawing, go to step 6 and create the new drawing file.



If you want to use a different default drawing, go to step 4.

4.

Click on the Default button. A dialog box appears, prompting you to Choose new default drawing
name. Notice that DataCAD automatically displays the contents of the Default Drawings folder.

5.

Click on the file you’d like to use from the Default Drawings folder; then click on Open or press
(Enter). The dialog box closes. You’ve just told DataCAD which default drawing to use to create
your new file. Notice that the default drawing file you selected appears to the left of the Default
button. Now you must create the new drawing file.

6.

Type a name for the new drawing you’d like to create in the Filename input box of the Enter name
of drawing file to create dialog box.

7.

Click on Create. Your new drawing file is created, with all the settings of the default drawing you
selected.

If no default drawing is specified in the Configure DataCAD for Windows Settings dialog box or through
the “Enter name of drawing file to create” dialog box, DataCAD uses its internal default settings for the
new drawing. To use these internal default settings, either toggle off Use Default Drawing on the Misc.
tab in the Configure DataCAD for Windows Settings dialog box (available when you select Program
Preferences from the Tools pull-down menu) or toggle off (remove the checkmark from) “Use default
drawing” in the “Enter name of drawing file to create” dialog box.
 To automatically use the same default drawing for every new drawing:
1.

Open any drawing file. (The Tools pull-down menu is not available unless a drawing file is
open.)

2.

Click on Program Preferences in the Tools pull-down menu. The Configure DataCAD for
Windows Settings dialog box appears.

3.

Click on the Misc. tab.
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4.

Make sure there is a checkmark in the Use Default Drawing box.

5.

Choose a default drawing from the drop-down box.

Figure 2.2: default drawing from the drop-down box
6.

Click on OK to save your new settings and close the dialog box. The default drawing you chose
will now automatically be used each time you start a new drawing, unless you specify a different
default drawing using the Default button in the “Enter name of drawing file to create” dialog box
described in the previous instructions.

(Pro) More About Default Drawings
Default drawing files are just regular DataCAD drawing files that are stored in your \DataCAD\Default
Drawings folder and used in a different way than your regular drawing files. A default drawing contains
predefined information and settings and is used much like a pattern for creating new drawings. You can
create your own default drawings with system settings, layer names and colors, text font and size,
dimension settings, display options, scale type, object snap settings, line type spacing, and more already
set. Using a default drawing can save you time in setting up each new drawing.
Setting up a system of default drawing files at different scales and for different types of work can
significantly reduce production time for drawings and provide consistency in work done by different
designers in your office.
 To create a new default drawing:
1.

Create a new drawing as described earlier in this chapter.

2.

Set whatever options you’d like your new drawings to have, including grid settings and layers.
See the “Before You Draw” chapter for more information about many of these settings.

3.

Save the file in your \DataCAD\Default Drawings folder. It’s ready to use whenever you need to
create a new drawing.

Importing a DWG or DXF Drawing File
DataCAD’s drawing translator can import DWG and DXF files compatible with AutoCAD R12-R14,
R2000-R2002, R2004-2009, R2010-R2012, and R2013-R2016. You can choose an automatic translation or an
interactive one, where you can decide how each line type and font should be translated and displayed in
DataCAD.
Symbol Attributes appear as Block Attributes when you open a DWG file.
 To import a DWG or DXF file and open it in DataCAD:
1.

Select Open from the File pull-down menu. The Enter name of drawing file to open dialog box
appears.
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2.

Select DWG or DXF from the Files of type drop-down box. Choose DWG to display all DWG files
or select DXF to display all DXF files.

Figure 2.3: DWG, DXF, and other types of files can be opened
3.

Select a file to import from the list or type the name of the file to import in the File name input
box. By default, DataCAD looks for DXF and DWG files in your DataCAD\Transfer folder. If
your DXF or DWG files are in a different folder, change to that folder and then click on the file
you want to import.
You can open multiple files at the same time. Just highlight the first file, then press (Ctrl), and
continue highlighting other files you want to open. DataCAD adds all the files you selected to the
Filename field and will open all of them when you click on Open or press (Enter).

4.

Click Open. The DWG Import Entity Assignments dialog box appears if the Import section of the
DXF/DWG tab of the Configure DataCAD for Windows Settings dialog shows that “Interactively
assign . . .” is toggled on. The options in the DWG Import Entity Assignments dialog box allow
you to choose how DataCAD will translate line types and fonts.

5.

Look at the options in the Line Type Assignments box; this lists each AutoCAD line type used in
the file and suggests a DataCAD equivalent. To change any of these assignments, click on the line
type to change. The line type you selected appears immediately below the Assignment list box
with the translation line type in a drop-down box. Choose a new line type from the drop-down
box; your selection appears in the preview window. When you click on the line type in the list
box again, the name of the line type changes to reflect your choice.

6.

Repeat step 5 for the Font Assignments. You can specify DataCAD-supplied or TrueType fonts.

7.

Click on OK to close the dialog box and begin importing the file. Progress is noted in the Message
toolbar. Or click on Cancel to stop the import process and close the dialog box.
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Figure 2.4: The DWG Import Entity Assignments dialog box
More About Importing Files Into DataCAD
The settings and assignments that are displayed in the DWG Import Entity Assignments dialog box are
contained in a file called TRANSFER.INI in your DataCAD\Support Files folder. If you change any of the
settings in the DWG Import Entity Assignments dialog box, you have the option to save those settings in
a new .INI file to use when translating other files. This new .INI file is saved in the \Support Files folder.
You can affect how importing files and the DWG Import Entity Assignments dialog box work through
settings on the DXF/DWG tab in the Tools/Program Preferences Configure DataCAD for Windows
Settings dialog box.
This could be useful if you normally exchange files with several different offices. If you change the
settings and save a separate .INI file for each office, then you can easily switch between .INI files without
having to go through entity assignments repeatedly.
 To save entity assignments:
1.

Change settings and assignments in the DWG Import Entity Assignments dialog box as described
in the step-by-step instructions on importing DWG files.

2.

Click on Save As. The Save Settings As dialog box appears.

3.

Type a filename for the new .INI file and click on Save. Or click on Cancel to stop the save. When
you save the .INI file, the setting for the Translator Settings File on the DXF/DWG tab of the
Configure DataCAD for Windows Settings dialog box is changed to that file.

4.

Continue with step 7 in the instructions for importing a DWG or DXF file and opening it in
DataCAD.

Using Windows Explorer to Open Files
When DataCAD is running, you can launch drawings from the Windows Explorer file browser. Just
double-click on the drawing file you want to use and DataCAD will open it.
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A Brief Tour

Figure 2.5: The DataCAD Application Window

The Menu Bar
The Menu Bar is located along the top of the DataCAD screen and contains the File, Edit, View, Insert,
Create, Tools, Toolbox, Window, and Help pull-down menus. These menus give you quick access to
standard Windows functions as well as many of DataCAD’s most used features.
Notice that some menu options have keyboard shortcuts associated with them. For instance, the Open
option in the File menu has (Ctrl) + (O). Instead of using the mouse to choose a menu option, you can
simply press the keyboard shortcut to quickly do the same thing.
 To choose an option from the Menu Bar:
1.

Click on the menu name in the Menu Bar. The menu will drop down, displaying all the options in
it.

2.

Move your mouse down the menu to the option you want. Notice that each option highlights as
your mouse passes over it.

3.

Click on the option you want to select.

We've added hints for pull-down menu options in the MNU file. Hints appear on the Coordinates/Hints
Toolbar when you highlight a pull-down menu item.
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You can create keyboard shortcuts for any of the 250+ pull-down menu selections by editing the
DCADWIN.MNU file. Refer to the Appendix for further information on creating keyboard shortcuts for
the DataCAD menu items.

Toolbars
Toolbars surround the DataCAD Drawing Window. They give you quick access to a variety of DataCAD
functions, no matter where you are in the program. In addition to the standard DataCAD toolbars, you
can also use context-sensitive toolbars that appear when you perform various functions.
Icons, representing various DataCAD options, make up the toolbars. If you move your cursor over an
icon, a description or ToolTip pops up nearby. The description is also displayed in the Coordinates/Hints
toolbar.
DataCAD’s toolbars can be moved to a different screen position if Lock Toolbars is not checked in the
View pull-down menu; you can even put them on your desktop to give you a larger Drawing Window.
You can also reposition the DataCAD Menu Window if Lock Toolbars is not checked in the View pulldown menu. When Lock Toolbars is toggled on (checked) in the View pull-down menu, the grab bars
disappear, making it impossible to move any of the toolbars, including the Menu Window.
Using Toolbar Icons to Access Menu Functions
You can click on an icon in any of the toolbars to quickly perform many drawing and editing tasks. For
example, the

icon opens the Architect menu and displays the context-sensitive toolbar

that contains popular tools to help you draw walls,
doors, and windows. Clicking on the door icon opens a further context-sensitive toolbar

that offers door swing alternatives.
Notice that as you click on different icons, the menu for that function appears in the Menu Window.
Accessing menus using the toolbars instead of the Menu Window reduces the number of steps to get to a
menu and, thus, saves you time.
For more information on how to turn off display of the toolbars or how to choose which toolbar appears,
see Toolbars Dialog” and “Customizing DataCAD” in this chapter. There are even icons in some toolbars
that let you switch to a new toolbar.
Toolbars Dialog
The Toolbars dialog box appears when you select Toolbars from the View pull-down menu. This lets you
select the toolbars you want to display. Toolbars you don’t want to display have no checkmark in the box.
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Figure 2.6: The Toolbars dialog box
Standard Toolbar
The Standard Toolbar provides direct access to common Windows-based functions and to some
frequently used DataCAD ones.

Figure 2.7: The Standard Toolbar
Going from left to right, the Standard Toolbar icons give quick access to these functions: create a new file;
open an existing file; save changes to the current file; output your drawings to printer or plotter; check
file for spelling errors; select entities to cut, copy, or paste; cut selected entities; copy selected entities to
the clipboard; paste entities from the clipboard; undo utility; redo; reference DataCAD files; reference
bitmaps; hyperlink a web URL, file, or go-to-view; change the order of entities; and open the reference
manual.

Figure 2.8: You can change the order of entities in your drawing from the Standard Toolbar
You can add the following entry to the [KeyFile] section of the DCADWIN.INI file to automatically
append the toolbar (.DTB) of your choice to the DataCAD Standard toolbar.
[KeyFile]
Standard=My_Toolbar.DTB
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Navigation Pad Toolbar
The Navigation Pad Toolbar helps you quickly move about in your Drawing Window. It provides an easy
way to view your model and access the Identify and Zoom menus. You can display this toolbar
lengthwise or in the traditional square format. Traditionally, the second configuration is used so that the
arrows are more ergonomically correct.
The icons in this toolbar (from left to right on the lengthwise version) do the following: zoom view in; pan
view up; identify (accesses the Identify menu so that you can display the properties of an entity); pan
view to left; zoom view to drawing extents; pan view to right; zoom view out; pan view down; and zoom
to area (accesses the Zoom menu).

Figure 2.9: The Navigation Pad Toolbar
You can also use the keyboard arrow keys in the same way you use the Navigation Pad Toolbar arrows.
The pan distance, or how much the display shifts each time you use one of the arrow keys, can be set to
any value by selecting Scroll Dist. in the Settings menu. See “Setting the Panning Distance” in the
“Settings” section of the “Before You Draw” chapter.
Projection (view) Toolbar
The nine icons in the Projection Pad Toolbar control the type of view that appears in your Drawing
Window. The functions these icons initiate are also available from the View pull-down menu. You can
display this toolbar lengthwise or in the traditional square format. The icons in this toolbar (from left to
right on the lengthwise version) display the following types of views: parallel; front elevation;
perspective; left elevation; plan; right elevation; isometric; back elevation; and oblique (axonometric).

Figure 2.10: Two versions of the Projection Pad Toolbar
View-sensitive Viewer Toolbar
The Viewer Toolbar changes based on the type of view you select in the Projection Pad.
If you are displaying the plan or oblique (axonometric) view of your drawing, the Viewer Toolbar
contains the following icons (from left to right): refresh display; display model in object viewer; display
shaded view of model; remove hidden lines from 3D view; save current view; update selected view based
on current view; set a new clip cube; and enable (on) or disable (off) clip cube.

Figure 2.11: Viewer Toolbar for plan or oblique (axonometric) view
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If you display the parallel, elevation (front, back, right, left), or isometric view of the model, the Viewer
Toolbar adds several rotation icons to the basic eight: rotate +X; rotate –X; rotate +Y; rotate –Y; rotate +Z;
and rotate –Z.

Figure 2.12: Viewer Toolbar for parallel, elevation, or isometric view
If you display the perspective view of the model, the basic options remain, but the clip cube and
rotational options are replaced by others with different functions (from left to right following the basic
options): walk forward; walk backward; step left; step right; step up; step down; look up; look down; turn
left; and turn right.

Figure 2.13: Viewer Toolbar for perspective views of your model
Context-sensitive Toolbar
Context-sensitive Toolbars appear when you perform various functions. To determine what function each
icon performs, place your cursor on it for a few seconds to display a tool tip.
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Cleanup options:

Architect options:

Door Swing options:

Window options:

Polygon options:

Polyline options:

Modeling options:

Figure 2.14: Options shown as icons in context-sensitive toolbars perform the same functions as
those in the traditional left-hand menu
A user-definable, context-sensitive toolbar automatically changes to present related icons based on the
menu you choose. A configuration dialog allows you to easily set which user-defined toolbar is related to
a particular menu selection.
A new .CST file (Context-sensitive Toolbar) located in \Support Files\Toolbars contains a list of menus
that can be associated with toolbars. You do not need to edit this file manually.
Status Panel Toolbar
The Status Panel Toolbar provides quick access to color, layer, line type, scale, selection sets, go-to-views,
and input mode. An icon located to the left of each drop-down list accesses the related menu (i.e., the
Layer Manager icon appears next to the layer list). If you click on the icon, the appropriate dialog box or
left menu appears so that you can make your selection. Pull-down arrows on the right offer other options
for each icon (e.g., the input modes are displayed on the pull-down menu in the example).
When you are working on a drawing, this toolbar provides information on the current settings. See
Customizing Display” in the “Before You Draw” chapter for more information on Display menu options.
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You can set the number of pixels to add (positive value) to or subtract (negative value) from the status
toolbar. In the DCADWIN.INI, you can adjust the drop-down width:
[StatusArea]
DropDownWidth=
Open Layer Manager

Current Layer

Open Color Palette

Current Color

Open Line Type Menu
Layer Search Toggle
Open Selection Sets Menu
Open GoTo View Menu

Current Line Type
Current Display Scale
Active Selection Set
Last GoTo View Selected

Input Mode

Figure 2.15: The Status Panel Toolbar
Hotspots
The Status Panel Toolbar gives you one-click access to the Layer Manager, Color Palette, Line Type,
Selection Sets, and GoTo View menus. In the Status Panel Toolbar, just left-click on the item (text, color
swatch, or square) you want to change. DataCAD instantly takes you to the appropriate menu or dialog
box so you can make your new selection. For example, if you click on the active layer’s name, the Layer
Manager dialog box appears. Clicking on a hotspot in the Status Panel Toolbar has the following results:
Active layer’s color swatch – the Color Palette appears
Active layer’s icon – the Layer Manager appears
Current line type – the Line Type menu appears
Current selection set icon – the Selection Sets menu appears
Changing the Active Layer
In a drawing with multiple layers, pressing (Tab) changes the active layer by scrolling through all the
layers that are on. You’ll see the active layer name in the Status Panel Toolbar change each time you press
(Tab). Press (Shift) + (Tab) to scroll backward through your drawing’s layers.
Toggling Layer Search On or Off
You can click on the layer search toggle in the Status Panel Toolbar to quickly toggle layer search on or
off. If the toggle is depressed, layer search is on; if the toggle button is raised, layer search is off. The
Attention Toolbar lets you know if layer search is on or off. We’ll discuss DataCAD’s layer search option
in Selection Menus” later in this chapter.
Shortcut: Press the apostrophe key (‘) to toggle the layer search option on or off.
SWOTHLUDFBK Toolbar
SWOTHLUDFBK settings affect how a drawing is plotted as well as how it appears on the screen. The
[S]nap, [W]alls, [O]rtho, [T]ext, [H]atch, [L]ine weight, [U]ser-line, [D]imensions, [F]ills, [B]itmaps, and
[K]nockouts toggles are located on their own toolbar.
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Figure 2.16: Toggles that are off appear as lower-case letters
Coordinates/Hints, Attention, and Message Toolbars
The Attention, Message, and Coordinates/Hints Toolbars supply you with helpful warnings, input
requirements and fields, and coordinate information. The information that appears in each toolbar
depends on the function you are currently performing and the location of your cursor. If your cursor is on
a symbol in the Symbol Browser, the Coordinates/Hints Toolbar displays information about the location
of the symbol file. The Coordinates/Hints Toolbar can be resized when you dock it.

Figure 2.17: Helpful information and hints appear in these toolbars
The Pause Hint Toolbar appears to remind you of information you need to supply or displays the
appropriate left menu.

Figure 2.18: DataCAD reminds you to supply information when you use a macro
Multi-view Windows (a.k.a. MVTOTB™ Multi-view Tear-Off Toolbars)
The visual GoTo View Windows can be displayed in a toolbar that is turned on or off from the
View/Multi-view pull-down menu.
Shortcut: Press (Ctrl) + (W) to turn the Multi-view Windows toolbar on and off.
 To use Multi-view Windows:
1.

Create and name several GoTo Views.

2.

Set the number of Multi-view windows you want by selecting Toolbars from the View pull-down
menu and checking the appropriate number of Window boxes.

3.

Select Multi-view from the View pull-down menu.
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4.

Right-click within a window, select GoTo View, and choose a view that you created in step 1. The
view appears in the window.

Figure 2.19: Docked Multi-View Windows Toolbars
5.

Close the windows that do not display GoTo Views.

You can display up to 10 GoTo View windows plus undock and resize them to meet your needs. Once
displayed, right click on the GoTo View window for options. These windows may be torn off, re-sized,
and repositioned. When docked, they return to their original size.

Figure 2.20: Undocked Multi-view Windows
Classic Desktop
If you prefer the way your screen looked in DataCAD versions 10 and prior, you can use the Classic
Desktop portion of the Toolbars dialog box in conjunction with a few other changes to recreate that
traditional combined menu window, navigation pad, projection pad, and status area. For detailed
information, see “Going Back to the Traditional Menu Window Setup” later in this chapter.
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Dialog Boxes
Many times when you select a menu option or click on a toolbar icon, an associated dialog box will
appear on your screen. Some dialog boxes are informational and just require you to click OK to verify
that you saw the message. Other dialog boxes ask for more input (such as color selection, layer names, or
file names) before DataCAD performs a specific function.
If you want all dialog boxes to be centered, you can add an entry (CenterDialogBoxes=TRUE) to the
DCADWIN.INI file. By default, dialog boxes are not centered.
 To center dialog boxes within an application:
1.

Open the DCADWIN.INI file. This document contains instructions for various aspects of the
DataCAD software.

2.

Scroll to the end of the [General] section.

3.

Add the following line at the end of the [General] section:

CenterDialogBoxes=TRUE
4. Select Save from the File pull-down menu or press (Ctrl) + (S).
5.

Close DCADWIN.INI by selecting Exit from the File pull-down menu. The dialog boxes will be
centered within the DataCAD applications.

If you later decide that you do not want dialog boxes to be centered, just change that line in the
DCADWin.Ini file to read:
CenterDialogBoxes=FALSE

The Menu Window
While DataCAD’s pull-down Menu Bar has menus that contain shortcuts to many of DataCAD’s most
used functions as well as basic Window options, the majority of DataCAD’s menus are displayed in the
Menu Window.
There are two main menus in the Menu Window: the Edit menu and the Utility menu. To switch between
these two menus, click on the menu option in the Menu Window or simply right-click anywhere in the
DataCAD window. Open a drawing in DataCAD and try right-clicking a few times; notice the menu
selection changes between the Edit and Utility menus.
Both 2D and 3D menus are displayed in the Menu Window, but these menus are not interchangeable. For
example, the Move command in the Edit menu should not be confused with the Move option in the 3D
Menus.
Menus in the Menu Window are nested; there are many submenus available from the Edit and Utility
menus. Each of these submenus may, in turn, contain additional submenus and menu options. When a
submenu is being displayed, right-clicking exits the submenu and displays the previous menu in the
Menu Window.
Shortcut: Press (PgUp) and (PgDn) to scroll forward and backward through menu lists. This only works
when you’re in a menu with Scroll Fwrd and Scroll Back options. At all other times, these shortcuts are
used to change your drawing display scale.
The Menu Window lists the options in the currently selected menu. If a menu contains more items than
can be shown in a single list, a scroll forward option (Scroll Fwrd) appears at the bottom of the menu and
will be available until you reach the end of the list. Once you scroll forward in a list, a scroll back option
(Scroll Back) will also be available. As you move through DataCAD’s menu structure, the selections in the
Menu Window change to reflect the different commands associated with each option.
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Some DataCAD menu options are toggles, switches that can be turned on or off. When a toggle is on, the
button appears depressed. When a toggle is off, the button appears raised. To make it more obvious that a
toggle is on or off, you can select Program Preferences from the Tools pull-down menu, click on the
Menus tab in the Configure DataCAD for Windows Settings dialog box, and change the colors in the
Toggle On Button and Toggle Off Button areas.

Used to edit or
change your
drawing

Used to organize
your drawing

Used to change
system settings
Used to draw
objects and text

Go to 3D menus
Use a DataCAD
macro

Figure 2.21: The Edit (left) and Utility menus
12-Character Menu Option Labels and Tool Tips
The menu option labels use up to 12 characters. DataCAD versions prior to 11 had an 8-character limit.
Menus such as Architct and Dmension now read Architect and Dimension, respectively. The logic used to
calculate the default width and height of menu buttons has been adjusted to make them more compact. A
“Classic” option has been provided so you can restore the 8-character labels if you wish. For information
on restoring the 8-character labels, go to the “Customizing DataCAD” section in this chapter.
Tool tips for each menu item have been added to help you use each option. Just resting your cursor
briefly on a menu item displays the tool tip. The same tip also appears in the Coordinates/Hints toolbar.
Menu items in macros do not have tool tips.
Choosing Menu Options
There are four ways to choose a menu option:


click on it using your mouse



press the corresponding function key



use a keyboard shortcut or command line alias



click on an icon in one of the toolbars (described earlier in the “Toolbars” section of this chapter)

Many of the most productive DataCAD users employ keyboard shortcuts to enter values and choose
menu options while using the mouse to draw and enter other drawing information. With one hand on the
keyboard and the other on the mouse, you can draw in DataCAD very efficiently and quickly.
 To choose a menu option using the mouse:
1.

Move the cursor over the option in the Menu Window that you’d like to use. The menu option
highlights as the mouse cursor passes over it.
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2.

Click the left mouse button.

3.

Right-click (click the right mouse button) when you are finished using the function; this lets you
exit the menu.

Notice that immediately to the left of each menu option in the Menu Window is a label corresponding to
the function keys on your keyboard. Function keys are usually located across the top or on the left side of
your keyboard and are labeled as “F1,” “F2,” “F3,” etc. To choose a menu option, simply press the
corresponding function key. If a menu option’s function key label is S1 through S0, press (Shift) + (F1)
through (Shift) + (F10).
Using Keyboard Shortcuts to Access Menu Options
Keyboard shortcuts let you access a variety of functions quickly just by pressing one or two keys. For
example, you can press (A) on the keyboard to open the Architect menu from anywhere in DataCAD
instead of using the mouse to choose the option from the Draw Toolbar or Menu Window.
In this manual, all keyboard shortcuts are described exactly how they should be executed. If a shortcut
requires a lowercase letter, you will be instructed to press only that letter. If a shortcut requires an
uppercase letter, you will be instructed to press (Shift) and that letter simultaneously. For instance, the
snap grid can be toggled on and off by pressing (X) (a lowercase “x”); however, to open the Object Snap
menu via the keyboard, you must use an uppercase “X,” so you must press (Shift) + (X).
There are several shortcuts that will be particularly useful to you as you draw:
SHORTCUT
(Home)
(,)
(<)
(.)
(>)
(Esc)
(End)

(Delete)
(PgUp), (PgDn)
(P)
(U\u)

FUNCTION
Centers a drawing or view on the screen at the cursor’s current position. To reposition a drawing,
move the cursor to the new center and press (Home).
Deletes only the last entity you drew.
Deletes the last group you drew; you can also use Undo in the Edit pull-down menu.
Restores only the last entity you deleted. This shortcut does not undo your previous actions; it just
restores the deleted entity.
Restores the last group you deleted; you can also use Redo in the Edit pull-down menu. This
shortcut does not redo your previous actions; it just restores the deleted group.
Refreshes the screen using the information in Display List.
Terminates the screen refresh on the active layer only. To terminate the screen refresh on additional
layers, press (End) once for each additional layer. (End) does not affect the drawing file, only that
portion of it which appears. Save time on large drawings. Once the part of the drawing you want to
edit is redrawn, press (End) to cancel the rest of the refresh.
Terminates the screen refresh on all layers simultaneously.
Changes the display scale in increments specified in the To Scale menu. To zoom out, press (PgUp);
to zoom in, press (PgDn).
Restores the previous view and returns to the previous scale in one keystroke. DataCAD
remembers up to 25 previous views.
Redraws the screen using the most recent information in the drawing file database.

Some keyboard shortcuts can yield unexpected results if you don’t clearly understand what the
command does. For example, there’s a difference between Undo/Redo and Restore commands. The
results you get with the keyboard shortcuts (,), (<), (.), and (>) are not the same as what happens when
you use Undo or Redo. The keyboard shortcut for Undo (which negates the last command you used) is
(Ctrl) + (Z); this produces the same results as selecting Undo from the Edit pull-down menu or clicking
the Back button on the Undo/Redo Toolbar. The keyboard shortcut for Redo (which reinstates the last
command undone by using Undo) is (Ctrl) + (Y); this produces the same results as selecting Redo from
the Edit pull-down menu or clicking the Redo button on the Standard Toolbar.
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The Appendix has a complete list of all keyboard shortcuts in DataCAD plus instructions on how to
program your own shortcuts.

(Pro) Using the Command Line Alias
The Command Line Alias lets you assign a keyboard shortcut to a single or multi-character shortcut. You
can have unlimited multi-keystroke shortcuts. A command line alias can include up to 1,024 commands.
 To use a command line alias:
1.

Press (Ctrl) + (Spacebar). The Enter Alias browse box appears. You are prompted to Enter alias (or
“?” to select from list).

2.

Choose an alias in either of these two ways:


Type the alias you want to use and press (Enter).



Press (?) and then (Enter) to see the list of available aliases. Highlight the alias you want to
use and press (Enter) or simply double-click on the alias.

Figure 2.22: The Alias browse box
(Pro) Customizing the Alias Browse Box
The number of lines shown in the list as well as its width can be adjusted in the [Alias] section of the
DCADWin.Ini file. By default, the DCADWin.Ini file is in the DataCAD installation directory,
C:\Program Files\DataCAD.
 To customize the alias list box:
1.

Locate DCADWin.Ini and open it in a text editor, such as Notepad.

2.

Find the Alias section, as shown below:
[Alias]
Popup Width=300
Popup Lines=4

3.

Change the width and lines values as necessary and then save the file.

(Pro) Making an Alias
Aliases are stored in a text file in your Support Files folder called DCADWIN.DCA. Aliases use the same
shorthand as custom keyboard macros. An item in the Alias file looks like this:
[cr]
comment=draw circle by radius
alias=^;^S5^S1^
 To make an alias called “ep” that will take you to the Erase, Partial menu:
1.

Press (Ctrl) + (Spacebar). The Alias menu appears.

2.

Click on Settings in the Alias menu; the Alias Manager appears.
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3.

Go to the Alias input box; type the shortcut you want to use, in this case ep.

4.

Go to the Comment box; type a hint to describe the alias: Erase Partial

5.

Go to the Sequence box; type the required keyboard sequence for the command: ^;^F7^F9^. Note
that the format for a Command Line Alias is the same as a Keyboard Macro. You must separate
each function with a carat [^].

Figure 2.23: The Alias Manager
6.

Click on Add to add the new alias to the list.

7.

Click on OK to close the Alias Manager. Your alias is now ready to use.

(Pro) Keyboard Macros and Nested Aliases
Keyboard macro sequences used in (Alt) + (Key) combinations, toolbars, or command line aliases can
include up to 1,024 commands. ^F1, or ^Enter this line of text$, and ^12.5$ each equal one command, so
there is essentially no limit to the number of keystrokes per macro string.
You can use the PAUSE character (Alt) + (0170) "ª" when defining a keyboard macro string. Inserting this
character after a carat "^ª" causes the macro sequence to halt until you click or type. If the pause character
is followed by text (i.e., "^ªThis is a comment"), the text will be displayed in DataCAD as a prompt. You
may not use the dollar sign ($) character in comment strings.
You can call a command line alias from a keyboard, toolbar, or command line alias macro sequence,
allowing you to chain together existing aliases by name. To call a command line alias by name, precede
the command name with the special character (Alt) + (0169) "©". For example, (B^;^F7^ªSelect entity to
erase^©cp) calls the "cp" alias after going to the Erase menu and waiting for one input.

The Drawing Area
The Drawing Area, the largest in the DataCAD window, displays drawing contents. Lines, arcs, walls,
fixtures, and anything else you design are displayed. Although drawings in DataCAD are drawn at full
scale in an infinite field, you can display any portion of a drawing at any scale. In other words, you can
zoom in and out on your drawing, as needed. To do this, you can use the Disp. Scale and Zoom options
in the Utility menu. See “Viewing Drawings” later in this chapter for more information on zooming in
and out on your drawing.
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Customizing DataCAD
The Configure DataCAD for Windows Settings dialog box (available from the Tools/Program Preferences
pull-down menu) lets you customize folders for each DataCAD file type, how the DataCAD screen looks,
how the DWG/DXF translator works, and the macros available in the Toolbox pull-down menu, as well as
several miscellaneous settings.

Customizing Pathnames
The Pathnames tab in the Configure DataCAD for Windows Settings dialog box lists the default folders
that files are stored in.
To reset all folder names to their defaults, click Defaults in the bottom right corner of the Configure
DataCAD for Windows Settings dialog box.
 To change a path:
1.

Choose Program Preferences from the Tools pull-down menu.

2.

Click in the input box of the folder path you’d like to change and type a new path; or click on the
folder icon at the right of the path to be changed and browse for a new path.

2.

Click on OK to save your changes and close the dialog box; click on Defaults to reset all paths to
their DataCAD defaults.

If you enter a folder name that doesn’t exist, clicking on OK will simply highlight the incorrect folder.

Figure 2.25: The Pathnames tab on the Configure DataCAD for Windows Settings dialog box
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DataCAD tries to resolve invalid reference file paths. It does this by checking the current drawing file
folder for valid references. If a valid reference file is found in the current drawing file folder, it will be
used instead of the file designated in the original path; however, the original path will be retained.

Customizing DataCAD’s Interface
DataCAD features a customizable program interface. You can position toolbars and menus where you
want by tearing them off and docking them to the top, bottom, left, or right side of the application
window. You can also place toolbars and menus outside of DataCAD to "float" on your desktop, allowing
you to resize the drawing area without adversely affecting the user interface.

Figure 2.26: The Menus tab of DataCAD’s Program Preferences dialog
Setting the Screen Calibration
You can access the Screen Calibration dialog box by clicking on the Screen Calibration button on the
Drawing tab. You can measure the test pattern in either decimal inches or millimeters to adjust both the
screen scaling and aspect ratio.
 To calibrate your screen:
1.

Select Program Preferences form the Tools pull-down menu. The Configure DataCAD for
Windows Settings dialog box appears.

2.

Click on the Drawing tab.

3.

Click on the Screen Calibration button. The Screen Calibration dialog appears.
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Figure 2.27: The Screen Calibration dialog box
4.

Indicate which unit of measurement you are using by selecting either Inches or mm in the Units
section.

5.

Measure the horizontal and vertical lines inside the ellipse and enter their lengths in the boxes
provided at the bottom of the Screen Calibration dialog. Click on OK or press (Enter) when you
are finished.

Customizing Menu Labels
You can easily change menu and toolbar options to customize your DataCAD desktop.
Have you been a long-time DataCAD user? If so, you may prefer the old-fashioned set-up that was in
effect from version 10 and prior. In DataCAD version 10 and prior, the menu options, navigation pad,
projection pad, and status area was “glued” together (instead of the newer Toolbar elements that you can
position anywhere). You can get this classic appearance by making a few changes in the Configure
DataCAD for Windows Settings dialog box and the Toolbars dialog box.
 To change the menu labels and/or buttons:
1.

Select Program Preferences from the Tools pull-down menu. The Configure DataCAD for
Windows Settings dialog box appears.

2.

Click on the Menus tab and go to the Menus area.

3.

Change the appearance of Menu Window labels and buttons:


To use the traditional 8-character labels that were standard with DataCAD versions prior to
11, click in the Classic Labels box to insert a checkmark.



To use the newer, 12-character labels, make sure there is no checkmark in the Classic Labels
box.



To use the traditional button shape for menu options that was a standard feature of DataCAD
versions prior to 11, click in the Classic Buttons box to insert a checkmark.
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4.

To use the newer, button-free menu, make sure there is no checkmark in the Classic Buttons
box.

Click on OK to close the Configure DataCAD for Windows Settings dialog box.

.
Figure 2.27: Comparison of 12-character (left) and Classic 8-character (right) menu labels
 To change the colors of the Drawing Area, menu buttons, function key labels, and tool tips:
1.

Click on Program Preferences in the Tools pull-down menu. The Configure DataCAD for
Windows Settings dialog box appears.

2.

Click on the Menus tab, if it’s not already showing.

3.

Position your cursor on the color swatch that you want to change.

2.

Click to open a Color dialog box.

Figure 2.28: The Color dialog box lets you select new colors for the function key labels, buttons,
drawing area background, and tool tips
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5.

Choose a new color from the basic or custom colors available or mix your own on the right side
of the Color dialog box. Click on OK to close the Color dialog box.

6.

Repeat steps 3 through 5 to change the colors shown on any of the other swatches on the Menus
tab.

7.

Click on OK to close the Configure DataCAD for Windows Settings dialog box. The colors you
selected are in effect.

 To change the font used on the menu buttons in the Menu Window or the font used in the toolbars:
1.

Click on Program Preferences in the Tools pull-down menu. The Configure DataCAD for
Windows Settings dialog box appears.

2.

Click on the Menus tab, if it’s not already showing.

3.

Click on the Font button in the top left corner of the Menus tab to change the type on the menu
and toolbars. The Fonts dialog box appears.

Figure 2.29: The Font dialog box
5.

Choose a new font, font style, and size; then click on OK. The Fonts dialog box closes.

6.

Click on OK to close the Configure DataCAD for Windows Settings dialog box. The fonts you
selected are in effect.

Going Back to the Traditional Menu Window Setup
You can get the “classic” look that was standard prior to DataCAD version 11 by making a few simple
changes.
 To glue the Menu Window, Navigation Pad, Projection Pad, and Status Area together to produce the
traditional (DataCAD version 10 and prior) appearance:
1.

Select Toolbars from the View pull-down menu. The Toolbars dialog box appears.

2.

Eliminate the checkmarks in the Projection Pad, Navigation Pad, and Status Panel boxes in the
upper portion of the Toolbars dialog box.

3.

Click in the three boxes in the Classic Desktop portion of the Toolbars dialog box. When these
three boxes in the Classic Desktop portion are checked, these elements will be “glued” together
with the Menu Window to produce the traditional (DataCAD version 10 and prior) appearance.
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You could have duplicate toolbar elements if checkmarks still appear in the Projection Pad,
Navigation Pad, and Status Panel boxes in the upper portion of the Toolbars dialog box and you
added checkmarks to the three options in the Classic Desktop portion. This will not affect
DataCAD’s performance, but it will add unnecessary clutter on your computer desktop.

Figure 2.30: The Classic Desktop elements are activated
4.

Click OK to close the Toolbars dialog box. The menu, navigation, projection, and status elements
are “glued” together.
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Figure 2.31: The traditional “glued” together menu, complete with buttons, 8-character menu
labels, navigation pad, projection pad, and status panel
Selecting Default Icon Toolbars
There are four user-defined toolbars that can be active simultaneously. You can configure these toolbars
by selecting the Toolbars tab in Program Preferences from the Tools pull-down menu.
You can select any of the available toolbars from the pull-down menu for these toolbars. Your options are:
Architect, Cleanup, Dimension, Door Swing, Draw, Edit, Model, Notate, Polygon, Polyline, Symbol Scale,
and Windows.
In this example, the default toolbars are Edit and Draw.

Figure 2.32: The default Draw Toolbar with pull-down menu for one icon
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In the Draw Toolbar, the icons (from left to right) are: Architect menu – draw walls, doors, and windows;
draw lines; draw walls; cleanup intersections of lines and walls; place doors in walls; place windows in
walls; draw 2D polygon shapes; draw rectangular shapes; draw arcs, circles, and polylines (with
additional options available from a pull-down menu); add text to the drawing; draw arrow or select
arrow settings; dimension entities in the drawing; hatch entities in the drawing; and browse symbol
directories.

Figure 2.33: Default Edit Toolbar showing one of three pull-down menus
In the Edit Toolbar, the icons (from left to right) are: move drawing entities (with additional options
available from a pull-down menu); make copies of drawing entities (with additional pull-down menu
options); rotate drawing entities around a point; rotate and keep the original entities; mirror drawing
entities about a line; mirror drawing entities about a line and keep the original entities; scale the size of
the entities (with additional pull-down menu options); offset (copy entities parallel to existing entities);
delete entities from the drawing; identify (display the properties of an entity); identify/set all (change
current settings to match those of an existing entity); change the properties of existing entities; change the
properties of existing entities to match those of another entity; and measure drawing entities and perform
takeoffs.
Changing Other Interface Settings
You can personalize other aspects of the DataCAD graphical interface to suit your needs (especially
helpful if you are colorblind) or your tastes (eclectic versus conservative).
 To change other interface settings:
1.

Select Program Preferences from the Tools pull-down menu. The Configure DataCAD for
Windows Settings dialog box appears.

2.

Click on the Menus tab. The settings affect the left menu and message lines; pull-down menus
cannot be changed.

3.

Decide what colors you want to change, click on the appropriate sample swatch, and select the
color you want from the Color Palette dialog box.
Function key label Located at the left edge in the left-hand menu.
Buttons
Each menu button has a highlight, text, and text highlight color that you can change.
Highlight Color appears when you run your cursor over a regular (not a toggle) menu
button; Text Color affects the text on the non-highlighted menu button; Text Highlight
Color appears on a highlighted button as your cursor passes over it.
Menu
Clicking on a menu button calls up a submenu or requests input.
Active Layer
Affects only the active layer button, not the inactive ones.
Toggle ON
Affects just the active menu functions (the button is depressed).
Toggle OFF
Affects just the inactive menu functions (the button is raised).
Background
Drawing window color.
Tooltips
Background color of tooltip.
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4.

Decide what fonts you want to change, click on the appropriate Font button, and select font, style,
and size from the Font dialog box:
Menu Button
Drawing Area

5.

Use the slider bars to set how long tooltips should appear.
Display Delay
Hide Delay

6.

Affects text that appears in the left-hand menu and in the message, error, and
coordinate toolbars.
Affects text displayed in your Drawing Window by macros.

Affects how fast a tooltip appears from the moment your cursor hovers on a function.
Affects how quickly the tooltip disappears.

Click on OK to make your changes take effect. If you click on Defaults, DataCAD ignores your
changes and asks you to confirm your decision before it restores the original interface settings.

Figure 2.34: This warning appears if you click on Defaults to restore DataCAD’s original interface
settings

Customizing File Translation
The DXF/DWG tab on the Configure DataCAD for Windows Settings dialog box (via Program
Preferences from the Tools pull-down menu) lets you choose an import method, translator default
settings, and 3D entity export method. DXF/DWG supports solid fills, TrueType fonts, polylines with
voids, and complex hatch patterns (such as StoneCAD).
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Figure 2.35: The DXF/DWG tab on the Configure DataCAD for Windows Settings dialog box
You can choose between two import methods: the first method allows you to interactively (manually)
assign line types and fonts, while the second makes these assignments automatically, according to the
Default Import Settings in the Configure DataCAD for Windows Settings dialog box. The interactive
option is the default method and uses the DWG Import Entity Assignments dialog box. The DWG Import
Entity Assignments dialog box appears during the import process only if the interactive option is
checked.
There are several Default Import Settings you can change as well. Set the default font, line type, base unit,
enlargement factor, and translator settings file to use during import. These defaults will be used as
assignment suggestions if you opted for the interactive import method; however, with automatic
translation, they will be used when DataCAD has no equivalent for an existing entity in the DWG or DXF
file. To change any of these settings, click on the arrow to the right of the drop-down box and select
another setting. You can also check the “Move drawing to origin” option to move drawing geometry to
absolute 0 during import. This option is unchecked (off) by default.
During export, the line definitions and shape codes for DataCAD line types are stored in a .SHX file. If
you export a DataCAD drawing named MYDRAWING.AEC, the translator will create two files:
MYDRAWING.DWG and MYDRAWING.SHX. In order for the line types in the DWG file to display
properly, the .SHX file must be placed in the \SUPPORT folder in the AutoCAD folder. The AutoCAD
user may also place the .SHX file in the same folder as the .DWG file. A .SHX file is only created if line
types other than Solid, Dashed, Dotted, or Dot-Dash are used.
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If you’re not concerned with line types displaying exactly as you drew them, check the User-defined Line
Type Export box in the Tools/Program Preferences Configure DataCAD for Windows Settings dialog box.
This will convert all user-defined line types (any line type except Solid, Dotted, Dashed, and Dot-Dash) to
Continuous when exporting a DataCAD drawing to a DWG or DXF file. In this case, a shape file will not
be created because none is needed; instead, all user-defined line types in MYDRAWING.AEC will be
permanently translated to the Continuous line type. The User-defined Line Type Export toggle in the
Configure DataCAD for Windows Settings dialog box is off by default.
Both DataCAD and AutoCAD define colors in terms of their place in each program’s internal color list.
For instance, in DataCAD's code, Color 1 = White, Color 2 = Red, Color 3 = Green, etc. While we see white,
red, and green colors on screen, DataCAD recognizes these only as Color 1, Color 2, and Color 3,
respectively. AutoCAD works similarly, except AutoCAD displays Color 1, Color 2, and Color 3 as red,
yellow, and green, respectively.
So, if you don’t have the Import/Export Color Translation toggle checked when you export a DataCAD
file, the resulting DWG/DXF file will only associate “Color 1,” “Color 2.” etc., with each entity. When the
file appears in AutoCAD, the program recognizes “Color 1” and displays the entity as red, instead of
white as it was drawn in DataCAD. With the Import/Export Color Translation toggle on, the table file
corrects for this, so that white entities in DataCAD are displayed as white when exported to a DWG/DXF
file and vice versa.
The Import/Export Color Translation toggle (which is on by default) tells DataCAD to use a table (.TBL)
file so that colors translate properly when exported to or imported from a DWG/DXF file. An easy way to
create a table file is to simply save DEFAULT.TBL under a new name that matches the custom RGB file.
You can select DXF/DWG Color Map from the Tools pull-down menu to create a TBL file to match the
currently selected RGB file. You must create this file for each custom RGB file. It should be given the same
filename as the currently selected RGB file and saved in the DataCAD\Support Files folder.

Figure 2.36: The DXF/DWG Color Map File
The 3D Entity Export option, located near the bottom of the DXF/DWG tab, is unchecked (off) by default.
Any 3D entities in a DataCAD (.AEC) file will be translated as a polyface mesh when exported to a DXF
or DWG file; this polyface mesh is a single entity. However, by checking the “Decompose 3D entities as
3D faces” option, each facet of a 3D entity will be turned into an individual polyface; thus, a single sphere
in DataCAD can be translated into many separate entities arranged in a sphere shape in a DWG or DXF
file.
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Checking the Decompose option can make translation faster and the translated entities will look the same
after a shade or hidden line removal. However, editing may be more difficult since these translated 3D
entities are made up of many smaller and separate entities.
Check the “Automatically export reference files” option in the Reference Files section of the DXF/DWG
tab to export any XREFs you’ve used in your drawing at the same time you export the drawing itself.
Each reference file is exported as a separate .DWG file. This option is checked by default; if you uncheck
it, XREFs will not be exported along with your drawing. If you send your drawing to a co-worker or
client, be sure to send all of the exported reference files as well so your drawing will be viewed as you
intended.
You can toggle on “Expand exported stamps to values” in the final section of the DXF/DWG tab. When
this box is unchecked, the stamp will export in its raw token format (i.e., @PLTTIME). When this box is
checked, the stamp will export as it appears in DataCAD (i.e., 12:00 P.M.).

Customizing the Macros Menu
The Macros tab in the Configure DataCAD for Windows Settings dialog box (Tools pull-down menu) lets
you choose which macros you want to be displayed in the Toolbox pull-down menu. To add macros to
the menu, click on the macros in the Available Macros list box, then click on the Add button. To delete
macros from the menu, click on the macros in the Macros in Menu list box and then click on the Remove
button.
The Available Macros list box contains all macros that you have installed (normally found in the
DataCAD\Macros folder). It is possible to add macros that are located in other folders: click on the file
folder button above the Available Macros list box to browse different folders and select macros to add to
the list.
You aren’t uninstalling macros when you remove them from the Toolbox pull-down menu. Macros
removed from the Macros in Menu list simply won’t be displayed as options in the pull-down menu.
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Figure 2.37: The Macros tab in the Configure DataCAD for Windows Settings dialog box

Customizing Miscellaneous Settings
The Misc. tab on the Configure DataCAD for Windows Settings dialog box (select Program Preferences
from the Tools pull-down menu) lets you customize DataCAD’s functionality.
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Figure 2.38: The Misc. tab in the Configure DataCAD for Windows Settings dialog box
(Pro) Default Drawing
You can set a default drawing to be used automatically when you create new drawings. To do this, check
the Use Default Drawing box and select the file you want from the drop-down box.
Default Character Set
You can select a default font for text that you enter into your drawing. Simply click in the SHX dropdown box to choose a default DataCAD font. Also, use the TrueType drop-down box to select the default
Windows font.
(Pro) Saved Drawing Sessions
Click in the Enable Sessions box to activate this option. Select the number of sessions you want to save by
using the up/down arrows. Click in the Use Fixed Path box if you always want to store your drawings in
a particular folder. Select a folder to hold your drawings by clicking on the folder icon, choosing the path
you want from the folders in the Browse box, and clicking on OK when you want to return to the Misc.
tab.
Copy to Clipboard
The Copy to Clipboard section has three options, “Copy entity color,” “Copy entity line weight,” and
“Expand exported stamps to values.” The first two options are both checked (on) by default. When you
select a DataCAD entity to copy, these options cause the entity’s color and line weight to be copied as
well. Then when the entity is pasted into another document, the entity displays as it did in the original
drawing.
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The “Expand exported stamps to values” option lets you determine the format of stamps when they are
either copied to the clipboard or exported via DXF/DWG. When this box is unchecked, the stamp will
export in its raw token format (i.e., @PLTTIME). When this box is checked, the stamp will export as it
appears in DataCAD (i.e., 12:00 P.M.).
Previous View (Now on Interface tab)
DataCAD can remember up to 25 previous views (at set scales) of your drawing. If you’d like Free Zooms
and pans and scrolls to be included in these previous views, check Remembers FreeZooms and
Remembers Pans/Scrolls in the Previous View section of the Misc. tab.
Shortcut: Press (P) to return to the previous view.
(Pro) Current Plot Scale
If this box is checked, the current plot scale is saved with GoTo Views.
And Copy Toggles (Now on Menus tab)
The And Copy Toggles option determines whether the status of the And Copy toggles in such menus as
Move, Rotate, Enlarge, and Mirror is remembered by DataCAD. By unchecking Remember On/Off Status,
the And Copy option in the menus will always be toggled off when the menu is opened.
(Pro) PgUp/PgDn in Text Menu (Now on Drawing tab)
Normally, pressing (Page Up) and (Page Down) changes your drawing scale. If you have PgUp/PgDn in
Text Menu checked on the Misc. tab and Text Scale is toggled on in the Text menu, pressing (Page Up)
and (Page Down) will not only change the drawing scale but also the plotting scale. With Text Scale on in
the Text menu, text is always inserted at a size relative to the current plot scale. If the toggle is on in the
Configure DataCAD for Windows Settings dialog box, then you can change the current plot scale by
pressing PgUp\PgDn rather than selecting the Plot Scale button in the Text menu. The Plot Scale button
only appears when the option is OFF in the Configure DataCAD for Windows Settings dialog box and
Text Scale is ON in Text menu.
Clip Cube (Now on Drawing tab)
There is also an option to display the boundary of a clip cube. Check Display On in the Clip Cube section
of the Misc. tab. See the “Viewing Your Model” chapter for more information on using clip cubes.
Scroll Wheel Zoom (Now on Drawing tab)
The Scroll Wheel Zoom section of the Misc. tab controls how you zoom in and out using your mouse
wheel. As a default, “Requires Ctrl key” is checked. This means that you must press (Ctrl) while you
move the mouse wheel to zoom in and out on your drawing. The zoom factor is +/- 25%.
Drawing Indicators (Now on Drawing tab)
There are three options you can activate in this section of the Misc. tab. Click in the appropriate box to
Show current reference point and to Show Object Snap point. You can also set the drawing origin
indicator by checking Absolute Zero.
Nested XREFs (Now on Drawing tab)
You can disable XREF nesting on a global basis. To do this, make sure there is no checkmark in the Allow
Nesting box.
When “Inherit current highlight setting” is unchecked in the Nested XREF section, the nested XREFs will
retain their highlight settings if you insert them in another drawing file. If the box is checked, the drawing
file’s current settings will be used for XREF highlighting.
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(Pro) Display External (Now on Interface tab)
You can display external line types and/or hatch pattern definitions that have not been embedded into
your drawing. To do this, check the Line Definitions and/or Hatch Patterns boxes. The default is to
display these.

Common Menus in DataCAD
There are several types of menus that appear frequently as submenus throughout DataCAD, including
selection, value, and color menus.

Selection Menus
Selection menus appear frequently in submenus throughout DataCAD. Selection refers to the way you
mark drawing entities for editing purposes. There are three primary ways to select drawing entities: by
Entity (one at a time), by Group (when multiple entities have been associated with one another), or by
Area (an editing box stretched around entities).

Figure 2.39: From left to right, examples of Entity, Group, and Area selection
Along with Entity, Group, and Area, selection menus include several other methods for selecting parts of
the drawing to edit. All of the options are not available in every selection menu; selection menus are
tailored for each editing option. Selection menu options can include:
Entity
Group
Point
Area
Fence
Crossing
Mask
Sel. Set
Layer Search

Select drawing entities one at a time; this is the default selection method.
Select entities that are associated as a group.
Select entities by a single point; available only when using Stretch.
Select geometry wholly contained within an area that you define with a rubber band box.
Select geometry wholly contained within a fence that you define with a temporary polygon boundary.
Select any entity that crosses an area or fence boundary.
Define selection filters on the fly. (Pro)
Select entities that are associated in a selection set. (Pro)
Editing operations search all layers that are toggled on.

More About Selection Menus
An entity is a straight or curved geometric element defined by two endpoints. A line, a circle, an ellipse,
and an arc are all entities. A B-spline or Bezier curve or a line of text is also an entity, as is a symbol,
associative dimensions, and associative hatching. There are also 3D entities, such as slabs, spheres, and
cylinders. Entities can be edited alone or as a group.
A group is a set of any number of entities, linked together logically but not necessarily graphically.
Entities that do not touch may be part of the same group, and entities that are contiguous may be part of
different groups.
Entities are linked as a group in several ways. A group of entities drawn in succession without
disconnecting the cursor are linked as one group. Similarly, a series of lines of text entered at the same
time are linked as one group. You can link entities or groups of entities using the Group option in the Edit
menu. Entities are also grouped when they are created at the same time with the Copy option. If the And
Copy option is toggled on when you use Move, then the copies will be a single group. When an existing
entity is edited, with the Change or Move options for example, it retains the same group associations.
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The grouping together of entities in DataCAD allows you to edit many related items without affecting
other entities in the same portion of a drawing. Because groups are also easily redefined, the designer can
organize a drawing as a series of elements composed of logically related pieces or entities.
You can also select entities by area or fence. Area selection uses a box, which is temporarily drawn around
the entities you want to select. All entities and groups enclosed completely within this area box are
included in the area selection. Any entities and groups partially enclosed or not enclosed within the area
box are not included in the area.
The orientation of the rubber band box for area selection matches the angle of the cursor or grid. When
you choose Area from the selection menu for the operation you want to perform, the Rotate toggle
appears. When you toggle Rotate on, you can align the rubber band box to the cursor or grid angle. If
Rotate is on, DataCAD reverts to ortho boxes. If Rotate is off, the rubber band box aligns with the
drawing window. For more information about grid angles, see “Setting the Grid Angle” in the “Before
You Draw” chapter.
Similar to an area but allowing more flexibility, fence selection uses a polygon with up to 100 sides
(previous versions were limited to 36 sides), which is temporarily drawn around the entities you want to
select. The fence polygon can be concave or convex and must be closed to complete the selection process.
Crossing is a toggle available during area and fence selection that you can enable after selecting the first
point of the rubber band box. Using Crossing, you can select any entity that crosses the rubber band box,
along with any entities fully within the box. Crossing works with all editing commands except Stretch.
A selection set is a user-defined set of entities and/or groups. Selection sets provide increased efficiency
during editing by reducing the time required to select entities or groups, or define areas or fences. A
selection set may contain any number of entities or groups, and up to eight different selection sets may be
defined. You can only edit active selection sets. Add or remove entities from selection sets with the Sel.
Sets option in the Edit menu. See “Working With Selection Sets” in the “Editing Drawings” chapter for
more information on using selection sets.
Press (Alt) + (1) through (Alt) + (8) to change the active selection set when editing. While in an edit
command, such as Move or Erase, press (Alt) + (2), for example, to switch to selection set 2.
(Pro) Mask replaces the Selection Set option in the selection method portion of many DataCAD menus.

Figure 2.40: The Mask (left) option lets you set selection filters (right)
Mask lets you define selection filters on the fly. The Mask filters you can activate and set are Entity, Color,
Line Type, and Weight. Previously-defined masks are retained for subsequent editing operations.
Layer Search controls whether or not DataCAD scans all layers during selection operations. If you toggle
Layer Search on, you can select entities on all layers that are on (being displayed). When the Layer Search
toggle is off, you can select entities only on the active layer (the layer you’re currently working on). We’ll
cover layers in more depth later in this chapter.
Shortcut: Press the apostrophe (‘) - single quotation mark - to toggle layer search on or off.
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In addition to the button in the Menu Window, a Layer Search Status Toggle is located in the Status Panel
of the DataCAD window. If the Layer Search icon is depressed, layer search is on; if it’s raised, layer
search is off. Click on the toggle button to turn Layer Search on or off with a single mouse click.
More About 3D Selection Menus
The 3D selection menu options are identical, with a few exceptions for Area and Fence. When using Area
and Fence for 3D entities, most entities are selected when all the endpoints of each displayed line segment
and all displayed markers (such as center points for cylinders) lie within area or fence boundaries.
When using 3D Fence selection, however, it’s possible to select some 3D entities by enclosing their
endpoints but not enclosing other parts of these entities. If your fence polygon is concave, for instance,
you could enclose the endpoints of a slab and still have the middle part of the slab lie outside the
polygon. The entity is still considered in the fence if the endpoints lie within the fence. But if any endpoint
of an entity lies outside the fence, the entity is considered outside the fence and is then not selected.
Selection by Area and Fence is independent of the current Z-base and Z-height settings. You can think of
the region enclosed by the area or fence as going back into the screen infinitely. If you can see the region
and it falls inside the boundary, the region is selected when you enclose it with an area or fence.
The following list includes the portions of an entity that must lie within the boundaries of the area or
fence to be selected:
3D Lines
Polygons
Blocks
Slabs
3D Arc
Cylinder
Symbol
Cone
Truncated Cone
Sphere
Torus
Mesh Surface
Surface of Rev.

Entire line.
Endpoints of all displayed edges, including endpoints of void edges.
Endpoints of all edges which directly determine the shape of the block.
Endpoints of all displayed edges, including endpoints of void edges.
Entire arc.
Entire cylinder
The symbol reference point.
Entire cone.
Entire truncated cone.
Entire sphere.
Entire torus.
Any control points; the surface and the control grid are ignored.
Entire surface of revolution.

Value Menus
Some DataCAD functions require you to enter a numerical value. When you choose one of these
functions from a menu, a list of values appears in the Menu Window, followed by these options:
Match
Add/Subtract
Clear
To Layer

Matches an existing value, entity, or angle; click on Match, then click on the entity to match.
Adds or subtracts one or more values from a given value; click on the option and then the number to
add or subtract
Returns the given value to zero and starts again (Clear does not function like Undo); choosing Clear
and then pressing (Enter) will accept a value of 0.
Puts an entity on more than one layer or on a different layer than you are currently working on;
available when you have more than one layer in the drawing.

You can select a value from the list, use the options on the previous page, or type any value and press
(Enter). The total appears in the prompt line in the Message Area but is not entered until you press
(Enter).
The decimal separator for all displayed dimensions and numbers is determined by the value of the
Windows Decimal Separator. To set this value, click on Control Panel in the Start/Settings menu on your
Windows desktop. Double-click on Regional Settings. On the Number tab, set the Decimal symbol value.
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DataCAD’s Online Calculator
DataCAD’s online calculator is available anytime you need to enter a value, such as a distance or angle.
Any time DataCAD prompts you to enter a value, you can simply type = and your equation; DataCAD
will automatically calculate the value. The online calculator supports pi; you can type pi in any equation.
Distances must be entered in decimal units; however, the results will be displayed according to the Scale
Type setting. For instance, the default setting, Architectural (Imperial) units, will display in
feet/inches/fractions of inches. See “Setting Scale and Angle Types” in the “Before You Draw” chapter for
more information on the Scale Type and Angle Type options.
The online calculator assumes angles are entered in radians, but you can enter an angle in degrees simply
by typing d immediately after the value. Results for angle calculations will be displayed according to the
Angle Type setting, with the default being Normal (in degrees/minutes/seconds).
The calculator can do the following kinds of operations:
OPERATION
EXAMPLE
Addition
=4.5+5
Subtraction
=7-2.5
Multiplication
=6*4.5
Division
=45/3
Parenthetical
=(4+3.5)*(8/2)
Square
=SQR(3)
Square Root
=SQRT(16)
Cosine
=COS(35d)
Sine
=SIN(35d)
Tangent
=TAN(35d)
Arc Tangent
=ATAN(12,16)
Natural Logarithm
=LN(9.3)
Z-Base
=ZBASE+1
Z-Height
=ZHITE+1
Last X
=LASTX+1
Last Y
=LASTY+1
Last Z
=LASTZ+1
Truncate
=TRUNC(123.456)
Fraction
=FRAC(123.456)
Logarithm
=LOG(1000)
Raised to the power of =10^2
Exponential
=EXP(1)
Absolute Value
=ABS(-123.456)
PI
=PI

CALCULATED VALUE
9.6 (9’-6”)
4.6 (4’-6”)
27.0 (27’)
15.0 (15’)
30.0 (30’)
9.0 (9’)
4.0 (4’)
0.9.27/32 (9 27/32”)
0.6.7/8 (6 7/8”)
0.8.13/32 (8 13/32”)
0.6435 radians (36.87)
2.23 (Base 2.71828)
Current Z-Base + 1
Current Z-Height + 1
X, Y, or Z coordinate of last point
selected relative to
absolute zero
123
0.456
3 (Base 10)
1000
2.718281828
123.456
3.14159265359

Following are two examples to illustrate how to use the online calculator to quickly figure scales and
angles.
 To define a new plotting scale:
1.

Click on Edit Defs. in the Settings menu.

2.

Click on Scales in the Edit Defs. menu.

3.

Click on Change to modify an existing scale.

4.

Select the scale to change from the menu.

5.

Look at the prompt to Enter new string for this scale. Enter 1/32 for the menu button name.

6.

Respond to the prompt to Enter new scaling value for this scale by typing =(1/32)/12 and pressing
(Enter) to get the result 0.002604167.

COMMON MENUS IN DATACAD |
7.

Press (Enter) to accept this value as a new scale factor.

 To calculate an angle:
1.

Respond to the prompt to enter an angle by typing =ATAN(6,12), where 6 is the rise and 12 is the
run.

2.

Press (Enter) to calculate an angle of 26.33.54, or 26 33’ 54”.

Color Menus
When an option requires you to assign a color, a list of colors appears in the Menu Window along with
the options Color Number, Custom, Match, and No Change.

Figure 2.41: A sample color menu
Custom opens the Color Palette dialog box so you can change a color by adjusting its red, green, and blue
(RGB) and hue, saturation, and brightness (HSB) values. To work properly, it requires a 256-color driver.
Warning: When you make a change to a color menu, you must save this new color palette or the colors
will revert back to their original RGB values when you close DataCAD, even if you save the drawing. See
“Customizing Colors” in the “Before You Draw” chapter for more information on how to save palettes.
 To change the color of one or more entities in your drawing:
1.

Click on Custom in any color menu. The Color Palette dialog box appears.
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Figure 2.42: The Color Palette dialog box
2.

Choose a color swatch, excluding the ones in the top row. (The top row contains the 15 standard
colors DataCAD uses.) If you are satisfied with one of the colors in the dialog box, double-click
on the swatch to activate that color and dismiss the Color Palette. You return to the drawing
where you are prompted to Select entity to <CHANGE>.

3.

Click on the entity whose color you want to change. DataCAD substitutes the new color for the
old one.

 To change the color of one entity to match that of another entity:
1.

Click on Match in the color menu.

2.

Select the entity whose color you would like to match.

3.

Select the entity whose color you would like to change. You can select multiple entities or groups
without repeating steps 1 and 2. Click on No Change to exit the color menu without making a
change.

Working with Dual Monitors
Many people find it easier to work with two monitors. In effect, this just expands your desktop. To
increase the size of your DataCAD drawing area, you could move many of your toolbars (such as the
menu, navigation pad, projection pad, symbol browser, etc.) to the second monitor. You can even expand
your DataCAD drawing area across the two monitors. DataCAD will remember your last setup on this
expanded desktop (across the two monitors) so that you won’t have to make a lot of changes the next
time you open the program.
Working with dual monitors is easy once you have your hardware (the two monitors) and software
(usually accessed through the Windows Control Panel, Display Properties, Settings tab) set up properly.
This may require you to upgrade your hardware and/or software.
For expert advice on setting up dual monitors, consult your system administrator or a local computer
guru. Once the dual monitors are set up and working properly, you’ll discover all sorts of ways to change
how DataCAD appears on your equipment and to increase your productivity.
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Planning Your Project
Much of your work will be editing drawings under design development. DataCAD is a flexible program
in terms of allowing you to change what you have drawn. Nevertheless, the more information you have
when you first draw something, the less time you’ll spend making revisions.
With traditional manual design development, you first do a rough sketch of the project and then
gradually refine this idea into a drawing that is dimensionally and materially specific. Computer-aided
design (CAD), however, produces a drawing with precise dimensions the first time it is drawn.
This suggests that the ideal process of CAD development might be the opposite of manual design
development. With CAD, it’s important to know such things as the exterior wall construction before you
start to draw, so your drawing will be accurate from the beginning. If you finalize your floor plan before
you decide on exterior wall construction materials, you’ll have to go back and change the thickness of all
exterior walls to do automatic dimensioning or wall sections and details. In turn, this wall thickness
change would impact the interior dimensions of rooms and may affect the modular grids of ceiling and
floor tile, lighting, etc. Some well-thought out planning before you start to draw can save you valuable
time.

Gathering Project Information
Practically speaking, it’s impossible to predict the exact dimensions and materials of everything in the
building before you finalize the design. But a realizable goal is to gather as much information as possible
about the construction of the building before you begin the design development or construction
documents phases of the project. This keeps time-consuming changes to a minimum and allows the
building to be drawn and dimensioned accurately.
You need to have as much information as possible on the following:
Scope of Work
Dimensions

Materials
Existing Elements

How much do you need to draw? In what detail? What information can be reused for several
drawings?
What are the basic dimensions of the structural grid, columns, and load-bearing partitions? What
size are the interior partitions? Doors and windows? Sill and jamb conditions? Floor and ceiling
heights? Joist sizes?
What are the walls and foundation made of? What floor and roof systems are you using?
Which parts of the drawing can be used to create other drawings for this project? Which typical
details can be used for this project? Which drawings from the schematic design phase can be
reused?

Planning Layers
The concept of layering drawings has been used in designing, drawing, and drafting long before
computers. In the past, it was referred to as overlay (or pin register) drafting.
With overlay drafting, drawings were developed in layers on trace paper, each aligned with the others.
Each sheet contained related information that you could separate and reproduce individually or in any
combination. You could also use this layering of drawings during the design process to overlay and
quickly trace, change, and rework drawings. This same procedure is easily accomplished using DataCAD
to form a highly productive drawing process.
The key to efficient CAD is the well-planned use of the almost unlimited number of layers available in
each drawing file to isolate related entities, details, and text. By organizing the information displayed on
each layer according to type or content, you can perform editing functions on one building component
without affecting components on other layers.
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There are many layering methods; however, it is important to devise a well thought out strategy based on
office standards for the type of work you do. A drawing file with a good layer structure could (and
probably should) contain all the drawings for a single project.
Just as your drawing can contribute to the drawings of others, what others in your office have already
drawn can help you. As you plan your drawing layers, make a note of where you can get some of the
basic information needed for your particular task. There’s no need to redraw all those toilets for the third
floor if they’ve already been drawn for the first floor or if you already have an appropriate toilet symbol
in a plumbing symbol folder.
Before you begin drawing, it is a good idea to sit down and make a list of all the layers you intend to
create, noting what you expect each layer will contain. Although creating layers is easy with DataCAD,
you will find it helpful to have a reference list as you draw to help you prioritize and chart your drawing
process. See “Working with Layers” in the “Before You Draw” chapter for more information on how to
set up layers in DataCAD.
In DataCAD, you can toggle each layer you create on or off at any time; only layers toggled on will be
displayed and only one of these layers is active. To continue our parallel with overlay drafting, the active
layer can be thought of as the top piece of trace paper; it is the layer you’re currently drawing on. The
remaining layers of trace paper in the overlay stack are all the layers toggled on. Existing layers not
currently in the stack are all the layers toggled off (not displayed).
The process of drawing from the most general to the most specific is opposite the process of gathering
information to prepare for drawing. You want to understand the building in the greatest detail possible
before you draw it. But once you start drawing, you want to document all that information gradually,
arriving at the most specific drawing (the detail) only after you have graphically described all the general
conditions.

Figure 2.44: The image on the left is how your drawing is organized using layers. On the right is
how you see your drawing in DataCAD.

Prioritizing Drawing Tasks
In addition to making a list of all your layers, make a flow chart of your drawing process: what you will
draw first, second, third, etc. To keep drawing redundancy to a minimum, you will want to draw those
parts of your drawing which are the most general first, then proceed to detail your drawing, gradually
making it more specific. Along the way, make copies of those parts of your drawing that can be used for
other drawings.
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Drawing Efficiently
A drawing will, of necessity, contain many entities. The idea behind CAD is to have the computer
automatically draw as many of those entities as possible. DataCAD incorporates several functions that
make this automation possible; entities may be copied or mirrored; symbols and line types may be added
as well.
Any entity, group, or area in your drawing can be copied one or several times automatically or flipped
and copied at once to produce a mirror image next to the original image. For example, you only need to
draw one side of a corridor of rooms if you use Mirror to create the opposite side. For more information
on using Mirror, see “Mirroring Entities” in the “Other Ways to Draw” chapter.
Any entity, group, or area in your drawing can be stored as a symbol. You can draw a tree once, save it as
a symbol, then place trees all over your site plan just by selecting with the mouse all the places in your
drawing where you want the trees to appear.
Many material symbols shown in sections and details can be drawn automatically by selecting the proper
line type or by creating one of your own. DataCAD has line types for materials like insulation, brick,
plywood, and roof shingles. For example, you could produce a line of insulation running up a wall just
by choosing the Insul1 line type and entering the two endpoints of the line.
DataCAD’s Edit menu provides you with many ways to modify anything you draw without redrawing it,
including moving or stretching entities or changing their attributes.
Use Stretch to select an area or point and move it to a new location, automatically stretching or shrinking
everything attached to what you are moving. For example, you can move a window to a new place in the
wall; the wall will be stretched to match the new position of the window. For more information on using
Stretch, see “Stretching Entities” in the “Editing Drawings” chapter.
Move is different from Stretch since only the entity, group, selection set, or area you select is moved to a
new location in the drawing; everything connected to those items stays where it is. So if you have two
cased openings, one of which contains a door, you can move the door to the other cased opening without
moving all the wall and jamb lines attached to the door. For more information on using Move, see
“Moving Entities” in the “Editing Drawings” chapter.
Use Change to alter the characteristics or attributes of any entity, group, area, or selection set you’ve
created. For example, you can change a wall from double-weight solid lines to single-weight dashed lines,
alter its height from 8 to 10 feet, change its color from green to blue, etc. For more information on using
Change, see “Changing Entities” in the “Editing Drawings” chapter.

Sample Project
This is an example of how to use DataCAD by outlining a detailed strategy for completing a project; it is
not intended to be a tutorial or replace DataCAD training.
Scope of Work
Following is a summary of what is known about the building for which you will produce working
drawings:
Description
Materials

Dimensions
Elevation Hgts

A 12,300 s.f. YMCA facilities building, two stories, flat roof, sloping site, with parking for 34 cars.
Structure: Clear-span metal frame with steel column grid, 25’ x 20’, lightweight steel floor and bar
joists @ 2’-0” O.C.
Exterior Walls: Metal panel over metal framing with batt insulation, CMU block veneer wall with
metal framing, batt insulation and GWB interior.
Interior Walls: Metal studs with fire-rated GWB.
Plan: 100’ x 68’-8” exterior limits of building.
Lower Level Floor @ 83.00’
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Lower Level Ceiling @ 91.00’
Upper Level Floor @ 95.00’
Upper Level Ceiling @ 106.75’
Top of Roof @ 107.00’
Top of Parapet @ 108.75’

Summary of Available Personnel and Drawings Needed
PERSONNEL
Job Captain
Draftsman 1
Draftsman 2

DRAWINGS
Site Plan
Foundation Plan
Lower Level Plan
Upper Level Plan
Four Exterior Elevations
North/South Building Section
Lower Level Electrical Plan
Upper Level Electrical Plan
Lower Level Plumbing Plan
Upper Level Plumbing Plan
Door, Window, and Finish Schedules
Door and Window Types

Planning the Drawing Time
1.

Summarize drawings needed; plan final sheet layout.

2.

Draftsman 1 develops base plans while Draftsman 2 begins work on typical details.

3.

Draftsman 1 gives Draftsman 2 the plan information. Draftsman 2 begins developing elevations and
sections.

4.

When plans, elevations, and sections have been developed, develop schedules and details on both
workstations using completed drawings as a base for detail drawings.

5.

When all drawings have been completed, assemble individual drawings into “sheets” for plotting.

How Draftsman 1 Drew the First Floor Plan
Draftsman 1 first spent some time with the Job Captain, learning what the project involved and the
assigned tasks. Then Draftsman 1 sat down and prepared two outlines:


an outline of the layers required and their names



a strategy of what to draw first, second, third, etc.

LAYER NAME
A2-BLK
A2-COL
A2-DIM
A2-DRS
A2-FND
A2-HCH
A2-LAV
A2-LBL
A2-NOT
A2-ROM
A2-STR
A2-TIL
A2-TXT
A2-WIN

DESCRIPTION
Lower Level Conc. Block
Upper Level Columns
Upper Level Dimensions
Upper Level Doors
Upper Level Foundation
Upper Level Hatch
Upper Level Lavatories
Upper Level Labels
Upper Level Notes
Upper Level Room Numbers
Upper Level Stair
Upper Level Tile
Upper Level Text
Upper Level Windows
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A2-WLS

Upper Level Walls

Draftsman 1’s drawing process outline is as follows:
1.

Create drawing file YMC-MSR1.AEC.

2.

Create and name drawing layers listed above.

3.

Load sheet border from symbol file.

4.

Input all existing site information.

5.

Draw Columns, Column Grid, Perimeter, and building elements on appropriate layers.

6.

Separate drawing layers needed for first floor by saving them out to the hard disk on separate layer
files.

7.

Create a detailed elevation drawing called YMC-ELV1.AEC.

8.

Create and name the required drawing layers.

9.

Load basic first floor plan drawing layers from layer files.

10. Draw interior partitions.
11. Place windows in perimeter wall.
12. Save modified plan layers to a layer file called YMC-PLN1.DLF. This layer will become the exterior
wall for the second and third floors, which have identical windows to the first floor.
13. Place doors and windows in perimeter wall and in interior partition walls.
14. Zoom in on lobby area and draw lobby details.
15. Zoom in on restroom area and draw fixture layout and details.
16. Draw reflected ceiling plan.
17. Add dimensions, labels, and notes to drawing.
18. Create a new detail elevation file for the Second Floor Plan called YMC-ELV2.AEC.
Notice that Draftsman 1’s outlines do not detail how to best draw each part of the drawing. This strategy
simply gives an outline of what to do next while leaving Draftsman 1 free to choose the best drawing
method for each part of the drawing. Copy, Mirror, and Stretch will be used to produce, respectively, the
column grid, two halves of a symmetrical parking layout, and two handicapped parking spaces that are
larger than the other parking spaces.

Basic Drawing and Editing
DataCAD is ready to draw lines immediately upon opening a drawing; notice that in the Create pulldown menu, Line is checked by default. You can even draw with custom line types to represent such
things as insulation, telephone and electrical lines, and siding. Editing lines or anything else you draw is
easy with DataCAD’s many editing features.
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Drawing Using the Mouse
 To draw a line by selecting two points:
1.

Move the cursor anywhere in the Drawing Area and click. You’ve just selected the first endpoint
of your first line. In addition to simply clicking to select a point and begin drawing, you can snap
to a point on another entity and begin drawing from there. See “Object Snapping” in the
“Drawing Tools” chapter for more information.

2.

Move the cursor to the point where you want the line to end and click. The line is drawn. Notice,
however, that if you move your cursor, it is still connected to the end of the line. This allows you
to continue drawing lines, using the end of the previous line as the beginning of the next one.

3.

Repeat step 2 to continue drawing lines until your last endpoint meets the first endpoint you
selected in step 1.

4.

Right-click to disconnect the cursor from the last line.

Drawing Using Coordinate Entry
Coordinate entry lets you draw lines more precisely by entering the exact coordinates of each endpoint of
a line. In DataCAD, you have a choice of five coordinate entry methods or input modes:


Relative polar requires that you enter a distance and an angle relative to the last point entered.



Absolute polar requires that you enter a distance and an angle from absolute 0.



Relative Cartesian requires that you enter an X and Y distance relative to the last point entered.



Absolute Cartesian requires that you enter an X and Y distance from absolute 0.



Distance-Direction requires that you indicate the direction with the mouse and then enter a distance
relative to the last point entered.

Figure 2.45: Polar and Cartesian coordinate entry methods
Once you select a coordinate entry method, it remains active until you choose a different one. The
coordinate entry method you’re using is always checked in the Tools pull-down menu’s Input Mode.
(Coordinates are only displayed when your cursor is in the Drawing Area.)
Four additional coordinate entry methods are available only while in the 3D Views/Controls menu:
relative and absolute cylindrical (enter distance, angle, and Z coordinate) and relative and absolute
spherical (enter distance, plan angle, and rise angle). These methods provide additional variables to the Z
component of coordinate entry, which may be helpful in specialized modeling applications like entering a
3D line that represents a solar angle.
 To choose a coordinate entry method, either:


press (Insert) until the name of the method you want appears in the Attention toolbar or
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click on Input Mode in the Tools pull-down menu and select a coordinate entry method from the
list.

 To draw a line using relative or absolute polar coordinate entry:
1.

Click in the Drawing Area to select the line’s first endpoint.

2.

Press (Spacebar).

3.

Type the length of the line (the distance from the endpoint you entered in step 1 to the next
endpoint) and press (Enter).

4.

Type the angle of the line from the X axis and press (Enter). The line is drawn, with your cursor
still attached to the endpoint of the line.

5.

Continue drawing lines by repeating steps 2-4. Right-click to disconnect the cursor from the line.

 To draw a line using relative or absolute Cartesian coordinate entry:
1.

Click in the Drawing Area to select the line’s first endpoint.

2.

Press (Spacebar).

3.

Type the relative or absolute X distance from the first endpoint and press (Enter).

4.

Type the relative or absolute Y distance from the first endpoint and press (Enter). The line is
drawn, with your cursor still attached to the endpoint of the line.

5.

Continue drawing lines by repeating steps 2-4. Right-click to disconnect the cursor from the line.

 To draw a line using direction-distance coordinate entry:
1.

Click in the Drawing Area to select the line’s first endpoint.

2.

Drag the cursor in the direction you want to draw the line.

3.

Press (Spacebar).

4.

Type the length you want the line to be, and press (Enter). The line is drawn, with your cursor
still attached to the endpoint of the line.

5.

Continue drawing lines by repeating steps 2-4. Right-click to disconnect the cursor from the line

More About Coordinate Entry
You can enter distances and angles either by typing a value or by using a value menu. See “Value Menus”
earlier in this chapter for more information on how to use them. Depending on the scale type you are
using, there may be several different methods you can use to enter coordinates. See “Setting Scale and
Angle Types” in the “Before You Draw” chapter for more information. For instance, in the architectural
scale type, which is DataCAD’s default, you must enter distances as feet.inches.fractions of inches.
TO ENTER:
4’
6”
3/16”
4’-6”
4’-6 3/16”

TYPE:
4
0.6 or .6 or (Spacebar)6
0.0.3/16 or ..3/16 or ..3.16 or (Spacebar)(Spacebar)3(Spacebar)16
4.6 or 4(Spacebar)6
4.6.3/16 or 4.6.3.16 or 4(Spacebar)6(Spacebar)3(Spacebar)16

Notice in this example that 3/16” is entered as 0.0.3/16, indicating 0 feet, 0 inches, and 3/16 of an inch.
Notice also that you can leave out the zeros when you enter distances, as long as the decimal points
remain as placeholders; so you could type ..3/16. Further, slashes, decimal points, and spaces are
interchangeable, so you could replace the slash with another decimal point and type ..3.16.
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Angles are entered in a similar fashion, except the (Spacebar) method can’t be used. For instance, using
relative polar coordinate entry, angles are entered as: degrees.minutes.seconds
TO ENTER:
38
12’
30”
38-12’-30”

TYPE:
38
0.12 or .12
0.0.30 or ..30
38.12.30

Drawing with Line Types
DataCAD has four standard line types (solid, dotted, dashed, and dot-dash) that are automatically
embedded into all drawing files. There are many more custom line types externally available from your
hard drive or server that you can embed in your current drawing file by using the Line Type Manager.
You cannot redefine the four standard line types (solid, dashed, dotted, and dot-dash) . These line types
do not appear in the Line Type Manager. You can set the default attributes of these line types in the
current drawing (or default drawing) only, but you cannot change the external definition.
Creating your own line types is easy; DataCAD allows you to add up to 175 custom line types such as
special symbolic lines for site plan utilities, center lines, and highlighted lines for review. See “Creating
Line Types” in the Appendix for a list of available custom line types and their settings.
 To draw a line using a line type:
1.

Go to the Edit menu in the Menu Window; click on Line Type. A list of the four most common
line types (solid, dotted, dashed, and dot-dash) appears in the Menu Window, along with options
to modify a chosen line type’s weight, color, spacing, factor, or overshoot.
Shortcut: Press (Alt) + (L) to access the Line Type menu.

2.

Look at a preview of a line type before you use it by moving the mouse cursor over the line type
option in the Menu Window. If the line type you need is not included in the list at the top of the
Line Type menu, use the Line Type Manager or create a new line. See “Using the Line Type
Manager” in this chapter for details.

3.

Click on a line type in the Menu Window to use that line type.

4.

Click on the Factor, Spacing, Line Weight, Color, or Overshoot options to change the settings for
the line type you chose. See “Line Type Settings” in this chapter for details on changing line type
settings.

5.

Begin drawing lines as described in “Drawing Using the Mouse” or “Drawing Using Coordinate
Entry” earlier in this section.

Using the Line Type Manager
The Line Type Manager lets you load or reload external line type definitions into your drawing. In
versions prior to DataCAD 11, all line types were listed and you would have to scroll through many
options before finding the two or three you use most frequently. Using the Line Type Manager lets you
embed only those line types you actually need in the current drawing file, streamlining the line selection
process. If you later need additional line types, you can return to the Line Type Manager and add them to
the Embedded Lines list.
The upper section of the Line Type Manager displays the definitions that are currently (or will be) loaded
into the active drawing. This section is used to modify parameters. Clicking OK or Apply will load newly
selected definitions and/or apply changes you’ve made. Once your changes have been applied, you can
use the Save or Save As options to save your internal definitions to the hard drive. You can use Reload to
overwrite an internal definition with an external one.
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The lower section of the Line Type Manager displays external definitions that you may load into the
active drawing. You cannot make changes to external definitions in this section. First, you must apply
changes to internal definitions, the use the Save or Save As options to externalize your new settings.
You can manually convert DataCAD line types (.LIN) to the new (.DLT) format. To do this, use the
Convert option in the Line Type Manager dialog box.
Up to 255 line types are available in DataCAD. You can create your own custom line type definitions, too.
When you give colleagues copies of your drawings that contain custom line types, you needn’t worry
about supplying them with the new definitions because DataCAD automatically converts them from
DCADWIN.LIN to individual .DLT files stored in \DataCAD\Support Files\Line Types.
You can also use the Line Type Manager to set the End Correction and default Factor for embedded or
external line type definitions. This means that you can customize the embedded lines.
 To use the Line Type Manager:
1.

Go to the Edit menu in the Menu Window and click on Line Type. The Line Type menu appears.

2.

Click on Line Type Manager. The Line Type Manager dialog box appears. In the lower portion,
the External Lines window contains a list of all the other line types you may want to use in this
particular drawing file. Each portion of the Line Type Manager contains a preview window so
that you can see what the highlighted line will look like.

3.

Add one of the external lines to your current drawing file by highlighting the line you want in the
lower portion of the Line Type Manager and clicking on the Load button. This loads the line you
selected from the External Lines list into the Embedded Lines list.

4.

Customize the lines in the Embedded Lines portion if necessary.


End Correction – check (enable) or uncheck (disable) the End Correction box in the
Embedded Lines portion of the Line Type Manager.



Line Spacing – change the default factor by supplying a different value in the Factor input
box in the Embedded Lines portion of the Line Type Manager.
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Figure 2.46: The Line Type Manager
5.

Click OK when you are satisfied with the choices you made in the Line Type Manager. The lines
you added to the Embedded Lines portion of the Line Type Manager appear in the Line Type
menu. These line types are now part of this particular drawing file.

Line Type Settings
All custom line types enter building materials at actual size and they appear at the display scale you
specify. You can use the following options to customize a line type:
Spacing

Changes the size of the line type pattern. Keep in mind that DataCAD defines units in absolute world
coordinates. For example, to set dashed lines to repeat every 1” on a 1/4”=1’-0” scale drawing, set the
spacing to 4’-0”. To set line spacing, click on a value in the value menu or type a spacing value, and
press (Enter).
Line Weight Sets the thickness of a line type. The most common line thickness is 1. To set the line weight, click on a
line weight in the value menu or type a line weight value, and press (Enter). For line weights to display,
Show Weight must be toggled on in the Display menu.
Color
Changes the color of a line type. Any new lines that you enter into the drawing appear in the new color.
Overshoot Displays extensions (or punch) at line intersections, giving drawings an architectural look. DataCAD
always dimensions to the actual length of a line, ignoring any displayed overshoot.

You must set the overshoot before you draw a line; previously drawn lines are not affected.
By default, DataCAD lets you apply line overshoot selectively to individual entities in your drawing.
However, you can change this and globally apply line overshoot to all lines in your drawing. Of course,
you must toggle Overshoot on in the Display menu to view and/or plot the overshoots either globally or
selectively.
 To set the overshoot:
1.

Go to the Edit menu in the Menu Window and click on Line Type. The Line Type menu appears.

2.

Click on Overshoot in the Line Type menu. The Overshoot menu appears.
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3.

4.

Decide whether you want to apply line overshoot to entities selectively or to all lines throughout
your drawing. These two options are mutually exclusive:


By Entity – by default, this is toggled on so that you apply line overshoot selectively to
particular entities in your drawing.



Globally – by default, this is toggled off. If you want all lines throughout your drawing to
overshoot, toggle this option on. This affects all future lines you draw in this file; it does not
affect lines you drew prior to toggling this option on. The global line overshoot is scaleindependent; it is defined as a real-world, plotted distance.

Choose or type an overshoot length by clicking on New Distance, selecting a value, and pressing
(Enter).

 To display line overshoot in your current drawing on your monitor and on your plots:
1.

Go to the Utility menu and click on Display. The Display menu appears.

2.

Toggle Overshoot on.

You can add line overshoot to an existing line in your drawing by using the Change menu. Depending on
the option you choose in the selection portion of the menu, you can change one line at a time (Entity) or
several at once (Group, Area, Fence, or Mask).
 To display overshoot for existing lines in your drawing:
1.

Go to the Edit menu in the Menu Window and click on Change. The Change menu appears.

2.

Toggle on Overshoot, select a value for the length of the overshoot, and press (Enter). You are
prompted to Select entity to <CHANGE>.

3.

Click on the line you want to overshoot in your drawing. If you want to overshoot more lines,
simply continue clicking on them. When you are finished using the overshoot, right-click to exit
the Change menu.

Basic Editing Tools
DataCAD’s Edit pull-down menu provides easy access to most editing functions, including primary
editing menus such as Move, Copy, Rotate, Mirror, Stretch, Enlarge, Erase, Change, Partial Erase, Line
Cleanup, and Wall Cleanup. Choose any of these editing options to display that menu in the Menu
Window. See the “Editing Drawings” chapter for details on these options.
The Edit pull-down menu also includes unlimited, global undo/redo options and cut, copy, and paste.
The Undo option reverses the last action, including any drawing or editing, changes made using macros,
or the deletion of layers. The Redo option restores the last action. To undo an action, click on Undo in the
Edit pull-down menu or press (Ctrl) + (Z); to redo an action, click on Redo in the Edit pull-down menu or
press (Ctrl) + (Y). You can also use the Undo/Redo icons in the Standard Toolbar.
Cut, Copy, Paste, and Paste Special are four more Edit pull-down menu options you can use to edit
drawings or share parts of drawings between documents. Cut removes entities from the drawing to the
clipboard, Copy copies entities in the drawing to the clipboard, Paste adds entities previously cut or
copied to the active drawing, and Paste Special lets you choose the format (metafile, text, etc.) for entities
previously cut or copied and then adds them to the active drawing. To cut or copy DataCAD entities, you
must first use the Clipboard Select option in the Edit pull-down menu to select the entities to be cut or
copied. You can choose whether to copy just the entity or the entity with its current color and line weight.
Check the Copy to Clipboard options on the Misc tab of the Configure DataCAD for Windows Settings
dialog box as appropriate.
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 To move or copy entities from one drawing to another:
1.

Click on Clipboard Select in the Edit pull-down menu. A selection menu appears. See “Selection
Menus” in this chapter for more information.
Shortcut: Press (Ctrl) + (E) to access the Clipboard Select selection menu.

2.

Toggle Ins. Point on to enter an insertion point for the entities. This point can then be used to
paste the entities into another drawing. Toggle Ins. Point off to enter entities relative to absolute
zero.

3.

Choose a selection method by clicking on one of the selection menu options.

4.

Select the entities to be moved or copied.

3.

Click on Cut in the Edit pull-down menu to remove the entities from the drawing or click on
Copy to simply copy them. If Ins. Point was toggled on in step 2, you are prompted to Enter the
insertion point. If Ins. Point was toggled off, skip to step 7.
Shortcut: Press (Ctrl) + (X) to cut entities or press (Ctrl) + (C) to copy entities.

4.

Click in the Drawing Area to select a reference point. Your cursor will be attached to this
reference point when you paste the entities into another drawing.
Shortcut: Press (Ctrl) + (V) to paste entities.

7.

Paste them into another DataCAD drawing or into a document in another application:


Open the drawing you’d like to add the entities to and click on Paste in the Edit pull-down
menu. Toggle By Center on to paste the entities by the center of their extents; toggle it off to
paste the entities by their insertion point (if Ins. Point was toggled on) or at absolute zero.



Open the drawing you’d like to add the entities to, click on Paste Special in the Edit pulldown menu, and select a format for the entities.



Open the Windows application document that you’d like to add entities to and use that
application’s paste function.

You can preserve the exact position of an entity (as measured from absolute zero) when copying it from
one drawing to another. For example, if a marker was placed at x=16’, y=16’ (as measured from absolute
zero) in the original file, then pasting it into a new file using Abs. Zero will place the marker at x=16’,
y=16’ from absolute zero in the new file.

(Pro) Referencing Drawings
You can reference (or link) an unlimited number of DataCAD drawings to your current drawing. These
referenced drawings (also called XREFs) are displayed in your current drawing and will even print as
though they were part of your current drawing; however, they are not actually added to your current
drawing, allowing you to keep file size as small as possible. Reference file geometry can be moved,
copied, mirrored, or enlarged just as any other entities can be. In addition, reference files can be rotated
into any plane in space. You can place an XREF in any orientation.
There are basically four types of referenced drawings:


Single – an XREF that has no nested XREFs, is not self-referencing, and is not circular.



Nested – an XREF that you add to your drawing can contain XREFs of its own. These XREFs within
an XREF are said to be “nested.”



Self - you can place an XREF for drawing A into drawing A. Self-referencing XREFs are automatically
redefined to reflect the new drawing filename when you use the Save As function.
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Circular – when drawing A references drawing B and drawing B references drawing A.

 To insert a reference file:
1.

Click on XREF in the Insert pull-down menu. A dialog box appears, prompting you to Enter name
of reference file to insert.

2.

Select a drawing from the list box and click on Open. The dialog box closes and a box
representing the extents of the referenced drawing appears, attached to your cursor. The Insert
XREF menu appears.

3.

Enlarge the referenced drawing before inserting it by clicking on Enlarge in the Insert XREF
menu. A value menu appears and you are prompted to Enter XREF enlargement factor.

4.

Use the value menu to enter the enlargement factor you want to use and press (Enter).

5.

Decide if you’d like to dynamically rotate the reference file geometry into place when you insert
it into your drawing. If you want to do this, toggle Dyn. Rotate on. The Dyn. Rotate option has no
effect if you use Abs. Zero to place the reference file geometry.

6.

Select one or more of these ways to insert the reference file:


To insert the referenced drawing relative to absolute zero, click Abs. Zero in the Menu
Window. The referenced file is inserted into your current drawing.



To place the referenced drawing by its center, toggle By Center on in the Menu Window.
Move the cursor to position the referenced drawing and click to insert it. If you toggled Dyn.
Rotate on in the previous step, you are prompted to Position XREF on drawing. Click in the
Drawing Area where you want to place the XREF, rotate the geometry into place, and click to
insert it.



If the By Center toggle is off, your cursor is attached to absolute zero in the referenced file.
Move the cursor to position the referenced drawing and click to insert it. If you toggled Dyn.
Rotate on in the previous step, you are prompted to Position XREF on drawing. Rotate the
geometry into place and click to insert it.



If the By Center toggle is on, DataCAD calculates the extents in all three directions: X, Y, and
Z.



To use the active clip cube(s) in the referenced file, toggle on XREF Clip. You are prompted to
Position XREF on drawing. DataCAD inserts the active clip cube(s) into the current drawing.



If you don’t want the inserted XREF to include any of its nested XREFs, toggle on the Nesting
option in the Insert XREF menu. This minimizes the amount of memory required to load an
XREF that contains XREFs of its own.



If you want to use the Reference File Manager after inserting an XREF, toggle on Open RFM.

You can also use coordinate entry to select the point to position the reference file geometry. See “Drawing
Using Coordinate Entry” in this chapter for more information.
Self-referencing XREFs are supported. You can place an XREF for drawing A into drawing A. “Circular”
XREFs are no problem since endless-loop swap files are not created. Self-referencing XREFs are
automatically redefined to reflect the new drawing filename when you use the Save As function.
 To insert a self-referencing XREF into your drawing:
1.

Click on Self-XREF in the Insert pull-down menu. The Insert XREF menu appears and a box
representing the extents of the self-referenced drawing appears, attached to your cursor. You are
prompted to Position XREF on drawing.
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2.

Make decisions about the self-XREF by using the toggles in the Insert XREF menu. For more
information about these options, see steps 3 through 6 for inserting a reference file.

3.

Move the XREF box to the appropriate spot. Then click to position the self-XREF in your drawing.

Referenced files may have unique clipping boundaries. You can have multiple Clip Cube definitions
active simultaneously. You can also enter text and dimensions outside of the XREF Clip Cube.
 To use XREFs with unique clipping boundaries:
1.

Select Reference File Management from the Insert pull-down menu.

2.

Select Clip Cubes from the extended menu.

3.

Choose the XREF for which you want to define a new Clip Cube.

For information about using clip cubes from referenced files, see “Viewing Selected Entities in Your
Model” in the “Viewing Your Model” chapter.

(Pro) Reference File Manager
You can use the Reference File Manager to manage reference files in your current drawing. When you
click on Reference File Management in the Insert pull-down menu, you can refresh or reload reference
files, resolve orphaned reference files, or open the Reference File Manager.
The GoTo Views for an XREF appear in the Available Views window. When you select a GoTo View from
the Available Views window, you can indicate which layers should be on or off in the Layer Control list
box.

Figure 2.47: The Reference File Manager dialog box
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You can also redefine loaded reference file names within the Reference File Manager by clicking on the
Redefine button. This allows you to redefine XREF files that were renamed. The redefined XREF retains
the previous XREF’s position, scale, and rotation.
You can add the following entry to the DCADWIN.INI file to enable automatic conversion of referenced
DC5 files to AEC format:
[XREFs]
Auto Convert=TRUE
The default value is FALSE; changing it to TRUE automatically updates referenced DC5 files to AEC.
(Pro) Displaying Reference File Layers
 To display only selected layers:
1.

Click on Reference File Management in the Insert pull-down menu. A submenu appears.

2.

Click on Manager in the submenu. The Reference File Manager dialog box appears. All the
reference files in your current drawing are listed in the Reference Files Loaded list box.
Shortcut: Press (Ctrl) + (R) to access the Reference File Manager dialog box.

3.

Click on a reference file in the list to select it. If necessary, you can use the horizontal scroll bar for
reference file names that extend beyond the dialog window. All the layers in the reference file are
listed in the Layer Control list box, with a checkmark next to the ones that are on (displayed).

4.

Click on the checkboxes next to the layers to turn layers in the reference file on or off.

5.

Click on Apply to apply the changes you’ve specified. The checked layers appear and the
unchecked layers are not displayed.

6.

Click on OK to close the Reference File Manager dialog box when you’re finished.

(Pro) Refreshing and Reloading Reference Files
You can refresh and reload reference files. Refresh will incorporate any changes you’ve made to the
reference file, such as editing the drawing, but will not update any changes to layer status. Reload will
update any changes you made to the reference file geometry as well as the reference file’s layer status,
such as which layers are toggled on and which are off.
 To refresh reference files:
1.

Click on Reference File Management in the Insert pull-down menu. A submenu appears.

2.

Click on Manager in the submenu. The Reference File Manager dialog box appears. All the
reference files in your current drawing are listed in the Reference Files Loaded list box.

3.

Click on a reference file in the list to select it. Press (Ctrl) or (Shift) and click to select multiple
files.

4.

Click on Refresh. The reference file name is copied into the Marked for Refresh list box.

5.

Click on Apply to apply the changes you’ve specified. The selected reference files are refreshed.

5.

Click on OK to close the Reference File Manager dialog box when you’re finished.

Double-clicking on a file listed in the Marked for Refresh, Marked for Reload, Marked for Bind, or
Marked for Delete list boxes will remove the file from the list and return it to the Reference Files Loaded
list box.
 To reload reference files:
1.

Click on Reference File Management in the Insert pull-down menu. A submenu appears.
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2.

Click on Manager in the submenu. The Reference File Manager dialog box appears. All the
reference files in your current drawing are listed in the Reference Files Loaded list box.

3.

Click on a reference file in the list to select it. Press (Ctrl) or (Shift) and click to select multiple
files.

4.

Click on Reload. The reference file name is copied into the Marked for Reload list box.

5.

Click on Apply to apply the changes you’ve specified. The selected reference files are reloaded.

3.

Click on OK to close the Reference File Manager dialog box when you’re finished.

Double-clicking on a file listed in the Marked for Refresh, Marked for Reload, Marked for Bind, or
Marked for Delete list boxes will remove the file from the list and return it to the Reference Files Loaded
list box.
(Pro) Binding Reference Files
XREFs and nested XREFs both bind, based on the On or All toggle in the XREF Manager.
 To bind reference files:
1.

Click on Reference File Management in the Insert pull-down menu. A submenu appears.

2.

Click on Manager in the submenu. The Reference File Manager dialog box appears. All the
reference files in your current drawing are listed in the Reference Files Loaded list box.

3.

Click on a reference file in the list to select it. Press (Ctrl) or (Shift) and click to select multiple
files.

4.

Look beside the Bind button where there are two small toggles: All and On. Click on All to bind
all layers in the reference file to the current drawing, regardless of whether they’re on or not.
Click on On to bind only the layers in the reference file that are on (displayed). Before you use the
On toggle to bind layers of the reference file, use the Layer Control list box to check those layers
you want toggled on.

7.

Click on Bind. The reference file name is copied into the Marked for Bind list box.
Warning: The drawing file size may increase substantially when you bind referenced files.
Binding too many files may cause the drawing file size to exceed the 1024MB limit. DataCAD
cannot provide a warning when this occurs. Check the Directory (available from the Tools pulldown menu) to monitor the current drawing file size.

6.

Click on Apply to apply the changes you’ve specified. The selected reference files are bound, and
their geometry is copied into the current drawing. Once a reference file is bound to the current
drawing, it ceases to be a reference file. So, if you choose to bind only a few layers of a reference
file, the entire reference file (even those layers you didn’t bind) is no longer linked to your current
drawing.

8.

Click on OK to close the Reference File Manager dialog box when you’re finished.

Highlighting is lost when an XREF is bound because it is no longer an XREF.
(Pro) Deleting Reference Files
 To delete reference files:
1.

Click on Reference File Management in the Insert pull-down menu. A submenu appears.

2.

Click on Manager in the submenu. The Reference File Manager dialog box appears. All the
reference files in your current drawing are listed in the Reference Files Loaded list box.
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3.

Click on a reference file in the list to select it. Press (Ctrl) or (Shift) and click to select multiple
files.

4.

Click on Delete. The reference file name is copied into the Marked for Delete list box.

5.

Click on Apply to apply the changes you’ve specified. The selected reference files are deleted.

9.

Click on OK to close the Reference File Manager dialog box when you’re finished.

Double-clicking on a file listed in the Marked for Refresh, Marked for Reload, Marked for Bind, or
Marked for Delete list boxes will remove the file from the list and return it to the Reference Files Loaded
list box.
(Pro) Highlighting Reference File Geometry
You can use color, line type, or a combination of the two to highlight reference file geometry.
Highlighting is lost when an XREF is bound because it is no longer an XREF.
 To highlight entities from a reference file:
1.

Click on Reference File Management in the Insert pull-down menu. A submenu appears.

2.

Click on Manager in the submenu. The Reference File Manager dialog box appears.

3.

Click on the reference file in the Reference Files Loaded list box to select the reference file you
want to highlight.

4.

Click on the On/Off checkbox in the Highlighting section to turn highlighting on.

5.

Choose a highlighting color and line type/line spacing from the drop-down boxes.

6.

Click on Apply to apply the changes you’ve specified. The highlighting is applied to the
geometry for that reference file.

7.

Repeat steps 3 – 6 to highlight the geometry from other reference files.

8.

Click on OK to close the Reference File Manager dialog box.

(Pro) Working with Nested XREFs
You can reduce the amount of memory required for an XREF by turning the Nesting feature off.
However, if you need to use the nested XREFs, you can easily turn it on again.
 To control the display of nested external references on a per-XREF basis in the Reference File
Manager:
1.

Select a loaded reference file from the list in the Reference File Manager.

2.

Click the On button in the Nesting section of the Reference File Manager to load nested XREFs;
click the Off button to prevent them from loading.

 To disable the display of nested external references when you insert an XREF:
1.

Select XREF from the Insert pull-down menu. Then open an XREF from the list of reference files.
The Insert XREF menu appears and a box that contains the XREF is attached to your cursor.

2.

Toggle Nesting on if you want to display nested external XREFs; toggle Nesting off if you want to
disable the display of nested external references.

 To control nested XREFs with the pop-up menu:
1.

Put your cursor over the XREF you want to work with in your drawing.

2.

Hold down the (Ctrl) key and right-click. The pop-up menu appears.
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3.

Click on XRef Tools to reveal the extended menu.

4.

Click on Nesting to reveal the extended menu.

5.

Select On if you want the nested XREFs to be available; select Off if you don’t want the nested
XREFs.

 To control the display of nested XREFs globally:
1.

Select Program Preferences from the Tools pull-down menu. The Configure DataCAD for
Windows Settings dialog box appears.

2.

Click on the Drawing tab.

3.

Go to the XREFs section and put a checkmark in the appropriate box if you want to Display
Nested XREFs. If you want to disable the display of nested XREFs, make sure there is no
checkmark in that box.

Multiple XREFs of the same file use a single memory space. When used in combination with the Display
Nested XREFs toggle, you can significantly reduce the amount of memory required to open your
drawings that contain XREFs.
(Pro) Resolving Orphaned Reference Files
Reference files can be orphaned if you move the file to another folder on your computer or if you delete
the referenced file. You can resolve the broken link between your current drawing and the referenced file
by either deleting the link or by redefining the path to where you moved the reference file. Clicking on
the Redefine button allows you to redefine XREF files that became orphaned when they were renamed.
Redefined XREFs retain the previous XREF’s position, scale, and rotation.
The path between the current drawing and the reference file is limited to 160 characters. This allows you
to use the full pathname that includes Drive + Path + Filename.
When you open a file that contains orphaned reference files, you will see a Warning dialog box. Click on
OK and then deal with the orphan.

Figure 2.48: Orphaned XREFs appear in a drawing
 To resolve orphaned reference files:
1.

Click on Reference File Management in the Insert pull-down menu. A submenu appears.

2.

Click on Orphans in the submenu to display the Orphaned Reference Files dialog box. Click on
the XREFs tab to list all the orphaned reference files in your current drawing.

3.

Click on a reference file in the list to select it.

4.

Resolve the orphaned file in one of these two ways:


Click on Delete to delete the reference file from your current drawing.
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Click on Redefine or on Redefine Path to reestablish the link between your current drawing
and the reference file. A dialog box appears, allowing you to browse for the file; find the
referenced file and click on OK. The dialog box closes. Click on Done to close the Orphaned
Reference Files dialog box.

(Pro) Context-Sensitive Pop-up Menu for XREFs
For quick access to many of the XREF options, you can use the enhanced context-sensitive pop-up menu.
 To use the context-sensitive pop-up menu for XREFs:
1.

Place your cursor on the XREF.

2.

Hold down the (Ctrl) key while you right-click with your mouse. As a result, the XREF is greyed
out and a pop-up menu with several options appears.

3.

Click on the XRef Tools option to open the extended menu. This gives you access to the following
options:


Open



Reference File Manager



Refresh



Reload



Bind – the submenu lets you bind either all layers or only the layers that are on.



Redefine



XClip



Nesting – the submenu lets you turn nesting on (nested XREFs will be available) or off
(nested XREFs will not be available).

Figure 2.49: The XREF Tools pop-up menu
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Inserting Images Directly into Drawings
You can insert a variety of images into your DataCAD drawings. The images you can insert include .BMP,
.JPG, .GIF, .TIF, .TGA, .PNG, .PCX, and .PCD files. Also, you can insert Objects to See (.o2c), 3D Studio
(.3DS), Stereolithography (.STL), SketchUp (.SKP), Text (.TXT), and Metafile (.WMF) files directly into
DataCAD.
 To insert an image directly into your drawing:
1.

Click on Insert in the pull-down menu bar.

Figure 2.50: The Insert pull-down menu
2.

Select the type of file you want to insert into your drawing.
XREF
o2c Object
3DS File
STL File
Text File
Metafile
Bitmap

Opens the Enter name of reference file to insert dialog box. See the “Referencing Drawings”
section in this chapter for more information. (Pro)
Opens the Select o2c file to import dialog box, giving you access to .O2C and .ACO file
formats. (Pro)
Opens the Insert 3d studio file dialog box, giving you access to 3D Studio (.3DS) files. (Pro)
Opens the Insert STL file dialog box, giving you access to Stereolithography (.STL) files. (Pro)
Opens the Enter the name of the text file to import dialog box, giving you access to .TXT files.
Opens the Enter name of Windows Metafile to insert dialog box, giving you access to .EMF
and .WMF files. (Pro)
Opens the Select Image dialog box, giving you access to file formats that include .BMP, .JPG,
.GIF, .TIF, .TGA, .PNG, .PCX, .EPS, and .PCD.
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Figure 2.51: The Select Image dialog box
3.

Highlight the file you want to insert into your drawing. The highlighted image appears in the
Preview Window of the dialog box and the file’s name appears in the Filename input field.

4.

Click Open or press (Enter). DataCAD closes the dialog box and inserts the file you selected into
your drawing.

Much like XREFs, bitmaps can become orphans. If your drawing contains one or more orphaned bitmaps,
you will see this Warning dialog box. Click on OK and then use the Bitmap Orphans Manager to solve the
problem.

Figure 2.52: Files can contain orphaned bitmaps
 To resolve orphaned bitmap files:
1.

Select Orphaned Bitmap Manager from the Insert pull-down menu. The Orphaned Reference
Files dialog box appears.

2.

Click on the Bitmaps tab. The orphaned bitmaps contained in that file appear.
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Figure 2.53: The orphaned bitmap can be redefined
3.

Highlight an orphaned bitmap file. Then redefine the path or the file or delete the orphan entirely
by clicking on the appropriate button.
Redefine Path
Delete
Redefine

4.

A Browse box appears, allowing you to select a new path for the orphaned bitmap file.
After selecting the path, click on OK to close the box.
Select this option if you want to eliminate the bitmap entirely.
The Select Image dialog box appears, allowing you to replace the orphaned bitmap with
another file. After selecting the appropriate bitmap file, click on Open. The file you
selected appears in the Orphaned Bitmap box on your screen.

Click Done to close the Orphaned Reference Files dialog box.

Viewing Drawings
Viewing is simply the way you look at your drawing when you work on it. Compare viewing a drawing
on the computer with looking at a drawing on your drafting board. As you draft on the board, your eyes
are always moving and refocusing, allowing you to concentrate on small details or view the entire
drawing sheet quickly and easily. At the computer, you need to consciously decide what you want to
focus on and to what degree. To say this in CAD terms, you will zoom in on an area of your drawing
when you have to focus on a detail; and when you want to see the entire drawing, you will zoom out to
the extents or outermost edges of the drawing.
Go-to-views, hyperview linking, and multi-view windows are three additional viewing features that
allow you to jump quickly to preset views of your drawing. See the “Viewing Your Model” chapter for
more information.

Zooming In and Out
The Zoom menu in DataCAD lets you zoom in on an area by displaying the drawing in a larger scale.
When you zoom out, you are actually looking at your drawing in a smaller scale, which allows you to see
more of your drawing. The scales that the Zoom menu uses are predefined in the Utility/ Settings/Edit
Defs./Scales menu.
 To zoom in on your drawing:
1.

Click on Zoom in the Utility menu.

2.

Click above and to the left of the area you want to scale.

3.

Move the mouse downward and to the right to stretch the box around the area you want to zoom
in on.
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4.

Click to complete the box. The drawing rescales automatically.
Shortcuts: Press (/) to display the Zoom menu in the Menu Window.
To return to the previous view (essentially undoing the zoom), press (P). DataCAD remembers up
to 25 previous views.
Press (PgUp) and (PgDn) to quickly zoom in and out on your drawing. To use PgUp and PgDn on
your numeric keypad, first make sure NumLock is off.

 To zoom to your drawing’s extents:
1.

Click on Zoom in the Utility menu.

2.

Click on Extents in the Zoom menu. Your drawing appears at the largest scale possible while still
displaying the drawing in its entirety. If you’ve made significant changes to your drawing, click
on Re-Calc. instead of Extents. DataCAD will review your drawing and update the extents of the
drawing accordingly.

 To zoom in on your drawing and display the area to its extents:
1.

Click on Zoom in the Utility menu.

2.

Toggle Free Zoom on or off in the Zoom menu, depending on your preference. When it is toggled
on, DataCAD can show a nonstandard display scale. When it is toggled off, DataCAD can only
use the predefined display scales from the Utility\Disp. Scale menu.

3.

Click at one corner of the area you want to zoom in on and move the mouse diagonally to stretch
a rubber band box around this area. The area appears at its extents.
Shortcut: Press (Home) to center your drawing at the current cursor position in the Drawing
Area.

Figure 2.54: Zooming in on your drawing.

Changing Your View Using the Keyboard
You can use the arrow keys to scroll or pan in different directions around the screen. Your view of your
drawing changes each time you press an arrow key. Pressing the up arrow key lets you look up toward
the top of your drawing by moving the drawing down. The scroll distance (the distance that the drawing
moves each time you press an arrow key) is defined using the Scroll Dist. option in the Utility/Settings
menu. See “Setting the Panning Distance” in the “Before You Draw” chapter for more information on
setting the scroll distance.
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 To pan quickly:
1.

Hold down (Ctrl) and (Alt).

2.

Depress the left mouse button and drag left, right, up, down, or diagonally.

3.

Release the keys and the mouse button to stop panning.

Changing Your View Using the Navigation Toolbar
Several icons on the Navigation toolbar let you quickly change the way you focus on your drawing. If the
Navigation toolbar is not currently on your computer monitor, select Toolbars from the View pull-down
menu and check Navigation Pad. The following icons affect your view of the drawing:
Zoom view in
Zoom view out
Zoom to the drawing’s extents
Zoom to an area that you define with a rubber band
Pan arrows to look left, right, up, and down

Saving Drawings
It is a good idea to save your drawing periodically, especially when you walk away from the computer or
when you’ve made several changes. There are four ways to save your drawing in DataCAD.


Press (Shift) + (F); if Caps Lock is on, just press (F). This shortcut is a great way to quickly save your
drawing with minimal interruption.



Click on Save in the File pull-down menu.

Shortcut: Press (Ctrl) + (S) to save your drawing.


Click on Save As in the File pull-down menu to save your changes under a different drawing
filename.

Shortcut: Press (Ctrl) + (Shift) + (S) to save your drawing with a different filename.


Click on Save All in the File pull-down menu to save changes to all open drawings.

Warning: If you close your drawing without saving it, any changes you’ve made since you last saved it
will be lost. If it’s a new drawing that has not yet been saved, all references to the drawing in DataCAD
will be erased.
Save Image As...
Shaded images and the drawing window can be saved to .BMP, .JPG, .GIF, .TIF, .TGA, .PNG, .PCX, .EPS,
or .PCD format.
 To save a drawing or image in a different file format:
1.

Select Save as Bitmap from the File pull-down menu. The Save Image As dialog box appears.

2.

Choose the file format you want for the saved image from the Files of type drop-down box.
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Figure 2.55: The Save Image As dialog box
3.

Supply a name for the image in the File name field. If you want, you can keep the name of the
original file that appears in the File name field because the file extension will be different based
on the choice you made in step 2.

4.

Click on Save to save the file in the format you specified. The Save Image As dialog box closes.

More About Naming Your Files
Naming your drawings is an important step to meaningful and efficient file organization. Ideally, the
names of your drawings and the folders you store them in will reflect the contents of the file as well as the
project they pertain to.
Identifying your drawings and layers with names like “floorplan” or “bricks” or “Dimensions” becomes
confusing and redundant. Which floorplan? What kind of bricks? Dimensions of what?
Despite the fact that everyone would rather read names than numbers, a naming system based on
numbers can eliminate confusion between files. How you structure this numbering system is up to you 
only you know the specific needs of your office.
In the sample project outlined earlier in this chapter, we used a different naming system. In the filename
YMC-MSR1, “YMC” is the job name abbreviation, “MSR” is the drawing type, and “1” is the drawing
version number. A similar convention is used for naming layer files in that project.
The system described below is a typical numbering system that has worked well in several architectural
offices.


The first three characters of the filename = the last three digits of the office job number.



The next two characters of the filename = the letter and number of the type of drawing. (See the
following drawing type list.)



The last two characters of the filename = the chronological revision number of the drawing.

A suggested system for identifying types of architectural drawings follows:
A0 = General (index, symbols, location plan, 3D views)
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A1 = Existing and temporary conditions, site work, demolition
A2 = Plans, detail plans, roof plan
A3 = Exterior elevations, detail elevations
A4 = Building sections, wall sections
A5 = Interior elevations, toilet elevations
A6 = Reflected ceiling plan, floor patterns, furnishings
A7 = Schedules, door and window types
A8 = Details
A9 = Alternates

Structural, mechanical, HVAC, and civil drawings can be identified by type in a similar fashion. Under
the above system, the drawing of the fourth elevation in job number 85236 would be named
236A304.AEC.

More About Working with Files
Although not very glamorous, directory/folder and file maintenance have a big impact on DataCAD’s
compatibility with other programs and on your productivity.
The program directory holds the .INI file, allowing you to run an older version (DataCAD 10 or earlier)
on the same computer. Expanded folder/directory names help you navigate quickly to the directory you
want to use. For more information about .INI settings, refer to “INI Settings” in the Appendix.
In comparison with older versions (DataCAD 10 and prior), import and export enhancements affect
many of the image file formats. Additionally, the drawing file size reduction gives you plenty of room for
new projects and makes it easy to share files.
(Pro) Compressed Drawing Files
DataCAD 18 drawings are stored in a compressed format. Though the drawing swap file is nearly double
in size (due to the double-precision database), AEC files are roughly 1/5 the size of the DC5 files you
created in previous versions.
Because of database changes, several DataCAD file extensions have changed. Most of DataCAD’s file
types are now registered with the operating system during installation. DataCAD includes some unique
file type icons to distinguish them from other programs’ files. The following list describes the DataCAD
18 file extensions. Items marked with an asterisk apply to DataCAD 11 and later versions.
AEC*

DataCAD 11 - 19 Drawing File

DC5

DataCAD 5 - 10 Drawing File

DC3

DataCAD 3 - 4 Drawing File

ANG

DataCAD Angle File

ARB*

DataCAD Auto-recover Backup File

ARF*

DataCAD Auto-recover File

CHR

DataCAD Font File

CST*

DataCAD Context Toolbar Configuration File

DBK*

DataCAD Drawing Backup File

DCA

DataCAD Command Alias File

DCX

DataCAD Add-On Macro File
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DEC

DataCAD Decimal File

DIMSTYLE

DataCAD Dimension Style File

DIS

DataCAD Distance File

DLF*

DataCAD Layer File

DMF

DataCAD Material File

DMX*

DataCAD Macro Extension

DOR

DataCAD Door Type File

DPF

DataCAD Pen Table File

DRF*

DataCAD Drawing Recovery File

DSF*

DataCAD Symbol File

DTB*

DataCAD Toolbar File

EDB

Estimator Link Database File

FRM

DataCAD Symbol Report Form File

GUI*

DataCAD Graphical User Interface File

LBL

DataCAD Menu Label File

LIN

DataCAD Line Type Definition File

LIT

DataCAD Shader Light Source File

MCR

DataCAD Keyboard Macro File

MNU

DataCAD Pull-Down Menu File

MSG

DataCAD Message File

O2C

Object To See File

PAK*

DataCAD Pak-N-Go Archive File

DHP*

DataCAD Hatch Pattern File

RGB

DataCAD Color Palette File

SCH

DataCAD Report Schedule File

SCL

DataCAD Scale File

SHP

DataCAD Font Definition File

SHX*

AutoCAD Font Definition File

STL

DataCAD Text Style File

STR

DataCAD Stair Style File

$WP

DataCAD Drawing Swap File

SYM

DataCAD Symbol File

TAG*

DataCAD Drawing Tag File

TBL

DataCAD DXF/DWG Color Map File

TPL

DataCAD Template File
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U$R*

DataCAD User File

WIN

DataCAD Window Style File

DataCAD User File
\datacad\drawings\my_drawing.U$R
The user file is a temporary file that stores the last date, time, username, and workstation name of the
operator who last opened the drawing successfully. DataCAD uses this data to provide you with helpful
information and appropriate options when you try to open a file that is marked “in-use.” Under normal
conditions, the user file is only present when a drawing file is open. However, if you exit a drawing
abnormally (e.g., in the case of a program error), the user file remains and DataCAD queries it to
determine an appropriate course of action the next time you attempt to open the file.

DataCAD Drawing Backup File
\datacad\drawings\my_drawing_(backup).DBK
Backup drawings (with a DBK extension) are created each time a drawing is saved. The DBK extension
distinguishes DataCAD’s backup files from other programs’ generic BAK extension.
(Pro) DataCAD Drawing Session Backup (10 Maximum)
\datacad\drawings\my_drawing_(session-01).AEC
You can configure DataCAD to automatically save up to 10 incrementally-named backup drawings.
Drawing session backups are only created when you exit and save your drawing.

DataCAD Drawing Swap File
\datacad\temporary files\my_drawing.$WP
The drawing swap file is a temporary copy that is created when you open your drawing. This is the file
DataCAD modifies when you edit your drawing.

DataCAD Auto-recover File
\datacad\drawings\my_drawing.ARF
The auto-recover file is an emergency backup copy of your drawing that DataCAD creates at regular time
intervals that you set. Auto-recover files are also created when you execute forced file saves.

DataCAD Auto-recover Backup File
\datacad\drawings\my_drawing.ARB
The auto-recover backup file is a copy of the auto-recover file. This file is automatically created the
second and subsequent times you perform an auto-recover file save.
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DataCAD Drawing Recovery File
\datacad\recover archive\my_drawing_(recovered-01).DRF
Drawing recovery files are incrementally-named copies of the drawing file that are created automatically
when you opt to restore an auto-recover (ARF) file. This file quarantines copies of recovered files that our
technical support staff may use when all attempts to restore the original drawing fail.

Backing Up and Recovering Files
Whenever you exit a drawing abnormally, DataCAD will automatically try to recover the most recent
version of your file without prompting you with unnecessary warnings and options. The following story
about Joe User summarizes the file creation, backup, and recover process.
File Open, Backup, and Recover Process
1. Joe User creates a new drawing. A corresponding swap file is created in the temporary files folder
along with a corresponding user file in the drawings folder.
\drawings\My_Drawing.U$R (User File)
\temporary files\My_Drawing.$WP (Swap File)

2. Joe User continues to work in the new file for 15 minutes when DataCAD saves an auto-recover file in
the drawings folder.
\drawings\My_Drawing.U$R (User File)
\drawings\My_Drawing.ARF (Auto-recover File)
\temporary files\My_Drawing.$WP (Swap File)

3. Joe User continues to work in the new file for another 15 minutes when DataCAD saves an autorecover file for the second time. The current auto-recover file is renamed to serve as a backup and a new
auto-recover file is created.
\drawings\My_Drawing.U$R (User File)
\drawings\My_Drawing.ARF (Auto-recover File)
\drawings\My_Drawing.ARB (Auto-recover File Backup)
\temporary files\My_Drawing.$WP (Swap File)

4. A few minutes later, Joe User presses (Shift) + (F) to save his drawing for the first time. At this point,
DataCAD creates a drawing file, copies the ARF to an ARB, saves a new ARF, and resets the auto-recover
timer to zero.
\drawings\My_Drawing.AEC (Drawing File)
\drawings\My_Drawing.U$R (User File)
\drawings\My_Drawing.ARF (Auto-recover File)
\drawings\My_Drawing.ARB (Auto-recover File Backup)
\temporary files\My_Drawing.$WP (Swap File)

5. About ten minutes later, Joe User completes an extraordinary modeling feat and decides to do a forced
file save just to be safe. DataCAD copies the AEC file to a backup file for the first time and updates the
auto-recover files as previously described.
\drawings\My_Drawing.AEC (Drawing File)
\drawings\My_Drawing.DBK (DataCAD Backup File)
\drawings\My_Drawing.U$R (User File)
\drawings\My_Drawing.ARF (Auto-recover File)
\drawings\My_Drawing.ARB (Auto-recover File Backup)
\temporary files\My_Drawing.$WP (Swap File)
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6. Another auto-recover save occurs and the auto-recover files are updated. However, the drawing and its
corresponding backup are not updated.
\drawings\My_Drawing.AEC (Drawing File)
\drawings\My_Drawing.DBK (DataCAD Backup File)
\drawings\My_Drawing.U$R (User File)
\drawings\My_Drawing.ARF (Auto-recover File)
\drawings\My_Drawing.ARB (Auto-recover File Backup)
\temporary files\My_Drawing.$WP (Swap File)

7. Then Joe user performs a forced file save. The drawing and its corresponding backup are updated, the
auto-recover files are updated, and the auto-recover timer is reset to zero.
\drawings\My_Drawing.AEC
\drawings\My_Drawing.DBK
\drawings\My_Drawing.U$R
\drwaings\My_Drawing.ARF
\drawings\My_Drawing.ARB
\temporary files\My_Drawing.$WP

Exit/Save and Crash/Recover Scenarios
Several things can happen to Joe User’s files. For example, he can successfully exit and save his files, he
can suffer a crash and recover his files by himself, or his files can crash and be recovered by another user.
A. Exit and Save
Joe User exits and saves the changes to his drawing. DataCAD updates the drawing and its
corresponding backup; then, it deletes the swap and auto-recover files.
\drawings\My_Drawing.AEC
\drawings\My_Drawing.DBK

B. Crash and Recover (Same User)
The power goes out on Joe User. When his computer is back up and running, he tries to re-open the file
he was using previously. DataCAD checks the user file and determines Joe was the previous user. Then
DataCAD checks for the presence of an ARF, determines that one is present, and notices it is newer than
the AEC file.
DataCAD informs Joe he exited the drawing abnormally and gives him the option to proceed and
automatically recover the most recent version. Joe User accepts (his only choice) and DataCAD copies the
AEC file to a "Recover_Archive" folder.
The ARF file is copied to a new AEC file, the ARB file remains, the semaphore file is updated, and the
recovered drawing is opened.
\drawings\My_Drawing.AEC
\drawings\My_Drawing.DBK
\drawings\My_Drawing.U$R
\drawings\My_Drawing.ARB
\temporary files\My_Drawing.$WP
\Recover_Archive\My_Drawing_(Recovered-01).DRF

Note: Each time My_Drawing is recovered, a new DRF file is created sequentially (i.e.,
My_Drawing_(Recovered-01).DRF, My_Drawing_(Recovered-02).DRF, My_Drawing_(Recovered03).DRF).
C. Crash and Recover (Different User)
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The power goes out on Joe User. He goes home for the day without trying to re-open the file. In the
meantime, Jill tries to open the file that Joe just crashed out of.
DataCAD checks the user file and determines Joe was the previous user. A message pops up telling Jill
that Joe was the last person to open the file and that DataCAD will perform a check to see if Joe is still in
the file.
Jill selects OK, then DataCAD tries to interrogate Joe's computer to see if he has the file open. There is no
response (Joe is not running DataCAD at the moment), so DataCAD then checks for the presence of an
ARF and determines one is present and that it is newer than the AEC file.
DataCAD informs Jill that the file was exited abnormally and her only option is to proceed and
automatically recover the latest version. Jill accepts and DataCAD copies the AEC file to a
"Recover_Archive" folder.
The ARF file is copied to a new AEC file, the ARB file remains, the semaphore file is updated, and the
recovered drawing is opened.
\drawings\My_Drawing.AEC
\drawings\My_Drawing.DBK
\drawings\My_Drawing.U$R
\drawings\My_Drawing.ARB
\temporary files\My_Drawing.$WP
\Recover_Archive\My_Drawing_(Recovered-01).DRF

(Pro) Drawing Session Backups
The Drawing Session Backups feature allows you to incrementally save up to 10 drawing sessions. When
enabled (off by default), DataCAD creates sequential session backups only when you exit and save your
drawing. Forced drawing file saves you perform during the session will not update drawing session
backups. Drawing session backups use the following naming convention.
\drawings\My_Drawing_Sessions\My_Drawing_(Session-01).AEC (Oldest)
\drawings\My_Drawing_Sessions\My_Drawing_(Session-02).AEC
\drawings\My_Drawing_Sessions\My_Drawing_(Session-03).AEC
\drawings\My_Drawing_Sessions\My_Drawing_(Session-04).AEC
\drawings\My_Drawing_Sessions\My_Drawing_(Session-05).AEC
\drawings\My_Drawing_Sessions\My_Drawing_(Session-06).AEC
\drawings\My_Drawing_Sessions\My_Drawing_(Session-07).AEC
\drawings\My_Drawing_Sessions\My_Drawing_(Session-08).AEC
\drawings\My_Drawing_Sessions\My_Drawing_(Session-09).AEC
\drawings\My_Drawing_Sessions\My_Drawing_(Session-10).AEC (Newest)

An additional option (found in the Configure DataCAD for Windows Settings dialog box) allows you to
specify a parent folder for all session backups. The default path is \datacad\sessions\. The contents of
the parent folder might look like this:
\sessions\My_Drawing_Sessions\
My_Drawing_(Session-01).AEC
My_Drawing_(Session-02).AEC
My_Drawing_(Session-03).AEC
\sessions\My_Other_Drawing_Sessions\
My_Other_Drawing_(Session-01).AEC
My_Other_Drawing_(Session-02).AEC
My_Other_Drawing_(Session-03).AEC
\sessions\My_Favorite_Drawing_Sessions\
My_Favorite_Drawing_(Session-01).AEC
My_Favorite_Drawing_(Session-02).AEC
My_Favorite_Drawing_(Session-03).AEC
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(Pro) Purging Files
DataCAD files are automatically purged of unused data each time you exit and save your drawing. In
addition, a Purge Drawing dialog box (which replaces the Layer Utility macro from versions prior to
DataCAD 11) lets you create new drawings based on a sub-set of an existing drawing. The Purge
Drawing dialog box has five drop-down menus (File, Layers, GoTo Views, MSP Sheets, and Multi-View
Windows) and five sections (Layers, GoTo Views, MSP Sheets, Multi-View Windows, and Purge Empty
or Unused).

Figure 2.56: The Purge Drawing dialog box
 To eliminate layers, multiviews, go-to-views, and/or sheets from your file:
1.

Select Purge from the File pull-down menu. The Purge Drawing dialog box appears.

2.

Decide what you want to keep from this file by placing a checkmark in the appropriate boxes in
the sections labeled Layers, Multi Views, GoTo Views, and Sheets. This lets you use the checked
portions of the current drawing as the basis for a different one.
Shortcut: Use the pull-down menus for Multi-View Windows, GoTo Views, and MSP Sheets and
click on All to place checkmarks in all the boxes in a section at once; click on None to leave all the
boxes blank. Use the pull-down Layers menu lets you select All to check every box in the Layers
section at once; choose On to check the box for each layer that is toggled on; or click on None if
you don’t want to check any of the boxes in the Layers section.

3.

Click in the boxes in the Purge section to indicate which features you want to save: the Layers,
Symbols, Line Types, and/or Hatch Patterns.

4.

Select an option from the File pull-down menu in the Purge Drawing dialog box. You can save
the drawing in three different file formats:


AEC - The Save file as dialog box appears. The Save as type input field shows that you
selected the AEC format from the File pull-down menu in the Purge Drawing dialog box.
Supply a name for the new file.
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Figure 2.57: Name the new AEC file


DXF – the Enter filename to export dialog box appears. The Save as type input field shows
that you selected the DXF format from the File pull-down menu in the Purge Drawing dialog
box; however, you can use the drop-down box to indicate the precise version of DXF. The
DXF file will be saved in the Transfer folder. Supply a name for the DXF file. Check off the
appropriate options in the Enter filename to export dialog box: Translate colors using color
table file; Translate user-defined line types to continuous line definition; Decompose 3D
entities as 3D faces; and/or Automatically export reference files. Click on one of the buttons in
the Export unit type section to indicate which measurement option you want: Arch
(architectural), Eng (engineering), Millimeters, Centimeters, or Meters.

Figure 2.58: The Enter filename to export dialog box
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5.

DWG – the Enter filename to export dialog box appears. The only difference between this
dialog box and the DXF one is the Save as type input field. Instead of showing available DXF
versions, it shows available DWG versions. The Save as type input field shows that you
selected the DWG format from the File pull-down menu in the Purge Drawing dialog box;
however, you can use the drop-down box to indicate the precise version of DWG.

Supply a name for the new file and click on Save or press (Enter). The Purge Drawing dialog box
reappears. If you want to create more purge files, repeat steps 2 through 5.

Click on the X in the upper right corner of the Purge Drawing dialog box when you are finished creating
new files based on the current drawing. Alternatively, you can select Close from the File pull-down menu
in the Purge Drawing dialog.

Exporting Files
You may need to export your DataCAD drawings to other file formats, so that you or other offices and/or
consultants you work with can use them in other applications. You can export both DWG and DXF files
compatible with AutoCAD releases R12-R14, and (Pro) R2000-R2015. You can also export a Design Web
Format (.DWF), Virtual Reality Markup Language (.WRL), DC Render (.RAY), Text (.TXT), Objects to See
(.o2c), 3D Studio (.3DS), SketchUp (.SKP), and Stereolithography (.STL) file. It’s generally a good idea to
purge your drawing file before exporting it. For details, see “Purging Files” in this chapter. See
“Customizing File Translation” in this chapter for more information about how entities are translated
during export.
During export, line definitions and shape codes for DataCAD line types are stored in a .SHX file. If you
export a DWG file of the DataCAD drawing MYDRAWING.AEC, the translator will create two files:
MYDRAWING.DWG and MYDRAWING.SHX. For line types in the DWG file to display correctly, the
.SHX file must be placed in the \SUPPORT folder in the AutoCAD directory.
 To export your drawing to a DXF, DWG, or DWF file:
1.

Save your drawing before starting the export function. This is especially important if you’ve
made any changes to your drawing.

2.

Click on Export in the File pull-down menu. A submenu appears.

3.

Click on DWG, DXF, or DWF in the submenu. Two export options appear in a submenu: All
Layers and On Layers.
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Figure 2.59: File export options
4.

Click on All Layers to export all the layers in your drawing. Click on On Layers to export only
those layers that are toggled on or are currently being displayed. The Export dialog box appears.

5.

Go to the File name input box and type a name for the file.

6.

Choose a file type from the Save As Type drop-down box. If you chose DWG in step 3, the default
file type is R14-DWG file (*.dwg); if you chose DXF in step 3, the default file type is R14-DXF file
(*.dxf); if you chose DWF in step 3, the default file type is DWF file (*.dwf).

7.

Click on Save; the export begins. The export’s progress appears in the Attention toolbar. To cancel
the translation, press (End). If the filename you entered in step 4 already exists, a dialog box will
be displayed, giving you the choice to overwrite (replace) the existing file. Also if the
DWG/DXF/DWF file you’re attempting to overwrite is open, a message explaining that the file is
currently in use will be displayed. By default, DataCAD saves all exported files to the
DataCAD\Transfer folder.

 To export a 3D model to VRML: (Pro)
1.

Select Export from the File pull-down menu.

2.

Click on VRML in the extended menu. A dialog box appears.
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Figure 2.60: Save VRML file format for export
3.

Supply a file name for the VRML file that you want to create. Then, click on Open or press
(Enter).

You can export DataCAD models to the Stereolithography (.STL) format for use with rapid prototyping
machines such as the 3D printers developed by ZCorp (www.zcorp.com). You can also use the Insert
menu to import STL files directly into DataCAD.
 To export to a Stereolithography (.STL) file: (Pro)
1.

Select Export from the File pull-down menu.

2.

Click on STL File in the extended menu. A dialog box appears.

3.

Supply a file name for the STL file that you want to create. Then, click on Save or press (Enter).

Exported .RAY files include eight light sources: one sunlight and seven spotlights.
 To export to a DC Render (.RAY) file: (Pro)
1.

Click on Export in the File pull-down menu. A submenu appears.

2.

Click on RAY in the submenu. A dialog box appears.

3.

Type the name of the .RAY file that you’d like to export.

4.

Decide what folder you want to use for the .RAY file. DC Render files are saved to your
DataCAD\RAY folder by default. If you’d like to save your .RAY file to another folder, use the
Save In drop-down box or the Up One Level icon button to change to another folder.

5.

Click on Save to export your drawing to the named .RAY file.

 To export an o2c object:
1.

Click on Export in the File pull-down menu. A submenu appears.

2.

Click on o2c in the submenu. A dialog box appears.

3.

Type a name for the o2c object that you’d like to export.

4.

Decide what folder you want to use for the o2c object. By default, o2c objects are saved to your
DATACAD\RAY folder. If you’d like to save your o2c objects to another folder, use the Save In
drop-down box or the Up One Level icon button to change to another folder.
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5.

Click on Save to export your model as the named o2c object.

More About o2c Objects
You can export your DataCAD model as an o2c object. o2c, an acronym for Objects to See, is a highly
compressed 3D format that is optimized for Internet-based communication.
Simply export your DataCAD model as an o2c object and then either distribute it to your client as an email attachment or embed it into one of your web pages.
Using the easy-to-use o2c player, your clients can freely rotate or walk through a fully rendered
architectural model. They can view models in wire-frame, hidden-line, flat-shaded, textured, or raytraced modes. The o2c objects can even contain animated elements that can be played in conjunction with
the 3D viewing commands. And because you can generate a high-resolution, photorealistic rendering of
the model right in the o2c player, you don't need to transmit excessively large images via email; your
clients can simply create their own. While the o2c player provides comprehensive and powerful viewing
controls, objects can’t be modified.
For more information about o2c, see “Using the o2c-based Object Viewer” in the “Viewing Your Model”
chapter.

Launching External Applications
A toolbar code lets you launch external application. You can use the new “P” code to launch an external
program (such as WordPad) from a DataCAD toolbar icon.
To launch an external program from a DataCAD toolbar, use the following syntax:
[Launch_WordPad]
Hint=Launch WordPad
Icon=WordPad_Icon
P=c:\program files\windows nt\accessories\wordpad.exe
If the external program supports command line parameters, you can include them as well. The following
example lauches WordPad and automatically opens my_document.txt.
[Open_My_Document]
Hint=Launch WordPad and open My_Document.txt
Icon=My_Document_Icon
P=c:\program files\windows nt\accessories\wordpad.exe
c:\my_documents\my_document.txt
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Chapter 3 Tutorial: Drawing a
Schoolhouse
In this chapter, you’ll learn how to customize both DataCAD and
your drawing before you ever draw a line. Then you’ll draw the
exterior and interior walls of the schoolhouse and add doors and
windows to it.
Note: This tutorial refers to DataCAD’s ‘Classic’ walls, doors,
and windows and does not cover ‘Smart’ walls, doors, and
windows that were introduced in DataCAD 12. For more
information, please see the “Smart Entities Tutorial” located in
the DataCAD 18\Help folder.

3

In this chapter:

 Drawing walls
 Drawing windows
 Drawing doors

102 | TUTORIAL: DRAWING A SCHOOLHOUSE

Setting Up a New Drawing
DataCAD contains many options for customizing the way your system operates. In this tutorial, you will
make only two modifications: adding layers to a new drawing and changing the snap grid setting.
To begin this tutorial, start DataCAD and start a new drawing, as described in “The Drawing Board”
chapter.

Setting the Snap Grid for the Tutorial
First, you’ll need to change the snap grid setting.
 To set the snap grid:
1.

Press (S) on your keyboard. Make sure Caps Lock is off. In the Message toolbar, you are
prompted to Enter X-snap grid.

2.

Type .1 and press (Enter). You are prompted to Enter Y-snap grid.

3.

Type .1 and press (Enter).

You just set the accuracy of the cursor movement to one inch. Move your cursor around the drawing
screen and look at the X and Y snap grid values in the Coordinates/Hints toolbar.

Creating New Layers for the Tutorial
When you start a new drawing in DataCAD, it contains only one layer (called Layer001), which is also the
active layer. Any settings in the active layer will automatically be used in new layers when you create
them. For example, the snap grid setting you entered above will be assigned to each layer you add to
your drawing; so you won’t have to set the snap grid in every new layer.
 To add layers to this drawing:
1.

Right-click to return to the Utility menu from the previous exercise.

2.

Click on Layers in the Utility menu.

3.

Click on New Layer in the Layers menu.

4.

Type 8 and press (Enter). You’ve just added eight layers to the drawing for a total of nine layers.

Naming Layers for the Tutorial
You’ll be given the layer names for this exercise, but you should develop your own plan for naming
layers based on the type of work you do.
 To rename your layers:
1.

Make sure you’re in the Layers menu. If you’re not, click on Layers in the Utility menu.

2.

Click on Rename in the Layers menu. The Rename menu contains a list of all your layers.

3.

Click on Layer001. You are prompted to Enter new name.

4.

Type Walls and press (Enter). Look at the list of layers in the Menu Window; notice that Layer001
has been changed to Walls.

5.

Click on Layer002. You are prompted to Enter new name.

6.

Type Doors and press (Enter). Notice that Layer002 is now named Doors in the layer list in the
Menu Window.

7.

Rename the rest of your layers as follows: Layer003 to Windows, Layer004 to Plumb, Layer005 to
Dim, Layer006 to Hatch, Layer007 to Notes, Layer008 to Misc, and Layer009 to Border.

SETTING UP A NEW DRAWING |
8.

Right-click twice to return to the Utility menu.

Moving Between Layers in the Tutorial
Now that you’ve created and named your new layers, you can move among them. To draw walls on the
Walls layer and doors on the Doors layer, you have to change to the corresponding layer before you begin
drawing. In DataCAD terms, before you place a wall on your drawing, you will make the Walls layer the
active layer.
The Status Panel toolbar shows the active layer or the layer that you are drawing on. As you change active
layers, the Status Panel toolbar is updated with the corresponding layer name. You can only draw on the
active layer.

Active layer color can be
changed using (K) or the
pull-down arrow or the
color swatch

Active layer name can be
changed using (Tab) or
the pull-down arrow or
the Layer Manager icon

Figure 3.1: Check the Status Panel toolbar for active layer name and color.
 To change the active layer:
1.

Press (Tab) on your keyboard. Notice that the active layer name in the Status Panel toolbar
changes.

2.

Keep pressing (Tab). Eventually you’ll return to the beginning of the layer list. Pressing (Shift) +
(Tab) cycles backwards through your layers.

Assigning Colors to Layers in the Tutorial
You can assign different colors to layers, so that any entities you add to a layer will be drawn in that
layer’s color. You’ll be able to tell at a glance what layer an entity is on simply by its color. That color is
the active color for that layer until you change it.
 To assign layer colors:
1.

Make sure you’re in the Layers menu. If you’re not, click on Layers in the Utility menu.

2.

Press (Tab) until the Doors layer is the active layer. Check the Status Panel toolbar to see which
layer is active.

3.

Click on Color in the Layers menu.
Shortcut: Press (K) to change the color of the active layer. Pressing (K) will cycle through the
colors; pressing (Shift) + (K) cycles backwards through the layers.

4.

Click on Green. The color assigned to the Doors layer is now Green. The layer color swatch in the
Status Panel toolbar is also green.

5.

Press (Tab), so that the Windows layer is active.

6.

Click on Color in the Layers menu.
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7.

Click on Cyan. The color assigned to the Windows layer is now Cyan.

8.

Use this same procedure to assign colors to the rest of your layers. Make the Plumb layer Lt.
Grey, the Dim layer Lt. Grey, the Hatch layer Brown, the Notes layer Lt. Red, the Misc layer Red,
and the Border layer Lt. Green.

9.

Right-click to return to the Utility menu.

Drawing Walls, Windows, and Doors
This part of the tutorial introduces you to using DataCAD as an architectural tool. You will learn how to
use the wall menu options to begin drawing architectural plans. This tutorial uses Arch units. See
“Customizing Drawing Settings” in the “Before You Draw” chapter for more information on how to
change drawing units.

Drawing the Schoolhouse Walls
Each wall that you draw will have two or more lines, rather than just one. In the following exercises, you
will draw walls using both the mouse and the keyboard.

Figure 3.2: Examples, from left to right, of 2-line walls, 3-line walls, and 4-line walls
The Architect menu is used for drawing walls as well as doors and windows.
Menu title
Turns Walls on/off. Draws parallel lines when on, single lines when off.
Choose type of multi-line wall:
2, 3, or 4 lines
Set wall thickness (the distance between the parallel lines)

Automatically cleans T-intersections as you draw walls
Enters the Door Swing menu to insert doors in walls
Enters the Windows menu to insert windows in walls
Exits the Architect menu. You can also right-click to exit.

Figure 3.3: The Architect menu is used for drawing walls, windows, and doors.
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Drawing the Schoolhouse’s Exterior Walls
Before you draw the exterior walls of the schoolhouse, you should make sure your wall settings are
correct.
 To set up for drawing exterior walls:
1.

Continue with the drawing you started in the previous section of this tutorial.

2.

Make sure you’re in the Edit menu in the Menu Window; click on Architect. The Architect menu
appears.

3.

Click on Walls in the Architect menu to toggle it on; walls will be drawn instead of single lines.
Notice that the “w” in the SWOTHLUDFB toolbar is now uppercase. This indicates that you will
draw walls instead of single lines.

4.

Click on 2 Line Walls in the Architect menu if it’s not already toggled on.

5.

Click on Width in the Architect menu to set the width of the wall. A value menu appears; you are
prompted to Enter wall width. For more information on using value menus, see “Value Menus” in
“The Drawing Board” chapter.

6.

Click 1’-0” in the value menu and then right-click or type 1; then, press (Enter).

7.

Click Outside in the Architect menu; any walls you draw will be defined by the outside line of
the wall.

8.

Right-click to return to the Edit menu.

9.

Look at the Status Panel toolbar to make sure that Walls is your active layer. If it’s not, press (Tab)
until it is.

Now you are ready to draw the exterior walls.
 To draw exterior walls:
1.

Use the mouse to draw the first wall. Notice that the prompt in the Message toolbar reads Select
first endpoint of new line/wall. Move the cursor to the lower left of the Drawing Area and click to
enter the first endpoint of the new wall. You are prompted to Select next endpoint of line/wall.

2.

Move the cursor to the right until the coordinate readout shows an X measurement of 28’-0” and
a Y measurement of 0 and click. This defines the exterior line of the wall. You are prompted to
Select a point to define the inside of the wall.

3.

Move the cursor to a position anywhere above the displayed line and click. The wall is
immediately drawn. You are prompted to Select next endpoint of line/wall.

Figure 3.4: Drawing the first wall
Leave the cursor
connected to the wall
line.

Figure 3.5: The wall is drawn.
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4.

Draw a second wall using coordinate entry. Press (Insert) until the Attention toolbar reads
Current input mode = Relative Polar (distance, angle). You can also use coordinate entry to enter
points. See “Drawing Using Coordinate Entry” in “The Drawing Board” chapter to review
coordinate entry methods.

5.

Press (Spacebar) to activate coordinate entry. You are prompted to Enter relative distance.

6.

Type 40.6 and press (Enter); 40.6 means 40 feet 6 inches in architectural units. You are prompted
to Enter relative angle.

7.

Type 90 and press (Enter). The wall is drawn and the corner is automatically cleaned. If the new
wall extends beyond your view of the Drawing Area, use the arrow keys to move your drawing
into view.

The cursor is connected to the outside
corner.

The corners automatically clean up as
you draw.

Figure 3.6: The second wall is drawn and the corner is cleaned.

8.

Click on the

icon in the Navigation Pad toolbar to zoom out to the extents of the drawing.

9.

Press (Spacebar). You are prompted to Enter relative distance.

10. Type 28 and press (Enter). You are prompted to Enter relative angle.
11. Type 180 and press (Enter).
12. Move the cursor close to the inside line of the corner where you originally began and click. The
last corner is cleaned, leaving a clean outline of the schoolhouse exterior walls.

Bring cursor close to the inside wall line.

Figure 3.7: Ending your exterior wall
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The final corner is automatically cleaned up.

Figure 3.8: The exterior walls are complete.
Drawing the Schoolhouse’s Interior Walls
Now you will draw the interior walls. You’ll change the wall thickness for the interior walls to four
inches.
 To set up for drawing the interior walls:
1.

Go to the Edit menu in the Menu Window; click on Architect. The Architect menu appears.
Shortcut: Press (A) to access the Architect menu at any time.

2.

Click on Width in the Architect menu. You are prompted to Enter wall width.

3.

Type .4 and press (Enter).

4.

Click on Inside in the Architect menu to define the wall by the inside line.

5.

Click on Clean to toggle on automatic T intersection cleaning. Walls and 2 Line Walls should still
be toggled on.

6.

Right-click once to return to the Edit menu.

 To draw interior walls:
1.

Click
on the Navigation Pad toolbar to open the Zoom menu. You are prompted to Select first
corner of the Zoom window.

2.

Position your cursor outside the lower-left corner of the plan and click. You are prompted to
Select second corner of the Zoom window.

3.

Move the mouse diagonally, stretching the rubber band box until it encloses the lower half of the
plan as in the next figure and click. Your drawing now appears larger.
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3
Click the left mouse button to close the
rubberband box.

2
Click the left mouse button to start the
rubberband box.

Figure 3.9: Zooming in on the lower half of the plan.
4.

Right-click to return to the Edit menu.

5.

Press (`) on the keyboard to set X and Y to 0. You are prompted to Select reference point. The accent
key (`) is located in the upper-left corner of your keyboard, just below (Esc) and to the left of (1)
on most keyboards.

6.

Move the cursor close to the inside left corner of the bottom wall and either click the middle
mouse button or press (N) on the keyboard. This sets this corner as the new reference point to
work from. Steps 6-9 are the equivalent of placing one end of an architect’s scale at a corner and
marking a point at 10’-2”.
6
New reference point

Figure 3.10: Setting a reference point
7.

Press (Spacebar). You are prompted to Enter relative distance.

8.

Type 10.2 (the inside dimension of the office) and press (Enter). You are prompted to Enter relative
angle.

9.

Type 0 for the relative angle and press (Enter). Notice that your cursor is now attached to the wall
exactly 10’-2” to the right of the corner you used as your reference point. This will be the first
point of the interior wall.
Cursor still attached to a point.

Referenced corner

Figure 3.11: Starting your interior wall
10. Press (Spacebar). You are prompted to Enter relative distance.
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11. Type 10.8 (the inside dimension of the office) and press (Enter). You are prompted to Enter relative
angle.
12. Type 90 and press (Enter). You are prompted to Select a point to define the Outside of the wall.
13. Move the cursor to the right of the displayed line and click to indicate the outside of the wall.
You remain connected to the wall.

13
Click the left mouse button.

Figure 3.12: Defining the outside of the wall
14. Move the cursor close to the inside line of the left exterior wall and click.

14
Click the left mouse button close to the inside line
of the exterior wall.

Figure 3.13: Drawing the last office wall
15. Right-click to disconnect from the line. The office area is complete and all intersections are
automatically cleaned.
 To draw the remaining interior walls:
1.

Press (`) on the keyboard. You are prompted to Select reference point.

2.

Move the cursor close to the inside right corner of the bottom wall and click the middle mouse
button. Remember, if you don’t have a three-button mouse you can also press (N) on the
keyboard.

2
New reference point

Figure 3.14: Selecting a new reference point
3.

Press (Spacebar). You are prompted to Enter relative distance.

4.

Type 10.2 and press (Enter). You are prompted to Enter relative angle.

5.

Type 180 and press (Enter). The cursor connects to a point on the inside line of the exterior wall.

6.

Press (Spacebar). You are prompted to Enter relative distance.

7.

Type 10.8 and press (Enter). You are prompted to Enter relative angle.

8.

Type 90 and press (Enter). You are prompted to Select a point to define the Outside of the wall.

9.

Move the cursor to the left of the new wall and click to define the outside of the wall.
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10. Move the cursor to the right just before the inside line of the exterior wall and click.
11. Right-click to disconnect from the wall line. The wall is drawn and your intersections are cleaned.

T intersection cleaned up automatically

Figure 3.15: The wall is drawn and the intersections are cleaned.
12. Press (`). You are prompted to Select reference point.
13. Move the cursor near the inside corner of the wall you just drew and click the middle mouse
button.

13
New reference point

Figure 3.16: Selecting a new reference point
14. Press (Spacebar). You are prompted to Enter relative distance.
15. Type 5.2 and press (Enter). You are prompted to Enter relative angle.
16. Type 270 and press (Enter). The cursor connects to a point on the inside line of the exterior wall.
17. Move the cursor to the left, close to the inside line of the wall, and click. You are prompted to
Select a point to define the Outside of the wall. It is important in step 17 to select a point closer to the
inside, not the outside, line of the room you just drew so that the correct wall line will be cleaned.
18. Move the cursor below the displayed line and click to define the outside of the wall.

17
Click mouse closer to the
inside line of the room just
drawn.

18
Click mouse here to define outside
of wall.

Figure 3.17: Drawing the dividing wall between the bathrooms
19. Right-click to disconnect from the wall.
20. Click on

in the Navigation Pad toolbar to view the drawing extents.
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Figure 3.18: The walls of the schoolhouse floor plan
21. Press (Ctrl) + (S) on the keyboard to save the drawing. This is a good habit to get into. You should
do it after you enter several items or make a lot of changes to your drawing.
You have now completed all the walls of the schoolhouse plan and saved your drawing. If any of the
walls did not clean and your drawing doesn’t look like the figure above, the next section will help you
straighten up your plan.
Cleaning the Schoolhouse’s Wall Intersections
As you insert walls, DataCAD automatically cleans intersections. If you right-click by accident and
disconnect from a wall prematurely or your intersections clean at the wrong wall line, you will need to
clean them.

1
If you disconnected from a wall and
reattached to continue the remaining
walls, the corner you reattach to will not
clean.

2
If you become disconnected from a wall,
when you attempt to complete the last
intersection, the “L” intersection will not
clean up properly.

3
If you were too close to the outside line of
this wall when drawing the dividing wall,
the wrong line will clean.

Figure 3.19: Examples of wall intersections that were improperly drawn
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If an L intersection doesn’t clean properly, despite Clean being toggled on when you drew the walls, it
may be because you disconnected your cursor from the end of one wall and then started drawing the next
wall. In such a case, you may have to use 2 Line Trim in the Cleanup menu so the wall lines intersect
properly; then use Erase to remove any unwanted lines within the intersection.
 To fix the error shown in example 1:
1.

Go to the Edit menu in the Menu Window; click on Cleanup.

2.

Click on L Intersect in the Cleanup menu. You are prompted to Select 1st corner around L
intersection (wall lines only).

3.

Click above and to the right of the intersection.

4.

Diagonally drag the cursor to the lower left of the intersection, stretching the rubber band box,
and click.

Place a rubberband box
around the corner to
clean.

The corner is
automatically
cleaned.

Figure 3.20: Cleaning an L intersection
 To fix the error shown in example 2 on the previous page:
1.

Go to the Edit menu in the Menu Window; click on Cleanup.

2.

Click on L Intersect in the Cleanup menu. You are prompted to Select 1st corner around L
intersection (wall lines only).

3.

Click above and to the right of the intersection.

4.

Drag the cursor diagonally to the lower left of the intersection, stretching the rubber band box
around the intersection, and click.
Place a rubberband box
around the corner to
clean.

The corner is
automatically
cleaned.

Figure 3.21: Cleaning an L intersection
 To fix the error shown in example 3 on the previous page:
1.

Go to the Edit menu in the Menu Window; click on Cleanup.

2.

Click on 1 Line Trim in the Cleanup menu. You are prompted to Select first point of line to clip to.

3.

Click on Entity in the 1 Line Trim menu. You are prompted to Point to line to trim to.

4.

Click on the inside wall line, shown in Figure 3.22. The line you select becomes dashed. You are
prompted to Point to outside.
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5.

Click to the left of the dashed line. You are prompted to Select entity to trim.

6.

Click on the two wall lines to select them as the lines to trim. The lines are trimmed.

4
Click the left mouse button
to define this line as the line
to clip to; the line becomes
dashed.

5
Click the left
mouse button to
define the outside.

6
Click the left mouse button to select
these two lines as the lines to trim.

Figure 3.22: Completing a 1-line trim
7.

Right-click once to return to the Cleanup menu.

The lines are trimmed to the
correct wall, but there is still a
break in the wall.

Figure 3.23: Trimming wall lines to the correct wall
8.

Fix the break in the outside wall by clicking on Weld Line in the Cleanup menu. You are
prompted to Select first line to weld.

9.

Click on one of the lines of the broken wall to select it; it becomes dashed. You are prompted to
Select second line to weld.

10. Click on the other line of the broken wall to select it. The line mends and becomes a single entity.

9
Click the left mouse button to
define the first line to weld. It
becomes dashed.

10
Click the left mouse button to
define the second line to weld.
The line is mended.

Figure 3.24: Selecting lines to be welded
11. Right-click once to return to the Cleanup menu.
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The lines are
trimmed to the
inside wall.

Figure 3.25: The wall line is welded.
12. To clean up the T intersection in the wall, click on T Intersect in the Cleanup menu. You are
prompted to Select 1st corner around “T” intersect (wall line ends only).
13. Click at the lower left of the intersection you want to clean. You are prompted to Select 2nd corner
around “T” intersect (Wall line ends only).
14. Move the cursor above and to the right of the intersection to enclose the corner to clean and click.
You are prompted to Point to a wall line to trim to.
15. Click on the inside line to select it as the line to trim to.
16. Right-click twice to return to the Edit menu.

13-14
Place a rubberband box
around the corner to clean.

15
Click the left mouse button to
define this line as the line to
trim to.

Figure 3.26: Completing a T intersection

The wall is cleaned and
the T intersection is
complete.

Figure 3.27: The wall intersection is cleaned.
Drawing Countertops in the Schoolhouse
While the 3-line walls function is usually used for drawing walls, we’ll use it here to quickly draw
parallel lines representing countertops.
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 To set up to draw countertops:
1.

Click on Architect in the Edit menu.

2.

Click on 3 Line Walls in the Architect menu to toggle on the 3-line wall option. This allows you to
draw three parallel lines at once. The two outer lines will define the edges of the counter and the
centerline will be a dashed line to represent the upper cabinets. Walls should still be toggled on.

3.

Click on Center Line in the Architect menu to set the attributes of the centerline of the two
parallel lines. This will represent the upper cabinets.

4.

Click on Line Type in the Center Line menu. All available line types are listed in the Menu
Window.

5.

Click on Dashed in the Line Type menu to make the centerline dashed.

6.

Right-click once to return to the Architect menu.

7.

Click on Width in the Architect menu. You are prompted to Enter wall width.

8.

Type 2 and press (Enter). This sets the width of the countertop at two feet.

9.

Click on Outside in the Architect menu; the wall will be defined by the outside line.

10. Click on Cap in the Architect menu to automatically cap the end of the parallel lines (or in this
case, countertops).
11. Right-click to return to the Edit menu.
Now you are ready to draw the countertops.
 To draw countertops on the plan:
1.

Click
on the Navigation Pad toolbar to open the Zoom menu. You are prompted to Select first
corner of the Zoom window.

2.

Click near the lower-left corner of the bottom wall. You are prompted to Select second corner of the
Zoom window.

3.

Drag the mouse diagonally until the rubber band box encloses the lower half of the plan and
click. The plan now appears larger.

4.

Right-click once to return to the Edit menu.

5.

Move the cursor to the corner marked 6 in Figure 3.28 and click the middle mouse button to select
it as your first reference point.
6
Click the middle mouse
button to connect to this
point.

Figure 3.28: Selecting the starting point of the countertop
6.

Press (Spacebar). You are prompted to Enter relative distance.
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7.

Type 10.2 and press (Enter). You are prompted to Enter relative angle.

8.

Type 180 and press (Enter).

9.

Move the cursor above the displayed line and click to define the other side of the counter.
9
Click the left mouse button to
define the other side of the
countertop.

7-8
The length of the countertop
is defined.

Figure 3.29: Drawing the countertop
10. Right-click to disconnect from the counter. The countertop lines are drawn and the end is capped.

Figure 3.30: The first countertop is drawn.
11. Repeat steps 5 - 10 for the counter on the opposite side. Remember that the relative angle for this
counter will be 0.

Figure 3.31: The second countertop is drawn.

12. Click

on the Navigation Pad toolbar to view the extents of the drawing.

13. Press (Ctrl) + (S) to save the drawing.

Drawing the Schoolhouse’s Doors and Windows
Now that you have drawn the walls for the schoolhouse plan, you are ready to insert doors and
windows.
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 To set up to draw a door:
1.

Press (Tab) until the Doors layer is the active layer in the Status Panel toolbar.

2.

In the Edit menu in the Menu Window, click on Architect.

3.

Click on Door Swing in the Architect menu.

Door entry method is by sides (jambs) if this is toggled
on or by centers if Sides is toggle off.

Adjusts settings to
determine what
doors will look like

Removes doors and cut-outs in walls
Draws temporary marks to help you place a door

Figure 3.32: The Door Swing menu
4.

Click on Draw Marks in the Door Swing menu to toggle the Draw Marks option on.

5.

Click on One Layer to toggle it on. (If One Layer is already toggled on, click on it to toggle it off;
then toggle it back on again.) You are prompted to Select layer to search for walls; a list of your
layers appears in the Menu Window.

6.

Click on Walls. DataCAD now knows where to find your walls when it needs to cut them for
doors and windows.

There are two methods to draw a door: by defining both of its sides and by defining one side and its
center. You’ll draw the first door by sides. To position and begin drawing a door, you need to reference
and measure from an existing point on the drawing.
 To draw a door by sides:
1.

Click
on the Navigation Pad toolbar to go to the Zoom menu. You are prompted to Select first
corner of the Zoom window.

2.

Click at the lower-left corner of the bottom wall. You are prompted to Select second corner of the
Zoom window.

3.

Drag the mouse diagonally until the rubber band box encloses the lower half of the plan and
click. The plan now appears larger.
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3
Click the left mouse button to close the
rubberband box.

2
Click the left mouse button to
start the rubberband box.

Figure 3.33: Zooming in on the plan

Figure 3.34: The result of zooming in on your drawing
4.

Right-click once to return to the Door Swing menu.

5.

Press (`) on the keyboard. You are prompted to Select reference point.

6.

Click the middle mouse button near the upper-right corner of the first room you drew, as shown
in Figure 3.35. Stay close to the inside of the corner. This will be your reference point. You are
prompted to Select hinge side of door.

6
Click the middle mouse button to set this corner
as the reference point.

Figure 3.35: Setting a reference point.
7.

Press (Spacebar). You are prompted to Enter relative distance.

8.

Type .3 and press (Enter). You are prompted to Enter relative angle.

9.

Type 270 and press (Enter). You are prompted to Select strike side of door.
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10. Press (Spacebar). You are prompted to Enter relative distance.
11. Type 3 and press (Enter). You are prompted to Enter relative angle.
12. Type 270 and press (Enter). You are prompted to Select direction of door swing.
13. Click anywhere inside the office (on the left side of the wall); this defines the direction of the
swing. The wall is cut and you are prompted to Select any point on the outside of the wall.
14. Click to the right of the outside wall to define the nonprinting snap point location. The door is
drawn.
7-9
The hinge side of the door.

A non-printing center
snap point.

.

14
Click the left mouse button to define the
outside of the wall.

10-12
The strike side of the door.

13
Click the left mouse button to define the
direction of door swing.

Figure 3.36: Drawing the door
 To draw a second door by center:
1.

Click on Sides in the Door Swing menu to toggle off the Sides option. Now you can define doors
by entering their center and strike side.

2.

Move the mouse to the location shown in Figure 3.37. Click the middle mouse button to snap to
the midpoint of the inside front wall. You are prompted to Select strike side of door.
2
.

Click the middle mouse
button to connect to the
midpoint of the line.

Figure 3.37: Defining the center of the front door
3.

Press (Spacebar). You are prompted to Enter relative distance.

4.

Type 1.6 and press (Enter). You are prompted to Enter relative angle.

5.

Type 0 and press (Enter). You are prompted to Select direction of door swing.

6.

Click inside the hall (above the wall) to define the direction of the door swing. The wall is cut.
You are prompted to Select any point on the outside of the wall.
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7.

Click anywhere on the outside of the exterior wall where you want to locate the nonprinting snap
point. The door is drawn.

6
Click the left mouse button to define the
direction of the door swing.

2
The center of the door.

3-5
The strike side of the door.

7
Click the left mouse button to define the
outside of the wall.

Figure 3.38: The front door is drawn.
8.

Click on Sides to toggle on the Sides option.

9.

Press (`) to set a new reference point.

10. Click the middle mouse button near the upper-left corner of Room A, shown in Figure 3.39. You
are prompted to Select hinge side of door.
10
Click the middle mouse button to
define the new reference point.

Room A

Room B

Figure 3.39: Locating the next door
11. Press (Spacebar). You are prompted to Enter relative distance.
12. Type .3 and press (Enter). You are prompted to Enter relative angle.
13. Type 270 and press (Enter). You are prompted to Select strike side of door.
14. Press (Spacebar). You are prompted to Enter relative distance.
15. Type 3 and press (Enter). You are prompted to Enter relative angle.
16. Type 270 and press (Enter). You are prompted to Select direction of door swing.
17. Click anywhere inside Room A (on the right side of the wall) to define the direction of the swing.
The wall is cut. You are prompted to Select any point on the outside of the wall.
18. Click inside the hall to define the outside of the wall. This defines the nonprinting snap point
location. The door is drawn.
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19. Repeat steps 9-18 to create a door for Room B.
20. Right-click twice to return to the Edit menu.

Figure 3.40: The remaining schoolhouse doors are drawn.

21. Click

on the Navigation Pad toolbar to zoom to the extents of the drawing.

22. Press (Ctrl) + (S) on the keyboard to save the drawing.
You have now completed entering all the doors for this exercise and saved them to your drawing file.
 To set up to draw windows:
1.

Before you begin to draw windows, press (Tab) until the Windows layer is the active layer in the
Status Panel toolbar.

2.

In the Edit menu in the Menu Window, click on Architect.

3.

Click on Windows in the Architect menu. The Windows menu appears.

Window entry method is by sides (jambs) if this is
toggled on or by centers if Sides is toggle off.

Adjusts settings that
define what windows will
look like.

Removes windows and cut-outs in walls.
Draws temporary marks to help you place windows.

Figure 3.41: The Windows menu
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 To draw the first window by sides:
1.

Click
on the Navigation Pad toolbar to open the Zoom menu. You are prompted to Select first
corner of the Zoom window.

2.

Click at the lower-left corner of the bottom wall. You are prompted to Select second corner of the
Zoom window.

3.

Drag the mouse diagonally until the rubber band box encloses the lower half of the plan and click
to zoom in on your plan.

3
Click the left mouse button to close the
rubberband box.

2
Click the left mouse button to start the rubberband box.

Figure 3.42: Zooming in on the lower half of your drawing
4.

Right-click once to return to the Windows menu.

5.

Press (`) on the keyboard. You are prompted to Select reference point.

6.

Click the middle mouse button near the lower left corner of the interior wall shown in Figure
3.43. This will be your reference point. You are prompted to Select one jamb of window.
6
Click the middle mouse button
to set the reference point.

Figure 3.43: Setting a reference point
7.

Press (Spacebar). You are prompted to Enter relative distance.

8.

Type 3.7 and press (Enter). You are prompted to Enter relative angle.

9.

Type 0 and press (Enter). You are prompted to Select one jamb of window.

10. Press (Spacebar). You are prompted to Enter relative distance.
11. Type 3 and press (Enter). You are prompted to Enter relative angle.
12. Type 0 and press (Enter). You are prompted to Select any point on the outside of the wall.

DRAWING WALLS, WINDOWS, AND DOORS |
13. Click anywhere on the outside of the exterior wall. The window is drawn.
7-9
First window jamb

10-12
Second window jamb

13
Click left mouse button for the outside of the wall.

Figure 3.44: Drawing the first window
14. Move the cursor to the bottom right corner of Room B and repeat steps 6 - 14 for the window on
the opposite side. Remember that the relative angles will now be 180.
15. Click

on the Navigation Pad toolbar to view the extents of the drawing.

 To draw multiple windows:
1.

Click on Sides in the Windows menu to toggle Sides off; you can now define windows by the
center and one side or jamb.

2.

Click
on the Navigation Pad to open the Zoom menu. You are prompted to Select first corner
of the Zoom window.

3.

Click at the upper-right corner of the top wall. You are prompted to Select second corner of the Zoom
window.

4.

Drag the mouse diagonally until the rubber band box encloses the upper half of the plan and
click to zoom in on the plan.
3
Click the left mouse button to start the
rubberband box.

4
Click the left mouse button to close the
rubberband box.

Figure 3.45: Zooming in on the upper half of your drawing
5.

Right-click once to return to the Windows menu.

6.

Press (`) on the keyboard. You are prompted to Select reference point.

7.

Move the cursor to the top left corner of the interior wall, as shown in Figure 3.46 and click the
middle mouse button to set the reference point. You are prompted to Select center of window.
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7
Click the middle mouse button to set the
reference point.

Figure 3.46: Setting a reference point
8.

Press (Spacebar). You are prompted to Enter relative distance.

9.

Type 7.8 and press (Enter). You are prompted to Enter relative angle.

10. Type 270 and press (Enter). You are prompted to Select one jamb of window.
11. Press (Spacebar). You are prompted to Enter relative distance.
12. Type 1.6 and press (Enter). You are prompted to Enter relative angle.
13. Type 270 and press (Enter). You are prompted to Select any point on the outside of the wall.
14. Click anywhere on the outside of the exterior wall. The wall is cut and the window is drawn.

8-10
The center of the window

11-13
14

The window jamb

Click the left mouse button
to define the outside of the
wall

Figure 3.47: The wall is cut and the window is drawn.
15. Press (`) on the keyboard. You are prompted to Select reference point.
16. Move the cursor to the center snap point of the window you just drew and click the middle
mouse button to set the reference point. You are prompted to Select center of window.
17. Press (Spacebar). You are prompted to Enter relative distance.
18. Type 5.6 and press (Enter). You are prompted to Enter relative angle.
19. Type 270 and press (Enter). You are prompted to Select one jamb of window.
20. Press (Spacebar). You are prompted to Enter relative distance.
21. Type 1.6 and press (Enter). You are prompted to Enter relative angle.
22. Type 270 and press (Enter). You are prompted to Select any point of the outside of the wall.
23. Click anywhere on the outside of the exterior wall. The wall is cut and the window is drawn.
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16
Click the middle mouse button to set this point as
the new reference point

17-20
The center of the window

21-23
24

The window jamb

Click the left mouse button to
define the outside of the wall

Figure 3.48: The wall is cut and the window is drawn.
24. Repeat steps 15 - 23 for the last window on this wall.
25. Repeat these steps to create the windows on the other wall.
26. Click
on the Navigation Pad to view the extents of the drawing. Your plan should look like
Figure 3.49.
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Figure 3.49: The Schoolhouse floor plan.
28. Press (Ctrl) + (S) to save the drawing.

Chapter 4 Tutorial: Adding
Dimensions, Notes, Symbols,
and Hatching
This part of the tutorial covers those functions that transform a
drawing into an architectural construction document. You will
add text notes and arrows, dimension the drawing, add a tile
hatch to the hallway, and insert plumbing symbols in the
bathrooms as well as a sink in one of the countertops. Finally,
you’ll draw a title block and border around the drawing.

4

In this chapter:

 Drawing notes and
other text

 Dimensioning the
drawing

 Adding hatch to

areas of the drawing

 Inserting symbols
 Drawing title blocks
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Adding Text to the Schoolhouse Drawing
As you enter text, the schoolhouse floor plan will start to take shape. Depending on the size, placement,
and font being used, your drawing can develop into something that looks very professional.
 To set text attributes:
1.

If you are not already working in DataCAD, open the program now. Open the drawing you
worked on in the previous chapter.

2.

Press (Tab) until the Notes layer is the active layer, as displayed in the Status Panel toolbar.

3.

Click on Text in the Edit menu in the Menu Window or click on Text in the Create pull-down
menu. The Text menu appears.

Adjusts settings
that determine
what the text
will look like.

Draws arrows

Aligns text in
paragraphs

Figure 4.1: The Text menu
4.

Set the size of the text by clicking on Size. A value menu appears. The text cursor graphically
represents the current size of the text.

5.

Click on 1’-0” and right-click or type 1 and press (Enter).

6.

Set the aspect ratio of the text by clicking on Aspect. A value menu appears. An aspect ratio
below 1.0 creates wider and fatter characters, while an aspect above 1.0 creates thinner characters.

7.

Type .75 and press (Enter).

8.

Click on Font to select a new font. The Set Text Parameters dialog box appears so that you can
select SHX or TTF fonts.
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Figure 4.2: The Set Text Parameters dialog box
9.

Click on ARCWY2HC.SHX. This font has a nice hand-drawn style. Then click on OK to close the
dialog box.

10. Click on Alignment in the Text menu to display the Alignment menu.
11. Click on Center to center the text within an area on the drawing. Then right-click to return to the
Text menu.
 To insert room names:
1.

Move the cursor to the center of the large room. You are prompted to Position text using cursor,
then ‘ENTER’.

2.

Click to set the position of the text.

2
Click the left mouse button to set
the text cursor position.

Figure 4.3: Positioning the text cursor
3.

Press (CapsLock) if it isn’t already on.

4.

Type CLASSROOM. The text appears in the drawing as you type.
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5.

Right-click to exit this command and return to the Text menu.

6.

Repeat steps 1 - 5 for the office, but type OFFICE in the room to the lower left instead of typing
CLASSROOM.

Figure 4.4: Room labels for the classroom and office are added
 To insert notes:
1.

Set the size of the text by clicking on Size. A value menu appears.

2.

Type .6 and press (Enter).

3.

Click on Aspect. A value menu appears.

4.

Type 1.25 and press (Enter). This sets the aspect ratio to create a thinner text.

5.

Click on Alignment. Then click on Right in the Alignment menu to align the text on the right side
of the indicated placement point.

6.

Click in the center of the room, between the text CLASSROOM and the countertops. To zoom in
closer to the drawing, press (PageDown). Press (PageUp) to zoom out.

7.

Type the following note, pressing (Enter) after each line:
PLASTIC LAMINATE COUNTERTOP
36” ABOVE FINISHED FLOOR WITH
ADJUSTABLE SHELVES BELOW

8.

Right-click to exit this command and return to the Text menu.
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6
Text cursor location, with
text justified to the right

Figure 4.5: The note is placed on the drawing

Drawing Text Arrows in the Schoolhouse Drawing
 To draw text arrows:
1.

Click on Arrows in the Text menu.

2.

Click on Size to change the arrow size. You are prompted to Enter arrow size.

3.

Type .6 and press (Enter). You are prompted to Draw arrow.

4.

Click near the right side of the paragraph of text you just entered. This defines the tail end of the
arrow.

5.

Click to define any bends in the tail of the arrow.

6.

Click to define the arrowhead location.

4
Click the left mouse button to define the
beginning of the tail.

5
Click the left mouse button to define
the bend of the tail.

6
Click the left mouse button to define
the point of the arrow.

Figure 4.6: Placing an arrow in the drawing
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7.

Right-click once. The arrow is drawn.

8.

Right-click twice to return to the Edit menu.

Editing Text in the Schoolhouse Drawing
 To correct existing text:
1.

Click on Change in the Edit menu.

2.

Click on Text to set the text attribute you want to change.

3.

Click on Contents to change or edit the words in existing text.

4.

Click on Area to select the text with a window box.

5.

Click below and to the left of the text paragraph.

6.

Drag the mouse diagonally until the rubber band box completely encloses the entire note and
click. The first line of text appears in the Message Area.

6
Click the left mouse button to close the
rubberband box.

5
Click the left mouse button to start the
rubberband box.

Figure 4.7: Changing text
7.

Type over the text to make the following correction, pressing (Enter) when you’re finished:

CERAMIC TILE COUNTERTOP
The first line of text is corrected and the second line of text appears in the prompt.
8.

Press (Enter) to accept the second line as it is. The third line of text appears in the prompt.

9.

Press (Enter) to accept the third line as it is.

10. Right-click twice to return to the Edit menu.
11. Click on

to view the extents of the drawing.

12. Press (Ctrl) + (S) to save your drawing.
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Dimensioning the Schoolhouse Drawing
In an architectural office, there are many factors that determine the type of dimension used for a project.
In this section of the tutorial, you will insert standard linear dimensions in the schoolhouse floor plan.
 To set up to dimension:
1.

Press (Tab) until the Dim layer is the active layer in the Status Panel toolbar.

2.

Click on Dimensions in the Utility menu to display the Dimensions menu in the Menu Window.

3.

Draw linear dimensions by clicking on Linear. The Linear menu appears.

Draw horizontal,
vertical, aligned, or
rotated dimensions.

Set the text, line, and arrow
styles for dimensions.

Figure 4.8: Linear dimension menu
4.

Click on Text Style to change the current text style or settings.

5.

Click on Font in the Text Style menu to change the font.

6.

Click on ARCWY2HC in the FontName list in the Set Text Parameters dialog box to match the
font style of the notes. Then click on OK or press (Enter) to leave the dialog box.

7.

Right-click to return to the Linear menu.

Drawing a String of Dimensions:
 To draw a dimension string:
1.

Click on Vertical to draw vertical dimensions. You are prompted to Select first point of distance to
dimension.

2.

Move the cursor to the lower left corner of the exterior wall and click the middle mouse button or
press (N) on the keyboard to object snap to the corner. You are prompted to Select second point of
distance to dimension.

3.

Move the cursor to the snap point of the window shown in Figure 4.9 and click the middle mouse
button to snap to it. You are prompted with Dimension which side of line?
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.
3
Click the middle mouse button to
define the second point of distance
to dimension.

.

2
Click the middle mouse button to set
the start of the dimension line.

Figure 4.9: Placing the first dimension on the drawing
4.

Move the cursor to the outside of the wall and click.

5.

Click on String Line to continue drawing dimensions in a stringline. You are prompted to Select
next point to dimension to.

6.

Move to the snap point of the middle window and click the middle mouse button to snap to the
next point to dimension to. You are prompted to Select next point to dimension to.

7.

Move to the snap point of the last window and click the middle mouse button to snap to the next
point to dimension to.

8.

Click the middle mouse button to select the corner of the wall, which is also the end of the
stringline.

9.

Right-click to exit the String line menu and return to the Linear menu.

8
Click the middle mouse button to
end the stringline.

7
Click the middle mouse button to
define the next point to dimension
to.

6
Click the middle mouse button to
define the next point to dimension
to.

4
Click the left mouse button to define
the outside of the wall. The first line
is drawn.

Figure 4.10: Defining a stringline of dimensions
10. Click on Overall in the Linear menu to place an overall dimension of the stringline.
11. Right-click twice to return to the Utility menu.
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Figure 4.11: The stringline and overall dimensions are drawn

Automatic Dimensioning
You can also use automatic dimensioning; follow the steps below to use this second method of adding
dimensions to your drawing.
 To use automatic dimensioning:
1.

Click on Dimensions in the Utility menu. The Dimensions menu appears.

2.

Click on Linear. The Linear menu appears.

3.

Click on Auto Style to change the current automatic dimension settings.

4.

Click on Only Points to search and dimension to points only.

5.

Click on Layer Search to enable layer searching. All of the layers will be searched for points to
dimension.

6.

Click on Miss Dist. to set the distance to look for snap points.

7. Click on 1” and right-click or type .1 and press (Enter).
8.

Right-click to exit the Auto Style menu and return to the Linear menu.

9.

Click on Horizontal to draw horizontal dimensions.

10. Click on Auto Dim. You are prompted to Select first endpoint of line to dimension along.
11. Move the cursor to the bottom left corner of the exterior wall and click the middle mouse button
or press (N) on the keyboard. You are prompted to Select second endpoint of line to dimension along.
12. Move the cursor to the bottom right corner of the exterior wall and click the middle mouse
button. You are prompted with Dimension which side of line?
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11
Click the middle mouse button
to define the beginning of the
dimension line.

12
Click the middle mouse button to
define the end of the dimension line.

Figure 4.12: Selecting the points of your automatic dimension line
13. Move the cursor below the bottom wall and click. The dimension string is drawn automatically.
14. Right-click to return to the Linear menu.
15. Click on Overall to place an overall dimension. The front wall is dimensioned. (See Figure 4.13)
16. Right-click three times to return to the Edit menu.

Figure 4.13: The front wall is dimensioned

Stretching Dimensions
 To stretch dimensions:
1.

Click on Stretch in the Edit menu. You are prompted to Select the first point of distance to stretch.

2.

Click anywhere on the drawing window to locate the first point of the distance to stretch. You are
prompted to Select the second point of distance to stretch.

3.

Press (Spacebar). You are prompted to Enter relative distance.
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4.

Type 1.6 and press (Enter). You are prompted to Enter relative angle.

5.

Type 270 and press (Enter). The distance and angle to stretch appear in the Attention toolbar.

6.

Click on Area as the selection method. You are prompted to Select first corner of box to
<STRETCH>.

7.

Make sure Layer Search is on.

8.

Click outside the upper-left corner of the plan.

9.

Drag the mouse diagonally until the rubber band box encloses the rear wall and part of the left
and right walls. (See Figure 4.14)

10. Click to close the rubber band box. The walls are shortened by 1’-6” and the dimensions are
automatically adjusted.

10
Click the left mouse button to
close the rubberband box.

8
Click the left mouse button to
start the rubberband box.

Figure 4.14: Stretching the rear wall
11. Click on Invert to stretch the same distance in the opposite direction. The new angle appears in
the Attention toolbar. You are prompted to Select first corner of box to <STRETCH>. You can use
Invert for most editing commands. It uses the inverse of the defined angle.
12. Repeat steps 8 - 10 to return the wall to its previous shape.
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Figure 4.15: The plan is dimensioned
13. Right-click to return to the Edit menu.
14. Press (Ctrl) + (S) to save the drawing.
You have dimensioned the schoolhouse plan. Floor plans for construction of a real building would
require more dimension lines as well as lines from many different angles. You can use DataCAD to create
them all.

Hatching the Schoolhouse Drawing
Hatching is adding lines to your drawing that are in patterns, such as square boxes that represent floor
tile, for example. As you will soon find out, there are many hatch patterns to choose from.
 To set up to draw a tile hatch pattern:
1.

Press (Tab) until the Hatch layer is the active layer in the Status Panel toolbar.

2.

Click on Hatching in the Utility menu.

HATCHING THE SCHOOLHOUSE DRAWING |

Define a boundary, point by point, to infill
with hatch.

Settings that affect the
appearance of the
hatch

Figure 4.16: The Hatching menu
3.

Click on Associative to toggle associative hatching on. This creates the entire hatch as a single
entity. See “Drawing Associative Hatch” in the “Hatch” chapter for details.

4.

Click on Hatch Managr. The Hatch Pattern Manager dialog box appears. See “Using the Hatch
Pattern Manager” in the “Hatch” chapter for details.

5.

Highlight 12x12til in the External Hatch Patterns window.

6.

Click on the Load button in the Hatch Pattern Manager. This loads the 12X12 tile into the
Embedded Hatch Patterns portion of the Hatch Pattern Manager.

7.

Change the scale of the embedded 12x12til if its value is other than 1; just click on Scale in the
upper portion of the Hatch Pattern Manager and replace the existing value with the number 1.

8.

Make sure the angle is 0 in the upper portion of the Hatch Pattern Manager dialog box. Click on
OK to close the Hatch Pattern Manager and load the tile pattern into your drawing file for the
schoolhouse.

9.

Click on Pattern in the Hatching menu. You are prompted to Enter hatch pattern name. The 12x12til
is listed in the Pattern menu. Notice that when you move your cursor over the 12X12til in the
Menu Window, an example of the pattern appears in the preview window.

10. Click on 12x12til in the Pattern menu and press (Enter) to return to the Hatching menu.
 To draw a tile hatch pattern:
1.

Click on
from the Navigation Pad toolbar to go to the Zoom menu. You are prompted to
Select first corner of the Zoom window.

2.

Click below and to the left of the exterior wall. You are prompted to Select second corner of the
Zoom window.

3.

Drag the mouse diagonally until the rubber band box encloses the lower half of the plan and
click. The plan now appears larger.
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4.

Right-click to return to the Hatching menu.

5.

Click on Origin to start the hatch pattern at a defined point. You are prompted to Select hatch
pattern origin.

6.

Move the cursor to the lower-left corner of the hall and click the middle mouse button.

7.

Click on Boundary to define a boundary for the hatch. You are prompted to Select first point on
boundary to hatch to.

8.

Use object snapping to select points for the hatch boundary. To select the first point of the
boundary, move the cursor to the lower-left corner in the hall and click the middle mouse button.
You are prompted to Select next point on boundary to hatch to. For more information on object
snapping, see “Object Snapping” in the “Drawing Tools” chapter.
Shortcut: Press (N) to object snap to a point.

9.

Move the cursor upward and click the middle mouse button to object snap to the corner marked
A with. (See Figure 4.17)

10. Move the cursor close to the corner marked B and click the middle mouse button to object snap to
that point.
11. Move the cursor close to the corner marked C and object snap to that point.
12. Right-click to close the hatch boundary. Right-click to return to the Hatching menu.
9-12
A
B

Click the middle mouse button to
select these three points. After
object snapping to the corner
marked C, click the right mouse
button to close the boundary.

C
8
Click the middle mouse button
to start the hatch boundary.

Figure 4.17: Selecting a hatch boundary
13. Click on Begin to draw the hatch pattern. The pattern will fill the boundary you defined in the
previous steps.
14. Click on

to recalculate the extents of the drawing.

15. Right-click to return to the Utility menu.
16. Press (Ctrl) + (S) to save the drawing.
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Figure 4.18: The tile hatch is drawn
You have now created a hatch pattern and saved your updated drawing file.

Adding Symbols to the Schoolhouse
Symbols are one of the most powerful features of DataCAD. You can build symbol libraries from the
drawings you create and reuse them in other drawings. The symbols can be sections, details, notes,
furniture, fixtures, or any part of a drawing that will be drawn repetitively.

Opening a Symbol Folder
 To open a symbol folder:
1.

Click on
in the Navigation Pad toolbar to open the Zoom menu. You are prompted to Select
first corner of the Zoom window.

2.

Click at the lower-left corner of the exterior wall. You are prompted to Select second corner of the
Zoom window.

3.

Drag the mouse diagonally until the rubber band box encloses the lower half of the plan and
click. The plan is now displayed larger.

4.

Make sure the Symbol Browser toolbar is displayed. If it isn’t, just select Symbol Browser from
the View pull-down menu or use the shortcut (Ctrl) + (T).

5.

Click on
in the Symbol Browser and select Folder from the drop-down options. The Browse
dialog box appears, listing the contents of your DataCAD\Symbols folder.

6.

Double-click on the Plumbing folder to list the plumbing fixture symbols subfolders.

7.

Click on the Commercial folder. The symbols contained in this folder appear in your Symbol
Browser. Each box in the browser contains a symbol. Then click on OK to close the Browse dialog
box so you can use the plumbing symbols in your drawing.

8.

Move the cursor over the symbols; as you move the cursor over a symbol, a description of it
appears in the Coordinates/Hints toolbar.
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Figure 4.19: The Browse dialog box and Plumbing/Commercial symbol folder opened in the
Symbol Browser toolbar

Selecting and Placing Symbols
 To select and place symbols:
1.

Press (Tab) until Plumb is the active layer in the Status Panel toolbar.

2.

Click on
in the Symbol Browser toolbar to display the Options drop-down menu. Then click
on Rotate and make sure a check appears in front of it to toggle dynamic rotation on. This lets
you preview a symbol’s position before you place it in the drawing.

3.

Move the cursor over the toilet with grab bar on the right. You will see in the Coordinates/Hints
toolbar. Click to select the symbol.

4.

Move the cursor into the Drawing Area. A boxed outline representing the toilet and grab bars is
now attached to your cursor. The insertion point is at the upper-left corner of the symbol, the
point the cursor is connected to. Remember, you can use the arrows on the keyboard to pan
around your drawing.
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5.

Position the cursor near the upper-right corner of the room that is in the lower-right corner of the
plan and click the middle mouse button. This is the insertion point and the center of rotation for
the symbol. If you move your cursor slightly up or down, you will see the boxed outline rotate
around the insertion point.

6.

Position the cursor near the lower-right corner of the bathroom and click the middle mouse
button. The toilet with grab bars is drawn. If you place the toilet incorrectly, click on Undo Place
Symbol in the Edit pull-down menu to delete it and then place the toilet again.
5
Click the middle mouse button to
define the insertion point.

6
Move the cursor down and to the right away
fromthe insertion point, and click the middle
mouse button to set the symbol into place.

Figure 4.20: Placing the toilet on your plan
7.

Right-click to cancel the toilet symbol.

Figure 4.21: The toilet and grab bars are placed on the drawing
8.

Move the cursor over the WALL-HUNG SINK (probably the top left symbol in the Symbol
Browser toolbar) and click on it to select it.

9.

Move the cursor into the Drawing Area. A boxed outline representing the sink is now attached to
your cursor. The insertion point for this symbol is in the back center of the sink.

10. Position the cursor at the center point, between the window and hallway wall, as shown in Figure
4.22. Click the middle mouse button.
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10
Click the middle mouse
button to define the
insertion point for the sink.

Figure 4.22: Placing the sink in your drawing
11. Rotate the symbol by dragging the cursor away from the insertion point and clicking when it is in
place. The sink is drawn. If you place the sink incorrectly, click on Undo Place Symbol in the Edit
pull-down menu to delete it and then place the sink again.

Figure 4.23: The sink is drawn
12. Right-click to cancel the sink symbol.
13. Press (Ctrl) + (S) to save the drawing.

Selecting Another Symbol File
 To select another symbol file:
1.

Click on
in the Symbol Browser toolbar and select Folder from the drop-down menu. The
Browse dialog box appears so that you can select another symbol folder.

2.

Double-click on the Kitchen folder to view a list of Kitchen subfolders.

3.

Click on Equipment folder in the Browse dialog box and click on OK. The kitchen equipment
symbols appear in the Symbol Browser toolbar.

4.

Select the bar sink (upper left in the Symbol Browser toolbar) and place it as shown in the figure
below. Refer to the previous section if you need help placing this sink.
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Place the kitchen sink, and
rotate into place.

Figure 4.24: The kitchen sink is drawn
5.

Right-click to go to the Edit menu.

Copying Symbols
 To copy symbols:
1.

Click on Copy in the Edit menu in the Menu Window. You are prompted to Select first point of the
distance to copy.

2.

Move the cursor to the upper-right corner of the bathroom you just placed fixtures in and click
the middle mouse button to define the first point to copy from. You are prompted to Select second
point of distance to copy.

3.

Move the cursor to the upper-right corner of the room directly above the bathroom and click the
middle mouse button. The distance and angle you just defined appear in the Attention toolbar.
3
Click the middle mouse button to define
the second point of distance to copy
from.

2
Click the middle mouse button to
define the first point of distance to
copy from.

Figure 4.25: Defining a distance to copy
4.

Click on Area if it’s not already active. You are prompted to Select first corner of area to <COPY>.

5.

Click on Layer Search to toggle layer searching off and search only the active layer for items to
copy.

6.

Click at the lower left of the bathroom sink. You are prompted to Select second corner of area to
<COPY>.

7.

Drag the mouse diagonally to the upper right of the toilet and grab bars, until the area box
encloses all bathroom fixtures and their insertion points.

8.

Click to close the box. The sink, toilet, and grab bars are copied into the other bathroom.
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8
Click the left mouse button to close the
area box.

6
Click the left mouse button to start the
area box.

Figure 4.26: Selecting the bathroom fixtures to copy

9.

Click on

to recalculate the extents of the drawing.

Figure 4.27: The bathroom fixtures are copied to the other bathroom
10. Right-click to return to the Edit menu.
11. Press (Ctrl) + (S) to save the drawing.

Drawing a Title Block and Border
To complete the schoolhouse plan, you will create a simple border that will plot with the floor plan. The
paper size will be 8 1/2” x 11”.
 To draw a title block and border:
1.

Press (Tab) until Border is the active layer in the Status Panel toolbar.

2.

Press (=) to toggle the Walls option off. Note the w in SwOTHLUDFB in the Status Panel toolbar is
now lowercase.

3.

Click on Polygons in the Edit menu in the Menu Window.

4.

Click on Rectangle to draw a rectangle.

5.

Move the cursor to the lower-left corner of the drawing where you want the border to start and
click. If necessary, press (PageUp) once to zoom out and give yourself more space to work
around your drawing.
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5
Click the left mouse button to define the first
corner of the border.

Figure 4.28: Creating a border
6.

Press (Insert) until the prompt in the Attention toolbar reads Current input mode = relative Cartesian
(x, y).

7.

Press (Spacebar). You are prompted to Enter relative X-distance.

8.

Type 80 and press (Enter). You are prompted to Enter relative Y-distance.

9.

Type 60 and press (Enter). The border is drawn.

10. Right-click to return to the Edit menu.
11. Click on

to view the extents of the drawing.

Moving the Border
 To move the border:
1.

Click on Move in the Edit Menu.

2.

Click on Drag.

3.

Click on Group. You are prompted to Select group to <MOVE>.

4.

Move the cursor to the center of the rectangle you just created and click the middle mouse button.
The rectangle appears in dashed lines to indicate its selection. You are prompted to Select the point
to drag from.

5.

With the cursor still at the center of the rectangle, click the middle mouse button. Notice that you
can now move the border by moving the mouse.

6.

Press (O) to turn off ortho mode. This allows free movement when you place the border. Note the
“o” in SwoTHLUDFB in the Status Panel toolbar is now lowercase.
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7.

Use (PageUp) or (PageDown) for a better view if you need to, then move the border over the floor
plan so the plan appears centered within it.

8.

Click to set the border into place.

9.

Right-click twice to return to the Edit menu.

10. Click on

to recalculate the extents of the drawing.

PLASTIC LAMINATE COUNTERTOP
3 6 ” ABOVE FINISHED FLOOR W ITH
CALL BAM.NET (BAM RULES!)

Figure 4.29: The border is placed

Drawing a Title Block
 To draw a title block:
1.

Click on Copy in the Edit menu. You are prompted to Select first point of the distance to copy.

2.

Move the cursor to the lower right corner of the border and click the middle mouse button. You
are prompted to Select second point of the distance to copy.

3.

Press (Spacebar). You are prompted to Enter relative X-distance.

4.

Type -5 and press (Enter). You are prompted to Enter relative Y-distance.

5.

Type 0 and press (Enter). The distance and angle to copy appear in the Attention toolbar.

6.

Click on Entity in the Menu Window. You are prompted to Select entity to <COPY>.

7.

Select the right vertical line of the border by clicking on it. The line is copied.

8.

Right-click to return to the Edit menu.

9.

Press (`) to set a new reference point.

10. Move the cursor to the lower right outside corner of the border and click the middle mouse
button to set a new reference point.
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7
Click the left
mouse button to
copy this line.

PLASTIC LAMINATE
COUNTERTOP
36” ABOVE FINISHED FLOOR
WITH ADJUSTABLE SHELVES
BELOW

10
Click the middle
mouse button to
set a new
reference point.

Figure 4.30: Completing the title block
11. Press (Spacebar). You are prompted to Enter relative X-distance.
12. Type 0 and press (Enter). You are prompted to Enter relative Y-distance.
13. Type 5 and press (Enter). You connect to a point on the right line of the border.
14. Press (Spacebar). You are prompted to Enter relative X-distance.
15. Type -5 and press (Enter). You are prompted to Enter relative Y-distance.
16. Type 0 and press (Enter). A line is drawn.
17. Right-click to disconnect from the line and return to the Edit menu.
18. Click on Move in the Edit menu.
19. Click on Drag.
20. Click on And Copy. You are prompted to Select entity to <MOVE>.
21. Select the line you just drew by clicking on it. The line becomes dashed. You are prompted to
Select the point to drag from.
22. Select an endpoint of the dashed line with the middle mouse button.
23. Press (O) to toggle ortho mode on.
24. Move the cursor upwards and click to place the line in a few different locations to section off the
title block, as in Figure 4.31.
25. Right-click three times to return to the Edit menu. The title block is drawn.
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PLASTIC LAMINATE COUNTERTOP
3 6 ” ABOVE FINISHED FLOOR W ITH
ADJUSTABLE SHELVES BELOW

Figure 4.31: The drawing with title block
26. Press (Ctrl) + (S) to save the drawing.

Chapter 5 Tutorial: Printing a
Drawing
DataCAD has many options available for plotting or printing
your drawing. This chapter will focus on printing your plan on
an 8 1/2” x 11” sheet of paper.

5

In this chapter:
 Printing the

schoolhouse
drawing

 Setting printing
options
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Printing the Schoolhouse Drawing
If you are not in DataCAD, start DataCAD now. Choose the drawing you worked on in the previous
tutorials. Before plotting the schoolhouse floor plan, make sure:


a printer or plotter is either connected to your computer or available via a network connection



the printer or plotter is turned on and is online or ready to receive data



you have the corresponding Windows driver for your printer installed on your computer (see your
printer’s manual for more information about installing a printer driver)

 To plot the schoolhouse:
1.

Choose Print from the File pull-down menu in the Menu Bar or choose Print/Plot from the Utility
menu in the Menu Window. The following message appears:

Since this is the first time you’ve printed this drawing, DataCAD requires you to choose a printer,
paper size, and orientation before you assign pens, complete a print layout, and plot your
drawing. To accept the default settings, click OK and skip to step 5; otherwise, continue with step
2 below.

Prints the current drawing

Accesses the Pen Table dialog box

Calls up a multi-scale plotting sheet
Accesses the Printer/Plotter Settings dialog box

Figure 5.1: The Print/Plot menu
2.

Choose a printer from the Printer Name drop-down box in the Printer/Plotter Settings dialog box.

3.

Choose a paper size. The sizes available are read from your printer driver. If a size you want is
not displayed in the drop-down box, your printer may not support it. Choose the closest
appropriate size, or use the User-Defined option if available, or use a different printer.
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4.

Click OK to close the Settings dialog box. The Print/Plot menu appears. You can exit DataCAD
and open the printer driver to see the supported paper sizes. Many times, the default settings of
the driver do not include all supported sizes. You must check them to activate them.

Figure 5.2: The Printer/Plotter Settings dialog box
5.

Choose Scale to set the plotting scale. The current plotting scale appears in the Message Window.

6.

Choose 1/8” if it’s not already the current plotting scale.

7.

Choose Quick Layout from the Print/Plot menu. A dashed box appears representing the 8 1/2” x
11” sheet. If you move the cursor over the Drawing Window, you will find a movable copy of this
box. You are prompted to Locate sheet of paper using cursor, “ENTER” to end.

8.

Center the box over the drawing and click the middle mouse button. This object snaps to the
center of the title block (the centered point of the rectangle) and centers the title block. You can
also move the box anywhere you want and click with the left mouse button.

9.

Choose Print/Plot to see a preview copy of the plot.

10. Click on Plot to send the drawing directly to the plotter or printer. The schoolhouse floor plan is
plotted.

Printing Options
There are many printing options that help you get the plotted output you want. In the next set of
exercises, you will use a few of the images that were created in this book to build a plot that contains
multiple drawings. Each drawing added to the plot can be set to a different scale.
Assigning Pens
Use Pen Assignments in the Pen Table dialog box to set a hierarchy of line weights, which help add line
definition to your drawings. For example, if your walls were a heavier line weight than your doors and
windows, the door and window openings would appear clearer. This difference in line weight helps
define the content of your drawing.
 To set the pens for printing the schoolhouse drawing:
1.

Choose Print/Plot.
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2.

Choose Pen Table to open the Pen Table dialog box. In the Pen Assignments section, you will
assign pen numbers to match the colors used in the drawing. You’ll notice that the first color in
the Pen Assignments list box is highlighted.
The Pen Table dialog box also includes a Pen Settings section that allows you to choose the pen
width, color, and color density for each pen you assigned in the Pen Assignments portion of the
dialog box. See “Using Pen Tables” in the “Printing Your Drawing” chapter for detailed
information on using the Pen Table.

Figure 5.3: The Pen Table dialog box
3.

Select White in the Pen Assignments box if it’s not already highlighted. Notice that just below this
list box is a small box displaying the highlighted color, followed by a number in a small input
box. This number is the pen that will be used to plot all white lines in your drawing.

4.

Type 1 in the input box. The color white is now set for pen number 1.

5.

Select Red in the Pen Assignments box or press (Down Arrow) to highlight Red.

6.

Type 3 in the input box. The color red is now set for pen number 3.

7.

Set the remainder of the colors: for Green use pen 1, for Cyan use 3, for Magenta use 3, for Brown
use 4, for Lt. Grey use 4, for Lt. Red use 2, for Lt. Green use 3, and for Yellow use 2.

8.

Click OK to save the pen assignments and close the Pen Table dialog box.

9.

Right-click to return to the Utility menu.
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(Pro) Using Multi-scale Plotting
The GoTo View menu will help you automate the viewing process which, in turn, is used with multiscale plotting to place differently scaled details on the same sheet. You can choose GoTo View in the
Utility menu, in the 3D Views menu, or from the View pull-down menu to assign an unlimited number of
views. Each view can have its own set of assigned layers. For example, in this schoolhouse tutorial, there
are 14 different layers. If you want to view only the Walls, Doors, and Windows layers, you can create a
view using GoToView with only these three layers visible. When you choose that view, all layers except
Walls, Doors, and Windows will automatically be toggled off. Choose another predefined view to turn on
a different set of layers. Using GoTo View, you can quickly change your view and continue working.
The GoTo View option is a helpful when you have a drawing that contains floor plans, elevations,
sections, and 3D models. In the following steps, you will establish two views, which help complete the
remainder of this schoolhouse project.
 To create views:
1.

Choose Plan from the View pull-down menu for plan view.

2.

Recalculate the extents of the drawing.

3.

Choose GoTo View from the View pull-down menu.

4.

Choose Add View. You are prompted: Enter name of new view?

5.

Name the view 3DPlan.

6.

Toggle the Doors, Windows, Plumb, Dim, Hatch, and Notes layers on.

7.

Toggle 3DWalls, 3DWindow, 3DDoors, 3DRoof, and 3DMisc layers off.

8.

Recalculate the extents of the drawing.

9.

Choose GoToView from the View pull-down menu.

10. Choose Add View. You are prompted: Enter name of new view?
11. Name the view 2DPlan.
When you need to switch between 3D layers and 2D layers, use the GoTo View menu. In the next section,
you will use the views you just set.
 To use multi-scale plotting:
1.

Press (L) to go to the Layers menu.

2.

Make Border the only active layer using Active Only from the Layers menu.

3.

Recalculate the extents of the drawing by clicking on
on the Navigation Pad toolbar or by
choosing Zoom to Extents from the View pull-down menu in the Menu Bar.

4.

Right-click to return to the Utility menu.

5.

Choose Print/Plot.

6.

Choose Multi-layout.

7.

Choose Layout. The drawing appears as a box attached to the cursor; the dashed box represents
the 8 1/2” x 11” sheet. You are prompted to Locate detail on sheet of paper, “ENTER” to end.

8.

Center the drawing in the dashed box and click to set the title block in place. You are prompted:
Enter name of new detail: Detail 1.

9.

Type Titleblk and press (Enter).
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10. Right-click twice to return to the Utility menu.
11. Choose GoTo View.
12. Choose 2DPlan. Right-click once.
13. Recalculate the extents of the drawing by clicking on
on the Navigation Pad toolbar or by
choosing Zoom to Extents from the View pull-down menu in the Menu Bar.
14. Choose Print/Plot from the Utility menu.
15. Choose Multi-layout.
16. Choose Layout. The drawing appears as a box attached to the cursor; the dashed box represents
the 8 1/2” x 11” sheet. You are prompted: Locate detail on sheet of paper, “ENTER” to end.
17. Center the drawing over the dashed box and click the left mouse button to position the plan. You
are prompted: Enter name of new detail: detail 2.
18. Type Plan and press (Enter).
19. Right-click out of the Plotter menu. Then adjust the layer settings to show layers relevant to the
Front Elevation view.
20. Recalculate the extents of the drawing by clicking on
on the Navigation Pad toolbar or by
choosing Zoom to Extents from the View pull-down menu in the Menu Bar.
21. Create a new GoTo View and name it FrntElev.
22. Choose Print/Plot from the Utility menu.
23. Choose Scale to change the scale factor.
24. Choose 1/16”.
25. Choose Multi-layout.
26. Choose Layout. The drawing appears as a box attached to the cursor; the dashed box represents
the 8 1/2” x 11” sheet. You are prompted: Locate detail on sheet of paper, “ENTER” to end.
27. Move the drawing into the upper-right quarter of the dashed box. Click to set the elevation in
place. You are prompted: Enter name of new detail: Detail 3.
28. Type FrntElev and press (Enter).
29. Recalculate the extents of the drawing by clicking on
on the Navigation Pad toolbar or by
choosing Zoom to Extents from the View pull-down menu in the Menu Bar.
30. Make Walls the only active layer.
31. Choose Print/Plot from the Utility menu.
32. Choose Scale to change the scale factor. You can press (PgUp) and (PgDn) to change the scale of
any detail on-the-fly before you place it on the sheet.
33. Choose 1:20.
34. Choose Multi-layout.
35. Choose Layout. The drawing appears as a box attached to the cursor and the dashed box that
appears representing the 8 1/2” x 11” sheet. You are prompted: Locate detail on sheet of paper,
“ENTER” to end.
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36. Move the drawing into the lower-right quarter of the dashed box. Click to set the perspective in
place.
37. Add a new detail named Walls.
38. Return to the Print/Plot main menu.
39. Choose Print/Plot to send the drawing directly to the plotter.
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Chapter 6 Tutorial: Modeling
This chapter guides you through some of the more commonly
used macros to help you complete the schoolhouse. In order to
keep this exercise simple and to help you understand a little
about 3D spatial relationships, you will work in orthographic
(plan) view and then use the 3D Views menu to view your work.

In this chapter:

 Adding 3D windows
and doors

 Adding a roof
 Viewing the model in
3D
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Modeling the Schoolhouse
You will create five new layers for the 3D items that you are going to add to the drawing. This enables
your drawing file to contain both your plan drawings (used for construction documentation) and 3D
drawings (used to present your designs).
If you are not in DataCAD, start DataCAD now.
 To add layers to your drawing:
1.

Choose the drawing file that you worked on in the previous chapters.

2.

Add five new layers to your drawing file.

3.

Name the new layers: 3DWalls, 3DDoors, 3DWindows, 3DRoof, and 3DMisc.

4.

Go to the Layers menu.

5.

Turn off Doors, Windows, Plumb, Dim, Hatch, Notes, Misc, and Border.

6.

Press (Esc) on the keyboard to refresh the drawing display.

7.

Zoom in on the lower half of the plan.

Adding Windows
You will work with the walls, doors, and windows that you have already placed in your drawing. Do not
erase them; they are an essential part of your drawing file.
 To add windows:
1.

Make the 3DWindows layer the active layer.

2.

Click on the Toolbox pull-down menu. If AEC_MODL is not one of the options, click on
Configure, click on AEC_MODL, click on Add. This makes the AEC_MODL macro appear in the
Toolbox pull-down menu. Click on OK to close the Configure DataCAD for Windows Settings
dialog.

3.

Choose AEC_MODL from the Toolbox pull-down menu. You are prompted to Select building
component to model.

4.

Choose Windows to go to the WindPlan menu.

5.

Choose In Plan to draw the windows in plan view.

6.

Choose UnitType. You are prompted to Select type of window unit.

7.

Choose DblHung to draw double-hung windows.

8.

Return to the WindPlan menu.

9.

Choose Glass to go to the Glass menu.

10. Choose PaneHorz to define the number of glass panes (divisions) across the window. You are
prompted to supply the Number of panes in the horizontal direction.
11. Choose 3.
12. Choose PaneVert to define the number of glass panes top to bottom in the window. You are
prompted to supply the Number of panes in the vertical direction.
13. Choose 2.
14. Return to the WindPlan menu. You are prompted to Enter a point on first inside corner of window.
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15. Click the middle mouse button on an inside corner of the front window opening in the office. You
are prompted to Enter a point on second inside corner of window.
16. Click the middle mouse button the other inside corner of the window opening. You are prompted
to Enter a point on outside surface of wall.
17. Click the middle mouse button on the outside of the wall. The window is created.
15
Click the middle mouse
button to define the first
inside corner of the
window.

16
Click the middle mouse
button to define the other
inside corner of the window.

17
Click the middle mouse
button to define the
outside corner of the
window.

Figure 6.1: Placing windows
18. Repeat steps 15 - 17 to create the remaining windows. Remember that you can use the arrow keys
on the keyboard to move around the drawing.

Figure 6.2: The 3D windows are drawn.
19. When you are finished placing windows, return to the AEC_MODL menu.

Adding 3D Doors
 To add doors:
1.

Make 3DDoors the active layer.

2.

Choose Doors from the AEC_MODL menu to go to the DoorPlan menu. You are prompted to
Enter a point on first inside corner of door.

3.

Move the cursor to an inside corner of the door opening in the office and click the middle mouse
button. You are prompted to Enter a point on second inside corner of door.

4.

Move the cursor to the other inside corner of the door and click the middle mouse button. You are
prompted to Enter a point on outside surface of wall.

5.

Move the cursor to the outside corner of the wall and click the middle mouse button. The first
door is created.
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6.

Choose Door. You are prompted to Select door data to change.

7.

Choose HingLft to change the hinge side of the front door to the left side.

8.

Return to the DoorPlan menu.

9.

Repeat steps 3 - 5 for the remaining doors.
3
Click the middle mouse
button to define the first
inside corner of the door.

4
Click the middle mouse
button to define the other
inside corner of the door.

5
Click the middle mouse
button to define the
outside surface of the
wall.

Figure 6.3: Placing the first door
10. Return to the Edit menu.
11. Recalculate the extents of the drawing.

Figure 6.4: The doors are drawn.
There are many other options you can use when placing doors and windows.

Viewing the 3D Model
Choose Isometric from the View menu on the Menu Bar. You will learn more viewing techniques later in
this chapter.
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Figure 6.5: An isometric view of the schoolhouse walls, windows, and doors

Adding a 3D Roof
As mentioned throughout this book, layers allow you more control over your drawing. Later in this
section of the Tutorial you will use these different layers to switch between viewing construction plans
and presentation graphics.
 To add a roof:
1.

Change to the 3DRoof layer.

2.

Change the color of the 3DRoof layer to Magenta.

3.

Click on the Toolbox pull-down menu. If ROOFIT is not one of the available options, click on
Configure, add it to the list of available macros, and close the dialog box.

4.

Choose ROOFIT from the Toolbox pull-down menu to go to the RoofIt menu.

5.

Choose Gable to create a gable roof.

6.

Choose Settings.

7.

Set the wall thickness to 1 foot.

8.

Return to the RoofIt menu. You are prompted to Pick the 1st point of roof boundary. It is important
to select the points of the roof boundary in a clockwise direction to ensure that the roof will be
placed correctly.

9.

Select the lower-left corner of the exterior wall with the middle mouse button. You are prompted:
Enter second point of roof length.

10. Select the upper-left corner of the exterior wall with the middle mouse button. You are prompted:
Enter second point of roof width.
11. Select the upper-right corner of the exterior wall with the middle mouse button. The roof appears
on top of the walls.
12. Return to the Edit menu.
13. Choose Isometric from the View menu on the Menu Bar to view the drawing in isometric.
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Figure 6.6: An isometric view of the schoolhouse with the new roof

Finishing the Schoolhouse Drawing
Notice that in the isometric view, portions of the wall above and below the windows are missing. You
will fix them in the next exercise, but these wall segments are going to be put on a different layer than the
existing Walls layer. Later in this chapter, you will see the reason for having two wall layers.
 To finish the drawing:
1.

Choose Plan from the View pull-down menu or click on
the schoolhouse in plan view.

in the Projection Pad toolbar to see

2.

Choose Layers from the Utility menu in the Menu Window.

3.

Make 3DWalls the active layer, with only the Walls layer turned on. All other layers should be off.

4.

Change the 3DWalls layer color to yellow.

5.

Go to the Architect menu and toggle the Walls option on.

6.

Toggle the 2-line wall option on.

7.

Set a new wall width of 1 foot.

8.

Toggle Outside on.

9.

Toggle Cap off, if it is on.

10. Press (Z) on the keyboard. You are prompted to Enter new Z-base.
11. Type 0 and press (Enter). You are prompted to Enter new Z-height.
12. Type 3.4 and press (Enter). You have just established a new 3D setting for all new items you
draw. All lines will now be drawn with a Z-base of 0 and a Z-height of 3’-4”.
13. Zoom in on the lower half of the plan.
14. Return to the Edit menu. You are prompted to Select first endpoint of new line/wall.
15. Move the cursor to an outside corner of the window opening in the office and click the middle
mouse button. You are prompted: Select next endpoint of line/wall.
16. Move the cursor to the other outside corner of the window and click the middle mouse button.
You are prompted: Select a point to define the Inside of the wall.
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17. Move the cursor anywhere on the inside of the plan and click. The cutout is filled.
18. Right-click to disconnect from the wall you just drew.
19. Repeat steps 15 - 18 for the remaining exterior window openings. Be sure to disconnect from each
wall segment you draw, before drawing the next. Remember to use the arrow keys on the
keyboard to move around the drawing.
20. Press (Z) on the keyboard. You are prompted to Enter new Z-base.
21. Type 6.8 and press (Enter). You are prompted to Enter new Z-height.
22. Type 8 and press (Enter). You have just established a new 3D setting for all new items you draw.
All lines will now be drawn with a Z-base of 6.8 and a Z-height of 8’-0”.
17
Click the first mouse
button to define the inside
of the wall.

16
Click the middle mouse
button to define the next end
point of the new wall.

15
Click the middle mouse
button to define the first
end point of the new wall.

Figure 6.7: Placing headers and sills
23. Repeat steps 15 - 18 to fill in over top of the sills to create window headers. You are prompted to
Select first endpoint of new line/wall.
24. Click the middle mouse button at the outside corner of the front door opening. You are prompted
to Select next endpoint of line/wall.
25. Move the cursor to the other outside corner of the door and click the middle mouse button. You
are prompted to Select a point to define the Inside of the wall.
26. Move the cursor anywhere on the interior of the plan and click. The door header is drawn.
27. Press (=) on the keyboard. The Attention toolbar reads Walls will NOT be drawn.
28. Press (=) again. You are prompted to Enter new wall width.
29. Type .4 and press (Enter). You are now set to draw the headers above the interior doors.
30. Move the cursor to an outside corner of the interior door opening in the office.
31. Repeat steps 24 - 26 to complete this header and the remaining interior headers.
32. Choose Isometric from the View pull-down menu on the Menu Bar to see the isometric view.
33. Toggle the 3DDoors, 3DWindow, and 3DRoof layers on.
34. Return to the Utility menu.
35. Recalculate the extents of the drawing.
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Viewing Your Drawing in 3D
Perhaps one of the most exciting features of DataCAD is that everything you draw has 3D parameters.
 To change your view:
1.

Choose 3D Menus from the Edit menu and click on 3D Views to go to the 3D Views menu.

2.

Choose Isometric. If your drawing is not centered choose
The lines that you drew earlier now appear in 3D.

3.

Return to the Edit menu.

4.

Choose Plan from the View pull-down menu in the Menu Bar to view your drawing in plan view.

5.

Choose Isometric to view the isometric view.

6.

Choose Plan to view your drawing again in plan view. Switching between 2D and 3D helps you
better understand what you are drawing.

7.

Press (Ctrl) + (S) on the keyboard to save the drawing.

from the Navigation Pad toolbar.

Advanced 3D Viewing
Throughout this tutorial, you moved around the drawing using a few of DataCAD’s different viewing
methods. One of the most exciting features of DataCAD is viewing your work in 3D. This section steps
you through a few viewing exercises of 2D (orthographic or plan) and 3D.
 To use advanced viewing techniques:
1.

Choose GoTo View from the Utility menu.

2.

Choose 3D Menus and then click on 3D Views.
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Figure 6.8: The View pull-down menu
Each time you start a new drawing, the Parallel and Perspective options in the 3D Views menu do not do
anything. They become active after you set the viewing parameters for each button. When you selected
Isometric when working with hatch earlier in the tutorial, you could choose Plan and Parallel and view
3D Views. If you chose Perspective, nothing happened.
Perspective Viewing
 To create a perspective view:
1.

Press (PageUp) twice to zoom out.

2.

Choose Set Persp. from the 3D Views menu. You are prompted to Select position of eye point for
perspective view.

3.

Click at the lower left corner of the screen. A perspective view of the schoolhouse appears.
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Figure 6.9: A perspective view of the completed schoolhouse drawing
4.

Choose Walk Through from the 3D Views menu. This displays a menu used for moving around
the 3D model. You can also use the Viewer toolbar (select Toolbars from the View pull-down
menu, then make sure Viewer is checked in the Toolbars dialog box) to display options for
walking through perspective views.

5.

Choose Walk Back. You just stepped away from the model.

6.

Experiment with a few of the other options in this menu.

7.

Exit the 3D menu and choose Plan from the View pull-down menu on the Menu Bar to view the
drawing in plan.

8.

Choose Perspective from the View pull-down menu on the Menu Bar to view the perspective
again.

9.

Choose Isometric from the View pull-down menu on the Menu Bar to view the isometric.

10. Choose Plan from the View pull-down toolbar to view the plan view again.
Once you establish the viewing options, all of these options display a different image of the drawing. This
is an easy way to change the view of a drawing during any stage of a project.
Hidden Line Removal
As you become more experienced with DataCAD, you will be adding more complex 3D elements to the
drawing. The more you add to a drawing, the harder it can be to understand a 3D view. The Hide option
in the 3D Menus menu is used to hide the lines in your model that would not be visible if it were an
actual building. This 3D view can be saved as a layer and edited.
 To hide lines in your model:
1.

Choose 3D Menus from the Edit menu to enter DataCAD’s 3D menus: 3D Menus, 3D Views, and
3D Entity.

2.

Choose Perspective from the View pull-down menu on the Menu Bar to display the perspective
of the schoolhouse.

3.

Choose Hide.

4.

Choose Begin. The hidden line removal generates a new image without most of the unwanted
lines.

5.

Wait until the hidden line removal is finished, then choose New Layer. You are prompted to Enter
name of new layer to be added.
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6.

Type Hide1 and press (Enter). You are asked Do you want the new layer ON or OFF?

7.

Choose Off. You will toggle this layer on later in the chapter. The hidden line removal is complete
and you have added a new layer to the drawing.

8.

Choose Plan from the View pull-down menu to see the schoolhouse in plan view.

9.

Choose Layers from the 3D Menus

10. Select Active Only from the Layers menu.
11. Choose Hide1. You’ll notice that there are still a few lines visible that should not be there, such as
the vertical lines above and below windows and doors. You can erase these lines from this view
without adversely affecting your drawing.
12. Choose Erase from the 3D Menus menu.
13. Choose Entity as the selection method for erasing lines.
14. Use your mouse to select any lines on the perspective that should not be there.
15. Return to the Utility menu. If you choose Perspective from the View pull-down menu on the
Menu Bar, you will see that the image is flat. This is because the hidden line removal created a
flat line drawing from the perspective. This drawing has no connection to the original 3D model.

Figure 6.10: The perspective view after a hidden line removal
16. Choose GoTo View.
17. Choose 3DPlan.
18. Choose Plan to see the schoolhouse in plan view.

Creating Elevations
This section shows you how to create elevations from the work you have already completed. You will use
the same procedure discussed in the Hide section for creating your elevations.
 To create elevations:
1.

Choose Elevation from the View pull-down menu; then select Front to display the front elevation
of the schoolhouse. Alternatively, click on

2.

Recalculate the extents of the drawing.

in the Projection Pad toolbar
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Figure 6.11: The front elevation of the schoolhouse
3.

Choose 3D Menus from the Edit menu.

4.

Choose Hide.

5.

Choose Begin. The hidden line removal process generates a new image with everything behind
the front wall not shown.

Figure 6.12: The elevation after a hidden line removal
6.

Wait until the hidden line removal is completed. Then choose New Layer. You are prompted to
Enter name of new layer to be added.

7.

Type FrntElev and press (Enter). You are asked Do you want the new layer ON or OFF?

8.

Choose Off. You will turn this layer on later in the tutorial. The hidden line removal is complete
and a new layer has been added to the drawing.

9.

Choose Plan from the View pull-down menu.

10. Choose 2D Menus to return to the Edit menu.
11. Choose Layers from the Utility menu.
12. Choose Active Only. You are prompted to Select layer to be the only layer on.
13. Choose Scroll Fwrd to view the end of the layer list.
14. Choose Elevation/Front from the View pull-down menu to display the schoolhouse front
elevation.
15. Return to the Edit menu.
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16. Recalculate the extents of the drawing.
17. Choose Erase from the Edit menu.
18. Choose Entity as the selection method for erasing lines.
19. Select any lines on the front elevation that should not be there.
20. Return to the Utility menu.
Experiment with a few symbols, hatch patterns, etc.

Figure 6.13: The schoolhouse elevation with symbols and hatch
This completes the DataCAD Tutorial. For additional instruction, please contact DATACAD LLC for
information on training materials and support options or visit us online at www.datacad.com.
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Chapter 7 Before You Draw
There are many settings that you can use to customize how
you’ll draw in DataCAD. You can keep track of time spent on a
drawing and enter other administrative information directly into
the drawing. The Settings menu has a variety of options to
customize your work session, including setting scale and angle
types, creating drawing passwords, setting cursor accuracy,
adjusting the time delay for creating autosave files, and editing
the definitions of DataCAD’s scale, angle, and distance lists.

In this chapter:

You can also set the size and angle of both the snap grid and the
two display grids and choose whether the display grids are
visible. And, perhaps most importantly, you can create and
name new layers for your drawing, choose which of these will
be displayed, assign different colors for each, and even save
them to a separate file.

 Setting the active

All of these settings can be used with default drawings to
increase efficiency and save time. First, create a new drawing
file; then change the settings, grids, and layers as you’d like them
to be set in all your new DataCAD drawings; and finally, save
the file in your default drawing folder. (See “The Drawing
Board” chapter for more information about using default
drawings.) Then in the Tools/Program Preferences Configure
DataCAD for Windows Settings dialog box, set the Default
Drawing File option to your new default drawing. All of your
customized settings will automatically be set in every new
drawing you create --- simply start drawing!

 Setting the snap grid
 Setting the display
grids

 Creating and

naming new layers

 Moving between
layers
layer

 Assigning colors to
layers

 Entering project

costing information

 Selecting the scale

type and angle type

 Creating passwords
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Managing Your Project
The Project Directory provides the basis for a comprehensive management system based on actual
computer usage and application. You can use Directory to review and enter project information directly
into the drawing file. You can also save the project information and time data to a text file and even purge
unused symbol information from your drawing. Simply click on Directory in the Utility menu in the
Menu Window or click on Directory in the Tools pull-down menu in the Menu Bar to display the
Directory dialog box. Even if you delete a symbol from your drawing, the symbol’s name will still be
listed in the Directory. To purge the names of all unused symbols from your drawing, click on Purge
Symbols in the Directory dialog box.
In the Billing Rate, Department Number, Phase Number, and Service Number text input boxes, you can
enter a number from 0 to 32,000. In the Project text input box, you can enter up to nine alpha-numeric
characters; in the Employee text input box, you can enter up to seven alpha-numeric characters.

Figure 7.1: The Drawing Information dialog box

Setting Up Your Drawing Grids
There are three separate grids in DataCAD: a snap grid and two display grids. The snap grid controls
cursor movement while drawing. The two display grids, used primarily for visual reference while
drawing, are shown as a series of dots and help you create drawings quickly and accurately. Each layer in
DataCAD has its own snap and display grids as well as grid origin and sizes. This lets you move quickly
between layers without having to change grid sizes or toggle grids on or off.

Using the Snap Grid
Although the snap grid doesn’t display in the Drawing Area, it helps you draw more precisely. The snap
grid causes the cursor to jump (or snap) from one point of the snap grid to the next as you move the
mouse across the Drawing Area. See “Changing Grid Size,” “Setting the Snap Angle,” and “Setting the
Grid Angle” later in this chapter for more information about the snap grid.
Look at the X and Y coordinate display in the Coordinates/Hints toolbar to see the exact coordinates of
the cursor as you move it over the Drawing Area. With the snap grid toggled on, notice the coordinate
display reflects the cursor’s “jumps” from one invisible snap point to the next across the snap grid. When
you toggle the snap grid off, the cursor advances freely across the Drawing Area, without snapping to
grid points.
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 To toggle the snap grid on or off:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.
Shortcut: Press (G) or (Shift) + (G) to access the Grids menu.

2.

Click on Grid Snap.
Shortcut: Press (X) to toggle the snap grid on or off. Note that the “S” in SWOTHLUDFB in the
Status Panel toolbar appears in lowercase when snap grid is toggled off and uppercase when it’s
toggle on.

Using the Display Grids
There are two display grids in DataCAD. One is a series of white dots in the Drawing Area, while the
second display grid is a series of small yellow crosses. These grids are visual aids only and can’t be
printed. The display grid colors are white and yellow by default. However, you can change these colors;
see “Changing Display Grid Color” later in this chapter.
 To toggle display grid 1 on or off:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Disp. Grid 1.
Shortcut: Press ([) to toggle Disp. Grid 1 on and off.

 To toggle display grid 2 on or off:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Disp. Grid 2.
Shortcut: Press (]) to toggle Disp. Grid 2 on and off.

Changing Grid Size
The snap grid’s default setting is 4”, display grid 1’s is 4’-0”, and display grid 2’s is 16’-0”. You can
change any or all of these grid sizes for each layer in your drawing. To change a grid size for another
layer, simply change the active layer before following the step-by-step instructions in the next paragraph.
 To set the snap grid’s size for the active layer:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Grid Size in the Grids menu. The Grid Size menu appears.

3.

Click on Set Snap in the Grid Size menu. A value menu appears.

3.

Use the value menu to select a new value or click Custom; type a new snap grid value and press
(Enter).
Shortcut: Press (S) to set the snap grid size.

 To set display grid 1’s size for the active layer:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Grid Size in the Grids menu. The Grid Size menu appears.

3.

Click on Set Grid 1 in the Grid Size menu. A value menu appears.

4.

Use the value menu to select a new value, type a new display grid value, and press (Enter). For
more information on using value menus, see “Value Menus” in “The Drawing Board” chapter.
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 To set the display grid 2’s size for the active layer:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Grid Size in the Grids menu. The Grid Size menu appears.

3.

Click on Set Grid 2 in the Grid Size menu. A value menu appears.

4.

Use the value menu to select a new value or click Custom; type a new display grid value and
press (Enter).

You can use the Custom option to enter a new value for any of these grid settings. For more information
on how to use the Custom option, see “Value Menus” in “The Drawing Board” chapter.

Changing Display Grid Color
You can change the color of both of the display grids; however, this setting is global, meaning the colors
will change on every layer in your drawing. You can’t set separate grid colors on each layer.
 To change the color of display grid 1:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Grid Color in the Grids menu. The Grid Color menu appears.

3.

Click on Set Grid 1 in the Grid Color menu. A color menu appears.

4.

Choose a new color from the Grid Color menu. For more information on using color menus, see
“Color Menus” in “The Drawing Board” chapter.

 To change the color of display grid 2:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Grid Color in the Grids menu. The Grid Color menu appears.

3.

Click on Set Grid 2 in the Grid Color menu. A color menu appears.

4.

Choose a new color from the Grid Color menu.

Setting the Snap Angle
The snap angle is the angle increment that you can draw lines at when ortho (plan) mode is on. When
you’re drawing a line or wall, once you click to place the first endpoint, you can move the cursor around
that point. Notice though that your cursor jumps (or snaps) in increments around that first endpoint.
These increments are set with the snap angle. With the snap angle set to 4, your cursor moves in 90
increments. If you change the setting to 36, the cursor snaps to 10 increments. If you toggle ortho (plan)
mode off, your cursor will move freely and you’ll be able to draw at any angle.
Shortcut: Press (O) to toggle ortho (plan) mode on or off. The “O” in SWOTHLUDFB in the Status Panel
toolbar will display as lowercase when ortho (plan) mode is off and uppercase when ortho (plan) mode is
toggled on.
 To set the snap angle:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Snap Angle in the Grids menu. A value menu appears.

3.

Use the value menu to set a new snap angle or type a new value and press (Enter). The maximum
setting for the snap angle is 36.
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Setting the Grid Angle
Rotating the snap grid and both display grids can make it easier to draw in some situations. The Angle
option will rotate all three grids. You can’t rotate each grid separately.
 To rotate all three grids:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Angle in the Grids menu. A value menu appears.

3.

Choose or type a new angle value (from 0 to 90) and press (Enter).

 To rotate the grids to the same angle as an entity in your drawing:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Angle in the Grids menu. A value menu appears.

3.

Click on Match: in the Angle menu.

4.

Click on an entity to match its angle; the angle of this entity appears in the Attention toolbar.
Check the Attention toolbar as you choose different options; it will display the angle associated
with each of the options in step 5.

5.

Decide which angle to use. To use this angle, right-click to exit the menu. To use the inverse of
this angle, click on Invert. To use the complementary angle of the original angle, click on
Complement. To use the supplementary angle of the original angle, click on Supplement. Click
on Original to go back to the original angle.

6.

Right-click to return to the value menu and press (Enter) to accept the angle value. The grid
rotates to the Angle setting.

Setting the Grid Origin
You can change the origin for the snap grid and both display grids on each layer or for all layers
simultaneously. The grid origin is not the drawing origin, which is a fixed point. The grid origin is
changed on all layers, whether they’re toggled on (and currently being displayed) or not.
 To change the grid origin on all layers in your drawing:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Grid Origin in the Grids menu. The Grid Origin menu appears.

3.

Look at the Grid Origin menu to make sure Set All is toggled on.

4.

Click anywhere in the Drawing Area or use coordinate entry to set the new grid origin. The
display grids realign themselves based on your new origin. For more information on using
coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter.

To display the grids at their new origin, you may have to press (Esc) to refresh the Drawing Area. You can
press (Esc) at any time while you work in DataCAD to refresh your drawing. Use object snapping to
more precisely choose the point in your drawing for the new grid origin. See “Object Snapping” in the
“Drawing Tools” chapter.
 To change the grid origin on the active layer only:
1.

Go to the Utility menu and click on Grids. The Grids menu appears.

2.

Click on Grid Origin in the Grids menu. The Grid Origin menu appears.

3.

Look at the Grid Origin menu to make sure Set All is toggled off.
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4.

Click anywhere in the Drawing Area or use coordinate entry to set the new grid origin. The
display grids realign themselves based on your new origin.

5.

Change the grid origins on other layers in your drawing if necessary. Just press (Tab) to change
the active layer and repeat steps 2 through 4.

Working With Layers
You can organize your drawing into groups (or layers) of related information to help increase your
editing speed and productivity. By organizing the information on each layer according to type or content,
you can display only the information that you need for the current drawing task. See “Planning Layers”
and “Sample Project” in “The Drawing Board” chapter for an introduction to planning your layering
system.

Figure 7.2: The Layers menu

Creating Layers
When you create a new drawing, only one layer exists, named Layer001. You can create new layers in
every drawing, either one at a time or in groups.
The maximum number of layers in DataCAD 18 Professional is 32,768. The maximum number of layers
in DataCAD LT 18 is 1,000.
Save time when you create new drawings by using a default drawing that contains all the layer names
and settings you’d normally use. Your new drawings will automatically have all the layers in your default
drawing and you can start drawing right away. See “Creating a New Drawing Using a Default Drawing”
in “The Drawing Board” chapter.
 To create layers in your drawing:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.
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Shortcut: Press (L) or (Shift) + (L) to access the Layers menu.
2.

Click on New Layer in the Layers menu. A value menu appears.

3.

Use the value menu to enter the number of new layers you’d like to create or type a value and
press (Enter). The number of layers created appears in the Attention toolbar, along with the total
number of layers now in your drawing.

More About Creating Layers
The active layer in your drawing acts as a seed layer for any new layers you create. When you create a
new layer, it takes on the settings of the active layer. To save time and avoid redefining settings for each
new layer, change the active layer to the layer in your drawing whose settings most closely match those
you want your new layer to have.
Each layer has several independent settings that you can customize. These include grid size, grid angle,
whether the snap grid is toggled on or off, whether ortho (plan) mode is toggled on or off, and layer
color. See “Setting Up Your Drawing Grids” earlier in this chapter for more information on grid settings.
A seed layer is a layer that is used as a basis for subsequent layers. For example, you might have a basic
perimeter plan of a multi-story building you’re drawing. This plan might contain the perimeter and
bearing walls, the columns, the column centerlines, and the common core elements, each on a different
layer. These layers could be used as seed layers for the partitioning layout on the third floor; in turn, that
could be used as the seed layer for the reflected ceiling plan or HVAC layout for the third floor. Any
layers you want to use as seed layers should be kept as generic and uncluttered as possible.

Setting the Active Layer
The active layer is the layer on which you’re currently drawing. To quickly check which layer is your
active layer, check the Status Panel toolbar.
 To change the active layer:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Set Active in the Layers menu. A list of layers appears.

3.

Click on a layer in the list to make it your active layer or type the layer name and press (Enter).
The active layer changes and the active layer name is updated in the Status Panel toolbar.
Shortcut: You can also use the keyboard to change the active layer. Press (Tab) to scroll through
all the layers in your drawing that are toggled on. To scroll backward through the layers, press
(Shift) + (Tab). Notice the active layer name in the Status Panel toolbar changes as you scroll
through the layers.

 To change the active layer and simultaneously toggle all other layers off:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Active Only in the Layers menu. A list of layers appears.

3.

Click on a layer in the list to make it your active layer or type the layer name and press (Enter).
The active layer name is updated in the Status Panel toolbar.

Displaying Layers
One of the most useful things about using layers in your drawings is that you can view only those layers
that you need at any given time. For instance, you don’t need to see the site plan while you’re working on
a reflected ceiling plan. In DataCAD, you simply toggle layers on to display them or off to hide them.
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You can toggle certain layers on to view them in the Drawing Area. You can then use go-to-views to save
that view of your drawing. See the “Viewing Your Model” chapter.
 To toggle a layer on or off:
1.

Go to the Utility menu and click on Layers. The Layers menu appears. The Menu Window
displays up to 15 layer names at one time; when there are more than 15 layers in your drawing,
options to scroll forward (Scroll Fwrd) and scroll backward (Scroll Back) through the list are
available.

2.

Click on On/Off in the Layers menu. A list of all the layers in your drawing appears.

3.

Click on the layer you want to toggle on or off. You can’t toggle all layers off in DataCAD. If the
active layer is the only one toggled on, you can’t toggle it off until you make a different layer
active. If there’s at least one other layer toggled on besides the active layer, you can toggle the
active layer off; the next layer in the list automatically becomes the active layer.

 To toggle on all the layers in your drawing simultaneously:
1.

Go to the Utility menu and click on Layers.

2.

Click on All On in the Layers menu. In the Message toolbar, you are asked Are you sure you want
to turn on all layers?

3.

Click on Yes. All layers are toggled on.

More About Displaying Layers
Refresh speed should also be considered when you plan and create the layers in your drawing. While
your computer’s speed determines the time it takes to refresh the display of your drawing, you can
dramatically increase refresh speed using some of the Layers options.
Shortcut: There are many reasons why you may want to refresh the display of your drawing during your
work session. Press (Esc) at any time to refresh your drawing.
As you toggle each layer on, DataCAD can automatically update (or refresh) your drawing in the
Drawing Area. To do this, toggle the layer refresh option (Layer Ref.) on in the Layers menu. To quickly
toggle several layers on without waiting for your drawing to refresh after each layer, make sure Layer
Ref. is toggled off before you begin toggling layers on. After you’ve finished toggling layers on, press
(Esc) to refresh the display of your drawing.
Each time you zoom in or out on your drawing or change the view (two things you’ll be doing
frequently), DataCAD must refresh the display of your drawing to reflect the change. Since only those
layers that are actually displayed are refreshed, toggling on only those layers that are necessary for your
current drawing task will speed up refresh rates. This is one of the many reasons why planning and
maintaining a good layer structure is important.
Additionally, controlling the number of entities on each layer will increase refresh rates. A drawing
containing many layers with a few entities on each will refresh faster than a drawing containing a few
layers with many entities on each. In other words, you can edit ten layers containing 100 lines faster than
one layer containing 1,000 lines.

Locking Layers
You can lock a layer to prevent others from editing the entities on that layer. In the list of layers in the
Menu Window, a line appears through the layer name of a locked layer.
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You can’t modify the layer in any way when it’s locked. If you try to edit a locked layer, a message saying
that no entities are selected appears in the Message Area. The layer lock status is saved with the layer
when you export or import layers.
 To lock a layer:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Lock in the Layers menu. A list of all the layers in your drawing appears in the Menu
Window.

3.

Click on the layer you want to lock in the list or type the layer name and press (Enter). DataCAD
draws a line through that layer’s name; if you make that layer the active layer, a small “X”
appears over the layer color box in the Status Panel toolbar. The layer can’t be edited until it’s
unlocked.

 To unlock a layer:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Lock in the Layers menu. A list of all the layers in your drawing appears.

3.

Click on the layer you want to unlock in the list or type the layer name and press (Enter). The line
through the layer name disappears; the layer can now be edited.

Renaming Layers
When you create new layers, DataCAD assigns generic names to the layers in numerical order, such as
Layer001, Layer002, etc. You can either rename the layers when you create them or rename them at some
other time. Layer names support extended characters.
 To rename an existing layer:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Rename in the Layers menu. A list of layers in your drawing appears in the Menu
Window.

3.

Click on the layer you want to rename.

4.

Type a new layer name (up to 88 characters) and press (Enter). You can use spaces; however, you
cannot use the following characters in layer names: , . * + / \ [ ] ; : .

Changing Layer Color
You can assign a color to a layer, so that all new entities you create on that layer appear in that color.
Assigning a different color to each layer gives you an easy way to tell at a glance what layer an entity is
on. If you assign yellow to your Walls layer, all entities drawn on the Walls layer will display in yellow.
By default, white is the color assigned to all layers.
When you change a layer’s color, entities already on that layer will not change to the new color. To
change these entities’ colors, you must use the Change menu. For more information, see “Changing
Entity Attributes” in the “Editing Drawings” chapter.
 To change the color assigned to a layer:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Color in the Layers menu. A color menu appears. See “Color Menus” in “The Drawing
Board” chapter for more information on how to use them.
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3.

Click on a color in the list or use the color menu options Custom or Match to assign a new color
to the layer.
Shortcut: To change the color of the active layer, press (K) to scroll through available colors;
press (Shift) + (K) to scroll backwards through the color menu.

Viewing a Layer
When you’re working with your layers, you may need to temporarily view a specific layer. Perhaps you
need to quickly verify the contents of a layer before you toggle it on.
 To temporarily view a layer:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on View Layer in the Layers menu. See “View Layer Menu Options” for more information
on these settings.

3.

Make sure Extents, Layer Ref., and Border are toggled on in the View Layer menu.

4.

Click on Select in the View Layer menu. A list of all the layers in your drawing appears in the
Menu Window.

5.

Click on the layer you’d like to view or type the layer name and press (Enter). The contents of
that layer appear in the Drawing Area.

6.

Press (Esc) when you’re finished viewing layers. This will refresh the Drawing Area and return to
the original view of your drawing, before you entered the View Layer menu.

View Layer Menu Options
Select
Extents
Layer Ref.
Border
Image Size

Lists the layers in your drawing; click on the layer name in the list or type the layer name and press
(Enter).
Toggle on to display the layer at its extents; toggle off to display the layer at the current scale.
Toggle on to refresh the Drawing Area as you select each layer.
Toggle on to use an invisible border to display each layer in.
Sets the percentage of the Drawing Area to use to display layers; only available when border is toggled
on.

Deleting Layers and Their Contents
When a layer is no longer useful to your project, you can erase only the contents of the layer or delete the
actual layer as well as its contents.
 To erase the contents of a layer:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Clear Layer in the Layers menu. A list of all the layers in your drawing appears in the
Menu Window.

3.

Click on the layer that contains the entities you want to erase or type the layer name. You are
asked Are you sure you want to erase: <layer name>.

4.

Click on Yes to erase the layer’s contents. The layer itself is not deleted and isn’t changed in any
other way. Click on No to exit the Clear Layer menu without erasing the layer’s contents.

 To delete a layer and its contents from the drawing:
1.

Go to the Utility menu and click on Layers.
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Warning: As a precaution, use Export Layer to save a copy of the layer before you delete it. If
you find you still need the layer later, you can then use Import Layer to copy it back into your
drawing.
2.

Click on Delete Layer in the Layers menu. A list of all the layers in your drawing appears.

3.

Click on the layer that you want to delete or type the layer name. The prompt Are you sure you
want to delete layer <layer name> appears in the Message toolbar.

4.

Click on Yes to delete the layer. Click on No to exit the Delete Layer menu without deleting a
layer. You cannot delete the active layer.

Selecting Layers Without Using Layer Names
You may have noticed the Match option in several of the Layers submenus. Match is used to select a layer
by selecting an entity on that layer instead of having to find the correct layer name in a list. You can set
the active layer, move entities from one layer to another, or point DataCAD to a specific layer, all without
having to remember layer names.
You can use Match with any of the following Layers menu options: On/Off, Set Active, Active Only, Lock,
Rename, Clear Layer, Delete Layer, View Layer/Select. It is also available when using To Layer in the
Move or Copy menus or when using Layer Search.
 To set the active layer using Match:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Set Active in the Layers menu. The Set Active menu appears.

3.

Click Match in the Set Active menu. You are prompted to Select entity on layer to match.

4.

Click on an entity in the Drawing Area to select the layer it is on. The active layer setting is
changed to that layer.

 To move entities to another layer using Match:
1.

Go to the Edit menu and click on Move.

2.

Click on To Layer in the Move menu. You are prompted to Select layer to move to in the Message
toolbar. The To Layer option is only available if your drawing has more than one layer. See
“Creating Layers” earlier in this chapter for more information on creating additional layers.

3.

Click Match in the To Layer menu. You are prompted to Select entity to match in the Message
toolbar.

4.

Click on an entity in the Drawing Area to select the layer to move the entity to. You are prompted
to Select entity to move in the Message toolbar.

5.

Click on the entity you want to move. The entity is moved to the layer you selected in step 4.

 To point DataCAD to a specific layer using Match:
1.

Indicate the Walls layer. When drawing doors or windows on a different layer from walls, you
must tell DataCAD which layer your walls are on so they can be cut properly. Make the Doors
layer your active layer and click on Architect in the Edit menu. See “Setting the Active Layer”
earlier in this chapter for more information.

2.

Click on Door Swing in the Architect menu.

3.

Toggle Layer Search on in the Door Swing menu. If it’s already toggled on, toggle it off and then
back on again to display the list of layers in your drawing.
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4.

Respond to the prompt to Select layer to search for walls in the Message toolbar. Click on Match at
the bottom of the list of layers.

5.

Respond to the prompt to Select entity on layer to match in the Message toolbar. Click on a wall in
your drawing to select the layer that your walls are drawn on.

6.

Draw your door. The wall will be cut properly on the Walls layer. This same procedure can be
used with the Windows or Cut Wall options. For details on how to draw doors and windows, see
the “Drawing Walls, Windows, and Doors” chapter.

Searching for Layers
You may have noticed the Filter option in several of the Layers submenus. Filter is used to search for
layers with similar names. For example, if you’ve put your plumbing and electrical drawings on separate
layers, you might have layers named 1FLPLUMB, 2FLPLUMB, 3FLPLUMB, 1FLELECT, 2FLELECT, and
3FLELECT. To search for a plumbing layer, you’d use Filter and enter ???plumb. Or you could search for
first floor layers by entering 1fl* or 1fl?????.
Use an asterisk (*) in place of any number of characters and a question mark (?) in place of each character
you’re unsure of. The filter disregards any characters following an asterisk. Therefore, if you enter
*plumb to search for plumbing layers, DataCAD recognizes only * as the search parameter and all of
your layers will be displayed.
 To search for layers:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on the Layers option you want to use (for example, On/Off).

3.

Click on Filter in the Layers option submenu to toggle Filter on.

4.

Type the search parameter, including any wildcard character(s), for the layers you want to find.
Your search results appear in a list in the Menu Window.

5.

Choose the layer(s) you want to use.

More About Searching for Layers
DataCAD groups layers with affixes (prefixes or suffixes) similar to what you entered. If your search
doesn’t find the layer you want, you can scroll through these groups to find the appropriate layer using
the Filter Back and Filter Fwd. options that appear at the bottom of the Menu Window, below your search
results.
DataCAD remembers the last search you did using Filter. When you next use Filter, the search parameter
you used last appears in the Attention toolbar and your search results appear in the Menu Window.

Saving and Loading Layers
You may occasionally need to copy a layer from one drawing to another, you may simply want to save a
copy of a layer before you delete it in case you find you need it again, or perhaps you’d like to save a
hidden line removal of your model to a layer file to avoid increasing your drawing file size. The Export
Layer and Import Layer options in the Layers menu can help you do all of these things. Export Layer
saves a layer to a layer (.DLF) file; Import Layer pastes a layer file into a drawing.
 To save a layer:
1.

Go to the Utility menu and click on Layers. The Layers menu appears.

2.

Click on Export Layer in the Layers menu. A list of your layers appears in the Menu Window.

3.

Click on the layer you want to save. A dialog box appears.
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Figure 7.3: Export Layer produces this dialog box
4.

Type the name of layer file and click on Save or press (Enter). DataCAD saves the layer with a
.DLF extension. If you already have a layer file by that name, DataCAD prompts you to verify
that you want to overwrite the existing file (replace the old version of the file with this new one).
Press (Enter) to overwrite the file. You are returned to the Layers menu. By default, files are saved
in your DataCAD\Layer Files folder. You can change the folder that layer files are saved to using
the Pathnames tab in the Tools/Program Preferences Configure DataCAD for Windows Settings
dialog box.

 To load a layer into a drawing:
1.

Go to your drawing and change the active layer to the layer that you want to copy the layer file
onto.

2.

Go to the Utility menu and click on Layers. The Layers menu appears.

3.

Click on Import Layer in the Layers menu. You are asked Delete active layer?” in the Message
toolbar.

4.

Click on Yes in the Menu Window to erase anything on the active layer. Click on No to add the
entities on the layer you will load to the entities already on your active layer. A dialog box
appears, listing all your layer files.
Warning: If you choose Yes to delete the active layer, you cannot restore those entities.

5.

Click on the layer file you want to load or type the filename in the File name input box.
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Figure 7.4: Import Layer produces this dialog box
6.

Click on Open or press (Enter). The layer file is copied to the active layer in your drawing.

More About Naming a Layer File
Just as you planned how to name the layers in your drawing, you should also plan a logical, useful
naming scheme for your layer files. To keep track of where the layer came from, the layer filename should
be as similar as possible to the name of the drawing file from which it originated. One way to name layer
files is to use the drawing filename followed by a descriptive name for the layer. For example, if you
saved the layer that contained a hidden line removal from the drawing file HOUSE.AEC, you might
name the layer file HOUSE_HL.DLF.

Using Layer Sets
In the Layers menu, Layer Sets replaces the layer utility macro from DataCAD versions 10 and prior.
Layer Sets controls settings on a per drawing basis and retains them with the drawing file.
 To create a layer set:
1.

Select Layers from the Utility menu. Then choose Layer Sets from the Layers menu. The Layer
Sets menu appears.

2.

Click on Create and toggle on the options you want in the current layer set.
All Layers
On Layers
Views
Details

3.

Creates a layer set with all layers.
Creates a layer set with only the layers that are on.
Includes saved views in the layer set.
Includes multi-scale plot details in the layer set.

Click on Begin. A dialog box appears so that you can enter the name of the layer set you want to
create.
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Figure 7.5: Supply a name for the Layer Set file you want to create
4.

Click in the File name input box, supply a name, and click Open or press (Enter).

 To load a layer set:
1.

Select Layers from the Utility menu. Then choose Layer Sets from the Layers menu. The Layer
Sets menu appears.

2.

Select Load from the Layer Sets menu. A dialog box appears, prompting you to enter the name of
the layer set you want to load.

Figure 7.6: Select a .DLS file to load
3.

Select the layer set you want to load from the *.DLS files in the list and click on Open or press
(Enter).

 To delete a layer set:
1.

Select Layers from the Utility menu. Then choose Layer Sets from the Layers menu. The Layer
Sets menu appears.
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2.

Select Delete Set from the Layer Sets menu. A dialog box appears, prompting you to enter the
name of the layer set you want to delete.

Figure 7.7: Select the .DLS file you want to delete
3.

Select the layer set you want to delete from the *.DLS files in the list and click on Open or press
(Enter). If you want to delete another layer set, repeat this step. If you do not want to delete
another layer set, click Cancel.

Assigning Materials for a Layer
You can assign materials on a per-layer basis to control your rendered drawing when you use the Object
Viewer or export your file to o2c format. This global setting is stored in the DCADWIN.INI file.
 To define materials on a per-layer basis:
1.

Select Rendering Settings from the View pull-down menu. The Material Assignment (Layer)
dialog box appears.

Figure 7.8: The Material Assignment (Layer) dialog box
2.

Click on the Layer button.

3.

Select a layer from the pull-down list in the Layer area of the dialog box.
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4.

Make changes in other portions of the dialog box to control the appearance of the rendering. For
more information about rendering settings, see “Using the o2c-based Object Viewer” in the
“Viewing Your Model” chapter.

Setting Z-Base and Z-Height for a Layer
Each layer can have different Z-base and Z-height settings.
 To specify Z-base and Z-height settings for each layer:
1.

Select Settings from the Utility menu. The Settings menu appears.

2.

Toggle on Z By Layer. The Z-base and Z-height will be remembered for each layer.

Using the Layer Manager
The Layer Manager gives you control over each layer’s number, status (on, off, locked, and unlocked),
color, and name. It displays the number of entities on each layer in the Count column.

Figure 7.9: The Layer Manager dialog box

Accessing Layer Manager
 To open the Layer Manager, use one of these options:


Select Layers from the Utility menu and click on Manage in the Layers menu. The Layer Manager
dialog box appears.



Or select Layer Manager from the Tools pull-down menu. The Layer Manager dialog box
appears.



Or use the keyboard shortcut (L) for Layer and (S8) for Manage. The Layer Manager dialog box
appears.



Or use the keyboard shortcut (Ctrl) + (L). The Layer Manager dialog box appears.



Or click on the active layer’s name in the status window.

Initially, the only active buttons are All On, New, OK, and Cancel. When you highlight the layer you
want to work with, other buttons will become active.
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Changing a Layer’s Number
 To change a layer’s number:
1.

Click on the number of the layer you want to change. The layer you selected is highlighted in the
Layer Manager dialog box. Notice that in addition to All On and New, the Set Active, Active
Only, Erase, Delete, Move Up, and Move Down buttons are active.
Hint: To select several successive layers (for example, layers 3 through 6) click on the first one,
press down and hold (Shift), and click on the last layer. Release the (Shift) key when you have
highlighted the successive layers you want to work with in the Layer Manager dialog box.
To select several layers that are not in consecutive order (for example, layers 3, 5, and 7), you
select the first one, press down and hold (Ctrl), and click on the other layers. Release the (Ctrl)
key when you have highlighted the nonconsecutive layers you want to work with in the Layer
Manager dialog box.

2.

Click on the Move Up or Move Down button until you are satisfied with the layer’s new position.
Alternatively, you can use the mouse to reposition the layer with drag and drop. Just click on the
number, drag your mouse, and release the left mouse button when you reach the desired new
number to dynamically reposition the layer.
Hint: When you make changes to the position of the layers by using the Move Up or Move Down
buttons or the drag-and-drop method, DataCAD automatically inserts a checkmark in the Save
new layer order box. If this box does not contain a checkmark, your changes will not be saved
and the layers will return to their original positions when you leave the Layer Manager dialog.

3.

Click on the Apply or OK button when you finish rearranging the layers. This saves your layers
in the new arrangement and deactivates the Revert button. When you click the OK button, the
Layer Manager dialog box disappears and you return to the drawing window.

 To return the layers you moved to their original positions, use one of these options:


Click on the Revert button if this option is available. If you selected Apply, the Revert button will
not be active. If you selected OK, the Layer Manager dialog box will not be displayed on your
screen.



Or click on the Undo arrow once if the Layer Manager dialog box is not on your screen to return
to the positions that were last active.



Or press (Ctrl) + (Z) for Undo if the Layer Manager dialog box is not on your screen.

Sorting the Layers
Use Layer Manager to sort your drawing’s layers by clicking on the column titles. Clicking the same
column title twice will reverse the sorting order. For example, you may want to sort the layers
alphabetically A-Z by the information in the Name column. If you click the Name column a second time,
the layers will appear alphabetically Z-A.
Hint: Sorting your layers by clicking on the column titles does not automatically place a checkmark in the
Save new layer order box. If you want to save the layers in the newly sorted order, make sure you click in
the Save new layer order box so that a checkmark appears before you exit from the Layer Manager
dialog box.
If you just want to quickly check the on/off or lock/unlock status of the layers, you may not want to store
the layers in that order. In these cases, you probably wouldn’t want to put a checkmark in the Save new
layer order box. Leaving the box unchecked means that DataCAD will return the layers to the order they
were in when you last opened the Layer Manager dialog box.

USING THE LAYER MANAGER |

Figure 7.10: Layers sorted alphabetically
This is what happens when you use the column titles to sort your layers:


LayerNum: Layers are arranged in numerical order. Clicking LayerNum again reverses the layers.



On: Layers that are On will appear first. Clicking On again makes the Off layers appear first.



Lock: Layers that are locked will appear first. Clicking Lock again makes the unlocked layers appear
first.



Color: Layers will be sorted from white through the darkest shades. Clicking Color again will sort
layers from darkest shades to white.



Name: Layers will be sorted alphabetically from A to Z. Clicking Name again will sort layers from Z
to A.



Count: Layers will be sorted numerically from the smallest to the largest number. Clicking Count
again will sort layers from the largest to the smallest numbers.

Hint: Count indicates the number of entities contained on a particular layer. You can sort by count to
quickly find the layers that do not contain any drawing entities. This makes it easy for you to delete empty
layers from your file.

Changing Layer Settings
Each layer has different settings that you can change. These settings are on/off, lock/unlock, color, and
name.
On/Off
A solid yellow light bulb in the On column indicates that a layer is on; a clear bulb means that a layer is
off. The green bulb designates the active layer. Only one bulb in the layer list can be green (meaning that
layer is on and active); however, any number of bulbs may be yellow (on) or clear (off).
 To change the on/off setting for one layer:
1.

Click on the light bulb of the layer you want to change. If the bulb was originally yellow, it
changes to clear and vice versa.
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2.

Click on Apply if you want to make other changes in the Layer Manager or click OK to return to
the drawing window, where your change is in effect.

 To change the on/off setting for several layers:
1.

Highlight the layers you want to change by using (Shift) for successive or (Ctrl) for
nonconsecutive layers.

2.

Click on the light bulb for one of the highlighted layers. All the bulbs in the highlighted layers are
changed to the same setting.
Hint: This is true even if some of the bulbs in the layers you selected were on and others were
off. For example, if you highlighted layers 3 (on), 5 (off), and 6 (on) before you clicked on the bulb
in layer 3, DataCAD would switch all three bulbs off.

3.

Click on Apply if you want to make other changes in the Layer Manager or click OK to return to
the drawing window, where all your changes are in effect.

Figure 7.11: Changing the On/Off status of a layer
 To turn all the layers on:
1.

Click the All On button.

2.

Click on Apply if you want to make other changes in the Layer Manager or click OK to return to
the drawing window, where all the layers are on.

 To designate the active layer:
1.

Select the layer you want to change to active status.

2.

Click on the Set Active button. The bulb for the highlighted layer changes to green and its name is
underlined. The bulb for the layer that was previously active changes to yellow (on) and its name
is no longer underlined.

3.

Click on Apply if you want to make other changes in the Layer Manager or click OK to return to
the drawing window. Notice that the layer you selected is active in the status box in your
drawing window.

 To display only the layer you designate as active:
1.

Highlight the layer you want to designate as active.

2.

Click the ActiveOnly button. The highlighted layer’s bulb is green (indicating it is on and active);
all other bulbs are clear (off). The layer’s name is also underlined.

3.

Click on Apply if you want to make other changes in the Layer Manager or click OK to return to
the drawing window. Notice that the active layer is the only one that appears in the drawing
window.

Lock/Unlock
You can edit unlocked layers, which are designated by an open padlock. Locked layers (red, closed
padlock) are protected and cannot be edited.
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 To lock or unlock one layer:
1.

Click on the padlock you want to change. DataCAD changes that layer’s lock status accordingly.

2.

Make changes to other layers in the Layer Manager if necessary. Remember that if you locked a
layer, DataCAD will not allow you to make any changes to it.

3.

Click OK to return to the drawing window.

 To lock or unlock several layers simultaneously:
1.

Highlight successive layers by using (Shift) or several nonconsecutive layers by using (Ctrl) to
select the padlocks you want to change.

2.

Click on a padlock in one of the selected layers. If the padlock you clicked was originally
unlocked, DataCAD will lock it and all the others in the layers you selected in step 1.

3.

Click OK to return to the drawing window.

Color
In the Layer Manager, the color of each layer appears in a square swatch. Changing the color that applies
to entities on a layer is easy. Keep in mind that the color change will apply only to the entities you create
on that layer; the new color doesn’t affect the entities that were on the layer.
 To change the color of a layer:
1.

Click on the square swatch in the Layer Manager for the layer you want to change. The Color
Palette dialog box appears.

Figure 7.12: The Color Palette dialog box
2.

Select a new color from the sample swatches in the palette.

3.

Click OK. Notice that the new color you selected appears on the swatch in the Layer Manager.

If you do not like any of the available colors, you can easily mix your own.
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Caution: Make sure that the color you want to edit is unique among the layers in your drawing. If several
layers use the same color, change the selected layer’s color as shown in the previous steps so that it is
different from the others. If the color of the layer you want to change is not unique, all other layers sharing
that color will also be changed in the editing process.
If you want to mix your own color for a layer, refer to the section on “Customizing Colors” at the end of
this chapter.
Name
DataCAD allows you to use up to 88 characters (including spaces) for meaningful layer names. You can
change a layer’s name in several ways with the Layer Manager. When you click on a layer’s name once,
that layer is highlighted or selected; however, you cannot edit the name.
 To change a layer’s name use one of these methods:


Double-click on the layer name you want to change, type the new name (up to 88 characters
long), and press (Enter). The new name appears on the list in the Layer Manager.

Figure 7.13: Double-clicking on the layer name lets you type a new name


Press (Enter) when a layer is highlighted, type the new name, and press (Enter).



Press (F2) when a layer is highlighted, type the new name, and press (Enter).

Using Other Layer Functions
With the Layer Manager, you can add new layers, erase all the entities on a layer, delete a layer, or revert
to previous layer settings. To access these basic functions, you use the buttons on the right side of the
layer list.

Figure 7.14: Buttons to the left of the layer list show options for changing settings
Add New Layer
The Layer Manager makes it easy to add new layers to your drawing. While you add the layer, you also
set its name, on/off and lock/unlock status, and color. Initially, the new layer will not contain any
drawing entities; those accumulate in the Count column as you use the layer.
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 To add a new layer to your drawing file:
1.

Highlight the layer that should appear before or above the new one you are creating. DataCAD
adds the new layer after the highlighted one. For example, if you want the new Brick layer to
come before Stucco, you would highlight Metal.

Figure 7.15: Highlight the layer above the position where you want the new layer to appear.
2.

Click on the New button to the right of the layer list. The Create New Layer(s) dialog box appears
and you are prompted to Enter the number of new layers to create.

Figure 7.16: The Create New Layer(s) dialog box
3.

Input the number of layers you want to add to your drawing and press (Enter) or click OK. The
new layer appears above the one you initially highlighted.

Figure 7.17: The new layer appears below the layer you highlighted in step 1.
4.

Type a name for the new layer and press (Enter). Notice that Count contains a zero because there
are no entities in this layer yet.

Figure 7.18: Type the new layer’s name.
5.

Continue adding new layers by repeating steps 1 through 4.

6.

Click in the box at the bottom of the Layer Manager to put a checkmark, indicating that you want
DataCAD to save the new layer order. When you are finished adding new layers to your drawing
file, click on Apply (if you want to continue working in the Layer Manager) or OK (if you do
want to leave the Layer Manager and return to your drawing window now).

195

196 | BEFORE YOU DRAW

Figure 7.19: Check the “Save new layer order” box.
Erase Entities from a Layer
You can quickly eliminate all the entities on a layer. This can help you save time when you want to make
major changes on a particular layer of your drawing.
 To erase entities from a layer:
1.

Highlight the layer that contains the entities you want to eliminate.

2.

Click on the Erase button. A Warning box appears.

Figure 7.20: Warning box
3.

Click on the Yes button or press (Enter).
Hint: The entities will be erased from your drawing when you click Apply or OK (to exit the Layer
Manager), but DataCAD gives you a chance to change your mind and keep those entities. To
change your mind, simply select either the Revert or Cancel button.

4.

Click on Apply if you want to have the entities erased while you continue working in the Layer
Manager. Click OK if you want to have the entities erased and return to your drawing window.
DataCAD erases the entities on the layer.

Delete a Layer
You can eliminate an entire layer from your drawing. It doesn’t matter whether the layer contains
hundreds of entities or none.
 To delete a layer:
1.

Highlight the layer you want to eliminate from your drawing file.

2.

Click on the Delete button to the right of the layer list. A warning box appears, giving you a
chance to change your mind.
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Figure 7.23: Warning box
3.

Select Yes or press (Enter) to indicate that you want to continue. The layer disappears from the
list.
Oh No! What if you accidentally deleted the wrong layer? Don’t panic because DataCAD gives
you two more chances to change your mind. You can click Revert to restore the layer
immediately; the other alternatives are to select Cancel or use the Undo function.

Changing an Incorrect Layer Setting
There are three ways for you to change settings if you made a mistake in the Layer Manager dialog box.
Depending on when you notice the mistake, you can select Revert or Cancel or use the Undo button if
you don’t catch the error until you leave the Layer Manager dialog box.
Revert to Previous Settings in the Layer Manager
If you accidentally do something to a layer (such as eliminate all its entities, turn a layer off, or eliminate
the layer entirely), you can go back to the previous settings with Revert.
Revert is available after you do something on the Layer Manager’s list and only applies to what you just
did. For example, if you change a layer’s status to Off and then give the layer a new name, Revert will
give you a chance to return to the older name but will not turn the status to On. If Revert is unavailable
(the button is gray), it’s too late to change your mind about a previous decision.
Cancel
If Revert is not available (the button is gray) or you notice a previous error (such as eliminating all the
entities in the wrong layer) you made during the current Layer Manager session, you can use the Cancel
button. Selecting Cancel closes the Layer Manager and puts you back in the drawing window, ignores all
the changes you made since you entered the dialog box, and returns all layer settings to those that existed
previously in your drawing file.
Cancel affects all the settings you changed in the Layer Manager dialog box since you opened it. You can’t
selectively eliminate some changes and retain others. If selecting Cancel eliminated settings that you
wanted to keep, you must reopen the Layer Manager dialog box, make the changes again, and save them
when you exit the dialog by choosing the OK button.
Undo
Use the Undo arrow on your button bar or select Undo Layer Manager from the Edit pull-down menu if
the Layer Manager dialog box is not active on your screen. This eliminates all the things you changed the
last time you used the Layer Manager dialog box. If you restored your old layer settings with Undo but
want to keep them after all, just click on the Redo button or select Redo Layer Manager from the Edit
pull-down menu.

Exiting from the Layer Manager
The buttons on the bottom of the Layer Manager dialog box give you several exit options:
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Figure 7.24: Exit options


Apply. When you click on this button, the changes you make in the layer list take effect in your
drawing while the Layer Manager dialog box remains open.



Save new layer order. This check box is available if any of your changes involved the original layer
order or if you added or deleted layers. By default, when this box is initially active, it contains a
checkmark. Remember to uncheck this box if you want to go back to the layer order that was in effect
before you opened the Layer Manager.



Cancel. This disregards everything you did since opening the Layer Manager dialog box. Clicking
this button returns you to the drawing window and retains your layer settings to those that were in
effect before you opened the Layer Manager.



OK. Clicking this button returns you to your drawing screen and makes all the layer setting changes
take effect in your drawing file.

Customizing Drawing Settings
Passwords, scale and angle types, and a variety of display options can be set and modified at any time
during your work session.

Setting a Password
A password can provide a level of security to individual drawing files. DataCAD’s password option
requires that the password be entered correctly to open the drawing.
Warning: There is no way to circumvent this setting if you forget your password. Use a password you can
easily remember or store a reminder of it in a safe place.
 To set a password for your drawing:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Password in the Settings menu. A Password dialog box appears.

3.

Enter a password (from 1 to 11 characters long) and press (Enter) or click OK. DataCAD prompts
you to Verify password by re-entering.
The password is case-sensitive. If you used “12mydrawing” as the password, you cannot open
the file with “12Mydrawing,” 12MyDrawing,” or any other combination of upper- and/or lower-case
letters. The file can only be opened if you use “12mydrawing” as the password.

4.

Type the same password again and press (Enter) or click OK. The password is set. Make sure you
save your drawing before closing it so that the new password is saved with the drawing file.

5.

Repeat these steps if you need to change the password.

After you save and close a drawing file that is password-protected, it can only be opened if you know the
password. Even though you can see the drawing in the Preview Window of the Enter name of drawing
file to open dialog box, you cannot open it without the password.
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You can remove the password from a file after you open it. Just select Password from the Settings menu
and press (Enter) twice. This enters a blank password.

Setting Scale and Angle Types
You can change the scale and angle types your drawing uses. When you change the scale type, all
associative dimensions in your drawing will be updated.
 To change the scale type:
1.

Go to the Utility menu and click on Settings.

2.

Click on Scale Type in the Settings menu.

3.

Click on the scale type you want: architectural, engineering, decimal, inch fractions, decimal
inches, metric, meters, centimeters, millimeters, DIN standard, or AS 1100 standard.

4.

Choose how dimensions are displayed, using the Units, Do Float, Sig. Digits, and Stack Frac.
options. Toggle these on or off, as you like. See “Scale Type Menu Options” later in this section
for details on these settings.

5.

Right-click to exit the Scale Type menu when you’re finished.

 To change the angle type in your drawing:
1.

Go to the Utility menu and click on Settings.

2.

Click on Angle Type in the Settings menu.

3.

Click on the angle type you want: normal, bearings, decimal degrees, radians, or gradients. See
“Angle Type Menu Options” later in this section for details on these settings.

4.

Choose how angles are used. You can do this by using the Compass, Clockwise, and Start. Angle
options.

5.

Right-click to exit the Angle Type menu when you’re finished.
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Figure 7.25: The Normal angle type as is (left) and with Compass applied (right).
Scale Type Menu Options
Arch.
Eng.
Decimal
Inch/Frac.
Inch/Decimal
Metric
Meters

Uses and displays dimensions and coordinates in the architectural scale or Imperial units (feet,
inches, and fractions of inches); this is DataCAD’s default scale type.
Uses and displays dimensions and coordinates in the engineering scale (feet and decimal inches).
Uses and displays dimensions and coordinates in decimal feet.
Uses and displays dimensions and coordinates in inches and fractions of inches.
Uses and displays dimensions and coordinates in decimal inches.
Uses and displays dimensions and coordinates in meters, centimeters, and millimeters.
Uses and displays dimensions and coordinates in decimal meters.
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Centimeter
Millimeter
DIN
AS 1100
Units
Do Float

Sig. Digits
Stack Frac.

Uses and displays dimensions and coordinates in decimal centimeters.
Uses and displays dimensions and coordinates in decimal millimeters.
Uses and displays dimensions and coordinates in the form meters.centimeters with superscripted
millimeters.
Uses and displays dimensions and coordinates in millimeters with a space separating thousands,
hundred thousands, millions and so on; input is done in meters.
Toggle on to use and display dimensions and coordinates with unit abbreviations.
Toggle on so that distance readouts use a floating decimal point; only available with the Decimal,
Inch/Decimal, Meters, Centimeter, or Millimeter scale types. When Do Float is toggled off, the Sig.
Digits option becomes available.
Sets the number of decimal places or significant digits (0 to 3) to display; only available with the
Decimal, Inch/Decimal, Meters, Centimeter, or Millimeter scale types, when Do Float is toggled off.
Toggle on so that fractions of an inch appear “stacked” (with the numerator over the denominator)
rather than inline; available only with the Arch. scale type. Some third-party fonts have improper
character definitions, which may cause the fraction to overwrite the non-fractional portion of the
dimension when using Stack Frac. Should this occur, try using a different font.

Angle Type Menu Options
Normal
Toggle on to set zero degrees equal to the positive X axis, a horizontal line to the right.
Bearings
Toggle on to enter angles using bearings.
Dec. Degrees Toggle on to enter angles in decimal degrees.
Radians
Toggle on to enter angles in radians.
Grads
Toggle on to enter angles in gradients.
Compass
Sets zero degrees equal to the positive Y axis, a vertical line pointing north; this is not a toggle, but
simply clicking on it activates it.
Clockwise Toggle on to increase the angle in a clockwise direction; toggle off to increase the angle in a
counterclockwise direction. When you click on Compass, Clockwise is automatically toggled on.
Start. Angle Sets zero degrees equal to two specified points.

Editing Scale, Angle, and Distance Lists
With some functions, DataCAD will list scale, angle, or distance values for you to choose from. You can
modify these scale, angle, and distance lists associated with your drawing. You can list the current values,
add new values, change existing values, or delete values you don’t use.
 To list scale, angle, or distance definitions:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Edit Defs. in the Settings menu. The Edit Defs. menu appears.

3.

Click on the definition list you’d like to edit: Scales, Angles, or Distances. Each of these options
contains a submenu that includes List, Add, Change, Delete, Save File, and Load File choices.

4.

Click on List. The definitions appear in the Menu Window.

5.

Right-click anywhere on the screen or press any key on your keyboard to exit the list.

 To add a value to a definition list:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Edit Defs. in the Settings menu. The Edit Defs. menu appears.

3.

Click on the definition list you’d like to edit: Scales, Angles, or Distances. You are limited to 18
definitions in a scale, distance, or angle list. If you already have 18 in the list you want to add to,
you must either delete or change an existing one.
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4.

Click on Add. If you’re adding a new angle or distance, you are prompted to enter the new
definition in the Message toolbar. If you’re adding a new scale you are first prompted to Enter
new string for this scale. Supply the text that will appear in the list and press (Enter) before
continuing with the next step.

5.

Type a new definition and press (Enter). The new value is added to the definition list. You can
save your customized scale, angle, or distance lists to a separate file (with a .SCL, .ANG. or .DIS
file extension, respectively) and load them into DataCAD at any time for use in your drawings.

 To delete a value from a definition list:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Edit Defs. in the Settings menu. The Edit Defs. menu appears.

3.

Click on the definition list you’d like to edit: Scales, Angles, or Distances.

4.

Click on Delete. In the Message toolbar, you are prompted to select the definition to delete.

5.

Click on the definition in the list that you want to delete. Instantly, DataCAD deletes the
definition you selected.

 To change a value in a definition list:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Edit Defs. in the Settings menu. The Edit Defs. menu appears.

3.

Click on the list to be edited: Scales, Angles, or Distances.

4.

Click on Change. You are prompted to select the definition that you want to change.

5.

Click on the definition you want to change. If you’re changing an angle or distance, you are
prompted to enter the new definition in the Message toolbar. If you’re changing a scale, you are
prompted to Enter new string for this scale; enter the text that will appear in the list and press
(Enter) before continuing with the next step.

6.

Enter a new definition to replace the existing one and press (Enter).

 To save your customized definition list:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Edit Defs. in the Settings menu. The Edit Defs. menu appears.

3.

Click on the definition list you’d like to edit: Scales, Angles, or Distances.

4.

Click on Save File. A Save dialog box appears.

5.

Type a name for the customized list file and click on Save or press (Enter). The customized list is
saved.

 To load a customized definition list for use in your drawing:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Edit Defs. in the Settings menu. The Edit Defs. menu appears.

3.

Click on the definition list you’d like to edit: Scales, Angles, or Distances.

4.

Click on Load File. A Load dialog box appears.

5.

Click on the name of the customized list file that you want to load and click on Open or press
(Enter). The customized list is loaded into DataCAD.
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More About Architectural Scales
To calculate additional scales, you can use DataCAD’s online calculator. For example, to calculate the
scale value for 1/4” = 1’ - 0”, type =1/4/12 when you’re prompted for a new scaling value. Or type =.25/12
to get the same result: 0.02083333”. For more information on the calculator, see “DataCAD’s Online
Calculator” in “The Drawing Board” chapter.
An architectural scale list example follows:
SCALE
1/32” = 1’-0”
1/16” = 1’-0”
3/32” = 1’-0”
1/8” = 1’-0”
3/16” = 1’-0”
1/4” = 1’-0”
3/8” = 1’-0”
1/2” = 1’-0”
3/4" = 1’-0”
1” = 1’-0”
1 1/2” = 1’-0”
2” = 1’-0”
3” = 1’-0”
6” = 1’-0”
12” = 1’-0”
24” = 1’-0”

DECIMAL FORM
.00260416
.00520833
.00781250
.01041666
.01562500
.02083333
.03125000
.04166666
.06250000
.08333333
.12500000
.16666666
.25000000
.50000000
1.00000000
2.00000000

More About Engineering Scales
To calculate additional scales, you can use DataCAD’s online calculator. For example, to calculate the
scale value for 1” = 20’, type =1/20/12 and press (Enter) when you’re prompted for a new scaling value.
The calculated value is .00416666. An engineering scale list example follows:
SCALE
1” = 10’
1” = 20’
1” = 30’
1” = 40’
1” = 50’
1” = 60’
1” = 100’
1” = 200’
1” = 400’
1” = 600’
1” = 1000’

DECIMAL FORM
.00833333
.00416666
.00277778
.00208333
.00166666
.00138889
.00083333
.00041666
.00020833
.00013888
.00008333

More About Metric Scales
To calculate additional scales, simply type the ratio in decimal form. To use DataCAD’s online calculator
for this, type =1/20 and press (Enter) to get the new scale value 0.05000000. For more information on the
calculator, see “DataCAD’s Online Calculator” in “The Drawing Board” chapter.
A metric scale list example follows:
SCALE
1:1
1:2
1:5
1:10

DECIMAL FORM
1.00000000
0.50000000
0.20000000
0.10000000
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1:20
1:50
1:100
1:200
1:500
1:1000
1:2000
1:5000
1:10000

0.05000000
0.02000000
0.01000000
0.00500000
0.00200000
0.00100000
0.00050000
0.00020000
0.00010000

Setting Cursor Accuracy
Your cursor’s miss distance is the length (in pixels) extending from the center of your cursor’s crosshairs
outward. The smaller the miss distance, the closer you’ll have to place your cursor to an entity to select it.
This distance affects object snapping and other editing commands where you use your cursor to select a
point or entity. The default miss distance is 20.
 To set your cursor’s miss distance:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Miss Dist. in the Settings menu. A value menu appears. For more information on using
value menus, see “Value Menus” in “The Drawing Board” chapter.

3.

Choose a new distance value from the list or type a new value and press (Enter).

Setting Display Options
There are several display options that you can customize in DataCAD, including grid display, reference
mark display, cursor size, and information displayed in the Message toolbar.
When you zoom out from your drawing, the grid spacing becomes smaller. The grid can become so small
that it’s difficult to work with and even distracting. You can use the Small Grid option in the Settings
menu to turn off the display grids when it reaches a specific pixel spacing. A good setting is usually
between 15 and 20 pixels.
Shortcut: Press (PgDn) and (PgUp) to zoom in and out on your drawing,
 To set the smallest grid size at which the display grid will still display:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Small Grid in the Settings menu. A value menu appears. For more information on using
value menus, see “Value Menus” in “The Drawing Board” chapter.

3.

Choose a new value from the list or type a new value for the smallest grid size that will display
and press (Enter).

Another display option is the Draw Marks toggle in the Settings menu. Toggle Draw Marks on to have
DataCAD automatically draw temporary visual references for every point and entity you draw. These
small Xs do not plot and you can't snap to them. When you refresh the Drawing Area, the marks
disappear.
Shortcut: Press (Esc) to refresh the display of your drawing in the Drawing Area.
You can also toggle the Big Cursor option on in the Settings menu to display a large cursor that spans the
Drawing Area; toggle it off to display a smaller cursor. When you toggle Big Cursor off, you can specify
the size of the cursor.
Shortcut: Press (+) to toggle between large and small cursors.

203

204 | BEFORE YOU DRAW
 To set the size of a small cursor:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Big Cursor to toggle it on. If it’s already toggled on, skip to step 3.

3.

Click on Big Cursor to toggle it off. A value menu appears. For more information on value menus,
see “Value Menus” in “The Drawing Board” chapter.

4.

Use the value menu or type a new value for the cursor size (in pixels) and press (Enter).

In the Settings menu, Neg. Dist. allows you to customize the Message toolbar display. To allow the
display of negative coordinates in the Message toolbar, toggle Neg. Dist. on.

Setting the Panning Distance
You can adjust the distance the screen scrolls when you use the arrow keys to pan around your drawing.
For example, a setting of 50% scrolls 50% of the Drawing Area width each time you press an arrow key.
Shortcut: Press the arrow keys to pan around your drawing.
 To adjust the scroll distance:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Scroll Dist. in the Settings menu. A value menu appears. For more information on value
menus, see “Value Menus” in “The Drawing Board” chapter.

3.

Choose a new scroll distance from the list or type a new value and press (Enter).

Auto-recover Save Interval
DataCAD’s auto-recover feature creates an auto-recover (.ARF) file that you can use to recover your
drawing file should DataCAD unexpectedly close before you’re able to save the changes you’ve made to
your drawing. The Save Delay option in the Settings menu determines how often DataCAD updates the
auto-recover (.ARF) file. When an auto-recover save is finished, Auto-recover file created appears in the
Attention toolbar. If there are a lot of entities on a layer, you may want to adjust this save delay to a
higher setting to avoid frequent interruptions until you’re finished working on that layer.
Warning: Auto-recover is not a substitute for saving your file. Auto-recover does not mean that DataCAD
automatically saves your file. If you chose No when you close the drawing, DataCAD will not
automatically save your changes.
The moral of the story: Use File Save often while you are drawing and when you are closing a file.
The auto-recover function does not permanently save your drawing, so your drawing (.AEC) file is not
updated. See “Backing Up and Recovering Files” in “The Drawing Board” chapter for information on
how to use auto-recover files.
 To adjust the time interval between auto-recover updates:
1.

Go to the Utility menu and click on Settings. The Settings menu appears.

2.

Click on Save Delay in the Settings menu. A value menu appears. To turn off the auto-recover
function, set Save Delay to zero. However, DataCAD does not recommend this because it leaves
you no way to recover work done since you last saved your drawing (.AEC) file.

3.

Use the value menu to choose a value for the time interval or type a new time value and press
(Enter).
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Synchronizing the Distance Display
In DataCAD, you can rotate the grids along with your cursor to make it easier to draw at an angle. The
Dist. Sync. option in the Settings menu is toggled on by default so that the coordinate display in the
Coordinates/Hints toolbar matches the rotated cursor position. If you are working with a rotated cursor
but want to view the distance relative to standard X and Y coordinates, toggle Dist. Sync. off.

Customizing Display
You can use the Display menu options to toggle the text, dimensions, hatching, or certain drawing
attributes on or off. Because the text, dimensions, and hatching that you add to your drawing are made
up of many entities, you may want to toggle one or all of these options off to speed up the refresh time
while you draw. Toggle these options on again before you plot the drawing.
 To customize the display of your drawing:
1.

Go to the Utility menu and click on Display. The Display menu appears.

2.

Decide what you want to display in your drawing. You can display all the text, associative
dimensions, and hatch patterns that you’ve added to your drawing or you can choose not to
display them while you work to decrease drawing refresh times. Toggle Text on to display text;
toggle it off to display text as boxes. Toggle Dimensions on to display associative dimensions;
toggle it off to hide associative dimensions. Toggle Hatch Pattern on to display hatch patterns;
toggle it off to hide hatch patterns.

Some DataCAD menu options are toggles, switches that can be turned on or off. When a toggle is on, the
button appears depressed. When a toggle is off, the button appears raised.
You can quickly identify on and off toggles by color. DataCAD uses green as the default for toggles that
are on; red is the default for toggles that are off. You can easily change the on and off colors by selecting
Program Preferences from the Tools pull-down menu, clicking on the Menus tab in the Configure
DataCAD for Windows dialog box, and choosing different colors in the Toggle ON Button and Toggle OFF
Button areas. For more information, see “Customizing DataCAD’s Interface” in “The Drawing Board”
chapter as well as “Customizing Colors” later in this chapter.

Figure 7.26: Text toggle on

Figure 7.27: Text toggle off
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3.

Look at the toggles that change how the lines in your drawing are displayed. Toggle Line
Weights on to display line weights you’ve applied to your drawing; toggle it off to display lines
with a weight greater than 1 as single solid lines. You can also toggle on Line Types to display
any user-defined line types you’ve added to your drawing. If Line Types is toggled off, userdefined lines (such as insulation, hedge, and shingles) appear as single solid lines. When Line
Types is toggled off causing user-defined lines to display as solid, these lines are not changed in
any way; they are merely represented on screen by a simple solid line. Toggle Overshoots on to
display line overshoots.

4.

Change display settings for symbols as well. Toggle Ins. Points on to display symbol insertion
points; toggle it off to hide symbol insertion points. You can also click on Small Symbol to set the
smallest displayable symbol size. Any symbol smaller than the Small Symbol setting will be
displayed as a box. A setting of 0 displays all symbols, regardless of size. See “Value Menus” in
“The Drawing Board” chapter for more information on using value menus.

5.

Change settings for displaying text by clicking on Small Text or Box Color. Small Text sets the
smallest text size displayable on screen; any text smaller than the Small Text setting appears as a
box. A setting of 0 displays all text, regardless of size. Box Color sets the color of the boxes that
replace small text or that replace all text if Show Text is toggled off. See “Color Menus” in “The
Drawing Board” chapter for more information on using color menus. You can select a global text
box color or click on No Change to display the text boxes in the same color as the text they
replace.

6.

Change the way DataCAD displays associative hatch. Display control points of associative
dimensions by toggling Dim. Points on. Display the origin of associative hatching with a small +
by toggling Hatch Origin on.

7.

Display the center points of 2D curves by toggling Curve Center on.

8.

Display visible attributes added with a macro by toggling Show Attrib. on.

9.

Click on Layer Order to assign the order in which to refresh drawing layers. In the Layer Order
menu, toggle First on to refresh the active layer first; toggle Last on to refresh the active layer last;
or toggle In Order on to refresh the layers in the order you created them. Only one of these three
options can be toggled on at any one time.
If Display List is on, Display List is also available in the Utility / Display menu. Click Display List,
click on Statistics in the Display menu, and look at the Attention toolbar to see how many entities
and line segments are in the Display List and how much memory is used to maintain the list. For
more information about Display List, see “Customizing Miscellaneous Settings” in “The Drawing
Board” chapter.

10. Look at the Arc Factor option; it changes how arcs and curves are displayed. The higher the
setting, the smoother curves appear. Use a lower setting while drawing to increase refresh
speeds; then increase the setting when drawing is complete (see Figure 7.28).
11. Display bitmaps in your drawing using the Bitmaps toggle. Turn this toggle off if you want to
suppress bitmaps to increase speed and refresh rates.
12. Right-click to exit when you’ve finished changing Display menu settings.

CUSTOMIZING DISPLAY |

Figure 7.28: Arc factor settings (0.5 and 3 respectively)

Customizing Colors
You can use any customized palette by loading it in the Color Palette dialog box.
 To use a standard palette:
1.

Click on Color Palettes in the Tools pull-down menu. The Color Palette dialog box appears.

Figure 7.29: The Color Palette dialog box
2.

Select a palette from the drop-down box. You can choose from Default, DXFDWG, Munzell,
Prizma, RGB_BMKR, RGB_CBGK, RGB_CWBM, RGB_KRGY, RGB_MWRY, RGB_WCYG, Sepia,
and White. The color swatches in the palette you selected appear in the dialog box.

3.

Click on OK or press (Enter) to use that palette in subsequent drawing sessions.

 To mix your own custom color:
1.

Click on Color Palettes in the Tools pull-down menu to display the Color Palette dialog box.

2.

Select a palette from the drop-down box.
The Prizma palette is good to use for developing custom colors. Using the blank swatches below
the colored ones can help you keep your custom colors separate from the supplied ones.

3.

Click on the swatch you want to customize in the Color Palette dialog box.

4.

Supply a name for the color you want to create. In this example, the new color will be called
“Mint.” Then click on the Edit button to display the Color Picker dialog box.
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5.

Use your mouse in the RGB (red, green, blue) and/or HSB (hue, saturation, brightness) window
to mix the color you prefer. Since the original and new colors appear at the bottom of the Color
Picker dialog box, it is easy to compare the two.

Figure 7:30: The Color Picker dialog box lets you mix custom colors for your color palette
6.

Select OK when you are satisfied with the new color. The Color Palette now contains your custom
color in the swatch.

7.

Click OK to exit the Color Palette dialog box.

Chapter 8 Drawing Walls,
Windows, & Doors

8

In this chapter:

The Architect menu includes the three most basic drawing
elements. It offers options for drawing 2-line, 3-line, and 4-line
walls. Door Swing and Windows open subsequent menus that
allow you to choose the door styles and windows you want,
along with a variety of customizable options.

 Drawing 2-line, 3-line,

With a single choice from the Architect menu, you can begin
drawing walls whose intersections can be cleaned automatically.
Windows, doors, and other wall openings can then be inserted
with just a few clicks and, if necessary, removed just as easily.

 Drawing and

Note: This chapter refers to DataCAD’s ‘Classic’ walls, doors,
and windows and does not cover ‘Smart’ walls, doors, and
windows that were introduced in DataCAD 12. For more
information, please see the “Smart Entities Tutorial” located in
the DataCAD 18\Help folder.

and 4-line walls

 Drawing and

removing doors

 Drawing and

removing windows
removing openings
in walls
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Drawing Walls
Walls can be drawn by simply toggling on the Walls option in the Architect menu. DataCAD
automatically cleans wall intersections, including the last intersection where the first and last walls drawn
meet.
You can draw 2-line walls using the 2 Line Walls option, 3-line walls using the 3 Line Walls option, or 4line walls using the 4 Line Walls option. Two line walls draw an inside and an outside line, 3-line walls
add a centerline, and 4-line walls add two cavity lines. The 2 Line Walls, 3 Line Walls, and 4 Line Walls
toggles are mutually exclusive; when one is toggled on, the others are automatically toggled off.
2 Line Wall
Inside wall

Center line
3 Line Wall

Cavity walls
4 Line Wall

Figure 8.1: DataCAD’s wall types
When you select Architect from the Edit menu, the Architect context-sensitive toolbar appears. The first

eight icons can be used to draw and edit walls:
. From
left to right, these icons let you draw 2-line walls, 3-line walls, or 4-line walls; select and manage wall
styles; set the wall width; draw walls by the outside; draw walls by the center; and clean up wall
intersections.
 To draw walls:
1.

Make sure you are in Ortho or Plan mode. You can toggle Plan on in the View pull-down menu,
click on the plan icon
in the Projection Pad toolbar, or toggle on Ortho Mode in the View
pull-down menu. Walls can only be drawn in plan (or orthographic) view.

2.

Go to the Edit menu in the Menu Window and click on Architect. Alternatively, you can click on
in the Icon Draw toolbar. (For information about defining the two Icon toolbars, see
“Selecting Default Icon Toolbars” in “The Drawing Board” chapter.) A third option is to select
Wall from the Create pull-down menu and indicate the type of wall you want to draw in the
submenu; if you use this method, skip to step 5.
Shortcut: Press (A) to access the Architect menu. Press (=) to quickly toggle Walls on or off from
anywhere in DataCAD.
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3.

Click on Walls in the Architect menu to toggle it on; Wall is checked in the Create pull-down
menu. You can now draw walls instead of lines.

4.

Click on 2 Line Walls to draw 2-line walls, click on 3 Line Walls to draw 3-line walls, or click on 4
Line Walls to draw 4-line walls.

5.

Set the wall attributes using the Highlight option along with Width for 2-line walls, Center Line
for 3-line walls, and Exterior, Interior, and Cavity for 4-line walls. See “More About Setting Wall
Attributes” later in this chapter.

6.

Select two points to draw a wall. When you do this, the line connecting those two points becomes
the outside wall, inside wall, center of the wall, or center of the wall cavity, depending on
whether Outside, Inside, Center Wall, or Center Cav. is toggled on, respectively. Outside defines
walls by the outside of the wall; Inside defines them by the inside of the wall; Center Wall by the
center of the wall; or Center Cav. by the center of the wall cavity. When drawing 2-line walls or 3line walls, Center Wall and Center Cav. work the same way. You can choose either option to
create walls based on the wall center.

7.

Click on Clean to automatically clean wall intersections as you draw your walls; click on Cap to
cap wall ends as you draw your walls. For more information on using Clean and Cap, see “More
About Finishing Walls” later in this chapter.

8.

Click anywhere in the Drawing Area or use coordinate entry to start drawing your walls.

9.

Move the cursor using your mouse and click again or use coordinate entry to specify the end of
the first wall.

10. Click anywhere on the inside or outside of the wall, depending on what you did in step 6. If you
chose Outside, Center Wall, or Center Cav. in step 6, click anywhere on the inside of the wall; if
you chose Inside in step 6, click anywhere on the outside the wall.
11. Notice that your cursor is still connected to the end of your first wall. You can continue selecting
wall endpoints, as you did in step 9; all intersections will be automatically cleaned.
12. Finish drawing walls by right-clicking to disconnect your cursor from the wall or clicking near
the first endpoint of your first wall to close your wall plan. Your cursor is automatically
disconnected.
Sometimes, you may need to fix wall intersections that didn’t clean properly when they were drawn. Use
the Cleanup menu’s T Intersect, L Intersect, and X Intersect options to clean wall intersections. Use the
Cleanup menu’s Weld Line and Weld Wall options to mend openings in walls. See “Cleaning Wall
Intersections” and “Welding Lines and Walls” in the “Editing Drawings” chapter.
More About Setting the Width of Walls
When toggling on the Walls option in the Architect menu, you are prompted for a new wall width. A wall
width is the distance between the inside and outside wall. You can also change wall width anytime while
drawing 2-line or 3-line walls.
 To change the width of walls to be drawn:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Width in the Architect menu. You can also click on
in the context-sensitive Architect
toolbar. A value menu appears. The Width option is not available when 4 Line Walls is toggled
on.
Shortcut: Press (=) to set the wall width.
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3.

Use the value menu to enter a new width or type a new width and press (Enter). DataCAD sets
the new wall thickness and subsequent walls will be drawn with that thickness. For more
information on using value menus, see “Value Menus” in “The Drawing Board” chapter.

More About Setting Wall Attributes
You can assign different attributes to outside or inside walls, including colors, line types, and line weights
by using the Highlight option in the Architect menu. Other attribute options apply only to 3-line or 4-line
walls.
 To draw walls with either the outside or inside wall in a different color, line type, or line weight:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Highlight in the Architect menu. The Highlight menu appears.
You can only set Highlight options for either the inside wall or the outside wall. For example, you
can’t assign a color to the outside wall and a line type to the inside wall. If the Highlight menu
does not appear, click on Highlight in the Architect menu twice.

3.

Click on Outside in the Highlight menu to highlight the outside of your walls. Click on Inside to
highlight the inside of your walls.

4.

Click on Color to choose a highlight color, click on Line Weight to choose a line weight to
highlight your walls with, or click on Line Type to choose a line type as a highlight.

5.

Right-click to return to the Architect menu.

6.

Begin drawing your walls. Notice that DataCAD applies the color, line type, or line weight
attributes you set as you draw walls.

 To set attributes for the center line when drawing 3-line walls:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Center Line in the Architect menu. The Center Line menu appears. The Center Line
option is only displayed when 3 Line Walls is toggled on.

3.

Click on Color to choose a highlight color, click on Line Weight to choose a line weight to
highlight your walls with, click on Line Type to choose a line type as a highlight, or click on
Spacing to set the spacing for the center line. The Spacing setting lengthens both the lines and the
spaces in a line type, so that the aspect ratio of the line type is preserved.

 To set the distance from the exterior wall to the exterior cavity wall when drawing 4-line walls:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Exterior in the Architect menu. A list of width values appears.

3.

Use the value menu or type a new value and press (Enter) to set the exterior wall thickness. For
more information about how to use value menus, see “Value Menus” in “The Drawing Board”
chapter.

 To set the distance from the interior wall to the interior cavity wall when drawing 4-line walls:
1.

Click on Architect in the Edit menu.

2.

Click on Interior in the Architect menu. A list of width values appears.

3.

Use the value menu or type a new value and press (Enter) to set the interior wall thickness.

 To set the attributes for the cavity wall when drawing 4-line walls:
1.

Click on Architect in the Edit menu.
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2.

Click on Cavity in the Architect menu. The Cavity menu appears.

3.

Click on Width to set the width from the exterior cavity wall to the interior cavity wall; click on
Color to choose a color for cavity walls; click on Line Weight to set the line weight of cavity walls;
click on Line Type to set the line type for cavity walls; click on Spacing to set the spacing for
cavity walls.

More About Finishing Walls
As you saw in the tutorial in this manual, DataCAD always cleans the intersections of walls as you draw
them, as long as you don’t disconnect your cursor from the last wall you drew. For T intersections, you
can toggle on Clean in the Architect menu to automatically trim the interior wall lines as you draw the
walls so that your walls look continuous, without internal lines at corners.
Sometimes you may need to fix wall intersections that didn’t clean properly when they were drawn. Use
the Cleanup menu’s T Intersect, L Intersect, and X Intersect options to clean wall intersections. Use the
Cleanup menu’s Weld Line and Weld Wall options to mend openings in walls.
Shortcut: Press (\) to toggle Clean on or off.
The Cap option in the Architect menu can be toggled on to insert a wall cap or closure on the end of a
wall. When you draw walls, DataCAD automatically caps the ends instead of leaving them open.
The Clean and Cap toggles are mutually exclusive; when one is toggled on, the other is automatically
toggled off.

Using Wall Styles
You can save wall styles for 2-line, 3-line, or 4-line walls with the wall attributes you use most often, and
then use them in any drawing file. The following attributes are saved in a wall style:


line color, line type, line spacing, and line weight of wall lines. The line spacing setting lengthens both
the lines and the spaces in a line type, so that the aspect ratio of the line type is preserved.



whether you want to highlight the inside or outside line of your walls using color, line weight, and
line type.



wall widths and center line and cavity wall attributes.

 To save a new wall style:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Wall Style in the Architect menu, or click on
in the context-sensitive Architect
toolbar, or select Wall Style from the extended Create/Wall pull-down menu. The Wall Style
Manager dialog box appears.
DataCAD provides several default wall styles in the drop-down box in the Wall Styles Available
portion of the dialog box. You can also use the arrow buttons beside the drop-down box to scroll
through the available default wall styles.
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Figure 8.2: The Wall Style Manager dialog box
3.

Click on SaveAs in the Wall Styles Available section at the bottom of the dialog box. Supply a
name (up to nine characters long) for the wall style and press (Enter) or click on OK. The wall
style is saved and now appears in the drop-down list in the bottom left corner of the dialog box.

Figure 8.3: New style name dialog box
4.

Type a name for your new wall style and press (Enter) or click on OK. The wall style is saved and
now appears in the drop-down list in the bottom left corner of the dialog box.

5.

Make decisions about the lines, colors, spacing, line weight, and other options available in the
Wall Style Manager dialog box.

6.

Click on Save to store your decisions and then click on OK. Now, you’re ready to draw walls
using your new style.

 To save changes to a wall style:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Wall Style in the Architect menu. The Wall Style Manager dialog box appears.

3.

Use the drop-down list in the Wall Styles Available section at the bottom of the dialog box or click
on the arrow buttons to select the wall style you want to modify.

4.

Change wall settings as necessary.

5.

Click on Save in the Wall Styles Available section at the bottom of the dialog box. The wall style is
saved with any changes you made to wall settings. Click on OK to exit the dialog box.

 To use a wall style:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Wall Style in the Architect menu. The Wall Style Manager dialog box appears.

3.

Use the drop-down list or the arrow buttons in the Wall Styles Available section at the bottom of
the dialog box to select the wall style you want to use. Wall settings in the dialog box are changed
to those of the wall style you selected.
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4.

Click on OK to close the dialog box.

 To delete a wall style:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Wall Style in the Architect menu. The Wall Style Manager dialog box appears.

3.

Use the drop-down list or the arrow buttons in the Wall Styles Available section at the bottom of
the dialog box to select the wall style you want to delete.

4.

Click on Delete. By asking Are you sure you want to delete filename?, DataCAD gives you a chance
to change your mind. Click on Yes to complete the process. The selected wall style is deleted.

5.

Click on OK to close the Wall Style Manager dialog box.

 To display the settings for a wall style:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Wall Style in the Architect menu. The Wall Style Manager dialog box appears.

3.

Use the drop-down list in the Wall Styles Available section at the bottom of the dialog box to
select the wall style whose settings you want to view. Wall settings in the dialog box are changed
to those of the wall style you selected.

4.

Click on OK to use those wall style settings and close the dialog box or click on Cancel to close
the dialog box without changing wall settings.

Cutting Walls
You can use Cut Wall in the Architect menu to remove sections of walls.
 To cut openings in walls using the mouse:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Cut Wall in the Architect menu or click on
The Cut Wall menu appears.

3.

Determine which layer your walls are on. If your walls are on a layer other than the active layer,
click on Layer Search to toggle it on. If Layer Search is already on, toggle it off and then back on
again to choose your walls layer. The layers in your drawing are listed in the Menu Window.

4.

Click on the layer your walls are drawn on.

5.

Select one side of the opening by clicking on a point on the wall or using coordinate entry to
specify the exact coordinates. To choose a coordinate entry method, use the Input Mode option in
the Utility pull-down menu.

6.

Select the other side of the opening by moving the mouse along the wall and clicking on any
point or by using coordinate entry. The wall is cut and the wall ends are capped automatically.

in the context-sensitive Architect toolbar.

If the wall opening is a result of adding a door or window when Cutout (an option in the Door Swing and
Windows menus only) was toggled off, you must use Erase in the Edit menu to erase the framed opening.
You will then need to use Weld Wall in the Edit/Cleanup menu to weld the wall.
 To remove an opening from your drawing:
1.

Go to the Edit menu in the Menu Window and click on Architect.
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2.

Click on Cut Wall in the Architect menu or click on
The Cut Wall menu appears.

3.

Determine which layer contains your walls.

in the context-sensitive Architect toolbar.



If you don’t want to search for the wall layer, toggle on Any Layer.



If you want to cut walls that appear on a specific layer, toggle on One Layer to list the layers
in your drawing. Then select the layer you want from the list.

4.

Click on Remove in the Cut Wall menu.

5.

Click to one side of the opening and move your mouse diagonally to stretch the rubber band box
around it, completely enclosing all elements of the opening. You can stretch the box around
multiple openings to remove them all at once.

6.

Click to complete the box. DataCAD removes the opening and welds the wall. If any remnant of
the opening remains, click (Esc) to refresh the drawing.

Drawing Doors
Not only can you draw walls using the Architect menu, you can also use it to draw doors, complete with
door swings, in a few quick steps. DataCAD places a jamb into the wall, erases the wall between the
jambs, draws the door at the specified thickness, and draws the door swing in the direction you
designated and the angle you selected.
You can draw doors by selecting the sides of the door or by selecting the center and strike side of the
door. When toggled on, the Sides option lets you draw doors by indicating the door sides (door jambs).
When Sides is toggled off, doors are drawn by indicating their center and strike side.
You can use the One Layer toggle if you want to select the specific layer (from those listed) that contains
the walls you want to cut for the doors. If you toggle on Any Layer, DataCAD will search all the “on”
layers for the walls that can hold your doors.
 To draw a door using the mouse:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Door Swing in the Architect menu. The Door Swing menu appears. You can also access
the Door Swing menu in the Edit/Architect menu using the Doors option in the DCAD_AEC
macro in the Toolbox pull-down menu. In addition, you can click on the
the Draw toolbar.

icon if you loaded

3.

Set the door jamb, angle, style, thickness, head height, and swing style as necessary. See the
following pages for more information on setting these door options.

4.

Look at the Sides toggle switch. If Sides is toggled on, you are prompted to Select hinge side of door.
If Sides is toggled off, you are prompted to Select center of door. To enter the point you’re
prompted for, click on a wall or use coordinate entry. You are prompted to Select strike side of door.

5.

Click on the wall or use coordinate entry to enter the strike side of the door. You are prompted to
Select direction of door swing. See “Drawing with Coordinate Entry” in “The Drawing Board”
chapter.

6.

Click either inside or outside the wall to indicate which direction the door should swing. You are
prompted to Select any point on the outside of the wall.

7.

Click anywhere outside the wall. The door and doorjamb are drawn.
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Figure 8.4: Drawing a door
More About Door Styles
The Door Style menu allows you to choose from six door styles: single, double, bi-fold, sliding, pocket,
and overhead. See Figure 8.5 for examples of door styles. Single creates single-leaf, hinged doors of any
size. This is the default setting for the Door Style menu. Click on Double to draw two opposing doors
hung on a single frame. Bi-fold creates simplified folding doors, while Sliding creates 2-panel sliding
doors, and Pocket creates pocket doors. Click on Overhead to create overhead garage doors. A dotted line
representing the overhead door in a raised position will be drawn, with the dimensions equaling the
width and head height of the door.

Single

Double

Bi-Fold

Sliding

Pocket

Overhead

Figure 8.5: Options in the Door Style menu
More About Door Jambs
Some of the Door Swing menu options affect how the door is drawn in the wall. Click on Draw Jamb, In
Wall, or Cutout to toggle the option on. The Draw Jamb option draws door jambs for each wall opening,
while In Wall precisely centers door openings between the two wall faces, and Cutout removes the wall
segment between the two jambs. An added benefit to drawing doors with Cutout toggled on is that the
walls will automatically weld themselves if you use Remove to erase the door. If you toggled on One
Layer, DataCAD presents a list of the layers in your drawing so that you can choose the wall layer where
the doors should be drawn.
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Jamb In is a toggle that determines whether the door will be drawn by rough opening or finished
opening. Rough opening means that the door jamb is drawn inside the opening specified; finished opening
means the door jamb will be drawn outside the opening specified. By default, Jamb In is toggled off,
meaning the door will be drawn by finished opening. When Jamb In is toggled on, DataCAD draws the
door by rough opening.
To explain further, when using Sides to draw a door with Jamb In off, the two points you select mark the
inside of the finished opening; therefore, the jamb will be drawn outside the two points specified. If you
toggle Jamb In on and draw another door, the two points you select mark the rough opening in the wall
and the jamb is drawn inside the two points.
You can also change the jamb width for your doors.
 To set a new jamb width:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Door Swing in the Architect menu. The Door Swing menu appears.

3.

Click on Jamb Width in the Door Swing menu.

4.

Choose or type a jamb width value and press (Enter).

Match Wall in the Door Swing menu is toggled on by default, causing jamb depth to automatically match
the wall width. When Match Wall is toggled off, the Jamb Depth option becomes available; you can use
Jamb Depth to set the jamb depth independently of the wall width. Jamb Depth is only available from the
menu when Match Wall is toggled off.
More About Door Angles
Click on Angle in the Door Swing menu to determine the door opening. An angle set to 0-0’ will result in
the doors being drawn closed, while a 90-0’ angle will result in the doors being drawn fully open. For bifold doors, a 90 angle creates a right angle at the intersection of each door. When an angle between 0-0’
and 90-0’ is entered, DataCAD will draw single and double doors open to varying degrees.
DataCAD will draw sliding and pocket doors open to varying degrees when an angle between 10-0’ and
90-0’ is chosen. When any angle 90-0’ or greater is chosen, sliding and pocket doors will be drawn fully
open. When fully open, sliding doors will be drawn to one side and at the first point chosen for the door
opening, making the opening at the second point. When doors are drawn closed, the door overlap is
equal to double the door thickness. The Angle setting does not affect Overhead doors; they are always
drawn the same, regardless of angle.
 To set the angle of the door opening:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Door Swing in the Architect menu. The Door Swing menu appears.

3.

Click on Angle in the Door Swing menu.

4.

Use the value menu to enter a new angle or type an angle value and press (Enter). An angle of 00’ draws doors closed. An angle of 90-0’ draws most doors fully open. See “Value Menus” in “The
Drawing Board” chapter for more information on how to use them.
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More About Door Swing
The Swing Style option in the Door Style menu lets you choose the type and color of the door swing.
From the Swing Style menu, you can choose to draw either a line or arc swing style or to have no door
swing drawn at all. The Line option draws a straight line from the corner of the doorjamb to the corner of
the open door to represent the door swing. The Arc option draws a curve from the corner of the jamb to
the corner of the door.
With both Line and Arc, you can toggle Match Door on in the Swing Style menu to match the door swing
color to the door color. This option is toggled on by default. When Match Door is toggled off, the Swing
Color option is available in the menu. Click on Swing Color to choose a color for the door swing,
independent from the door color.
More About Other Door Settings
Regardless of which way you draw a door, you can use Center Point to add a point in the center of the
door. Then you can use the automatic dimensioning feature to find and dimension to this center point.
See “Drawing Linear Dimensions” in the “Dimensions” chapter.
The Draw Marks option in the Door Swing menu is another helpful, visual drawing aid. With Draw
Marks toggled on, DataCAD draws small crosses on the screen where you’ve selected points in the
Drawing Area. These marks are a temporary visual reference only; they disappear when you press (Esc)
to refresh the screen. They don’t plot and you can’t object snap to them.
This Draw Marks option is independent of Draw Marks in the Utility/Settings menu and affects only
doors and windows. See “Setting Display Options” in the “Before You Draw” chapter for more
information on the Settings menu’s Draw Marks option.
The Door Swing menu also has options to set the door thickness and head height.
 To set the door thickness:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Door Swing in the Architect menu. The Door Swing menu appears.

3.

Click on Thickness in the Door Swing menu. A value menu appears.

4.

Use the value menu to enter a door thickness or type a thickness value and press (Enter). See
“Value Menus” in “The Drawing Board” chapter for more information on how to use them.

 To set the door head height:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Door Swing in the Architect menu. The Door Swing menu appears.

3.

Click on Head Height in the Door Swing menu. A value menu appears.

4.

Use the value menu to enter a door thickness or type a height value and press (Enter).

Removing a Door
You can quickly remove any door from your drawing and automatically weld the wall with the Remove
option in the Door Swing menu. Keep in mind that Remove only erases the door if Cutout was toggled on
in the Door Swing menu when the door was drawn. If you didn’t use Cutout when you drew the door,
use Erase to erase the door as a group. You will then need to use Weld Wall in the Edit/Cleanup menu to
weld the wall. See “Erasing Entities” and “Welding Lines and Walls” in the “Editing Drawings” chapter.
 To remove a door from your drawing:
1.

Go to the Edit menu in the Menu Window and click on Architect.
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2.

Click on Door Swing in the Architect menu. The Door Swing menu appears.

3.

Click on Remove in the Door Swing menu. You are prompted to Select first point of box around door
or window to remove.

4.

Click above and to the left of the door to be removed.

5.

Move your mouse diagonally, completely enclosing all elements of the door, and click. DataCAD
removes the door. You can stretch the box around multiple doors to remove them all at once.

Drawing Windows
The Windows option draws windows with cased openings in walls, either by selecting the sides of the
window or by selecting the center and strike side of the window. You can customize the detail of the
windows by changing basic window components, including jamb size, sill projection, glass thickness, sill
height, and head height.
 To draw a window:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Windows in the Architect menu. The Windows menu appears.

3.

Set the window jamb, exterior and interior sill projections, thickness of glass, and sill height and
head height as necessary. See the following pages for more information on setting window
options.

4.

Toggle Sides on to draw windows by selecting the window sides (jambs); toggle Sides off to draw
windows by selecting their center point and one side. If Sides is toggled on, you are prompted to
Select one jamb of window. If Sides is toggled off, you are prompted to Select center of window.

5.

Click on a wall to enter one side of the window jamb or the center of the window. You are
prompted to Select second jamb of window or Select one jamb of window, depending on the status of
the Sides toggle.
If One Layer is toggled, you may encounter the error message No walls found to cut. Please check
search layer. Toggle One Layer on (if it’s already on, toggle it off and then on again) to display the
layers in your drawing. Choose the layer your walls are drawn on from the list in the Menu
Window.

6.

Click on the wall to enter the side of the window jamb. You are prompted to Select any point on the
outside of the wall.

7.

Click outside the wall. The window is drawn.

Figure 8.6: Drawing a window with Sides toggled on
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More About Window Jambs
Some of the Windows menu’s options affect how the window is drawn in the wall. The Draw Jamb
option draws window jambs for each wall opening, while In Wall precisely centers window openings
between the two wall faces, and Cutout removes the wall segment between the two jambs. Click on Draw
Jamb, In Wall, or Cutout to toggle the option on. An added benefit to drawing windows with Cutout
toggled on is that the walls will automatically weld themselves if you use Remove to erase the window.
You may need to use One Layer with this if you’re drawing windows on a different layer than your walls
are on; click on One Layer and then click on the layer your walls are on.
Jamb In is a toggle that determines whether the window will be drawn by rough opening or finished
opening. Rough opening means that the window jamb is drawn inside the opening specified; finished
opening refers to the window jamb being drawn outside the opening specified. By default, Jamb In is
toggled off, meaning the window will be drawn by finished opening. When Jamb In is toggled on,
DataCAD draws the window by rough opening.
To explain further, when using Sides to draw a window with Jamb In off, the two points you select mark
the inside of the finished opening; the jamb will be drawn outside the two points specified. If you toggle
Jamb In on and draw another window, the two points you select mark the rough opening in the wall; the
jamb is drawn inside the two points.
Match Wall is toggled on by default, causing the jamb depth of the window to automatically match the
wall width. When this option is toggled off, you can use Jamb Depth to set the jamb depth independently
of the wall width. Jamb Depth is only available from the menu when Match Wall is toggled off.
You can also change the jamb width for your windows.
 To set a new jamb width:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Windows in the Architect menu. The Windows menu appears.

3.

Click on Jamb Width in the Windows menu.

4.

Use the value menu to enter a jamb width or type a jamb width value and press (Enter).

More About Sill and Glass Settings
Other Windows options you’ll want to set include distances for the exterior and interior sill projections,
the thickness of the glass, and the sill height and head height.
 To change the distance of the exterior sill projection:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Windows in the Architect menu. The Windows menu appears.

3.

Click on Out Sill in the Windows menu. A value menu appears.

4.

Use the value menu to enter a new exterior sill projection or type a sill projection value and press
(Enter).

 To change the distance of the interior sill projection:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Windows in the Architect menu. The Windows menu appears.

3.

Click on In Sill in the Windows menu. A value menu appears.

4.

Use the value menu to enter a new interior sill projection or type a sill projection value and press
(Enter).
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 To change the thickness of the glass:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Windows in the Architect menu. The Windows menu appears.

3.

Click on Glass Thk. in the Windows menu. A value menu appears.

4.

Use the value menu to enter a new thickness or type a new value and press (Enter). If you enter a
thickness of 0”, DataCAD draws a single sheet of glass.

 To enter a new window sill height relative to the current Z-base elevation:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Windows in the Architect menu. The Windows menu appears.

3.

Click on Sill Height in the Windows menu. A value menu appears.

4.

Use the value menu to enter a new exterior sill projection or type a new height value and press
(Enter).

 To enter a new window head height relative to the current Z-base elevation:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Windows in the Architect menu. The Windows menu appears.

3.

Click on Head Height in the Windows menu. A value menu appears.

4.

Use the value menu to enter a new exterior sill projection or type a new height value and press
(Enter).

More About Other Window Settings
Regardless of which way you draw a window, you can use Center Point to add a point in the center of the
window. You can use DataCAD’s automatic dimensioning feature to find and dimension to this center
point.
The Draw Marks option in the Windows menu is another helpful, visual drawing aid. With Draw Marks
toggled on, DataCAD draws small crosses on the screen when you select points in the Drawing Area.
This Draw Marks option is independent of Draw Marks in the Utility/Settings menu and affects only
doors and windows. These marks are a temporary visual reference only; they disappear when you press
(Esc) to refresh the screen. They don’t plot and you can’t object snap to them.

Removing a Window
You can quickly remove any window from your drawing and automatically weld the wall with the
Remove option in the Windows menu. Keep in mind that Remove only erases the window if Cutout was
toggled on in the Windows menu when the window was drawn. If you didn’t use Cutout when you drew
the window, use Erase to erase the window as a group. You will then need to use Weld Wall in the
Edit/Cleanup menu to weld the wall.
 To remove a window from your drawing:
1.

Go to the Edit menu in the Menu Window and click on Architect.

2.

Click on Windows in the Architect menu. The Windows menu appears.

3.

Click on Remove in the Windows menu. You are prompted to Select first point of box around door or
window to remove.

4.

Click above and to the left of the window to be removed.
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5.

Move your mouse diagonally, completely enclosing all elements of the window, and click.
DataCAD removes the window. You can stretch the box around multiple windows to remove
them all at once.

(Pro) Drawing Linear Bays of Windows
With the Windows menu in the DCAD_AEC macro, you can draw 2D linear bays of windows. Click
OneWindw in the Windows menu in the DCAD_AEC macro to access the Windows menu in the
Edit/Architect menu.
 To draw a linear bay of windows:
1.

Click on DCAD_AEC in the Toolbox pull-down menu. If DCAD_AEC is not listed in your
Macros menu, click on Configure in the Toolbox menu and add DCAD_AEC to the Macros in
Menu list.

2.

Click on Windows in the DCAD_AEC menu. The Windows menu appears.
To model 3D windows, use the Windows menu in the AEC_Modl macro.

3.

Click on HeadHght in the Windows menu. A value menu appears, prompting you to Enter new
window header height.

4.

Type a new header height or use the value menu to enter a new height.

5.

Press (Enter) or right-click to accept the new value and exit the menu. The Windows menu
appears again.

6.

Click on SillHght in the Windows menu. A value menu appears, prompting you to Enter new
window sill height.

7.

Type a new sill height or use the value menu to enter a new height.

8.

Press (Enter) or right-click to accept the new value and exit the menu. The Windows menu
appears again.

9.

Click on LinrWndw in the Windows menu to display the Linear menu.

10. Decide if you want to draw a set quantity of equally spaced bays (as many bays of a set size that
can be fit into a space) or a set number and size of bays. In the Linear menu, click on Eq Bays to
draw equally spaced bays, click on FitBays to fit bays into a space, or click on SetBays to specify
the number and size of the bays. For the SetBays option, the opening length is determined by the
number and size of the bays you specify.
11. Set bay and window options as necessary. See “Linear Window Bay Options” on the following
pages for more information. You are prompted to Enter starting point of window wall.
12. Use the mouse or coordinate entry to select a starting point for your bay of windows. You are
prompted to Enter ending point of window wall. For more information on using coordinate entry,
see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter.
13. Use the mouse or coordinate entry to select an ending point for your bay of windows. You are
prompted to Enter a point on the outside of the wall.
14. Click anywhere outside the wall. DataCAD draws the bays of windows.
(Pro) Linear Window Bay Options
Bay Qty

Set the number of window bays you want drawn; not available when using FitBays because bay
quantity is automatically calculated.
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Bay Size
WallWdth
Cutout

CntrLin
InnrEdg
By Ends
By Cent
Mullions

Glass

Set the width of each window bay, which will be multiplied to create the window wall; not available
when using Eq Bays because individual bay size is automatically calculated.
Set the width of the wall, which then determines the depth of the sills; not available when Cutout is
toggled on because the wall width (and, therefore, the sill depth) is calculated automatically.
Toggle on to automatically calculate the wall width and cut an opening; only one of the three options
(Cutout, CntrLin, and InnrEdg) can be toggled on at any given time. When you use Cutout, the window
wall opening will be cut from Z-base to Z-height (from the bottom of the wall to the top), just as it is
with the Cutout option in the Architect menu.
Toggle on to center the depth of the wall along the starting and ending points you enter; only one of the
three options (Cutout, CntrLin, and InnrEdg) can be toggled on at any given time.
Toggle on to draw the inside face of the wall along the starting and ending points you enter; only one of
the three options (Cutout, CntrLin, and InnrEdg) can be toggled on at any given time.
Toggle on to draw a window wall by selecting the starting and ending points of the wall; only one of
the two options (By Ends and By Cent) one can be toggled on at any given time.
Toggle on to draw a window wall by selecting the starting point and the center point of the wall; only
one of the two options (By Ends and By Cent) can be toggled on at any given time.
The width, depth, and offset for window mullions are set using value menus. For more information on
value menus, see “Value Menus” in “The Drawing Board” chapter. Customize the dimensions and
position of window mullions; following are the Mullions menu options:
DoMulln
Models mullions; toggle this option off to draw windows without mullions.
Width
Sets the width of mullions; the width is the mullion dimension along the face of the wall.
Depth
Sets the depth of mullions; the depth is the mullion dimension through the wall.
Offset
Sets the distance from the inner edge of the wall to the inner edge of the mullion.
DoMarks
Toggle on to display a snapping point to the center of each mullion.
No Ends
Toggle on to draw windows without mullions at either end of the window wall; only one
of the three options (No Ends, HalfEnd, and FullEnd) can be toggled on at any given time.
HalfEnd
Toggle on to draw mullions of half-width on either end of the window wall; of the three
options No Ends, HalfEnd, and FullEnd, only one can be toggled on at any given time
FullEnd
Toggle on to draw mullions of full-width on either end of the window wall; only one of
the three options (No Ends, HalfEnd, and FullEnd) can be toggled on at any given time.
Color
Sets the color of mullion lines. For more information on using color menus, see “Color
Menus” in “The Drawing Board” chapter.
Line type
Sets the line type of mullion lines.
LineWdth
Sets the line width of mullion lines; make mullion lines wider by increasing this value.
LinSpcng
Sets the line spacing of window mullion lines, The LinSpcng setting lengthens both the
lines and the spaces in a line type, so that the aspect ratio of the line type is preserved.
Customize the dimensions and position of window glass; following are the Glass menu options:
DoGlass
Models glass; toggle this option off to draw windows without glass.
Thickness
Sets the thickness (or distance between the panes) of the glass; this setting has no effect
when 1-Line is toggled on. The thickness and offset for window glass are set using value
menus. For more information on value menus, see “Value Menus” in “The Drawing
Board” chapter.
Offset
Sets the distance between the inner edge of the wall and the inside face of the glass pane.
1-Line
Toggle on to model glass as a single line between mullions; only one of the three options
(1-Line, 2-Line, and 3-Line) can be toggled on at a time.
2-Line
Toggle on to model glass as a double line between mullions; only one of the three options
(1-Line, 2-Line, and 3-Line) can be toggled on at a time.
3-Line
Toggle on to model glass as a triple line between mullions; only one of the three options
(1-Line, 2-Line, and 3-Line) can be toggled on at a time.
Color
Sets the color of glass lines. For more information on using color menus, see “Color
Menus” in “The Drawing Board” chapter.
Line type
Sets the line type of glass lines.
LineWdth
Sets the line width of glass lines; make glass lines wider by increasing this value.
LinSpcng
Sets the line spacing of window glass lines. The LinSpcng setting lengthens both the lines
and the spaces in a line type, so that the aspect ratio of the line type is preserved.
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Sills

Customize the dimensions and position of inner and outer window sills. The inside and outside sills,
header depth, and sill depth for window sills are set using value menus. For more information on value
menus, see “Value Menus” in “The Drawing Board” chapter. Following are the Sills menu options:
DoSill
Models sills and headers; toggle this option off to draw windows without sills and
headers.
In Sill
Sets the distance from the inner edge of the window wall to the edge of the inner sill.
Out Sill
Sets the distance from the outer edge of the window wall to the edge of the outer sill.
HeadDpth Sets the depth of the window header.
SillDpth
Sets the depth of the window sill.
Color
Sets the color of sill lines. For more information on using color menus, see “Color Menus”
in “The Drawing Board” chapter.
Line type
Sets the line type of sill lines.
LineWdth
Sets the line width of sill lines; make sill lines wider by increasing this value.
LinSpcng
Sets the line spacing of window sill lines.

(Pro) Drawing Curved Bays of Windows
With the Windows menu in the DCAD_AEC macro, you can draw 2D curved bays of windows. Click
OneWindw in the Windows menu in the DCAD_AEC macro to access the Windows menu in the regular
DataCAD Edit/Architect menu.
 To draw a curved bay of windows:
1.

Click on DCAD_AEC in the Toolbox pull-down menu. If DCAD_AEC is not listed in your
Macros menu, click Configure in the Toolbox menu and add DCAD_AEC to the Macros in Menu
list.

2.

Click Windows in the DCAD AEC menu. The Windows menu appears.
To model 3D windows, use the Windows menu in the AEC_Modl macro

3.

Click HeadHght in the Windows menu. A value menu appears, prompting you to Enter new
window header height.

4.

Type a new header height or use the value menu to enter a new height.

5.

Press (Enter) or right-click to accept the new value and exit the menu. The Windows menu
appears again.

6.

Click on SillHght in the Windows menu. A value menu appears, prompting you to Enter new
window sill height.

7.

Type a new sill height or use the value menu to enter a new height.

8.

Press (Enter) or right-click to accept the new value and exit the menu. The Windows menu
appears again.

9.

Click on CircWndw in the Windows menu to display the Circular windows menu.

10. Decide if you want to draw a set quantity of equally spaced bays (as many bays of a set size that
can be fit into a space) or a set number and size of bays. You can draw a set quantity of equally
spaced bays (as many bays of a set size that can be fit into a space) or a set number and size of
bays. In the Circular menu, click on Eq Bays to draw equally spaced bays, click on FitBays to fit
bays into a space, or click on SetBays to specify the number and size of the bays. When using the
SetBays option, the opening length is determined by the number and size of the bays that you
specify.
11. Set bay and window options as necessary. See “Curved Window Bay Options” below for more
information. You are prompted to Enter center point of window wall arc.
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12. Use the mouse or coordinate entry to select a center point for the arc of your bay of windows. You
are prompted to Enter starting point of window wall arc.
13. Use the mouse or coordinate entry to select a starting point for the arc of your bay of windows.
You are prompted to Enter ending point of window wall. For more information on using coordinate
entry, see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter.
14. Use the mouse or coordinate entry to select an ending point for the arc of your bay of windows.
DataCAD draws the bay of windows.
(Pro) Curved Window Bay Options
Bay Qty
BayAngle

WallWdth
CntrLin
InnrEdg
Clckwse
Averagd

Mullions

Glass

Set the number of window bays you want drawn; not available when using FitBays because bay
quantity is automatically calculated.
Set the separation angle between individual window bays, which will be multiplied to create the total
curvature of the window wall; not available when using Eq Bays because individual bay angle is
automatically calculated.
Set the width of the wall, which then determines the depth of the sills.
Toggle on to center the depth of the wall along the starting and ending points you enter; only one of the
two options (CntrLin and InnrEdg) can be toggled on at a time.
Toggle on to draw the inside face of the window wall along the starting and ending points you enter;
only one of the two options (CntrLin and InnrEdg) can be toggled on at a time.
Toggle on to model windows in a clockwise direction; toggle off to model windows in a
counterclockwise direction.
Available only when FitBays is toggled on; toggle on to slightly increase or decrease the separation
angle of each bay to fit the number of bays you specified precisely into the defined opening, leaving no
extra space at one end of the window wall; if Averagd is toggled off, any leftover space at either end of
the curved window wall is filled with bays of a smaller width. Increasing or decreasing the separation
angle of each bay will increase or decrease, respectively, the width of each bay.
Customize the dimensions and position of window mullions. The width, depth, and offset for window
mullions are set using value menus. For more information on value menus, see “Value Menus” in “The
Drawing Board” chapter. Following are the Mullions menu options:
DoMulln
Models mullions; toggle this option off to draw windows without mullions.
Width
Sets the width of mullions; the width is the mullion dimension along the face of the wall.
Depth
Sets the depth of mullions; the depth is the mullion dimension through the wall.
Offset
Sets the distance from the inner edge of the wall to the inner edge of the mullion.
DoMarks
Toggle on to display a snapping point to the center of each mullion.
No Ends
Toggle on to draw windows without mullions at either end of the window wall; only one
of the three options (No Ends, HalfEnd, and FullEnd) can be toggled on at any given time.
HalfEnd
Toggle on to draw mullions of half-width on either end of the window wall; only one of
the three options (No Ends, HalfEnd, and FullEnd) can be toggled on at any given time.
FullEnd
Toggle on to draw mullions of full-width on either end of the window wall; only one of
the three options (No Ends, HalfEnd, and FullEnd) can be toggled on at any given time.
Color
Sets the color of mullion lines. For more information on using color menus, see “Color
Menus” in “The Drawing Board” chapter.
Line type
Sets the line type of mullion lines.
LineWdth
Sets the line width of mullion lines; make mullion lines wider by increasing this value.
LinSpcng
Sets the line spacing of window mullion lines. The LinSpcng setting lengthens both the
lines and the spaces in a line type, so that the aspect ratio of the line type is preserved.
Customize the dimensions and position of window glass; following are the Glass menu options:
DoGlass
Models glass; toggle this option off to draw windows without glass.
Thickness
Sets the thickness (or distance between the panes) of the glass; this setting has no effect
when 1-Line is toggled on. The thickness and offset for window glass are set using value
menus. For more information on value menus, see “Value Menus” in “The Drawing
Board” chapter.
Offset
Sets the distance between the inner edge of the wall and the inside face of the glass.
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1-Line

Sills

Toggle on to model glass as a single line between mullions; only one of the three options
(1-Line, 2-Line, and 3-Line) can be toggled on at a time.
2-Line
Toggle on to model glass as a double line between mullions; only one of the three options
(1-Line, 2-Line, and 3-Line) can be toggled on at a time.
3-Line
Toggle on to model glass as a triple line between mullions; only one of the three options
(1-Line, 2-Line, and 3-Line) can be toggled on at a time.
Color
Sets the color of glass lines. For more information on using color menus, see “Color
Menus” in “The Drawing Board” chapter.
Line type
Sets the line type of glass lines.
LineWdth
Sets the line width of glass lines; make glass lines wider by increasing this value.
LinSpcng
Sets the line spacing of window glass lines.
Customize the dimensions and position of inner and outer window sills. The inside and outside sills,
header depth, and sill depth for window sills are set using value menus. For more information on value
menus, see “Value Menus” in “The Drawing Board” chapter. Following are the Sills menu options:
DoSill
Models sills and headers; toggle this option off to draw windows without sills and
headers.
In Sill
Sets the distance from the inner edge of the window wall to the edge of the inner sill.
Out Sill
Sets the distance from the outer edge of the window wall to the edge of the outer sill.
HeadDpth Sets the depth of the window header.
SillDpth
Sets the depth of the window sill.
Color
Sets the color of sill lines. For more information on using color menus, see “Color Menus”
in “The Drawing Board” chapter.
Line type
Sets the line type of sill lines.
LineWdth
Sets the line width of sill lines; make sill lines wider by increasing this value.
LinSpcng
Sets the line spacing of window sill lines.
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Chapter 9 Drawing Other
Geometry
DataCAD offers several additional drawing tools outside of the
Architect menu. The Polygons and Curves menus in the Edit
menu allow you to draw a number of geometric shapes, from
simple rectangles to Bezier curves. The DCAD_AEC macro has
options to automate drawing stairs and elevators.

9

In this chapter:






Drawing polygons
Drawing curves
Drawing polylines
Drawing stairs
Drawing elevators
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Drawing Polygons
With the Polygons menu, you can draw rectangles or polygons with up to 36 sides. DataCAD uses a
temporary circle to define a polygon. The relationship between this circle and the resulting polygon is
dependent on the Inscribe option (see Figure 9.1). The points you select to draw the polygon will
determine the orientation of the polygon in your drawing.
 To draw a polygon:
1.

Go to the Edit menu in the Menu Window and click on Polygons. You can also click on the
icon in the Draw toolbar. The Polygons menu appears.

2.

Look at the toggle switches. The Dynamic, Center Point, Vertex, Diameter, and Inscribe options
are toggled on by default. Change these settings as necessary. See “Polygon Menu Options”
below for more information.

3.

Click on No. of Sides in the Polygons menu. A value menu appears and you are prompted to
Enter number of sides.

4.

Use the value menu or type a number and press (Enter). You are prompted to Select first point on
polygon.

5.

Click in the Drawing Area or use coordinate entry to select the first point for the polygon, as
prompted. See “Drawing Using Coordinate Entry” in “The Drawing Board” chapter to review
coordinate entry methods.

6.

Click to select the second point on the outside of the temporary circle used to define the polygon.
With Diameter toggled off, the distance between these two points defines the radius of the
temporary circle; with Diameter toggled on, the distance between the points is the diameter of the
circle. The polygon is drawn.

Polygon drawn with Inscribe on

Polygon drawn with Inscribe off

Figure 9.1: Polygons are actually defined by two points on a circle. These circles are not
displayed.
Polygon Menu Options
When you create polygons with both Vertex and Diameter toggled on, the two points you specify are
vertices opposite each other on the polygon. With Vertex on and Diameter off, you specify the center
point and one vertex. With Vertex off and Diameter on, you specify the mid-point of two sides of the
polygon that are opposite each other.
Dynamic

Toggle on to see the size and shape of the polygon you’re drawing before you choose the second point;
Dynamic is toggled on by default.
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Center Point Toggle on to display a snapping point, marking the center of the polygon; Center Point is toggled on by
default.
Vertex
Toggle on to draw polygons by defining two vertices of the polygon; toggle off to define polygons by
the mid-points of opposite sides of the polygon; Vertex is toggled on by default.
Diameter
Toggle on to draw polygons by defining the diameter of the polygon (two points opposite each other);
toggle off to define the radius of the polygon (the center point and one side or vertex); Diameter is
toggled on by default.
Inscribe
Toggle on to draw polygons as though they were inscribed within a circle; toggle off to draw polygons
as though a circle was inscribed within them (see Figure 9.1); Inscribe is toggled on by default. See
Figure 9.1 for more information about using Inscribe.

Drawing Rectangles
To draw a rectangle, you must select two diagonally opposite corner points. The X and Y coordinates of
these diagonal corners appears in the Message Area as you draw the rectangle.
 To draw a rectangle:
1.

Click on Polygons in the Edit menu. You can also click on the

icon in the Draw toolbar.

Shortcut: Press (Alt) + (R) to access the Polygons menu.
2.

Click on Rectangle in the Polygons menu.

3.

Toggle Center Point on to automatically add a snap point marking the center of the rectangle. If
Walls are toggled on and the Outside or Inside option in the Architect menu is toggled on as well,
you will be prompted to indicate the inside or outside of the wall, respectively, after you enter the
second point for your rectangle.

4.

Click in the Drawing Area or use coordinate entry to select the first point of the rectangle. For
more information on using coordinate entry, see “Drawing Using Coordinate Entry” in “The
Drawing Board” chapter.

5.

Move the cursor diagonally and click or use coordinate entry to enter the second point of the
rectangle. The rectangle is drawn.
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Drawing Curves
You can draw circles, arcs, ellipses, and other curvilinear entities using a wide variety of methods.
Selecting from the Menu Window is the traditional method. You can also click on
toolbar to open the drop-down menu that offers many curve-drawing alternatives:

in the Draw

Shortcut: Press (Alt) + (A) to access the Curves menu.

Drawing 2-Point Arcs
Two-point arcs are drawn by indicating the radius of the arc and then defining the length of the arc.

Second Point

First Point

Center Point

Figure 9.2: 2-point arc
 To draw a 2-point arc:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu.
Alternatively, click on

in the Draw toolbar, select
from the drop-down options to display the 2 Pt. Arc

menu, and skip to step 3.
2.

Click on 2 Pt. Arc in the Curves menu. You can also click on 2D Curves in the Create pull-down
menu and then click on 2-Point Arc in the submenu. The 2 Pt. Arc menu appears.

3.

Toggle Dynamic on in the 2 Pt. Arc menu to preview the arc before you enter the final point. With
Dynamic toggled on, you can move your mouse around the center point to preview the arc at
various angles before selecting the second point. You are prompted to Select center of arc.

4.

Select the center point of the arc by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. You are prompted to Select start point of arc.

5.

Select the first point on the arc by clicking in the Drawing Area or using coordinate entry. The
Clockwise option is now available in the menu. You are prompted to Select endpoint of arc.

6.

Toggle Clockwise on to draw the arc clockwise from the first point; toggle it off to draw the arc
counterclockwise.
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7.

Select the second point on the arc by clicking in the Drawing Area or using coordinate entry. This
point is used only to determine the angle of the arc, so it doesn’t have to be exactly on the arc. The
arc is drawn.

Drawing 3-Point Arcs
Three-point arcs are drawn by selecting the endpoints of the arc as well as one other point on the arc.

Second Point

Third Point

First Point

Figure 9.3: 3-point arc
 To draw a 3-point arc:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu.
Alternatively, click on
the drop-down options.

in the Draw toolbar and select

from

2.

Click on 3 Pt. Arc in the Curves menu. You can also click on 2D Curves in the Create pull-down
menu and then click on 3-Point Arc in the submenu. The 3 Pt. Arc menu appears.

3.

Toggle Dynamic on in the 3 Pt. Arc menu to preview the arc before you enter the final point. With
Dynamic toggled on, you can move your mouse to preview the arc at various angles before
selecting the third point. You are prompted to Select first endpoint of arc.

4.

Select the first endpoint of the arc by clicking in the Drawing Area or using coordinate entry. You
are prompted to Select second endpoint of arc. For more information on coordinate entry, see
“Drawing Using Coordinate Entry” in “The Drawing Board” chapter.

5.

Select the second endpoint of the arc by clicking in the Drawing Area or using coordinate entry.
Keep in mind when selecting the second endpoint that the arc will be drawn in a
counterclockwise direction. You are prompted to Select any point on the arc.

6.

Select the third point on the arc by clicking in the Drawing Area or using coordinate entry. The
arc is drawn, along with its center point.

Drawing Arcs By Center Angle
You can draw arcs based on a center angle that you define.

Figure 9.4: An arc defined by selecting an endpoint, the center point, and an angle
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 To draw an arc by defining the center angle:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on Cent. Angle in the Curves menu. You can also click on 2D Curves in the Create pulldown menu and then click on Center Angle Arc in the submenu. The Cent. Angle menu appears
and you are prompted to Select starting point of arc.

3.

Select the first endpoint of the arc by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. Keep in mind when selecting this starting point that the arc will be drawn in a
counterclockwise direction. You are prompted to Select center of arc.

4.

Select the center point of the arc by click in the Drawing Area or using coordinate entry. You are
prompted to Enter included angle; a value menu listing angle values appears.

5.

Type an angle or use the value menu to enter an angle and press (Enter). For more information
on using value menus, see “Value Menus” in “The Drawing Board” chapter. The arc is drawn.

Drawing Arcs By Arc Length
You can draw arcs by defining their length.

Figure 9.5: An arc defined by the starting point, center point, and length of the arc
 To draw an arc based on the arc’s length:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on Cent. Arc in the Curves menu. You can also click on 2D Curves in the Create pull-down
menu and then click on Center Arc in the submenu. The Cent. Arc menu appears and you are
prompted to Select starting point of arc.

3.

Select the first endpoint of the arc by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. Keep in mind when selecting this starting point that the arc will be drawn in a
counterclockwise direction. You are prompted to Select center of arc.

4.

Select the center point of the arc by clicking in the Drawing Area or using coordinate entry. You
are prompted to Enter arc length; a value menu appears.

5.

Type a length or use the value menu to enter a length, and press (Enter). For more information on
using value menus, see “Value Menus” in “The Drawing Board” chapter. The arc is drawn.
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Drawing Arcs By Chord Length
You can draw arcs by defining the length of a chord, measuring from the starting point of the arc to an
endpoint.

Figure 9.6: An arc defined by selecting the starting point of the arc, its center point, and the
length of a chord from endpoint to endpoint.
 To draw an arc based on chord length:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on Cent. Chord in the Curves menu. You can also click on 2D Curves in the Create pulldown menu and then click on Center Chord Arc in the submenu. The Cent. Chord menu appears
and you are prompted to Select starting point of arc.

3.

Select the first endpoint of the arc by click in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. Keep in mind when selecting this starting point that the arc will be drawn in a
counterclockwise direction. You are prompted to Select center of arc.

4.

Select the center point of the arc by clicking in the Drawing Area or using coordinate entry. You
are prompted to Enter chord length; a value menu appears. For more information on using value
menus, see “Value Menus” in “The Drawing Board” chapter.

5.

Type a length or use the value menu to enter a length and press (Enter). The arc is drawn.

Drawing Arcs By Radius
You can draw arcs by selecting two endpoints and then entering the length of the arc’s radius.

Figure 9.7: An arc defined by selecting a starting point and an ending point for the arc and then
setting an arc radius
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 To draw an arc based on a specified radius:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

2.

in the Draw toolbar

from the drop-down options. The Curves menu

Click on End Pt. Rad in the Curves menu. You can also click on 2D Curves in the Create pulldown menu and then click on End Point Radius Arc in the submenu. The End Pt. Rad menu
appears and you are prompted to Select starting point of arc.
To properly define an arc, you must make the radius value larger than half the distance between
the starting and ending points. If the message These points do not define an arc appears in the
Attention toolbar, increase the radius length.

3.

Select the first endpoint of the arc by clicking in the Drawing Area or using coordinate entry.
Keep in mind when selecting this starting point that the arc will be drawn in a counterclockwise
direction. You are prompted to Select ending point of arc.

4.

Select the endpoint of the arc by clicking in the Drawing Area or using coordinate entry. You are
prompted to Enter radius of arc; a value menu appears.

5.

Type a radius length or use the value menu to enter a radius and press (Enter). The arc is drawn.

You can use Stretch to change the radius of an arc. This stretches the endpoint and redraws the arc. For
more information on stretching, see “Stretching Entities” in the “Editing Drawings” chapter.

Drawing Arcs By Included Angle
You can draw arcs by selecting the endpoints of the arc and then entering an arc angle.

Figure 9.8: An arc defined by selecting a starting point and an ending point and then entering
the included angle for the arc.
 To draw an arc based on its included angle:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on End Pt. Ang. in the Curves menu. You can also click on 2D Curves in the Create pulldown menu and then click on End Point Angle Arc in the submenu. The End Pt. Ang. menu
appears and you are prompted to Select starting point of arc.

3.

Select the first endpoint of the arc by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. Keep in mind when selecting this starting point that the arc will be drawn in a
counterclockwise direction. You are prompted to Select ending point of arc.
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4.

Select the endpoint of the arc by clicking in the Drawing Area or using coordinate entry. You are
prompted to Enter included angle; a value menu appears.

5.

Type an angle or use the value menu to enter an angle and press (Enter). For more information
on using value menus, see “Value Menus” in “The Drawing Board” chapter. The arc is drawn.

Drawing Arcs Using a Tangent Line
The Start Ang. option in the Curves menu uses a temporary tangent line to define the angle of the arc.

Figure 9.9: An arc defined by selecting two endpoints and then setting the arc angle by placing
a temporary tangent line
 To draw an arc using a temporary tangent line:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on Start Ang. in the Curves menu. You can also click on 2D Curves in the Create pull-down
menu and then click on Start Direction of Arc in the submenu. The Start Ang. menu appears and
you are prompted to Select starting point of arc.

3.

Select the first endpoint of the arc by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. Keep in mind when selecting this starting point that the arc will be drawn in a
counterclockwise direction. You are prompted to Select ending point of arc.

4.

Select the endpoint of the arc by clicking in the Drawing Area or using coordinate entry. You are
prompted to Select starting direction of arc. Notice that a line is now connected to the starting point
you entered and the line moves as you move your mouse.

5.

Move your cursor until the line is positioned as a tangent line to the arc you want to draw.

6.

Click to set the tangent line. The arc is drawn. If Ortho mode is toggled on in the Tools pull-down
menu, the tangent line will “jump” in increments equal to the snap angle setting.

Drawing Tangent Arcs
You can draw arcs that are tangent to an existing line or arc by simply selecting the entity to be tangent
and then selecting an endpoint.
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 To draw arcs tangent to another entity:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu and then
click on Tangent. Or click on

in the Draw toolbar, select

from the drop-down options. You can also click on
2D Curves in the Create pull-down menu and then click on Tangent Arc in the submenu. The
Tangent menu appears; Dynamic is toggled on by default, allowing you to preview the arc before
entering the final point. You are prompted to Select line or arc from which to draw.
2.

Move your cursor over the entity that will be tangent to the arc you’re drawing and click to select
it. You can also object snap to an entity at a particular point. For more information on object
snapping, see “Object Snapping” in the “Drawing Tools” chapter.If you’ve selected the wrong
entity, click on New Line in the Tangent menu (or simply right-click using your mouse) to
deselect the entity; you can then select another entity for your tangent. You are prompted to Select
ending point of arc.

3.

Select the endpoint of the arc by clicking in the Drawing Area or using coordinate entry. For more
information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. The arc is drawn. Notice your cursor is still attached to the arc. You can continue
drawing tangent arcs by entering endpoints. Right-click to detach your cursor from the last arc
you drew.

Drawing Circles By Radius
You can draw a circle by defining its radius.

Figure 9.10: A circle defined by selecting a center point and a point on the circle
 To draw a circle based on its radius:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu and then
click on Radius Circ. Or click on
in the Draw toolbar and select
. You can also click on 2D Curves in the Create pull-down menu and then click on Radius Circle
in the submenu. The Radius Circ. menu appears with Dynamic toggled on by default, allowing
you to preview the circle before you select the last point. You are prompted to Select center of
circle.

2.

Select the center point of the circle by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. Notice the radius (and, therefore, the circle) changes size as you move your
mouse. You are prompted to Select any point on circle.

4.

Select a point on the circle by clicking in the Drawing Area or using coordinate entry. The circle is
drawn.
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Drawing Circles By Diameter
You can draw a circle by defining its diameter.

Figure 9.11: A circle defined by selecting two points opposite each other on the circle
 To draw a circle based on its diameter:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on Dia. Circ. in the Curves menu. You can also click on 2D Curves in the Create pull-down
menu and then click on Diameter Circle in the submenu. The Dia. Circ. menu appears with
Dynamic toggled on by default, allowing you to preview the circle before you select the last
point. You are prompted to Select first point on circle.

3.

Select the first point on the circle by clicking in the Drawing Area or using coordinate entry.
Notice the diameter (and, therefore, the circle) changes size as you move your mouse. You are
prompted to Select second point on circle.

4.

Select the second point on the circle by clicking in the Drawing Area or using coordinate entry.
The circle is drawn.

Drawing Circles By Points
You can draw a circle by defining three points on the circle.

Figure 9.12: A circle defined by selecting three points
 To draw a circle by selecting points:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu
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2.

Click on 3 Pt. Circ. in the Curves menu. You can also click on 2D Curves in the Create pull-down
menu and then click on 3-Point Circle in the submenu. The 3 Pt. Circ. menu appears with
Dynamic toggled on by default, allowing you to preview the circle before you select the last
point. You are prompted to Select first point on circle.

3.

Select the first point on the circle by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. You are prompted to Select second point on circle.

4.

Select the second point on the circle by clicking in the Drawing Area or using coordinate entry.
Notice the circle changes size as you move your mouse. You are prompted to Select third point on
circle.

5.

Select the third point on the circle by clicking in the Drawing Area or using coordinate entry. The
circle is drawn.

Drawing Ellipses
You can draw ellipses by simply selecting two diagonally opposed points, as though you were selecting
two diagonal corners of a rectangle.
 To draw an ellipse:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Ellipse. Or click on
in the Draw toolbar and select
from the drop-down options; then click on Ellipse in the Curves menu. In the Ellipse menu,
Dynamic is toggled on by default, allowing you to preview the ellipse before you select the last
point. You are prompted to Select first corner of ellipse rectangle.

2.

Select the first point for the ellipse by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. Notice the ellipse changes shape and size as you move your mouse. You are
prompted to Select second corner of ellipse rectangle.

3.

Select the second point for the ellipse by clicking in the Drawing Area or using coordinate entry.
The ellipse is drawn.

Drawing Curves Using Control Points
You can draw more complex curves by selecting control points that affect how the curves are drawn.

Figure 9.13: A Bezier curve with selected control points

DRAWING CURVES |

Figure 9.14: A B-spline curve with selected control points
 To draw a Bezier curve:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on Bezier in the Curves menu. You can also click on 2D Curves in the Create pull-down
menu and then click on Bezier Curve in the submenu. The Bezier menu appears with Dynamic
toggled on by default, allowing you to preview the curve as you select control points. You are
prompted to Select Bezier control point.

3.

Select a control point for the curve by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter.

4.

Continue selecting control points; you must select at least three but no more than twenty points.

5.

Right-click to detach your cursor from the curve. The Bezier curve is drawn. If you enter all eight
control points, your cursor is detached automatically and the curve is drawn.

The formula used to create B-spline curves in DataCAD is specific to Third Order splines.
 To draw a B-spline curve:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on B-Spline in the Curves menu. You can also click on 2D Curves in the Create pull-down
menu and then click on B-Spline Curve in the submenu. The B-Spline menu appears with
Dynamic toggled on by default, allowing you to preview the curve as you select control points.
You are prompted to Select B-Spline control point.

3.

Select a control point for the curve by clicking in the Drawing Area or using coordinate entry. For
more information on coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter.

4.

Continue selecting control points; you must select at least three but no more than twenty points.

5.

Right-click to detach your cursor from the curve. The B-spline curve is drawn. If you enter all
eight control points, your cursor is detached automatically and the curve is drawn.
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Drawing Curves Using Surveyor’s Data
You can draw curves based on surveyor’s data that you enter. Based on this data and the options you use,
DataCAD can even extrapolate additional data. For instance, if you enter the radius point of the curve,
the central angle of the curve, and the starting point of the curve, DataCAD can calculate the coordinates
of the ending point and draw the curve. For more information on the options noted in Figure 9.15, see
“Curve Data Menu Options” on the following page.

Figure 9.15: An arc drawn by entering surveyor’s data
 To draw a curve using surveyor’s data:
1.

Click on Curves in the Edit menu in the Menu Window. Or click on
and select
appears.

in the Draw toolbar

from the drop-down options. The Curves menu

2.

Click on Curve Data in the Curves menu. You can also click on 2D Curves in the Create pulldown menu and then click on Curve from Data in the submenu. The Curve Data menu appears.

3.

Enter the surveyor’s data using Curve Data menu options. Once enough information has been
entered to draw the curve, an Add option appears in the Curve Data menu.

4.

Click on Add. The curve is drawn.

Curve Data Menu Options
Radius Point
Start Point
End Point
Int. Point
Angle
Radius
Tangent
Chord
Arc Length
Bearing In
Bearing Out
Bearing P.C.
Bearing P.T.

Defines the center (or radius point) of the curve.
Defines the starting point (or the point) of the curve.
Defines the ending point (or point of tangency) of the curve.
Defines the point of intersection, where the tangent line intersects the starting point of the curve.
Defines the central angle about the radius point.
Defines the radius of the curve, or the distance between the radius point and the starting point or the
ending point of the curve.
Defines the distance from the starting point or ending point to the intersection of the tangent lines to
these two points.
Defines the straight-line distance between the starting point and the ending point of the curve.
Defines the distance along the curve from the starting point to the ending point.
Defines the bearing of the line going into the starting point of the curve.
Defines the bearing of the line going away from the ending point of the curve.
Defines the bearing of the line from the radius point to the starting point of the curve.
Defines the bearing of the line from the radius point to the ending point of the curve.
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Drawing Polylines
A polyline is a continuous series of lines and/or arcs that are treated by DataCAD as a single entity. You
can use the Rectangle option to quickly draw rectangular polylines or draw polylines, segment by
segment. You can use the Curves option to create polylines with curved rather than straight line
segments. Polylines can be open or closed, depending on whether you toggle Closed off or on.

Closed

Open

Figure 9.16: Examples of a closed polyline (drawn with Closed toggled on) and an open polyline
(drawn with Closed toggle off)
Closed polylines can be hatched; see the “Hatch” chapter for more information about hatching. If your
polyline (no matter how irregular) is not closed, you cannot hatch it. In addition, you can measure the
area or perimeter of a closed polyline or find its centroid; see “Measuring Areas, Perimeters, and
Volumes” in the “Drawing Tools” chapter for more information.
 To draw a rectangular polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Rectangle in the Polyline menu. You are prompted to Select first corner of rectangle.

3.

Click in the Drawing Area or object snap to a point to select the first corner of the polyline. Notice
that the rectangle stretches as you move your cursor. You are prompted to Select second corner of
rectangle.

5.

Click in the Drawing Area or object snap to a point to select the second corner of the polyline. The
polyline is drawn.
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 To draw a polyline, segment by segment:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears. Closed is toggled on by default, allowing you to draw a
polyline that will automatically be closed when you’re finished selecting points. You are
prompted to Select first point on polyline.

2.

Toggle Closed on or off, depending on whether you want to draw a closed or open polyline.

3.

Toggle Covered on or off, depending on whether you want DataCAD to supply a top and bottom
covering (like a roof and floor) for a closed polyline. Covered is available if you toggled Closed
on in step 2; it is not offered as an option if you toggled Closed off in step 2.

4.

Decide how you want to begin drawing your polyline:


To begin with a curve drawn without a 2-point or 3-point arc, click on Curves in the Polyline
menu.

When you click on Curves in the Polyline menu, the Curves submenu provides all the options you
need to construct curved polylines by using standard curve creation methods. The options in the
Polyline/Curves submenu are 2 Pt. Arc, 3 Pt. Arc, Cent. Angel, Cent. Arc, Cent. Chord, End Pt.
Rad., End Pt. Ang., Start Ang., Tangent, Radius Circ., Dia. Circ, and 3 Pt. Circ. For more
information about how to use specific options in the Polyline/Curves menu, review the “Drawing
Curves” section earlier in this chapter.
The Polyline/Curves options are exactly the same as those in the standard Curves menu. In
Version 10, DataCAD added them to the Polyline menu for your convenience. Accessing these
options through the Polyline menu makes it easier to draw curved polylines because you don’t
have to constantly right-click to back up to the main Curves menu.


To begin with a 2-point arc, select the first point for the polyline by clicking in the Drawing
Area or using coordinate entry. For more information on coordinate entry, see “Drawing
Using Coordinate Entry” in “The Drawing Board” chapter. You are prompted to Select next
point on polyline. Click on 2 Pt. Arc in the Polyline menu. Select a center point for the arc
(toggle Clockwise off if you want to draw in a counterclockwise direction). Either continue
drawing 2-point arcs as part of the polyline or right-click to exit that function.

If you only need the 2 Pt. Arc or 3 Pt. Arc polyline options, you do not need to select the Curves
submenu from the Polylines menu. Those two functions appear in the Polyline menu if you click
to select the first point on the polyline immediately, instead of opening the Curves submenu.

5.



To begin with a 3-point arc, select the first point for the polyline by clicking in the Drawing
Area or using coordinate entry. For more information on coordinate entry, see “Drawing
Using Coordinate Entry” in “The Drawing Board” chapter. Click on 3 Pt. Arc in the Polyline
menu. You are prompted to Select second endpoint of arc. Click where you want the arc to end
or use coordinate entry. You are prompted to Select any point on the arc. Drag your mouse or
use coordinate entry, then click to select any other point on the arc. Either continue drawing
3-point arcs as part of the polyline or right-click to exit that function.



To begin with a straight line, select the first point for the polyline by clicking in the Drawing
Area or using coordinate entry. For more information on coordinate entry, see “Drawing
Using Coordinate Entry” in “The Drawing Board” chapter. You are prompted to Select next
point on polyline. Indicate the second point of a straight line segment by clicking in the
Drawing Area, using coordinate entry, or object snapping to a point on an entity.

Continue drawing line segments, curves, or arcs until your polyline is complete.
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Notice that Tangent appears in the Polyline menu after you finish drawing the first straight line
segment or after you right-click to exit the 2-point or 3-point arc functions. It also appears in the
Polyline/Curves menu. When you are prompted to Select next point on polyline, you can draw a
tangent arc in your polyline by clicking on Tangent. Move your cursor until the arc displayed is the
one you want drawn and then click to draw the arc. For more information, see the “Drawing
Tangent Arcs” section earlier in this chapter.
6.

Click Backup any time to erase the last line segment or arc of your polyline. You can click Cancel
at any time to erase the polyline you’re drawing.

7.

Right-click to finish the polyline. If Closed is toggled on, the polyline is automatically closed. If
Closed is toggled off, your cursor is detached from the last point of the open polyline.

 To draw a polyline that is both closed and covered:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears. Closed is toggled on by default, allowing you to draw a
polyline that will automatically be closed when you’re finished selecting points. You are
prompted to Select first point on polyline.

2.

Toggle Covered on in the Polyline menu.

3.

Draw the polyline. Right-click when you are finished.

4.

Select Object Viewer from the View pull-down menu to look at the covered polyline from all
angles.

(Pro) Using Contour Search
Contour search (Cont. Search) is an option that is available in the Curves, Polyline, Hatching, and
Boundary menus. With this tool, you can easily create outlines for fills and hatches. It automatically
searches for the boundaries of a closed shape (including line/arc and arc/arc conditions) and creates a
polyline around it. For example, contour search can find the edges of your walls in plan view so that you
can add a hatch pattern to your drawing.
 To search for the contour of a closed polyline:
1.

Make sure you have a closed polyline in your drawing window.

2.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

3.

Click on Cont. Search from the Polyline menu. You are prompted to Select point inside/outside
contour.
Hint: You can press (K) to change the color if you want the contour to be obvious.

4.

Click an entity along the boundary of the closed polyline or entity. DataCAD creates a closed
polyline that corresponds to the original closed polyline. Alternatively, you can place the cursor
within a closed group of lines. DataCAD searches for the boundary and draws a closed polyline
around the perimeter.
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You can also select Hatching from the Utility menu, select Boundary from the Hatching menu, and click
on Cont. Search. Then, click on the boundary of the closed polyline or entity so that DataCAD can draw
around its perimeter.

(Pro) Editing Polylines
You can edit any polyline in your drawing. You can add or delete a vertex, convert line segments to
curves and curves to line segments, move a vertex, convert the entire polyline into lines and arcs, modify
arcs in the polyline, convert lines and arcs into a polyline, or open or close a polyline. A vertex is the point
where two segments of the polyline intersect, usually marked with a point.
In 3D views, 2D lines are limited. You can turn the 2D lines into exploded polygons.

(Pro) Converting Polylines
You can convert a polyline to standard lines and curves, and conversely you can convert lines and arcs
into a single polyline. You can also convert an open polyline to a closed one. A polyline is considered a
single entity by DataCAD. You cannot convert a single line or arc that is part of a polyline; you must
convert the entire polyline.
 To convert a polyline into standard lines and arcs:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Poly to Line in the Edit menu. You are prompted to Select entity to explode from polylines to
lines and arcs.

4.

Move your mouse over one of the lines or vertices of the polyline and click. The polyline is
exploded.

 To convert lines and arcs into a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Line to Poly in the Edit menu. You are prompted to Select start point of polyline.

4.

Toggle Keep Lines on to retain the original lines and arcs and draw a polyline on top of them;
toggle Keep Lines off to convert the lines and arcs to a polyline.

5.

Move your mouse over one of the lines or vertices of the polyline and click. Dots are drawn at
each vertex of the new polyline and its perimeter, area, and volume appear in the Attention
toolbar.
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 To open or close a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Close in the Edit menu. You are prompted to Select polyline to close.

4.

Move your mouse over the polyline and click. A line segment is added to the polyline, closing it.

 To convert a closed shape to a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Cont. Search in the Polyline menu. The Cont. Search menu appears and you are
prompted to Select point inside/outside contour.

3.

Click inside the area you want to convert or click outside the area. If contour search finds an area
enclosed by lines, a polyline is created, tracing those lines. If contour search cannot find a
completely enclosed area, the message Contour is not closed appears in the Attention toolbar; you
must search again or use another method to define the boundary.

 To convert a closed polyline to a polygon or slab:
1.

Select 3D Menus from the Edit menu. This displays the 3D Menus.

2.

Click on Explode. The Explode menu appears.

3.

Select To Polygons if you want to convert the polyline to a polygon; alternatively, select TTF->
Slab if you want to convert the polyline to a slab. These are mutually exclusive toggle switches.
Select entity to <EXPLODE> appears in the Message toolbar.

4.

Click on the closed polygon you want to convert.

(Pro) Editing Polyline Vertices
You can add, delete, or move a vertex on a polyline. The Move Vertex option lets you move a vertex
freely; the Drag Vertex option preserves the angle of the existing vertex while letting you move it.
 To add a vertex to a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Add Vertex in the Edit menu. You are prompted to Select edge to which to add vertex.

4.

Toggle Info on at the bottom of the Edit menu to display the area and perimeter of the polyline as
you position the new vertex.

247

248 | DRAWING OTHER GEOMETRY
5.

Move your mouse over the line or arc segment of the polyline that you want to add the vertex to
and click. Notice your cursor is now attached to the segment; this point will be the new vertex.

6.

Move your mouse to position the new vertex and click or use coordinate entry to enter the vertex
position. The new vertex is added and the polyline is modified.

7.

Repeat steps 4 and 5 to continue adding vertices to polylines in your drawing. To exit this
function, click on another Edit menu option or right-click until the Polyline menu appears again
in the Menu Window.

 To delete a vertex from a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Del. Vertex in the Edit menu. You are prompted to Select vertex to be deleted.

4.

Move your mouse over the vertex that you want to delete and click. The vertex is deleted and the
polyline is modified.

5.

Repeat the previous step to continue deleting vertices from polylines in your drawing. To exit
this function, click on another Edit menu option or right-click until the Polyline menu appears
again in the Menu Window.

 To move a vertex on a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Move Vertex in the Edit menu. You are prompted to Select vertex to be moved.

4.

Toggle Info on at the bottom of the Edit menu to display the area and perimeter of the polyline as
you reposition the vertex.

5.

Move your mouse over the vertex that you want to move, and click. Your cursor is now attached
to the vertex you selected.

6.

Move your mouse to reposition the vertex and click; you can also use coordinate entry to
precisely position the vertex. The new vertex is moved and the polyline is modified.

7.

Repeat steps 4 and 5 to continue moving vertices on polylines in your drawing. To exit this
function, click on another Edit menu option or right-click until the Polyline menu appears again
in the Menu Window.

 To move a vertex dynamically:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.
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2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Drag Vertex in the Edit menu. You are prompted to Select vertex to be moved.

4.

Toggle Info on at the bottom of the Edit menu to display the area and perimeter of the polyline as
you reposition the vertex.

5.

Move your mouse over the vertex that you want to move and click. Your cursor is now attached
to the vertex you selected.

6.

Move your mouse to reposition the vertex and click; you can also use coordinate entry to
precisely position the vertex. For more information on coordinate entry, see “Drawing Using
Coordinate Entry” in “The Drawing Board” chapter. The vertex is moved and the polyline is
modified.

7.

Repeat steps 4 and 5 to continue moving vertices on polylines in your drawing. To exit this
function, click on another Edit menu option or right-click until the Polyline menu appears again
in the Menu Window.

(Pro) Editing Polyline Arcs
 To edit an arc in a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Drag Arc in the Edit menu. You are prompted to Select arc to be modified.

4.

Toggle Info on at the bottom of the Edit menu to display the area and perimeter of the polyline as
you reposition the arc.

5.

Move your mouse over the arc you want to edit and click. Notice that your cursor is now
attached to the arc.

6.

Move your mouse to change the arc and then click. The new arc is drawn and the polyline is
modified. You can also use coordinate entry to edit the arc. For more information on coordinate
entry, see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter.

7.

Repeat steps 4 and 5 to continue editing arcs on the polyline. To exit this function, click on
another Edit menu option or right-click until the Polyline menu appears again in the Menu
Window.

(Pro) Editing Polyline Edges
You can drag a polyline’s edge to a new position or delete an edge entirely.
 To reposition a line in a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.
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3.

Click on Drag Edge in the Edit menu. You are prompted to Select an edge to drag.

4.

Toggle Info on at the bottom of the Edit menu to display the area and perimeter of the polyline as
you reposition the edge.

5.

Move your mouse over the edge you want to edit and click. Notice that your cursor is now
attached to the line.

6.

Move your mouse to change the line’s position and then click. The new edge is drawn and the
polyline is modified. You can also use coordinate entry to edit the edge. For more information on
coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter.

7.

Repeat steps 4 and 5 to continue editing edges on the polyline. To exit this function, click on
another Edit menu option or right-click until the Polyline menu appears again in the Menu
Window.

 To delete an edge from a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Del. Edge in the Edit menu. You are prompted to Select edge to be deleted.

4.

Move your mouse over the edge you want to delete and click. The edge is deleted.

5.

Repeat the previous step to continue deleting edges on the polyline. To exit this function, click on
another Edit menu option or right-click until the Polyline menu appears again in the Menu
Window.

(Pro) Converting Polyline Edges and Arcs
You can convert an edge (or line) in a polyline to an arc or, conversely, convert an arc to a straight edge.
Both of these actions can be done with a single menu option: the Arc To Edge option simply converts any
polyline segment you click on. So if you click on an arc, this function will automatically change it to a
straight line segment; and if you click on an edge, it will convert it to an arc, which you can then define by
dragging it into position.
 To convert an arc to a straight edge or an edge to an arc:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Arc To Edge in the Edit menu. You are prompted to Select edge/arc to be modified.

4.

Toggle Info on at the bottom of the Edit menu to display the area and perimeter of the polyline as
you convert the edge or arc.

5.

Move your mouse over the edge or arc that you want to convert and click.


If you clicked on an arc, it is converted into a straight edge.
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6.

If you clicked on an edge, it is converted into an arc; move your mouse to position the arc and
click.

Repeat the previous step to continue converting arcs or edges. To exit this function, click on
another Edit menu option or right-click until the Polyline menu appears again in the Menu
Window.

(Pro) Changing the Polyline Cover Toggle
If you created an uncovered polyline, you can use the Toggle Cover option in the Polyline/Edit menu to
add a top and bottom cover. Conversely, if you created a covered polyline, you can use the Toggle Cover
option in the Polyline/Edit menu to remove the top and bottom covers. Remember that only closed
polylines can be covered; you cannot cover open polylines.
 To add or remove a cover for a closed polyline:
1.

Use the Object Viewer to find the closed polyline that you want to cover or uncover. Either select
Object Viewer from the View pull-down menu or click on the
icon in the Viewer toolbar.
Once you have identified the correct closed polyline, click on the X in the upper right corner of
the Object Viewer to return to your Drawing Area.

2.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

3.

Click on Edit in the Polyline menu. The Edit menu appears.

4.

Click on Toggle Cover in the Edit menu. You are prompted to Select polyline to add/remove the
cover.

5.

Click on the closed polyline you identified in step 1. Use the Object Viewer again to make look at
the closed polyline that you changed; then close the Object Viewer.

6.

Repeat the previous step to continue adding or removing covers. To exit this function, click on
another Edit menu option or right-click until the Polyline menu appears again in the Menu
Window.

(Pro) Editing Polyline Corners with Fillet or Chamfer
You can connect any two nonparallel edges in a polyline with either an arc or a line. The Fillets option
connects two edges with an arc, automatically adjusting the line segments to match the arc radius and, if
indicated, cleaning up the line extensions to form a smooth curve. Chamfer clips the corners of
rectangular groups, connecting two joined sides with a line. By default, DataCAD uses a distance of 1’-0”
for the first and second chamfer distance.
 To edit the vertices of polylines:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu; then, choose one of these options, depending on what type of
vertex you want:
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3.



Fillets

Clicking on Radius lets you control the fillet.



Chamfer

Clicking on Distances and selecting two values lets you control the chamfer.

Select the first edge of the polyline you want to fillet or chamfer. Then click on the second.

 To connect two lines with an arc:
1.

Click on Cleanup in the Edit menu in the Menu Window.

2.

Choose Fillets from the Cleanup menu. The following options appear in the Fillets menu:


Radius

Sets the fillet radius. To join two nonparallel, nonintersecting lines, accept the
standard radius of zero. This extends the lines to intersect. After you set the
radius, DataCAD saves it with the drawing file until you modify it again.



Clip

Trims (erases) the line segments extending past the intersection of the
selected lines; set Clip prior to selecting the entities to fillet.



Layer Search

Scans all layers during selection operations when toggled on.

Shortcut: Press (Alt) + (F) to access the Fillets menu.
3.

Select the first line to trim. For more information on using selection menus, see “Selection
Menus” in “The Drawing Board” chapter.

4.

Select the second line to trim. DataCAD creates a fillet at the intersection.

 To connect two lines with a line:
1.

Click on Cleanup in the Edit menu in the Menu Window.

2.

Choose Chamfer from the Cleanup menu. The following options appear in the Chamfer menu:


Distances

Sets the first and second chamfer distance.



Clip

Trims (erases) the line segments extending the intersection of the selected
lines to chamfer.



Layer Search

Scans all layers during selection operations when toggled on.

3.

Select the first line to trim. For more information on using selection menus, see “Selection
Menus” in “The Drawing Board” chapter.

4.

Select the second line to trim. A chamfer is created at the intersection of the two lines.

(Pro) Measuring Polylines
You can measure the area or perimeter of a closed polyline. If you are measuring land, you can use the
Acres option. In addition, you can find the closed polyline’s centroid.
 To measure the area or perimeter of a closed polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Area/Per. In the Edit menu. The Area/Per. menu appears.

4.

Click on Select in the Area/Per. menu. You are prompted to Select polyline or circle for area/perimeter
calculation.
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5.

Click on the closed polyline you want to measure.

6.

Select the appropriate toggles. The Perim. + and Perim. - options are mutually exclusive as are the
Area + and Area - toggles.


Acres

Displays the area within the closed polyline as acreage.



Perim. +

Displays the perimeter of the closed polyline.



Perim. -

Subtracts the perimeter of a void contained within a closed polyline. This is
useful with windows and doors in elevations.



Area +

Displays the area of the closed polyline.



Area -

Subtracts the area of the void(s) contained within a closed polyline.

7.

Toggle on Cont. Search.

8.

Click on the closed polyline you want to measure. DataCAD traces the contour of the polyline
and displays the measurement information in the Attention toolbar.

 To find the centroid of an irregular closed polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Edit in the Polyline menu. The Edit menu appears.

3.

Click on Area/Per. in the Edit menu. The Area/Per. menu appears.

4.

Select Cont. Search from the Area/Per. menu. You are prompted to Select point inside/outside
contour.

5.

Click on the closed polyline whose centroid you want to find. The polyline is highlighted.

6.

Select Centroid. You are prompted to Select centroid function.

7.

Click on Show It to simply display a temporary crosshair or choose Add to put an actual dot in
the center of your closed polyline.

Voids in Polylines
You can add voids to or erase voids from polylines as well as convert voids to polygons. To add a
polyline void, you must first draw the closed master polyline (to which you want to add the void); then,
draw the closed polyline that represents the void itself. For example, in a building elevation that you
want to hatch, you would create a master polyline around the perimeter of the elevation. Then, you
would draw closed polylines around each of the windows and doors; these would become voids or areas
that you wouldn’t want to hatch.
 To add a void to a polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Draw your master, closed polyline. Then, draw the closed polyline(s) that will become your
void(s) within that master polyline.
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3.

Click on Voids in the Polyline menu. You are prompted to Select master polyline to process voids.

4.

Click on the closed master polyline that you want to put the void in. DataCAD puts dashed lines
around that shape. You are prompted to Select entity to select polylines to convert to voids.

5.

Make sure Entity and Add Void are toggled on in the Voids menu.

6.

Click on the polyline that will represent the void. The void is added. Dashed lines surround the
void.

7.

Continue selecting other closed polylines within the master if necessary.

You could easily hatch the polyline with voids. Just select Hatching from the Utility menu; click Pattern,
choose one of the options, and press (Enter); then click on the polyline you want to hatch and select Begin
from the Hatching menu. The area within the master polyline is hatched, but the voids are not.
Alternatively, you could fill the master polyline with solid fills or bitmaps.
 To erase a void polyline:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Voids in the Polyline menu. You are prompted to Select master polyline to process voids.

3.

Click on the master polyline that contains the void(s) you want to erase. The Voids menu
appears.

4.

Toggle Erase Void on. You are prompted to Select polyline to delete from drawing.

5.

Click on a void to erase it. If you want to eliminate more voids, click on them, too.

 To convert a void to a polygon:
1.

Click on Curves in the Edit menu in the Menu Window to display the Curves menu; then click on
Polyline. Or click on
in the Draw toolbar and select
from the dropdown options to display the Polyline menu. You can also select Polyline from the Create pulldown menu; the Polyline menu appears.

2.

Click on Voids in the Polyline menu. You are prompted to Select master polyline to process voids.

3.

Click on the master polyline. The Voids menu reappears.

4.

Toggle Convert Void on. You are prompted to Select void convert to polyline.

5.

Click on a void to convert it. The polyline remains, but the void is gone.

(Pro) Drawing Stairs
The Stairs tool in the DCAD_AEC macro creates basic 2D single- and double-run stairs.
 To draw stairs:
1.

Click on DCAD_AEC in the Toolbox pull-down menu. The DCAD AEC menu appears. If
DCAD_AEC is not listed in the Toolbox pull-down menu, see “Customizing the Macros Menu”
in “The Drawing Board” chapter for details on how to add it to the menu. The Stairs menu
appears.

2.

Click on Stairs in the DCAD AEC menu.
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3.

Click on Up Only to draw stairs going up, click on Dn Only to draw stairs going down, or click
on UpAndDn to draw bidirectional stairs.

4.

Click on Up Left to draw stairs going up on the left side of the stair well or click on Up Rght to
draw stairs going up on the right side of the stair well.

5.

Customize stair options if necessary:


To set the number of stair risers, click on NumRiser. Use the value menu or type a number
and press (Enter). For more information on using value menus, see “Value Menus” in “The
Drawing Board” chapter.



To set the distance from the railing to the first riser, click on Offset. Use the value menu or
type a number and press (Enter).



To set the stair width including newel posts and stringers, click on StrWidth. Use the value
menu or type a number and press (Enter).



To set the width of the stair treads, click on TrdWidth. Use the value menu or type a number
and press (Enter).



To set the nosing overhang, click on Nosing. Use the value menu or type a number and press
(Enter).



To set the color of the stairs, click on Color and use the color menu. For more information on
setting colors, see “Color Menus” in “The Drawing Board” chapter.

6.

Click on Rails to customize the stair railings. Railing options appear in the Menu Window. For
details on railing options, see “Stair Railing Options” below. You are prompted to Select railing
option.

7.

Click on a railing option to change the setting.

8.

Click on StrWell to customize the stair well. Stair well options appear in the Menu Window. For
details on stair well options, see “Stair Well Options” on the following page. You are prompted to
Select stair well option.

9.

Click on a stair well option to change the setting. Right-click to return to the Stairs menu when
you are finished changing stair well settings.

10. Click on SectnLin to customize the section lines that are drawn when UpOnly or UpAndDn is
toggled on. Section line options appear in the Menu Window. For details on section line options,
see “Section Line Options” on the following page. You are prompted to Select stair variable option.
11. Click on a section line option to change the setting. Right-click to return to the Stairs menu when
you are finished changing section line settings. You are prompted to Enter starting location of stair.
12. Click in the Drawing Area or use coordinate entry and press (Enter). For more information on
coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter.
Notice that your cursor is now attached to the point you just entered. You are prompted to Enter
point along stairs.
13. Enter a point along the stair line by clicking in the Drawing Area or using coordinate entry and
pressing (Enter). You are prompted to Point to inside of stair well.
14. Click to indicate the inside of the stair well. The stairs are drawn.
(Pro) Stair Railing Options
DrwRail
Diameter

Toggle on to draw railings.
Set the railing diameter; use the value menu or type a number and press (Enter).
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Clearnce

Set the clearance from the wall (the space between the railing and the wall); use the value menu or type
a number and press (Enter).
Set the railing runout (the extension past the last tread); use the value menu or type a number and press
(Enter).
Set the color of the railings using the color menu. For more information on setting colors, see “Color
Menus” in “The Drawing Board” chapter.

RunOut
Color

(Pro) Stair Well Options
DrwWell
LandLnth
ChseWdth
Color

Toggle on to draw stair wells.
Set the stair landing length; use the value menu or type a number and press (Enter).
Set the chase width (the distance between stair wells); use the value menu or type a number and press
(Enter).
Set the color of the stair wells using the color menu.

(Pro) Section Line Options
GapWidth
LinAngle
LinColor
DashSpcg

Set the width of the gap between section lines; use the value menu or type a number and press (Enter).
Set the angle of section lines; use the value menu or type a number and press (Enter).
Set the color of section lines using the color menu.
Set the dashed line spacing; use the value menu or type a number and press (Enter).

(Pro) Drawing Elevators
With the Elevator option in the DCAD_AEC macro, you can draw a single elevator or banks of elevators.
Start by customizing the capacities, doors, shaft walls, and cabs of the elevator banks, then select points to
draw the elevators.
 To draw elevators:
1.

Click on DCAD_AEC in the Toolbox pull-down menu. The DCAD AEC menu appears.

2.

Click on Elevator in the DCAD AEC menu. The Elevator menu appears; use the Num Cab,
Capacity, Cab, Walls, Doors, ByFront, and ByBack options to customize your elevators.

3.

Click on Num Cab. A value menu appears and you are prompted to Enter number of elevator cabs.

4.

Type the number of elevator cabs you want in the bank of elevators or use the value menu to
enter the number of cabs and press (Enter).

5.

Click on Capacity. A list of capacity values in pounds appears in the Menu Window. You are
prompted to Select standard elevator capacity.

6.

Click on the capacity value. Based on the capacity value you choose, DataCAD automatically
resizes the elevator dimensions to match those found in Architectural Graphic Standards;
however, you can modify these dimensions using the Cab, Walls, and Doors options. You are
returned to the Elevator menu.

7.

Click on Cab to customize the elevator cab. Cab options appear. You are prompted to Select cab
variable to change.

8.

Click on a cab option to change the setting. For all cab options except Color, a value menu listing
clearance distances appears; when you click on Color, a color menu appears.

9.

Use the value menu to enter a clearance distance for the cab option or type a new value and press
(Enter); use the color menu to select a color for the elevator cab lines.

10. Click on Walls to customize the elevator shaft walls. Walls options appear. For details on Walls
options, see “Elevator Shaft Wall Options” below. You are prompted to Select wall variable to
change.
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11. Change wall dimensions by clicking on Front, Back, Left, Right, or Between. A value menu listing
wall dimensions appears. Use the value menu to enter a dimension for the wall option or type a
new value and press (Enter).
12. Click on Doors to customize the elevator doors. Door options appear. For details on Doors
options, see “Elevator Door Options” below. You are prompted to Select door variable to change.
13. Click on a door option to change the setting.
14. Position the elevator bank by defining the front or the back wall. When you toggle ByFront on,
the two points you select in the following steps define the outside face of the front elevator shaft
wall; when you toggle ByBack on, the two points you select will define the outside face of the
back elevator shaft wall. Only one of the options, ByFront and ByBack, can be toggled on at any
one time. If ByFront is toggled on, you are prompted to Enter one front corner of elevator bank. If
ByBack is toggled on, you are prompted to Enter one back corner of elevator bank.
15. Begin drawing the elevator banks. To select the corner of the elevator bank, click in the Drawing
Area or use coordinate entry. For more information on coordinate entry, see “Drawing Using
Coordinate Entry” in “The Drawing Board” chapter. (The elevator bank will be drawn starting at
this corner.) Your cursor is now attached to this point, and you are prompted to Indicate direction
of elevator bank.
16. Notice the “direction” of the elevator bank or the bearing of the row of elevators. Position the line
now attached to your cursor so that it’s parallel to the front and back of the elevator bank and
click. You are prompted to Point to back side of elevator bank if ByFront is toggled on; you are
prompted to Point to front side of elevator bank if ByBack is toggled on.
17. Click anywhere towards the front or back of the bank, as prompted. The bank of elevators is
drawn.
(Pro) Elevator Cab Options
ClearFrt
ClearBck
ClearLft
ClearRht
ClearBtw
CabWidth
CabDepth
Color

Set the clearance distance between the front of the elevator cab and the inside face of the elevator shaft
wall.
Set the clearance distance between the back of the elevator cab and the inside face of the elevator shaft
wall.
Set the clearance distance between the left side of the elevator (as you face the back of the cab) cab and
the inside face of the elevator shaft wall.
Set the clearance distance between the right side of the elevator cab and the inside face of the elevator
shaft wall.
Set the clearance distance between elevator cabs when the separating shaft wall between the cabs is not
drawn.
Set the width of the elevator cab using the value menu.
Set the depth of the elevator cab using the value menu.
Set the color of the elevator cab lines using the color menu. For more information on setting colors, see
“Color Menus” in “The Drawing Board” chapter.

(Pro) Elevator Shaft Wall Options
Front
Back
Left
Right
Between

Set the width of the front wall of the elevator shaft using the value menu.
Set the width of the back wall of the elevator shaft using the value menu.
Set the width of the left wall of the elevator shaft using the value menu.
Set the width of the right wall of the elevator shaft using the value menu.
Set the width of the wall between elevator cabs using the value menu.
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DrwBack

DrwCntr

Color

Toggle on to draw the back wall of the elevator shaft when the elevator banks are drawn; when toggled
off, the back wall of the elevator shaft is not drawn and the side walls of the elevator shaft are extended
a distance equal to half the width of the back wall (in other words, side walls are drawn to the center
line of the back wall). Toggling DrwBack off allows for easy creation of back-to-back elevator banks
since two halves of a back wall put together equal one party wall between back-to-back cabs.
Toggle on to draw the elevator shaft wall between elevators when the elevator banks are drawn; when
toggled off, these center walls are not drawn. Toggling DrwCntr on increases the center-to-center
distance between elevators.
Set the color of the elevator shaft walls using the color menu.

(Pro) Elevator Door Options
None
Single
Double
Lap
AtFront

AtBack
Alternat

Width
Thickness
Offset

Color

Toggle on to draw elevators without doors.
Toggle on to draw elevators with single doors.
Toggle on to draw elevators with double doors.
Toggle on to draw elevators with overlapping doors.
Toggle on to draw doors at the front of the elevator bank. Toggle both AtFront and AtBack on to draw
elevators with doors at both the front and the back of the elevator bank. Toggling both options off is the
equivalent of toggling None on: no elevator doors are drawn.
Toggle on to draw doors at the back of the elevator bank.
Toggle on to alternate drawing overlapping doors, with the left panel outside and the left panel inside,
on every other elevator; when the door is offset from the center of the cab (using the Offset option),
toggling Alternat on causes the first elevator to be drawn with the doors offset to the right, and the next
to be drawn with the doors offset to the left, creating the effect of pairs of elevators based on the
proximity of their doors.
Set the width of the elevator doors using the value menu.
Set the thickness of the elevator doors using the value menu.
Elevator doors are drawn off-center by the distance specified. The offset distance is the distance along the
front wall from the center of the cab to the center of the elevator door. An offset distance of 1’-0” center
the door one foot to the right of the center of the cab, while an offset distance of -1’-0” centers the door
one foot to the left of the center of the cab.
Set the color of the elevator doors using the color menu. For more information on setting colors, see
“Color Menus” in “The Drawing Board” chapter.

Chapter 10 Other Ways to
Draw
Drawing lines and entering points directly in the Drawing Area
are the most common ways of drawing. However, DataCAD has
other tools that can significantly increase your productivity and
even the accuracy of your drawings.
The Copy and Mirror options in the Edit menu are two such tools
that can add entities to your drawing with just a few steps,
freeing you from drawing similar things over and over.
DataCAD even offers a tool that can be used to sketch your ideas
before you begin drawing. With the Freehand tool in the Utility
menu, you can sketch in a variety of line widths and line types.

10

In this chapter:

 Copying entities
 Making multiple

copies of entities

 Mirroring entities
 Freehand Sketching
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Copying Entities
There are several ways to copy DataCAD entities. The Copy option in the Edit pull-down menu (grouped
with Cut and Paste) is a standard Windows command and can be used to quickly copy entities to other
DataCAD drawings or to other Windows applications. For details on how to use Cut, Copy, and Paste,
see “Basic Editing Tools” in “The Drawing Board” chapter.
The Copy option in the Edit menu in the Menu Window (also available just below the Move option in the
Edit pull-down menu) duplicates entities at a specified distance within the same drawing. With this
option, you can:


copy entities at a distance and angle that you set,



copy entities by dragging them,



copy entities to a different layer in your drawing, or



make multiple copies of selected entities, arranged in rectangular or circular arrays.

To copy entities in the Z direction, use the Move Z option in the Move menu. See “Moving Entities” in the
“Editing Drawings” chapter for details.
You can also use the

icon in the Edit toolbar to copy drawing entities. When you click on this icon,

three options appear in a drop-down menu:
Shortcut: To access the Copy menu, press (C) or (Shift) + (C).

Copying Entities a Specified Distance and Angle
When you use Copy in the Edit menu in the Menu Window, you are prompted to enter two points. The
distance between these two points will be the distance the copy is drawn from the original entity you
selected; the angle defined by these two points will be the angle the copy is drawn from the original one.
 To copy an entity a specified distance and angle:
1.

Click on Copy in the Edit menu in the Menu Window, or click on Copy (located just below Move)
in the Edit pull-down menu, or click on

in the Edit toolbar and select

from the drop-down options. The Copy menu appears and you are
prompted to Select first point of the distance to copy. To use the same distance and angle as the last
time you used Copy, click on Prev. Dist.
2.

Click in the Drawing Area or use coordinate entry to enter the first point. A directional arrow
appears; notice that moving your mouse changes the length and angle of the arrow. You are
prompted to Select second point of the distance to copy. The points you select in steps 2 and 3 can be
selected anywhere on the screen; they indicate the distance and angle to copy only; these are not
the beginning and ending points of the copy.

3.

Click in the Drawing Area or use coordinate entry to enter the second point. For more
information on using coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter. A selection menu as well as other Copy options appear.

4.

Click on a selection method in the menu. For more information on using selection menus, see
“Selection Menus” in “The Drawing Board” chapter. You are prompted to select the entities you
want to copy.
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5.

Select the entities; they are copied in the drawing. You can continue selecting entities to make
additional copies at the same distance and angle.

6.

Copy entities at the same distance and angle but in the opposite direction by clicking on Invert
and then selecting the entities to be copied (see Figure 10.1).

7.

Enter a new distance and angle by clicking on New Distance and continuing with step 2 above.

Invert

Original

Copy

Figure 10.1: Inverting a copy

Copying Entites by Dragging
Instead of entering a specific distance and angle to copy entities, you can simply drag the copy any
distance and at any angle.
 To copy entities by dragging them:
1.

Click on Copy in the Edit menu in the Menu Window, or click on Copy (located just below Move)
in the Edit pull-down menu, or click on

in the Edit toolbar and select

from the drop-down options. The Copy menu appears.
2.

Click on Drag in the Copy menu. The Drag menu appears.

3.

Toggle Layer Search on if the entities you want to copy are on a different layer than the active
layer.

4.

Drag complex entities more smoothly by setting the maximum number of lines to be displayed
while dragging. Click on Max. Lines and use the value menu to enter the number of lines. Press
(Enter) or right-click to return to the Drag menu. When the entities you selected to drag contain
more lines than the Max. Lines setting, a rectangular box representing the selected entities
appears when you begin to drag them. The entities reappear after you select the new location for
them. When you set Max. Lines to 0, the rectangular box is always displayed while dragging.

5.

Toggle Multiple on to make multiple selections of entities to be copied.

6.

Click on a selection method in the menu. You are prompted to select the entities you want to
copy.

7.

Select the entities to be copied. You are prompted to Select the point to drag from.

8.

Check the button for Multiple. If it is toggled off, skip to step 9. If you toggled Multiple on in step
5, click on Begin and continue with step 9.

9.

Click on a point in the Drawing Area; you can also use coordinate entry or object snapping to
select this point. For more information on using coordinate entry, see “Drawing Using
Coordinate Entry” in “The Drawing Board” chapter. You are prompted to Select new position for
these entities.

10. Move your mouse to drag the entities to their new position and click to place them. The entities
are copied in the drawing. You can copy the same entities and place them in another position by
repeating this step. Right-click when you are finished copying.
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Copying Entities at the Perpendicular
You can copy an entity a specific distance from and perpendicular to the original. While you can’t copy
an entity at any angle, as you can with the Copy function described above, this is a very straightforward
way to quickly make one entity into an entire row.
 To copy an entity perpendicular to the original:
1.

Click on Geometry in the Tools pull-down menu and then click on Offset in the extended menu.
You can also click on Geometry in the Utility menu and select Offset in the Geometry menu.
Alternatively, click on the

2.

icon in the Edit toolbar. The Offset menu appears.

Set the copy distance using one of the following methods:


You can toggle Dynamic off (if it’s toggled on) and define the distance just as you did in steps
2 and 3 in “Copying Entities a Specified Distance and Angle.” Click in the Drawing Area or
use coordinate entry to select two points to define the distance.



You can toggle Dynamic on (if it’s toggled off); you’ll be able to see the position of the copy
before you place it in your drawing.



You can click on Perp. Dist. to display a value menu. Use the value menu or type distance
and press (Enter). If Perp. Dist. is already toggled on, toggle it off and on again to display the
value menu.

You are prompted to Select object of offset.
3.

Toggle Layer Search on if the entities you want to copy are on a different layer than the active
layer.

4.

Click on the entity you want to copy. The selected entity appears in dashed lines. If you toggled
Dynamic on in step 2, a copy of the entity is attached to your cursor. You are prompted with
Offset to which side?

5.

Click to one side or the other of the original entity. The copy is placed.

6.

Continue copying entities by repeating steps 4 and 5; or if Dynamic is toggled on, simply repeat
step 5. To redefine the offset distance, click on New Distance and continue with step 2 above.

Copying to Another Layer
When you have more than one layer in your drawing, the To Layer option appears in the Copy menu. To
Layer is used to copy entities from one layer to another in your drawing. You can copy entities in the
same position as the original layer (no distance and angle entered) or you can copy entities to another
layer at a specified distance and angle. For more information on creating layers, see “Creating Layers” in
the “Before You Draw” chapter.
 To copy entities to another layer without changing their positions:
1.

Click on Copy in the Edit menu in the Menu Window. Or click on Copy (located just below
Move) in the Edit pull-down menu. Or click on

in the Edit toolbar and select

from the drop-down options. The Copy menu appears.
2.

Click on To Layer in the Copy menu. A list of all the layers in your drawing appears and you are
prompted to Select layer to copy to.
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3.

Click on the layer you’d like to copy entities to or type the name of the layer and press (Enter). If
your drawing has many layers, you can use the Match and Filter options in the To Layer menu to
select or find the layer you want to copy to. For details on how to use these options, see
“Selecting Layers Without Using Layer Names” and “Searching for Layers” in the “Before You
Draw” chapter.

4.

Click on a selection method in the menu. You are prompted to select the entities you want to
copy.

5.

Select the entities; they are copied to the layer you chose in step 3. You can continue selecting
entities to make additional copies.

6.

Choose another layer to copy entities to by clicking on New Layer and continuing with step 3
above.

 To copy entities to another layer at a specific distance and angle:
1.

Click on Copy in the Edit menu in the Menu Window. Or click on Copy (located just below
Move) in the Edit pull-down menu. Or click on

in the Edit toolbar and select

from the drop-down options. The Copy menu appears. You are
prompted to Select first point of the distance to copy.
2.

Click in the Drawing Area or use coordinate entry to enter the first point. A directional arrow
appears; notice that moving your mouse changes the length and angle of the arrow. You are
prompted to Select second point of the distance to copy. The points you select in steps 2 and 3 can be
selected anywhere on the screen; they indicate the distance and angle to copy only; these are not
the beginning and ending points of the copy. To use the same distance and angle as the last time
you used Copy, click on Prev. Dist.

3.

Click in the Drawing Area or use coordinate entry to enter the second point. A selection menu as
well as other Copy options appears.

4.

Click on To Layer in the Copy menu. A list of all the layers in your drawing appears and you are
prompted to Select layer to copy to.

5.

Click on the layer you’d like to copy entities to or type the name of the layer and press (Enter). A
selection menu as well as other Copy options appears. For more information on using selection
menus, see “Selection Menus” in “The Drawing Board” chapter.

6.

Click on a selection method in the menu. You are prompted to select the entities you want to
copy.

7.

Select the entities; they are copied to the layer you chose in step 5. You can continue selecting
entities to make additional copies.

8.

Choose another layer to copy entities to if necessary. Just click on New Layer and continue with
step 5 above.

Copying Using Arrays
You can make multiple copies of an entity in a one-dimensional, rectangular, or circular array. A onedimensional array simply makes multiple copies in one direction. In a circular array, an entity is copied a
specified number of times at a specified angle of separation around a center of rotation.
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A rectangular array repeats an entity a specified number of times at a specified angle. You can copy an
array of elements in the X direction, the Y direction, or in both directions at the same time. The number of
X and Y repetitions determines the total number of entities in the array. An array of one X repetition and
one Y repetition has only one entity, the original. A two-by-two array has a total of four entities (see
figures 10.2 and 10.3). You can also change the angle of the X and Y axes to create a rectangular array at
the specified angle.
X R epetitions =3
Y R epetitions =1

Distance to C opy

R esult

Figure 10.2: Creating a rectangular array in only the X direction. You can also use Array in the
Copy menu to make multiple copies in only one direction. See the instructions for copying an
entity in a one-dimensional array below.

Distance to C opy

X R epetitions =1
Y R epetitions =4

Figure 10.3: Creating a rectangular array in only the Y direction. You can also use Array in the
Copy menu to make multiple copies in only one direction. See the instructions for copying an
entity in a one-dimensional array below.
 To copy an entity in a one-dimensional array:
1.

Click on Copy in the Edit menu in the Menu Window. Or click on Copy (located just below
Move) in the Edit pull-down menu. Or click on

in the Edit toolbar and select

from the drop-down options. The Copy menu appears. You are
prompted to Select first point of the distance to copy.
2.

Click in the Drawing Area or use coordinate entry to enter the first point. A directional arrow
appears; notice that moving your mouse changes the length and angle of the arrow. You are
prompted to Select second point of the distance to copy. The points you select in steps 2 and 3 can be
selected anywhere on the screen; they indicate only the distance and direction of each copy in the
array; these are not the beginning and ending points of the copy.

3.

Click in the Drawing Area or use coordinate entry to enter the second point.
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If you used the icon from the Edit toolbar in step 1, a value menu appears; skip to step 5. If you
used selected Copy from either the Edit menu in the Menu Window or the Edit pull-down menu,
a selection menu as well as other Copy options appear in the Menu Window; go to step 4.
4.

Click on Array in the Copy menu. A value menu appears and you are prompted to Enter the
number of repetitions.

5.

Use the value menu or type a number and press (Enter). You are prompted to select the entities
you want to copy.

6.

Select the entities; they are copied in the array you defined. You can continue selecting entities to
make additional copies.

 To copy an entity in a rectangular array:
1.

Click on Copy in the Edit menu in the Menu Window. Or click on Copy (located just below
Move) in the Edit pull-down menu. The Copy menu appears. Go to step 2.
Or click on
in the Edit toolbar and select
from the dropdown options. The Rect. Array menu appears. You are prompted to Select first point of the distance
to copy. Skip to step 3.

2.

Click on Rect. Array in the Copy menu. The Rect. Array menu appears and you are prompted to
Select first point of the distance to copy.

3.

Click in the Drawing Area or use coordinate entry to enter the first point. Two bi-directional
arrows appear, representing the X and Y axes. Notice that moving your mouse changes the
length and direction of the arrows; the length and direction of the arrows indicates the distance
and angle you want to copy entities at. You are prompted to Select second point of the distance to
copy. The points you select in steps 3 and 4 can be selected anywhere on the screen; they indicate
only the distance and direction of each copy in the array; these are not the beginning and ending
points of the copy. For more information on using coordinate entry, see “Drawing Using
Coordinate Entry” in “The Drawing Board” chapter.

4.

Click in the Drawing Area or use coordinate entry to enter the second point. A value menu
appears and you are prompted to Enter number of X-repetitions. For more information on using
value menus, see “Value Menus” in “The Drawing Board” chapter.

5.

Select the number of repetitions from the value menu or type a number and press (Enter). You are
prompted to Enter number of Y-repetitions.

6.

Select the number of repetitions from the value menu or type a number and press (Enter). The
Rect. Array menu offers selection methods and other options.

7.

Toggle Counter on in the Rect. Array menu to display on the Attention toolbar the number of
entities added each time you copy.

8.

Click on a selection method in the menu. You are prompted to select the entities you want to
copy.

9.

Select the entities; they are copied in the array you defined. You can continue selecting entities to
make additional copies.

10. Click on NewArray to define another rectangular array, then continue with step 3 above. If you
don’t want to define another array, right-click or click on Exit to return to the Edit menu.
Keep in mind that an array is a separate group from the original copied entity. If you use Group in the
selection menu and select an entity in an array, the entire array will be copied.
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X Repetitions = 4
' Y ' Distance
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To Copy
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Figure 10.4: Creating a rectangular array
 To copy an entity in a rectangular array set at an angle:
1.

Click on Copy in the Edit menu in the Menu Window. Or click on Copy (located just below
Move) in the Edit pull-down menu. The Copy menu appears. Go to step 2.
Or click on
in the Edit toolbar and select
down options. The Rect. Array menu appears. Skip to step 3.

from the drop-

2.

Click on Rect. Array in the Copy menu. The Rect. Array menu appears.

3.

Click on Angular in the Rect. Array menu. You are prompted to Select first point of the distance to
copy.

4.

Enter the angle for the X axis for the copy by defining the beginning and endpoints of a
directional arrow. The points you select for directional arrows can be selected anywhere on the
screen; they indicate only the distance and direction of each copy in the array and not the
beginning and ending points of the copy. Click in the Drawing Area or use coordinate entry to
enter the beginning point. A directional arrow appears; notice that moving your mouse changes
the angle of the arrow. You are prompted to Select vector indicating angle of array. For more
information on using coordinate entry, see “Drawing Using Coordinate Entry” in “The Drawing
Board” chapter.

5.

Click in the Drawing Area or use coordinate entry to enter the first point. Two bi-directional
arrows appear, representing the X and Y axes. Notice that moving your mouse changes the
length and direction of the arrows; the length and direction of the arrows indicates the distance
and angle you want to copy entities at. You are prompted to Select the second point of the distance to
copy. The points you select in steps 4 and 5 can be selected anywhere on the screen; they indicate
only the distance and direction of each copy in the array; these are not the beginning and ending
points of the copy. For more information on using coordinate entry, see “Drawing Using
Coordinate Entry” in “The Drawing Board” chapter.
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6.

Click in the Drawing Area or use coordinate entry to enter the second point. A value menu
appears and you are prompted to Enter number of X-repetitions. For more information on using
value menus, see “Value Menus” in “The Drawing Board” chapter.

7.

Select the number of repetitions from the value menu or type a number and press (Enter). You are
prompted to Enter number of Y-repetitions.

8.

Select the number of repetitions from the value menu or type a number and press (Enter). The
Rect. Array menu offers selection methods and other options.

9.

Toggle Counter on in the Rect. Array menu to display the number of entities added each time
you copy.

10. Click on a selection method in the menu. You are prompted to select the entities you want to
copy.
11. Select the entities; they are copied in the array you defined. You can continue selecting entities to
make additional copies.
12. Click on NewArray to define another rectangular array and continue with step 3 above. If you
don’t want to define another array, right-click or click on Exit to return to the Edit menu.
Keep in mind that an array is a separate group from the original copied entity. If you use Group in the
selection menu and select an entity in an array, the entire array will be copied.
 To copy an entity in a circular array:
1.

Click on Copy in the Edit menu in the Menu Window. Or click on Copy (located just below
Move) in the Edit pull-down menu. Or click on

in the Edit toolbar and select

from the drop-down options. The Copy menu appears.
2.

Click on Circ. Array in the Copy menu. The Circ. Array menu appears and you are prompted to
Select center point of array. For more information on circular array options, see “More About Circ.
Array Menu Options” later in this chapter.

3.

Click in the Drawing Area or use coordinate entry to enter the center point. A value menu
appears and you are prompted to Enter relative X-distance. For more information on using value
menus, see “Value Menus” in “The Drawing Board” chapter.

4.

Use the value menu or type a number and press (Enter). Another value menu appears and you
are prompted to Enter relative Y-distance.

5.

Use the value menu or type a number and press (Enter). Another value menu appears and you
are prompted to Select angle between items (+=CCW, -=CW). If you enter a positive angle, the array
will be copied in a counterclockwise direction; if you enter a negative angle, the array will be
copied in a clockwise direction.

6.

Use the value menu or type a number and press (Enter). Another value menu appears and you
are prompted to Enter number of objects in array.

7.

Use the value menu or type a number and press (Enter). The Circ. Array menu appears.

8.

Click on a selection method in the menu. You are prompted to select the entities you want to
copy.

9.

Select the entities; they are copied in the array you defined. You can continue selecting entities to
make additional copies. When you are finished, click on Exit or right-click to return to the Edit
menu.

267

268 | OTHER WAYS TO DRAW
Keep in mind that an array is a separate group from the original copied entity. If you use Group in the
selection menu and select an entity in an array, the entire array will be copied.
More About Using Z Elevations in Rectangular Arrays
The Z elevation can be increased or decreased incrementally with each repetition in a rectangular array.
In the Rect. Array menu, the Z Inc. X option sets the Z elevation in the X direction of an array, while the Z
Inc. Y option sets the Z elevation in the Y direction of an array. To set an incremental Z elevation for an
array that copies an entity in both the X and Y directions, set both options.
The Z Inc. X and Z Inc. Y options are set using value menus. For more information on using value menus,
see “Value Menus” in “The Drawing Board” chapter.
You can use the Z Inc. X and Z Inc. Y to generate such things as three-dimensional stairs with only a few
keystrokes (see Figure 10.5). You can also generate several three-dimensional floors of a building by
setting Z Inc. X or Z Inc. Y to the floor-to-floor height for the building and copying a rectangular array
with an X and Y distance of zero. This creates an array of floors, stacked one above the other.

X Repetitions = 1

Z Incr X = 0

Y Repetitions = 8

Z Incr Y = 8"

Figure 10.5: Creating 3D stairs with the incremental Z elevation options
More About Circ. Array Menu Options
You can change array settings, set a Z elevation for the array, and even rotate the entity copies using the
following Circ. Array menu options:
New Center Sets a new center for the array you are copying; click on New Center, select a new center point for the
array, and then select the entity to copy.
Obj. Center Sets a new center for the entity you are copying; click on Obj. Center, select a new center point for the
entity, and then select the entity to copy.
Sep. Angle Sets a new angle of separation between each entity in the array; click on Sep. Angle, enter a new angle,
and press (Enter).
No. Object Sets a new number of repetitions for the array; click on No. Object, enter a new number, and press
(Enter).
Z Increment Sets the Z elevation with each repetition in the array; click on Z Increment, enter a positive value to
increase the elevation or a negative value to decrease it, and press (Enter) (use this option to draw 3D
circular stairs).
Rotate
Toggle on to rotate each copy in the array by an angle equal to the angle of separation; toggle off to
leave the orientation of each copy in the array the same as the original entity.

Mirroring Entities
In some projects, being able to copy and mirror part of your drawing would save you a lot of time. For
instance, it would be far more efficient to draw only one side of a hotel corridor and mirror that side to
create the full corridor than it would be to draw both sides. The Mirror option in the Edit menu allows
you to do just that, mirroring geometry across a reflection line that you define.
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 To mirror entities:
1.

Click on Mirror in either the Edit menu in the Menu Window or the Edit pull-down menu. Or
click on the

icon (mirror only) in the Edit toolbar if you want to mirror the entity and move

it to the opposite side of the line of reflection. Or click on the
icon (mirror and copy) in the
Edit toolbar if you want to mirror the entity, copy it to the opposite side of the line of reflection,
and keep the original entity in its place. The Mirror menu appears and you are prompted to Select
first point along the line of reflection.
Shortcut: Press (Alt) + (M) to access the 2D Mirror menu.
Hint: You can use the same reflection line as the last time you used Mirror. Instead of defining a
new reflection line, click on Prev. Line in the Mirror menu. This displays the previous line of
reflection. The Prev. Line option is only available if you have used Mirror during the current
drawing session. If you want to keep the previous line of reflection, skip to step 5. If you want to
change the previous line of reflection, go to step 4.
2.

Click in the Drawing Area or use coordinate entry to select the first point of the reflection line.
You are prompted to Select second point along the line of reflection.

3.

Click in the Drawing Area or use coordinate entry to select the second point of the reflection line.
DataCAD draws a temporary, dashed line representing the reflection line. The Mirror menu
appears.

4.

Determine if the reflection line is not correct. If you want to change it, click on New Line, then
repeat steps 2 and 3 to create a new line of reflection.

5.

Mirror and copy the selected entities across the reflection line by toggling And Copy on. Toggle
And Copy off to mirror and move selected entities across the reflection line.
If you clicked on the
is toggled on.

icon, And Copy is toggled off; if you clicked on the

icon, And Copy

6.

Toggle Fix Text on to mirror the position of text but not its orientation. When Fix Text is toggled
off, text is mirrored and rotated 180 (see Figure 10.6).

7.

Click on a selection method. You are prompted to select the entities you want to mirror.

8.

Select the entities; they are mirrored across the reflection line you defined. You can continue
selecting entities to mirror. When you are finished, click on Exit or right-click to leave the Mirror
menu and return to the Edit menu.

Figure 10.6: Mirroring text with Fix Text toggled on (left) and toggled off (right)
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Freehand Sketching
You can use the Freehand option to sketch lines in varying widths and line types. When using line types
such as dotted or dashed, you can give a rendered or weighted quality to the lines by varying the speed
that you move the cursor across the Drawing Area as you draw. Sketching with Freehand works best if
you toggle both grid snapping and ortho mode off. Press (X) to toggle grid snapping off; press (O) to
toggle ortho mode off.
 To sketch:
1.

Click on Freehand in the Utility menu. The Freehand menu appears.
Shortcut: Press (Alt) + (H) to access the Freehand menu.

2.

Toggle Lines on to draw lines, toggle 3D Lines on to draw three-dimensional lines, or toggle
Polyline on to draw polylines. You can toggle only one of these three options on at any given
time.

3.

Toggle Closed on to automatically close the shape when you finish drawing.

4.

Click in the Drawing Area and then move your mouse to draw.

5.

Click to disconnect your cursor from the line when your sketch is complete. You can continue
drawing additional shapes.

6.

Click on Exit or right-click to return to the Utility menu.

11

Chapter 11 Drawing Tools
There are many tools in DataCAD to aid in drawing. Reference
points can be set anywhere in your drawing, giving you a precise
way to position new entities. Object snapping can help you add
entities to existing geometry quickly and accurately.
You can also identify and measure entities in your drawing to
retrieve information, such as what layer the entity is drawn on,
its line type and line weight, its length or angle, or even its area
or perimeter measurements.

In this chapter:

 Setting reference
points







Object snapping
Identifying entities
Measuring entities
Dividing entities
Editing entity
attributes
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Setting Reference Points
A reference point is used as a starting point for drawing. In DataCAD, there are two kinds of reference
points: floating and fixed.
Floating reference points are useful when you use relative coordinate entry methods to draw. They can be
set at any time, regardless of what menu appears or what you’re drawing. Floating reference points are
temporary and can be displayed and snapped to, but they can’t be plotted.
To see how floating reference points are used when drawing, see the “Tutorial: Drawing a Schoolhouse”
chapter, specifically the instructions on drawing interior walls and adding windows and doors to the
schoolhouse.
Fixed reference points are useful when you use absolute coordinate entry methods to draw. Absolute
coordinate entry uses absolute zero as a fixed point of reference: every time you enter a point using
absolute coordinate entry, the distances you enter are measured from absolute zero. With a fixed
reference point, you can use another point in your drawing, exactly as you would use absolute zero.
 To set a floating reference point:
1.

Click on Reference Point in the Tools pull-down menu. The Ref. Point menu appears.
Shortcut: Press (`) [located in the upper-left corner of most keyboards, just below (Esc)] to
quickly access the Ref. Point menu and set a reference point. After selecting a point, you are
automatically returned to the menu you were working in before you set the point.

2.

Click on Draw Marks to display a small “x,” representing the reference point.

3.

Click in the Drawing Area, use coordinate entry, or object snap to a point in your drawing to
select the reference point. The reference point is marked with a small “x.” Reference points are
displayed until you refresh your drawing by pressing (Esc).

 To set a fixed reference point:
1.

Click on Settings in the Utility menu. The Settings menu appears.

2.

Toggle Draw Marks on in the Settings menu if you want the fixed reference point marked with a
small “x.” Toggle Draw Marks off if you don’t want the small “x” to appear.

3.

Click on Fixed Ref. in the Settings menu. You are prompted to Select fixed reference point using
cursor.

4.

Click in the Drawing Area, use coordinate entry, or object snap to a point in your drawing to
select the reference point. If Draw Marks was toggled on in step 2, the reference point is marked
with a small “x.” Reference points are displayed until you refresh your drawing by pressing
(Esc).

5.

Right-click to exit the Settings menu. You can now continue drawing, using your fixed reference
point.

6.

Use absolute zero again if necessary. Instead of your fixed reference point, click on Settings in the
Utility menu, toggle Fixed Ref. off and then on again (click on the option twice); next, click on
Abs. Zero. Right-click to exit the Settings menu and continue drawing.

More About Setting Reference Points
Reference points can give you a quick way to draw very precisely. For example, to insert a window in a
wall 3’-0” from the corner of a room, you could create a reference point at that corner and then, using
relative Cartesian for coordinate entry, simply enter the distance (in this case, it is 3’-0”) from the
reference point.
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 To use a reference point, using this example:
1.

Make sure the current input mode is Relative Cartesian. You can do this in several ways: click on
Input Mode in the Tools pull-down menu and make sure Relative Cartesian is checked; check the
input mode in the Status Panel toolbar; or press (Ins) until Current input mode = Relative Cartesian
(x, y) appears in the Attention toolbar.

2.

Click on Window in the Create pull-down menu, or select Windows in the Edit/Architect menu,
or click on the

3.

icon in the Draw toolbar. The Windows menu appears.

Press (`); the Ref. Point menu appears.
Shortcut: To set a reference point using the mouse, press (Ctrl) and click. To set a reference
point at a specific point on an entity by object snapping to it, press (Ctrl) and click the middle
mouse button or press (Ctrl) + (Shift) and click the left mouse button.

4.

Toggle Draw Marks on to display the reference point.

5.

Object snap to the inside left corner of the wall to place your reference point exactly at the corner
intersection. You are prompted to Select one jamb of window. For more information on object
snapping, see “Object Snapping” in this chapter.

6.

Press (Spacebar) to activate coordinate entry. You are prompted to Enter relative X-distance.

7.

Type 3 and press (Enter). You are prompted to Enter relative Y-distance.

8.

Type 0 and press (Enter). Your cursor is connected to a point on the wall that is 3’-0” from the
corner of the room. You are prompted to Select second jamb of window.

9.

Press (Spacebar) to activate coordinate entry and enter the X and Y coordinates for the other side
of the window. You are prompted to Select any point on the outside of the wall.

10. Click anywhere outside the wall. The window is drawn, exactly 3’-0” from the corner of the
room.
Using reference points with direction-distance coordinate entry is even easier and faster.
 To use a reference point and direction-distance mode, using the same example:
1.

Make sure the current input mode is Direction-Distance. You can do this in several ways: click on
Input Mode in the Tools pull-down menu and make sure Direction/Distance is checked; check the
input mode in the Status Panel toolbar; or press (Ins) until Current input mode = Direction, Distance
appears in the Attention toolbar.

2.

Click on Window in the Create pull-down menu, or select Windows in the Edit/Architect menu,
or click on the

icon in the Draw toolbar. The Windows menu appears.

3.

Press (`); the Ref. Point menu appears.

4.

Toggle Draw Marks on to display the reference point.

5.

Object snap to the inside left corner of the wall to place your reference point exactly at the corner
intersection. You are prompted to Indicate the reference angle, which is the direction that will be
used in the following steps.

6.

Make sure Ortho mode is on, then drag your cursor to the right and click. You are prompted to
Select one jamb of window.
Shortcut: To toggle Ortho mode on or off, press (O).
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7.

Press (Spacebar), type 3, and press (Enter). You are prompted to Select second jamb of window.

8.

Drag your cursor to the right. Press (Spacebar), type the width of the window, and press (Enter).
You are prompted to Select any point on the outside of the wall.

9.

Click anywhere on the exterior side. The window is inserted in the wall.

Object Snapping
Object snapping is a precise way of selecting a point on or relative to an existing entity. Depending on
what drawing function is in progress, this point may simply be entered to complete the task or your
cursor may be attached to that point so you can begin drawing from there.
The dynamic snap indicator automatically displays available object snap locations in real-time, based on
your object snap settings. You can customize the behavior of the dynamic snap indicator via the Drawing
tab of Program Preferences.
You can object snap to drawing entities and snap points in several ways. Ideally, you press the middle
button on a three-button mouse to invoke object snapping. You can use one method or any combination
of the object snapping methods described in this chapter.
Shortcut: Press (N) to invoke object snapping.
Object Snap Menu Options
Most object snapping options are in the Utility/Object Snap menu; however, a related function called GetSnap also uses snapping to help you draw. See “Using Get-Snap” later in this chapter for details.
None
Toggles all object snap methods off.
Fast Symbol Toggle on to snap only to symbol insertion points rather than endpoints within the symbol. Increases
object snapping speed. See “More About Increasing Snapping Speed” in this chapter.
Fast 3D
Toggle on to snap to the center marker of circular 3D entities. Increases object snapping speed. See
“More About Increasing Snapping Speed” in this chapter.
Miss Dist.
Set the distance your cursor can be from a point while still being able to snap to it.
Layer Snap Toggle on to snap to entities on all displayed layers; toggle off to snap to entities only on the active
layer.
Search Hatch Toggle on to snap to hatch lines; toggle off to ignore hatching when object snapping and increase
snapping speed.
Quick
Toggle on to snap to the first entity you drew; toggle off to snap to the nearest point according to the
snapping methods you have toggled on. Increases object snapping speed. See “More About Increasing
Snapping Speed” in this chapter.
Sel. Set
Toggle on to snap only to entities in the active selection set. Increases object snapping speed. See “More
About Increasing Snapping Speed” in this chapter.
Aperture
Toggle on to display a box representing the miss distance. Toggle Aperture on to make sure the point
you want to snap to is inside the miss distance.
Virtual
Toggle on to snap to the “virtual” intersection of lines.
Offset
Toggle on to snap a specific distance from an endpoint, midpoint, or intersection.
On Screen Toggle on to snap only to points within the display area.

More About Snapping Points
You can add snapping points anywhere in your drawing; these points are displayed as dots in the
Drawing Area but can’t be plotted.
 To add a snapping point to your drawing:
1.

Go to the Utility menu and click on Measures.

2.

Click on Snap Point in the Measures menu.

OBJECT SNAPPING |
3.

Click in the Drawing Area or use coordinate entry to enter the snapping point. The point appears
in the Drawing Area.

More About Using Your Mouse for Snapping
If you’re using a three-button mouse, set your middle mouse button to Middle Button; do not set it to
Double Click, because you will not be able to use it for object snapping. If your middle mouse button
doesn’t seem to be snapping to points, check your mouse settings.
 To check your mouse settings:
1.

Close DataCAD if it is running. From the Windows Start menu, click on Settings and then on
Control Panel.

2.

Double-click on Mouse in the Control Panel window to open the Mouse Properties dialog box.

3.

Click on the Devices tab and make sure you have a three-button mouse driver installed.

4.

Click on the Buttons tab and make sure the left button is set to Click Select, the middle button is
set to Middle Button, and the right button is set to Alternate Menu/Click Select. If there is no
Middle Button setting, set the middle mouse button to Unassigned or Default. Another option is
to use Auto-Scroll.

5.

Click on OK to close the dialog box.

More About Increasing Snapping Speed
There are several options you can use to increase object snapping speed. Use Sel. Set, Search Hatch, and
Fast Symbol to more precisely target the geometry you want to snap to.
The Fast 3D option can also increase snapping speed when your drawing has many circular 3D entities,
such as 3D arcs, cylinders, cones, domes, tori, or contour curves. When you toggle on Fast 3D and then
select entities using the area or fence selection method, only those entities whose center axis markers or
control points are within the defined area or fence are selected.

Snapping to the Nearest Point
You can snap to the point nearest your cursor, regardless of what other object snap options are toggled
on. For instance, even if you don’t have Mid Point toggled on, it is still possible to snap to the midpoint of
a line using the Nearest option, as long as that midpoint is the point nearest to your cursor.
 To snap to the nearest point:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears. Press
(PageDown) to zoom in on your drawing and place your cursor more accurately.
Shortcut: Press (Shift) +(X) to access the Object Snap menu.

2.

Click on Nearest in the Object Snap menu.

3.

Move your cursor close to the point you’d like to snap to and press (N) or click the middle mouse
button. The nearest point on any entity is snapped to.
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Snapping to Dividing Points
You can divide an entity in a specified number of sections, with each section separated by a snapping
point. These snapping points are only visible if Draw Marks is toggled on in the Settings menu and after
you snap to them.

Figure 11.1: Snapping to a point on a divided entity
 To snap to a dividing point:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears.

2.

Click on No. Divisions in the Object Snap menu. A value menu appears.

3.

Set the number of divisions for an entity by use the value menu or typing a number. Then press
(Enter).

4.

Move your cursor close to the point you’d like to snap to and press (N) or click the middle mouse
button. The nearest division point is snapped to.

Snapping to Endpoints
You can snap to the endpoints of entities in your drawing.

Figure 11.2: Snapping to an endpoint of a line
 To snap to the nearest endpoint:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears. You
can also snap to endpoints of lines in unexploded symbols and nested symbols. For more
information on symbols, see the “Symbols, Images, and Objects” chapter.

2.

Click on End Point in the Object Snap menu.

3.

Move your cursor close to the point you’d like to snap to and press (N) or click the middle mouse
button. The nearest endpoint is snapped to.

Snapping to the Midpoint of a Line
You can snap to the nearest midpoint of a line.
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Figure 11.3: Snapping to the midpoint of a line
 To snap to the nearest midpoint of a line:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears.

2.

Click on Mid Point in the Object Snap menu.

3.

Move your cursor close to the point you’d like to snap to and press (N) or click the middle mouse
button. The nearest midpoint is snapped to.

Snapping to Arc and Circle Centers
You can snap to the center point of an arc or circle.

Figure 11.4: Snapping to the center point of a circle
 To snap to the nearest center point:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears.

2.

Click on Center in the Object Snap menu.

3.

Move your cursor close to the point you’d like to snap to and press (N) or click the middle mouse
button. The nearest center point of any arc or circle point is snapped to.

Snapping to Quadrant Points
You can snap to points marking the north, south, east, or west quadrants of a circle or arc.

Figure 11.5: Snapping to a quadrant point on a circle
 To snap to the nearest quadrant point:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears.

2.

Click on Quadrant in the Object Snap menu.

3.

Move your cursor close to the point you’d like to snap to and press (N) or click the middle mouse
button. The nearest quadrant point is snapped to.
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Snapping to Intersections
You can snap to the intersection of lines, arcs, and circles.

Figure 11.6: Snapping to an intersection of two lines
 To snap to the nearest intersection point:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears.

2.

Click on Intersect in the Object Snap menu.

3.

Move your cursor close to the point you’d like to snap to and press (N) or click the middle mouse
button. The nearest intersection point is snapped to.

Snapping to a Perpendicular
You can use perpendicular snapping to draw a line that is perfectly perpendicular to another line, arc, or
circle.

90°

Figure 11.7: Snapping to a point that forms a perpendicular to a line
 To draw a line perpendicular to another entity:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears.

2.

Click on Perp. in the Object Snap menu.
Shortcut: Press (Alt) + (O) to toggle Perp. object snapping on and off.

3.

Click in the Drawing Area or use coordinate entry to enter the first endpoint of the line.

4.

Move your cursor close to the entity you’d like to draw the line perpendicular to and press (N) or
click the middle mouse button to snap to it. The nearest perpendicular point on that entity is
snapped to.

Snapping to Tangents
You can use tangent snapping to draw a line that is tangent to an arc or circle.

Figure 11.8: Snapping to a point that forms a tangent with a circle
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 To draw a line that is tangent to an arc or circle:
1.

Go to the Utility menu and click on Object Snap. You can also click on Settings in the Tools pulldown menu and then click on Object Snap in the submenu. The Object Snap menu appears.

2.

Click on Tangent in the Object Snap menu.

3.

Click in the Drawing Area or use coordinate entry to enter the first endpoint of the line.

4.

Move your cursor close to the arc or circle you’d like to draw the line tangent to and press (N) or
click the middle mouse button to snap to it. The nearest tangent point on the arc or circle is
snapped to.

Using Get-Snap
Get-Snap allows you to input distances relative to other objects in the drawing. Instead of inputting a
distance, you can simply object snap to a point; the distance between your original point and the point
you snapped to is automatically entered. So you can quickly create, move, copy, or stretch entities that
align with other objects without having to draw guidelines or markers first.
Hint: You can only access Get-Snap functions with the middle mouse button, not with the object snap
keyboard shortcut (N) or (Shift) + (N).
 To use snapping to enter a horizontal or vertical distance:
1.

Enter a point in your drawing. This may be one endpoint of a wall or the first point in the
distance to move an entity.

2.

Press and hold down (Shift) while you click the middle mouse button for object snap. The GetSnap pop-up menu appears.

Figure 11.9: The Get-Snap pop-up menu
3.

Click on either Get X or Get Y and begin to type a number. A value menu appears and the
number you are typing appears in the input field in the Message toolbar that prompts you to
Enter relative X-distance.

4.

Continue typing the X distance value and press (Enter). Another value menu appears and you are
prompted to Enter relative Y-distance. If you want to enter a negative value, type the “-” (minus)
sign at the beginning of the input field.

5.

Type the Y distance value and press (Enter). If you want to enter a negative value, type the “-”
(minus) sign at the beginning of the input field. The line extends from your initial point to the one
you just designated. Since your cursor is attached to the last point you designated, you can
continue to input horizontal and vertical distances to extend the line.

 To add to or subtract from the Get X distance:
1.

Enter a point in your drawing. This may be one endpoint of a wall or the first point in the
distance to move an entity.

2.

Press and hold down (Shift) and object snap to a point in your drawing. The Get-Snap pop-up
menu appears.
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3.

Click on Get X + Distance to enter a horizontal distance; click on Get Y + Distance to enter a
vertical distance. A value menu appears and you are prompted to Enter relative distance.

4.

Type a positive value to add to the distance between your original point and the point you
snapped to; type a negative value to subtract from the distance between your original point and
the point you snapped to.

5.

Press (Enter). The distance is entered.

 To use snapping to define an angle:
1.

Enter a point in your drawing. This may be one endpoint of a wall or the first point in the
distance to move an entity.

2.

Press and hold down (Shift) and object snap to the point that lies along the angle. The Get-Snap
pop-up menu appears.

3.

Click on Get Angle from the pop-up menu. A value menu appears and you are prompted to Enter
relative distance.

4.

Use the value menu or type a length for your line and press (Enter). The line is created at the
referenced angle and length.

 To use snapping to define an angle, and then add or subtract from it:
1.

Enter a point in your drawing. This may be one endpoint of a wall or the first point in the
distance to move an entity.

2.

Press and hold down (Shift) and object snap to the point that lies along the angle. The Get-Snap
pop-up menu appears.

3.

Click on Get Angle + Angle in the pop-up menu. A value menu appears and you are prompted to
Enter angle from the origin.

4.

Use the value menu to enter the angle to add to the reference angle or type an angle and press
(Enter). The default is 90°. A value menu appears and you are prompted to Enter relative distance.

5.

Use the value menu to enter the length of the line or type a value and press (Enter). The line is
created at the referenced angle and length.

Using Virtual Snapping
In the Object Snap menu, the Virtual option applies only to Nearest, Intersect, and Perp. snapping
methods. When Virtual is turned off, DataCAD's object snapping mechanism will only return points that
lie on line segments passing through the current Miss Dist. (the snap aperture) and will not return either
intersections or perpendiculars that lie beyond the endpoints of these lines.
By default, Virtual is toggled off. If you want Virtual to be toggled on when you open drawings created
prior to DataCAD 10 for the first time, you can add the following entry to the [General] section of the
DCADWin.Ini file:
Virtual Snapping=TRUE
 To use virtual snapping:
1.

Click on Object Snap in the Utility menu. The Object Snap menu appears.

2.

Make sure that one of the options Nearest, Intersect, and Perp. is active.

3.

Toggle Virtual on.
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Identifying Entities
You can review the properties of any entity in your drawing.
 To identify an entity:
1.

Click on Identify in the Tools pull-down menu; or click on Identify in the Edit menu in the Menu
Window; or click on the

icon in the Edit toolbar. The Identify menu appears.

Shortcut: Press (Shift) + (I) or (Alt) + (I) to access the Identify menu.
2.

Click on the entity in your drawing that you want to identify. The selected entity is temporarily
displayed as dashed lines and a list of its properties appears in the Menu Window. It may be
necessary to change the view of your drawing, so that you have a clear view of the entity you
want to identify. Click on 3D Views in the Identify menu to display the 3D Views menu and
change the view of your drawing, choose a view from the View pull-down menu, or simply zoom
in on your drawing.

3.

(Pro) Change the current settings for line type, layer, line color, line weight, overshoot, and line
spacing to match those of the entity you identified in step 2 by clicking on Set All. You many also
use the
icon in the Edit toolbar for Set All. The settings are changed; any entities you
subsequently draw will automatically have those properties, until you change them again.

 To identify an entity with the pop-up menu:
1.

Place your cursor on the entity you want to identify.

2.

Hold down the (Ctrl) key while you right-click with the mouse. The entity appears as a dashed
line and a pop-up menu appears.

Figure 11.10: The pop-up menu
3.

Click on Identify in the pop-up menu to look at the properties of the entity you selected.
Change the current settings for line type, layer, line color, line weight, overshoot, and line spacing
to match those of the entity you identified in step 2 by clicking on Set All. The settings are
changed; any entities you subsequently draw will automatically have those properties, until you
change them again.

(Pro) You can click on Set All in the Identify pop-up menu or in the Menu Window (select Identify from
the Edit menu) to match everything based on the entity you selected. Alternatively, you can use the
button in the Edit toolbar.
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More About Entity Properties
The properties displayed when you identify an entity can vary, depending on the type of entity. For
example, if you identify a line, the following information might be displayed:

If you select text, the following information might be displayed:

Measuring Entities
You can measure the length or angle of entities or measure the distance between two points without
dimensioning them. You can also calculate areas and perimeters as well as the total length of lines in your
drawing. And most measurements can be added as text to your drawing.

Measuring Lengths and Angles
You can take a variety of measurements of lines, arcs, and angles in your drawing.
 To measure the length of a line:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Line in the extended menu.
Or click on Measures in the Utility menu and click on Line in the Measures menu. You are
prompted to Select line.
Shortcut: Press (Alt) + (X) to access the Measures menu.
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2.

Click on the line in your drawing that you want to identify. The line appears as a dashed line and
the measurement appears in the Attention toolbar.

3.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the angle of a line:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Line Angle. Or click on
Measures in the Utility menu and click on Line Angle in the Measures menu. You are prompted
to Select line.

2.

Click on the line. The angle measurement appears in the Attention toolbar.

3.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the distance between two points in your drawing:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Pnt. To Pnt. Or click on
Measures in the Utility menu and click on Pnt. To Pnt. in the Measures menu. You are prompted
to Select first point of distance to measure.

2.

Click on the first point, object snap to a point, or use coordinate entry to select a point. You are
prompted to Select second point of distance to measure.

3.

Click on the second point, object snap to a point, or use coordinate entry to select a point. The
measurement appears in the Attention toolbar.

4.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the diameter of a curve:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Diameter. Or click on
Measures in the Utility menu and click on Diameter in the Measures menu. You are prompted to
Select curve.

2.

Click on the curve in your drawing that you want to identify. The curve appears as a dashed line
and the measurement appears in the Attention toolbar.

3.

Add this measurement in text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the radius of a curve:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Radius. Or click on
Measures in the Utility menu and click on Radius in the Measures menu. You are prompted to
Select curve.

2.

Click on the curve in your drawing that you want to identify. It’s displayed in a dashed line and
the measurement appears in the Attention toolbar.

3.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the chord length of an arc::
1.

Go to the Tools pull-down menu, click on Measure, and then click on Chord. Or click on
Measures in the Utility menu and click on Chord in the Measures menu. You are prompted to
Select curve.
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2.

Click on the curve in your drawing that you want to identify. It’s displayed in a dashed line and
the measurement appears in the Attention toolbar.

3.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the arc length of a curve:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Arc Length. Or click on
Measures in the Utility menu and click on Arc Length in the Measures menu. You are prompted
to Select curve.

2.

Click on the curve in your drawing that you want to identify. It’s displayed in a dashed line and
the measurement appears in the Attention toolbar.

3.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the circumference of a circle:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Circ. Or click on Measures
in the Utility menu and click on Circ. in the Measures menu. You are prompted to Select curve.

2.

Click on the circle in your drawing that you want to identify. It’s displayed in a dashed line and
the measurement appears in the Attention toolbar.

3.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the included angle between two lines:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Incl. Angle. Or click on
Measures in the Utility menu and click on Incl. Angle in the Measures menu. You are prompted
to Select first line of angle to measure.

2.

Click on the first line. You are prompted to Select second line of distance to measure.

3.

Click on the second line. The measurement appears in the Attention toolbar.

4.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

 To measure the excluded angle between two lines:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Excl. Angle. Or click on
Measures in the Utility menu and click on Excl. Angle in the Measures menu. You are prompted
to Select first line of angle to measure.

2.

Click on the first line. You are prompted to Select second line of distance to measure.

3.

Click on the second line. The measurement appears in the Attention toolbar.

4.

Add this measurement as text to your drawing by clicking on To Drawing, setting the text
options as necessary, and clicking in the drawing where you want to place the text.

Measuring the Total Length of Lines
You can calculate the total length of lines in a drawing according to color, line type, and line weight. You
can use the Color, Line Type, and Weight filters individually or in any combination.
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 To measure total length of lines:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Takeoffs. Or click on
Measures in the Utility menu and click on Takeoffs in the Measures menu. The Takeoffs menu
appears.

2.

Decide which lines you want to include:


To include all lines of a specific color in the measurement, click on Color in the Takeoffs
menu and then select a color from the color menu. For more information on using color
menus, see “Color Menus” in “The Drawing Board” chapter.



To include all lines of a specific type, click on Line Type in the Takeoffs menu and then select
a line type from the menu.



To include all lines of a specific weight, click on Weight in the Takeoffs menu and then select
a weight from the value menu. For more information on using value menus, see “Value
Menus” in “The Drawing Board” chapter.



To include lines on all displayed layers, toggle Layer Search on. Toggle it off to include only
those lines on the active layer.

3.

Click on Begin. The measurement appears in the Attention toolbar.

4.

Add this measurement as text to your drawing by clicking on To Drawing; choose to add the
area, the perimeter, or both to your drawing; set the text options as necessary; and click in the
drawing where you want to place the text.

Measuring Areas, Perimeters, and Volumes
You can calculate the area, perimeter, and volume of an existing polyline or circle in your drawing, or you
can define a temporary polyline to measure an area or arc in your drawing.
 To measure the area, perimeter, and volume of an existing polyline or circle:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Area/Perimeter. Or click on
Measures in the Utility menu and click on Area/Per. in the Measures menu. The Area/Per. menu
appears.

2.

Click on Scale Type; a list of scale types appears. This Scale Type setting is independent from the
drawing scale type set in the Settings/Scale Type.

3.

Click on a scale type to select it and right-click to exit the scale type list. If you selected Decimal,
Inch/Decimal, Meters, Centimeter, Millimeter, DIN, or AS1100 for the scale type, the Area Prec.
option is available in the scale type menu if Do Float is toggled off. Use this option to set the
number of digits of precision to be displayed for area calculations.

4.

Right-click to return to the Area/Per. menu and toggle Add Snap on to add a snapping point to
your drawing at each vertex of the polyline you select.

5.

Click on Select. You are prompted to Select polyline or circle for area/perimeter calculation.

6.

Click on the polyline or circle you want to measure. The area and perimeter measurements
appear in the Attention toolbar and additional Area/Per. menu options appear. If you select Arch.,
Eng., Decimal, Inch/Frac., or Inch/Decimal for the scale type, the Acres option is available in the
Area/Per. menu, which you can toggle on to display area units in acres.

7.

Display the centroid of the polyline by clicking on Centroid; then click on Show It to display a
cross marking the centroid of the polyline or click on Add to add a snapping point at the
centroid. Right-click to return to the Area\Per menu.
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8.

Add or subtract the next area or perimeter measurement from the total. Click on Perim. + to add
the next perimeter measurement, click on Perim. - to subtract the next perimeter measurement,
click on Area + to add the next area measurement, or click on Area - to subtract the next area
measurement. Repeat step 6 as necessary to add or subtract an area or perimeter measurement.
Click on Volume in the Area/Per menu to display the volume of the selected polyline. If you
select Decimal, Inch/Decimal, Meters, Centimeter, Millimeter, DIN, or AS 1100 for the scale type,
Area Prec. is available in the scale type menu. Click on Area Prec. and use the value menu to set
the number of digits of precision to be displayed for area calculations.

9.

Add the measurement as text to your drawing by clicking on To Drawing; choose to add the area,
the perimeter, the volume, or both area and perimeter to your drawing; set the text options as
necessary; and click in the drawing to place the text.

 To measure the area, perimeter, and volume of a polyline you define:
1.

Go to the Tools pull-down menu, click on Measure, and then click on Area/Perimeter. Or click on
Measures in the Utility menu and click on Area/Per. in the Measures menu. The Area/Per. menu
appears.

2.

Click on Scale Type. A list of scale types appears.

3.

Click on a scale type to select it and then right-click to exit the scale type list. If you select Arch.,
Eng., Decimal, Inch/Frac., or Inch/Decimal for the scale type, the Acres option is available in the
Area/Per. menu, which you can toggle on to display area units in acres.

4.

Toggle Add Snap on to add a snapping point to your drawing at each vertex of the polyline you
select.

5.

Define the polyline to measure using one of these methods:


Trace the closed polyline by clicking in the Drawing Area or using object snap to precisely
select the first point for the polyline. You are prompted to Select next point on polyline.
Continue selecting points as necessary, until the area you want to measure is enclosed by the
polyline. You can also trace around arcs. See “More About Tracing Polylines” on the
following pages for details.



Use Rectangle to define a rectangular polyline.



Use Cont. Search to define any type of closed polyline.

6.

Click on Close in the Area/Per. menu to automatically connect the last point on the polyline you
selected with the first one. Your cursor is detached from the polyline, and the area and perimeter
measurements appear in the Attention toolbar. Additional Area/Per. menu options appear in the
Menu Window. Click on Volume in the Area/Per. menu to display the volume of the selected
polyline.

7.

Display the centroid of the polyline if necessary. Click on Centroid; then click on Show It to
display a cross marking the centroid of the polyline, or click on Add to add a snapping point at
the centroid. Right-click to return to the Area/Per. menu.

8.

Add or subtract the next area or perimeter measurement from the total. Click on Perim. + to add
the next perimeter measurement, click on Perim. - to subtract the next perimeter measurement,
click on Area + to add the next area measurement, or click on Area - to subtract the next area
measurement. Repeat step 5 and 6 as necessary to add or subtract an area or perimeter
measurement. To measure a rectangular area or perimeter, simply click on Rectangle in the
Area/Per. menu and enter two, diagonally opposite points.
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9.

Add this measurement as text to your drawing by clicking on To Drawing; choose to add the
area, the perimeter, the volume, or both area and perimeter to your drawing; set the text options
as necessary; and click in the drawing to place the text.

More About Tracing Polylines
Besides tracing straight sides for your polylines, you can also trace around 2-point arcs, 3-point arcs, and
tangent arcs. The 2 Pt. Arc, 3 Pt. Arc, and Tangent options are available in the Area/Per. menu after you
select the first point for your polyline.
 To trace 2-point arcs:
1.

Begin your polyline anywhere on the shape and continue it until you select one endpoint of the 2point arc.

2.

Click on 2 Pt. Arc in the Area/Per. menu. You are prompted to Select center of arc.

3.

Click on the center of the arc or object snap to it. You are prompted to Select endpoint of arc.

4.

Click or object snap to the other endpoint of the arc. For more information on how to object snap,
see “Object Snapping” earlier in this chapter.

5.

Repeat steps 3 and 4 to immediately trace around another 2-point arc or right-click to exit the 2
Pt. Arc menu.

6.

Continue tracing your polyline and click on Close when finished. The area and perimeter
measurements appear in the Attention toolbar.

 To trace 3-point arcs:
1.

Begin your polyline anywhere on the shape and continue it until you select one endpoint of the 3point arc.

2.

Click on 3 Pt. Arc in the Area/Per. menu. You are prompted to Select second endpoint of arc.

3.

Click on the second endpoint of the arc or object snap to it. You are prompted to Select any point
on the arc.

4.

Click anywhere on the arc.

5.

Repeat steps 3 and 4 to immediately trace around another 3-point arc or right-click to exit the 3
Pt. Arc menu.

6.

Continue tracing your polyline and click on Close when finished. The area and perimeter
measurements appear in the Attention toolbar.

 To trace tangent arcs:
1.

Begin your polyline anywhere on the shape, making sure you trace the line the arc was drawn
tangent to before you reach the first endpoint of the tangent arc.

2.

Select the first endpoint of the tangent arc, then click on Tangent in the Area/Per. menu. You are
prompted to Select ending point of arc.

3.

Click on the other endpoint of the arc or object snap to it.

4.

Repeat step 3 to immediately trace around another tangent arc or right-click to exit the Tangent
menu.

5.

Continue tracing your polyline and click on Close when finished. The area and perimeter
measurements appear in the Attention toolbar.
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Working with Entities
The Geometry menu has three options that may help you work with the entities in your drawing. You can
mark divisions or intersections of entities as well as rotate the snap grid and even the X and Y axes to
match an entity.
Shortcut: Press (Alt) + (G) to quickly access the Geometry menu.

Dividing Entities
You can calculate equal divisions of lines and arcs and mark those divisions with snap points. This
feature is useful for such things as dividing a stair run into equal tread lengths.
You can also divide a line using the Golden Mean proportion. Golden Mean divides a line into two
segments, one longer than the other, so that the smaller section is to the larger section as the larger is to
the whole. The exact ratio is 1:1.618, a proportion considered harmonic by ancient Greeks.
 To divide a line:
1.

Click on Geometry in the Tools pull-down menu or select Geometry from the Utility menu and
then click on Divide. The Divide menu appears.

2.

Click on Divisions. A value menu appears and you are prompted to Enter number of divisions.

3.

Use the value menu or type a number and press (Enter).

4.

Decide how you want to divide the line. If you simply want to divide the line into equal parts,
skip to step 5. However, to divide the line into sections of a specific distance as well, click on Div.
+ Dist. A value menu appears and you are prompted to Enter distance between division points. Use
the value menu or type a number and press (Enter). You are prompted to Select first point.

5.

Click in the Drawing Area to select the first endpoint of the line or use object snap to select it. You
are prompted to Select second point. Click in the Drawing Area to select the second endpoint of the
line or use object snap to select it. The line is divided and a snap point appears at each division.
If you clicked on Div. + Dist. in step 4, you are prompted to Indicate direction of arrows. Drag your
cursor to pull the arrow in the direction you want. Then click. DataCAD breaks the line into the
number of divisions you selected in step 3; however, each division is the length you specified in
step 4. If the sum of the lengths of the divisions is less than the total length of the line, DataCAD
will mark off only the number of divisions you specified. If the sum of the lengths of the divisions
is more than the total length of the line, some markers will extend past the end of the line.

 To divide an arc, circle, or line:
1.

Click on Geometry in the Tools pull-down menu or select Geometry from the Utility menu and
then click on Divide. The Divide menu appears.

2.

Click on Divisions. A value menu appears and you are prompted to Enter number of divisions.

3.

Use the value menu or type a number and press (Enter).

4.

Decide how you want to divide the line, arc, or circle. If you simply want to divide the entity into
equal parts, skip to step 5.
However, to divide the entity into sections of a specific distance as well, click on Div. + Dist. A
value menu appears and you are prompted to Enter distance between division points. Use the value
menu or type a number and press (Enter). Div. + Dist. can be used on straight lines only, not on
arcs or circles. You are prompted to Select first point. Skip to the second paragraph in step 6.

5.

Click on Entity. You are prompted to Select line, arc, or circle to divide.
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6.

Select the entity you want to divide by clicking on it in the Drawing Area. The line is divided and
a snap point appears at each division.
If you clicked on Div. + Dist. in step 4, click at the beginning of the line you want to divide. You
are prompted to Indicate direction of arrows. Drag your cursor to pull the arrow in the direction
you want. Then click. DataCAD breaks the line into the number of divisions you selected in step
3; however, each division is the length you specified in step 4. If the sum of the lengths of the
divisions is less than the total length of the line, DataCAD will mark off only the number of
divisions you specified. If the sum of the lengths of the divisions is more than the total length of
the line, some markers will extend past the end of the line.

 To divide a line using Golden Mean:
1.

Click on Geometry in the Tools pull-down menu or select Geometry from the Utility menu and
then click on Divide. The Divide menu appears.

2.

Click on Golden Mean. You are prompted to Select first point.

3.

Select the two endpoints of the line or simply select the line itself.
If you select the two endpoints of a line, the longer segment will start at the first endpoint.
If you want to select the line itself, click on Entity. You are prompted to Select line to be divided for
Golden Section. When you select the line using Entity, the longer segment will appear on the side
of the line that you clicked on.

4.
A

Click in the Drawing Area to select the entity you want to divide. The line is divided and a snap
point appears at the division between the two segments.
B

C

e you
a divide the line AC at point B using Golden Mean, the ratio of AB:AC is
Figure
Golden 11.11:
M
nWhen
:
equal
Line divto
ide1:1.618
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Marking Line Intersections
You can identify the precise point where two lines intersect and mark the intersection with a snapping
point.
 To mark the intersection of two lines:
1.

Click on Geometry in the Tools pull-down menu or select Geometry from the Utility menu and
then click on Intersection. The Intersection menu appears.

2.

Determine if the two lines are on different layers. If so, toggle Layer Search on. You are prompted
to Select first line.

3.

Click on one of the lines to select it. You are prompted to Select second line.

4.

Click on the other line to select it. The intersection is marked with a snapping point.
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Matching the Snap Grid to an Entity
You can rotate the snap grid to match the angle of an entity, making it easier to draw. This does not rotate
the X and Y axes.
 To match the snap grid to an entity:
1.

Click on Geometry in the Tools pull-down menu or select Geometry from the Utility menu and
then click on Tangents. The Tangents menu appears. DataCAD automatically changes to
orthographic (plan) view when you use Tangents.

2.

Set the number of cursor snap angles by clicking on Tan. Div. A value menu appears and you are
prompted to Enter number of cursor snap angles.

3.

Use the value menu or type a number and press (Enter). You are prompted to Select the line to
draw tangent to.

4.

Select an entity to match its angle or select two lines and align the snap grid with the line that
bisects the angle between them. You can also select an arc or circle; the cursor is rotated to match
the angle of the entity at the point you selected.


To match an entity’s angle, click on a line to select it. The cursor and snap grid are rotated to
match the angle of the line.



To match a bisected angle between two lines, click on Bisect. Click on the two lines to select
them. The cursor and snap grid are rotated to match the angle of the line bisecting the
selected entities (see Figure 11.12).



To align the X and Y axes with the tangent entity, toggle Dist. Sync. on in the Utility/Settings
menu (see Figure 11.11).
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Figure 11.12: Rotating the cursor and snap grid with Tangents, both with and without Dist. Sync.
toggled on
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Chapter 12 Editing Drawings
Tools included in Edit (in both the Menu Window and the pulldown menu) can change the visible characteristics of entities as
well as their position in the drawing. You can clean wall and line
intersections, weld breaks, and trim lines to another entity or to
an intersection in your drawing.

In this chapter:

In addition to repairing drawing mistakes, you can also use a
number of features to edit entities. Not only can you change such
properties as the color or line type of an entity, you can also
move, rotate, or stretch an entity or even an entire room.

 Trimming lines
 Changing entity

 Cleaning

intersections

 Welding lines and
walls

properties








Moving entities
Rotating entities
Erasing entities
Enlarging entities
Stretching entities
Clipping entities
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Trimming, Welding, and Cleaning
There are several tools you can use to trim corners and lines, weld lines and walls, and clean up
intersections in your drawing.

Trimming Corners
You can connect any two nonparallel lines with either an arc or a line. The Fillets option connects two
lines with an arc and can then trim them to make a smooth curve. The Chamfer option connects two lines
with a line and can then trim the two lines to the chamfer. These two lines do not have to be connected
prior to using Fillets or Chamfer. They can be two lines that form the corner of a room or they can be two
completely separate lines in your drawing.
 To connect two lines with an arc:
1.

Click on Cleanup in the Edit menu in the Menu Window to display the Cleanup menu; go to step
2. Alternatively, click on
in the Draw toolbar and click on
display the Fillets menu; go to step 3.

in the Context toolbar to

Shortcut: Press (Alt) + (F) to access the Fillets menu.
2.

Click on Fillets in the Cleanup menu. The Fillets menu appears.

3.

Change the fillet radius if necessary. The default setting for the fillet radius is 1’-0.” To change the
radius of the fillet arc, click on Radius. A value menu appears. Use the value menu or type a
radius and press (Enter). The radius remains at this setting for this drawing until you change it.
In fact, this setting is saved with the drawing, so that every time you open the drawing, the Fillets
radius is automatically set to the value you enter in these steps.

4.

Toggle Clip on or off. To trim the ends of the selected lines to the ends of the arc, toggle Clip on.
To draw the arc but leave the ends of the lines unaffected, toggle Clip off (see Figure 12.1).

5.

Connect lines on two different layers by toggling Layer Search on. You are prompted to Select first
line to fillet.

6.

Click on one of the lines to select it. You are prompted to Select second line to fillet.

7.

Click on the other line to select it. The two lines are connected by an arc.

You can use Fillets to extend two nonparallel, nonintersecting lines until they intersect. Simply set the
Radius to 0 and select the two lines. The lines are lengthened until they intersect.

Figure 12.1: Lines trimmed to fillet (Clip on) and lines left untrimmed (Clip off)
 To connect two lines with a line:
1.

Click on Cleanup in the Edit menu in the Menu Window to display the Cleanup menu; go to step
2. Alternatively, click on
in the Draw toolbar and click on
display the Chamfer menu; go to step 3.

2.

in the Context toolbar to

Click on Chamfer in the Cleanup menu. The Chamfer menu appears.
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3.

Set the chamfer distance for each line by clicking on Distances. The chamfer distance is the distance
from the intersection of the two lines to the chamfer point on each line. A value menu appears.
You are prompted to Enter first chamfer distance. See Figure 12.2 for an illustration of chamfer
distances and how they relate to the lines you select.

4.

Use the value menu or type a chamfer distance for the first line you will select and press (Enter).
Another value menu appears. You are prompted to Enter second chamfer distance.

5.

Use the value menu or type a chamfer distance for the second line you will select and press
(Enter).

6.

Toggle Clip on or off. To trim the ends of the selected lines to the ends of the chamfer line, toggle
Clip on. To draw the chamfer but leave the ends of the lines unaffected, toggle Clip off.

6.

Connect lines on two different layers by toggling Layer Search on. You are prompted to Select first
line to chamfer.

7.

Click on one of the lines to select it. You are prompted to Select second line to chamfer.

8.

Click on the other line to select it. The two lines are connected by a line.

Lines may be shortened or lengthened to meet the ends of the chamfer.

Figure 12.2: The first chamfer distance entered corresponds with the first line you select and the
second chamfer distance entered corresponds with the second line you select.

Trimming Entities
Trimming entities involves either shortening or lengthening selected lines or arcs. You can trim existing
entities to a temporary line that you draw, you can trim two lines so they intersect cleanly, or you can
specify not only what entities you want trimmed, but exactly how to trim them. Two-line trim can handle
line/arc and arc/arc conditions.
 To trim entities so they end at a line you specify:
1.

Click on Line Cleanup in the Edit pull-down menu and then click on 1 Line Trim in the submenu.
You can also select Cleanup from the Edit menu in the Menu Window and click on 1 Line Trim in
the Cleanup menu. Alternatively, you can click on
the Context toolbar. The 1 Line Trim menu appears.

2.

in the Draw toolbar and click on

Select a trim line, a line that entities will be trimmed to. Entities in your drawing will either be
shortened or lengthened to meet the trim line. This line can either be an existing line in your
drawing or it can be a temporary line that you draw.


To use an existing line in your drawing as the trim line, click on Entity in the 1 Line Trim
menu. Toggle Layer Search on if your trim line is on a different layer. Click on the line in
your drawing to select it as the trim line. Skip to step 4.

in
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To draw a temporary trim line, click in the Drawing Area or use coordinate entry to enter the
first endpoint of your trim line. Click in the Drawing Area or use coordinate entry to enter
the second endpoint of your trim line. A dashed line representing the trim line appears.

3.

Click anywhere on the outside of the trim line; this will be the side that will be trimmed (see
Figure 12.3).

4.

Choose a selection method and then select the entities you want to trim. The entities are trimmed
to the trim line. For more information on using selection menus, see “Selection Menus” in “The
Drawing Board” chapter.

Figure 12.3: Trimming entities to a trim line
 To trim two lines to their intersection:
1.

Click on Line Cleanup in the Edit pull-down menu and then click on 2 Line Trim in the submenu.
You can also select Cleanup from the Edit menu in the Menu Window and click on 2 Line Trim in
the Cleanup menu. Alternatively, you can click on
the Context toolbar. The 2 Line Trim menu appears

in the Draw toolbar and click on

in

2.

Toggle Layer Search on if the lines you want to trim are on different layers. You are prompted to
Select first line to trim.

3.

Click on one of the lines you want to trim. You are prompted to Select second line to trim.

4.

Click on the other line you want to trim. The lines are trimmed at their intersection. The lines you
select do not have to intersect; if they don’t, they will be lengthened when they are trimmed.

Figure 12.4: Trimming two intersecting lines
 To specify the entities to be trimmed and how to trim them:
1.

Click on Line Cleanup in the Edit pull-down menu and then click on Free Trim in the submenu.
You can also select Cleanup from the Edit menu in the Menu Window and click on Free Trim in
the Cleanup menu. The Free Trim menu appears. Free Trim only trims to or between selected
entities; therefore, you must select not only the entity you want to trim, but also all the entities
that it intersects with.

2.

Choose a selection method and then select the entities you want to trim as well as any
intersecting entities. All selected entities are displayed in dashed lines.

3.

Click on Begin in the Free Trim menu. You are prompted to Select entity section to be trimmed.
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4.

Click on the line or arc segment that you want trimmed (removed). DataCAD searches for the
nearest intersections and trims to the intersection points (see Figure 12.5).

5.

Continue selecting segments to be trimmed or leave the Free Trim menu by clicking on Exit or
right-clicking once.

If you get unexpected results after using Free Trim, click on Undo Free Trim in the Edit pull-down menu
or press (Ctrl) + (Z).

Figure 12.5: Selecting the line segment you want trimmed (removed)

Welding Lines and Walls
You can repair lines and walls that have breaks in them, making a single, straight, continuous line or wall.
 To weld lines:
1.

Click on Line Cleanup in the Edit pull-down menu and then click on Weld Line in the submenu.
You can also select Cleanup from the Edit menu in the Menu Window and click on Weld Line in
the Cleanup menu. Alternatively, you can click on
the Context toolbar. The Weld Line menu appears.

in the Draw toolbar and click on

in

Shortcut: Press (Alt) + (W) to access the Weld Line menu.
2.

Toggle Layer Search on if the lines you want to weld together are on different layers. You are
prompted to Select first line to weld.

3.

Click on one of the lines you want to weld. You are prompted to Select second line to weld.

Figure 12.6: Two lines welded into a single line
 To weld walls:
1.

Click on Wall Cleanup in the Edit pull-down menu and then click on Weld Wall in the submenu.
You can also select Cleanup from the Edit menu in the Menu Window and then click on Weld
Wall. Or you can click on
Weld Wall menu appears.

in the Draw toolbar and click on

in the Context toolbar. The

If you have already cut the walls by inserting a window or door, you must first erase the window
or door before you can weld the walls.
2.

Toggle Layer Search on if the walls you want to weld together are on different layers. You are
prompted to Select first point on box around wall opening to weld.
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3.

Select the walls to be welded by drawing a rubber band box around the two wall ends you want
to weld. There must be only two wall ends within the rubber band box in order for the walls to be
welded. To select the first corner of this box, click above and to the left of the wall ends you want
to weld. You are prompted to Select second point on box around wall opening to weld.

4.

Move your mouse diagonally to stretch the rubber band box around the two wall ends you want
to weld and click. The walls are welded. If the two walls are not in line with each other, an error
message will be displayed in the Attention toolbar, saying Unable to weld these walls.

Figure 12.7: Welding two wall ends

Cleaning Wall Intersections
You can clean the wall intersections of 2-line, 3-line, or 4-line walls that meet in an L, T, or X shape.
Figure 12.8: T-shaped intersections with different wall types

Figure 12.9: L-shaped intersections with different wall types
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Figure 12.10: X-shaped intersections with different wall types
 To clean wall lines meeting in a T intersection:
1.

Click on Wall Cleanup in the Edit pull-down menu and then click on T-Intersection in the
submenu. You can also select Cleanup from the Edit menu in the Menu Window and then click
on T-Intersect. Or you can click on
in the Draw toolbar and click on
toolbar. The T Intersect menu appears.

in the Context

2.

Toggle Layer Search on if the wall intersection you want to clean is on a different layer than the
active layer. You are prompted to Select first corner around T intersect (wall line ends only).

3.

Select the intersection to be cleaned by drawing a rubber band box around it. To select the first
corner of the box, click above and to the left of the intersection. You are prompted to Select second
corner around T intersect (wall line ends only).

4.

Move your mouse diagonally to stretch the rubber band box around the intersection and click.
You are prompted to Point to wall line to trim to. Make sure you include only one intersection
within the rubber band box.

5.

Click on the wall line to trim to (see Figure 12.11). The intersection is cleaned.

Figure 12.11: Cleaning a T-shaped intersection
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 To clean wall lines meeting in a L intersection:
1.

Click on Wall Cleanup in the Edit pull-down menu and then click on L-Intersection in the
submenu. You can also select Cleanup from the Edit menu in the Menu Window and then click
on L-Intersect. Or you can click on
in the Draw toolbar and click on
toolbar. The L Intersect menu appears.

in the Context

2.

Toggle Layer Search on if the wall intersection you want to clean is on a different layer than the
active layer. You are prompted to Select first corner around L intersect (wall line ends only).

3.

Select the intersection to be cleaned by drawing a rubber band box around it. To select the first
corner of the box, click above and to the left of the intersection you want to clean. You are
prompted to Select second corner around L intersect (wall line ends only).

4.

Move your mouse diagonally to stretch the rubber band box around the intersection and click.
The intersection is cleaned.

Figure 12.12: Cleaning L-shaped intersections
 To clean wall lines meeting in a X intersection:
1.

Click on Wall Cleanup in the Edit pull-down menu and then click on X-Intersection in the
submenu. You can also select Cleanup from the Edit menu in the Menu Window and then click
on X-Intersect. Or you can click on
in the Draw toolbar and click on
toolbar. The X Intersect menu appears.

in the Context

2.

Toggle Layer Search on if the wall intersection you want to clean is on a different layer than the
active layer. You are prompted to Select first corner around X intersect (0 line ends).

3.

Select the intersection to be cleaned by drawing a rubber band box around it. To select the first
corner of the box, click above and to the left of the intersection you want to clean. You are
prompted to Select second corner around X intersect (0 line ends).

4.

Move your mouse diagonally to stretch the rubber band box around the intersection and click.
The intersection is cleaned.
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Original

Resulting "X" Intersection

Figure 12.13: Cleaning an X-shaped intersection

Changing Entities
You can change an entity’s properties, such as line type, line weight, color, line spacing, overshoot, Zbase, and Z-height. You can also change the size, weight, slant, aspect, and font of text.
In addition to properties, some entities have information associated with them; you can also edit this
information. There’s even a macro that you can use to convert lines to walls or walls to lines.

Changing Entity Properties
The line type, line weight, line spacing, overshoot, Z-base, and Z-height properties can all be changed
using value menus. Line spacing settings apply only to nonsolid line types. Use a color menu to change
an entity’s color.
 To change entity properties:
1.

Click on Change in either the Edit pull-down menu or the Menu Window. Or click on
Edit toolbar. The Change menu appears.

in the

Shortcut: Press (Alt) + (C) to access the Change menu.
2.

Toggle Layer Search on if the entities you want to change are on a different layer than the active
layer.

3.

Click on the attribute you want to change: Line Type, Line Weight, Spacing (line spacing),
Overshoot (line overshoot), Z-Base, or Z-Height. A value menu appears.

4.

Use the value menu or type a number and press (Enter). For more information on using value
menus, see “Value Menus” in “The Drawing Board” chapter.

5.

Change the color of the entity by clicking on Color. Select the color you want to use from the
color menu. For more information on using color menus, see “Color Menus” in “The Drawing
Board” chapter.

6.

Choose the selection method you want to use. You are prompted to select the entities you want to
change.

7.

Select the entities you want to change. The properties of these entities are modified.
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Figure 12.14: Changing the overshoot of lines
 To change entity properties to match those of another entity:
1.

Click on Change in either the Edit pull-down menu or the Menu Window. The Change menu
appears. Or click on

in the Edit toolbar and skip to step 3.

2.

Click to toggle Match on.

3.

Toggle Layer Search on if the entities you want to change are on a different layer from the entities
you want to match.

4.

Choose which properties to change by toggling on any of the following options: Line Type, Line
Weight, Color, Spacing, Overshoot. Z-Base, and Z-Height. Or click on All to toggle all of these
attribute options on.

5.

Choose the selection method you want to use. You are prompted to select the entity you want to
change. For more information on selection menus, see “Selection Menus” in “The Drawing
Board” chapter.

6.

Select the entity you want to change. You are prompted to select the entity whose properties you
want to match.

7.

Select the entity to match. The properties of the entities you selected in step 6 are modified.

Changing Text Attributes
You can change the attributes of a single line of text or of all text in your drawing, depending on what
selection method you use.
 To change the attributes of text:
1.

Click on Change in either the Edit pull-down menu or the Menu Window. Or click on
Edit toolbar. The Change menu appears.

2.

Click on Text in the Change menu.

3.

Toggle Layer Search on if the text you want to change is on a different layer than the active layer.

4.

Change the appearance of text in your drawing. You can change the size, weight, slant, aspect,
contents, capitalization, font name, and matching characteristics in the Change\Text menu. For
more information on text parameter settings, see the “Text, Notes, and Labels” chapter.


in the

To change the font, click on Font. The Set Text Parameters dialog box appears. Select a font in
the Font Name list box. Keep in mind that the fonts displayed under Font Name are
determined by the Font Type selection in the lower-left corner of the dialog box. You can
display TrueType fonts (TTF), DataCAD fonts (SHX), or both in the list. Make other changes
in the dialog box if necessary.
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To change the text’s size, use the Size button and type the new value. Alternatively, you can
click Font to open the Set Text Parameters dialog box; then enter the new size in the Height
field or select a value from the Height list box.



To change the angle of the lines of text, type an angle value or click on one in the Angle list
box.



To change the height of each character relative to its width, type an aspect ratio value or click
on one in the Aspect list box.



To change the slant of text when using an SHX font, type a slant value or click on one in the
Slant list box.



To change the line weight of text when using an SHX font, type a weight value or click on one
in the Weight list box.



To change the font style when using a TrueType font, click on a style in the TTF Style list box.



To change the text properties when using a TrueType font, select Fill, Outline, or Both and
then set the colors for the Fill and Outline, as necessary.

5.

Click on OK to save the text parameter changes and close the dialog box.

6.

Change the text itself by clicking on Contents. (Otherwise, skip to step 9.) You are prompted to
select the text you want to change.

7.

Choose a selection method from the menu and then select the text. It appears in the Message
toolbar. For more information on selection menus, see “Selection Menus” in “The Drawing
Board” chapter.

8.

Type the new text and press (Enter).

9.

Choose the selection method you want to use. You are prompted to select the text you want to
change.

10. Select the text you want to change. The attributes of the text are modified.
 To change text attributes to match those of another text block:
1.

Click on Change in either the Edit pull-down menu or the Menu Window. The Change menu
appears. Or click on

in the Edit toolbar and skip to step 3.

2.

Click on Match.

3.

Toggle Layer Search on if the text you want to change is on a different layer from the text you
want to match.

4.

Choose which attributes to change by toggling on any of the following options: Size, Weight,
Slant, Aspect, and Font. Or click on All to toggle all of these attribute options on.

5.

Choose the selection method you want to use. You are prompted to select the text you want to
change.

6.

Select the text you want to change. You are prompted to select the text whose attributes you want
to match.

7.

Select the text to match. The attributes of the text you selected in step 6 are modified.
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(Pro) Editing Entity Information
Most of the standard DataCAD entities don’t have any additional information attached to them, but a few
do, such as associative hatching and entities that are hyperlinked to go-to-views. You can edit this
information using the FormAtr macro.
 To edit entity attributes:
1.

Click on FormAtr in the Toolbox pull-down menu. The FormAtr menu appears. If FormAtr is not
listed in your Macros menu, click Configure in the Toolbox pull-down menu and add it to the
Macros in Menu list.

2.

Click on Entities in the FormAtr menu. You are prompted to Select entity to edit attribute fields.

3.

Click on the entity. The entity’s information appears in the Drawing Area.

4.

Press (Tab) to move the edit box to the text you want to change.

5.

Type the new text and press (Enter). The information is changed.

6.

Repeat steps 4 and 5 to continue editing or press (Esc) to exit editing and return to your drawing.

(Pro) Converting Lines to Walls
Using the Lin2Wall macro, you can convert lines to 2-line, 3-line, or 4-line walls. You can only convert
lines; you can’t convert curves. Alternatively, you can convert walls to lines. This tool can be useful when
you draw three lines and then want DataCAD to recognize them as a 3-line wall, so that it will be
properly cut when you insert doors or windows.
 To convert lines or walls:
1.

Click on Lin2Wall in the Toolbox pull-down menu. The Lin2Wall menu appears. If Lin2Wall is
not listed in your Toolbox menu, click Configure and add it to the Macros in Menu list.

2.

Toggle Layer Search on if the lines/walls you want to convert are on a different layer than the
active layer.

3.

Choose your conversion result:


To convert walls to lines, click on Lines.



To convert lines to 2-line walls, click on 2LnWall.



To convert lines to 3-line walls, click on 3LnWall.



To convert lines to 4-line walls, click on 4LnWall.

4.

Choose the selection method you want to use. You are prompted to select the entities you want to
change.

5.

Select the entities you want to change. The entities are modified, although their actual appearance
on screen won’t change. See “More About Converting Lines to Walls” below for details.

When you use Lin2Wall to convert lines with doors or windows in them to walls, use the Entity selection
method to ensure that all lines are converted to walls.
(Pro) More About Converting Lines to Walls
When you convert lines to walls in your drawing, they will no longer be recognized as separate lines;
instead, DataCAD will see them as a wall. If you’ve drawn three lines that you now want to convert into a
single 3-line wall, simply choose the 3LnWall option and select each of the lines. When you select a line to
convert it, the line’s appearance isn’t changed and it’s not redrawn on screen; rather, its attribute setting
is changed so that DataCAD recognizes each line as part of a 3-line wall.
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After you’ve converted the lines to 3-line walls, you can use the Identify option from the Tools pull-down
menu or the Edit menu in the Menu Window. When you click on a line that you converted to a 3-line
wall, DataCAD displays its characteristics in the Menu Window. If you click on the LINE option, you can
see the attribute setting displayed in the Coordinates/Hints toolbar. Single lines and lines in 2-line walls
have an attribute setting equal to 5; lines in 3-line walls have Attrib=36; and lines in 4-line walls have
Attrib=63.

Moving Entities
You can move an entity to a different position in your drawing by either specifying the distance and angle
to reposition it or by dragging it to the new location. You can also move entities to another layer in your
drawing.
If an entity is linked to others in a group or selection set, it remains linked when you move it.
You can use object snapping to align a point on the entity you move with a point on another entity in
your drawing. Simply snap to the entity to move at the point you want to align and then snap to the other
entity at the point to align. The first entity is moved and aligned at the points you snapped to.

Moving Entities to Absolute Zero
 To move entities to absolute zero:
1.

Select Input Mode from the Tools pull-down menu and choose Absolute Cartesian. You can also
select Abs. Cartesian from the drop-down list in the Status Panel toolbar. Or click (Ins) until you
see Current input mode = Absolute Cartesian (x, y) in the Attention toolbar.

2.

Recalculate the extents of the drawing by clicking on
press (PgUp) to zoom out.

3.

Select Move from the Edit pull-down menu or the Menu Window. Or you can click on

in the Navigation Pad toolbar. Then

in

the Edit toolbar and select
from the drop-down list. The Move menu
appears. You are prompted to Select first point of the distance to move.
Shortcut: Press (M) to access the Move menu.
4.

Select the first point near the center of the drawing. You are prompted to Select second point of the
distance to move.

5.

Press (Spacebar) to use coordinate entry. The press (Enter) twice to accept the coordinates 0, 0 as
the distance from absolute zero.

6.

Toggle Layer Search on.

7.

Make sure that no layers are locked.
Hint: Click on
in the Status Panel toolbar to display the Layer Manager dialog box; then
check the Lock column and click on any locked icons to change them to unlocked status.
Then click on OK to close the dialog box.

8.

Click on Area in the selection portion of the Move menu. You are prompted to Select first corner of
area to <MOVE>.
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9.

Draw an area box around the entire drawing. To do this, click at the upper left of the drawing,
drag your mouse diagonally downward until the rubber band surrounds the entire drawing, and
click again in response to the prompt to Select second corner of area to <MOVE>. DataCAD moves
all the entities in your drawing to absolute zero.

Moving Entities by Specific Distance and Angle
When you use Move, you are prompted to enter two points. The distance between these two points will
be the distance the entity is moved from the original position; the angle defined by these two points will
be the angle of the move from the original position.
 To move an entity a specified distance and angle:
1.

Click on Move in the Edit pull-down menu or the Menu Window. Or you can click on

in

the Edit toolbar and select
from the drop-down list. The Move menu
appears. You are prompted to Select first point of the distance to move.
2.

Click in the Drawing Area or use coordinate entry to enter the first point. A directional arrow
appears; notice that moving your mouse changes the length and angle of the arrow. You are
prompted to Select second point of the distance to move. To use the same distance and angle as the
last time you used Move, click on Prev. Dist.

3.

Click in the Drawing Area or use coordinate entry to enter the second point. A selection menu as
well as other options appear in the Move menu. The points you select in steps 2 and 3 can be
selected anywhere on the screen; they indicate the distance and angle to move only, not the
beginning and ending points of the move.

4.

Move the selected entities in the Z direction if necessary. To do this, click on Move Z and use the
value menu to enter the distance to move the entities in the Z direction. Press (Enter) or rightclick to return to the Move menu.

5.

Toggle Layer Search on if the entities you want to move are on a different layer than the active
layer.

6.

Toggle And Copy on to copy the selected entities the specified distance and angle.

7.

Click on a selection method in the menu. You are prompted to select the entities you want to
move. For more information on using selection menus, see “Selection Menus” in “The Drawing
Board” chapter.

8.

Select the entities; they are moved in the drawing. You can continue selecting entities to move
them at the same distance and angle.


To move entities at the same distance and angle but in the opposite direction, click on Invert
and then select the entities to be moved.



To enter a new distance and angle, click on New Distance and continue with step 2 above.
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Figure 12.15: Specifying the distance and angle to move a polygon

Moving Entities by Dragging
One advantage to dragging entities is that you have the option to select multiple entities before moving
them.
 To move entities by dragging them:
1.

Click on Move in the Edit pull-down menu or the Menu Window. The Move menu appears. Or
you can click on
in the Edit toolbar and select
drop-down list and skip to step 3.

from the

2.

Click on Drag in the Move menu. The Drag menu appears.

3.

Toggle Layer Search on if the entities you want to move are on a different layer than the active
layer.

4.

Toggle And Copy on to copy the selected entities as you drag them.

5.

Change the maximum number of lines to be displayed if your entities are complex and you want
a smoother drag. Click on Max. Lines and use the value menu to enter the number of lines. Press
(Enter) or right-click to return to the Drag menu. When the entities you selected to drag contain
more lines than the Max. Lines setting, a rectangular box representing the selected entities
appears when you begin to drag them. The entities reappear after you select a new location for
them. When you set Max. Lines to 0, the rectangular box is always displayed while dragging.

6.

Toggle Multiple on to make multiple selections of entities to be moved.

7.

Click on a selection method in the menu. You are prompted to select the entities you want to
move.

8.

Select the entities to be moved. You are prompted to select a point to drag from.

9.

Skip to step 10 if Multiple is toggled off. If you toggled Multiple on in step 6, click on Begin and
continue with step 10.

10. Click on a point in the Drawing Area; you can also use coordinate entry or object snapping to
select this point. For more information on using coordinate entry, see “Drawing Using
Coordinate Entry” in “The Drawing Board” chapter.
11. Move your mouse to drag the entities to their new position and click to place them. The entities
are moved in the drawing.
12. Continue dragging and placing copies of the selected entities if And Copy is toggled on.
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Moving Entities to Another Layer
When you have more than one layer in your drawing, the To Layer option appears in the Move menu. To
Layer is used to move entities from one layer to another in your drawing. You can move entities in the
same position as the original layer (no distance and angle entered) or you can move entities to another
layer at a specified distance and angle. For more information on creating layers, see “Creating Layers” in
the “Before You Draw” chapter.
 To move entities to another layer without changing their positions:
1.

Click on Move in the Edit pull-down menu or the Menu Window. Or you can click on
the Edit toolbar and select
appears.

in

from the drop-down list. The Move menu

2.

Click on To Layer in the Move menu. A list of all the layers in your drawing appears and you are
prompted to Select layer to move to.

3.

Click on the layer you’d like to move entities to or type the name of the layer and press (Enter).
The To Layer menu appears. Use Match and Filter to select or find the layer you want to move to.
For details on how to use these options, see “Selecting Layers Without Using Layer Names” and
“Searching for Layers” in the “Before You Draw” chapter.

4.

Toggle Layer Search on if the entities you want to move are on a different layer than the active
layer.

5.

Click on a selection method in the menu. You are prompted to select the entities you want to
move.

6.

Select the entities; they are moved to the layer you chose in step 3. You can continue selecting
entities to move them.

7.

Choose another layer to move entities to by clicking on New Layer and continuing with step 4
above.

 To move entities to another layer at a different distance and angle:
1.

Click on Move in the Edit pull-down menu or the Menu Window. Or you can click on

in

the Edit toolbar and select
from the drop-down list. The Move menu
appears and you are prompted to Select first point of the distance to move. To use the same distance
and angle as the last time you used Move, click on Prev. Dist.
Hint: The points you select in steps 2 and 3 can be selected anywhere on the screen; they
indicate the distance and angle to move only, not the beginning and ending points of the move.
2.

Click in the Drawing Area or use coordinate entry to enter the first point. A directional arrow
appears; notice that moving your mouse changes the length and angle of the arrow. You are
prompted to Select second point of the distance to move.

3.

Click in the Drawing Area or use coordinate entry to enter the second point. A selection menu as
well as other Move options appear. For more information on using coordinate entry, see
“Drawing Using Coordinate Entry” in “The Drawing Board” chapter.

4.

Click on To Layer in the Move menu. A list of all the layers in your drawing appears. You are
prompted to Select layer to move to.

5.

Click on the layer you’d like to move entities to or type the name of the layer and press (Enter). A
selection menu plus other Move options appear.
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6.

Toggle Layer Search on if the entities you want to move are on a different layer than the active
layer.

7.

Click on a selection method in the menu. You are prompted to select the entities you want to
move. For more information on using selection menus, see “Selection Menus” in “The Drawing
Board” chapter.

8.

Select the entities; they are moved to the layer you chose in step 5. You can continue selecting
entities to move them.

9.

Choose another layer to move entities to by clicking on New Layer and continuing with step 6
above.

Moving SPB-Filled Entities
You can change the order of entities that contain solid, pattern, and bitmap (SPB) fills – instead of
standard, vector-based hatch patterns – on a per-layer basis. You can move one SPB-filled entity in front
of or behind one another. If you have many of these entities, you can bring one to the front of the group
or move it all the way to the back. For more information on creating filled entities, see “Using SPB Fills
Instead of Standard Hatch Patterns” in the “Hatch” chapter.
In addition to moving the SPB-filled entities forward and backward, you can change their order using
Swap. The In Front, Behind, To Front, To Back, and Swap functions do not work with entities containing
standard, vector-based hatch patterns.
You can only move SPB-filled entities forward and backward if they are all on the same layer. If you try to
move SPB-filled entities that are on separate layers, the message Both entities must reside on the same layer!
appears in the Attention toolbar.
 To move one SPB-filled entity in front of another on the same layer:
1.

Click on Move in the Edit pull-down menu or the Menu Window. The Move menu appears. Or
you can click on
in the Edit toolbar and select
drop-down list and skip to step 3.

from the

2.

Click on In Front. The In Front menu appears and you are prompted to Select entity to move.

3.

Click on the SPB-filled entity you want to move in front of another. The entity is surrounded by
dashed lines and you are prompted to Select entity to move in front of.

4.

Click on the entity that you want to follow the one you selected in step 3. The first SPB-filled
entity you selected is now in front of the second.

 To move one SPB-filled entity behind another on the same layer:
1.

Click on Move in the Edit pull-down menu or the Menu Window. The Move menu appears. Or
you can click on
in the Edit toolbar and select
drop-down list and skip to step 3.

from the

2.

Click on Behind. The Behind menu appears and you are prompted to Select entity to move.

3.

Click on the SPB-filled entity you want to move behind another. The entity is surrounded by
dashed lines and you are prompted to Select entity to move behind.

4.

Click on the SPB-filled entity that you want to precede the one you selected in step 3. The first
entity you selected is now behind the second.
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 To move an SPB-filled entity to the front of its layer:
1.

Click on Move in the Edit pull-down menu or the Menu Window. Or you can click on
the Edit toolbar and select
appears.

in

from the drop-down list. The Move menu

2.

Click on To Front. The To Front menu appears and you are prompted to Select entity to move to
front of layer.

3.

Click on the SPB-filled entity you want to move to the front of the layer. The entity you selected is
moved.

 To move an SPB-filled entity to the back of its layer:
1.

Click on Move in the Edit pull-down menu or the Menu Window. Or you can click on
the Edit toolbar and select
appears.

in

from the drop-down list. The Move menu

2.

Click on To Back. The To Back menu appears and you are prompted to Select entity to move to back
of layer.

3.

Click on the SPB-filled entity you want to move to the back of the layer. The entity you selected is
moved.

 To exchange the order between two SPB-filled entities on one layer:
1.

Click on Move in the Edit pull-down menu or the Menu Window. Or you can click on
the Edit toolbar and select
appears.

in

from the drop-down list. The Move menu

2.

Click on Swap. The Swap menu appears and you are prompted to Select first entity to swap.

3.

Click on the first SPB-filled entity you want to swap. The entity is now surrounded by dashed
lines and you are prompted to Select entity to swap database positions with.

4.

Click on the second SPB-filled entity. The positions of the two entities are swapped.

Rotating Entities
You can turn an entity around a rotation center and position it at a specific angle. Or you can dynamically
rotate an entity, so that you can preview the rotated position before you place the entity.
 To rotate an entity:
1.

Click on Rotate in the Edit pull-down menu or the Menu Window. Or you can click on
in
the Edit toolbar. The Rotate menu appears and you are prompted to Select center of rotation.
Shortcut: Press (R) or (Shift) + (R) to access the Rotate menu.

2.

Click in the Drawing Area or use coordinate entry to enter the center of rotation. A selection
menu as well as other Rotate options appear.

3.

Toggle Layer Search on if the entities you want to rotate are on a different layer than the active
layer.

4.

Enter an angle of rotation by clicking on NewAngle. A value menu appears. The default angle of
rotation is 90. Use the value menu or type an angle and press (Enter).
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5.

Toggle And Copy on if you want to both rotate and copy the selected entities.

6.

Click on a selection method in the menu. You are prompted to select the entities you want to
rotate.

7.

Select the entities; they are rotated in the drawing. You can continue selecting entities to rotate
them at the same angle and around the same center.


To rotate entities around the same rotation center but at the opposite angle, click on Invert
and then select the entities to be rotated.



To return to the original angle, click on Invert again.



To enter a new center of rotation, click on New Center and continue with step 2 above.

 To rotate and copy an entity from the Edit toolbar:

1.

Click on
in the Edit toolbar.
in the Drawing Area.

appears

2.

Click in the Drawing Area or use coordinate entry to enter the center of rotation. A selection
menu as well as other Rotate options appear. Notice that And Copy is already toggled on.

3.

Toggle Layer Search on if the entities you want to rotate are on a different layer than the active
layer.

4.

Enter an angle of rotation by clicking on NewAngle. A value menu appears. The default angle of
rotation is 90. Use the value menu or type an angle and press (Enter).

5.

Click on a selection method in the menu. You are prompted to select the entities you want to
rotate.

6.

Select the entities; they are rotated in the drawing. You can continue selecting entities to rotate
them at the same angle and around the same center.


To rotate entities around the same rotation center but at the opposite angle, click on Invert
and then select the entities to be rotated.



To return to the original angle, click on Invert again.



To enter a new center of rotation, click on New Center and continue with step 2 above.

 To rotate an entity dynamically:
1.

Click on Rotate in the Edit pull-down menu or the Menu Window. Or you can click on
in
the Edit toolbar. The Rotate menu appears and you are prompted to Select center of rotation.

2.

Click in the Drawing Area or use coordinate entry to enter the center of rotation. A selection
menu as well as other Rotate options appear.

3.

Toggle Layer Search on if the entities you want to rotate are on a different layer than the active
layer.

4.

Click on NewAngle to enter an angle of rotation. A value menu appears. Use the value menu or
type an angle and press (Enter).

5.

Toggle And Copy on to both rotate and copy the selected entities.
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6.

Click on Dynamic to preview the rotation before you place the entity. The Max. Lines and
Multiple options appear.

7.

Set the maximum number of lines to be displayed while rotating for smoother rotating of
complex entities. Click on Max. Lines and use the value menu to enter the number of lines. Press
(Enter) or right-click to return to the Rotate menu.

8.

Toggle Multiple on to select multiple entities to be rotated.

9.

Click on a selection method in the menu. You are prompted to select the entities you want to
rotate.

10. Select the entities; they are rotated in the drawing. You can continue selecting entities to rotate
them at the same angle and around the same center.


To rotate entities around the same rotation center but at the opposite angle, click on Invert
and then select the entities to be rotated.



To enter a new center of rotation, click on NewCentr and continue with step 2 above.

More About Setting an Angle of Rotation
Not only can you set the angle of rotation using the NewAngle value menu, but you can also use other
options when you click on Match in the value menu to get exactly the angle you want. You can:


click on an entity to match its angle of rotation



select two points which define an angle of rotation to match



enter an angle of rotation and then use the inverse of that angle



enter an angle of rotation and then use the complement of that angle



enter an angle of rotation and then use the supplement of that angle

For instance, when your original angle is 30, clicking on Invert in the Match menu gives you an angle of
rotation of –30. The complement angle is 60 and the supplement angle is 150.

Stretching Entities
You can increase or decrease the length of an entity –- or even an entire room --- while maintaining
connections to adjacent entities. For example, you can stretch a wall or closet without breaking it from
connected walls.
 To stretch an entity:
1.

Click on Stretch in the Edit pull-down menu or the Menu Window. The Stretch menu appears
and you are prompted to Select first point of the distance to stretch.
Shortcut: Press (Alt) + (S) to access the Stretch menu.

2.

Click in the Drawing Area or use coordinate entry to enter the first point. A directional arrow
appears; notice that moving your mouse changes the length and angle of the arrow. You are
prompted to Select second point of the distance to stretch.
To increase the possible angles of the directional arrow, press (O) to toggle ortho mode off.

3.

Click in the Drawing Area or use coordinate entry to enter the second point. A selection menu as
well as other Stretch options appear.

4.

Toggle Layer Search on if any of the entities you want to stretch are on a different layer than the
active layer.
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5.

Click on a selection method in the menu. You are prompted to select the entities you want to
stretch.

6.

Select the entities; they are stretched in the drawing. You can continue selecting entities to stretch
them at the same distance and angle.


To stretch entities at the same distance and angle but in the opposite direction, click on Invert
and then select the entites to be stretched.



To enter a new stretch distance and angle, click on New Distance and continue with step 2
above.

Figure 12.16: Stretching a wall

Enlarging Entities
You can increase or decrease the size of an entity by entering specific enlargement values for the X, Y, and
Z axes.
You can enlarge or reduce imported bitmap and vector graphics to real-world scale. For example, if you
import a site map, you can use the Calibrate Distance function to enlarge the plan to real-world
dimensions. For more information about this, refer to “Calibrating Enlargements” in the “Symbols,
Images, and Objects” chapter.
 To enlarge an entity:
1.

Click on Enlarge in the Edit pull-down menu or the Menu Window. Or click on the

icon in

the Edit toolbar and select
from the drop-down options. The Enlarge
menu appears and you are prompted to Select center of enlargement.
2.

Click in the Drawing Area or use coordinate entry to enter the center of enlargement. A selection
menu as well as other Enlarge options appear; the enlargement factor and line spacing setting
appear in the Attention toolbar.

3.

Click on Enlarge Z to enter a Z elevation for the center of enlargement. Use the value menu to
enter a Z elevation and press (Enter).

4.

Toggle Layer Search on if the entities you want to enlarge are on a different layer than the active
layer.
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5.

Click on Enlargement in the Enlarge menu to change one or all of the enlargement factors. The X
Enlargmnt., Y Enlargmnt., Z Enlargmnt., Line Factor, and Set All options appear.

6.

Click on any enlargement factor option to display a value menu that you can use to set these
factors:


To enlarge entities along the X axis, click on X Enlargmnt.



To enlarge entities along the Y axis, click on Y Enlargmnt.



To enlarge entities along the Z axis, click on Z Enlargmnt.



To set the line spacing enlargement factor for nonsolid line types, click on Line Factor. The
Line Factor setting affects how line types like Dashed are enlarged. A setting matching those
of the X, Y, and Z enlargement factors will maintain the line type’s spacing. The Line Factor
setting cannot be applied to the geometry of referenced files.



To set all of these options to the same setting and enlarge the entity equally in all directions,
click on Set All.

7.

Use the value menu or type an enlargement setting and press (Enter).

8.

Right-click to return to the Enlarge menu.

9.

Toggle And Copy on if you want to both enlarge and copy the selected entities.

10. Click on a selection method in the menu. You are prompted to select the entities you want to
enlarge.
11. Select the entities; they are enlarged in the drawing. You can continue selecting entities to enlarge
them by the same factor and around the same center.


To enlarge entities around the same enlargement center but at different enlargement factors,
click on Invert and then select the entities to be enlarged. Invert mathematically inverts all of
the current enlargement factors and displays the new factors in the Attention toolbar. For
example, if your enlargement factor is 2.0, clicking on Invert sets it to 0.5.



To enter a new center of enlargement, click on Center and continue with step 2 above.

You can use the

options in the drop-down list when you click on

in the Edit toolbar to enlarge entities by set amounts. If you select the option
, you must first indicate an enlargement center; then the Set All value menu
appears, prompting you to Enter enlargement factor.
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Erasing Entities
You can remove entities from your drawing by simply using the selection menu in the Erase menu to
select the entities. You can also erase a specific segment of a line, circle, or curve.
All entities in an array are identified as a single group. To erase entities within an array, use the Entity or
Area selection method.
 To erase an entity:
1.

Click on Erase in the Edit pull-down menu or the Menu Window. You can also click on
the Edit toolbar. The Erase menu appears.

in

Shortcuts: Press (E) or (Shift) + (E) to access the Erase menu. Press (,) to erase the last entity
you drew. Press (<) to erase the last group of entities, such as an entire array.
2.

Toggle Layer Search on if the entities you want to erase are on a layer other than the active layer.

3.

Click on a selection method in the menu. You are prompted to select the entities you want to
erase.

4.

Select the entities; they are erased from the drawing. You can continue selecting entities to erase
them.
Avoid choosing an entity where it crosses another entity because it may be difficult for DataCAD
to know which one you want to select. Zoom in on your drawing or change your view to select
entities more precisely.

5.

Right-click when you’re finished erasing entities to exit the Erase menu.

 To erase a selected piece of an entity:
1.

Click on Partial Erase in the Edit pull-down menu or select Erase in the Edit menu in the Menu
Window. You can also click on

in the Edit toolbar. The Erase menu appears.

2.

Click on Partial in the Erase menu. The Partial menu appears.

3.

Toggle Layer Search on if the entities you want to erase are on a layer other than the active layer.
You are prompted to Select entity to modify.

4.

Click on the entity. It appears in dashed lines to indicate that you selected it. You are prompted to
Select first point of line segment to remove.
You cannot partially erase a B-spline or Bezier curve, polyline, or contour.

5.

Object snap or click on one point of the segment you want to remove. You are prompted to Select
second point of line segment to remove.

6.

Object snap or click on the other endpoint of the segment you want to remove.


When erasing the end of an entity, select the second point slightly beyond the end of the
segment to avoid leaving a single point at the end of the line.



If you’re erasing part of a line, the line segment you selected is removed; skip to step 8.



If you’re erasing part of a curve or circle, you are prompted to Select point on arc to clip out.

7.

Click between the two points you selected to remove that segment of the curve or circle or click
outside the two points you selected to remove the rest of the curve or circle.

8.

Repeat steps 4 – 7 as necessary to continue erasing entities. When you’re finished erasing entities,
right-click to exit the Erase menu.
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Editing Multiple Entities
You can associate entities in DataCAD to simplify editing groups of entities, making your drawing
process more efficient and productive. Simple linking groups selected entities together, while selection
sets associate entities and groups based on their attributes.

Grouping Entities Together
You can combine entities, groups, areas of your drawing, or even multiple selection sets into a single
group to make editing easier.
Caution: When you group entities, DataCAD moves all entities in the group to the same layer. By
definition, all entities in a group must be on the same layer.
 To group or link entities:
1.

Click on Group in the Edit menu in the Menu Window or click on Group Entities in the Tools
pull-down menu. The Group menu appears.
Shortcut: Press (Alt) + (K) to access the Group menu.

2.

Toggle Layer Search on if the entities you want to group together are on different layers.
Note: When you select entities that are on other layers, DataCAD moves all entities to the current
layer. By definition, a group resides on one layer.

3.

Click on a selection method in the menu. You are prompted to select the entities you want to link
together into a group.

4.

Click on the entities you want to group; they are displayed in dashed lines as you select them.

5.

Right-click when you’re finished selecting entities. This groups or links the selected entities
together.

6.

Click on Exit or right-click again to exit the Group menu.

 To ungroup or separate entities:
1.

Click on Group in the Edit menu in the Menu Window or click on Group Entities in the Tools
pull-down menu. The Group menu appears.

2.

Toggle Layer Search on if the groups you want to separate are on different layers.

3.

Toggle Un-Group on in the Group menu.

4.

Click on a selection method in the menu. You are prompted to select the entities you want to
separate.

5.

Click on the entities you want to separate; they are displayed in dashed lines as you select them.

6.

Right-click when you’re finished selecting entities. This removes the selected entities from the
group.

7.

Click on Exit or right-click again to exit the Group menu.

(Pro) Working with Selection Sets
Selection sets are temporary storage containers, used to quickly identify and edit certain entities in your
drawing. There are eight selection sets available in DataCAD.
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Unlike grouping entities, selection sets do not regroup entities; in fact, entities in a selection set will
maintain their association with their group. Instead, you can identify entities by particular attributes,
associate those entities with a selection set, and then select all of those entities at once by using the Sel. Set
option in the selection menus. Instead of using the usual selection methods when moving or copying
entities, for instance, you can specify a selection set to edit.
 To display the entities in a selection set:
1.

Click on Sel. Sets in the Edit menu in the Menu Window or click on Selection Sets in the Tools
pull-down menu. The Sel. Sets menu appears.

2.

Click on Show Set in the Sel. Sets menu. All eight selection sets available in DataCAD appear.

3.

Click on the selection set you want to view. All entities in that selection set are displayed in
dashed lines; if there are no entities in that selection set, nothing in your drawing will be
displayed in dashed lines.

 To add entities to a selection set:
1.

Click on Sel. Sets in the Edit menu in the Menu Window or click on Selection Sets in the Tools
pull-down menu. The Sel. Sets menu appears.

2.

Click on Add To Set in the Sel. Sets menu. All eight selection sets available in DataCAD appear in
the Menu Window. You can add entities to a selection set automatically. See “Automatically
Adding to Selection Sets” later in this chapter for more information.

3.

Click on the selection set you want to add entities to. All entities already in that selection set are
displayed in dashed lines and the Add To Set menu appears.
If you need to delete an entity from a selection set, click on Del From Set in the Add To Set menu
to quickly access the Del From Set menu.

4.

Click on Mask. Four entity attribute types appear: Entity, Color, Line Type, and Weight. These
attribute type settings are set to All by default, as noted in the Attention toolbar. You can change
any or all of these settings. These settings apply not only to the Add To Set menu but also to the
Del From Set menu.
Besides using Mask, you can add entities to a selection set by simply clicking on them; they are
displayed in dashed lines as you select them.


To include only certain types of entities in the selection set, click on Entity. A list of entity
types appears. Click on every entity type that you want to add to the selection set. Right-click
when you’re finished selecting.



To include only certain entity colors in the selection set, click on Color. A color menu
appears. Click on every color for entities that you want to add to the selection set. Right-click
when you’re finished selecting.



To include only certain line types in the selection set, click on Line Type. A list of line types
appears. Click on the line type that you want to add to the selection set.



To include only certain entity line weights in the selection set, click on Weight. A value menu
appears. Use the value menu to enter the line weight of entities you want to add to the
selection set and press (Enter).

5.

Right-click to return to the Add To Set menu.

6.

Toggle Layer Search on if the entities you want to add to the selection set are on different layers.
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7.

Click on Area or Fence in the selection menu. You are prompted to select the entities you want to
add to the selection set. It may be beneficial to simply enclose the entire drawing in the area or
fence box, so that every entity that matches attribute settings is added to the selection set. For
more information on how to use Area or Fence, see “Selection Menus” in “The Drawing Board”
chapter.

8.

Select the entities you want to add to the selection set. All selected entities matching the mask
settings are displayed in dashed lines.

9.

Right-click to exit the Add To Set menu and return to the Sel. Sets menu.

 To delete entities from a selection set:
1.

Click on Sel. Sets in the Edit menu in the Menu Window or click on Selection Sets in the Tools
pull-down menu. The Sel. Sets menu appears.

2.

Click on Del From Set in the Sel. Sets menu. All eight selection sets available in DataCAD appear.

3.

Click on the selection set you want to delete entities from. All entities in that selection set are
displayed in dashed lines and the Del From Set menu appears.
If you need to add an entity to a selection set, click on Add To Set in the Del From Set menu to
quickly access the Add To Set menu.

4.

Click on Mask. Four entity attribute types appear: Entity, Color, Line Type, and Weight. These
attribute type settings are set to All by default, as noted in the Attention toolbar. You can change
any or all of these settings. These settings apply not only to the Del From Set menu but also to the
Add To Set menu.
Besides using Mask, you can also delete entities from a selection set by simply clicking on them;
they are displayed in their assigned line type as you select them.


To choose the type of entity you want to delete from the selection set, click on Entity. A list of
entity types appears. Click on every entity type that you want to delete from the selection set.
Right-click when you’re finished selecting.



To choose the color of entities you want to delete from the selection set, click on Color. A
color menu appears. Click on every color for entities that you want to delete from the
selection set or click on Match and then click on entities of the color you want to delete.
Right-click when you’re finished selecting.



To choose the line type of entities you want to delete from the selection set, click on Line
Type. A list of line types appears. Click on the line type that you want to delete from the
selection set.



To choose the line weight of entities you want to delete from the selection set, click on
Weight. A value menu appears. Use the value menu to enter the line weight of entities you
want to delete from the selection set and press (Enter).

5.

Right-click to return to the Del From Set menu.

6.

Toggle Layer Search on if the entities you want to delete from the selection set are on different
layers.

7.

Click on Area or Fence in the selection menu. You are prompted to select the entities you want to
delete from the selection set. For more information on how to use Area or Fence, see “Selection
Menus” in “The Drawing Board” chapter.
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8.

Select the entities you want to delete from the selection set. All selected entities matching the
mask settings are displayed in their normal line type; entities still in the selection set remain
displayed in dashed lines.

9.

Right-click to return to the Sel. Sets menu.

To edit a selection set, the set must be active. See “Automatically Adding to Selection Sets” above for
details on how to activate a selection set.
(Pro) More About Selection Sets
Selection sets let you select entities in your drawing based on particular attributes of those entities. For
instance, you may want to change all yellow text in your drawing to green. The complexity of your
drawing combined with a lot of yellow text would make it time-consuming and even difficult to use the
standard selection methods to identify the entities in your drawing that you want to change to green.
However, masking by Entity (text) and Color (yellow) and then using the Area selection method to select
the entire drawing quickly adds all yellow text to the selection set. To change the color of the yellow text
to green, simply select Green from the color menu in the Change menu and then click on Sel. Set; the text
color is changed.
(Pro) Clearing Selection Sets
Because there are only eight selection sets available, you may occasionally need to reuse one that you’ve
already defined. Before you can redefine a selection set, you must first delete its current contents.
 To clear a selection set:
1.

Click on Sel. Sets in the Edit menu in the Menu Window or click on Selection Sets in the Tools
pull-down menu. The Sel. Sets menu appears.

2.

Click on Clear Set in the Sel. Sets menu. All eight selection sets available in DataCAD appear in
the Menu Window, and you are prompted to Select selection set to clear.

3.

Click on the selection set you want to clear. You are prompted to verify whether you want to clear
that selection set.

4.

Click Yes to clear the selection set; the selection set is cleared. Click No to cancel the clear
function.

(Pro) Naming Selection Sets
You can name your selection sets to help you better identify them.
Shortcut: To activate a selection set, press (Alt) + a number 1 through 8, which corresponds to the
number of the selection set. For instance, press (Alt) + (1) to make Sel. Set1 active; press (Alt) + (1) again
to deactivate selection set 1.
 To name a selection set:
1.

Click on Sel. Sets in the Edit menu in the Menu Window or click on Selection Sets in the Tools
pull-down menu. The Sel. Sets menu appears.

2.

Click on Rename Set in the Sel. Sets menu. All eight selection sets available in DataCAD appear in
the Menu Window and you are prompted to Select selection set to rename.

3.

Click on the selection set you want to name. You are prompted to Enter new name.

4.

Type a name for the selection set and press (Enter). The selection set is named.

5.

Repeat steps 3 – 4 to continue naming sets. Right-click when finished to return to the Sel. Sets
menu.
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(Pro) Automatically Adding to Selection Sets
Another way to add entities to a selection set is to append them as you draw them. Simply set the active
selection set and then toggle Append on in the Sel. Sets menu.
 To automatically add entities to a selection set:
1.

Click on Sel. Sets in the Edit menu in the Menu Window or click on Selection Sets in the Tools
pull-down menu. The Sel. Sets menu appears.

2.

Click on Set Active in the Sel. Sets menu. All eight selection sets available in DataCAD appear in
the Menu Window and you are prompted to Select selection set to set active.

3.

Click on the selection set you want to activate. A dollar sign ($) appears before the selection set’s
name in the menu window and the active selection set name appears in the Status Panel toolbar.

4.

Right-click to return to the Sel. Sets menu.

5.

Toggle Append on in the Sel. Sets menu. Any entities you draw will now be automatically added
to the active selection set.

Clipping and Cropping
The ClipIt macro can be used to erase, move, or copy 2D and 3D lines, 2D arcs, or 2D circles. ClipIt is
especially useful for editing hatched areas in elevation drawings or for copying large portions of your
drawing. Entities that are clipped or cropped retain such attributes as line type and line color. Circles, 2D
arcs, and 2D lines all retain their Z-base and Z-height settings. The Z values for the new endpoints for 3D
lines are recalculated based on the slope of the line.
ClipIt only works in orthographic (plan) view. So if you are using a perspective view, DataCAD will
automatically switch to plan view for ClipIt functions and then switch back to perspective view when
you exit ClipIt.
Caution: Make sure you leave the ClipIt macro by clicking the Exit button in the Menu Window. This
macro creates a temporary file that it uses as an undo buffer. If you exit the ClipIt macro by right-clicking,
this temporary undo buffer is not deleted. That can lead to file corruption in future drawing sessions.
When you click on the Exit button to leave the ClipIt macro, you delete the temporary undo buffer.
You can choose whether to clip or crop the selected portion of your drawing. Clipping selects entities
inside the selection boundary, while cropping selects entities outside the selection boundary.

Figure 12.17: Clipping vs. cropping
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You can also choose to erase the selection from your drawing, move the selection to another place in your
drawing, or copy the selection to another place in your drawing.

Figure 12.18: Different results from cutting, cutting and copying, and copying
 To clip or crop entities in your drawing:
1.

Click on ClipIt in the Toolbox pull-down menu. The ClipIt menu appears. If ClipIt is not listed as
a macro, click on Configure in the Toolbox pull-down menu and add ClipIt to the Macros in
Menu list.

2.

Toggle one of the four boundary types (Area, Fence, Radius Circ., or DiaCirc) on. The ClipIt
boundary separates a selected area from the rest of your drawing, allowing you to select entities
either inside or outside of it.


Area lets you draw a rectangular boundary by selecting two diagonal corners of the
rectangle.



Fence lets you draw a polygonal boundary with up to 36 sides that can be concave or convex
as long as its lines don’t cross. If you select less than 36 points for the boundary, right-click to
finish the polygon.



Radius Circ. lets you draw a circle by defining its radius (select its center point and a point on
the circle).



DiaCirc lets you draw a circle by defining its diameter (select two points opposite each other
on the circle).

Generally, ClipIt processes entities most quickly when the boundary is a rectangle or a simple
polygon with only three or four sides. A circular boundary will process more slowly and a more
complex polygon will have the slowest processing time.
3.

Click on Cut to erase entities, click on CutCopy to move entities, or click on Copy to copy entities.
You can clip or crop entities from multiple layers, but you can only copy entities to the active
layer.

4.

Click on Clip to select entities inside the boundary you will draw or click on Crop to select
entities outside the boundary.

5.

Click on 2D Line, 3D Line, 2D Arc, or Circle to specify the type of entity you want to select. You
can select one or any combination of these four entity types.

6.

Toggle Boundry on to leave the outline of the boundary in your drawing. (See “After Clipping”
for Cut and CutCopy in Figure 12.18 for an example of a boundary outline.)

7.

Toggle LyrSrch on to clip or crop entities on all layers that are toggled on; toggle LyrSrch off to
clip or crop entities on only the active layer.
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To decrease processing time, click on Layers in the ClipIt menu and toggle off all the layers that
don’t have entities that you want to clip or crop. This Layers option accesses the Layers menu in
DataCAD without exiting ClipIt.
8.

9.

Select points as prompted to draw the boundary. After you select the last point for the boundary:


If you toggled Cut on, selected entities are clipped or cropped. Skip to step 11.



If you toggled CutCopy or Copy on, you are prompted to Enter point to drag from.

Click in the Drawing Area to enter the point where your cursor will attach to the copy. You are
prompted to Enter point of insertion on [the active layer].

10. Place the copy in your drawing. To do this, move your mouse and click in the Drawing Area, use
coordinate entry, or object snap to an existing entity. Repeat this step to continue placing copies.
11. Repeat steps 2 – 10 to continue clipping or cropping. When you are finished, click on Exit to close
the ClipIt macro.
If your drawing is very complex, the percentage of entities clipped/cropped (not the percentage of
processing time) appears in the Attention toolbar. When processing is complete, the total time is also
displayed.
You can change the layer to copy to – without changing the active layer setting – by clicking on To Layer in
the ClipIt menu and selecting the layer you want to copy to. To create new layers to copy to, use the
Layers option in the ClipIt menu to quickly access the Layers menu without exiting ClipIt.

Chapter 13 Text, Notes, and
Labels
You can add notes, labels, and other text to your drawing using
DataCAD’s Text tools. You can control text appearance and
justification, save these settings as a text style that you can use in
any drawing, and check for spelling errors. To place text in your
drawing, simply click in the Drawing Area to select a
justification point or define an area to fit the text into. With either
method, you can position notes quickly and precisely.
Text can be imported into your drawing or even exported from
it. DataCAD uses text (.TXT) files in each of these processes.
You can use Windows TrueType fonts to enter text in your
drawings.
You can also add room, door and window labels using some of
DataCAD’s macros. Descriptive attributes can even be assigned
to door and window labels and later applied to schedules and
reports.
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Drawing Text
Text can be entered and edited anywhere in your plan. DataCAD has 23 text fonts you can use, and you
can add your own fonts to your DATACAD\Fonts folder. You can also use any TrueType fonts (TTF) that
you have installed in the Windows\Fonts folder on your computer.
When the Text menu appears, the text cursor replaces the standard drawing crosshairs. This cursor
appearance represents the current text height, angle, slant, and aspect ratio settings. To change the
appearance of text already in your drawing, you must select Change\Text\Font to open the Set Text
Parameters dialog box. This lets you change text parameters. See “Changing Text Attributes” in the
“Editing Drawings” chapter.
 To add text to your drawing:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on

2.

in the Draw toolbar. The Text menu appears.

Customize the appearance of text by clicking on each setting option in the Text menu or by
clicking on Font to change all the settings at once. If you click on Font, the Set Text Parameters
dialog box appears.
Note: Using the Set Text Parameters dialog box saves time and shows you a sample of the font
in the preview window before you click OK.

Figure 13.1: The Set Text Parameters dialog box


Click on a font in the FontName list box. Keep in mind that the fonts displayed under
FontName are determined by the Font Type selection in the lower-left corner of the dialog
box. You can display TrueType fonts (TTF), DataCAD fonts (SHX), or both in the list.
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Note: Prior to DataCAD 12, each drawing had its own swap space for stroke fonts and could only
display up to 64 fonts simultaneously. Fonts are now stored globally for all drawings and
DataCAD can display an unlimited number of fonts.


To set the text’s actual size in your drawing, type a height value or click on one in the Height
list box. With Text Scale toggled on, text is entered in the drawing relative to the current plot
scale setting. For example, if you set Height to 1” and the plotting scale to ¼”, text entered in
your drawing would appear 4’ high.



To set the angle of the lines of text, type an angle value or click on one in the Angle list box.



The aspect ratio of text is the height relative to the width of each character. An aspect ratio of 1
represents the normal character style, while an aspect ratio of 5 produces text that is taller
and narrower. To set the height of each character relative to its width, type an aspect ratio
value or click on one in the Aspect list box.



When using an SHX font (not a TTF font), you can set the angle of each character of text, as
measured from the base of the character to its top. Type a slant value or click on one in the
Slant list box.



When using an SHX font (not a TTF font), you can set a text weight from 1 to 99, with “1”
being the default weight setting. For example, to triple the weight of text, set Weight to 3. To
set the line weight of the text, type a weight value or click on one in the Weight list box.
Another way to produce heavy text on a drawing is to place it on a separate layer and then
define a unique color for that layer. When you plot the drawing, you can assign a thicker pen
to that layer. See “Using Pen Tables” in the “Printing Your Drawing” chapter for details on
how to set pens for plotting.



When using a TrueType font, you can select a font style. Click on a style in the TTF Style list
box.



When using a TrueType font, you can set the properties for the font using the TTF Properties
options. Select Fill, Outline, or Both and then set the colors for the Fill and Outline, as
necessary.

3.

Click on OK to save the text parameter changes and close the dialog box.

4.

Set the space between lines of text by clicking on Factor in the Text menu. Use the value menu or
type a factor for your text; right-click to return to the Text menu. DataCAD calculates the amount
of space between lines of text by multiplying the text height by the factor.

5.

Toggle Dynamic on to enter text directly into the drawing as you type it. Toggle Dynamic off to
enter the text only in the Message toolbar; you will have to press (Enter) to add the text to the
drawing.
Hint: With Dynamic on, your cursor must remain in the drawing window if you want carriage
return to work when you press (Enter).

6.

Toggle Text Scale on to size your text by using the Size setting relative to the current plot scale. If
you toggle Text Scale off, the text size displays and plots, according to the Height setting in the
Set Text Parameters dialog box.

7.

Toggle All Caps on to enter your text in capital letters; toggle All Caps off to enter text as you
typed it.

8.

Decide on how you want to align the text. Use the Alignment button to set text appearance before
entering text. To left align text, toggle Left on; to center align text, toggle Center on; to right align
text, toggle Right on.
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If you want to align text that has already been entered, use the Justify button.
9.

Click in the Drawing Window or use coordinate entry to select the point where text should be
entered in your drawing. This is the point of justification for the text you enter.

10. Type the text. If you toggled Dynamic on in step 5, the text appears in the drawing as you type; if
Dynamic is toggled off, the text appears in the Message toolbar and you must press (Enter) to
add the text to the drawing.
Text can include many other characters in addition to those found on the keyboard. These
extended characters are typed by pressing (Alt) + a character number. See the Appendix for a
complete list of extended characters.
11. Click on Exit or right-click when you’re finished entering text.

Justifying Text
You can change the justification of text after you enter it in your drawing. Text can be justified to the left,
center, or right of a justification line that you define.
 To justify text in your drawing:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on

2.

in the Draw toolbar. The Text menu appears.

Click on Justify in the Text menu. You are prompted to Select first point on justification line.
The justification line should be vertical, not horizontal.

3.

Click in the Drawing Area or use coordinate entry to enter the first point of the justification line.
You are prompted to Select second point on justification line.

4.

Click in the Drawing Area or use coordinate entry to enter the second point of the justification
line. The Justify menu appears.

5.

Decide how you want to justify the text. To left justify text, toggle Left on; to center justify text,
toggle Center on; to right justify text, toggle Right on.

6.

Click on a selection method in the menu. You are prompted to select the text you want to justify.
For more information on using selection menus, see “Selection Menus” in “The Drawing Board”
chapter.

7.

Select the text you want to justify. The text is aligned with the justification line, according to the
justification setting you chose in step 5.

8.

Continue selecting text to justify it to the same justification line; click on NewLine to define a new
justification line and continue with step 3 above; or right-click to return to the Text menu.

Aligning Text
You can control the alignment of the text you use in your drawing. There are nine text alignment points:


Top - Left



Top – Center



Top – Right



Middle – Left



Middle – Center
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Middle – Right



Bottom – Left



Bottom – Center



Bottom - Right

 To set the alignment for the text you enter into your drawing:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on

in the Draw toolbar. The Text menu appears.

2.

Click on Alignment in the Text menu. The Alignment menu appears.

3.

Use the toggles to control the way your text will be inserted.
Left
Center
Right
Top
Middle
Bottom
Aligned
Fit
Reversed
Mirrored

4.

Text inserted from left to right.
Text inserted from the center.
Text inserted from right to left.
Cursor is at the top of the characters you input.
Cursor is at the midpoint of the characters you input.
Cursor is at the bottom of the characters you input.
Adjusts text to fit between two given points.
Adjusts text to fit a certain width and height.
Draws each character backward from right to left.
Draws each character upside down from left to right.

Right-click to return to the Text menu.

The text cursor coincides with the current text alignment setting. A “+” marker is incorporated into the
carat as a visual indicator of the current alignment setting.

Fitting Text into Defined Areas
Another way to enter text in your drawing is to define the height and width of the area where you’d like
to place a line of text. The text size and aspect ratio are automatically calculated so that the text you type
fits into the area you defined.
 To fit text into an area:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on

in the Draw toolbar. The Text menu appears.

6.

Click on Alignment in the Text menu. You are prompted to Set text alignment method.

7.

Toggle Fit on. Then right-click to display the Fit Text menu. You are prompted to Select text start
point.

8.

Click in the Drawing Area or use coordinate entry to enter the point where you want the text to
begin. You are prompted to Select text endpoint.

9.

Click in the Drawing Area or use coordinate entry to enter the point where you want the text to
end. You are prompted to Select point to mark text height.

10. Click in the Drawing Area or use coordinate entry to enter a point; this point and the endpoint
you selected in step 5 define the height of the area. You are prompted to Enter text.
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11. Type the line of text that you want to fit in the defined area. Then press (Enter). DataCAD
calculates the aspect ratio and size so that it can fit the text you typed into the area you defined.
This changes the Aspect and Size settings in the Text menu.
To return Aspect and Size to their previous settings (before you used Fit), change them in the Text
menu.
8.

Enter additional lines of text using the same aspect ratio and size calculated in step 7 by simply
typing them. Since DataCAD does not support word wrapping, you must press (Enter) at the end
of each line.

Figure 13.2: Three words fit in the parameters set in steps 3 through 5
9.

Stop fitting text within the defined area by right-clicking to return to the Fit Text menu, selecting
Alignment to go to the Alignment menu, clicking on Aligned, and right-clicking to go to the
Aligned Text menu. Then you can select the text start point and type the information. If you
right-click again, you return to the Edit menu.
If you do not toggle Aligned on, DataCAD will continue using the Fit criteria the next time you type
text. In the Alignment menu, Aligned and Fit are mutually exclusive toggles.

(Pro) Checking Text for Spelling Errors
Although not a new feature, spell-checking was not documented in recent versions of the DataCAD
User’s Manual.
When you type text in your Drawing Window, you don’t have to worry if you lost the spelling bee when
you were in school. DataCAD provides a spell-check function much like the ones found in word
processing programs.
 To check spelling and correct errors:
1.

Type text in your Drawing Window.

2.

Select Spelling from the Tools pull-down menu. The Spell Check menu appears.
Shortcut: Press (Ctrl) + (F7) to access the Spell Check menu.

3.

Select the text you want to spell-check, by using Entity, Group, Area, Fence, Mask, Layer Search,
or All (which applies to all visible layers).

4.

Click on the text you want to check for errors. The Check Spelling dialog box appears. The text
you selected appears in a preview box. DataCAD highlights the first misspelled word it
encounters, copies it into the Not in Dictionary field, offers alternatives in the Suggestions box, or
gives you access to one or more dictionaries in the Add words to box.
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If DataCAD doesn’t detect an error in the text, the Check Spelling dialog box will not appear. The
labels of some buttons and text boxes in the Check Spelling dialog change according to the
context.

Figure 13.3: The Check Spelling dialog box offers suggestions and other options.
5.

Use the buttons to indicate your choices.
Ignore
Ignore All
Add

Skips the highlighted word.
Skips all instances of the highlighted word in the selected text.
Lets you put a word (such as your last name) in the spelling dictionary you selected in the Add
words to drop-down list.
Change
Replaces the current highlighted word with the one you selected from the Suggestions box. If
you edited the word, DataCAD uses that as the replacement.
Change All Replaces the highlighted word throughout your selected text. If you edited the word, that is
used as the replacement word.
Suggest
Searches more thoroughly each time you click on it. This button is disabled when all possible
suggestions have been located.
Undo
Removes the last change made. Pressing Undo several times removes the last several changes.
Options
Opens the Options dialog box.
Dictionaries Opens the Dictionaries dialog box
Help
Cancel
Stops the current spelling check

6.

Continue making decisions about other misspelled words. Once DataCAD corrects the
highlighted word, it automatically goes to the next misspelled one. If there are no more
misspelled words, the Check Spelling dialog box closes automatically. If you decide not to
continue checking spelling, just click on Cancel.

You can change the way the spelling checker operates.
 To modify the spell-checking criteria:
1.

Click on the Options buttons in the Check Spelling dialog box. The Options menu appears.
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Figure 13.4: The Check Spelling Options dialog box
2.

Click in a box to select an option, indicated with a checkmark. You can click in a box that contains
a checkmark to remove it.
Ignore capitalized words: Ignores (skips over without checking) any words beginning with a capital letter.
This is useful if the text being checked contains many proper names.
Ignore all-caps words: Ignores (skips over without checking) any words containing all capital letters. This is
useful if the text being checked contains many acronyms.
Ignore words with numbers: Ignores (skips over without checking) any words containing embedded digits.
Examples of such words include “Win98” and “Q4.” This is useful if the text being checked
contains many code words or other symbols containing digits.
Ignore words with mixed case: Ignores (skips over without checking) any words containing an unusual
mixture of upper- and lower-case letters. Examples of such words include “MicroHouse” and
“CapsLock.” This is useful if the text being checked contains many variable names or other
symbols which use case changes to distinguish words.
Ignore domain names: Ignores (skips over without checking) any words that appear to be Internet domain
names (such as “wintertree-software.com”).
Report doubled words: Reports any word that appears twice in a row.
Case sensitive: Distinguishes between capitalized and non-capitalized words. For example, “canada” is
considered different from “Canada,” so “canada” would be reported as a misspelling. When
the option is disabled, “canada” and “Canada” are considered identical. Disabling this option
reduces the performance of the spelling checker.
Phonetic suggestions: Makes suggestions based on phonetic (sounds-like) similarity to the misspelled word.
This tends to improve suggestions for badly misspelled words. This option increases the time
required to locate suggestions.

Either the Phonetic suggestions or Typographical suggestions option must be enabled or no
suggestions will be offered.
Typographical suggestions: Makes suggestions based on typographical (looks-like) similarity to the
misspelled word. This is appropriate for people who are generally good spellers.
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Suggest split words: Suggests two separate words as a replacement for a misspelling containing two joined
words. For example, “is the” would be suggested as a replacement for “isthe.”
Auto correct: Automatically changes words marked with "Auto Change" actions to their specified
replacements. When disabled, you are prompted before the words are changed.

3.

Check the Main Dictionary language option. You can set the language of the main dictionary
used to check spelling. The list shows only languages for which dictionaries are installed on your
system. To check spelling in a different language, select the language in the list.

Figure 13.5: Select the dictionary’s language
4.

Select one of the options in the Suggestions area. These options determine the speed and accuracy
of the initial search for suggested replacements for misspelled words. When a misspelled word is
detected, a search is automatically made for suggestions. This option controls the speed and
accuracy of this automatic search. Pressing the Suggest button in the Check Spelling dialog
causes an increasingly more accurate (but slower) search for suggestions.

5.

Close the Options dialog when you are ready to resume checking spelling in your file.
OK
Cancel

Closes the Options dialog and saves any changes made to the option settings.
Closes the Options dialog and discards any changes made to the option settings.

The Dictionaries dialog box lets you open and close user dictionaries and edit the contents of an open
user dictionary. The contents of dictionaries are saved in disk files. You can open some or all user
dictionary files at any time. Only open dictionaries are searched during a spelling check.
 To add a word to the user’s dictionary:
1.

Click on the Dictionaries button in the Check Spelling dialog box. The Dictionaries dialog box
appears.
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Figure 13.6: The Dictionaries dialog box
2.

Click on the arrow to display options in the Action area. Then choose the appropriate option
from the drop-down list.

Figure 13.7: The Action pull-down menu
Auto change (use case of checked word): Automatically replaces one word with another. For example, if you
often type “recieve” instead of “receive,” you might enter the word “recieve” with “receive” as
the other word and "Auto change (use case of checked word)" as the action. The spelling
checker automatically corrects “recieve” wherever it appears. If it is capitalized (“Recieve”),
the spelling checker automatically replaces it with “Receive.” The replacement is made
automatically only if the "Auto change" option is enabled (see the Options Dialog for
information on the Auto change option).
Auto change (use case of other word): Automatically replaces one word with another, always with the same
case pattern as the other word. This is useful for automatically expanding abbreviations. For
example, you could enter “TBD” with “to be determined” as the other word and "Auto change
(use case of other word)" as the action. The spelling checker automatically replaces “TBD”
with “to be determined” wherever it appears. The replacement is made automatically only if
"Auto change" is enabled (see the Options Dialog for information on the Auto change option).
Conditionally change (use case of checked word): Lets you optionally replace one word with another. For
example, if you often type “receive” instead of “receive,” you might enter the word “receive”
with “receive” as the other word and “Auto change (use case of checked word) ” as the action.
The spelling checker asks if you want to replace “receive” with “receive.” If it is capitalized
(“Receive”), the spelling checker asks if you want to replace it with “Receive.”
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Conditionally change (use case of other word): Lets you optionally replace one word with another, always
with the same case pattern as the other word. This is useful for optionally expanding
abbreviations. For example, you could enter the word “TBD” with “to be determined” as the
other word and "Conditionally change (use case of other word)" as the action. The spelling
checker asks if you want to replace “TBD” with “to be determined.”
Exclude (treat as misspelled): Tells the spelling checker that the word is misspelled, even if it is listed in
another dictionary. Words marked with “Exclude” will never be offered as suggestions for
misspelled words and they will be reported as misspellings when they are encountered by the
spelling checker. The spelling checker looks up words in user dictionaries in the order in
which they appear in the Files list. If you want to exclude a word, make sure it doesn't appear
in a previous user dictionary.
Ignore (skip): Tells the spelling checker that the word is spelled correctly and can be skipped over. This is
the most common action.

3.

Click on the button in the Words portion of the Dictionaries dialog box that performs the action
you want. This portion lists words in the currently selected user dictionary.
Add Word button: Adds the word you type in the Words input box to the currently selected dictionary. The
currently selected action and other word are associated with the word. You can use the Add
Word button to change the action or other word associated with a word. The Add Word
button is enabled only when a new word is typed in the edit area of the Words list. The words
you add may contain virtually any character, but only words which contain embedded periods
should have trailing periods (e.g., “U.S.A.” is OK, but USA. is not).
Delete Word button: When you highlight a word in the list, DataCAD places it in the Words input box.
When you click Delete Word, DataCAD removes the highlighted word from the currently
selected dictionary. The associated action and other word are also removed.
Import button: Adds the words contained within a text (*.txt) file to the currently selected dictionary. When
you select Import, a dialog box lets you select the text (*.txt) file you want. Each word in the
selected file is loaded into the dictionary in alphabetical order. Importing a large list of words
may take some time.
Export button: Saves the contents of the currently selected dictionary to a text (*.txt) file. When you click
Export, a dialog box lets you select the name of the text (*.txt) file to which words in the
dictionary will be exported. The words are written to the file one per line.
Other word box: Contains an alternate word associated with the currently selected word. The other word is
used in the "Auto change" and "Conditionally change" actions to supply a replacement word.
You can enter more than one word in the Other Word box, but the total length should be
limited to 63 characters.

4.

Click on the appropriate button in the Files portion of the Dictionaries dialog box. The pull-down
list displays the open dictionary files. When you select a file from the list, its contents appear in
the Words list. Language: Displays the language (e.g., English or French) of the words in the
currently selected dictionary.
Add File button: Displays the Add Dictionary File dialog box. Supply the name of the file.
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Figure 13.8: The Add Dictionary File dialog box
New File button: Creates a new user dictionary file. When you select this button, a dialog appears which
you can use to specify attributes of the new dictionary. See the New Dictionary dialog box for
details.
Remove File button: Closes the currently selected dictionary file. Closed dictionaries are not checked during
a spelling check. Although the file is closed, it is not deleted. Closed dictionary files can be
reopened later using the Add File button.
Close button: Closes the Dictionaries dialog.

You can use the New Dictionary dialog box to specify the attributes of a new user dictionary.
 To select a new dictionary:
1.

Click on New File in the Dictionaries dialog box. The New Dictionary dialog box appears.

2.

Click Browse to display the names of other user dictionary files in the Create Dictionary File
dialog box. You can use this dialog box to view the names of existing dictionary files or to enter
the name of the new dictionary file. Dictionary files end with the *.tlx extension.
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Figure 13.9: The Create Dictionary File dialog box
3.

Type the name of the new user file and click Save to exit the Create Dictionary File dialog box.
The new dictionary appears in the File Name input field in the New Dictionary dialog box.
(Alternatively, you can click Cancel to abort the operation if you don’t want to create a new
dictionary.)

Figure 13.10: The New Dictionary dialog box
4.

Select the language of the new dictionary you are creating by highlighting it in the list. If the
language you want to use is not listed, select "Any."

5.

Click OK to close the New Dictionary dialog box and create the new dictionary.

Importing and Exporting Text
You can export text in your drawing to a text (.TXT) file as well as import a text file into your drawing.
Using this method to import text only supports MS-DOS Text (*.TXT) files. To import other text formats,
open the text file in its native program (for example, MS Word or Word Perfect), then use Copy and Paste
to bring the text into DataCAD.
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 To import text into your drawing:
1.

Click on Text File in the Insert pull-down menu. In the dialog box that appears, find the text files
you want to insert into your drawing. If necessary, you can search in other folders (not just those
listed in the Plot Files folder).

2.

Click on the text (.TXT) file you want to import; then click on Open. The dialog box closes and the
FromFile menu appears.

3.

Use the menu options (as described earlier in this chapter in the instructions on adding text to
your drawing) to customize the appearance of the text you want to import. You are prompted to
Select point to position text.

1.

Click in the Drawing Area or use coordinate entry to enter the upper-left point of the block of text
being imported. The text is added to the drawing.
The Wrap Length option uses a value menu to set the number of characters allowed per line;
characters over this number are wrapped to the next line.

5.

Continue selecting points to copy the imported text to other parts of your drawing or right-click
to return to the Text menu.

 To export text from your drawing:
1.

Click on Export in the File pull-down menu; then click on TXT in the submenu. The dialog box
prompts you to Enter the name of the text file to create.

2.

Type a name for the text file that you want to export text to; then click on Save. The dialog box
closes and a From File selection menu appears.

3.

Click on a selection method in the From File menu. You are prompted to select the text you want
to add to the text file. For more information on using selection menus, see “Selection Menus” in
“The Drawing Board” chapter.

4.

Select the text you want to export. DataCAD exports the text you selected to the text file you
created in step 2.

5.

Continue selecting text to export to the text file. Alternatively, you can right-click to display the
dialog box again and save information in another text file. If you don’t need to save another text
file, click Cancel to close the dialog box.

Using Text Styles
You can save your Text menu settings as a text style. Then, you can use them later to quickly apply those
settings before adding text to a drawing.
 To save a text style:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on

in the Draw toolbar. The Text menu appears.

2.

Click on Font… in the Text menu. The Font dialog appears.

3.

Click on

in the Text Styles section.
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A Enter Text Style Name dialog appears.
4.

Type a name for your new text style and click OK. DataCAD LT saves the text style.

 To use a text style:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on

in the Draw toolbar. The Text menu appears.

2.

Click on Font… in the Text menu. The Font dialog appears.

3.

Click on

4.

Click on a text style in the list. Settings for Text options are changed to those of the text style you
chose; any text you draw now will use those settings.

in the Text Styles section. A list of text styles appears.

 To delete a text style:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on

in the Draw toolbar. The Text menu appears.

2.

Click on Font… in the Text menu. The Font dialog appears.

3.

Click on
appears.

4.

Select the name of the text style you want to delete then click on
appears.

5.

Press (Enter) or click Yes to confirm you really want to delete the text style.

in the Text Styles section. A list of existing text styles

. A confirmation box

Drawing Text Arrows
You can draw arrows from text in your drawing to the parts of the drawing the text refers to. It is easy to
customize the size, style, aspect, weight, and color of the arrowheads.
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Figure 13.11: Examples of different arrowhead styles (left) and aspect ratios (right)
 To draw a text arrow:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on

in the Draw toolbar. The Text menu appears.

2.

Click on Arrows in the Text menu. The Arrows menu appears.

3.

Choose an arrowhead style. Click on Style in the Arrows menu. A list of five arrowhead styles
appears (see Figure 13.11 for examples).

4.

Click on the name of the arrowhead style you want to use and right-click to return to the Arrows
menu.
For Closed and Dot arrowheads, you can fill the space with a color or leave it blank. Use the
Filled toggle to fill (On) or to leave the arrowhead blank (Off). The Filled toggle is not available if
you select Open, Bridge, or Tick arrowhead styles.

5.

Indicate the size of the arrowhead. The size of the arrowhead is the measurement of its widest
point. Arrowhead size is relative to text size; if the Size setting in the Text menu is 1 and the Size
setting in the Arrows menu is 3, the arrowhead size will be three times the height of your text. To
set the size of the arrowhead, click on Size. A value menu appears.
For Open and Closed arrowheads, Size sets the length of the arrowhead base. For Bridge
arrowheads, Size sets the radius of the curve of the arrowhead. For Dot arrowheads, Size sets
the diameter of the dot. For Tick arrowheads, Size sets the length of the tick mark.

6.

Use the value menu or type a number for the size and press (Enter). This setting, Relative arrow
size, appears in the Attention toolbar whenever you are in the Arrows menu.

7.

Set the aspect ratio for arrowheads by clicking on Aspect in the Arrows menu. A value menu
appears.

8.

Use the value menu or type a number for the aspect ratio and press (Enter). See Figure 13.11 for
examples of aspect settings. An ANSI-standard arrowhead has an aspect ratio of 6.

9.

Set the line weight for arrowheads by clicking on Weight. A value menu appears.

10. Use the value menu or type a number for the line weight and press (Enter).

USING TRUETYPE FONTS INSTEAD OF SHX FONTS |
11. Set the color for arrowheads by clicking on Color. A color menu appears. For more information
on using color menus, see “Color Menus” in “The Drawing Board” chapter.
12. Use the color menu to select a color for arrowheads. You are prompted to Draw arrow.
13. Draw arrows. Arrows are drawn from the end of the arrow to the point of the arrowhead. Click
in the Drawing Area or use coordinate entry to enter the end of the arrow.
14. Continue entering points to draw bends or angles in the arrow if necessary. The last point you
enter will be the point of the arrowhead.
15. Right-click to complete the arrow; the arrowhead is drawn according to the settings you specified
in previous steps.

Using TrueType Fonts Instead of SHX Fonts
In addition to “stroke”, a.k.a. vector-based SHX fonts, you can use TrueType fonts in your drawings. You
can convert TrueType fonts to 3D for signage in architectural models. Any font definitions that cannot be
found will be replaced by the default SHX or TrueType font specified in Program Preferences.
 To use TrueType fonts:
1.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on
in the Draw toolbar. The Text menu appears. Then, click on Font in the
Text menu. The Set Text Parameters dialog box appears.

Figure 13.12: Control the appearance of TrueType fonts
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2.

Type something in the small box at the lower right corner of the Font Preview area. For example,
in Figure 13.12, HapPenInc is the name of the company that manufactures pens. The larger
display shows what the text will look like, depending on the font you highlight in the Font List
section of this dialog box.

3.

Go to the Font Format(s) section and click Only TTF if you want to display just the TrueType
fonts in the Font Name section of this dialog box.

4.

Change the settings in the Font Name, Height, Angle, Aspect, Slant, Weight, and Style sections
until the sample in the Font Preview window is correct.

5.

Control the color of the font’s fill and outline in the TTF Properties section. Color choices appear
in the Font Preview window.


To choose colors, click Fill, Outline, or Both in the TTF Properties section.



To use the active layer’s color for the fill and/or outline, check the Fill using current color
and/or the Outline using current color boxes.



To specify your own colors for the fill and/or outline, uncheck the boxes. Then click on the
color swatch to the left of the unchecked box to display the Color Palette dialog box, where
you can either select a standard color or mix your own. For more information on using the
color palette, see “Color Menus” in “The Drawing Board” chapter and “Customizing Colors”
in the “Before You Draw” chapter.

6.

Click OK when you are satisfied with your text parameters. When you return to the Drawing
Window, the cursor changes to a text tool and you are prompted to Select point to position text.

7.

Click where you want the text to appear in your drawing.

8.

Type the text in your drawing. Notice that all your font settings are in effect.

9.

Right-click when you are finished typing text.

Figure 13.13: Results of TrueType font decisions in the drawing
 To convert TrueType fonts to 3D:
1.

Go to the 3D Menus menu and select Explode.

2.

Click on TTF->P-Line in the Explode menu to convert the TrueType fonts to covered polylines.

You can create 3D signage by exploding the polylines to slabs. To do this, use the TTF-> Slab option in the
Explode menu.
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Using Text Attributes for Symbols
Text attributes can be defined and added to symbols. This lets you use the same symbol multiple times,
supplying a unique text string for each one. For example, you could use one desk symbol several times
and label them “Jim’s desk,” “Nancy’s desk,” and “Bob’s desk.”

Adding Text Attributes for Symbols
When you create a text attribute for a symbol, you use the Drawing Window as a scratch pad. There are
several ways to create these attributes: using Sym Attrib in the Text menu, choosing Create Attribute in
the Symbol Browser’s Options menu, or selecting Symbol Attributes from the Create pull-down menu.
You control the appearance of the attribute by selecting options from the Text menu.
You associate the text attribute you created with an exploded symbol by using Save Symbol from the
Symbol Browser’s Options menu. Make sure Explode is off when you place the symbol back into your
drawing.
 To create a symbol attribute from the Text menu:
1.

Place an exploded symbol in your Drawing Window.

2.

Click on Text in the Create pull-down menu, or click on Text in the Edit menu in the Menu
Window, or click on
in the Draw toolbar. The Text menu appears. Make decisions about the
text’s appearance by using the Size, Angle, Weight, Slant, Aspect, Factor, Font, Text Style, Text
Scale and All Caps options.
Hint: Save time by selecting Font from the Text menu and use the Set Text Parameters dialog
box to control many of your options and view a sample in the Font Preview window.

3.

Click on Alignment and use the toggles to control the way your text will be inserted; then rightclick to return to the main Sym Attrib menu.
Left
Center
Right
Top
Middle
Bottom
Aligned
Fit
Reversed
Mirrored

Text inserted from left to right.
Text inserted from the center.
Text inserted from right to left.
Cursor is at the top of the characters you input.
Cursor is at the midpoint of the characters you input.
Cursor is at the bottom of the characters you input.
Adjusts text to fit between two given points.
Adjusts text to fit a certain width and height.
Draws each character backward from right to left.
Draws each character upside down from left to right.

Note: The text cursor coincides with the current text alignment setting. A “+” marker is
incorporated into the carat as a visual indicator of the current alignment setting. There are nine
text alignment points.
4.

Click on Sym Attrib. The text cursor appears and you are prompted to Select point to position text.
Once you position your cursor, the Create Symbol Attribute dialog box appears for a symbol.
Attribute Name
Prompt
Value
Value Properties
Invisible

Name of the attribute.
Reminder question.
Information that should appear on the symbol. This can include constant text.
Information that appears in the Value field will be invisible if you check this box. If
there is no check in the box, the Value text will appear in your drawing. This can be
applied to either Locked or Preset.
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Variable
Preset
Locked
Create multiple
attributes

Supply new information when prompted.
Add new information. This allows you to use constant text either before or after the
new information.
Supply information that cannot be changed.
If this is checked, you can supply more symbol attributes. Each symbol can have many
attributes.

Figure 13.14: A symbol can have multiple attributes if the Create multiple attributes box is
checked
5.

Click on OK or press (Enter) to leave the Create Symbol Attribute dialog box. If you enabled (the
box is checked) Create multiple attributes, repeat steps 4 and 5. When you are finished creating
attributes for this symbol, make sure you disable Create multiple attributes (the box is not
checked).

6.

Turn off Explode in the Symbol Browser’s Options pull-down menu. Then save the symbol and
its attribute by following the directions under “Creating New Symbols” in the “Symbols, Images,
and Objects” chapter. Make sure you use Area in the Save Symbol menu rather than Group.
(Group ignores the attribute.) DataCAD creates a .DSF file for the symbol. When you are finished
saving the symbol and its attribute, right-click to leave the Sym Attrib menu.

7.

Place the symbol into your drawing as often as necessary.
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Figure 13.16: You can place several symbols in your drawing and modify the attributes
8.

Select Edit Symbol Attributes from the Symbol Browser’s Options pull-down menu. Then click on
the symbol. The Edit/Customize Symbol Attribute dialog box appears.

Figure 13.17: The Edit/Customize Symbol Attribute dialog box prompts you for the value that
should appear on the symbol in your drawing
9.

Supply the information in the Value column and click on OK. (In this example, “’s Desk” and
“PD-1-” were constants; “Michelle” and “936” were added to these constant values.) If you
placed the same symbol into your drawing several times and want to use different values, repeat
steps 8 and 9 as often as necessary.

Figure 13.18: Several personalized desks were placed in the drawing

Editing Text Attributes for Symbols
If you selected Locked in the Value Properties portion of the Create Symbol Attribute dialog box, you
cannot edit the value. If you selected Variable, you supply new information when responding to the
Prompt question.
What if some of the information in a symbol changes. For example, what if Harry leaves the company
and his desk is reassigned to MaryJane?
 To edit an existing symbol attribute for a symbol:
1.

Select Edit Symbol Attributes from the Symbol Browser’s Options menu.

2.

Click on the symbol attribute you want to edit. (In this case, Harry.) The Edit/Customize Symbol
Attribute dialog box appears.
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3.

Change only the relevant information. (In this case, change Harry to MaryJane.) Then click on
OK.

Figure 13.19: Notice that the inventory control number stayed the same, but MaryJane replaced
Harry as the desk’s owner.
4.

Edit other existing symbol attributes by repeating steps 2 and 3.

Symbol Attributes appear as Block Attributes when you open a DWG file.

Generating Reports Based on Symbol Text Attribute Data
You can use symbol text attributes to generate reports. In addition, you can assign values to symbol text
attributes by selecting them form a tab-delimited database.
 To generate a report based on symbol text attribute data:
1.

Create the text attributes and symbols and place them in your drawing.

2.

Select Extract Attributes from the Symbol Browser’s Options menu. The Symbol Attribute Report
dialog box appears. Each attribute has its own column.

3.

Select one of the options in the Layer Search block. You can search for symbol attributes in only
the Active layers, only the layers that are turned On, or All the layers in your drawing.

4.

Determine how you want to display the data and click in the appropriate boxes:


Quantities – displays the attributes with a Qty column.



Layers – displays the attributes with a Layer column.



Quantities and Layers – displays the attributes with both Layer and Qty columns.

Figure 9.20: Symbol Attribute Report dialog box.
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5.

Click on Copy if you want to add the symbol attribute report to your clipboard. This allows you
to past the symbol attribute report into a drawing file or a document.

(Pro) Drawing Labels
In addition to drawing standard text, you can add labels to rooms, doors, and windows using some of
DataCAD’s macros. Descriptive attributes can even be assigned to door and window labels.

(Pro) Drawing Room Labels
You can customize the appearance of both the text and the border of the label. Room labels can have only
one line of text per label.
 To draw a room label:
1.

Click on DCAD_AEC in the Toolbox pull-down menu. The DCAD AEC menu appears.
If the DCAD_AEC macro doesn’t appear in the Toolbox pull-down menu, click on Configure.
Select the Macros tab in the Configure DataCAD for Windows Settings dialog box. Highlight
DCAD_AEC in the list of Available Macros and click on the Add button. This places DCAD_AEC
in the list of Macros in Menu. Click on OK to accept this addition to the Toolbox pull-down menu
and close the dialog box. Now, when you click on the Toolbox pull-down menu, DCAD_AEC
appears as an option.

2.

Click on RmLabels in the DCAD AEC menu. The RoomLabl menu appears.

3.

Indicate which one of the three types of borders you want to use for the label. You can toggle on
only one of these border options at a time.

4.

5.



Click on Box to draw a rectangle around the text.



Click on Capsule to draw a rectangle with rounded corners around the text.



Click on None to draw labels with no border at all.

Customize the appearance of label text with several options that use value menus:


To set the label text’s size, click on TextSize. Use the value menu or type a size for your label
text, and right-click to return to the RoomLabl menu. If Text Scale is on in the Text menu,
label text size will be determined relative to the current plotting scale.



To set the angle of the lines of label text, click on TextAngl. Use the value menu or type an
angle for your label text. Right-click to return to the RoomLabl menu.



To set the line weight of the label text, click on TextWgt. Use the value menu or type a size for
your text. Right-click to return to the RoomLabl menu.



To set the angle of each character of label text, as measured from the base of the character to
its top, click on TextSlnt. Use the value menu or type an angle for text characters. Right-click
to return to the RoomLabl menu.



To set the height of each character relative to its width, click on TextAspt. Use the value menu
or type an aspect ratio for your text. Right-click to return to the RoomLabl menu. The aspect
ratio of text is the height relative to the width of each character. An aspect ratio of 1 represents
the normal character style, while an aspect ratio of 5 produces text that is taller and narrower.

Choose a font to use for label text by clicking on TextFont. In the DCAD AEC macro, you cannot
use TrueType fonts; instead, you are limited to SHX fonts. The dialog box lists all the SHX fonts
available in your DataCAD\Fonts folder. Click on a font to select it and click on Open.
Alternatively, you can highlight the SHX font and double-click to simultaneously choose the font
and close the dialog box.
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6.

Insert a symbol as part of your room labels by clicking on AddSymb. In the dialog box, you may
need to change to your DATACAD\Symbol folder. Highlight the symbol folder you want to use
and click on Open. Highlight the symbol you want to use with labels and click on Open. The
AddSymb option appears depressed, indicating that a symbol will be used with labels. To stop
using a symbol in room labels, click on AddSymb again to turn that option off and raise (disable)
the AddSymb option.

7.

Set the text color for room labels by clicking on TextColr. Use the color menu to choose a color. If
necessary, right-click to return to the RoomLabl menu. For more information on using color
menus, see “Color Menus” in “The Drawing Board” chapter.

8.

Set the border color for room labels by clicking on BrdrColr. Use the color menu to choose a color.
If necessary, right-click to return to the RoomLabl menu.

9.

Place the room label by clicking in the Drawing Area or using coordinate entry to enter a point
that will be the bottom left corner of the label. You are prompted to Enter label text.

10. Type the text for the room label and press (Enter). The label is added to your drawing.
11. Repeat steps 9 and 10 to continue adding labels to your drawing. When you are finished adding
labels, right-click to exit the RoomLabl menu.

(Pro) Drawing Door and Window Labels
You can add labels (or “tags”) for doors and windows in your drawing.

Chapter 14 Dimensions

14

Dimensions in DataCAD can measure the distance between two
points, the diameter or radius of curves, or the angle between
two entities. You have full control over how the dimension text,
lines, and arrows look as well as where they are placed in your
drawing.

In this chapter:

Stringline and baseline dimensions can be drawn by simply
selecting a series of points; they can even be drawn
automatically, with the distance between every endpoint along
a wall measured and added to the series of dimensions.

 Editing dimensions
 Associative

You can even draw associative dimensions. These dimensions
are linked to the entity they measure; whenever that entity
changes size, the dimension is automatically updated.

 Dimension text and
line styles

 Adding dimensions
to your drawing

dimensioning
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Drawing Linear Dimensions
Linear dimensions (the most common type) measure the distance between two points. You can draw
standard stringline or baseline linear dimensions, which require you to select the endpoints for each
dimension, or you can automatically create a stringline or baseline dimension by simply selecting the two
endpoints of the entire series of dimensions. In addition, you can edit dimensions or explode them into
separate entities.
 To dimension between two points in your drawing:
1.

Click on Dimension in the Create pull-down menu and then click on Linear Dimension in the
submenu. You can also click on
in the Draw toolbar or click on Dimensions in the Utility
menu, then select Linear from the Dimensions menu. The Linear menu appears.

2.

Choose one of the following options to position dimensions:


To dimension a single line, arc, or circle, simply click on Entity and follow the prompts.

You can toggle only one of the following options on at any time: Horizontal, Vertical, Aligned, and
Rotated.


To draw horizontal linear dimensions, toggle Horizontal on.



To draw vertical linear dimensions, toggle Vertical on.



To draw linear dimensions that are parallel to the dimensioned entity, toggle Aligned on.



To set the angle to draw linear dimensions, click on Rotated and use the value menu to enter
a rotation angle. For more information on using value menus, see “Value Menus” in “The
Drawing Board” chapter.

Figure 14.1: Examples of the four available positions for linear dimensions
3.

Decide whether you want to use associative dimensions. Associative dimensions are connected to
the entity they measure; so if you were to stretch that entity, its dimension would automatically
be updated. Toggle Associative on if you want to draw associative dimensions. Another
advantage to using associative dimensions is that if you change drawing scales (for example,
from architectural to engineering), all associative dimensions would automatically be updated
with the new scale.

4.

Customize the way dimension text is drawn by clicking on Text Style and setting the options as
necessary. See “Text Style Options for Linear Dimensions” on the following pages for details.
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5.

Customize the way dimension lines are drawn by clicking on Dim. Style and setting the options
as necessary. See “Line Style Options for Linear Dimensions” on the following pages for details.

6.

Customize the way dimension arrows are drawn by clicking on Arrow Style and setting the
options as necessary. See “Arrow Style Options for Linear Dimensions” on the following pages
for details.

7.

Respond to the prompt to Select first point of distance to dimension. For greater accuracy, object snap
to one endpoint of the distance you want to dimension. You can also select this point by clicking
in the Drawing Area or using coordinate entry. You are prompted to Select second point of distance
to dimension. For more information on how to object snap to an entity, see “Object Snapping” in
the “Drawing Tools” chapter.

8.

Object snap to the second endpoint of the distance you want to dimension. The dimension lines
appear; notice if you move your mouse cursor to the other side of the entity you’re dimensioning,
the dimension lines flip to that side. You are asked, Dimension which side of line?

9.

Click to one side of the line to place the dimension on that side. If the dimension text fits between
the extension lines, the dimension is drawn; skip to step 12 to continue.
If the dimension text doesn’t fit between the extension lines, only the dimension lines are drawn
and you’re prompted with Text does not fit. Enter new text position.

10. Place dimension text that doesn’t fit between the extension lines by using any of the following
options:
You can use any combination of the Rotate, Draw Leader, and Text Style options to customize
dimension text.


Click on Rotate and use the value menu to set an angle for the text; click in the Drawing Area
to place the text.



Click on Draw Leader to draw a leader from the dimension line to the text. Click in the
Drawing Area or use coordinate entry to draw the leader, and then right-click to place the
dimension text.



Click on Text Style to change the text style settings so that the text will fit between the
extension lines; click in the Drawing Area to place the text.

11. Draw stringline dimensions from the dimension you just drew by clicking on String Line. To
draw baseline dimensions, click on Baseline. Follow the prompts to draw the series of
dimensions. Using String Line or Baseline to dimension along an entire wall of your plan can
save you time because you only have to enter the second point of each dimension. Whether this
series of dimensions is stringline or baseline depends on the settings in the Auto Style menu.
12. Finish drawing the dimension series. Then right-click to return to the Linear menu.
13. Complete drawing stringline dimensions. Then click on Overall in the Linear menu to dimension
the entire stringline.
14. Continue with step 8 above to enter additional dimensions.
 To automatically create a series of dimensions:
1.

Click on Dimension in the Create pull-down menu and then click on Linear Dimension in the
submenu. You can also click on
in the Draw toolbar or click on Dimensions in the Utility
menu, then select Linear from the Dimensions menu. The Linear menu appears.

2.

Indicate which of these four options you want use to position dimensions:
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To draw horizontal linear dimensions, toggle Horizontal on.



To draw vertical linear dimensions, toggle Vertical on.



To draw linear dimensions that are parallel to the dimensioned entity, toggle Aligned on.



To set the angle to draw linear dimensions, click on Rotated and use the value menu to enter
a rotation angle.

See Figure 14.2 for examples of these options.
3.

Decide whether you want to use associative dimensions. Associative dimensions are connected to
the entity they measure; so if you were to stretch that entity, its dimension would automatically
be updated. Toggle Associative on if you want to draw associative dimensions. Associative
dimensions can be exploded or changed to standard dimensions that aren’t connected to the
entity. See “Exploding Linear Dimensions” later in this chapter for more information.

4.

Customize the way dimension text is drawn by clicking on Text Style and setting the options as
necessary. See “Text Style Options for Linear Dimensions” on the following pages for details.

5.

Customize the way dimension lines are drawn by clicking on Dim. Style and setting the options
as necessary. See “Line Style Options for Linear Dimensions” on the following pages for details.

6.

Customize the way dimension arrows are drawn by clicking on Arrow Style and setting the
options as necessary. See “Arrow Style Options for Linear Dimensions” on the following pages
for details.

7.

Customize the way automatic dimensions are drawn by clicking on Auto Style and setting the
options as necessary. See “Automatic Dimension Style Options for Linear Dimensions” on the
following pages for details.

8.

Click on Auto Dim. You are prompted to Select first endpoint of line to dimension along.

9.

Object snap to one endpoint of the distance you want to dimension for greater accuracy. You can
also select this point by clicking in the Drawing Area or using coordinate entry. You are
prompted to Select second endpoint of line to dimension along.

10. Object snap to the second endpoint of the distance you want to dimension. The dimension lines
appear; notice if you move your mouse cursor to the other side of the entity you’re dimensioning,
the dimension lines flip to that side. You are asked, Dimension which side of line?
11. Click to one side of the line to place the dimension on that side. The series of dimensions is
drawn.
12. Continue using automatic dimensioning by going back to step 9.
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Stringline dimensions

Stringline with an overall dimension

Baseline dimensions

Figure 14.2: Examples of stringline, stringline with overall, and baseline dimensions
Text Style Options for Linear Dimensions
Use the following options in the Text Style menu to customize dimension text styles:
Text Size

Weight
Slant
Aspect
Text Scale
In Horiz.
Out Horiz.

Set the dimension text’s actual size in your drawing. The Text Size, Weight, Slant, Aspect, Color, Text
Scale, and Font options work exactly like equivalent options in the Text menu. See the “Text, Notes, and
Labels” chapter for more information. For more information on using value menus, see “Value Menus”
in “The Drawing Board” chapter. The decimal separator for all dimensions and numbers is determined
by the Decimal Symbol setting. In your Windows Start menu, click on Settings, click on Control Panel,
click on Regional Settings, and click on the Number tab.
Set the line weight of dimension text, from 1 to 99 with “1” being the default weight setting; to triple the
weight of text, for instance, set Weight to 3.
Set the angle of each character of text, as measured from the base of the character to its top.
Set the height of each character relative to its width; an aspect ratio of 1 represents the normal character
style, while an aspect ratio of 5 produces text that is taller and narrower.
Toggle Text Scale on to size your text by using the Size setting relative to the plot scale; toggle Text Scale
off to size your text size based only on the Text Size setting. (Pro)
Toggle on to place dimension text horizontally in your drawing (independent of the orientation of the
dimension lines); the dimension line is “broken” to accommodate the text.
Toggle on to place dimension text horizontally in your drawing (independent of the orientation of the
dimension lines) and at the end of the leader; this option is only used with the Draw Leader option,
which is available only if the text is too large to fit between the dimension’s extension lines.
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Above

Offset
Auto

Color
Font

Toggle on to draw the dimension text parallel to and "above" the dimension line; if InHorz is also
toggled on, then the dimension text will be drawn horizontally but the dimension line will not be
"broken"
Set the distance of text from the dimension line.
Toggle on to automatically place text, according to the Text Style menu settings; toggle off to place the
text for each dimension manually, using Rotate, Draw Leader, or Text Style as described in the
instructions for drawing dimensions earlier in this chapter; when Auto is off, right-clicking to place the
dimension text will place the text as if Auto were toggled on.
Set the color of dimension text. For more information on using color menus, see “Color Menus” in “The
Drawing Board” chapter.
Set the font used for dimension text (see Figure 14.3).

Figure 14.3: Selecting a font, with a preview of the selection
Line Style Options for Linear Dimensions
Each dimension in a stringline shares its extension lines with the next dimension in the series, so you see
only a single line displayed on screen. But when you plot your drawing, your plotter reads two lines – the
second extension line for one dimension and the first extension line for the following dimension. If your
plotter prints both these lines, extension lines in a stringline can appear to have a double thickness. To
avoid this, toggle either Line 1 or Line 2 off when you draw stringline dimensions.
Use the following options in the Dim. Style menu to customize dimension line styles:
Line 1
Line 2
Offset
Overlap

Toggle on to draw the first extension line.
Toggle on to draw the second extension line.
Set the distance between the entity being dimensioned and the beginning of the extension lines of the
dimension (see Figure 14.4).
Set the distance extension lines are drawn past dimension lines (see Figure 14.4).

DRAWING LINEAR DIMENSIONS |
Increment

Set the distance between dimension lines when drawing baseline dimensions; this option has no
effect on stringline dimensions unless set to 0, which results in a running dimension without the first
arrow (see Figure 14.4).
Overrun
Set the distance dimension lines are drawn past extension lines; a setting of 0 results in the dimension
line ending at the extension lines (see Figure 14.4).
Fixed Incr.
Toggle on to draw dimension lines a fixed distance away from the entity being dimensioned; toggle
off to enter the distance yourself when you click to select which side of the entity to draw the
dimension on (see Figure 14.4).
DIN Standard Toggle on to use the DIN Standard, set by the German Institute for Standardization (see Figure 14.5).
Rounding
Set rounding for dimension text; toggle RoundIt on and choose from rounding up or down or
banker’s rounding; click on Precsion to set the fractional rounding value for rounding up or down.
Limits
Set the upper and lower limit for the size of entities to dimension (see Figure 14.6).
Tolerance
Set positive and negative geometric tolerances (see Figure 14.6).
B
C

E

D

A

Figure 14.4: Dimension settings: A = Offset, B = Overrun, C = Overlap, D = Increment (with Fixed
Incr. toggled on), E = Text Offset

Figure 14.5: DIN standard dimension

Figure 14.6: Dimensions with Limit and Tolerance settings
Arrow Style Options for Linear Dimensions
Use the following options in the Arrow Style menu to customize dimension arrow styles:
Only one of the three options Arrows, Tick Marks, and Dots can be toggled on at a time.
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Arrows
Tick Marks
Dots
Size

Weight
Aspect

Filled
Color

Toggle on to draw arrows at the ends of dimension lines.
Toggle on to draw tick marks at the ends of dimension lines.
Toggle on to draw dots at the ends of dimension lines.
Set the size of dimension arrows, tick marks, or dots; this setting is relative to the dimension text size, so
if Size is set to 2, dimension arrows will be drawn twice the size of dimension text. The dimension text
size is set using the Text Size option in the Linear/Text Style menu.
Set the line weight of tick marks; not available if Arrows or Dots is toggled on.
Set the aspect ratio of the dimension arrows; this aspect ratio setting is the length of the arrowhead
divided by the height, so a setting of 1 draws arrowheads with a 90 angle; not available when Tick
Marks or Dots is toggled on.
Toggle on to fill the arrowhead or dot.
Set the color of arrows, dots, or tick marks. For more information on using color menus, see “Color
Menus” in “The Drawing Board” chapter.

Automatic Dimension Style Options for Linear Dimensions
Use the following options in the Auto Style menu to customize automatic dimension styles:
Baseline
String Line

Toggle on to draw a series of dimensions that all have one endpoint in common.
Toggle on to draw a series of dimensions, each of which uses the last endpoint of the previous
dimension as the first endpoint of the next dimension.

Just one of the two options Only Points and No Points one can be toggled on at a time.
Only Points Toggle on to dimension to center points only; useful for dimensioning window and door openings.
No Points
Toggle on to dimension to every center and endpoint that is greater than the minimum distance to
dimension (set with the Min. Dist. option).
Min. Dist.
Set the minimum distance to dimension; a setting of zero (0) results in all distances, no matter how
small, being dimensioned.
Miss Dist.
Set the search distance for points to dimension; the miss distance is perpendicular to the line you want
to dimension. For more information on using value menus, see “Value Menus” in “The Drawing Board”
chapter.
Layer Search Toggle on if any of the entities you want to dimension are on layers other than the active layer.
Direct Dim. Toggle on to automatically go directly to the Auto Dim. menu when you click on Linear Dimension in
the Create pull-down menu.

Editing Linear Dimensions
You can edit any linear dimensions in your drawing by changing the text styles, lines styles, or arrow
styles of the dimension. You can also change the position of dimension text.
 To edit linear dimension text, lines, or arrows:
1.

Click on Dimension in the Create pull-down menu and then click on Linear Dimension in the
submenu. You can also click on
in the Draw toolbar or click on Dimensions in the Utility
menu, then select Linear from the Dimensions menu. The Linear menu appears.

2.

Click on Change in the Linear menu. The Change menu appears.

3.

Click on Text Style to change the dimension text settings, click on Dim. Style to change the
dimension line settings, or click on Arrow Style to change the dimension arrow settings. The Text
Style, Dim. Style, and Arrow Style options in the Change menu are the same as those in the
Linear menu. See “Text Style Options for Linear Dimensions,” “Line Style Options for Linear
Dimensions,” and “Arrow Style Options for Linear Dimensions” earlier in this chapter for details.

4.

Click on a selection method in the Change menu. You are prompted to select the dimension you
want to change.
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5.

Click on the dimension you want to edit. The dimension is changed to match the text, line, and
arrow style changes you made in step 3.

 To move dimension text:
1.

Click on Dimension in the Create pull-down menu and then click on Linear Dimension in the
submenu. You can also click on
in the Draw toolbar or click on Dimensions in the Utility
menu, then select Linear from the Dimensions menu. The Linear menu appears.

2.

Click on Change in the Linear menu. The Change menu appears.

3.

Click on Text Pos. in the Change menu. You are prompted to Select associative dimension to change
text position.

4.

Click on the dimension text you want to move. A box representing the text is connected to your
cursor and the Rotate option appears in the menu.

5.

Rotate the text before repositioning it in your drawing by clicking on Rotate and using the value
menu to enter a rotation angle. Otherwise, continue with step 6.

6.

Move your cursor to the new location and click to place the text in its new position or use
coordinate entry to enter a new location for the text. For more information on using coordinate
entry, see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter.

7.

Move dimension text back to its default position by clicking on Default and then clicking on the
dimension text. The text is returned to its default angle and position.

Exploding Linear Dimensions
While you can freely edit non-associative dimensions, there may also be times that you need to edit an
associative dimension measurement. Associative dimensions are connected to the entity they measure, so
these measurements automatically adjust when the entity changes size. To edit an associative dimension,
you first must explode the dimension or disconnect it from the entity it’s associated with.
When you explode dimensions, their appearance is not affected.
 To explode an associative dimension:
1.

Click on Dimension in the Create pull-down menu and then click on Linear Dimension in the
submenu. You can also click on
in the Draw toolbar or click on Dimensions in the Utility
menu, then select Linear from the Dimensions menu. The Linear menu appears.

2.

Click on Explode in the Linear menu. The Explode menu appears.

3.

Click on a selection method in the Explode menu. You are prompted to select the dimension you
want to explode.

4.

Click on the associative dimension(s) you want to explode. The dimensions you selected are
exploded or disassociated from the entities they measure. They become 2D lines and text.

Drawing Dimensions for Angles and Curves
You can dimension the angle between two lines as well as the diameter or radius of a curve.
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 To dimension the angle between two lines:
1.

Click on Dimension in the Create pull-down menu and then click on Angular Dimension in the
submenu. You can also click on
in the Draw toolbar or click on Dimensions in the Utility
menu, then select Angular from the Dimensions menu.. The Angular menu appears.

2.

Customize the way dimension text is drawn by clicking on Text Style and setting the options as
necessary. See “Text Style Options for Angle and Curve Dimensions” on the following pages for
details.)

3.

Customize the way dimension lines are drawn by clicking on Dim. Style and setting the options
as necessary. See “Line Style Options for Angle and Curve Dimensions” on the following pages
for details.

4.

Customize the way dimension arrows are drawn by clicking on Arrow Style and setting the
options as necessary. See “Arrow Style Options for Angle and Curve Dimensions” on the
following pages for details.

5.

Toggle Layer Search on if the lines that form the angle you want to dimension are on different
layers. You are prompted to Select first line.

6.

Click on one of the lines in your drawing that forms the angle you want to dimension. The line
appears as dashed to indicate its selection. You are prompted to Select second line.

7.

Click on the other line in your drawing that forms the angle you want to dimension. The line
appears as dashed to indicate its selection. Also notice that your cursor is connected to a curve
representing the angle dimension line; moving your cursor changes the position of the dimension
line.

8.

Position the angle dimension line and click to place it in your drawing. You are prompted to
Enter angle.

9.

Press (Enter) to accept the actual angle measurement or type an angle and press (Enter). The
dimension line is drawn and a small box representing the dimension text is connected to your
cursor.

10. Place the dimension text next to the dimension line by positioning your cursor and clicking. To
place the text in its default position, simply right-click. The dimension is completed.
 To dimension a curve’s diameter:
1.

Click on Dimension in the Create pull-down menu and then click on Diameter Dimension in the
submenu. You can also click on
in the Draw toolbar or click on Dimensions in the Utility
menu, then select Diameter from the Dimensions menu. The Diameter menu appears.

2.

Customize the way dimension text is drawn by clicking on Text Style and setting the options as
necessary. See “Text Style Options for Angle and Curve Dimensions” on the following pages for
details.

3.

Customize the way dimension lines are drawn by clicking on Dim. Style and setting the options
as necessary. See “Line Style Options for Angle and Curve Dimensions” on the following pages
for details.

4.

Customize the way dimension arrows are drawn by clicking on Arrow Style and setting the
options as necessary. See “Arrow Style Options for Angle and Curve Dimensions” on the
following pages for details.
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5.

Toggle Layer Search on if the curve you want to dimension is on another layer. You are prompted
to Select arc or circle to dimension.

6.

Click on the curve you want to dimension. You are prompted to Enter diameter.

7.

Press (Enter) to accept the actual diameter measurement or type a diameter and press (Enter).
The dimension is drawn.

 To dimension a curve’s radius:
1.

Click on Dimension in the Create pull-down menu and then click on Radius Dimension in the
submenu. You can also click on
in the Draw toolbar or click on Dimensions in the Utility
menu, then select Radius from the Dimensions menu The Radius menu appears.

2.

Customize the way dimension text is drawn by clicking on Text Style and setting the options as
necessary. See “Text Style Options for Angle and Curve Dimensions” on the following pages for
details.

3.

Customize the way dimension lines are drawn by clicking on Dim. Style and setting the options
as necessary. See “Line Style Options for Angle and Curve Dimensions” on the following pages
for details.

4.

Customize the way dimension arrows are drawn by clicking on Arrow Style and setting the
options as necessary. See “Arrow Style Options for Angle and Curve Dimensions” on the
following pages for details.

5.

Toggle Layer Search on if the curve you want to dimension is on another layer. You are prompted
to Select arc or circle to dimension.

6.

Click on the curve you want to dimension. You are prompted to Enter radius.

7.

Press (Enter) to accept the actual radius measurement or type a radius and press (Enter). The
dimension is drawn.

Text Style Options for Angle and Curve Dimensions
Use the following options in the Text Style menu to customize dimension text styles:
Text Size

Weight

Slant
Aspect
Text Scale
Auto

Color
Font

Set the dimension text’s actual size in your drawing. The Text Size, Weight, Slant, Aspect, Color, Text
Scale, and Font options work exactly like equivalent options in the Text menu. See the “Text” chapter
for more information.
Set the line weight of dimension text, from 1 to 99 with “1” being the default weight setting; to triple the
weight of text, for instance, set Weight to 3. For more information on using value menus, see “Value
Menus” in “The Drawing Board” chapter.
Set the angle of each character of text, as measured from the base of the character to its top.
Set the height of each character relative to its width; an aspect ratio of 1 represents the normal character
style, while an aspect ratio of 5 produces text that is taller and narrower.
Toggle Text Scale on to size your text by using the Size setting relative to the plot scale; toggle Text Scale
off to size your text size based only on the Text Size setting. (Pro)
Toggle on to automatically place text, according to the Text Style menu settings; toggle off to place the
text for each dimension manually, using Rotate, Draw Leader, or Text Style as described in the
instructions for drawing dimensions earlier in this chapter.
Set the color of dimension text.
Set the font used for dimension text (see Figure 14.3).

The decimal separator for all dimensions and numbers is determined by the Decimal Symbol setting. In
your Windows Start menu, click on Settings, click on Control Panel, click on Regional Settings, and click
on the Number tab.
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Line Style Options for Angle and Curve Dimensions
Use the following options in the Dim. Style menu to customize dimension line styles:
Offset

Set the distance between the entity being dimensioned and the beginning of the extension lines of the
dimension. See Figure 14.4 for an example of Offset and Overlap settings.
Overlap
Set the distance extension lines are drawn past dimension lines.
Center Mark Toggle on to draw center marks for diameter and radius dimensions.
Rounding
Set rounding for dimension text; toggle Round It on; and choose Round Up or Round Down or Bankers
rounding; click on Precision to set the fractional rounding value for rounding up or down.
Limits
Set the upper and lower limit for the size of entities to dimension (see Figure 14.6).
Tolerance
Set positive and negative geometric tolerances (see Figure 14.6).

Arrow Style Options for Angle and Curve Dimensions
While the Arrows, Tick Marks, and Dots toggles appear only in the Arrow Style menu for linear
dimensions, they affect all four dimension types: Linear, Angular, Diameter, and Radius. Use the
following options in the Arrow Style menu to customize dimension arrow styles:
Size
Weight
Aspect

Filled
Color

Set the size of dimension arrows, tick marks, or dots; this setting is relative to the dimension text size, so
if Size is set to 2, dimension arrows will be drawn twice the size of dimension text.
Set the line weight of tick marks; not available if Open or Dots is toggled on in the Arrow Style menu
for linear dimensions.
Set the aspect ratio of the dimension arrows; this aspect ratio setting is the length of the arrowhead
divided by the height, so a setting of 1 draws arrowheads with a 90 angle; not available when Tick
Marks or Dots is toggled on in the Arrow Style menu for linear dimensions.
Fill in the arrowhead when Open or Dots is toggled on.
Set the color of arrows, dots, or tick marks. For more information on using color menus, see “Color
Menus” in “The Drawing Board” chapter.

Chapter 15 Hatch
Hatch patterns can add detail as well as visual information to
your drawings. In DataCAD, there are two types of hatch:
standard and associative. Standard hatch is a group of entities
inserted in your drawing according to Hatching menu settings.
Associative hatch is a single entity and will update itself as
necessary when you edit your drawing. Both types require you
to define polyline boundaries for the hatch pattern.

15

In this chapter:

 Drawing hatch
 Hatch boundaries
 Associative hatching
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Drawing Hatch Patterns
You can fill areas of your drawing with repetitive patterns, called hatch patterns, to distinguish between
building materials or to highlight parts of your drawing. However, standard hatch can increase file size
and refresh times dramatically. To control file size as well as save time while editing your drawing, use
associative hatch. See the Appendix for a list of the hatch patterns that come with DataCAD.

Drawing Standard Hatch
The lines in hatch patterns are separate entities that are linked as a group, so you can move or edit the
entire area of hatch using the Group option in selection menus. However, you can also edit individual
lines in the hatch pattern using the Entity selection method.
 To draw a standard hatch pattern:
1.

Click on Hatch in the Create pull-down menu, or click on Hatching in the Utility menu, or click
on

in the Draw toolbar. The Hatching menu appears.

Shortcut: Press (H) or (Shift) + (H) to access the Hatching menu.
2.

Click on Hatch Type to set the hatching type. Select one of the four options available and then
right-click to return to the main Hatching menu.


Normal – toggle this on to alternate hatching within defined boundaries (see Figure 15.1).



Outermost – toggle this on to hatch only the first boundary (see Figure 15.2).



Ignore – toggle this on to hatch within the outermost boundary and ignore all other
boundaries (see Figure 15.3).



Locked – toggle this on to assign associative hatch patterns that are relative to their
boundaries versus the drawing. If Locked is toggled on, the pattern stays with the hatched
entity. DataCAD saves the locked associative hatch pattern for that entity alone, not globally
for the entire drawing. For more information about associative hatch, see “Drawing
Associative Hatch” at the end of this chapter.

Figure 15.1: Hatching using the Normal hatching type

Figure 15.2: Hatching using the Outermost hatching type
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Figure 15.3: Hatching using the Ignore hatching type
3.

Click on Manage. The Hatch Pattern Manager dialog box appears. This allows you to select the
particular patterns you want to use in this drawing and embed them as part of the current
drawing file. See “Using the Hatch Pattern Manager” for more information.

4.

Click on Pattern. A list of the hatch patterns you selected with the Hatch Pattern Manager
appears, along with a preview window. Notice that as you move your cursor over each hatch
pattern name in the list, an example of the highlighted hatch pattern appears in the preview
window. Click on Scroll Fwrd to scroll forward through the list of patterns; click on Scroll Back to
scroll back through the list. Choose a pattern by clicking on its name in the list and pressing
(Enter). You are returned to the Hatching menu.

5.

Change the scale or angle of the hatch pattern you selected if necessary.


Scale – change this setting by clicking on Scale. A value menu appears. Use the value menu or
type a scale and press (Enter).

The Scale setting in the Hatching menu affects only the scale of the hatch pattern; it does not
change the drawing scale. For example, the pattern Line is based on 1/32” increments. To draw
the Line pattern with 4” spacing, set Scale to 128 (128 X 1/32”=4”).


Angle - change this setting by clicking on Angle. A value menu appears. Use the value menu
or type an angle and press (Enter). (The default setting is 0.)

5.

Set the point where the hatch pattern will begin by clicking on Origin. You are prompted to Select
hatch pattern origin. Click in the Drawing Area, use coordinate entry, or object snap to an entity to
select the origin for the hatch pattern.

6.

Define a boundary for the hatch pattern. A boundary is a polyline that defines the area of your
drawing that will be hatched. Click on Boundary. The Boundary menu appears. You can define a
rectangular boundary, have DataCAD automatically create it with Cont. Search, generate a
unique one that may include curves/arcs as well as straight line segments, or create voids within
the polyline that will not be hatched. These different boundary definition methods are described
in “Defining the Hatch Boundary.”
Notice that the Attention toolbar describes your hatch pattern, scale, angle, and type.

7.

Click on Begin to hatch the area within the boundary. The hatch pattern is drawn. Click on Clear
to delete the boundary and return all hatch settings to their defaults.

Using the Hatch Pattern Manager
There are many hatch patterns available with DataCAD; however, you probably don’t want to scroll
through all of them when you just need six or seven in your drawing file. The Hatch Pattern Manager
allows you to embed a few patterns from all those available into your current drawing file. Later, you can
add more hatch patterns to the list if you want to embed more into a particular file.
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Embedded hatch patterns now require less memory than those used in DataCAD versions 10 and prior.
DataCAD automatically converts your hatch pattern definitions from DCADWIN.PAT to individual
.DHP files stored in \DataCAD\Support Files\Hatch Patterns.
The Hatch Pattern Manager has two sections: the Embedded Hatch Patterns and the External Hatch
Patterns. The lower section lists all the External Hatch Patterns that are available from your hard disk or
server. When you highlight one of the patterns, a picture of it appears in the window to the right of the
list. Beneath the picture of the hatch pattern is information about the scale, angle, and display scale of that
pattern.
In the External Hatch Patterns section, highlight the pattern you want and click on the Load button to add
a copy of it into the Embedded Hatch Patterns list. You cannot make changes to external definitions in
this section.
You can make changes (affecting scale, angle, and/or display scale settings) to hatch patterns that are
loaded into the Embedded Hatch Patterns section only. If you do not want to use changes you made to
the scale, angle, and/or display scale settings, you click on the Reload button to reload the pattern’s
default values from the hard drive or server.
The upper section lists the Embedded Hatch Patterns that you selected and modified (if necessary) from
the list in the lower window. This list of patterns is attached to your current drawing file. When you
select Pattern from the Hatching menu, you will see only the patterns that appear in the Embedded Hatch
Patterns window of the Hatch Pattern Manager.
You can make a change (for example, changing the scale value) to one of the embedded hatch patterns. If
you want this change to take effect, click on Apply. This activates the Save and Save As buttons in the
Embedded Hatch Patterns section. Highlight the pattern you changed, click Save As, and supply a name
for the hatch pattern. It will be saved as a .DHP file and be added to the External Hatch Patterns portion
of the Hatch Pattern Manager. Then, you can load the newly named pattern into the Embedded Hatch
Patterns section. If you want to reinstate the values of the original pattern, simply highlight it in the list of
Embedded Hatch Patterns and click on Reload.
When you are satisfied with your choices and/or modifications, clicking on OK transfers the list in the
Embedded Hatch Patterns section of the Hatch Pattern Manager to your current drawing file. This list
appears when you select Pattern from the Hatching menu.
You can manually convert DataCAD hatch patterns (.PAT) to the new (.DHP) format. Use the Convert
option from the Hatch Pattern Manager to do this.
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Figure 15.4: The Hatch Pattern Manager

Defining the Hatch Boundary
The hatch boundary is a closed polyline that surrounds the hatch pattern. One of the easiest ways to
define the hatch boundary is to let DataCAD perform a contour search. The next easiest method is to
hatch within a rectangular boundary. The most complex method is to define a boundary that includes
curves and/or arcs as well as straight line segments.
 To hatch a closed polyline with contour search: (Pro)
1.

Click on Hatch in the Create pull-down menu, or click on Hatching in the Utility menu, or click
on

in the Draw toolbar. The Hatching menu appears.

2.

Choose Boundary from the Hatching menu.

4.

Click on Cont. Search in the Boundary menu. You are prompted to Select point inside/outside
contour.

5.

Click on the boundary of the closed polyline you want to use.

6.

Right-click to return to the Hatching menu.

 To define a rectangular boundary:
1.

Click on Hatch in the Create pull-down menu, or click on Hatching in the Utility menu, or click
on

in the Draw toolbar. The Hatching menu appears.

2.

Click on Boundary. The Boundary menu appears.

3.

Select Rectangle. The Rectangle menu appears and you are prompted to Select first corner of
rectangle.
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4.

Select the first point of the rectangle by clicking in the Drawing Area, using coordinate entry, or
object snapping to an entity. For more information on coordinate entry, see “Drawing Using
Coordinate Entry” in “The Drawing Board” chapter. You are prompted to Select second corner of
rectangle.

5.

Drag your mouse toward the diagonally opposite corner of the rectangular area you want to
hatch. Click once when you get to the opposite corner of the rectangle. The rectangular boundary
is drawn.

6.

Right-click to return to the Hatching menu.

 To define a boundary that includes curves and/or arcs:
1. Click on Hatch in the Create pull-down menu, or click on Hatching in the Utility menu, or click on
in the Draw toolbar. The Hatching menu appears.
2.

Click on Boundary. The Boundary menu appears and you are prompted to Select first point on
boundary to hatch to.

3.

Select the first point of the boundary by clicking in the Drawing Area, using coordinate entry, or
object snapping to an entity. The options 2 Pt. Arc and 3 Pt. Arc appear in the Boundary menu.
You are prompted to Select next point on boundary to hatch to. For more information on coordinate
entry, see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter.

4.

Add a line segment, 2-point arc, or 3-point arc to your polyline boundary:


To select the second point of a straight line segment, click in the Drawing Area, use
coordinate entry, or object snap to a point on an entity. After you select the second point of
the boundary, the Tangent option is added to the menu.



To add a 2-point arc to the boundary, click on 2 Pt. Arc in the Boundary menu. Select a center
point for the arc, toggle Clockwise on (if you want to draw the boundary in a clockwise
direction) or off (if you want to draw the boundary in a counterclockwise direction), and
select an endpoint. You can continue drawing additional 2-point arcs or you can right-click to
exit the 2-point arc function.



To add a 3-point arc to the boundary, click on 3 Pt. Arc in the Boundary menu. Select a
second endpoint for the arc (with the first endpoint being the point you selected in the
previous step) and then select any other point on the arc. You can continue drawing
additional 3-point arcs or you can right-click to exit the 3-point arc function.



To add a tangent arc to the boundary, click on Tangent in the Boundary menu. (The Tangent
option appears in the Boundary menu after you select the second point of the polyline
boundary.) Move your cursor until the arc displayed is the one you want drawn and then
click to draw the tangent arc.

You can click Backup any time to erase the last straight line segment or arc of your boundary. You
can click Cancel any time to erase the entire boundary you’ve drawn.
5.

Continue selecting points for line segments or arcs, as outlined in step 4, until your polyline
boundary is complete.

6.

Click on Close in the Boundary menu and click on Exit in the next menu that appears.
Alternatively, just right-click twice to leave both Boundary menus. The Hatching menu appears.
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 To hatch a master polyline that contains voids (or areas that you do not want to hatch):
1.

Create the master polyline. This will contain the hatch pattern. For details on creating the master
polyline, see “Voids in Polylines” in the “Drawing Other Geometry” chapter.

2.

Create the polylines that will serve as voids (areas that will not be hatched).

3.

Click on Voids in the Polyline menu. You are prompted to Select master polyline to process voids.

4.

Click on the closed master polyline that you want to put the void in. DataCAD puts dashed lines
around that shape.

5.

Make sure Entity and Add Void are toggled on in the Voids menu. You are prompted to Select
entity to convert to voids.

6.

Click on the polyline that will represent the void. The void is added. Dashed lines surround the
void.

7.

Continue selecting other closed polylines within the master if necessary.

8.

Click on Hatch in the Create pull-down menu, or click on Hatching in the Utility menu, or click
on

9.

in the Draw toolbar. The Hatching menu appears.

Click on Pattern and choose one of the options. Make other adjustments to the pattern if
necessary. For example, you may want to change the scale or the angle. The decisions you make
for the pattern, scale, angle, and hatch type are shown in the Attention toolbar.
If no patterns are listed, use the Hatch Pattern Manager to select the ones you want to include in
this drawing file.

10. Click the polyline you created in steps 1 through 7. This selects the polyline.
11. Click on Begin. The hatch pattern you selected appears within the master polyline boundary;
however, the voids you created are empty.

Using SPB Fills Instead of Standard Hatch Patterns
Instead of using the standard vector-based hatch patterns (saved as .PAT files), you can use solid, pattern,
and bitmap (SPB) fills. Unlike hatch patterns, solid fills will display and print with the same density, no
matter what the viewed or plotted scale is.
 To use solid, pattern, and bitmap fills:
1.

Click on Display in the Utility menu or select Settings from the Tools pull-down menu and click
on Display. Make sure Fill On and Bitmap On are toggled on in the Display menu. Then, rightclick to return to the Utility menu. There is now an upper-case F in SWOTHLUDFB, indicating
that Fill is on (lower-case f means it’s off).

2.

Select Hatching from the Utility menu.

3.

Choose SPB-Fill from the Hatching menu.

4.

Click on Settings to choose the colors and patterns you want in your drawing. The Select Fill
Color/Pattern dialog box appears.
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Figure 15.5: Control the solid, pattern, and bitmap (SPB) fills.
5.

Make decisions about the solid, pattern, and/or bitmap fills for your drawing. Your choices
appear in the Preview window of the Select Fill Color/Pattern dialog box.

6.

Click in the box beside Solid Pattern Fill or Bitmap Fill. These are mutually exclusive.
Use the Fill Settings options to make decisions about solid pattern details.


Control the fill and pattern colors by clicking on the rectangular swatch and making your
selections from the Color Palette dialog box. For more information, see “Customizing Colors”
in the “Before You Draw” chapter.



Select the pattern you prefer from the drop-down box. The outline boundary, pattern, and fill
may have different colors. Your choices are shown in the Preview window.



Check the Entity box if you want the fill to display with the color of the polyline entity in the
drawing.

Use the Bitmap/JPEG options to make decisions about bitmap fills.


Click the file folder button to select the image you want to use. Supported file types are listed
in the drop-down box in the Select Image dialog box. After you select the image, click on
Open or press (Enter) to return to the Select Fill Color/Pattern dialog box.



Uncheck the Maintain Aspect box if you want to change the X/Y aspect of the original image.

Figure 15.6: Select the image you want for the fill.
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6.

Click OK on the Select Fill Color/Pattern dialog box when you are satisfied with your choices. The
dialog box disappears.

7.

Click on an existing polyline boundary that you want to fill. If none exists yet, select Boundary
from the Solid Fill menu and draw one.

You can reposition SPB-filled entities that are on the same layer. For example, you can move one in front
of another, move one behind another, move one to the top, move one to the bottom, or swap two of them.
For more information, see “Moving SPB-Filled Entities” in the “Editing Drawings” chapter.
You can control whether solid fills and bitmaps print behind or in front of lines by using the Print first or
Print last options in the Pen Table. For more information about using the Pen Table, see “Using Pen
Tables” in the “Printing Your Drawing” chapter.

Drawing Associative Hatch
Associative hatch treats hatch patterns as a single entity, instead of a group of entities as standard hatch
does. You can associatively hatch only 3D polygons and 2D polylines. When you use associative hatch:


You can stretch walls in your drawing and the hatch will update automatically.



You can rotate your drawing without changing the angle of the hatch pattern.



Your drawing file size is usually smaller because the hatch pattern is a single entity instead of a group
of entities.



You can’t edit individual lines in the hatch pattern.



The hatch is drawn the same color as your entity. If you use standard hatch (Associative is toggled
off), the hatch is drawn in the current layer’s color.



You have different hatch type options: Outline draws an outline around the hatching, while
NoOutline does not.

 To draw associative hatching:
1.

Click on Hatch in the Create pull-down menu, or click on Hatching in the Utility menu, or click
on

in the Draw toolbar. The Hatching menu appears.

2.

Toggle Associative on in the Hatching menu.

3.

Click on Hatch Type to set the hatching type.

4.

Toggle Outline on to draw an outline around the hatching; toggle No Outline on to draw only the
hatching. Right-click or click on Exit when you are done.

5.

Toggle Locked on to assign associative hatch patterns that are relative to their boundaries versus
the drawing. If Locked is toggled on, the pattern stays with the hatched entity. DataCAD saves
the locked associative hatch pattern for that entity alone, not globally for the entire drawing.

6.

Set the hatch pattern, scale, and angle. For more information, see “Drawing Standard Hatch” in
this chapter.

7.

Set the point where the hatch pattern will begin by clicking on Origin.
If you want to distinguish the origin of associative hatch entities, toggle on Hatch Origin in the
Display menu. When this option is toggled on, DataCAD displays a small + on the screen to
indicate the associative hatch origin. Independently from the Hatch Origin display setting,
DataCAD will show the origin of associative hatch entities when they are highlighted.

8.

Define the boundary for the hatch pattern.
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9.

Click on Begin in the Hatching menu to draw the associative hatch.
After the hatching is drawn, you can click on Del. Assoc. to remove the associative hatching,
without clearing the boundary you traced. Click Clear to delete the boundary and return the hatch
settings to their defaults.

Chapter 16 Symbols, Images,
and Objects

16

In this chapter:

A symbol is a collection of entities (lines, arcs, and text) and their
corresponding layers that is treated as a single entity. The
Symbol Browser makes it easy to work with and manage these
entities.

 Using the Symbol

Symbols in DataCAD can be organized and displayed in the
Symbol Browser. You can insert symbols in your drawing, revise
symbol descriptions as well as the symbols themselves, and even
create new symbols from geometry in your drawing. Each
symbol can have an unlimited amount of information associated
with it. And one of the biggest advantages to using symbols in
your drawings, instead of separate lines and arcs, is that you can
use this information to generate a variety of reports.

Importing images

In addition to symbols, you can also import many types of
images into your drawings or insert o2c objects.

Browser






Working with symbols
Creating symbols
Inserting o2c objects
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Using the Symbol Browser
DataCAD makes it easy to use symbols in your drawings. With just a few mouse clicks, you can open the
appropriate folder, display the symbols in the browser, and select the ones you want to use into your
drawing. If you developed custom templates with DataCAD 10 and prior versions, you can open them in
the Symbol Browser, too. In effect, the subfolders in the DataCAD\Symbols folder contain collections of
symbols that you can access via the Symbol Browser.
Shortcut: The hotkey (Ctrl) + (T) toggles the Symbol Browser on and off.
Note: In the Symbol Browser and Insert Symbol dialog, .DSF files supersede .SM3 (used in DataCAD 10
and prior versions) files.

Positioning the Symbol Browser on your DataCAD Desktop
When you first open DataCAD, the Symbol Browser is docked along the right side of your Drawing
Window. Since it is actually a toolbar, you can undock the Symbol Browser and position it anywhere on
your desktop or hide it from view altogether.
 To undock the Symbol Browser:
1.

Place the cursor along the upper margin of the Symbol Browser. Move the cursor until it is
shaped like a cross with arrows at its tips.

2.

Click and keep the mouse button depressed to grab the Symbol Browser.

3.

Drag the Symbol Browser away from the side of the Drawing Window and position it elsewhere.
Notice that “Symbol Browser” appears in the title bar at the top of this toolbar.
Click folder icon to
browse for symbols
on your hard drive
Click lock icon to
turn automatic
divisions in Symbol
Browser on or off

Each symbol
appears in its own
division box

Click to remove the Symbol
Browser from your desktop
Press [Ctrl]+[T] to toggle the
Symbol Browser on and off
Click options icon to
access additional features
and settings
X and Y divisions are set to
automatically show all
symbols in the folder at the
same time if “auto divisions”
is “on.” If “auto division” is
“off,” you can manually set X
and Y divisions with the pullElevator bar helps you
scroll through large symbol
folders

Figure 16.1: Undocked Symbol Browser
You can dock the Symbol Browser at either the right or left edge of the Drawing Window; however, you
cannot dock it at the top or bottom edge. When you originally open DataCAD, the Symbol Browser is
docked at the right edge.
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 To dock the Symbol Browser:
1.

Click and hold on the title bar near Symbol Browser.

2.

Drag the Symbol Browser to the right or left margin of the Drawing Window until the title bar
disappears. To dock the Symbol Browser to the left of the Edit/Utility menu bar, simply continue
dragging it leftward until it pops into place.

DataCAD automatically calculates the divisions to display all the symbols in the folder you selected. This occurs
when the lock on the Symbol Browser menu bar is “on” (or depressed) and the pull-down number menus are grayed
(this means you cannot change them).

 To specify the number of X and Y divisions for the Symbol Browser:
1.

Click on the auto divisions icon on the Symbol Browser menu bar. When the drop-down arrows
appear next to the X and Y division numbers, you can change these values manually to suit your
needs.

2.

Select the number of X divisions you want the Symbol Browser to display.

3.

Select the number of Y divisions you want the Symbol Browser to display.

Figure 16.3: X and Y divisions can be set manually
Selecting and Placing Symbols
Symbols that you can use in your drawing are contained in DataCAD’s Symbols folder or directory.
Clicking the arrow to the right of the folder gives you three options:


Folder shows you all the symbol files in the DataCAD Symbols directory or folder.



Template displays the files in the DataCAD Templates directory or folder. The templates were either
supplied older versions of DataCAD (version 10 and prior) or were created in your office to meet
specific clients’ needs. Templates hold collections of symbols. You will probably find it more efficient
to create new subfolders containing collections of symbols in your Symbols folder rather than using
the more cumbersome, old-fashioned templates.



Drawing contains just the symbols you placed in the current drawing. DataCAD remembers this
information so that you can have quick access to the symbols you’ve already used and may want to
re-use elsewhere in your drawing.

 To open a collection of symbols:
1.

Click on the arrow to the right of the folder in the Symbol Browser.

2.

Select Folder, Template, or Drawing from the pull-down list.
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If you select Folder, the Browse dialog box opens. Notice that as you click on different
folders, their contents appear in the Symbol Browser. Click OK when you find the folder that
contains the symbol(s) you want to use in your drawing.

Figure 16.4: Symbols contained in the folder in the Browse window simultaneously appear in the
Symbol Browser

3.



If you pick Template, the Select Template File to Browse dialog box opens. When you click on
a file in the list, its collection of symbols is displayed in the Symbol Browser. Click Open
when you find the file that contains the symbol(s) you want to use in your drawing. For
information about accessing Template files from DataCAD versions prior to 11, refer to
“Finding and Using Older Template and Symbol Files” in the Appendix.



If you choose Drawing, DataCAD displays the symbols you used already in the current
drawing.

Open the file that contains the symbols you want to use in your drawing. Once you open a file,
the Browse or Select Template File to Browse dialog box closes, allowing you to work directly
with the symbols.

You are now ready to place the symbols into your drawing. Basically, you select a symbol from the
Symbol Browser and place it into your drawing where you want it to appear.
 To look at an object you are considering placing in your drawing:
1.

Move your cursor over the symbol you want to examine.

2.

Right-click to display a pop-up menu.

3.

Select Object Viewer from the menu. The item appears in the Object Viewer window, where you
can examine it.
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Figure 16.6: The symbol appears in the Object Viewer so that you can examine it
4.

Click on the X in the upper right corner to close the Object Viewer.

 To insert a symbol into your drawing:
1.

Click on the symbol you want in the Symbol Browser. This attaches a particular symbol to your
cursor.

2.

Position your cursor where you want the symbol to appear in your drawing. Notice that the
symbol assumes a rectangular shape until you decide where you want to place it.
Hint: You can use Max. Lines to increase the number of entities to display simultaneously so
DataCAD can display the entire symbol while you drag it.

Figure 16.7: By default, DataCAD only displays the rectangular extents of your symbol as you
drag it into your drawing.
3.

Click when the rectangular shape is positioned where you want to place the symbol into your
drawing. Notice that a rectangular shape is still attached to your cursor. This allows you to
“place” many copies of a symbol into your drawing. (For chairs, replication may be a convenient
feature, but most houses only require one kitchen.)

4.

Right-click when you are finished placing the symbol(s) into your drawing. The cursor returns to
its normal shape, allowing you to continue working in your drawing or to select and place other
symbols.
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Controlling Symbols
You don’t have to live with the symbols as they are; you can change them in several ways by using the
Options pull-down menu. For example, you can enlarge, offset, or rotate them.

Figure 16.9: The Options menu lets you further control the symbols you add to your drawing. The
left menu offers related options when you insert a symbol.
The Attention toolbar tells how the symbol will behave within the drawing. In the following example, the
desk symbol will be rotated, enlarged, and offset based on the options that you set. These settings remain
in effect for placing all future symbols until you change one of the options.

Figure 16.10: The Attention toolbar summarizes settings you selected through the Options menu
 To rotate a symbol:
1.

Select Rotate from the Symbol Browser’s Options pull-down menu. The Edit menu appears and
you are prompted to Position symbol on drawing.

2.

Decide whether you want to rotate the symbol dynamically with your cursor or use a fixed
rotation angle. When Rotate is on, you can place the symbol dynamically; when Rotate is off, you
are prompted to specify the angle you want.
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If you opted for a fixed angle instead of dynamic rotation, remember to set the angle back to zero. If you
don’t do this, all future symbols will be placed at the rotation angle you specified. For example, if you set
a 30-degree rotation angle while placing a desk symbol and neglect to change it back to zero, the next
symbol (perhaps a conference table) will also appear at a 30-degree angle.
 To enlarge a symbol:
1.

Select Enlarge from the Symbol Browser’s Options pull-down menu. The Enlarge menu appears
and you are prompted to Select symbol enlargement factor to change.

2.

Choose X Englargmnt., Y Enlargmnt., Z Enlargmnt., Line Factor, or Set All from the Enlarge
menu; select an enlargement value from the list or type your own; and press (Enter). Notice that
the enlargement factor(s) you entered are displayed on the Attention toolbar.
Hint: If you want to reduce the size of a symbol, use a decimal value (such as .25). If you want to
mirror the symbol, enter a negative value (such as –1).

3.

Right-click, or click on Exit, or press (Shift) + (F10) to leave the Enlarge menu.

4.

Click on the symbol that you want to drag into your drawing.

5.

Drag the symbol into your drawing with your mouse. You are prompted to Position symbol on
drawing.

6.

Click the left button when the symbol is in the correct place. The enlarged symbol appears in the
drawing. Continue placing additional copies of the symbol by repeating this step.

7.

Right-click to stop placing additional copies of the symbol into your drawing.

 To offset the insertion height of symbols:
1.

Select Z Offset from the Symbol Browser’s Options pull-down menu. The Z Offset menu appears
and you are prompted to Enter Z Offset for symbols.

2.

Supply the value and press (Enter). Notice that the Z Offset you entered is displayed on the
Attention toolbar.

3.

Click on the symbol that you want to drag into your drawing.

4.

Drag the symbol into your drawing with your mouse. You are prompted to Position symbol on
drawing.

5.

Click the left button when the symbol is in the correct place. The symbol appears in the drawing
at the Z Offset you supplied in step 2. Continue placing additional copies of the symbol by
repeating this step.

6.

Right-click to stop placing additional copies of the symbol into your drawing. You can use the
Object Viewer in the View pull-down menu to see the effect of the Z Offset you applied.

Editing Symbols
If you want to edit or change the symbol, you must first convert it into separate lines and/or arcs. In other
words, you will “explode” the symbol back into its component drawing elements. You can do this when
you insert the symbol into your drawing or after the symbol has been inserted. Once the symbol has been
edited, you can reform the symbol lines and arcs into a single symbol entity and save it back into the
Symbol Browser and then update the symbols already in your drawing.
 To explode a symbol:
1.

Click on the Options icon in the Symbol Browser.
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2.

Select Explode. When this function is “on,” a checkmark appears to the left of the word
“Explode.”

3.

Click on the symbol you want to use and drag it into your drawing.

4.

Click the left mouse button to place it. The exploded symbol appears in your drawing. You can
repeat this step to continue placing copies of the exploded symbol.

5.

Right-click to stop placing copies of this symbol.

6.

Make changes to the exploded symbol.

7.

Select and place other symbols you want to drag into your drawing as exploded lines and/or arcs.

8.

Deactivate Explode in the Symbol Browser’s Options menu when you are finished. Until the
checkmark to the left of Explode disappears, all symbols that you place will be converted to lines
and/or arcs in your drawings.

When you activate Explode in the Symbol Browser’s Options menu, the left Layers menu includes an
Explode button. This is how you explode a symbol when you place it. If you want to explode a symbol
that you previously placed in your drawing, select Explode from the 3D Edit menu.
Creating New Symbols
You can create and save your own symbols in a new or existing folder.
 To create and save a symbol:
1.

Draw something that you want to use as a symbol.

2.

Select Save Symbol from the Options pull-down menu in the Symbol Browser. The contents of
the active symbol folder appear in a window and you are asked to Enter name of symbol file to be
saved.

3.

Type a name for the item you drew in step 1. Then press (Enter) or click on Save. The Save
Symbol menu appears.
The file name is limited to 255 characters.
You could save the item in another folder or create a new folder by using the icons at the top of
this window.

4.

Select the entities you drew in step 1. The items you selected are highlighted. You are prompted
to Select an insertion point for symbol.

5.

Click once in the Drawing Window to create a “handle” that will help you place your symbol. A
symbol descriptor window appears.
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Figure 16.13: Describe the item you are saving as a symbol
6.

Fill in the fields with information about the item. Double-click in a field and supply information
in the Name or Value columns. When you double-click on the Type column, you can select Text,
Decimal, or Integer for the information that should appear in the Value column.

7.

Click on OK when you have finished describing the item. The object you created appears in the
Symbol Browser. Once an item you created is designated as a symbol, you can put clones of it
anywhere in the drawing on your screen.

Editing Symbols
What if you want to edit information about a symbol or get rid of it in your Symbol Browser? That’s easy.
 To edit information about a symbol:
1.

Move your cursor in the Symbol Browser to the symbol you want to edit.

2.

Right-click to display the pop-up menu.

3.

Select Edit Fields. The symbol descriptor box appears.

4.

Double-click in the field you want to change and supply the new information in the Name or
Value columns. When you double-click on the Type column, you can select Text, Decimal, or
Integer for the information that should appear in the Value column.

5.

Click on OK when you have finished editing the description of the symbol.

 To delete a symbol from the Symbol Browser:
1.

Move your cursor in the Symbol Browser to the symbol you want to delete.

2.

Right-click to display a pop-up menu.

3.

Click on Delete. Then click on Yes or press (Enter) to confirm that you really want to eliminate the
symbol. The undesirable symbol disappears from the Symbol Browser and from your computer’s
hard drive.

 To replace one symbol with another in your drawing:
1.

Select Replace from the Options pull-down menu in the Symbol Browser. You are prompted to
Select symbol to replace.
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2.

Click on the symbol in your Drawing Window that you want to replace with another one that
appears in your Symbol Browser. You are prompted to Select symbol to replace with.

3.

Click on the symbol you want in your Symbol Browser. You are prompted to Select entity to
replace.

4.

Click on the undesirable symbol in your Drawing Window again. The undesirable symbol
disappears and its replacement that you selected in step 3 appears in your Drawing Window.
Continue using the replacement symbol by clicking on other undesirable symbols in your
Drawing Window.

5.

Right-click in your Drawing Window to discontinue the replacement process.

If you select Reload All from the Options pull-down menu, DataCAD gets the most recent definition of a
symbol from the hard drive. Otherwise, it goes to the drawing itself for the definition.
Once you place a symbol in your drawing, DataCAD will no longer read the definition from your hard
drive. That’s why Reload All is important.
Symbols you insert “travel” with your drawing. If you insert symbol A into drawing 1, then redefine
symbol A from drawing 2, symbol A will look different in drawings 1 and 2. You can use Reload All to
make symbol A look the same in drawings 1 and 2.
Generating Reports About Symbols
You can generate reports based on the symbols that appear in your drawing.
 To generate reports about symbols used in your drawing:
1.

Select Reports from the Options pull-down menu. The Report Forms dialog box appears.

Figure 16.16: The Report Forms dialog box
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2.

Click in the box to the left of the items you want to include in your report. If you want reports on
all the items, click on Select All. If you want to start over with a clean slate, click on Select None.
Symbols that are not currently used in your drawing but still “live” in your drawing’s database
are grayed out or unavailable for reports.

3.

Use the drop-down box in the right corner to select the type of report you want to generate. If
you want to use forms that are in another folder, click on the browse icon and make your
selection.

4.

Decide which layer(s) you want to include in your reports by clicking on the appropriate option
in the Layer Search box.

5.

Choose an output option in the lower left portion of the Report Forms dialog box:


If you select To File, you are asked to supply a file name. The file will be in .TXT format.



If you select To Printer, the report goes to your default text printer.



If you select To Drawing, you are prompted to Select point to position text. You can change the
appearance of the text by selecting Size, Angle, Weight, Slant, Aspect, Factor, or Font from the
left menu. Place the text insertion icon where you want the report to appear in your Drawing
Window.

Hint: To keep report column spacing consistent, use a fixed-width font (such as ARCWY2FW).
6.

Right-click to return to the Report Forms dialog box. You can generate other reports and select
the appropriate output option by following steps 2 through 5.

7.

Click Close when you are finished generating reports.

Purging Unused Symbols
DataCAD remembers all the symbols you used even though you may have already erased some of those
symbols from the drawing on your screen. When you add a symbol to your drawing, DataCAD stores
that symbol with your drawing. This definition is not deleted when you erase the symbol and continues
to take up drawing file space. When you erase symbols from your drawing, it’s important to purge the
symbol if you don’t plan to use it again.
 To eliminate unused symbols from your drawing:
1.

Select Purge Unused Symbols form the Options pull-down menu. A confirmation box appears.

Figure 16.18: You can change your mind about purging unused symbols
2.

Press (Enter) or click on Yes to continue the purge. If DataCAD finds unused symbols to remove
from your drawing, another warning box appears.
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Figure 16.19: You can still change your mind at this point
3.

Click on Yes or press (Enter). All the unused symbols as well as all prior actions (such as erased
entities) are eliminated from your Undo buffer.

Text Attributes for Symbols ,
Text attributes can be defined and added to symbols. This lets you use the same symbol multiple times,
supplying a unique text string for each one. For example, you could use one desk symbol several times
and label them “Jim’s desk,” “Nancy’s desk,” and “Bob’s desk.” For more information on creating and
editing text attributes, see “Using Text Attributes for Symbols” in the “Text, Notes, and Labels” chapter.
Layers in Symbols
Symbols retain layer information. This lets you customize on/off layer settings for each symbol. When a
symbol is exploded, its constituent entities are returned to their proper layers or new layers are created
automatically if necessary.
Symbol Browser Settings
The Symbol Browser retains the following settings between DataCAD sessions.


Last browse type (folder, template, or drawing)



Last path browsed for symbols (independent from Templates and Insert Symbol menus)



Last path browsed for templates (independent from Templates menu)



Auto-divisions On/Off status

Shortcut: You can use (Ctrl) + (Click) on either the Folder or Templates menu item in the browse pulldown menu to bypass the folder/file dialog. This lets you go directly to browsing the last symbol folder or
template file.
If the Symbol Browser is not displayed, you can click on
will appear.

in the Draw toolbar. The Symbol Browser
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Inserting Stamps
You can choose from more than a dozen pre-formatted date-, time-, and file-related stamps to insert into
your drawing. The examples shown in the stamp selection menu are based on the current date, time, and
file settings as they will appear in the drawing. The values are updated when the display is regenerated
and when the drawing is printed. Since a stamp is really an ordinary DataCAD text entity that contains a
special formatting string, it has all the font, sizing, and style options of ordinary DataCAD text strings.
You can further customize how you want stamps to appear in your drawing by doing a
change/text/content and adding text around the special strings. Stamp text can be used in XREFs and
symbols. The values update automatically, making stamps very flexible.
 To add a stamp to your drawing:
1.

Select Stamp form the Insert pull-down menu.

2.

Select the stamp you want to use from the extended menu.

(Pro) Inserting o2c Objects
Thousands of o2c objects (including people, cars, furniture, and landscape elements) are available for you
to import into DataCAD drawings. Or you can import your own o2c objects, such as your company logo.
 To insert an o2c object:
1.

Click on o2c Object in the Insert pull-down menu. A dialog box appears, prompting you to Select
o2c file to import.

2.

Locate the o2c object you want to insert into your drawing and click on it to select it.

3.

Click on Open. The dialog box closes, and a box representing the extents of the o2c object is now
attached to your cursor.

4.

Place the object by clicking in the Drawing Area, using coordinate entry, or object snapping to a
point in your drawing. The o2c object is inserted into your drawing. For details on coordinate
entry, see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter. For details on
object snapping, see “Object Snapping” in the “Drawing Tools” chapter.

5.

Repeat the previous step to continue placing the object in your drawing or right-click to exit the
menu.

Importing BMP, JPEG, and Other Image Files
You can import bitmap (.BMP), JPEG (.JPG), GIF (.GIF), Tagged Image (.TIF), Targa (.TGA), Portable
Network Graphics (.PNG), Z-Soft (.PCX), and Kodak (.PCD) files into your DataCAD LT drawing.
Import any number of black and white, grayscale, and 8- to 32-bit color images. You can trace scanned
drawings, display site maps, or show digital photos of existing building facades when you import
bitmaps into your drawing.
Imported bitmaps are referenced, not inserted into your drawing file. That means your drawing file size
will not increase.
 To import an image:
1.

Click on Bitmap in the Insert pull-down menu. The Select Image dialog box appears.

2.

Click on the .BMP BMP, .JPG, .GIF, .TIF, .TGA, .PNG, .PCX, or .PCD file you want to insert in
your drawing and click Open. The Bitmap menu appears and you are prompted to Enter first
point of bitmap rectangle.
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3.

Toggle Outline on if you want to draw a visible polyline boundary around the inserted image.
Toggle No Outline on if you do not want a visible boundary around the image. These are
mutually exclusive toggles.

4.

Toggle the Fixed Ratio option on to preserve the original dimensions of the image; toggle it off to
dynamically stretch the X and/or Y ratios while you are inserting the bitmap. After you insert the
image, you cannot change the ratio if Fixed Ratio was turned on; therefore, for future flexibility,
you may want to turn Fixed Ratio off.
While working in your drawing, you can toggle off Bitmap On in the Display menu to decrease
drawing refresh times by not displaying all the bitmaps in your drawing. Toggle it on again to
display all images in your drawing as well as allow printing of them. Notice that SWOTHLUDFB
in the Status Window contains an upper-case letter B if BmpOn is active; but it turns to a lowercase b if BmpOn is not active.

5.

Enter the first corner of the image’s extents by clicking in the Drawing Area, using coordinate
entry, or object snapping to an existing point in your drawing. Notice that if you move your
cursor diagonally away from that point, a rectangular box (representing the extents of your
image) stretches with it. You are prompted to Enter second point of bitmap rectangle.

6.

Enter the corner diagonally across from the first corner by clicking in the Drawing Area, using
coordinate entry, or object snapping to an existing point in your drawing. The image is inserted
in your drawing. If Bitmap On is toggled off in the Utility/Display menu, only a rectangular box
representing the extents of the image appears in your drawing. To display your image, toggle
Bitmap On in the Display menu.

7.

Use the Calibrate options in the Enlarge menu to scale bitmaps to real-world size. For more
information about this, see “Calibrating Enlargements” in this chapter.

You can control whether bitmaps or JPEGs print behind or in front of lines by using the Print first or Print
last options in the Pen Table. For more information, see “Using Pen Tables” in the “Printing Your
Drawing” chapter.

Calibrating Enlargements
You can enlarge or reduce imported bitmap and vector graphics to real-world scale. For example, if you
import a site map, you can use the Calibrate Distance function to enlarge the plan to real-world
dimensions.
 To calibrate imported bitmaps or vector graphics and enlarge to real-world size:
1.

Select Enlarge from the Edit menu. You are prompted to Select CENTER of enlargement.

2.

Click on the graphic you want to resize. Options appear in the Enlarge menu.

3.

Select Enlargement to display the calibration options.

4.

Click on Cal. Dist.

5.

Show the length of an entity or a known distance in the bitmap by clicking on your imported
graphic at the first point to begin drawing a measuring line. Extend the line and click again when
you reach the end of the entity or known distance in the graphic. You are prompted to Enter new
distance. The current distance follows this prompt.

6.

Replace that value with what it should be in the “real world.” For example, the current value may
be 0.8, but in reality, it should be 6 feet; therefore, you would type 6 in the input field. Press
(Enter). DataCAD calculates the enlargement factor.

7.

Right-click to go to the Enlarge menu. You are prompted to Select entity to <ENLARGE>.
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8.

Select the entity or entities that you want to enlarge by that factor.

Cal. Dist. automatically calculates an equal X/Y enlargement factor. Instead of Cal. Dist., you can use the
Cal. X and Y, Cal. X, or Cal. Y options to enlarge entities independently or unequally in the X and Y
directions.

(Pro) Drawing Arrows
You can draw arrows of varying widths using the Arrow macro.
 To draw an arrow:
1.

Click on Arrow in the Toolbox pull-down menu. The Arrow menu appears. If ARROW is not
listed in the Toolbox pull-down menu, see “Customizing the Macros Menu” in “The Drawing
Board” chapter for details on how to add it to the menu.

2.

Click on Width in the Arrow menu. A value menu appears.

3.

Use the value menu or type a width for the arrow and press (Enter). You are prompted to Enter
first point of arrow centerline.

4.

Enter the two endpoints of the arrow. Click in the Drawing Area, use coordinate entry, or object
snap to an entity to enter the base of the arrow. Notice that the length and direction of the arrow
changes as you move your cursor. You are prompted to Enter second point of arrow centerline.

5.

Click in the Drawing Area, use coordinate entry, or object snap to an entity to enter the tip of the
arrowhead. The arrow is drawn.
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Chapter 17 Borders and Title
Blocks
You can draw drawing sheet borders and title blocks manually
(with DataCAD’s Polygons menu) or you can use the Drawing
Sheet tool in the DCAD_AEC macro to automate the process.

17

In this chapter:

 Drawing sheet
borders

 Adding title blocks
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(Pro) Drawing Borders and Title Blocks
Borders and title blocks can be added to your drawing in two ways: either follow the procedure outlined
in the tutorial in this manual or use the Drawing Sheet tool in the DCAD_AEC macro.
 To use the Drawing Sheet tool:
1.

Click on DCAD_AEC in the Toolbox pull-down menu. The DCAD_AEC menu appears. If
DCAD_AEC is not listed in the Toolbox pull-down menu, see “Customizing the Macros Menu”
in “The Drawing Board” chapter for details on how to add it to the menu.

2.

Click on DwgSheet in the DCAD_AEC menu. The DwgSheet menu appears.

3.

Notice the Drawing Sheet tool. It calculates the size of the border sheet by using the plotting scale
and paper size you will use when you print your drawing. To enter the plotting scale, click on
Scale. A value menu appears and you are prompted to Select the plotter output scale you will be
using.

4.

Use the value menu to enter the plotting scale you will use.

5.

Enter the sheet size you will use when plotting by clicking on PaperSiz. A menu listing sheet sizes
appears and you are prompted to Select the sheet size you will be plotting to.

6.

Click on a sheet size in the list. If the size of the sheet you are using does not appear on the list,
you can define a custom sheet size, by clicking on Custom and using the value menus to enter the
plotting width and height.

7.

Right-click to return to the DwgSheet menu.

8.

Define the title block. To specify the location of the title block on the sheet, click on TitleLoc.

9.

Choose one of the following locations for your title block:


Click on Top to place the title block on the top of the sheet.



Click on Bottom to place it on the bottom of the sheet.



Click on Left to place it on the left side of the sheet.



Click on Right to place it on the right side of the sheet.



Click on None to draw the sheet border without a title block.

10. Set the number of boxes you want the title block to contain by clicking on TitleDiv. A value menu
appears and you are prompted to Enter number of title block divisions across. For more information
on using value menus, see “Value Menus” in “The Drawing Board” chapter.
11. Use the value menu or type a number and press (Enter). You are prompted to Enter number of title
block divisions down.
12. Use the value menu or type a number and press (Enter). You are returned to the DwgSheet menu.
13. Set the height of the title block by click on TitleSiz. A value menu appears and you are prompted
to Enter height of drawing sheet title block.
14. Use the value menu or type a size and press (Enter). You are returned to the DwgSheet menu.
15. Set the number of detail blocks by clicking on DtailDiv. A value menu appears and you are
prompted to Enter number of detail block divisions across.
16. Use the value menu or type a number and press (Enter). You are prompted to Enter number of
detail block divisions down.
17. Use the value menu or type a number and press (Enter). You are returned to the DwgSheet menu.
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18. Set the height of detail title blocks by clicking on DtailTtl. A value menu appears and you are
prompted to Enter the height of detail title block.
19. Use the value menu or type a height and press (Enter). You are returned to the DwgSheet menu.
20. Add a snapping point at the center of your sheet border by toggling AddSnap on. Toggle
AddSnap off to draw sheet borders without the center snapping point.
21. Draw the border and title block. You must select the center point of the drawing sheet border.
Click in the Drawing Area, use coordinate entry, or object snap to an entity to select the center
point. The sheet border is drawn.
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Chapter 18 Elevations and
Sections
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In this chapter:

With the EZ Tools macro, you can parametrically draw
residential or commercial elevations and sections quickly and
easily. This set of tools eliminates the need for the tedious
linework and calculations otherwise required to create basic
elevations. All angles, lines, offsets, and line lengths are done
automatically, leaving you free to concentrate on the drawing
aesthetics.

 Drawing exterior

The Elevations tool assists in drawing exterior and interior
residential elevations (including door, window, and cabinet
elevations); the Sections tool draws cabinet outline sections.

 Drawing cabinet

You can also create 2D sections from 3D models with the 3D
Section tool.

elevations

 Drawing door
elevations

 Drawing window
elevations

 Drawing cabinet
elevations
sections
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Drawing Exterior Elevations
Exterior elevations are defined by selecting two points along the line of the subfloor. The exterior
elevation will be drawn relative to those two points, based on the Exterior menu settings.

Figure 18.1: A sample exterior elevation with default exterior elevation settings noted. EZ Tools
draws only those lines represented above by extra line thickness.
 To draw an exterior elevation:
1.

Click on EZTOOLS in the Toolbox pull-down menu. The EZ Tools menu appears. If EZTOOLS is
not listed in the Toolbox pull-down menu, click Configure in the Toolbox menu and add
EZTOOLS to the Macros in Menu list.

2.

Click on Elev in the EZ Tools menu. The Elev menu appears.

3.

Click on Exterior in the Elev menu. The Exterior menu appears.
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4.

Choose between a full or partial elevation. Full exterior elevations are drawn by assuming that
the points you will select are on two opposite walls of the structure. Partial elevations are drawn
by assuming that the first point you select will be on a wall and the second point will be at the
mid-point of the structure. To draw a full elevation, toggle Full on; to draw a partial elevation,
toggle Partial on. These two toggles are mutually exclusive; only one can be toggled on at any
given time.

5.

Set the roof style for your elevation by clicking on Style. The Style menu appears and you are
prompted to Select roof style.

6.

Decide what type of roof you want to use by selecting one of the four mutually exclusive toggles:


Toggle Gable on to draw a gable roof in your elevation.



Toggle Hip on to draw a hip roof in your elevation.



Toggle Boston on to draw a Boston-style roof in your elevation.



Toggle Shed on to draw a shed roof in your elevation.

You are returned to the Elev menu.
7.

Set the height of the top plate on which the rafters rest by clicking on PlateHgt. A value menu
appears and you are prompted to Enter plate height. The default PlateHgt setting is 8’-0”. For more
information on using value menus, see “Value Menus” in “The Drawing Board” chapter.

8.

Use the value menu or type a height and press (Enter).

9.

Set the rise of the roof for every one foot of run by clicking on Pitch. A value menu appears and
you are prompted to Enter rise per foot for roof.

10. Use the value menu or type a pitch value and press (Enter). The default Pitch setting is 6”.
11. Set the width of the rafters by clicking on RoofThck. A value menu appears and you are
prompted to Enter the roof thickness.
Notice that the roof thickness is drawn relative to the plate height and the roof line is always
drawn an additional 1/2” from the top surface of the rafter.
12. Use the value menu or type a thickness and press (Enter). The default RoofThck setting is 9 1/2”.
13. Set the length of the roof overhang by clicking on Overhang. A value menu appears and you are
prompted to Enter the roof overhang.
Notice that the roof overhang is measured from the wall exterior framing surface to the back
surface of the fascia.
14. Use the value menu or type a length and press (Enter). The default Overhang setting is 1’-0”.
15. Set the wall thickness by clicking on WallThck. A value menu appears and you are prompted to
Enter the wall thickness.
Notice that the wall thickness is drawn relative to the first point you will select to draw the
elevation.
16. Use the value menu or type a thickness and press (Enter). The default WallThck setting is 3 1/2”.
17. Set the fascia width by clicking on Fascia. A value menu appears and you are prompted to Enter
the width of the fascia.
Notice that the fascia width is measured across the back surface of the fascia; the fascia
thickness is set to 3/4” and can’t be changed.
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18. Use the value menu or type a width and press (Enter). The default Fascia setting is 7 1/2”.
19. Set the rake board width by clicking on Rake Brd. A value menu appears and you are prompted
to Enter the width of the rake board.
Notice that the rake board width is measured from the roof line.
20. Use the value menu or type a height and press (Enter). The default Rake Brd setting is 7 1/2”.
19. Set the corner board width by clicking on CornrBrd. A value menu appears and you are
prompted to Enter the width of the corner board.
Notice that the corner board width is measured relative to the exterior wall line.
20. Use the value menu or type a width and press (Enter). The default CornrBrd setting is 5 1/2”.
19. Set the cladding thickness by clicking on CladThck. A value menu appears and you are prompted
to Enter the cladding thickness.
Notice that the thickness of the cladding is measured from the wall framing out to the exterior wall
line.
20. Use the value menu or type a thickness and press (Enter). The default CladThck setting is 1 1/2”.
19. Set the grade elevation by clicking on GradElev. A value menu appears and you are prompted to
Enter sub-floor distance above the grade.
Notice that the grade elevation is measured relative to the subfloor.
20. Use the value menu or type a distance and press (Enter). The default GradElev setting is 2’-0”.
The distance between the top surface of the subfloor and the bottom edge of the cladding is 1’-0”
and can’t be changed. For best results, set the grade elevation to 1’-0” or greater.
21. Set the color of the outside lines of the elevation by clicking on Out Colr. A color menu appears
and you are prompted to Select outer color.
22. Use the color menu to set the outside line color. The default Out Colr setting is White.
23. Set the color of the inside lines of the elevation by clicking on In Colr. A color menu appears and
you are prompted to Select inner color. The default In Colr setting is Red.
24. Use the color menu to set the inside line color.
25. Select the two points along the top surface of the subfloor. The first point should be located on
the outside surface of the wall framing. To select the first point, click in the Drawing Area, use
coordinate entry, or object snap to a point in your drawing. You are prompted to select the other
side of the elevation.
26. Select the second point by clicking in the Drawing Area, using coordinate entry, or object
snapping to a point in your drawing. The elevation is drawn, aligned with the two points you just
selected. You can click on Defaults at any time to restore all default settings in the Exterior menu.

Drawing Door Elevations
Door elevations are defined by selecting two points along the subfloor line. The door elevation will be
drawn relative to those two points, based on the Door menu settings.
 To draw a door elevation:
1.

Click on EZTOOLS in the Toolbox pull-down menu. The EZ Tools menu appears. If EZTOOLS is
not listed in the Toolbox pull-down menu, click Configure in the Toolbox menu and add
EZTOOLS to the Macros in Menu list.
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2.

Click on Elev in the EZ Tools menu. The Elev menu appears.

3.

Click on Door in the Elev menu. The Door menu appears.

4.

Toggle on the door type: Single or Double. These are mutually exclusive toggles; only one can be
toggled on at any given time. The Single and Double toggles do not apply to Garage A, Garage B,
or Sliding door styles.

5.

Set the door style for your elevation by clicking on Style. The Style menu appears and you are
prompted to Pick style of door to draw.

Figure 18.2: Door styles available for door elevations
6.

Click on a door style in the list. You are returned to the Door menu. See “Door Styles for
Elevations” below for details.

Figure 18.3: Door elevation settings
7.

Set the head height of the door by clicking on Head Hgt. A value menu appears and you are
prompted to Enter door head height.
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8.

Use the value menu or type a height and press (Enter).

9.

Toggle on Trim or SideLght; these are mutually exclusive toggles, so you can select only one.
Draw door trim in your elevation by toggling Trim on; draw the door sidelight by toggling
SideLght on. The Stop option appears. The default setting for Trim is 2 1/2”, the style for the
SideLght option is automatically set, and the Stop option default is 3/4”.

10. Toggle Stop on to draw the door stop if you toggled either Trim or SideLght on in the previous
step.
11. Set the trim color by clicking on TrimColr. A color menu appears and you are prompted to Select
the trim color.
12. Use the color menu to set the trim color. The default TrimColr setting is White.
13. Set the door color by clicking on DoorColr. A color menu appears and you are prompted to Select
the door color.
14. Use the color menu to set the door color. The default DoorColr setting is Red.
15. Enter the first point for the door elevation. You can click in the Drawing Area, use coordinate
entry, or object snap to a point in your drawing. You are prompted to enter a point for the other
side of the door.
16. Enter the second point for the door. You can click in the Drawing Area, use coordinate entry, or
object snap to a point in your drawing. The door elevation is drawn. You can click on Defaults at
any time to restore all default settings in the Door menu.
Door Styles for Elevations
Flush
HalfLght
Patio
French
Leaded
HalfLead
SixPanel
Bifold
Accord
Vented
NarLtRt
NarLtLft
StorFrnt
Garage A
Garage B
Sliding

Flush door style.
Half light door style.
Patio door style.
French door style.
Leaded glass door style.
Half leaded glass door style.
Six panel door style.
Bifold door style.
Accordian door style.
Vented door style.
Door drawn with a narrow light on the right side of the door.
Door drawn with a narrow light on the left side of the door.
Storefront door style.
Garage door style, with four panels; Single and Double toggles do not apply to this style.
Garage door style, with four panels and four windows in the second panel from the top; Single and
Double toggles do not apply to this style.
Sliding door style; Single and Double toggles do not apply to this style.

Drawing Window Elevations
Window elevations are defined by selecting two points along the subfloor line. The window elevation
will be drawn relative to those two points, based on the Window menu settings.
 To draw a window elevation:
1.

Click on EZTOOLS in the Toolbox pull-down menu. The EZ Tools menu appears. If EZTOOLS is
not listed in the Toolbox pull-down menu, click Configure in the Toolbox menu and add
EZTOOLS to the Macros in Menu list.

2.

Click on Elev in the EZ Tools menu. The Elev menu appears.
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3.

Click on Window in the Elev menu. The Window menu appears.

4.

Toggle on either Single or Double; these are mutually exclusive toggles. Draw single windows by
toggling Single on; draw double windows by toggling Double on.

5.

Set the window style for your elevation by clicking on Style. The Style menu appears and you are
prompted to Pick style of window to draw. The Single and Double toggles do not apply to the
casement and sliding window styles.

Figure 18.4: Window styles available for window elevations
6.

Click on a window style in the list. You are returned to the Window menu. See “Window Styles
for Elevations” below for details.

7.

Set the head height of the window by clicking on Head Hgt. A value menu appears and you are
prompted to Enter window head height.

8.

Use the value menu or type a height and press (Enter).

9.

Set the sill height of the window by clicking on Sill Hgt. A value menu appears and you are
prompted to Enter window sill height.

10. Use the value menu or type a height and press (Enter).
11. Toggle one of the five mutually exclusive sill, capstone, and shutter options on to draw brick sills,
capstones, or shutters with your window elevations.


Toggle BrkSillA on to draw brick sills along the bottom of the window.



Toggle BrkSillB on to draw brick sills along the bottom and top of the window.



Toggle Capstone on to draw a bottom and top sill with a capstone.



Toggle ShutterA on to draw a single shutter on either side of the window.



Toggle ShutterB on to draw a double shutter on either side of the window.



To draw window elevations without brick sills, capstones, or shutters, click on whatever
option is toggled on to toggle it off again.
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Figure 18.5: Sill and shutter styles for window elevations
12. Set the frame color by clicking on FramColr. A color menu appears and you are prompted to
Select the frame color.
13. Use the color menu to set the frame color. The default FramColr setting is White.
14. Set the window sash color by clicking on SashColr. A color menu appears and you are prompted
to Select the sash color.
15. Use the color menu to set the sash color. The default SashColr setting is Red.
16. Enter the first point for the window by clicking in the Drawing Area, using coordinate entry, or
object snapping to a point in your drawing. You are prompted to enter a point for the other side
of the window.
17. Enter the second point for the window by clicking in the Drawing Area, using coordinate entry,
or object snapping to a point in your drawing. The window elevation is drawn. You can click on
Defaults at any time to restore all default settings in the Window menu.
Window Styles for Elevations
Picture
Pict 4x8
Pct3x6
PictLead
DH 1/1
DH 4/4
DH 6/6
DH 6/4
DH 9/6
CasemntA
CasemntB
CasemntC
CasemntD
CasemntE
HSliderA
HSliderB

Picture window style.
Picture window style with four columns and eight rows of panes.
Picture window style with three columns and six rows of panes.
Picture window style with leaded glass.
Double-hung window style with no panes.
Double-hung window style with four panes in each window.
Double-hung window style with six panes in each window.
Double-hung window style with six panes in the top window and four panes in the bottom window.
Double-hung window style with nine panes in the top window and six panes in the bottom window.
Casement window style with no panes; Single and Double toggles do not apply to this style.
Casement window style with three panes of equal size; Single and Double toggles do not apply to this
style.
Casement window style with four panes of equal size; Single and Double toggles do not apply to this
style.
Casement window style with three panes, with the center pane larger and the two side panes of equal
size; Single and Double toggles do not apply to this style.
Casement window style with four panes, two center panes larger and of equal size and the two outside
panes of equal size; Single and Double toggles do not apply to this style.
Horizontal sliding window style with two panes of equal size; Single and Double toggles do not apply
to this style.
Horizontal sliding window style with three panes of equal size; Single and Double toggles do not apply
to this style.
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Drawing Cabinet Elevations
Cabinet elevations are defined by selecting two points along the subfloor line. The cabinet elevation will
be drawn relative to those two points, based on the Cabinet menu settings.
Click on Section in the Elev menu to display the Section menu and draw cabinet sections.
 To draw a cabinet elevation:
1.

Click on EZTOOLS in the Toolbox pull-down menu. The EZ Tools menu appears. If EZTOOLS is
not listed in the Toolbox pull-down menu, click Configure in the Toolbox menu and add
EZTOOLS to the Macros in Menu list.

2.

Click on Elev in the EZ Tools menu. The Elev menu appears.

3.

Click on Cabinet in the Elev menu. The Cabinet menu appears.

4.

Toggle on Single or Double; these two options are mutually exclusive. Draw cabinets with one
door by toggling Single on; draw cabinets with double doors by toggling Double on. The Single
and Double toggles do not apply to the drawer, desk, pantry, or oven cabinet styles.

5.

Set the cabinet style for your elevation by clicking on Style. The Style menu appears and you are
prompted to Pick style of cabinet to draw.

Figure 18.6: Cabinet elevation styles
6.

Click on a cabinet style in the list. You are returned to the Cabinet menu. See “Cabinet Styles for
Elevations” below for details.

7.

Set the wall height of the cabinet by clicking on WCab Hgt. A value menu appears and you are
prompted to Enter wall cabinet height.

8.

Use the value menu or type a height and press (Enter).

9.

Set the splash height of the cabinet by clicking on SplshHgt. A value menu appears and you are
prompted to Enter wall splash height.

10. Use the value menu or type a height and press (Enter).
11. Toggle on either PullRt or PullLft to draw cabinet pulls; these are mutually exclusive toggles. If
you toggle Pull Rt on, cabinet pulls are drawn on the right; if you toggle PullLft on, cabinet pulls
are drawn on the left. These options only affect cabinet elevations when Single is toggled on in
the Cabinet menu; they have no effect when Double is toggled on.
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12. Set the counter color by clicking on CntrColr. A color menu appears and you are prompted to
Select the counter color.
13. Use the color menu to set the counter color.
14. Set the cabinet color by clicking on Cab Colr. A color menu appears and you are prompted to
Select the cabinet color.
15. Use the color menu to set the cabinet color. The default Cab Colr setting is Red.
16. Enter the first point for the cabinet. You can click in the Drawing Area, use coordinate entry, or
object snap to a point in your drawing. You are prompted to enter a point for the other side of the
cabinet.
17. Enter the second point for the cabinet. You can click in the Drawing Area, use coordinate entry, or
object snap to a point in your drawing. The cabinet elevation is drawn. You can click on Defaults
at any time to restore all default settings in the Cabinet menu.
Cabinet Styles for Elevations
Std Wall
Std Base
Std Drwr
Std Sink
Std Desk
Van Base
Van Drwr
Van Sink
HC Wall
HC Drwr
HC Sink
HC Desk
Pantry
Oven

Standard wall cabinet style.
Standard base cabinet style.
Standard drawer cabinet style; Single and Double toggles do not apply to this style.
Standard sink cabinet style.
Standard desk cabinet style; Single and Double toggles do not apply to this style.
Vanity base cabinet style.
Vanity drawer cabinet style; Single and Double toggles do not apply to this style.
Vanity sink cabinet style.
Handicapped wall cabinet style.
Handicapped drawer cabinet style; Single and Double toggles do not apply to this style.
Handicapped sink cabinet style.
Handicapped desk cabinet style; Single and Double toggles do not apply to this style.
Pantry cabinet style; Single and Double toggles do not apply to this style.
Oven cabinet style; Single and Double toggles do not apply to this style.

Drawing Sections
The Section tool gives you a quick way to create an outline section cut through cabinets, baths, and
showers. Click on Elev in the Section menu to display the Elev menu and draw elevations.

Figre 14.6: A sample cabinet section with default settings noted
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 To draw a cabinet section:
1.

Click on EZTOOLS in the Toolbox pull-down menu. The EZ Tools menu appears. If EZTOOLS is
not listed in the Toolbox pull-down menu, click Configure in the Toolbox menu and add
EZTOOLS to the Macros in Menu list.

2.

Click on Section in the EZ Tools menu. The Section menu appears.

3.

Click on Cabinet in the Section menu. The Cabinet menu appears.

4.

Set the cabinet style for your section by clicking on Style. The Style menu appears and you are
prompted to Select the type of section to draw. See “Cabinet Styles for Sections” below for details.

5.

Click on a style in the list. You are returned to the Cabinet menu.

6.

Set the soffit height of the cabinet by clicking on Soff Hgt. A value menu appears and you are
prompted to Enter soffit height.

7.

Use the value menu or type a height and press (Enter).

8.

Set the wall elevation of the cabinet by clicking on WCabElev. A value menu appears and you are
prompted to Enter wall cabinet elevation.

9.

Use the value menu or type a value and press (Enter).

10. Set the wall height of the cabinet by clicking on WCab Hgt. A value menu appears and you are
prompted to Enter wall cabinet height.
11. Use the value menu or type a height and press (Enter).
12. Set the back-splash height of the cabinet by clicking on SplshHgt. A value menu appears and you
are prompted to Enter back-splash height.
13. Use the value menu or type a height and press (Enter).
14. Set the section color by clicking on SectColr. A color menu appears and you are prompted to
Select the section color.
15. Use the color menu to set the section color. The default SectColr setting is White.
16. Set the element color (for bathtubs and showers) by clicking on ElemColr. A color menu appears
and you are prompted to Select the element color.
17. Use the color menu to set the element color. The default ElemColr setting is Red.
18. Enter the first point for the cabinet section. You can click in the Drawing Area, use coordinate
entry, or object snap to a point in your drawing. You are prompted to enter a point for the other
side of the section.
19. Enter the second point for the cabinet section. You can click in the Drawing Area, use coordinate
entry, or object snap to a point in your drawing. The cabinet section is drawn. You can click on
Defaults at any time to restore all default settings in the Cabinet menu.
Cabinet Styles for Sections
Standard
HandiCap
Vanity
PassThru
BarTop
Bathtub
Shower

Standard cabinet style.
Handicapped cabinet style.
Vanity cabinet style.
Pass-through cabinet style.
Bar top style.
Bathtub style.
Shower style.
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(Pro) Drawing 2D Sections from a 3D Model
You can use the sectioning tool in the 3D Menus to create 2D sections. Simply select Section from the 3D
Menus. For detailed information about generating 2D sections from a 3D model, see “3D Sectioning Tool”
in the “Site Modeling” chapter.

Chapter 19 Printing Your
Drawing
Printing in DataCAD offers you many different options, so you
can always get the result you need. You can set the plotting scale
for your drawing, customize pen widths for plotting, and assign
colors and weights to different plotter pens. You can plot your
entire drawing or just part of it by using a quick layout; or you
can place multiple details on a single sheet using multi-scale
layout. DataCAD’s print preview allows you to visually check
your plot before you send it to your plotter. You can quickly
check to make sure your final plot will be correct. Either print
just one single sheet or define and then plot several sheets at
once.
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In this chapter:

 Assigning colors and
plotter pen widths

 Laying out your

drawing on sheets

 Previewing your print
 Checking your print
 Printing details and
drawings

 Batch plotting
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Printing Basics
Make sure you first set up the printer(s) you intend to use in Windows so that you can plot your
DataCAD drawings. You can check the printers attached to your computer locally or available on your
office network with Windows. Simply click on the Start button, select Settings, and click on Printers. If the
printer(s) or plotter(s) you intend to use are not displayed in the Printers dialog box, click on the Add
Printer icon. Follow the instructions in Windows to set up the printer(s) you want to use. If you want to
use a printer that is connected to your office network, but it doesn’t appear in the listing in the Printers
dialog box, ask your Network Administrator for assistance. If you occasionally use a printer in your
home, make sure you add that to the list, too.
The first time you print a drawing, you need to set several printing options, including the printer/plotter
you’ll use, the paper size and orientation, and the layout orientation of the drawing. These settings
become part of your drawing when you save the file and DataCAD will use them the next time you print
that particular drawing. You can always change these settings later by using the Print Setup option in the
File pull-down menu.
DataCAD stores printing information on a per-drawing file basis. For each subsequent drawing file, you
must again establish that file’s printing/plotting criteria.
Printing your DataCAD drawing is a simple process. Just display the drawing on your screen as you
want to print it. Then go to the Print/Plot menu. Use the options in this menu to set the criteria for the
plotter, control the plotting scale and the pens (including the width, density, and color), and lay out the
drawing on the sheet(s). You can preview the drawing before you commit it to paper. Finally, you send
the drawing to the printer/plotter or to a file.
 To print a drawing:
1.

Display in the Drawing Window exactly what you want to print. Decide if you want to print the
text, dimensions, hatching, and line weights in your drawing. If you do, make sure Show Text,
Show Dim., Show Hatch, and Show Weight, respectively, are toggled on in the Utility/Display
menu. Keep in mind that the printed version of your drawing will contain only what is displayed
on your screen. If something isn’t visible in the Drawing Window, it will not appear on paper
either.

2.

Click on Print in the File pull-down menu, click on Print/Plot in the Utility menu, or click on
in the Standard toolbar. Depending on whether you’ve printed this drawing before or not, one of
two things may happen now:


If you’ve printed this drawing before, the Print/Plot menu appears. Click on Setup in the
Print/Plot menu to display the Printer/Plotter Settings dialog box.



If this is the first time you’ve printed this drawing, DataCAD tells you A printer has not yet
been selected for this drawing. Please click OK to assign a printer and select a paper size for this
drawing. Click on OK to close the message box and display the Printer/Plotter Settings dialog
box.

Shortcut: Press (Ctrl) + (P) to print your drawing.

PRINTING BASICS |

Figure 19.1: The Printer/Plotter Settings dialog box
3.

Indicate the printer/plotter settings for this drawing file. Make your decisions using the
Printer/Plotter Settings dialog box. These settings will be stored as part of your file so that you
can use them the next time you want to print this particular drawing. Of course, you can change
any of the settings the next time you want to print your drawing.


Printer section - use the Name drop-down box to select the printer you’d like to use. Clicking
the Properties button displays details about the printer you selected.



Paper section - use the Size drop-down box to select a paper size. The paper sizes available in
the Size drop-down box are read from your Windows printer driver. If a size you want is not
listed, then your printer doesn’t support it or the driver may not be configured to display it.
You can change the driver properties by closing DataCAD and opening the Printers dialog
box from the Control Panel in Windows. Choose the next closest appropriate size, select
User-Defined if listed, or use a different printer.

Notice that the Effective plotting area dimensions (displayed directly below the Size drop-down
box) change depending on the Size of paper you choose. The effective plotting area is the
printable area for the paper size you’ve selected, as defined by the printer manufacturer’s driver.
Any part of the drawing extending outside this area will not be printed (see Figure 19.2).


Paper Orientation at Device section - click on Normal or Rotated.



User Defined Paper Size section – indicate the units of measurement (English for inches or
Metric for millimeters) for your printer. Then indicate the width and length of the paper you
want to use. Some printer drivers (such as LaserJets and older plotters) don’t support userdefined paper sizes, even though that option remains listed in the Size drop-down box. One
way to check is to select User-Defined for the paper size and enter a width and length for the
paper size. If the Effective plotting area dimensions don’t change based on the size
dimensions, then the selected printer’s driver doesn’t support user-defined paper sizes. Select
another paper size from the drop-down box.
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Limits of 24”x36” sheet
Effective plotting area, as reported by Windows driver in
print set-up for the selected printer (23.6”x34.66”)
Limits of drawing must be within effective plotting area
Non-printing region

Figure 19.2: Example of printed sheet showing the edges of the sheet, the nonprinting area, the
effective plotting area, and the extents of the drawing


Check Plot section – decide whether you want to print a test copy of your drawing on your
laser printer. If you do not want to print a test copy, click on None. If you want to print a test
copy, use the other options in this portion of the Printer/Plotter Settings dialog box. For more
information, see “Printing a Check Plot” later in this chapter.



Copies section - enter the number of copies of each sheet you’d like to print.



DataCAD Layout Orientation section - click on Normal to print the sheet as it appears on screen
or click on Rotated to rotate the sheet 90° for plotting. The Rotated option in the DataCAD
Layout Orientation section rotates the geometry for the print only; it does not rotate the
drawing itself.

4.

Click OK to close the Printer/Plotter Settings dialog box. The Print/Plot menu appears.

5.

Make decisions about the plotting scale, pen width and/or colors, and rotation for this drawing.


Scale - change the plotting scale by clicking on Scale. A value menu appears and you are
prompted to Select new scale. Use the value menu to select a new scale and press (Enter).



Pen Width - determine if you have lines in your drawing with a line weight above “1.” If so,
you can change the amount of space between pen passes when printing these thicker lines
(see Figure 19.3). Click on Pen Width in the Print/Plot menu and use the value menu to enter
a width.
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Figure 19.3: Lines drawn with a line weight of 4 and printed with a pen width setting of 12 (left)
and 95 (right)


Pen Table - use Pen Table to assign each pen in your plotter to a line color in your drawing as
well as to set the width and color density for each pen. To change Pen Table settings, click on
PenTable in the Print/Plot menu; the Pen Table dialog box appears. Change the settings as
necessary and click on OK. See “Using Pen Tables” later in this chapter for more information.



Rotate – toggle this option on if you want to plot your drawing or detail at a rotation angle,
use the value menu to select an angle, and then press (Enter).

Depending on the plotting history for this drawing, one of two things may happen if you toggle
Rotate on:
If you haven’t plotted this drawing before or if you used the Quick Layout option the last time you
plotted it, you are prompted to Select CENTER of rotation. Click in the Drawing Area to enter the
center of rotation for your plot. You are prompted to Enter ANGLE of rotation.
If you used the Multi-layout option the last time you plotted the drawing, you are prompted to
Enter ANGLE of rotation.
6.

Lay out your drawing with either the Quick Layout or Multi-layout options. Use the Quick
Layout option if you want everything displayed in your Drawing Window to be printed as is on
one sheet of paper. Use the Multi-layout option if you want to lay out multiple details on one or
more sheets. See “Laying Out Your Drawing” later in this chapter for more information on using
the Quick Layout and Multi-layout options.

7.

Decide if you want to look at the plot before sending it to the printer/plotter. Toggle Preview on
to look at your plot before you actually send it to the plotter; toggle Preview off to send the sheet
directly to the plotter. (The Preview toggle can only be used with the Plot and Partial options in
the Print/Plot menu. See “More About Previewing Your Plot” for details.)

8.

Plot the sheet using one of the following options:


Print/Plot – send the sheet to your printer by clicking on Print/Plot in the Print/Plot menu. If
you toggled Preview off in the previous step, the sheet is plotted; if you toggled Preview on,
the DataCAD Plot Previewer opens, allowing you to see the plot before sending it to your
plotter. To interrupt a plot in progress, press (End).



To File – send the sheet to a file by clicking on To File in the Print/Plot menu. A dialog box
appears. Type a name for your plot (.PLT) file and click on Save or press (Enter). Plot files are
saved by default in your DataCAD\Plot Files folder.



Partial - plot only a part of your drawing by clicking on Partial. Choose a selection method
from the Partial menu and then select the part of your drawing you want plotted. If you
toggled Preview off in the previous step, the selection is plotted; if you toggled Preview on,
the DataCAD Plot Previewer opens, allowing you to see the selection before sending it to
your plotter.

405

406 | PRINTING YOUR DRAWING

More About Previewing Your Plot
Preview is a look-before-you-leap function. This is especially useful in large offices where several people
share a printer or plotter. It is also a convenient way to spare a tree.
Previewing a plotting sheet before actually printing it allows you to verify that you’re using the proper
paper size and plotting scale, that your drawing is positioned properly, and that such things as hatching,
dimensions, and line overshoot are displayed as you want them. From the DataCAD Plot Previewer
window, you can change the view of your preview and then plot, copy, or save it.
Copy an image of the preview to
the Windows clipboard. Then paste
it into another Windows
application.

Save the preview as a
PDF file or metafile.

Zoom In, Zoom Out, and Full Page let you see the preview at
different levels of detail. You can also click on the preview to
zoom in or press (Ctrl) or (Shift) and click to zoom out.
Close Plot Previewer
without plotting your
preview and return to
your drawing.
Plot your drawing, just as it’s
displayed in the Plot
Previewer window.

Figure 19.4: The DataCAD Plot Previewer window

(Pro) PDF Files with Layers
You can include drawing layers when you create a PDF file directly from DataCAD. You have three
options when saving a plot preview as a PDF document: No Layers, Drawing Layers, and MSP Details as
Layers (this option is only available when there are MSP sheets defined in the drawing; otherwise, the
only valid options are No Layers and Drawing Layers). You must have Adobe Reader version 6 to view
layers. However, PDF files created by DataCAD (versions 11 and later) can be read by Adobe Reader
versions 4 and 5 as well.
 To create a PDF file of your drawing:
1.

Click on Print in the File pull-down menu, click on Print/Plot in the Utility menu, or click on
in the Standard toolbar. The Print/Plot menu appears.

2.

Make sure Preview is toggled on.

3.

Select Print/Plot. The DataCAD Plot Previewer appears.

4.

Click on Save As or select Save Image As from the File pull-down menu. The Save As dialog box
appears.
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Figure 19.5: Layer options available for creating PDF files
5.

Select the PDF layer option you prefer.

6.

Supply a file name and click on Save or press (Enter).

7.

Exit from the DataCAD Plot Previewer by clicking on Close.

Printing a Check Plot
You can use check plots to do a quick test print to your laser printer before sending the file to your
plotter. Check plots use separate settings for the printer, paper size, and paper orientation you
designated.
 To do a check plot:
1.

Click on Setup in the Print/Plot menu. The Printer/Plotter Settings dialog box appears. Go to the
Check Plot section and select the options you prefer.

2.

Click on Fit to or Use this factor. These options are mutually exclusive.


Fit to – select this if you want to fit the drawing to a single page. This option scales a
previously defined layout to fit on the selected paper size. It does not automatically scale
your drawing to fit on a defined paper size.



Use this factor – select this to scale your drawing to a particular size for the check plot. Select
the scale factor percentage by clicking on the arrows. Your drawing and pen widths (as set in
the Pen Table) are scaled.

Notice that all the settings above the Check Plot section are now grayed and the settings in the
Check Plot section are now available.
3.

Select a printer or plotter to use from the drop-down box in the To this printer area in the Check
Plot section.

4.

Choose a page size from the drop-down box in the Check Plot section.

5.

Go to the Paper Orientation at Device area in the Check Plot section and select Normal or Rotated.
This setting works exactly like the one described in “Printing Basics” earlier in this chapter.

6.

Click on OK to close the Printer/Plotter Settings dialog box.

7.

Continue with step 5 in the instructions under “Printing Basics” earlier in this chapter.
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Using Pen Tables
Using pen tables will allow you to print the lines in your drawing in different colors than you drew them,
in greyscale, or in black, or all of these in a single print! Custom color names also appear in the pen
definition list. When you map a pen to a color, the color is remembered when you re-select the color to
map to. The “In order” option prints SPB fills in order instead of first or last. The print order depends on
pen numbering.
First assign a pen number to the onscreen line color in the Pen Assignments
list box.

Next, set the desired width, density,
and printed color for that pen
number in the Pen Settings table.

Checking a box prompts you to
select a printed color for the
pen. The checkbox is
surrounded with the color you
choose.
If the Map to Color box is not
checked, the pen number will
print in the on-screen color.

Overrides the above color settings
and prints all pens in black.

Figure 19.6: DataCAD’s Pen Table
 To use a pen table:
1.

Click on PenTable in the Print/Plot menu. The Pen Table dialog box appears.

2.

Go to the Pen Assignments list box and click on the color you want to assign to a pen. The color
and its name appear beneath the list box, along with the pen number that color is currently
assigned to.

3.

Type the pen number you want to assign to that color. The pen assignment is changed in the list.

4.

Repeat steps 2 – 3 to continue changing pen assignments as necessary.

4.

Go to the Pen Settings section and make decisions about the width, density, and colors for the
pens.


Width - enter the width (in millimeters) for each pen that you assigned a color to.



Percent Density - print screened colors. A setting of 100% prints full color; entering a lesser
percentage prints a screened color. This setting works only with printers that accept RGB
color definitions. For example, a LaserJet IV can print shades of grey using screened black,
but a LaserJet III can only print black.
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Map to Color - print lines in your drawing in a different color than they are on screen by
checking the box for the pen assigned to the color you used in your drawing. The Color
dialog box appears so that you can select the color (or create a custom color) you’d like to
print. After you click on OK in the Color dialog box, the new color surrounds the Map to
Color checkbox. The Map to Color checkboxes only affect printing; they don’t change entity
colors in your drawing.

Percent Density and Map to Color settings are used only for color and greyscale printing, so they
are only available when All Black is unchecked.

6.

All Black - print all lines in black (regardless of what color they are on screen or what settings
are entered in the rest of the pen table) by checking this option.

Click on OK to save the changes you made to the pen table.

More About Using Pen Tables
Here are some examples of how pen table settings affect plotting:


If you set the Width for Pen 1 to .25 and the Percent Density to 20% and leave Map to Color
unchecked, all lines printed with Pen 1 will be printed .25mm wide in 20% of their full color (i.e., with
a 20% color screen). Full color is a color at 100% density.



You can produce heavy text on a print by drawing all text in a specific color and then mapping that
color to a thicker pen using the Pen Table dialog box.



To print in gray scale, check the Map to Color option for any pen you’d like to print as gray scale. The
Color dialog box appears. Since black is chosen by default, click on OK to accept black as the color
mapped to that pen. Then set the Percent Density option. For example, to print a half-toned black
color, change Percent Density to 50%. Some black and white printers will automatically produce
greyscale print when Map to Color and All Black are left unchecked.



To print lines in a different color than they are on screen, click on the Map to Color checkbox. Select a
color from the Color dialog box; black is selected by default. Click on OK. All lines using that pen will
be reprinted in the selected color, regardless of their color on the screen. The Map to Color options
only affect printing; the actual colors of the entities aren’t changed.

Saving and Using Pen Table Settings
You can save a lot of time when setting up to plot your drawings if you save your Pen Table settings in a
.DPF file. You can then quickly load those settings when you want to use them, instead of having to
change all the Pen Table settings each time you print.
The name of the Pen Table file used in a drawing is always saved in that drawing. The default Pen Table
file is dcadwin.dpf, located in your DataCAD\Support Files folder.
 To save pen table settings:
1.

Click on Pen Table in the Print/Plot menu. The Pen Table dialog box appears.

2.

Change the settings as necessary.

3.

Click on Save As in the Pen Table dialog box. Another dialog box appears, prompting you to Save
pen file as.

4.

Type a name for the Pen Table settings file and click on Save or press (Enter). The dialog box
closes.

5.

Click on OK in the Pen Table dialog box to close it.
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 To use pen table settings that you’ve saved in a .DPF file:
1.

Click on Pen Table in the Print/Plot menu. The Pen Table dialog box appears.

2.

Click on Load in the Pen Table dialog box. Another dialog box appears, prompting you to Load
pen file.

3.

Click on the pen file you want to use and click on Open or press (Enter). The dialog box closes
and the settings are loaded into the Pen Table dialog box.

4.

Click on OK in the Pen Table dialog box to close it.

Laying Out Your Drawing
You have two options for defining plot sheets:


Quick Layout - You can easily lay out your drawing at a single scale on a single sheet of paper.



Multi-layout - You can place multiple details at different scales, add perspective views, or show
rotated clip cubes on a single sheet or several sheets of paper.

Whenever you change Print/Plot menu settings, make sure you check the layouts you’ve already set up
before you plot them. You can use the Preview option to check your sheets.

Using Quick Layout
As its name implies, quick layout is a fast, simple way to print all or part of your drawing on a single
sheet.
 To quickly lay out your drawing for plotting at a single scale:
1.

Click on Quick Layout in the Print/Plot menu. The Layout menu appears. Notice that a grid
representing the plotting area of the selected paper size is now attached to your cursor. (A
dashed grid may also be displayed, representing the last defined quick layout.)

2.

Position the grid over your drawing, so that the part you want to print is inside the grid. If your
drawing is too large or small for the grid, exit the Layout menu and change the plotting scale;
repeat steps 1 – 2.

3.

Position the grid as you want it and click. The layout is defined and you can continue with the
plotting instructions given in “Printing Basics” earlier in this chapter.

(Pro) Using Multi-Scale Layout
Multi-scale layout lets you place multiple details, each at any scale, on a single sheet. You can define up to
256 multi-scale sheets for plotting. You can rename each sheet as well as copy, move, or delete the
contents. See “More About Editing Details and Sheets” in this chapter for more information.
Multi-scale plotting can be used with go-to-views to lay out multiple floors of a building on a single
sheet. Toggle only layers for the first floor on and then save this view using the GoTo View option in the
View pull-down menu. Repeat this for each additional floor. Then place each go-to-view on the sheet
using multi-scale plotting. See “Tutorial: Printing a Drawing” for an example of how to use go-to-views
and multi-scale plotting together.
Once you’ve created and rotated a clip cube, you can add it to a multi-scale plotting sheet. The rotated
clip cube is just like any other detail. You can also place perspective views on a multi-scale plotting sheet.
 To use multi-scale layout:
1.

Click on Multi-layout in the Print/Plot menu. The Multi-layout menu appears.
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2.

Make sure Show All is toggled on to display all details already on the sheet while you’re placing
additional details.

3.

Click on Sheet in the Multi-layout menu. A list of plotting sheets, along with a few other options,
appears in the Menu Window. Click on the sheet you want to use. Remember, you can click on
Scroll Fwrd and Scroll Back to look through all 256 sheets available. Right-click to return to the
Multi-layout menu.
It’s a good idea to give each sheet that you use a meaningful name. This is the Rename option,
described in the “More About Editing Details and Sheets” section of this chapter.

4.

Define how you’d like to set up your sheet layout. Click on Layout Set. in the Multi-layout menu.
The Layout Set. menu appears. Use the options (described in the following bulleted list) available
in the Layout Set. menu to control the appearance of the sheet currently displayed in the Drawing
Window. When you are finished defining the sheet layout, right-click to return to the Multilayout menu.


Set the number of divisions for the sheet by clicking on Layout Div. in the Layout Set. menu.
A value menu appears and you are prompted to Enter X-divisions for layout sheet. Use the
value menu or type a number and press (Enter). A value menu appears and you are
prompted to Enter Y-divisions for layout sheet. Use the value menu or type a number and press
(Enter). You are returned to the Layout Set. menu.



Toggle Auto Calc on in the Layout Set. menu to have DataCAD automatically recalculate the
extents of a detail before you place it on the sheet. If this option is toggled off, you may need
to use the Re-Calc. option for the layout box to accurately represent the extents of the detail.



Toggle Extents on in the Layout Set. menu to display only the extents of details already on
the sheet. This reduces refresh time when you’re working on a sheet with several details on
it. Toggle Extents off to display the details.



Toggle Snap To Divs on to make the cursor snap to the intersection of divisions you defined
with Layout Div.



Toggle on either Grid Lines or Grid Marks. These are mutually exclusive toggles. Grid Lines
uses dashed lines to represent the layout grid; Grid Marks displays only the corner marks.



Toggle on either CC Extents or Ent. Extents. These are mutually exclusive toggles. When you
toggle on CC Extents (clip cube extents), the layout box will reflect the extents of the clip cube
(which may not correspond with the extents of the entities contained within it). If you toggle
on Ent. Extents (entity extents), the Layout box will reflect the extents of the entities (which
may not correspond with the extents of the clip cube surrounding them).

DataCAD remembers the most recent settings and uses them for all future sheets until you
change those layout settings. When you set up another sheet, you can return to the Layout Set.
menu to change any (or all) of the settings to enhance the appearance of the new multi-scale
plotting sheet.
5.

Begin placing details on the sheet. You can place the current view of your drawing or select a goto-view that you’ve defined.


To place the current view of your drawing, click on Layout in the Multi-layout menu. Notice
that a box representing the extents of the current view is now attached to your cursor.



To change a plot layout setting, click on Layout Set. in the Multi-layout menu.
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If you select Layout, you can use Ins. Point to select or snap to a specific point within the drawing.
This becomes the insertion point for the detail. If you select Layout, you can toggle Snap To Divs
on so the detail can be snapped to the intersection you defined with Layout Div. You can also
change the “handle” to position a multi-scale plotting detail on the fly by using the arrow keys
during layout. If you select Layout Set., you can use Auto Calc and Extents options as well as
Snap To Divs. Both Layout and Layout Set. let you set the mutually exclusive toggles Grid Lines
or Grid Marks as well as CC Extents or Ent. Extents.


To place a go-to-view you’ve defined, click on GoTo View in the Multi-layout menu. A list of
your go-to-views appears. Click on the go-to-view you want to place on the sheet. Notice that
a box representing the extents of the go-to-view is now attached to your cursor.

Shortcut: To save go-to-views, click on either 3D Views in the Print/Plot menu and then select
GoTo View from the 3D Views menu; or select GoTo View from the View pull-down menu; or click
on

in the Status Panel toolbar to quickly access the GoTo View menu.

6.

Press (PageUp) or (PageDown) to dynamically scale the detail, then click on the sheet to place the
detail. You are prompted to Enter name of new detail.

7.

Type a name for the detail and press (Enter). If you’re placing go-to-views, you can add another
go-to-view or right-click to return to the Multi-layout menu.

8.

Right-click to return to the Print/Plot menu and plot your sheets.

To make it easier to manage your multi-scale plotting sheets, you should use a meaningful name for each
sheet. Each detail that you place on these sheets should also have a name.
More About Editing Details and Sheets
You can make changes to sheets and the individual details on them. In addition, you can move or copy
details from one multi-scale plotting sheet to another.
 To rename a sheet:
1.

Click on Sheet in the Multi-layout menu. The Sheet menu appears.

2.

Click on Rename. You are prompted to Select sheet to rename.

3.

Click on the sheet in the list that you want to rename. The Rename menu appears and you are
prompted to Enter new name.

4.

Type a new name for the sheet and press (Enter). The sheet name is changed in the list.

 To erase all details on a sheet:
1.

Click on Sheet in the Multi-layout menu. The Sheet menu appears.

2.

Click on Clear Sheet. You are prompted to Select sheet to clear.
Warning: You cannot undo clearing a sheet. Be certain you’re clearing the correct sheet.

3.

Click on the sheet in the list that you want to clear. You are asked Are you sure you wish to clear
‘[sheet name]?

4.

Click on Yes to clear the sheet; click on No to cancel.

 To erase only selected details from a sheet: (Pro)
1.

Click on Details in the Multi-layout menu. The Details menu appears.

2.

Click on Delete in the Details menu. You are prompted to Select detail to delete from list.
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3.

Go to the Menu Window and click on the detail you want to delete. It’s removed from the list and
from the sheet.

 To move a detail on a sheet: (Pro)
1.

Go to the Multi-layout menu, click on the name of the detail you want to move. Notice as you
move your cursor over the Drawing Area, a box representing the extents of the detail is now
attached to your cursor.

2.

Press (PageUp) or (PageDown) to dynamically scale the detail. Then click on the sheet to place the
detail on the sheet.

 To update a detail with your drawing’s current layer settings: (Pro)
1.

Click on Details in the Multi-layout menu. The Details menu appears.

2.

Click on Update in the Details menu. You are prompted to Select detail to update from list.

3.

Click on the detail you want to update. The detail is redrawn with your current layer settings.

 To toggle layers on or off in a detail: (Pro)
1.

Click on Details in the Multi-layout menu. The Details menu appears.

2.

Click on Layer Toggle in the Details menu. You are prompted to Select the detail to toggle layers on
and off.

3.

Click on the detail you want to change. Then click on Total. The layers used in that detail appear
in the Menu Window and you are prompted to Select the layer to toggle on/off.

4.

Click on layers to toggle them on or off, as necessary. The detail is updated on the sheet as you
toggle layers on and off.

5.

Right-click three times to return to the Multi-layout menu.
Caution: Turning layers off in one detail affects all other copies of that same detail you may have
placed on the same or different sheets. If this isn’t the result you want, you could use go-to-views
as details to show different versions of your drawing. For example, you could use go-to-views
such as Floor2 (with dimensions, doors, windows, plumbing, electrical, etc.), Floor2noElec
(without electrical elements), Floor2noPlumb (without plumbing), and so on.

 To change the current view of your drawing to match a detail: (Pro)
1.

Click on Details in the Multi-layout menu. The Details menu appears.

2.

Click on Make Current in the Details menu. The Make Current menu appears, listing the details
on the sheet. You are prompted to Select the detail you wish to use as the current view.

3.

Click in the Menu Window on the detail you want to use. You are returned to the Utility menu
and the view of your drawing is changed.

 To copy a detail from one sheet onto another sheet: (Pro)
1.

Click on Details in the Multi-layout menu. The Details menu appears.

2.

Click on Copy in the Details menu. The Copy menu appears along with a list of the details on
your multi-scale plotting sheet. You are prompted to Select detail to copy.

3.

Click in the Menu Window on the name of the detail that you want to copy to another sheet. The
list of plotting sheets appears and you are prompted to Select destination sheet for detail
“DetailName.”
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4.

Click on the sheet you want to copy the detail onto. DataCAD copies the detail to the sheet you
selected.
The detail you copied is placed on the destination sheet just as it appeared on its original sheet.
For example, if you copied DetailB from the lower left corner of Sheet3 (original sheet) onto
Sheet9 (destination sheet), you will find that copy of DetailB in the lower left corner of Sheet 9.

 To copy all the details from one sheet onto another sheet:
1.

Click on Sheet in the Multi-layout menu. The Sheet menu appears with the list of available multiscale plotting sheets.

2.

Click on Copy. You are prompted to Select the sheet to copy from.

3.

Click on the sheet whose details you want to copy. You are prompted to Select the sheet to copy to.

4.

Click on the sheet where you want to place a copy of all the details from the original sheet. The
message “X details copied from sheet “Name1” to sheet “Name4” appears in the
Coordinates/Hints toolbar. This lets you know how many details were copied from the original
sheet to the destination sheet. When you compare the two sheets, you will see that all the details
were copied in the same positions as they appeared on the original sheet.

 To move all details from one sheet onto another sheet:
1.

Display the sheet that contains the detail you want to move. To do this, select Sheet from the
Print/Plot menu and click on the sheet you want. Then right-click to return to the Print/Plot menu
and click on Multi-layout.

2.

Click on Details in the Multi-layout menu. The Details menu appears.

3.

Click on Move. The Move menu appears with a list of the details on the current sheet. You are
prompted to Select detail to move.

4.

Click on the detail in the Menu Window that you want to move from the current sheet onto
another sheet. The available sheets appear and you are prompted to Select destination sheet for
detail “DetailName.”

5.

Click on the sheet that you want to receive the detail. The message “Detail “DetailName” moved
from sheet “Sheet1” to sheet “Sheet3” appears in the Coordinates/Hints toolbar.
Notice that the detail you moved disappeared from the list displayed in the Move menu even
though it still is pictured on the current sheet. Did it really move or did you take a mental
vacation? Check it out by calling up the destination sheet (in step 5) and then going back to the
original sheet (step 1). The detail you moved (steps 3 through 5) appears on the destination sheet
but is no longer displayed on the original sheet.

(Pro) Batch Plotting
You can batch plot details, multi-layout sheets, and go-to-views from one drawing or from multiple
drawings, all at once. Batch plotting your drawings can save your office a lot of time; instead of waiting
for each drawing to finish printing before you print others, you can batch plot everything at once. You
can set up a batch plot for multiple drawings and plot them all overnight, thereby freeing up valuable
time during regular office hours. It isn’t possible to batch plot in a background mode, so you must wait
until the batch plotting process is complete before continuing your work in DataCAD.
See “Printing Basics,” “Using Pen Tables,” and “Laying Out Your Drawing” earlier in this chapter for
details. Keep in mind that all go-to-views that are batch plotted will use the same quick layout that you
set up using the Quick Layout option in the Print/Plot menu. Using multi-layout sheets is recommended
for greatest control over your plotting results.
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 To batch plot from a single drawing:
1.

Set up details, multi-layout sheets, and go-to-views and change other Print/Plot menu settings as
necessary.

2.

Click on Batch Plot in the Print/Plot menu. The DataCAD Batch Plotting Setup dialog box
appears.

Figure 19.7: The Batch Plotting Setup dialog box
3.

Notice that the list box in the Batch Plotting Setup dialog box lists any quick layouts, go-to-views,
and multi-layout sheets that you’ve defined for the drawing. To choose the views and layouts to
plot, click in the checkbox beside the view or layout. A white box indicates that view will not be
plotted; a black box indicates that view will be plotted. If the checkbox beside the Go-To-Views or
Multi-Layout Sheets folders is half white and half black, some of the views or sheets will be
printed but not all of them. Click the Clear All button to uncheck all boxes.

4.

Go to the Copies input box at the top of the dialog box. Enter the number of copies of each layout
you want to plot.

5.

Go to the top of the dialog box. Check the Plot to File(s) option to plot each selected layout to a
file, instead of sending them directly to your plotter. These plot files will be saved to your
DataCAD\Plot Files folder, with the following filenames:


Go-to-views:

“go-to-view” viewname.PLT



Quick layout:

drawing name – “quick layout”.PLT



Multi-layout sheets:

drawing name – “sheet” sheetname.PLT
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6.

Go to the top of the dialog box. Check the Append Results to Log File option to copy details of
the plotting process and results to a file called BATCHPLOT.LOG in your DataCAD\Plot Files
folder. Normally, each DataCAD station that batch plots will have a separate BATCHPLOT.LOG
file. However, if you set each DataCAD station to a shared network folder for plot files (.PLT) and
.LOG files, then all plot results will be appended in a single .LOG file.

7.

Go to the bottom of the dialog box. Check the Skip Screen Redraws option to speed up the
plotting process. Checking this option skips displaying each drawing or view as it is opened; you
simply won't see each view or layout displayed as it is plotted.

8.

Click on Print/Plot to begin plotting; click on OK to save these plot settings for plotting later (see
instructions below for batch plotting from multiple drawings); or click on Cancel to cancel the
batch plot settings and close the dialog box.

 To batch plot from multiple drawings:
1.

Complete steps 1 – 7 in the instructions above (batch plotting from a single drawing) for each
drawing you’d like to include in the multiple-drawing batch plot. Click on OK in step 8 to simply
save the plot settings.

2.

Click on Close All in the File pull-down menu to close all drawings. Make sure you click Yes to
save changes for each file.

3.

Click on Batch Plot in the File pull-down menu. The DataCAD Batch Plotting Setup dialog box
appears.
Shortcut: Press (Ctrl) + (B) to access the Batch Plotting Setup dialog box.

Figure 19.8: The Batch Plotting dialog box; notice the differences between this one and the
previous Figure
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4.

Click on Add to open the dialog box to select the drawings you want to batch plot. After you add
drawings to the Batch Plotting Setup list box, you can save the group of drawings as a Project Set
File (.SET); simply click on Save As, type a name for the .SET file, and click on Save. In
subsequent batch plotting sessions, you can load a .SET file to quickly plot sets of drawings that
are commonly plotted together, without having to add them to the Batch Plotting Setup list box
each time.

5.

Select the drawings that you set up for batch plotting in step 1 and click on Open. The dialog box
closes and the drawing names and paths appear in the list box in the DataCAD Batch Plotting
Setup dialog box. To remove a drawing from the list, select it and click on Remove. Click on Clear
All to remove all drawings listed.

6.

Enter the number of copies to be plotted. This setting overrides the number of copies setting that
you entered in the Batch Plotting dialog box for each individual drawing.

7.

Plot each drawing to a file instead of sending them directly to your plotter by checking the Plot to
File(s) option at the top of the dialog box. These plot files will be saved to your DataCAD\Plot
Files folder, with the filename: drawing name – “sheet” sheetname.PLT. This setting overrides the
Plot to File setting in each individual drawing.

8.

Go to the top of the dialog box and check the Append Results to Log File option to copy details of
the plotting process and results to a file called BATCHPLOT.LOG in your DataCAD\Plot Files
folder. Normally, each DataCAD station that batch plots will have a separate BATCHPLOT.LOG
file. However, if you set each DataCAD station to a shared network folder for plot files (.PLT) and
.LOG files, then all plot results will be appended in a single .LOG file.

9.

Go to the bottom of the dialog box and check the Skip Screen Redraws option to speed up the
plotting process. Checking this option skips displaying each drawing or view as it is opened; you
simply won't see each view or layout displayed as it is plotted.

10. Go to the bottom of the dialog box and check the Ignore Auto-Recover and ‘File in Use’ Condition
option. This setting lets DataCAD ignore autosave and in use messages that would normally
interrupt batch plotting.
11. Click on Plot to begin plotting; click on OK to save these plotting settings for plotting later; or
click on Cancel to cancel the batch plot settings and close the dialog box.
Printer selection and batch plot settings are stored in each drawing, so you could batch plot each drawing
to a different printer.
 To batch plot drawings to Adobe Acrobat’s PDF format:
1.

Check Plot to File(s) in the Batch Plotting Setup dialog box (see Figure19.7).

2.

Set the File Format to PDF.

Larger firms may want to develop customized batch plotting routines using an enhanced scripting
language. For more information about how to do this, contact DataCAD Technical Support.
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Chapter 20 Modeling Basics
DataCAD has a comprehensive set of 3D modeling tools, which
can be used to complement the 2D tools. Since DataCAD is a true
3D modeling program, 2D and 3D data can coexist in the same
drawing, allowing the user to combine the flexibility and
strengths of each method. For example, you can develop a 2D
drawing that can then be used to construct a 3D profile or
perhaps a surface of revolution.

In this chapter:

 Z-base and Z-height
 The zero plane
 Changing 3D
settings

 Drawing 3D lines
 3D snapping
 Using markers
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Z-Base and Z-Height
After using DataCAD as a 2D drafting tool, you’re probably familiar with the concept of Z-base and Zheight as the “floor” and “ceiling” of entities you draw. When you use the 3D modeling tools in
DataCAD, however, Z-base and Z-height no longer have to be floor and ceiling values. Instead, they’re
measured from the zero plane. Normally, the zero plane is parallel to the floor of your model; so in plan
view, positive values for Z-base and Z-height extend toward you (out of the screen) while negative Z
values extend away from you (into the screen). See “The Zero Plane” below for more information.
Z-base doesn’t have to be at a lower elevation than Z-height, although you may find it easier to use them
this way. Keep in mind, however, that entities are always constructed from Z-base to Z-height.
Most 3D entities have some kind of thickness associated with them; for instance, slabs have thickness
while cylinders and cones have height. Because you can place the zero plane, Z-base, and Z-height in any
spatial orientation with respect to your model, DataCAD can use the Z-base and Z-height settings to
determine the thickness or height of a 3D entity. They can represent the front and back walls of a
building, the sides of a bookcase, or any other two values that, taken together, create a depth to a drawing
object.
In addition to Z-base and Z-height, you can use two auxiliary Z elevations as well: Z-User 1 and Z-User 2.
These elevations are two extra planes in space, placed somewhere between Z-base and Z-height, that can
be useful for creating 3D entities.

Z By Layer
Beginning with DataCAD version 11, you can set unique Z-base and Z-height values on each layer. To do
so, toggle Z By Layer on in the 2D Utility\Settings menu. Each time you set Z-base and Z-height, those
settings will affect the current layer only. Any new layers you create take on the settings of the current
layer, including its values.

The Zero Plane
The zero plane is the plane in your model where Z=0. In plan view, the zero plane is fixed at the ground
plane; however, in other views, you can change its position in relation to your model. It is important to
note that, regardless of how its position changes relative to your model, the zero plane is always parallel
to the screen. When you change its position, the zero plane doesn’t change in relation to your screen; rather it
changes in relation to your model. So when you change views of your model, you can use the following
methods to change the orientation of the zero plane as well:


Change the view of your model to orthographic (plan) view. The zero plane is changed to equal the
ground plane. This method is best used when changes to your model can be made in plan view. Keep
in mind that the model is temporarily displayed in plan view when you define a new elevation.



Create a new elevation (click on New in the View/Elevation pull-down menu). The zero plane is
changed to equal the elevation plane. This method is best used when changes to your model can be
made in elevation view.



Change the view of your model to a parallel view; this is often an elevation but you can use any
parallel view. Use Edit Plane in the 3D Views menu to change the orientation of the zero plane. See
“More About Positioning the Zero Plane” for more information on using the Edit Plane and Plane
Snap options.



Change the view of your model to an isometric or similar view. Using Plane Snap in the 3D Views
menu, change the orientation of the zero plane by selecting three points on the plane, such as the
corners of a slab. This method is useful when you want to change the zero plane to match the plane of
a roof or something similar.
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Using the Controls option in the 3D Views menu, change the view of your model to any parallel
view. The zero plane is changed so that it passes through the view center.

More About Positioning the Zero Plane
As described above, you can use both Edit Plane and Plane Snap to position the zero plane. Following are
specific instructions on using both options.
 To position the zero plane using Edit Plane:
1.

Change to a parallel view that will allow you to draw a line indicating where you want the zero
plane to be. This parallel view is usually an elevation of some kind.

2.

Click on 3D Menus in the Edit menu in the Menu Window. The 3D Menus appears.

3.

Click on 3D Views. The 3D Views menu appears.

4.

Click on Edit Plane in the 3D Views menu. The Edit Plane menu appears.

5.

Notice that a new view center is created when you define a new zero plane. To set the Z
coordinate (or height) of the view center, click on Center Z in the Edit Plane menu, enter a Z
value, and press (Enter). You are prompted to Select a point on the edit plane. The Center Z setting
automatically reverts back to its default of 5’-0” after you finish defining the new zero plane.

6.

Click in the Drawing Area or use coordinate entry to enter the first point of the new zero plane.
This point will also be the new view center. The cursor changes to a New Elevation Indicator and
you are prompted to Indicate the direction of the edit plane. See “More About the New Elevation
Indicator Cursor” in the “Viewing Your Model” chapter.

7.

Click in the Drawing Area or use coordinate entry to enter the second point of the new zero
plane. The view is changed based on the plane you just defined.

8.

Save this new view. Click on Add View in the Edit Plane menu, type a name for the view, and
press (Enter). The view is added to your go-to-view list. Keep in mind that view names can
include up to eight characters but no spaces. If your model moves off screen, click Reset in the
Edit Plane menu. The view is changed back to the most recent plan view.

There are a few rules when using Plane Snap that you should be aware of before you begin:


When you select the three plane-defining points, be sure you snap to them in a clockwise direction.



The first two points you snap to will align with the bottom of the screen in the new view; be sure to
select the points in such a way that the new view will make sense to you. Keep in mind that if the
new view is not what you wanted, you can always click on Reset in the Plane Snap menu to revert
back to your original view.

In the following example, we need to place a skylight in the roof. To do this, we must first reposition the
zero plane so it matches the plane of the roof. The easiest method for doing this is to use Plane Snap to
simply snap to three points of the roof.
Remembering to work in a clockwise direction, we snap to the first two points along the bottom edge of
the roof, rather than along the side. This bottom edge of the roof is aligned with the bottom of the screen,
making it easy for us to orient ourselves to the new view, shown on the right of the example below.
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3
Clockwise
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This edge will align with the bottom of the screen.

Figure 20.1: An example of effectively using Plane Snap to define a new zero plane
 To position the zero plane using Plane Snap:
1.

Change to a parallel view that will give you easy access to three points that lie on the plane that
will be the new zero plane.

2.

Click on 3D Menus in the Edit menu in the Menu Window. The 3D Menus appears.

3.

Click on 3D Views in the 3D Menus menu. The 3D Views menu appears.

4.

Click on Plane Snap in the 3D Views menu. The Plane Snap menu appears and the cursor changes
to a 3D world-snapping cursor. You are prompted to Select first point of snapping plane. For details
on the 3D world-snapping cursor, see “All About 3D Snapping” later in this chapter.

5.

Enter the first point on the new zero plane and snap to a point on your model. You are prompted
to Select second point of snapping plane.

6.

Enter the second point on the new zero plane and snap to the point on your model. You are
prompted to Select third point of snapping plane.

7.

Enter the third point on the new zero plane and snap to the point on your model. The view is
changed based on the plane you just defined. If your model moves off screen, click Reset in the
Plane Snap menu. The view is changed back to the most recent plan view

8.

Save this new view. Click on Add View in the Plane Snap menu, type a name for the view, and
press (Enter). The view is added to your go-to-view list. Keep in mind that view names can
include up to eight characters but no spaces.

Changing 3D Settings
The 3D Settings menu has several toggles and other settings that affect the 3D menus. You can either click
on Settings in the 3D Menus menu or click on Settings in the Tools pull-down menu and then click on 3D
Settings in the submenu.

3D Settings Toggles
There are several toggles that affect drawing using 3D entities:
Layer Search Toggle on to scan all layers when you’re selecting entities; this option works exactly like the one in 2D
selection menus. See “More About Selection Menus” in “The Drawing Board” chapter for more
information on Layer Search.
Quick Search Toggle on to select curved 3D entities only by their center points; toggle off to select them by any
displayed edge
Layer Snap Toggle on to scan all layers when you’re snapping to entities; toggle off to snap to entities on the current
active layer only. See “More About 3D Snapping” later in this chapter for more information on quick
snap.
Quick Snap Toggle on to snap only to straight edges or center points of 3D entities; toggle off to snap to these points
as well as the endpoints of curved entities
Draw Marks Display (on) or suppress (off) control points. This letting also applies to control points on 2D polylines.
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Mesh Grid
Mesh Point
Global Divs.
Dynamic
Slab Refs.

Display (on) control grid for mesh surfaces.
Display (on) control points for mesh surfaces.
Use fixed primary and secondary divisions for all curved entities (on).
Display entities while rotating (on).
Display slab reference points (on).

Setting Primary and Secondary Divisions
Primary divisions are the number of curve divisions in the plane of the screen, also known as the sweep
angle. Secondary divisions are those divisions that affect curves that bulge into or out of the plane of the
screen; these are known as rise or roll angles. You can set the primary and secondary divisions for curved
3D entities using the 3D Settings menu.
 To set the number of primary divisions:
1.

Click on Settings in the 3D Menus menu. The Settings menu appears.

2.

Click on Prim. Divs. in the Settings menu. A value menu appears and you are prompted to Enter
number of primary circle divisions.

3.

Use the value menu or type a value and press (Enter). The primary divisions setting is changed
and you are returned to the Settings menu.

 To set the number of secondary divisions:
1.

Click on Settings in the 3D Menus menu. The Settings menu appears.

2.

Click on Sec. Divs.in the Settings menu. A value menu appears and you are prompted to Enter
number of secondary circle divisions.

3.

Use the value menu or type a value and press (Enter). The secondary divisions setting is changed
and you are returned to the Settings menu.

Setting Z-Elevations
You can change the Z-base and Z-height elevations in the 3D Settings menu, as well as two alternative Zelevation settings.
 To change a Z-elevation:
1.

Click on Settings in the 3D Menus menu. The Settings menu appears.

2.

Click on the Z-elevation you want to change: Z-Base, Z-Height, or one of the two alternative Zelevations, Z-User 1 or Z-User 2. A value menu appears and you are prompted to enter a new
value for the Z-elevation.

3.

Use the value menu or type a value and press (Enter). The Z-elevation is changed and you are
returned to the Settings menu.

Drawing 3D Lines
3D lines are like wires or threads in space; they can connect any two points in 3D space. They are not
constrained to lie in the XY plane; however, unlike 2D lines, 3D lines have no extrusion value.
When you draw 3D lines from Z-base to Z-height and select two points at exactly the same place on the
screen, you create a line that is perpendicular to the screen. Such a line looks like a dot from the current
view (a line viewed end-on). Although this method works, it is usually conceptually easier to draw such
lines flat across the screen in an appropriate elevation view.
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You can specify the endpoints of 3D lines in the same way that you specify the endpoints of 2D lines. You
can select points with the left mouse button, snap to points with the middle mouse button, or enter
coordinates. You can also use the 3D cursor.
The first four options in the 3D Entity/3D Lines menu are toggles that specify one of the four standard Zelevations at which you can define entities. 3D lines can be drawn at Z-Base, Z-Height, or one of two
alternative Z elevations (Z-User 1 or Z-User 2), which are set using the Set Z User 1 and Set Z User 2
options in the 3D Lines menu, respectively.
 To set the height of the Z-User 1 variable:
1.

Choose Set Z User 1 from the 3D Lines menu. A list of values appears.

2.

Choose or type a height value and press (Enter).

 To set the height of the Z-User 2 variable:
1.

Choose Set Z User 2 from the 3D Lines menu. A list of values appears.

2.

Choose or type a height value and press (Enter).

You can also draw 3D lines that begin at Z-base (first point selected) and end at Z-height (second point
selected) by toggling the Base/Height option on in the 3DLine menu. See “Z-Base and Z-Height” in the
beginning of this chapter for more information on Z-elevations.
Further, you can toggle Chain on to create 3D lines that rubber band from the last point entered, just like
2D lines. If you toggle Chain off, you must select both endpoints of each 3D line you draw.

All about 3D Snapping
DataCAD 3D uses a different technique for object snapping than the two-dimensional DataCAD editor.
The most important difference between normal 3D snapping and its 2D counterpart is that normal 3D
snapping attaches the cursor to the projection of the model on the screen, not to the model itself. A
projection is a two-dimensional view of a three-dimensional object. If you want to attach the cursor to
points on the model, you need to orient the zero plane (screen plane) so that it coincides with the part of
the model you are snapping to.
Three-dimensional snapping is designed to work when the model appears in orthographic or any parallel
view. See “The Zero Plane” earlier in this chapter for more information.
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Zero Plane not aligned with
the model.

Snapping here attaches the cursor to the
projection on the screen, not to the model.

Screen

Figure 20.2: Normal snapping
Zero plane aligned with
the model.

Snapping here attaches the cusor
directly to the model.
Screen

Figure 20.3: Zero plane alignment
In several menus in DataCAD 3D, you can use a 3D world-snapping cursor to snap to the endpoints you
see in the model. This 3D world-snapping cursor snaps to the entities themselves rather than connecting
to the projections of those entities. If the 3D cursor appears, then world snapping is on; if you press the
middle button on the mouse, you snap to points on the model and not the projections of those points on
the screen. World snapping works regardless of the location of the zero plane.
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Figure 20.4: 3D world-snapping cursor
Zero plane not aligned
with the model

World snapping here with
the 3-D cursor will attach
you directly to the model
Screen

Figure 20.5: World snapping with 3D cursor
More About 3D Snapping
If you toggle Fast 3D on in the 2D Utility/Object Snap menu or toggle Fast 3D Snap on in the 3D
Menus/Settings menu, you can only snap to the edges of straight-edged objects and the center axis points
of curved entities. If you toggle Fast 3D or Fast 3D Snap off, you can snap to the endpoints of the circular
divisions as well.
The following is a list of entities that you can snap to using Fast 3D and Quick Snap:
3D Lines
Polygons
Blocks
Slabs
3D Arc

Snap to either end of a 3D line
Snap to either end of any displayed edge (including the edges of voids)
Snap to either end of any edge
Snap to either end of any displayed edge (including the edges of voids)
Snap to the arc center marker; with Fast 3D Snap off, you can snap to the endpoints
of the division segments that make up the arc itself
Horizontal or Vertical Cylinder Snap to any of the three center axis markers; with Fast 3D Snap off, you can snap to
the endpoints of the circular divisions of a cylinder
Cone
Snap to any of the three center axis markers; with Fast 3D Snap off, you can snap to
the endpoints of the circular divisions of the cone
Truncated Cone
Snap to any of the three center axis markers; with Fast 3D Snap off, you can snap to
the endpoints of the circular divisions of the truncated cone
Sphere
Snap to any of the three center axis markers; with Fast 3D Snap off, you can snap to
any edge of the facets that make up the sphere
Torus
Snap to the center marker of the sweep or the center markers at the beginning and
end of the roll; with Fast 3D Snap off, you can snap to any edge of the facets that
make up the torus
Contour Curve or Mesh Surface Snap to any control point; Fast 3D Snap has no effect on snapping to contours or
mesh surfaces

|
Surface of Revolution

Symbol

Snap to any control point; with Fast 3D Snap off, you can snap to any edge of the
single-curvature facets which make up the surface of revolution, but you cannot
snap to the edges of the double-curvature facets
Snap to any displayed edge of any portion of the symbol according to the rules for
each individual entity that makes up the symbol

Using Markers
A marker is a 3D snapping point. When you choose 3D Markers from the 3D Entity menu, the following
options appear:
Z-Base
Z-Height
3D Cursor
3D Views

Places a marker at the current Z-base
Places a marker at the current Z-height
Snaps to any object with world snapping enabled; for more information on world snapping. See “All
about 3D Snapping” earlier in this chapter for more information on world snapping.
Accesses the 3D Views menu
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Polygons, Slabs, and Blocks
DataCAD’s 3D polygons, slabs and blocks are closely related
entities with a few important differences. A 3D polygon is a
single entity with no thickness (unlike a 2D polygon, which is a
group of lines drawn from Z-base to Z-height). Slabs, usually the
most common entity in a model, are very similar to polygons,
except that they have a thickness that you can specify. Blocks are
simple solids with six rectangular or parallelogram-shaped
faces. Because the top of a block doesn’t have to lie directly over
its bottom, blocks are particularly useful for modeling support
members that lean to one side.
Another important distinction between 3D polygons and slabs is
that slabs have a reference face, which is the face of the slab that
orients the slab, controls the direction that you can pass a void
through the slab, and is important when moving or adding
vertices or voids to a slab. DataCAD automatically assigns one
face of a slab to be the reference face, depending on what kind of
slab you draw:
Horizontal slabs If you draw the slab from Z-base with the
specified thickness (Base+Thk toggle), the
reference face is at Z-base. If you draw the
slab from Z-height with the specified
thickness (Height+Thk toggle), the reference
face is at Z-height. If you draw the slab from
Z-base to Z-height (Base/Height toggle), the
reference face is at Z-base.
Vertical slabs

When you draw a slab from the top of the
screen to the bottom, the reference face in on
the left. When you draw a slab from the
bottom of the screen to the top, the reference
face in on the right.

Inclined slabs

The reference face is always on the underside
of the slab.

If you forget which face of a slab is the reference face, toggle Slab
Refs. on in the 3D Menus/Settings menu. Dots will be displayed
on every vertex of each reference face, along with an additional
dot on one of the opposite vertices.
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In this chapter:

 Drawing horizontal
and vertical 3D
polygons

 Drawing horizontal
and vertical slabs

 Using inclined

polygons and slabs
to draw roofs

 Adding voids to 3D

polygons and slabs

 Editing 3D polygons
and slabs

 Drawing blocks
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Drawing Rectangular 3D Polygons and Slabs
 To draw a rectangular 3D polygon:
1.

Choose Rectangle from the 3D Entity/Polygons menu.

2.

Choose a Z elevation (Z-Base, Z-Height, Z-User1, or Z-User2) at which to draw the rectangle. To
set the alternative Z elevations, choose Set Z User 1 to set the Z-User 1 elevation or choose Set Z
User 2 to set the Z-User 2 elevation.

3.

Select a point to start the rectangle.

4.

Drag the cursor diagonally to size the rectangle and click. The rectangle is drawn. You can also
create rectangular polygons with Horizontal, but using Rectangle is faster and easier.

 To draw rectangular slabs:
1.

Choose Rectangle from the 3D Entity/Slabs menu.

2.

Choose a Z elevation at which to draw the rectangular slab: from Z-base to a thickness
(Base+Thk), from Z-height to a thickness (Height+Thk), or from Z-base to Z-height (Base/Height).

3.

Determine if you are using Base+Thk or Height+Thk to draw slabs. Set the thickness value by
choosing Thickness from the Rect. Slab menu and then choosing or typing a value and pressing
(Enter). As with all Z measurements, a positive thickness extends out of the screen and a negative
thickness extends into the screen.

4.

Select a point to start the rectangle.

5.

Drag the cursor diagonally to size the slab and click. The slab appears. You can also create
rectangular slabs with Horizontal, but using Rectangle is faster and easier.

Drawing Horizontal 3D Polygons and Slabs
 To draw horizontal 3D polygons:
1.

Choose Polygons from the 3D Entity menu. Then select Horizontal from the Polygons menu.

2.

Choose the elevation at which you want to draw the polygon: Z-Base, Z-Height, or one of the two
alternative Z elevations (Z-User 1 or Z-User 2). These alternative Z elevations are set using the Set
Z User 1 and Set Z User 2 options in the menu, respectively. To set the height of an alternative Z
elevation, choose Set Z User 1 or Set Z User 2 from the Polygons menu and then choose or type a
height value and press (Enter). See “Z-Base and Z-Height” in the “Modeling Basics” chapter for
details about Z-elevations.

3.

Select the first point of the polygon. You can create polygons of up to 36 vertices this way.

4.

Continue selecting points until you are ready to close the polygon. If you make a mistake in
placing a vertex, use Backup to erase the last selected point. Use Backup to erase the last side of
the polygon you drew. Backup is available as soon as you select the first point of a polygon and
until you close the polygon or right-click to disconnect from the polygon you’re drawing. To
cancel the polygon before the polygon is completed and added to the drawing, choose Cancel.
Use Cancel to erase the polygon you’re currently drawing. Cancel is only available after you
select the third point of the polygon and until you close the polygon or right-click to disconnect
from the polygon you’re drawing. You can also choose Exit, which is available until you select the
third point of the polygon, when it becomes Close. Use Exit to stop drawing a polygon and erase
what you’ve drawn to that point.
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If you create a 36-vertex polygon, DataCAD closes the polygon for you. To circumvent this 36vertex limitation, see “Editing 3D Polygons and Slabs” later in this chapter.
5.

Connect the last point you selected with the first one and close the polygon by choosing Close or
right-clicking.
Hint: Do not place two points directly on top of one another. For example, to create a square
polygon, select four points, not five. When you right-click to close the polygon, DataCAD
automatically connects the first and last points. In this example, point four will be automatically
connected to point one.

 To draw horizontal slabs:
1.

Choose Slabs from the 3D Entity menu. Then select Horizontal from the Slabs menu.

2.

Choose the elevation at which you want to draw the slab: Z-base extending to a thickness
(Base+Thk.), Z-height extending to a thickness (Height+Thk.), or Z-base extending to Z-height
(Base/Height). Backup is available as soon as you select the first point of a slab and until you
close the slab or right-click to disconnect from the slab you’re drawing.

3.

Set a thickness for the slab by choosing Thickness from the Slabs menu. Then choose or type a
value and press (Enter). As with all Z measurements, a positive thickness extends out of the
screen and a negative thickness extends into the screen. Set Thickness when you are drawing
slabs with Base+Thk. or Height+Thk.; otherwise, the Thickness setting is ignored.

4.

Select the first point or vertex of the slab. You can create slabs of up to 36 vertices. If you create a
36-vertex slab, DataCAD closes the slab for you. If you make a mistake in placing a vertex, use
Backup to remove the last vertex you entered and then continue to place vertices. Use Exit to stop
drawing a slab and erase what you’ve drawn to that point. After you select the third point of the
slab, the Exit option changes to Close. See “Editing 3D Polygons and Slabs” later in this chapter
for more information about simulating polygons or slabs with more than 36 sides.

5.

Select a second corner point that, along with the first point, forms an edge for the base of the
block.

6.

Choose Cancel if you want to cancel the slab before it is completed and added to the drawing.
Cancel is only available after you select the third point of the slab and until you close the slab or
right-click to disconnect from the slab you’re drawing.

7.

Use Close when you want to connect the last point you selected with the first one and finish the
slab.

Drawing Vertical 3D Polygons and Slabs
Vertical polygons and slabs are rectangular shapes drawn edge on. Vertical polygons are useful for
quickly creating forms that show some kind of extruded quality (like gutters or irregular curtain walls);
vertical slabs are useful for quickly creating free-standing walls. Draw the edge of the vertical polygon or
slab by selecting points on the screen; the height of the entity is determined by the separation of Z-base
and Z-height (or the two alternative Z elevations).
 To draw a vertical 3D polygon:
1.

Choose Polygons from 3D Entity menu. Then select Vertical from the Polygons menu. The Vert.
Poly menu appears.
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2.

Choose to draw the polygon from Z-base to Z-height (Base/Height) or from Z-User 1 to Z-User 2
(Z1/Z2). These toggles set the height of the vertical polygon to run from one Z elevation to the
other (from Z-base to Z-height or from Z1 to Z2). To set the height of the Z1 or Z2 elevation,
choose Z-User 1 or Z-User 2 from the Vert. Poly. Menu, choose or type a height value, and press
(Enter).

3.

Choose Chain to create vertical polygons in succession, with the first edge of each polygon
connected to the last edge of the previous polygon. This is similar to the way 2D lines are drawn.
When you toggle Chain off, DataCAD does not automatically connect lines, so you must select
both points of each polygon edge you draw.

4.

Select two points on the screen creating one edge of the vertical polygon. The polygon is drawn
upright, into or out of the screen.

Figure 21.1: Vertical polygons
 To draw a vertical slab:
1.

Choose Slabs from the 3D Entity menu. Then select Vertical from the Slabs menu. The Vert. Slab
menu appears.

2.

Choose to draw the slab from Z-base to Z-height (Base/Height) or from Z-alternative 1 to Zalternative 2 (Z1/Z2). These toggles set the height of the vertical slab to run from one Z elevation
to the other; they are mutually exclusive. To set the values of Z-alternative 1 and Z-alternative 2,
choose Z-User 1 or Z-User 2 from the Vert. Slab menu, select a value from the list, or type a value
and press (Enter).

3.

Set the thickness of the slab by choosing Thickness from the Vert. Slab menu. Then choose or type
a value and press (Enter). Do not confuse this setting with the Thickness setting in horizontal and
rectangular slabs. Thickness for vertical slabs refers to the short dimension of the slab as seen
across the screen, not the depth of the slab going into the screen.

4.

Choose Left, Center, or Right to determine the side of the slab on which to attach the cursor. The
terms Left, Center, and Right refer to the slab as drawn from the top of the screen toward the
bottom. If you draw the slab from the bottom to the top with Left toggled on, your cursor appears
attached to the right side of the slab. These toggles are mutually exclusive and can be activated at
any time, even after you select the first point of the slab.
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Figure 21.2: Cursor positions on vertical slabs (left, center, and right respectively)
5.

Select the first corner point of the vertical slab.

6.

Move the cursor diagonally to the opposite point of the slab. The slab sizes dynamically with the
cursor. Click to complete the slab. The slab is drawn upright, between the two elevations you
selected in step 2.

Figure 21.3: Vertical slabs
Use Slab Refs. to display markers that indicate the reference face for a slab as well as the direction of
extrusion. The reference face of the slab is determined by the points selected on the screen. The extrusion
is determined by the relative Z-base and Z-height (or Z-User 1 or Z-User 2) settings you have entered.

Figure 21.4: Reference faces
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Drawing Inclined 3D Polygons and Slabs
Inclined polygons can be used to create roof elements. Roofs that you create with this menu do not have a
thickness. To create roofs with thickness, use the Inclines menu in the 3DEntity/Slabs menu, or use the
RoofIt macro available from the Toolbox menu to create simple roofs automatically.
 To create roof elements using inclined polygons:
1.

Use the 3D Views option from the 3D Entity/Polygons menu and then select Plans to place the
model in an orthographic view.

2.

Set Z-Base to the height of the lowest point on the roof.

3.

Set Z-Height to the height of the ridge line (peak) of the roof. DataCAD needs Z-base and Zheight information about the roofs that you are going to create—information that is easily
calculated but not immediately at hand. Calculate the heights and breadths of roofs before using
the Inclines menu.

4.

Choose Inclines from the Polygons menu.

5.

Continue with the sections below to draw the three- or four-edged inclined polygon you need.

 To create roof elements using inclined slabs:
1.

Place the model into orthographic (plan) view.

2.

Choose Slabs from the 3D Entity menu. Then select Inclines from the Slabs menu.

3.

Choose Thickness to set the depth of the roof element; choose or type a value and press (Enter).

4.

Choose whether to add the thickness perpendicularly or vertically. Vertical adds the thickness of
the slab to the roof element vertically or perpendicular to the ground. This produces a plumb cut
on the edge of the roof element. Perped. adds the thickness of the slab to the roof perpendicularly
to the roof slope.

5.

Continue with the instructions below to draw the three- or four-edged inclined slab you need.

 To draw gable, A-frame, and shed roofs:
1.

Choose 4 Edge Para. from the 3D Entity/Slabs/Inclines/Slabs menu.

2.

Select the first corner point at the bottom edge of the slope.

3.

Select the second corner point at the bottom edge of the slope.

4.

Select the first corner point on the ridge of the roof. Enter this third point opposite the first point,
as shown below. Locate this point by snapping or with a reference point shortcut and coordinate
entry. The fourth corner point is automatically derived.
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Figure 21.5: Four-edged parallelograms
 To draw hip and mansard roofs:
1.

Choose 4 Edge Trap. from the 3D Entity/Slabs/Inclines/Slabs menu.

2.

Select the first corner point at the bottom edge of the slope.

3.

Select the second corner point at the bottom edge of the slope.

4.

Select the first corner point on the ridge of the roof. Enter this third point opposite the first point,
as shown below. Locate this point by snapping or with a reference point shortcut and coordinate
entry. The fourth corner point is automatically derived.

3

1

4

2

Figure 21.6: Four-edged trapezoids
When a portion of a roof has four edges, but the opposite edges are not parallel due to unusual
intersections or valleys with other roofing elements, use the four-edged general inclined polygon or slab
option.
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 To draw dormers and other unusual roofs:
1.

Choose 4 Edge Gen. from the 3D Entity/Slabs/Inclines/Slabs menu.

2.

Select the first corner point at the bottom edge of the slope.

3.

Select the second corner point at the bottom edge of the slope.

4.

Select the first corner point on the ridge of the roof. Enter this third point opposite the first point,
as shown below. Locate this point by snapping or with a reference point shortcut and coordinate
entry.

5.

Select the last corner point on the ridge of the roof.

4
2

3

1

Figure 21.7: Four-edged general incline
 To draw the triangular pieces of hip roofs:
1.

Choose 3 Edge Bot. from the 3D Entity/Slabs/Inclines/Slabs menu.

2.

Select the first point at the bottom edge of the slope (at Z-base).

3.

Select the second corner point at the bottom edge of the slope (also at Z-base).

4.

Select the corner point on the ridge of the roof (at Z-height). Locate this point by snapping or
with a reference point shortcut and coordinate entry.

1

3

2

Figure 21.8: Three-edged bottom incline
 To draw simple dormers:
1.

Choose 3 Edge Top from the 3D Entity/Slabs/Inclines/Slabs menu.
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2.

Select the first corner point on the ridge of the roof (at Z-height).

3.

Select the second corner point on the ridge of the roof (also at Z-height). Locate this point by
snapping or with a reference point shortcut and coordinate entry.

4.

Select the corner point at the bottom edge of the slope (at Z-base).

2

1

3

Figure 21.9: Three-edged top incline
The four-edged vertical incline is created edge on, very much like the vertical polygon or slab, except that
the incline has an independent thickness associated with it that controls the depth of the roof.
 To draw a roof using inclined polygons or slabs:
1.

Choose 4 Edge Para. from the 3D Entity, Slabs, Inclines menu.

2.

Choose Thickness to set the depth of the slab (roof). A list of values appears.

3.

Choose or type a value and press (Enter).

4.

Toggle either Vertical or Perpendicular to set the direction for the thickness offset.

5.

Select the location for the lower edge of the polygon or slab or the base of the incline, including
the thickness of the polygon or slab.

6.

Select the location for the upper edge of the polygon or slab or the top of the incline. The polygon
or slab ends at the Z-height, including the thickness of the polygon or slab.

Figure 21.10: Four Edge Parallel Inclined Slabs (thickness applied vertically and perpendicular
respectively)
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 To create three-edged vertical, inclined polygons or slabs:
1.

Choose 3 Edge Poly. from the 3D Entity/Slabs/Inclines/Slabs menu.

2.

Set the thickness of the slab using the Thickness option if you’re drawing a slab.

3.

Snap to the first corner point on the incline. Use the 3D cursor to snap to the corners of roof
elements already in place. You don’t have to select the points in any particular order.

4.

Snap to the second corner point on the incline.

5.

Snap to the third corner point on the incline. The polygon or slab is drawn.

Adding Voids to Polygons and Slabs
The Voids menu in the Polygons and Slabs menus has options for creating and deleting holes in polygons
and slabs. You create a void by drawing a small polygon or slab (representing the void) inside a larger
(primary) polygon or slab. The smaller polygon or slab is then converted into a void with the Add Void
option.
When creating slabs, the reference face of each void must coincide exactly with the reference face of the
primary slab; in addition, the voids must be exactly as thick as the primary slab.
 To add a void:
1.

Draw a primary polygon or slab (the polygon or slab you will be adding a void to). Use Plane
Snap, Elevation/New Elev., or Edit Plane (in the 3D Views menu) to bring the primary polygon or
slab into the zero plane before adding voids. When you create both the primary and void
polygons or slabs without changing the view, they automatically lie in the same plane.

2.

Draw the void polygon or slab inside the primary polygon or slab in exactly the same plane, at Zbase (or whatever Z elevation you drew the primary polygon or slab at) equal to zero. You can
draw more than one void polygon or slab at this time. Make sure the void polygon or slab lies
completely within the primary polygon or slab.

3.

Choose Voids from the Polygons or Slabs menu.

4.

Highlight the primary polygon or slab by selecting one of its edges.

5.

Choose Add Void.

6.

Select the void polygon(s) or slab(s) you drew in step 2. The void polygons or slabs are
highlighted as you select them. The primary polygon or slab now has voids in it.

When you add a void to a polygon or slab, you are left with one entity (a polygon or slab with a hole in it)
where separate polygons or slabs existed before. If you erase or move the primary polygon or slab, the
void moves with it, as you would expect of a single entity. The void polygons or slabs no longer have an
identity apart from the primary polygon or slab to which they belong.
Use Convert Void to convert voids back into the polygons or slabs from which they originated. You must
convert a void when you want to edit the void by adding, deleting, or moving vertices using the Visibility
menu.
 To convert a void:
1.

Select Voids from the Polygons or Slabs menu.

2.

Select a primary polygon or slab by indicating one of its edges. The primary polygon or slab and
any voids are highlighted.

3.

Choose Convert Void from the Voids menu.
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4.

Select the voids that you want to convert back into polygons or slabs. Any converted voids now
exist as individual, embedded polygons or slabs.

To add vertices to a void, convert the void back into a polygon or slab with Convert Void, add vertices
with Add Vertx from the Visibility menu, then use Add Void to turn the polygon or slab back into a void.
You can also move a void or resize it using 3D Menus/Stretch.
Once you add a void to a primary polygon or slab, the void polygon or slab no longer exists as an
independent entity; it becomes a hole in a larger object. Use Erase Void to remove these voids from a
primary polygon or slab.
 To erase a void:
1.

Choose Voids from the Polygons or Slabs menu.

2.

Select the primary polygon or slab by indicating one of its edges. The polygon or slab and any
voids are highlighted.

3.

Choose Erase Void from the Voids menu.

4.

Select the voids that you want to delete from the polygon or slab. Selected voids disappear
entirely, sealing the hole.

Editing 3D Polygons and Slabs
With the Visibility menu options, you can edit (move, add, or delete vertices in) a polygon or slab. You
can also toggle the edges of a polygon or slab to visible or invisible.
To maintain its integrity, edit the polygon or slab in the same plane in which it was created or at least in a
plane parallel to the polygon or slab. Use Plane Snap, NewElev, or Edit Plane from the 3D Views menu.
See the chapter on “Viewing Your Model” for more information about the options for Plane Snap,
Elevation/New Elev., and Edit Plane in the 3D Views menu.
To simulate polygons or slabs with more than 36 sides, you can create a 36-sided polygon or slab and
mark one of the edges as invisible. You can connect another polygon or slab with a shared invisible edge
to the first invisible edge. By hiding the seams, you can build a patchwork of polygons or slabs that
simulates a polygon or slab of an unlimited number of sides.
 To add vertices to a polygon or slab:
1.

Choose Visibility from the 3D Entity/Polygons or Slabs menu. Then select Add Vertex from the
Visibility menu. Make sure that the current editing plane is parallel to the polygon or slab you
want to edit.
Warning: Use caution with Move Vertex and Add Vertex. These commands can create physically
impossible shapes. The most common problems include letting edges cross over one another
and pulling vertices out of the plane of the polygon or slab, thus creating a twisted and ambiguous
shape.

2.

Select the edge of the polygon or slab to which you want to add a vertex. Remember that a
polygon or slab can have no more than 36 vertices. Notice that this edge of the polygon or slab
becomes a rubber band line with your cursor attached to the edge.

3.

Position the new vertex.
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Figure 21.11: Adding a vertex
 To delete the vertices of a polygon or slab:
1.

Choose Del. Vertex from the Visibility menu.

2.

Select the vertex you want to delete. The vertex disappears and the two edges that led into the
deleted vertex now become a single edge. Because a polygon or slab can have no less than three
vertices, you cannot delete a vertex from a triangular-shaped polygon or slab.

Figure 21.12: Deleting a vertex
 To reposition the vertex of a polygon or slab:
1.

Choose Move Vertex from the Visibility menu. Make sure that your current editing plane is
parallel to the polygon or slab that you want to edit.

2.

Select the vertex you want to move. Notice that this vertex is now attached to your cursor and the
two edges of the polygon or slab that lead to this vertex become rubber band lines. You can also
move a vertex with the Stretch option in the 3D Edit menu.

3.

Select a new vertex position.

Figure 21.13: Moving a vertex
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Use Show/Hide to change the visibility of individual edges of a polygon or slab. Selecting a visible edge
makes it invisible, while selecting an invisible edge makes it visible. Edges made invisible are not erased;
they are suppressed from view, usually to hide the seams between adjacent polygons or slabs. Invisible
edges remain invisible after hidden line removal, but the polygon or slab is processed as if they were
visible; invisible edges can obscure objects that lie behind them.
 To make an edge visible or invisible:
1.

Choose Show/Hide from the Visibility menu.

2.

Select the edge of the polygon or slab you want invisible.

Figure 21.14: Using MarkVis on one edge
 To make all edges visible:
1.

Choose Show All from the Visibility menu.

2.

Select the polygon or slab that you want visible. The edges of the selected polygon or slab become
visible.

 To make all edges invisible:
1.

Choose Hide All from the Visibility menu.

2.

Select the polygon or slab that you want invisible. The edges of the selected polygon or slab
become invisible.

Making a polygon or slab completely invisible with Hide All has obvious problems. The best way to
recover an invisible polygon or slab is to use Area or Fence from the selection menu with Show All in the
region where you think the polygon or slab exists.

Drawing Blocks
A block is a simple solid with six rectangular or parallelogram-shaped faces. Because the top of a block is
not constrained to lie directly over its bottom, blocks are particularly useful for modeling supporting
members that lean to one side.
 To draw blocks:
1.

Choose Blocks from the 3D Entity menu.

2.

Select the shape of the base of the block: for a rectangular base, choose Rectangle; for a
parallelogram base, choose Parallel.

3.

Choose Auto Height to automatically place the vertex at Z-height, centered over the center point
of the base; otherwise, you must place the vertex manually.

4.

Choose to place the reference face of the block with one of the following:
 Base+Thk.

At Z-base, extending up through a distance equal to the thickness parameter
set below
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 Height+Thk.

At Z-height, extending up through a distance equal to the thickness
parameter set below

 Base/Height

At Z-base, extending up to Z-height

If you choose Base+Thk. or Height+Thk., you can use Thickness to set the thickness of the block.
(Otherwise, the Thickness setting is ignored.) As with all Z measurements, a positive thickness
extends out of the screen, and a negative thickness extends into the screen. Choose Thickness
from the Blocks menu; then choose or type a value and press (Enter).
5.

Continue with the sections below for either rectangular-based blocks or parallelogram-based
blocks.

 To draw rectangular-based blocks:
1.

Select the first corner of the block base.

2.

Move the mouse diagonally, expanding the base of the block to the proper size. Select the second
corner of the block base. If you selected Auto Height, DataCAD places the top of the block
directly over the bottom and the block is finished.

3.

Turn Auto Height off and select a location of the top of the block; the sides of the block are drawn,
connecting the top and bottom faces.

Figure 21.15: Rectangular-based blocks
 To draw parallelogram-based blocks:
1.

Select a point to serve as one corner of the block.

2.

Select a second corner that, along with the first point, forms an edge for the base of the block.

3.

Select a third corner point to form the parallelogram base of the block. Notice how opposite sides
of the base remain parallel but are not constrained to right angles. When you select Auto Height,
DataCAD places the top of the block directly over the bottom and the block is finished.

4.

Turn Auto Height off and select a location of the top of the block; the sides of the block lean to
connect the top and bottom faces.

Chapter 22 Drawing SingleCurved Entities
Unlike their 2D counterparts, all curved 3D entities in DataCAD
are actually drawn using a number of short line segments to
approximate true curves.
Some 3D entities, such as cylinders, 3D arcs, cones, and
truncated cones, only curve in one direction, around the entity’s
center point or central axis. For these entities, you only need to
set the number of primary divisions.
Entities that curve in more than one direction, such as domes and
spheres, tori, surfaces of revolution, and mesh surfaces, have
both primary and secondary division settings. See “Drawing
Double-Curved Entities” for more information on drawing
entities with both primary and secondary divisions.
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444 | DRAWING SINGLE-CURVED ENTITIES

Drawing 3D Arcs
3D arcs are essentially the same as their 2D counterparts, with the following exceptions:


3D arcs can exist at any orientation in space;



3D arcs can be specified as open or closed;



3D arcs have no extrusion value



3D arcs are approximations of arcs consisting of up to 36 short line segments called divisions.

The first eight options on the 3D Curves menu are quite common and are seen wherever there is a curved
3D entity. Creating this 3D arc footprint is often the first step in creating a curved 3D entity. This footprint
defines the sweep angles for the entity.
3D two- and three-point arcs and radius, diameter, and three-point circles are drawn exactly as their 2D
counterparts. Use Clockwise (available only with 2 Pt. Arc) to create an arc in the clockwise direction
rather than counterclockwise. Use Closed to close the arc and perform a hidden line removal. See
“Drawing Curves” in the “Drawing Other Geometry” chapter for more information about arcs and
circles.

Figure 22.1: Open and closed arcs and circles
Use Tangent to draw arcs that are tangent to a specified line. This method is slightly different from the
way tangent arcs are created in 2D.
 To draw a 3D tangent arc:
1.

Choose Tangent from the 3D Curves menu.

2.

Select the first point of the tangent line. This is the line that the 3D arc draws to.

3.

Select the beginning point of the arc.

4.

Select the endpoint of the arc.

Figure 22.2: Drawing a tangent arc
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A dog-leg arc is defined by the two tangent points of the arc and the point at which those two tangent
lines cross (the knee point). You can use Dog-leg to create an arc that must be tangent to two existing
lines.
 To draw a dog-leg arc:
1.

Choose Dog-leg from the 3D Curves menu.

2.

Select the first point of tangency, or the first point of the arc.

3.

Select the knee point, the point where the two lines of tangency meet.

4.

Select the second point of tangency or the end of the arc.

Figure 22.3: Drawing a dog-leg arc
You can enter the arc at the current elevation of Z-base or Z-height. Choose Z-base or Z-Height,
respectively, and draw the arc.
 To create 3D arcs that curve out of the screen:
1.

Choose Vertical from the 3D Curves menu.

2.

Select the center point of the arc.

3.

Select a starting point for the arc. A list of values appears.

4.

Choose or type a value and press (Enter).

5.

Type the angle of elevation for the first endpoint and press (Enter).

6.

Type the angle of elevation for the second endpoint and press (Enter).

 To set the number of divisions for 3D arcs:
1.

Choose Divisions from the 3D Curves menu. A list of values appears.

2.

Choose or type a division value and press (Enter).

Figure 22.4: Divisions examples (36, 24, 12, and 8 respectively)
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Drawing Vertical Cylinders
Vertical cylinders are drawn as columns or posts standing on end. The diameter of the column is
dynamically specified by drawing the footprint of the cylinder using one of the standard 3D arcs. The
height of the column is controlled by setting Z-base, Z-height, and thickness.
 To draw a vertical cylinder:
1.

Choose Vert. Cyls. from the 3D Entity menu.

2.

Select one of these options: 2 Pt. Arc, 3 Pt. Arc, Tangent, Dog-leg, Radius Circ., Dia. Circ., and 3
Pt. Circ. These options are identical to those in the 3D Curves menu. Choose one of these options
to draw the footprint of the cylinder. A footprint is the shape of the base of the cylinder. For
example, to draw a full cylinder, choose Radius Circ., Dia. Circ., or 3 Pt. Circ. to draw a circular
footprint.

3.

Choose whether to draw the cylinder from Z-base to the thickness value (Base+Thk.), from Zheight to the thickness value (Height+Thk.), or from Z-base to Z-height (Base/Height).

4.

Use Closed to create a closed cylinder for hidden line removals. The cylinder is processed as a
solid element with Closed on.

5.

Follow the prompts in drawing the footprint of the cylinder. For more information on using 2 Pt.
Arc, 3 Pt. Arc, Tangent, Dog-leg, Radius Circ., Dia. Circ., 3 Pt. Circ., and Clockwise, see “3D Arcs”
earlier in this chapter.

Figure 22.5: Vertical columns
Set Thickness when you draw cylinders by Base+Thk. or Height+Thk.; otherwise the Thickness value is
ignored. As is true for all Z measurements, positive thickness extends out of the screen, while negative
thickness extends into the screen.
 To set a thickness:
1.

Choose Thickness from the Vert. Cyls. menu. A list of values appears.

2.

Choose or type a value and press (Enter).
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 To set the number of divisions for the cylinders:
1.

Choose Divisions from the Vert. Cyls. menu. A list of values appears. This setting is the same as
Prim. Divs. in the 3D Menus/Settings menu.

2.

Choose or type a value and press (Enter).

The 3D Views option is a shortcut to the 3D Views menu. See the “Viewing Your Model” chapter for more
information about the 3D Views menu.

Drawing Horizontal Cylinders
Horizontal cylinders draw flat across the screen.
 To draw a horizontal cylinder:
1.

Choose Horiz. Cyls. from the 3D Entity menu.

2.

Select a radius for the cylinder.

3.

Choose the extent of the sweep angles with Start Angle and EndAngle. Alternatively, you can
select one of the four presets: Full Circle, Top Half, Bottom Half, or Side Half.
For more control over the portion of the cylinder that appears, you can:

4.



Reorient the view to draw a vertical cylinder and use the 3D Curves menu to set the portion
of the cylinder needed



Stay with horizontal cylinders and explicitly specify sweep angles for the cylinder

Select two points to represent the endpoints of the cylinder.

To create a cylinder section that covers from the 10:00 position to the 2:00 position on a clock, decide
which way you want to draw the cylinder across the screen. You can draw it from top to bottom or
bottom to top. When drawing from top to bottom, remember that cylinders are drawn counterclockwise.

Figure 22.6: Horizontal cylinder
 To specify the beginning angle of the cylinder sweep angle:
1.

Choose Start Angle from the Horiz. Cyls. menu. A list of beginning sweep angles appears.

2.

Choose or type a beginning sweep angle and press (Enter).

 To specify the ending sweep angle of the cylinder sweep angle:
1.

Choose End Angle from the Horiz. Cyls. menu. A list of ending sweep angles appears.

2.

Choose or type an ending sweep angle and press (Enter).
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Figure 22.7: Computing sweep angles
 To control the radius of the cylinder:
1.

Choose Radius from the Horiz. Cyls. menu. A list of radius values appears.

2.

Choose or type a radius value and press (Enter).

 To draw a full and complete cylinder:
1.

Choose Full Circle from the Horiz. Cyls. menu.

2.

Select the center point of one end of the cylinder.

3.

Select the center point of the other end of the cylinder.

 To draw the top half of a cylinder using a preset pair of sweep angles (much like a speed bump):
1.

Choose Top Half from the Horiz. Cyls. menu.

2.

Select the center point of one end of the cylinder.

3.

Select the center point of the other end of the cylinder.

 To draw the bottom half of a cylinder using a preset pair of sweep angles (much like a trough):
1.

Choose Bottom Half from the Horiz. Cyls. menu.

2.

Select the center point of one end of the cylinder.

3.

Select the center point of the other end of the cylinder.

 To draw half of a cylinder using a preset pair of sweep angles:
1.

Choose Side Half from the Horiz. Cyls. menu.

2.

Select the center point of one end of the cylinder.

3.

Select the center point of the other end of the cylinder. When the two points used to define the
cylinder are drawn from the top to the bottom of the screen, the resulting half-cylinder appears
on the left.
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Use Closed to create a closed cylinder for hidden line removals. The cylinder is processed as a solid
element when Closed is on.
Use the Z-Base toggle to set the centerline of the cylinder to lie at Z-base. If you draw a full circle cylinder,
half of the cylinder lies above Z-base and half lies below. Similarly, the Z-Height toggle sets the centerline
of the cylinder to lie at Z-height. If you draw a full circle cylinder, half of the cylinder lies above Z-height
and half lies below.
 To set the number of divisions for the cylinders:
1.

Choose Divisions from the Horiz. Cyls. menu. A list of values appears. This setting is the same as
Prim. Divs. in the 3D Menus/Settings menu.

2.

Choose or type a value for the number of cylinder divisions and press (Enter).

3D Views accesses the 3D Views menu. See the “Viewing Your Model” chapter for more information
about the 3D Views menu.

Drawing Cones and Truncated Cones
Cones are entities that are not used often in architectural modeling, but they are sometimes seen in spires
and pylons. You can create cones by drawing the base of the cone (at Z-base) using the standard 3D
Curves menu and placing the vertex of the cone at Z-height. DataCAD automatically places the vertex,
thus creating a right cylinder, or you can place the vertex yourself, creating a skewed cylinder.
 To draw a cone:
1.

Choose Cones from the 3D Entity menu.

2.

Decide how you want to place the vertex of the cone at Z-Height. Then use the Auto Height
toggle. If you toggle Auto Height on, DataCAD automatically places the vertex of the cone at ZHeight, centered over the center point of the base. If you toggle Auto Height off, you will have to
manually place the vertex at the top of the cone.

3.

Use Divisions to set the number of divisions for the cone. (This setting is the same as the Prim.
Divs. setting of the 3D Menus/Settings menu.) To set the divisions of a cone, choose Divisions
from the Cones menu; then choose or type a value for the number of divisions and press (Enter).

4.

Toggle Closed on to close the bottom of the cone, creating a solid base. This base won’t be visible
unless you perform a hidden line removal or shade the image.

5.

Draw the footprint (sweep angle) of the cone. The base of the cone is always drawn at Z-base and
the vertex is always drawn at Z-height. See “Drawing 3D Arcs” earlier in this chapter for more
information about drawing the footprints of the cone or on using 2 Pt. Arc, 3 Pt. Arc, Tangent,
Dog-leg, Radius Circ., Dia. Circ., 3 Pt. Circ., Clockwise, and Closed.

6.

Place the vertex of the cone if you toggled Auto Height off. If you place the vertex to one side, you
create a skewed cone.
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Figure 22.8: Cones
See “Drawing 3D Arcs” earlier in this chapter for more information about drawing the footprints of the
cone or on using 2 Pt. Arc, 3 Pt. Arc, Tangent, Dog-leg, Radius Circ., Dia. Circ., 3 Pt. Circ., Clockwise, and
Closed.
Truncated cones have sheared off tops. Creating a truncated cone is similar to creating a regular cone,
except you must also specify the diameter of the top opening of the truncated cone.
 To draw a truncated cone:
1.

Choose Trunc. Cones from the 3D Entity menu.

2.

Set the Z-base and Z-height appropriately. As with regular cones, you draw truncated cones from
Z-base to Z-height.

3.

Toggle Closed on to close the bottom and top of the cone, creating a solid base and top. This solid
base and top won’t be visible unless you perform a hidden line removal or shade the image.

4.

Choose the footprint (sweep angle) of the truncated cone by drawing one of the 3D arcs.

5.

Determine whether you want to toggle Auto Height on or off. If you toggle Auto Height on,
DataCAD automatically uses the Z-height and centers the top portion; then DataCAD prompts
you for the diameter of the top part of the truncated cone. If you toggle Auto Height off,
DataCAD prompts you for the center point of the top circle and then the radius.

Figure 22.9: Truncated cones
The 3D Views option is a shortcut to the 3D Views menu. See the “Viewing Your Model” chapter for more
information about the 3D Views menu.

|
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Chapter 23 Drawing DoubleCurved Entities
Unlike their 2D counterparts, all curved 3D entities in DataCAD
are actually drawn using a number of short line segments to
approximate true curves.
Some 3D entities, such as cylinders, 3D arcs, cones, and
truncated cones, only curve in one direction, around the entity’s
center point or central axis. See “Drawing Single-Curved
Entities” for more information on drawing entities with only
primary divisions.
Entities that curve in more than one direction, such as domes and
spheres, tori, surfaces of revolution, and mesh surfaces, have
both primary and secondary division settings. Primary divisions
are the number of curve divisions in the plane of the screen, also
known as the sweep angle. Secondary divisions are those divisions
that affect curves that bulge into or out of the plane of the screen;
these are known as rise or roll angles.
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In this chapter:

 Drawing domes and
spheres

 Drawing tori
 Drawing surfaces of
revolution

 Drawing mesh
surfaces
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Drawing Spheres and Domes
Spheres are any full sphere or section of a sphere. The menu combines features from both the vertical and
horizontal cylinder menus as well as the 3D arcs menu. See “Drawing 3D Arcs,” “Drawing Vertical
Cylinders,” and “Drawing Horizontal Cylinders” in the “Drawing Single-Curved Entities” chapter for
more information.
 To draw a sphere:
1.

Choose Spheres from the 3D Entity menu.

2.

Choose a 3D curves option from the top part of the menu: 2 Pt. Arc, 3 Pt. Arc, Tangent, Dog-leg,
Radius Circ., Dia. Circ., 3 Pt. Circ., or Clockwise to enter the footprint (sweep angles) of the
sphere. See “Drawing 3D Arcs” in the “Drawing Single-Curved Entities” chapter for more
information on using 2 Pt. Arc, 3 Pt. Arc, Tangent, Dog-leg, Radius Circ., Dia. Circ., 3 Pt. Circ.,
and Clockwise.

3.

Set the rise angles with Start Angle or End Angle or use one of the presets: Full Circle, Top Half,
or Bottom Half. This determines exactly how much of the sphere curves out of the plane of the
screen.

4.

Set the Z-Base or Z-Height properly to set the location of the sphere. The sphere is drawn with its
center point at either Z-base or Z-height, depending on which is toggled on.

5.

Draw the footprint with 3D curves options. DataCAD generates the dome from the footprint and
the rise angles you supplied.

Figure 23.1: Spheres
For more control over the portion of the sphere that appears, you can specify rise angles. A rise angle
describes the angle by which something tilts out of the plane of the screen. Something that lies exactly in
the plane of the screen has a rise angle of 0; something that extends straight out of the screen has a rise
angle of 90.
 To set the beginning rise angle for the sphere:
1.

Choose Start Angle from the Spheres menu. A list of beginning rise angles appears.

2.

Choose or type a beginning rise angle and press (Enter).
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 To set the ending rise angle for the sphere:
1.

Choose End Angle from the Spheres menu. A list of ending rise angles appears.

2.

Choose or type an ending rise angle and press (Enter). When setting the rise angles for the
beginning and end of the sphere, remember that spheres are drawn counterclockwise.

Use Full Circle to create a sphere section encompassing both the north and south hemispheres. Use Top
Half to create a sphere section with just the northern hemisphere. Use Bottom Half to create a sphere
section with just the southern hemisphere. Use Z-Base to set the center of the sphere at the Z-base. Use ZHeight to set the center of the sphere at the Z-height.
 To set the primary (sweep) divisions of the dome:
1.

Choose Prim. Divs. from the Spheres menu. A list of values appears.

2.

Choose or type a value for the number of primary divisions and press (Enter).

 To set the secondary (roll) divisions of the dome:
1.

Choose Start Angle from the Horiz. Cyls. menu. A list of values appears.

2.

Choose or type a value for the number of secondary divisions and press (Enter).
Secondary
divisions

Primary
divisions

Figure 23.2: Primary and secondary divisions

Drawing Tori
A torus is a donut-shaped entity. Full tori are obviously very rare in architectural modeling, but sections
of tori are fairly common. Typical applications include turns in railings, elbow connectors in pipes, and
even children’s playground slides.
 To draw a torus:
1.

Choose Tori from the 3D Entity menu.
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2.

Choose a 3D curves option from the top of the menu: 2 Pt. Arc, 3 Pt. Arc, Tangent, Dog-leg,
Radius Circ., Dia. Circ., 3 Pt. Circ., Clockwise, or Radius for creating the footprint (sweep angles)
of the torus. See “Drawing 3D Arcs” in the “Drawing Single-Curved Entities” chapter for more
information on using 2 Pt. Arc, 3 Pt. Arc, Tangent, Dog-leg, Radius Circ., Dia. Circ., 3 Pt. Circ.,
and Clockwise.

3.

Set the roll angles for the tube part of the torus with Start Angle or End Angle. To use one of the
preset angles, click on Presets in the Tori menu and choose Full Circle, Top Half, Bottom Half, In
Half, or Out Half; then right-click to return to the main Tori menu.

4.

Choose Z-Base or Z-Height. Center the torus at either the Z-base or the Z-height, respectively.

5.

Draw the 3D curves footprint of the torus. The torus (or toroidal section) is calculated from the
footprint and the roll angles.

For more control over how far the torus sweeps out of the plane of the sphere, you can specify roll angles.
A roll angle describes the angle by which something tilts out of the plane of the screen. Something that lies
exactly in the plane of the screen has a roll angle of 0; something that comes straight out of the screen has
a roll angle of 90.
 To set the beginning roll angle for the torus:
1.

Choose Start Angle from the Tori menu. A list of beginning roll angle values appears.

2.

Choose or type a beginning roll angle and press (Enter).

 To set the ending roll angle for the torus:
1.

Choose End Angle from the Tori menu. A list of ending roll angle values appears.

2.

Choose or type an ending roll angle and press (Enter). When setting the roll angles, remember
that tori are drawn counterclockwise as seen in a front elevation.

You can also use these preset options (available when you select Presets from the Tori menu) to set the
most common roll angles:
Full Circle
Top Half
Bottom Half
In Half
Out Half

Creates a full inner-tube torus section
Creates a torus section using only the top part of the torus roll
Creates a torus section using only the bottom part of the torus roll
Creates a torus using only the inside part of the torus roll
Creates a torus using only the outside part of the torus roll

 To indicate the radius of the tube section of the torus (not the radius of the torus itself):
1.

Choose Radius from the Tori menu. A list of radius values appears.

2.

Choose or type a radius value and press (Enter).

 To set the primary (planar) divisions of the torus:
1.

Choose Prim. Divs. from the Tori menu. A list of values appears.

2.

Choose or type a value for the number of primary divisions and press (Enter).

 To set the secondary (roll) divisions of the torus:
1.

Choose Sec. Divs. from the Tori menu. A list of values appears.

2.

Choose or type a value for the number of secondary divisions and press (Enter).
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Figure 23.3: Torus connecting two cylinders

Drawing Surfaces of Revolution
Use Rev. Surface to create 3D solids with radial symmetry. Columns, lampshades, fountains, and
canopies are all examples of objects with radial symmetry that you can model using Rev. Surface.
Surfaces of revolution are so named because of the way you construct them: a polyline profile revolved
around an axis of revolution. As the profile revolves around a given axis, it “sweeps out” a surface in its
wake. This surface is the surface of revolution. To create any surface of revolution, you must determine
what profile and axis combination generates the surface you want.
Surfaces of revolution are single entities. To modify or edit a surface of revolution, you can explode it and
stretch it; alternatively, you can enlarge it to create complex shapes. If you’re trying to model a shape that
doesn’t have radial symmetry, but is close, try starting with a surface of revolution. Then through
enlargements, explosions, and stretches, shape the solid into the form you need.

Figure 23.4: Surface of revolution

457

458 | DRAWING DOUBLE-CURVED ENTITIES
 To draw a surface of revolution:
1.

Choose Rev. Surface from the 3D Entity menu.

2.

Draw or select the profile to rotate. Create the cross section of the object as a polyline. If you
already have a polyline, you can use Select to select the polyline. You can use Backup and Cancel
to create polylines.

3.

Choose Exit. The rise angle options appear.

4.

Set the rise angles for the surface of revolution:
Start Angle
End Angle
Full Circle
Top Half

Sets the beginning rise angle on the surface of revolution
Sets the ending rise angle on the surface of revolution
Sets the rise angle to rotate the profile 360 around, thus creating a full solid
Sets the rise angle to rotate the profile 180 out of the screen, creating just the top half of a full
surface of revolution
Bottom Half Sets the rise angle to rotate the profile 180 into of the screen, creating just the bottom half of a
full surface of revolution
Side Half
Sets the rise angle to rotate the profile 180 into and out of the screen, on whatever side the
contour appears, creating half of a full surface of revolution

5.

Choose a surface of revolution:
Open
Close Side

Close End

With open ends and sides; no surfaces are generated for these parts of the surface of revolution
With closed sides; sides are inside surfaces, the part of the surface of revolution you see if you
stand on the axis of revolution and look outward toward the profile or if you stand outside the
surface and look inward toward the axis
With closed ends; ends refer to the top and bottom, the part of the surface of revolution you see
if you look along the axis of revolution

6.

Choose Prim. Divs. to set the number of circular divisions along the roll of the surface of
revolution (the surfaces which curve out of or into the plane of the screen, which rotate around
the X or Y screen axes. Select Prim. Divs. from the Rev. Surface menu, choose or type a value for
the number circular divisions along the roll, and press (Enter).

7.

Choose Sec. Divs. to set the number of circular divisions along the sweep of the surface of
revolution (the surfaces that show curvature in the plane of the screen, which rotate around the Z
screen axis). Select Sec. Divs. from the Rev. Surface menu, choose or type a value for the number
of circular divisions along the sweep, and press (Enter).

8.

Choose Z-Base or Z-Height to create a surface of revolution whose axis of revolution is at the Zbase or Z-height, respectively.

9.

Choose Exit when you are done with the polyline cross section.
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Figure 23.5: Polyline cross section
10. Select two points for the axis of revolution. The action here is to spin the polyline profile around
the axis of revolution, sweeping out a solid in the process.
1

2

Figure 23.6: Selecting the axis of revolution

Drawing Mesh Surfaces
A mesh surface is a smooth patch that you can mold into a variety of useful shapes including free-form
built structures, tents, and canopies. Mesh surfaces are the surface equivalents of Bezier curves.
Like contours, mesh surfaces are created through a series of control points that you specify. The greater
the variation in the elevation of these control points, the more dramatic the curves in the surface.
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There are always exactly 16 control points to specify for a mesh surface, and these 16 control points
always form a 4x4 grid of points, although the spacing of these points may not be uniform.

Figure 23.7: Mesh surfaces
There are three ways to create a mesh surface:


Specify all 16 control points individually, as four rows, with four points per row. The first control
point is numbered [1,1], meaning row 1, column 1 in the grid of points. The second control point is
numbered [1,2], then [1,3] followed by [1,4], then [2,1], etc. You can change the Z-base or Z-height at
any time during the entry of control points, thus creating a surface that curves into and out of the
screen. The resulting surface is a Bezier-like curved sheet that curves into and out of the screen.



Draw a rubber band box that forms the outer boundary of the mesh surface. The 16 control points are
equally spaced in this box. The resulting surface is a flat sheet.



Place four points in the drawing that represent the four rows of a rectangular sheet surface that go
into the screen.

 To manually draw a mesh surface:
1.

Choose Mesh Surface from the 3D Entity menu.

2.

Select the Z elevation of the first control point [1,1].

3.

Select the first control point.

4.

Repeat steps 2 and 3 until you enter all 16 control points.

Figure 23.8: Mesh grid and its corresponding control points
 To create a rectangular mesh surface:
1.

Choose Rect. Surf. from the Mesh Surface menu.
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2.

Select one corner of a rubber band box to contain the mesh surface.

3.

Select the opposite corner of the rectangular region. The 16 control points are automatically
placed within the boundary rectangle, all at the same elevation and an equal distance apart. To
create a rolling surface, take an elevation view and use the stretch command to move the control
points.

Figure 23.9: Rectangular mesh surface
 To create a vertical mesh surface from Z-base to Z-height:
1.

Choose Vert. Surf. from the Mesh Surface menu.

2.

Select four points across the screen. DataCAD generates a mesh surface that runs from Z-base to
Z-height that fits the control points. For each control point you select on the screen, DataCAD
generates four points: one at Z-base at that location, one at Z-height, and two more, equally
spaced between these extremes.

Figure 23.10: Vertical mesh surface
 To set the number of columns (divisions in the surface in direction 1):
1.

Choose Divs. Dir. 1 from the Mesh Surface menu. A list of surface division values appears.

2.

Choose or type a value for the number of surface divisions in Direction 1 and press (Enter).

 To set the number of rows (divisions in the surface in direction 2):
1.

Choose Divs. Dir. 2 from the Mesh Surface menu. A list of surface division values appears.

2.

Choose or type a value for the number of surface division in Direction 2 and press (Enter).
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Use Disp. Points to display the control points for the surface. When you edit a mesh surface, toggle Disp.
Points on. Toggle Disp. Points off for presentations.
Use Display Grid to connect the surface’s control points with lines. Toggle Display Grid off for
presentations.
As with Contours, you can specify an increment distance to add or subtract to the base elevation as you
enter control points. Set Index sets the index; Add Index and Sub. Index determine whether you add to or
subtract from the current Z elevation value. See “Drawing Topographical Maps with Contours” in the
“Site Modeling” chapter for more information about contours.
 To specify and increment distance:
1.

Choose Set Index from the Mesh Surface menu. A list of distance values appears.

2.

Choose or type an increment distance and press (Enter).

These are the four standard elevations at which you can enter a mesh surface control point Use all four to
create a mesh surface with varying Z elevations. Use Add Index or Sub. Index to change these values.
 To set the values for Z-User 1 and Z-User 2:
1.

Choose one of these elevation options from the Mesh Surface menu. A list of elevation values
appears.

2.

Choose or type an elevation value and press (Enter).

24

Chapter 24 Site Modeling
DataCAD has a tool you can use for site modeling: the Drop
Mesh tool. The Drop Mesh tool creates a triangulated regular
network (TRN) of 3D polygons and is an averaged
representation of data points. Drop Mesh produces a "clean,"
rectilinear result, which may be desirable when accuracy is less
of a concern than the visual representation.
Contours are curved 3D lines drawn through points that you
enter. These are particularly useful for drawing topographical
maps.
As with most tools in DataCAD, the Drop Mesh can be used to
create not only site models but also any surface in your model.
Contours can be used in other drawing situations as well.
Other tools you can use for site modeling include the TIN
Modeler, the 3D Knife, Ruled Surface, and the Section Tool.
The Ruled Surf function allows you to mesh polygons between
contours and polylines. If you are 3D modeling, investigate the
new TIN (Triangular Irregular Network) modeler in the 3D
Polygon menu. The TIN modeler can connect a random series of
survey points (3D markers) with triangular polygons. Once the
polygons are generated, you can calculate the surface area of TIN
models, use the flip valley option to “flip” the valley between
coincident polygon edges, or create roads, foundation cuts, etc.
with the 3D Knife. The drop point option lets you place 3D
markers on the surface of inclined polygons. You can create
polyline contours from polygon site models.

In this chapter:

 Using the drop mesh
 Using contours to

create
topographical maps

 Using the TIN
Modeler

 Using the 3D Knife
 Using Ruled Surface
 Using the Section
Tool
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Site Modeling with Drop Mesh
One option in the 3D Entity/Polygons menu is Drop Mesh. It creates a regular, triangulated, polygon
mesh that lays over selected geometry or points, which can be created from a survey data file. This mesh
can then be shaded or processed through a hidden line removal to provide a model of the building site.
A drop mesh is a group of triangulated polygons, not a single entity; thus, it can increase your drawing
file size substantially. A mesh with 100 X divisions and 100 Y divisions will add 20,000 polygons to your
drawing (X divisions x Y divisions x 2 polygons per grid division, or 100x100x2), increasing your drawing
file by 3MB. Additionally, since entities are not deleted from the drawing database even after you delete
them from the drawing itself, your drawing file size can increase rapidly if you add a drop mesh, delete
it, add another one, and so on. To remove unused entities from the drawing database, use Manage in the
Edit/Layers menu or select Layer Manager from the Tools pull-down menu. DataCAD recommends that
you only use as many divisions as is necessary for a reasonably accurate model.
A drop mesh acts like a cloth dropped over the geometry. The way it drapes over the geometry can be
adjusted with the Divisions-X, Divisions-Y, Stiffness, Smooth, and Smooth Pass options. The mesh is
made up of a grid of polygon divisions, with lines running in both the X and Y directions. These divisions
are set with the Divisions-X and Divisions-Y options; increasing these values adds flexibility to the mesh.
Smooth adds points between the geometry to flatten the surface. Smooth Pass increases the number of
smoothing passes. Stiffness controls how closely the mesh coincides with the actual geometry; in other
words, the lower the stiffness setting, the more tightly it fits to the geometry.
 To drop a mesh:
1.

Choose Drop Mesh from the 3D Entity/Polygons menu. Notice that the current settings appear in
the Attention toolbar.

2.

Click on Options. The Drop Mesh dialog box appears.

Figure 24.1: The Drop Mesh dialog box
3.

Choose Divisions-X and Divisions-Y to set the number of X and Y divisions in the mesh grid.

4.

Choose Stiffness to set the stiffness of the mesh. Enter a number from 1 through 10, where 1 is the
stiffest, and press (Enter). The default setting is 5.

5.

Choose Smooth to toggle on smoothing. This setting will have no effect on points created from an
imported survey data file; it only works with vector geometry. Use of this option increases the
time it takes DataCAD to generate the mesh.
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6.

Determine if Smooth is toggled on. If Smooth is toggled on, the Smooth Pass option becomes
available on the Drop Mesh menu. Choose Smooth Pass to set the number of smoothing passes.
Enter a number from 1 through 10, where 1 is the minimum number of passes; 1 is the default
setting.

7.

Toggle Drop Edge on to model the site edges. When Drop Edge is toggled on, Edge Height
becomes available on the menu. Choose Edge Height to set the distance below the lowest,
calculated point of the site model. The default edge height is 10 feet.

8.

Toggle Show Diagonals on if you want to display the diagonal polygon edges of the mesh.

9.

Drop a mesh over either selected geometry or imported, survey points. To drop a mesh over
existing geometry, use the selection menu at the top of the Drop Mesh menu to select geometry in
your drawing. You can select all of the geometry or only a portion of it. When selection is
complete, continue with step 10. You can choose Clear at any time to cancel your selections. To
use survey data instead, skip to step 10. You can drop a mesh over any geometry in the drawing
except geometric primitives, such as spheres, cones, or cylinders. To drop a mesh over geometric
primitives, you must first explode the entities.

10. Make sure survey data is in a text file formatted in columns. You must use one of five data
formats, including X-Y-Z, Y-X-Z, Horizontal Angle-Distance-Height (HorizAng-Dis-Hght),
Distance-Horizontal Angle-Height (Dist-HorizAng-Hght), and Horizontal Angle-Vertical AngleDistance-Elevation (HorizAng-VertAng-Dist-Elev). To import one of these files, choose Import
from the Drop Mesh menu. The Points File Settings dialog box appears.

Figure 24.2: The Points File Settings dialog box
11. Set the scale for the data of the imported file in the Size of Points File Units input field. Select one
data format from the File DataType portion. Also select the Horizontal Angles and Vertical
Angles options. Click on Continue. The Open dialog box appears.
12. Select the file you want to use and press (Enter) or click on Open. Points based on the survey data
appear in the Drawing Window.
13. Choose Begin from the Drop Mesh menu to begin drawing the drop mesh. Press End to cancel
the mesh at any time.

465

466 | SITE MODELING
The following series of figures demonstrate the effect that the divisions, stiffness, and smoothing options
have on a drop mesh.

Figure 24.3: Site plan drawn using contours

Figure 24.4: Isometric view of contour line drawing.
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Figure 24.5A: Model using 16 x 30 divisions, a stiffness setting of 5, and Smooth toggled off. The
isometric view to the right shows the results of these drop mesh settings. As you can see above,
the mesh (represented by the gray line) does not always meet the points on the contour lines
(represented by the darker line and dots). The result is a rougher approximation of the contour
geometry.

Figure 24.6A: Divisions are increased to 32 x 60, while the stiffness and smooth settings remain the
same. A higher resolution mesh produces a stair-step effect with this stiffness setting.
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Figure 24.5B: Isometric view of model using 16 x 30 divisions with stiffness set to 5 and Smooth
toggled off.

Figure 24.6B: Isometric view of model with divisions increased to 32 x 60.
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Figure 24.5A: Divisions remain at 32 x 60 with Smooth toggled off, but stiffness is increased to 9.
The stiffness is adjusted to counter the stair-stepping effect, resulting in a closer relationship to the
contour points.

Figure 24.6A: Another way to smooth the drop mesh is to use the Smooth option. Here the
divisions and stiffness have been reduced to their original values of 16 x 30 and 5, respectively.
However, Smooth has been toggled on and SmthPass has been set to 5. The interpolation of the
smoothing operation creates smoother transitions between contour points.
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Figure 24.5B: Isometric view of model with stiffness increased to 9.

Figure 24.6B: Isometric view of model with Smooth toggled on and set to 5.

Drawing Topographical Maps with Contours
Contours are curved versions of 3D lines; like 3D lines, they have no thickness. Use contours to create
topographical maps.
Creating contours is similar to creating Bezier or B-spline curves. You place a number of control points
that define the curve. DataCAD accepts up to 36 control points. Unlike Bezier or B-spline curves, the
contour curve that DataCAD generates passes through the points that you draw.
 To draw a contour:
1.

Choose Contours from the 3D Entity menu. The Contours menu appears.

2.

Choose the type of contour you want to draw: Natural, Cyclic, or Tangent. Natural creates a
contour that begins at the first control point you select and ends at the last point. Cyclic creates a
contour that connects the first and last control points with a smooth curve, making a closed
shape. Tangent creates a contour that connects two additional points to the control points,
making a tangency at the end of the contour.

3.

Use the Stiffness option to determine the curvature as the contour passes through each control
point. A high stiffness forces the contour to remain flat as it passes through each point. To set a
stiffness for the contour, choose Stiffness from the Contours menu and choose or type a stiffness
value and press (Enter).
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4.

Choose Divisions and enter a value to indicate the number of line segments you want to use in
between each control point. The further apart your control points, the more divisions you need. If
you set too many divisions, your display regeneration time slows.

5.

Choose the elevation at which you want to draw this contour. Z-Base, Z-User 1, Z-User 2, and ZHeight are the four standard elevations at which you can enter a contour control point. You can
use Add Index or Sub. Index to alter these values. To set the Z elevations, Z-User 1 and Z-User 2,
choose one of these elevation options from the Contours menu, choose or type an elevation value,
and press (Enter).

6.

Determine if you are working with tangent contours. Only with tangent contours, select a first
tangent point, the point before the curve. This point determines the direction of the curve as it
enters the first control point.

7.

Select the control points. You can choose up to 36 control points for any one contour. You may
select Add Index or Sub. Index to enter the next control point at a new elevation. Choose Add
Index to add the value of the Index setting to the current Z elevation value. Choose Sub. Index to
subtract the value of the Index setting from the current Z elevation value.


If you are working with tangent contours, specify the ending tangent point. This is the point
after the curve. It determines the direction that the curve heads as it enters the last control
point.

Figure 24.7: Types of contours (Natural, Cyclic, and Tangent respectively)
Use 3D Cursor to attach a control point to a particular point on your model (vertex of a slab, center of a
sphere, etc.) by snapping in world coordinates with the 3D cursor.
You can force the contour to lie in a plane by specifying that the control points have a fixed Z elevation.
Use the Z-Base, Z-Height, Z-User 1, or Z-User 2 toggles to set the height.
Use Set Index to help create a single contour that rises steadily in the Z direction. For example, to create a
series of concentric contours set at 10’ intervals, use Set Index to set the index to 10’. After drawing the
first contour at Z-base, select Add Index and draw the second contour, which would be entered into the
drawing 10’ higher than the first, and so on.
 To draw a contour that steadily rises:
1.

Choose Set Index from the Contours menu. A list of index distance values appears.

2.

Choose or type an index distance and press (Enter).

(Pro) TIN Modeler
The Triangulated Irregular Network (TIN) modeler uses a set of points, polylines, or contours to help you
accurately plan site changes that will be necessary to accommodate your building. Often, the surveyor
will provide the points or contours you need to generate the TIN model. However, you can also generate
your own points or contour lines using Contours or Markers from the 3D Entity menu.
Once the TIN is generated from the points or contour lines, you can cut, fill, and sculpt the surface of the
building site. DataCAD calculates the surface area and volume for each operation.
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(Pro) Generating a TIN Model from Contour Lines or Markers You Created
You can use the Contours or 3D Markers functions in the 3DEntity menu to represent the surface of your
building site. Then, you can generate a TIN model.
 To create your own contour lines:
1.

Choose Contours from the 3D Entity menu. The Contours menu appears.

2.

Activate one of the mutually exclusive toggles Natural (open-ended), Cyclic (connects the first
and last points with a smooth closed curve), or Tangent (requires two more points at the start and
end of the contour line), depending on the type of contour you want to create. For a tangent
contour line only, you must select a first point before the curve; this point determines the curve’s
tangent direction when you enter the first control point.

3.

Set the number of line segments (from 4 to 36) between control points by clicking on Divisions,
typing a number when prompted to Enter number of divisions per contour segment, and pressing
(Enter). The farther apart your control points, the more divisions you need to create a smooth
curve.

4.

Set the curve tangent factor by clicking on Stiffness, typing a number when prompted to Enter
new contour stiffness tangent factor, and pressing (Enter). The higher the number, the flatter the line
as it passes through each control point.

5.

Set elevation values by clicking on Set Z User 1 or Set Z User 2, typing a number when prompted
to Enter new Z-user1 (or Z-user2) height, and pressing (Enter).

6.

Use Set Index to control the Z-coordinate index distance.

7.

Select up to 36 control points for each contour line. To accurately position each control point, use
coordinate entry by pressing (Spacebar), supplying the X and Y values, and pressing (Enter). You
can use Add Index or Sub Index for a steadily rising or declining line. You can use Z-Base, Z-User
1, Z-User 2, and Z-Height to change elevation values.

8.

Right-click when you have entered the final control point. DataCAD generates the contour line.
For a tangent contour line only, you must also specify the ending tangent point after the curve;
this point determines the curve’s tangent direction when it enters the last control point.

9.

Generate more contour lines if necessary. You can use these lines to generate the TIN model.

 To draw concentric contour lines that steadily rise at specified intervals:
1.

Draw the first contour line at Z-Base.

2.

Click on Set Index, specify a value, and press (Enter). This controls the Z-coordinate index height
of the second and subsequent contour lines. For example, if you specify the Set Index value as 2,
the second contour line will be 2’ above the first, the third will be 2’ above the second, and so on.

3.

Click on Add Index and draw the second contour line. When DataCAD generates this line, it will
be higher than the first one, based on the index you set in step 2.

4.

Generate more contour lines using Add Index if necessary by repeating step 3.

 To generate a TIN model from contour lines:
1.

Open the drawing that contains the lines you entered using Contours.

2.

Rename the file to distinguish it from the contour lines. For example, if the lines were in a file
named My Contours, you may want to use My Contours TIN for the TIN model. To do this select
Save As from the File pull-down menu, supply the new file name, and click on Save or press
(Enter).

(PRO) TIN MODELER |
3.

Select Polygons from the 3D Entity menu and click on TIN Surface. The TIN Surface menu
appears. Another way to arrive at the TIN Surface menu is to select 3D Surfaces from the Create
pull-down menu and then click on TIN Surface.

Figure 24.8: Opening the TIN modeler
4.

Select Area, click above the top left contour, draw the rubber band around the set of contours,
and click to end the box. DataCAD generates the TIN model.

Figure 24.9: TIN Model generated from contour lines
 To use Marker to generate a set of points for the TIN model:
1.

Set the Z-Base for the points by choosing Settings from the 3D Edit menu. Alternatively, you can
choose 3D Settings from the Tools, Settings pull-down menu. The 3D Settings menu appears.

2.

Click on Z-Base, supply the new value, and press (Enter).

3.

Choose 3D Markers from the 3D Entity menu. The 3D Markers menu appears.

4.

Click on Z-Base. If you changed the Z-Base in steps 1 and 2, the new value will appear in the
Information bar. You are prompted to Select the snapping point or marker.
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5.

Use the coordinate entry method to accurately place the points on your screen. A small dot
appears each time you supply the X and Y coordinate values and press (Enter). These dots are
markers that you can use to generate a TIN model.

 To generate a TIN model from points you entered using Marker:
1.

Open the drawing that contains the points you entered using 3D Markers.

2.

Rename the file to distinguish it from the data points. For example, if the points were in a file
named My 3DMarkers, you may want to use My 3D TIN for the TIN model. To do this select
Save As from the File pull-down menu, supply the new file name, and click on Save or press
(Enter).

3.

Select Area, click above the top left point, draw the rubber band around the set of markers, and
click to end the box. DataCAD generates the TIN model.

Figure 24.10: TIN model from points, using Marker

(Pro) Generating a TIN Model from Surveyor’s Data
If the surveyor provides you with data in a point file, you can import that information into DataCAD.
Then, you can create the TIN model.
 To generate a TIN model from a file containing the surveyor’s points:
1.

Select 3D Surfaces from the Create pull-down menu, then click on TIN Surface in the submenu.
Alternatively, select Polygon from the 3D Entity menu, then click on TIN Surface. The TIN
Surface menu appears.

2.

Open the file that contains the surveyor’s set of points by selecting Import from the TIN Surface
menu.

3.

Highlight the file that contains the data for the site and click on Open. The surveyor’s points
appear on your screen.

4.

Select Area, click once above the top leftmost point, draw the rubber band around all the points,
and click again. DataCAD generates the TIN model.

(PRO) TIN MODELER |

Figure 24.11: TIN model from surveyor’s points
The surveyor may have inadvertently duplicated points in the data file. This could result in a TIN model
that takes up more storage space than necessary on your computer. To control the size of your file, you
can eliminate duplicate points before you generate the TIN model.
 To delete duplicate points:
1.

Use Import in the TIN Surface menu to bring the surveyor’s information into DataCAD.

2.

Click on Delete Dupes in the TIN Surface menu.

3.

Select Miss Dist from the TIN Surface menu.. You are prompted to supply the Maximum Distance
between points to combine.

4.

Choose a distance from the ones offered in the menu or supply your own value. Press (Enter).
The Miss Distance lets you determine what “duplicate” means in terms of your file. For example,
if you want to eliminate points that are within 1 foot of each other, you would input 1 as the miss
distance. The larger the value you supply for the miss distance, the more points will be
eliminated and the smaller your file.

5.

Click at the top leftmost corner of the points, drag the rubber band diagonally downward until
you surround the area, and click again. DataCAD eliminates the duplicate points that fall within
the miss distance you specified. If you specified a large value for the miss distance, you should
see a lot less points on your drawing screen. If you specified a small miss distance value, the
difference may not be as obvious.

6.

Right-click to return to the main TIN Surface menu. You are prompted to Select first corner of area
to Process Points for TIN.

7.

Click above the top leftmost corner of the area, surround the points with the rubber band, and
click again. DataCAD produces the TIN model. Depending on the miss distance you selected, the
resulting TIN model will be much simpler and your file will be much smaller.
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Figure 24.12: TIN model without duplicate points

(Pro) Refining the TIN Model
The TIN Modeler dialog box, available through Options in the TIN Surface menu, offers several ways to
refine or further control your model. This dialog box allows you to set the edge factor of the triangles or
to eliminate duplicate points.
The Eliminate Duplicates selection in the Options part of the dialog box serves the same function as
Delete Dupes in the TIN Surface menu. If you activate this feature in the dialog box, you can select from
the pull-down offerings or supply your own value in the Max Distance input box. You may find the
Eliminate Duplicates selection saves you time since you won’t have to go through several menus to enter
the maximum distance between points.
You can divide the TIN model into levels designated by different colors to aid in site preparation
(excavation or augmentation). The Color Slice selections allow you to specify the Z-height where you
want to begin the slice, the size of each level, and the color(s) associated each increment.
The Divisions portion of this dialog box works with TIN models developed from contour lines instead of
point data. You can specify how the contours are divided to control the number of polygons DataCAD
creates while generating your TIN model.

Figure 24.13: The TIN Modeler dialog box

(PRO) TIN MODELER |

(Pro) Using the Edge Factor
The edge factor affects the length of triangles at the TIN model’s boundary. The minimum edge factor is
1; the default factor is 15; and the maximum is 50. If you input a low value, the triangles at the perimeter
of the TIN model will have short, jagged edges. In comparison, a high edge factor value produces
triangles with longer edges and a smoother perimeter.
 To generate a TIN model with smoother edges:
1.

Open the file that contains the point data that you or the surveyor supplied.

2.

Click on Options in the TIN Surface menu. The TIN Modeler dialog box appears.

3.

Use the slide bar or type a value in the Edge Factor input field to indicate the degree of
smoothness. The higher the value, the longer triangles and the smoother the perimeter of the
model. The lower the value, the shorter the triangles and the more jagged the perimeter of the
TIN model.

4.

Click on OK or press (Enter) to accept the value and return to the drawing window.

5.

Activate Area in the TIN Surface menu and surround the points with a rubber band box.
DataCAD generates the TIN model.

Figure 24.14: Edge factor of 50 produces longer triangles and a smoother perimeter

Figure 24.15: Edge factor of 1 produces shorter triangles and a jagged perimeter

(Pro) Using the Color Slice
You can slice or divide the TIN model into several levels, designated by separate colors. If Auto Calc is
activated, DataCAD uses default values; however, you can select the colors for each slice. If you want to
control the base and size of the slice, you must deactivate Auto Calc and supply slice origin and
increment values. The slice origin is the Z-height of the base point; DataCAD produces the slices based on
this value. The slice increment controls the height for each level. You can select the color for each level as
well as the number of colors.
 To slice the TIN model and control the color of the levels:
1.

Open the file that contains the point data that you or the surveyor supplied.

2.

Click on Options in the TIN Surface menu. The TIN Modeler dialog box appears.
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3.

Activate Color Slice in the TIN Modeler dialog box.

4.

Deactivate Auto Calc if you want to supply your own specifications for each slice.

5.

Supply the Z-height for the first slice or make a selection from the pull-down values beside Slice
Origin.

6.

Specify the height that will apply to all the levels or choose from the pull-down values for the
Slice Size.

7.

Indicate in the Num Colors box how many colors you want to use.

Figure 24.16: The TIN Modeler and Color Palette dialog boxes
8.

Click on one of the colored boxes to reveal the Color Palette, make your selections, and click on
OK or press (Enter). You can use between 2 and 15 colors to indicate different elevations. You can
select shades of one color (for example, light green to dark green) or you can use a different color
for each slice. The TIN Modeler dialog box reappears.

9.

Click on OK to make your selections take effect.

Figure 24.17: TIN model using color slice
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(Pro) Using the Division Settings
If you are using contours to generate a TIN model, you can control the number of polygons that are
created. You do this by specifying how the contours are divided through the dialog box that appears
when you select Options from the TIN Surface main menu. The Division Settings portion of the dialog
box offers four mutually exclusive alternatives:


Nodes Only – This is the default. When this option is activated, the contours will not be divided.
Only nodes will be used to generate the TIN model.



Contour Divisions – This option uses the division setting from each contour.



Specify Divisions – This overrides the division setting for all contours. You indicate how many
divisions the TIN model should have. The minimum number of divisions is 2; the maximum is 36.



Division Distance – This allows you to specify divisions by distance.

 To generate a TIN model and control contour divisions:
1.

Open the file that contains the contours that you input or the surveyor supplied.

2.

Click on Options in the TIN Surface menu. The TIN Modeler dialog box appears.

3.

Activate one of the alternatives (Nodes Only, Contour Divisions, Specify Divisions, or Division
Distance) in the Division Settings portion of the dialog box. If you activate either Specify
Divisions or Division Distance, you must also select a value from the pull-down list or supply
your own.

4.

Click on OK.

5.

Click on Area in the TIN Surface menu and surround the contours with the rubber band.
DataCAD produces the TIN model.

Figure 24.18: Nodes Only option
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Figure 24.19: Contour Divisions option

Figure 24.20: Specify Divisions, set at 15

Figure 24.21: Division Distance, set at 10 meters

(Pro) Using the Flip Valley
You can flip the valley seam that the TIN modeler generated between two adjoining triangular polygons.
This gives you greater flexibility and control when you work with the TIN surfaces.

(PRO) USING THE 3D KNIFE |
 To flip the valley seam between two triangles:
1.

Open a file that contains triangles generated with the TIN modeler.

2.

Select Polygons from the 3D Entity menu. The Polygons menu appears.

3.

Click on Flip Valley in the Polygons menu. You are prompted to Select triangle junction to flip.

4.

Zoom to enlarge the triangle junction you want to flip and place your cursor on the line between
the two triangles.

Figure 24.22: Flip valley procedure with cursor on the line between two triangles
5.

Click on the line that separates two adjoining triangles. DataCAD flips the valley.

Figure 24.23: Flipped valley

(Pro) Using the 3D Knife
You can use your TIN model to cut out, raise, or depress irregular areas and paths on the building site.
Since DataCAD also calculates the volume of the affected area, you can estimate the amount of fill that
must be removed (if you are digging for a foundation or a roadway) or added (if you are building up part
of the site). To differentiate the cut area, you can specify a different color from the rest of the TIN model.
Further, you can select distinct colors for each level and/or side of the cut area.
 To cut polygons from the TIN model:
1.

Open the TIN model of the building site.

2.

Select Polygon from the 3DEntity menu. The Polygons menu appears.

3.

Click on 3D Knife in the Polygon menu. The 3D Knife menu appears.

4.

Click on Options in the 3D Knife menu. The 3D Knife Settings dialog box appears. The choices
you make in this dialog box affect the type of cut you create based on your TIN model. The
choices you make will be shown in the small preview window in the dialog box. If you are
unhappy with your choices, you can change them until the representation in the preview
window is correct.
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Figure 24.24: The 3D Knife Settings dialog box
5.

Make selections from the Cut Type options. The options you activate in Cut Type portion of this
dialog box affect the number of settings you can control in other parts of the 3D Knife Settings
dialog box. If an option is gray in the dialog box, it is unavailable.
Remove
Cut Edge
Indent

Uplift

Level

Eliminates the cut polygons from your drawing.
Cuts the edge of the boundary, but does not remove the polygons. You can select the color of
the surface from the palette.
Produces a depressed area or path with visible sides. You can select separate colors from the
palette for the surface and the side of the depression. You can control the depth of the cut
using the pull-down selections or input your own value.
Raises the cut polygons, producing visible sides. You can select separate colors from the palette
for the surface and the side of the raised polygons. You can control the height of the cut using
the pull-down selections or input you own value.
Depresses or raises the cut polygons to a fixed level that you designate. You can use this to
create terraces on a sloping site. This lets you control the maximum depth of the cut or the
maximum height of the fill in addition to the surface and side colors.

6.

Set the measurement you want (meters, yards, or feet) in the Volume Units portion of the dialog
box.

7.

Select one of the options in the Cut Selection portion of the dialog box. You can either select an
existing polygon/polyline or create your own line.

8.

Indicate how to deal with bulges by changing the values in the Bulge Divisions and Maximum
Arc input boxes. These control the curved boundaries.

9.

Click on one of the mutually exclusive options in the Path Setting portion of the dialog box. If you
select either Center Path or Side Path, you must also supply the path width in the input field.

10. Activate Hide Triangulation Edges to hide the edges of cut polygons.
11. Click on OK when you are satisfied with your responses in the dialog box.

(Pro) Drop Point
You can place a three-dimensional marker on a polygon at an inclined point.
 To place a 3D marker on a polygon:
1.

Select Polygons from the 3D Entity menu.
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2.

Select Drop Point from the Polygons menu. The Drop Point menu appears.

3.

Select Area. You are prompted to Select first corner of area to drop 3D markers on.

4.

Click in your drawing window where you want the area to begin; then extend the rubber band by
dragging your mouse.

5.

Click again when you have enclosed the entire area of polygons that should contain 3D markers.
You are prompted to Place markers.

6.

Position your cursor where you want the 3D marker to appear in one of the polygons you
selected. If you want to place markers in additional polygons in the area you selected, just click to
indicate where they should appear.

(Pro) Make Contours
You can make a topological contour map based on a group of three-dimensional points or polygons by
specifying an interval for the contours or using a list of colors for each level. Also, you can label the
contours with their respective Z-heights.
 To generate contours based on 3D points or polygons:
1.

Select Polygons from the 3D Entity menu.

2.

Select Gen. Contour from the Polygons menu. The Gen. Contour menu appears.

3.

Click on From Polys. if you are working from polygons or From Points if you are basing the
contours on points.

4.

Make decisions about variables:
Base
Interval
Highlight
Highlt. Inc.
Highlt. Clr.
Color Slice
Slice Int.
Slice Colors
Label
Label Spec.

Set the Z-base.
Set the Z-distance between contour lines.
Highlight contours at specific height intervals. If you select this option, Color Slice is
unavailable.
Set the Z-distance between highlighted contours.
Select the highlight color you want.
Change the color of the TIN model at specific intervals.
Indicate size of the color slice.
Select colors.
Turn labels on.
Set text attributes (font, size, color, etc.) for labels and indicate the label’s position (top
end, bottom end, etc.).

5.

Select Area. You are prompted to Select first corner of area to Interpolate Contours.

6.

Click where you want the Area rubber band to begin, drag diagonally until the points or
polygons are enclosed, then click to end it.

(Pro) Surface Area
You can calculate the surface area of the polygons you cut, duplicated, or indented.
 To calculate the surface area of the polygons:
1.

Select Polygons from the 3D Entity menu.

2.

Choose Surface Area from the Polygons menu.

3.

Indicate the selection method (Entity, Group, Area, Fence, Mask) that you prefer and follow the
prompts in the Message toolbar. DataCAD calculates the surface area of the polygon(s) you
selected.
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Ruled Surface
You can join two contour lines or two polylines with a ruled surface. Each contour line or polyline can
have its own Z-height and shape.
Drawing direction (clockwise or counterclockwise) can have a significant impact on concentric closed
polylines. If you want to stretch a ruled surface between two concentric closed polylines, they must both
be drawn in the same direction. For example, if you draw the outer closed polyline clockwise, you must
draw the inner closed polyline clockwise, too. Likewise, if you draw the outer closed polyline
counterclockwise, you must draw the inner one clockwise, too. If you draw one closed polyline clockwise
and the other counter clockwise, you will not be able to stretch a ruled surface between the two. In fact,
you will end up with a jumbled mass of polygons.
 To create a ruled surface between two contour lines:
1.

Make sure the two contour lines you want to connect with a ruled surface appear on your
drawing screen. Each contour line can have a different Z-height.

2.

Click on Polygons in the 3DEntity menu. The Polygons menu appears.

3.

Click on Ruled Surf.

4.

Decide how you want the polygons to be drawn on the ruled surface. If you want the rules to be
evenly distributed along the length of the two contour lines, activate Even. If you want the rules
to be weighted based on the relationship between the two contour lines, deactivate Even.

5.

Click on Div. Dist to set the distance between contour divisions. You can control the smoothness
of the ruled surface by the distance between divisions. For example, selecting a small distance
between divisions (such as 3 inches) produces a smoother ruled surface than a larger division
distance (such 3 feet). The larger your division distance, the more jagged the resulting edges of
your ruled surface. Either select a value from the menu or type your own in the input field. Then
press (Enter).

6.

Click on the first contour line. The solid contour line becomes a lighter colored, dashed one. You
are prompted to Select second contour line to process.

Figure 24.25: Two contour lines

RULED SURFACE |
7.

Click on the second contour line. DataCAD stretches the ruled surface between the two contour
lines. In this example, the distance between divisions was set at 3 inches to produce a very
smooth ruled surface.

Figure 24.26: Ruled surface between contour lines
8.

Use the o2c viewer to get a better picture of the ruled surface.

Figure 24.27: o2c view of the ruled surface
Creating a ruled surface between two polylines is similar creating it between two contour lines. Just begin
with two polylines instead of two contour lines. You can place a ruled surface over a closed polyline, too.
 To stretch a ruled surface between two closed concentric polylines:
1.

Create two closed concentric polylines. Make sure you draw the second closed polyline in the
same direction as the first. For example, if you draw the first closed polyline clockwise, you must
draw the second closed polyline clockwise, too. Otherwise, if you draw the first clockwise and
the second counterclockwise, the resulting ruled surface will be a jumbled mass of polygons.

2.

Click on Polygons in the 3D Entity menu. The Polygons menu appears.

3.

Click on Ruled Surf.

4.

Decide how you want the polygons to be drawn on the ruled surface. If you want the rules to be
evenly distributed between the two concentric closed polylines, activate Even. If you want the
rules to be weighted based on the relationship between the two closed polylines, deactivate Even.
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5.

Click on Div. Dist to set the distance between divisions. You can control the smoothness of the
ruled surface by the distance between divisions. For example, selecting a small distance between
divisions (such as 3 inches) produces a smoother ruled surface than a larger division distance
(such as 3 feet). The larger your division distance, the more jagged the resulting edges of your
ruled surface. Either select a value from the menu or type your own in the input field. Then press
(Enter).

6.

Click on the first polyline. The solid polyline becomes a lighter colored, dashed one. You are
prompted to Select second polyline to process.

7.

Click on the second polyline. DataCAD stretches the ruled surface between the two concentric
closed polylines. In this example, the distance between divisions was set at 8 inches to produce a
very smooth ruled surface.

Figure 24.28: Ruled surface between closed concentric polylines
8.

Use the o2c viewer to examine the ruled surface.

Figure 24.29: o2c view of the ruled surface
Once you have created a ruled surface between two contour lines, two polylines, or two concentric closed
polylines, you can use 3D Knife functions to cut out, uplift, or indent irregular shapes or areas. Just treat
the ruled surface as if it were a TIN model.

(PRO) 3D SECTIONING TOOL |

Figure 24.30: 3D Knife
Use the o2c viewer to get a better picture of the cut out, raised, and depressed areas on the ruled surface.

Figure 24.31: o2c view of 3D Knife

(Pro) 3D Sectioning Tool
You can use the sectioning tool to create 2D sections from 3D models. Draw a section line through your
model and indicate a direction of view. From there, you can generate a sectional line drawing from the
boundary. Several of the options available in the Sections Settings dialog box allow you to customize
hatching and shading.
 To create 2D sections from a 3D model:
1.

Select Section from 3D Menus. The Section menu appears.

2.

Click on Options. The Section Settings dialog box appears.
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Figure 24.32: Section Settings dialog box
3.

Make decisions based on the options available in the Section Settings dialog box. Press (Enter) or
click on OK when you are finished.

4.

Select Cut Line from the Section menu. You are prompted to Select first point on Section Cut Line.
Then, you are prompted to select the second point of the cut line. A dotted line appears on your
drawing. You are prompted to Select a point to define direction of view.
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Figure 24.33: The cut line is a series of dashes; the arrow indicates the view direction
5.

Click in your drawing to indicate the direction.

6.

Select Begin from the Section menu. The section is attached to your cursor in the shape of a box.
You are prompted to Select location for Section.

7.

Position the cursor where you want the section to appear in your drawing and click the left
mouse button. You can place the section on any existing layer or you can create a new one (just
select New Layer from the Section menu).
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Figure 24.34: The section
If you change your drawing, you can select Update from the Section menu so that the section will also be
current.
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Chapter 25 Editing 3D Entities
The 3D Menus menu looks similar to its 2D counterpart and, in
most cases, works the same way. In fact, the Erase, Layers, and
Identify options in 3D Menus are actually shortcuts to those
menus in the (2D) Edit menu. However, keep in mind that the
3D Menu options should only be used on 3D entities, unless
otherwise noted. See the “Rules for Editing 3D Entities” section
in this chapter for details.
Perhaps one of the most useful features of 3D entities is that you
can edit them in any plan or parallel view. The 3D Menus work
closely with the 3D Views menu; all 3D Menus submenus have
a 3D Views option, which takes you immediately to the 3D
Views menu. In addition, to help you move quickly from menu
to menu, 3D Menus also includes shortcuts to the Edit menu and
the 3D Entity menu.

In this chapter:

 Rules for editing 3D
entities

 Moving, copying,

rotating, stretching,
mirroring, and
enlarging 3D entities

 Exploding 3D entities
 Modifying 3D entity
attributes
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Rules for Editing 3D Entities
Keep in mind the following when editing 3D entities:


You can’t erase edges. The lines that make up a 3D entity represent the edges of a single entity; they
are not an entity themselves. If you try to erase one edge of a slab, for instance, the entire slab is
deleted.



Edit 2D entities with 2D editing options only. The Edit menu contains the 2D editing tools you’ll
need to edit 2D entities. However, the Erase, Change, and Explode options in the 3D Menus can also
be used on 2D entities.



Many 2D editing options can be used on 3D entities. For example, the Stretch option in 3D Menus
can be used on a horizontal slab. However, keep in mind that most 2D editing options work only in
plan view. When you select such an editing option, DataCAD automatically changes to plan view.



Edit in plan or parallel views only. If your model is not being displayed in plan or parallel view and
you select a 3D editing option, DataCAD automatically changes to the last plan or parallel view.



Select entities in any view. However, when using Entity or Group in 3D selection menus, you can
select entities according to the following rules:
3D line
Polygon
Slab
Block
3D arc
Cylinder
Cone
Truncated cone
Sphere
Torus
Contour
Mesh surface
Surface of Rev.
Symbol

Anywhere on the line
Any displayed edge (including the edges of voids)
Any displayed edge (including the edges of voids)
Any displayed edge
The arc’s center marker
Any of the three center axis markers
Any of the three center axis markers
Any of the three center axis markers
The center marker
The center marker of the sweep or the center markers at the beginning and end of the roll
Any control point (you can’t select the curve itself)
Any displayed edge of the control grid or any of the displayed control points (you can’t select
the surface itself)
Any control point
The insertion point

With Fast 3D Snap toggled off (3D Menus/Settings menu), you can select any circular division of a 3D arc,
cone, truncated cone, sphere, or torus; you can also select any edge of a single-curved facet of a surface of
revolution, but not an edge of a double-curved facet. With both Fast 3D Snap and Fast 3D (Utility/Object
Snap menu) toggled off, you can select any displayed edge of a symbol, according to the rules for each
entity in that symbol.

Moving 3D Entities
Use Move in 3D Menus to shift an entity to a different position on the screen. 3D Move works the same as
the 2D Move option, with the exception of the following:


When specifying the two points of the distance to move, the model can be in any parallel or
orthographic view. DataCAD draws specific distances across the screen, but the distance and
direction is taken with respect to the model in the current view. For example, if you view the model
in an elevation view and specify a distance and angle to move (such as 10’ at 90), objects that you
select move up, off the ground plane.



The model displays in any view during the process of selecting entities to move. This makes the
precise selection of individual entities or collections of entities easier, especially in cases where
entities are stacked one upon another or when it is difficult to separate one entity from another.
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Elevation on
screen

Parallel view
on screen

2
Distance
to move

1

Side windows will
move up as well
when selected

Figure 25.1: Using the 3D Move option
Choose 3D Cursor from the Move menu to toggle on the world snapping cursor. The world cursor lets
you snap directly to the objects in the model rather than to their projections on the screen. See “All About
3D Snapping” in the “Modeling Basics” chapter for more information on the world snapping cursor.
 To move an entity:
1.

Choose Move from 3D Menus.

2.

Toggle And Copy on to copy the entity at the same time you move it. If you toggle And Copy off,
the entities move to the new location but do not copy.

3.

Select the first point of the distance to move.

4.

Select the second point of the distance to move.

5.

Choose Z Distance to move the entity in the Z-direction relative to the plane on the screen.
Positive distances indicate movement out of the screen; negative distances indicate movement
into the screen. You can also use Z-Only to set the move distance to zero (0) in the X and Y
directions. Then select the entities to move. Entities move relative to the screen Z-axis. DataCAD
resets the Z-distance to zero each time you choose Move from 3D Menus.

6.

Choose a selection method and select the objects to move. Use the 3D Views menu to reorient
your view to get the best vantage point for selecting objects. DataCAD moves the selected entities
relative to the plane of the screen.

7.

Choose Invert if you make a mistake and select the wrong entity to move; then, reselect the
moved entity. The entity returns to its original position.

You can also use Prev. Dist. to use the last distance and direction specified in an editing option. You can
choose this option instead of specifying two points of the distance to move. Or use New Distance to enter
a new move distance. This does not change the Z distance. New Distance only appears after you’ve
entered a move distance.
 To move an entity to another layer in your drawing file:
1.

Choose To Layer from the Move menu.

2.

Choose a layer from the list or use Match or Filter to indicate the layer to move to. See the
instructions below to use Match and Filter.

3.

Choose a selection method and select the entity or entities to move.

Use Match to select a layer by selecting an entity on that layer. Set the active layer, move objects to
another layer, or point DataCAD to a specific layer, all without having to remember layer names.
 To move entities to another layer using Match:
1.

Select To Layer from the Move menu. You are prompted to Select layer to move to.
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2.

Choose Match from the To Layer menu. You are prompted to Select entity to match. Use Match
with any of the following Layers options: On/Off; Set Active; Active Only; Lock; Name; Clear
Layer; Delete Layer; Export Layer; View Layer, Select. It is also available when using To Layer
under Move and Copy or when using Layer Search.

3.

Select an entity to select the layer it is on. You are prompted to Select entity to move.

4.

Select the entity you want to move to the selected layer. The entity is moved to the selected layer.

Use the Filter toggle to scan or filter for layers with similar names. When you specify a prefix or suffix
that the filter searches for, a list of layers with that affix appears. To access a layer that you don’t know
the name of, use Filter to search for layers with a similar affix.
For example, if you specify layers by plumbing and electrical, you might have layers named
1FLPLUMB.LYR, 2FLPLUMB.LYR, 3FLPLUMB.LYR, and 1FLELECT.LYR, 2FLELECT.LYR, and
3FLELECT.LYR. To search for a plumbing layer, use ???plumb. You can search for first floor layers using
a prefix of 1fl: 1fl* or 1fl?????.
Use the asterisk (*) in place of any number of characters and the question mark (?) in place of each
character you’re unsure of.
The Filter toggle only appears when you are prompted to select from the list of layers. The filter
disregards any characters following an asterisk. Therefore, if you entered *plumb to search for plumbing
layers, all layer names would be displayed.
 To filter layers:
1.

Choose Filter from the To Layer menu to toggle Filter on.

2.

Type the affix, including the wildcard character(s), for the layer you want to find and press
(Enter). A list of layer files with this affix appears.
DataCAD also allows you to scroll through different layer groups with similar affixes. If the
group you initially searched for doesn’t contain the layer you wanted, you can scroll through the
remaining groups to find the appropriate layer.
Filter Back
Filter Frwd

3.

Scrolls back to a group of similarly named layers.
Scrolls forward to a group of similarly named layers.

Choose the layers you want to use.

DataCAD remembers the last affix for which you filtered. The prefix name appears in the Message
Window and the layer names appear in the Menu Window when you re-enter the Filter function.

Copying 3D Entities
The 3D Copy option works identically to the 2D Copy option: specify the distance to copy from any
parallel or orthographic view, and then select the objects to copy in any view.
 To copy 3D entities:
1.

Choose Copy from 3D Menus.

2.

Enter the first point of the distance to copy.

3.

Enter the second point of the distance to copy.

4.

Select the objects to copy using the Selection Menu. You can use the 3D Viewer to reorient your
view and get the best vantage point for selecting the objects. DataCAD copies the selected entities
relative to the plane of the screen.
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Rectangular Arrays
Use Rect. Array to create three-dimensional rectangular arrays of 3D entities at any orientation in space.
This option works like the 2D rectangular array option, except that you can copy objects in the X, Y, and Z
directions simultaneously, each with its own spacing and number of repetitions.
 To create a rectangular array:
1.

Choose Copy from 3D Menus.

2.

Choose Rect. Array from the Copy menu.

3.

Set the Z distance to copy if you are creating an array of more than one element in the Z
direction.

4.

Select the first point of the distance to copy each element of the array.

5.

Select the second point of the distance to copy each element of the array.

6.

Type the number of repetitions in the array in the X direction, Y direction, and Z direction,
pressing (Enter) after each value entered.

7.

Choose a selection method and select the objects to copy in the rectangular array. You can use the
3D Views menu to reorient your view to get the best vantage point in selecting objects.

Figure 25.2: Original object to copy

3 copies in X
5 copies in Y
2 copies in Z

Figure 25.3: Resulting array
Choose 3D Cursor to toggle on the world snapping cursor. The world cursor lets you snap directly to the
objects in the model rather than to their projections on the screen. See “All About 3D Snapping” in the
“Modeling Basics” chapter for more information.

Rotating 3D Entities
Like all 3D editing options, you can use the Rotate option in any parallel or orthographic view. Choose
the center of rotation, and then select the objects to rotate. You can rotate the objects in any order.
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 To rotate a 3D entity:
1.

Choose Rotate from 3D Menus.

2.

Choose And Copy to copy the entities at the same time you rotate them. To rotate entities without
copying them, leave And Copy toggled off.

3.

Select a point that defines the center of rotation relative to the plane of the screen. If you want the
Z-coordinate of the center of rotation to be something other than zero, use Center Z to enter the
Z-coordinate. See the instructions below to set the Z-coordinate. You can use New Center to reenter the center of rotation relative to the current plane of the screen. This option does not change
the Z-coordinate of the center of rotation. New Center only appears after you choose a center of
rotation.

4.

Choose which of the three axes (X, Y, or Z) you wish to rotate around, relative to the screen. Use
X-Axis to rotate selected entities about an axis parallel to the X axis of the screen and passing
through the center of rotation. Use Y-Axis to rotate selected entities about an axis parallel to the Y
axis of the screen and passing through the center of rotation. Use Z-Axis to rotate selected entities
about an axis parallel to the Z axis of the screen and passing through the center of rotation.

5.

Choose X Angle, Y Angle, or Z Angle to set the angle at which entities rotate around the X, Y, and
Z axis, respectively, relative to the plane of the screen at the time the center of rotation is
specified. The option you choose should match the axis that you selected in step 3. Use X Angle,
Y Angle, and Z Angle from the Rotate menu, then choose or type a value, and press (Enter).

6.

Choose a selection method and select the objects that you want to rotate. You can use the 3D
Viewer to reorient your view to find the best vantage point in selecting objects.

7.

Select Invert if you make a mistake and select the wrong entity to rotate. Then, reselect the entity.
The entity returns to its original position.

 To set the Z-coordinate of the center of rotation relative to the plane of the screen:
1.

Choose Center Z from the menu. A list of values appears.

2.

Choose or type a value and press (Enter). DataCAD resets Center Z to zero each time you choose
Rotate from 3D Menus.

Mirroring 3D Entities
Use Mirror to mirror entities about a plane in space. You can view a model from any angle in space; the
mirror plane is always perpendicular to the screen.
You define the mirroring plane the same way as with the 2D Mirror option.
 To mirror a 3D entity:
1.

Choose Mirror from 3D Menus.

2.

Create the mirror line by responding to the prompts to Select first point of line about which to mirror
and then Select second point of line about which to mirror. The mirror line appears.

3.

Choose And Copy to copy entities at the same time you mirror them. To mirror entities without
copying them, leave And Copy toggled off. You can use New Line to re-enter the mirroring plane
perpendicular to the current plane of the screen. New Line only appears after you create a mirror
line.

4.

Choose a selection method and select the objects that you want to mirror. You can use the 3D
Viewer to reorient your view to find the best vantage point for selecting objects.
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Stretching 3D Entities
3D Stretch lets you stretch three-dimensional entities similarly to 2D Stretch. As with other 3D Entity
menu options, you can specify the distance, direction, and entities to stretch from any parallel or
orthographic (plan) view.


Explode curved 3D entities into polygons or lines before stretching them. See “Exploding Entities”
later in this chapter for instructions.



Cylinders, 3D arcs, spheres, cones, truncated cones, and tori are non-stretchable entities. Use Enlarge
to increase or decrease their size in one direction by an appropriate factor; alternatively, explode
them into polygons and then stretch the polygons.



3D Stretch can only be used on 3D lines, polygons (and their voids, if any), blocks, slabs (and their
voids, if any), contour curves, and mesh surfaces. You can use Stretch to edit polygons, slabs, and
voids. You must define the distance to stretch in a plane parallel to the polygon or slab you want to
stretch; otherwise, the resulting polygon or slab may become nonplanar. To make sure that the plane
of the screen is parallel to the slab, you can use Plane Snap, Elevation/ New Elev., or Edit Plane from
the 3D Views menu.



If the entity you select is contained completely within the limits of the selecting point, area, or fence,
DataCAD moves the entity the distance you indicated to stretch.

 To stretch a 3D entity:
1.

Choose Stretch from 3D Menus. See the “Viewing Your Model” chapter for more information.

2.

Select the first point of the distance to stretch.

3.

Select the second point of the distance to stretch.

4.

Choose Z Distance to enter a distance to stretch portions of entities in the Z direction relative to
the plane of the screen. Positive distances indicate movement out of the screen; negative distances
indicate movement into the screen. You can use New Distance to re-enter the distance to stretch
in the X and Y directions. New Distance does not change the distance to stretch in the Z direction.

5.

Use Prev. Dist. if you want to deal with the last X and Y distance and direction you specified in
an editing option to stretch. You can use this option instead of specifying the distance to stretch in
steps 2 and 3.

6.

Choose a selection method and select the objects that you want to stretch. You can use the 3D
Viewer to reorient your view to get the best vantage point for selecting objects.

7.

Choose Invert if you make a mistake and select the wrong entity to stretch. Then, reselect the
stretched entity. The entity returns to its original size. DataCAD resets the Z distance to zero each
time you choose Stretch from 3D Menus. Choose Z-Only to set the stretch distance in the X and Y
directions to zero. Then select the entities to stretch.

Enlarging 3D Entities
Use Enlarge to enlarge or scale entities to different sizes in the X, Y, and Z directions. Enlarge works
similarly to its 2D counterpart, except that you can set the center of enlargement in any orthographic
(plan) or parallel view. You can also select entities you want to enlarge in any view or orientation once
you enter the center of enlargement.
 To enlarge a 3D entity:
1.

Choose Enlarge from 3D Menus.
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2.

Choose And Copy to copy entities at the same time you enlarge them. To enlarge entities without
copying them, leave And Copy toggled off. After you choose a center of rotation, you can use
New Center to re-enter the center of enlargement. This option does not change the Z coordinate
of the center of enlargement. To set the Z coordinate relative to the plane of the screen, choose
Center Z from the menu, then choose or type a value, and press (Enter).

3.

Select a point that defines the center of enlargement relative to the plane of the screen.

4.

Use X Enlargmnt., Y Enlargmnt., and Z Enlargmnt. to change the current value of the
enlargement factor in the X, Y, and Z directions of the screen, respectively. The enlargement
factor cannot be zero. Choose X Enlargmnt. from the menu, then choose or type a value, and
press (Enter). Use Reset to set all of the enlargement factors to 1.0. The 2.0x option sets all of the
enlargement factors to 2.0. The 0.5x option sets all of the enlargement factors to 0.5.

5.

Choose a selection method and select the objects that you want to enlarge. You can use the 3D
Viewer to reorient your view to get the best vantage point for selecting objects.

6.

Choose Invert if you make a mistake and select the wrong entity to enlarge. Then, reselect the
entity. The entity returns to its original size. DataCAD resets the Center Z to zero each time you
choose Enlarge from 3D Menus.

Exploding 3D Entities
Use Explode to separate 3D entities into their polygonal facets or into three-dimensional lines. After you
explode an entity into lines or polygons, it is not possible to reverse the operation and recreate the
original entity from these lines and polygons.
Explode can create a large amount of data in the drawing file. For example, take a single sphere with 20
divisions in the sweep direction (primary divisions) and 10 divisions in the rise direction (secondary
divisions). After an explode operation, this single sphere produces some 200 polygons, each of which
occupies approximately as much drawing storage space as did the original sphere. A mesh surface with
20 divisions in each direction would produce 800 polygons, which would collectively require 364 times as
much drawing storage space as the original mesh surface.


Explode separates curved entities (cylinders, cones, truncated cones, tori, spheres, mesh surfaces, and
surfaces of revolution) into lines or polygons for subsequent editing operations (like stretch).



You can explode a text entity into 3D lines that you can then rotate in space. The lines then respond to
a hidden line removal.



Explode determines the validity of exploding entities. For example, if you select a contour curve to
explode into polygons, DataCAD ignores the selection and does not explode the curve because it has
no polygonal components.

 To explode a 3D entity:
1.

Choose Explode from 3D Menus.

2.

Toggle To Lines on to explode entities into 3D lines; alternatively, toggle To Polygons on to
explode entities into polygons.

3.

Choose a selection method and select the objects that you want to explode. You can use the 3D
Views menu to reorient your view to get the best vantage point in selecting objects.

Changing 3D Entities
3D Change lets you change the divisions of circular entities and the stiffness of contours as well as colors,
line types, line overshoots, and more.
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 To change an attribute of a 3D entity:
1.

Choose Change from 3D Menus.

2.

Choose the option you want to change.

3.

Choose or enter a new value; follow the prompts in the Message Window.

4.

Choose Closed to indicate whether 3D arcs, cylinders, cones, and truncated cones are treated as
closed solids or as open surfaces, then choose one of the following:
Yes
No

5.

3D entities will be treated as closed shapes
3D entities will be treated as open shapes

Choose a selection method and select the objects that you want to change. You can use the 3D
Views menu to reorient your view to get the best vantage point for selecting objects.

Use Prim. Divs. to change the number of segment divisions of circular entities. Prim. Divs. affects 3D arcs,
cylinders, cones, truncated cones, spheres, tori, surfaces of revolution, contour curves, and mesh surfaces.
For spheres, surfaces of revolution, and tori, Prim. Divs. affects only the number of segment divisions in
the sweep direction (in the plane of the screen). For mesh surfaces, it affects only the number of segment
divisions in the first direction. For contour curves, it affects the number of segment divisions between
each control point of the curve.
Use Sec. Divs. to change the number of segment divisions of certain circular entities. This toggle affects
only spheres, tori, surfaces of revolution, and mesh surfaces. For spheres and surfaces of revolution, it
affects the number of segment divisions in the rise direction. For tori, it affects the number of segment
divisions in the roll direction. For mesh surfaces, it affects the number of segment divisions in the second
direction.
Use Stiffness to change the stiffness factor associated with contour curves. Stiffness affects only contour
curves. The stiffness can be any number except zero.
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In this chapter:

DataCAD gives you several ways to view your model to help
you draw and create views for plotting or presentations. While
there are many different kinds of views, only plan, parallel,
perspective, and oblique are commonly used for architectural
models, and DataCAD lets you customize each of these types of
views. You must use a parallel or plan view for editing your
drawing, while perspectives and obliques are most often used
for visualization, rendering, and presentations.

 Creating and

Once you have a view defined, you can perform a hidden line
removal of it or shade it. You can save any hidden-line, shaded,
or standard 3D view and then link any entity in your model to
that view to easily display it. You can even create walk-throughs
of your model.

throughs

The o2c-based object viewer provides real-time, dynamic,
shaded 3D views of DataCAD models. You can adjust many of
the o2c settings and save them as high-quality rendered images.

changing views

 Shading your model
 Performing hidden

line removals on your
model

 Saving and linking to
views

 Creating walk Using the o2c-based
object viewer
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Ortho (Plan View)

Parallel (Isometric View)

Plan Oblique (Axonometric View)

Front (Parallel View)

Left (Parallel View)

Back (Parallel View)

Right (Parallel View)

Parallel (Isometric View)

Elevation Oblique

Perspective (One point)

Perspective (Three point)
Perspective (Two point)
Figure 26.1: Examples of views you can create in DataCAD
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Creating Parallel Views
Parallel in the View pull-down menu restores the last parallel view you generated and displays the globe.
Elevations and isometrics are parallel views but by no means the only ones. Because these two cases are
used so frequently, they have their own menu selections. It may help, however, to remember that these
are just different kinds of parallel views. You can, in fact, choose any eye point to create a parallel view.
See “More About Changing the Eye Point for a View” later in this chapter for more information on the
globe display and how it affects parallel views.
Elevations and isometric views can be quickly created in DataCAD in just a few steps. Isometric views
can be created by simply choosing Isometric from the View pull-down menu or by choosing Isometric
from the 3D Views menu. You can use the Viewer Toolbar to work with any parallel view. Choose Viewer
Toolbar from the View pull-down menu. This toolbar will automatically change when you change your
view to any parallel view or to orthographic (plan) view.
More About Rotation Angles in 3D Views
In 2D, positive rotation angles go counterclockwise; in 3D, the concept is a bit more complex. This
rotation angle of -90 flips the model to the left. DataCAD uses the right-hand rule to indicate the
direction in which positive angles run. To understand the right-hand rule, point the thumb of your right
hand in the direction of the axis in question. Your fingers curl in the direction of positive rotation. The Yaxis goes up, so when you point your thumb up, your fingers curl toward you a counterclockwise
direction. Negative angles run in a clockwise direction.

90°

POSITIVE AXIS OF ROTATION

Figure 26.2: Right-hand rule
More About Changing the View Center
When you create the first parallel view in a drawing, DataCAD calculates the view center by examining
the extents of the model. DataCAD generates all parallel views with the assumption that the model is
situated over a point called the view center or the point in space at which the observer is looking.
DataCAD places the view center in the middle of the extents, halfway between Z-base and Z-height.
Ideally, this is somewhere near the center of the model.
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The view center is not attached to the model in any way, so if the model moves, the view center does not
change. Be careful when you use Globe. Sometimes, models spin off the screen completely because the
globe is always situated directly over view center. Reposition the view center to somewhere inside the
model to avoid this problem.
The view center in a perspective view is always the point of intersection between the picture plane and
the line of sight.
 To reposition the view center:
1.

Choose Reset from the 3D Views/Controls menu. Reset places the drawing in the last
orthographic view you generated. This helps you find a center of the model.

2.

Choose View Center; an Auto option becomes available.

3.

Select a new center point in one of the following ways:


Select a point in the center of the model



Choose Auto to calculate a view center with the center point halfway between Z-base and Zheight

The new view center is set and you return to the Controls menu.
In the 3D Views menu, both the Elevation/New Elev. and Edit Plane options change the view center
implicitly. In both of these options, you select a point on the plane where Z=0. This point becomes the
new view center for parallel views. This point also becomes the new grid origin for grid snapping. See
“Creating Perspective Views” later in this chapter for more information on the view center in a
perspective view.
More About Changing the Eye Point for a View
The view sphere (known as the “globe” in versions 10 and prior) display is used to reorient your eye
point in a parallel or perspective view; it is automatically displayed on screen whenever you choose a
parallel or perspective view. Selecting a point inside the view sphere display indicates the new observer
position for viewing the model.
In perspective views, the view sphere changes the elevation of the observer’s eye point and the direction
from which you observe the model (north, south, east, or west), but it does not change the view center,
the distance to the object, or the cone of vision.
In a parallel view, the view sphere sets the observer’s eye point above or below the ground plane at
which the observer stands. The center of the view sphere represents a point directly over view center and
all points on the outer circle represent a point in space directly below the view center looking up.

Figure 26.3: View sphere perspective
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To visualize how the view sphere operates, imagine that the model sits inside a large sphere. Half of the
sphere is above the ground plane and half of it is below, with the ground plane cutting the sphere at the
equator. The equator of this sphere is represented as the inner circle. Therefore, all points inside this circle
are the upper half of the sphere (above ground) and all points outside the inner circle are the lower half of
the sphere (below ground).
While the view sphere display is in the upper-left corner of the screen by default, you can use the View
Sphere option in the 3D Views menu to reposition it on the screen. You can:


Move the view sphere to a different location on the screen so that you can continue to work on a part
of the model without interference



Change the size of the view sphere; a larger view sphere gives you finer control over the rotation of a
parallel or perspective view

 To move the view sphere display:
1.

Choose View Sphere from the 3D Views menu. The View Sphere menu appears:
Default

Returns the view sphere to its customary position in the upper-left corner of the Drawing
Window

2.

Select a new center for the view sphere. Move your mouse to dynamically size the View Sphere
display.

3.

Select a point on the perimeter of the new view sphere. The view sphere moves to the selected
position.

Use 3D Views/Controls to specify a vantage point for a parallel view. You can think of the Controls menu
as a more accurate version of View Sphere and just another way of generating parallel views. You can use
the Controls menu to position the view center inside the model for smoother operation of the view
sphere.
When you choose Controls from the 3D Views menu, the Controls menu appears in the Menu Window.
In addition, the control buttons appear on the Viewer toolbar if that is currently displayed. (To display
the Viewer toolbar, select Toolbars from the View pull-down menu and make sure there is a checkmark
for Viewer in the Toolbars dialog box.)
The cursor you see while you are in the Controls menu displays the current orientation of the X, Y, and Z
world coordinate axes.
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The model exists in
screen coordinates

World
Coordinates

The model is viewed
and edited in the
screen coordinate
system

The model is projected
onto the screen

Screen
Coordinates

Figure 26.4: Screen coordinates vs. world coordinates
The Screen option rotates the view around the screen coordinate axes. Screen coordinates refer to the
right-handed coordinate system that you worked with in 2D. The +X axis goes to the right, the +Y axis
goes up, and the +Z axis comes out of the screen. This does not change.
The World option rotates the view around the world coordinate axes. World coordinates refer to the
right-handed coordinate system associated with the model. Imagine that your model is in orthographic
view and you attach the screen coordinate axes to the model itself. What you have is a set of three axes
known as world coordinate axes. These do not change with respect to the model, but they do change with
respect to the screen.
When you choose any of the Rotate options, DataCAD rotates the view by a set number of degrees
around the axis you indicate.
Reset changes the current view to the last orthographic view taken. Reset also brings the model back into
view in case it moves off the screen. Use this option before using View Center.
Rot. Angle controls the number of degrees that the object rotates under any Rotate+ or Rotate- options.
Four additional input modes are available in the Controls menu: relative and absolute cylindrical
(distance, angle, Z coordinate) and relative and absolute spherical (distance, plan angle, rise angle). These
modes provide additional variables to the Z component of coordinate entry, which may be helpful in
specialized modeling applications like entering a 3D line that represents a solar angle.
Hint: You can access these modes by pressing the (Insert) key.
 To set the rotation angle:
1.

Choose Rot. Angle from the Controls menu. A list of rotation angles appears.

2.

Choose or type a value and press (Enter).

Add View adds the current parallel view to the list of saved views.

Creating an Isometric View
Isometric creates a true isometric view. Isometric views are a special parallel view where the X- and Yaxes of the model form a 30 angle from the horizontal. To make sure that the angle is precise, choose
Isometric from the 3D Views menu or choose Isometric from the View pull-down menu.
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Creating Elevations
Elevations are a special kind of parallel view. When you view an elevation in plan, the front of the model
faces the bottom of the screen.
Use Front Elev. to view the front elevation of the model. Use Back Elev. to view the back elevation of the
model. Use Right Elev. to view the right elevation of the model. Use Left Elev. to view the left elevation of
the model.
In addition to the four preset elevations (Front Elev., Back Elev., Left Elev., and Right Elev.), you can
create non-orthogonal elevations. You can use New Elev. to generate views for rendering or to orient the
model for a side view in which you can precisely place the zero plane, Z-base, and Z-height. If you choose
a Front Elev., you cannot guarantee where Z-base and Z-height are in relation to the new view.
 To create a new elevation:
1.

Choose New Elev. from the 3D Views/Elevation menu or choose Elevation/New from the View
pull-down menu. The view changes into plan view so that you can specify the elevation line.
Center Z appears in the Elevation menu.

2.

Choose Center Z to set the height of the view center. You must choose this option before you
select the first point in the new elevation indicator. A list of values appears.

3.

Choose or type a value and press (Enter).

4.

Select a point to lie on the new zero plane (such as the corner of a wall). This point also serves as
the new view center and grid origin.
Move the cursor and it changes into a New Elevation Indicator. There are several parts to this
cursor:
Z-base indicator
Z-height indicator
Zero plane (the plane at which Z = 0)
Direction of view

The Z-base and Z-height indicators may not be visible if their values appear off the screen or if
their values are set to zero, in which case these indicators coincide with the zero plane.
New view center
and grid origin

The Zeroplane (Z=0)

Z-Height
Z-Base

Out of the screen

Figure 26.5: The new elevation indicator

Into the screen
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5.

Adjust Z-base and Z-height if necessary. The indicators change position to show you the new
location of Z-base and Z-height. Remember that negative distances go in the direction of the view
(into the screen).

6.

Select a point in the direction of the view. The specified view appears on the screen.

Options for creating front, back, left, right, and new elevations are available from both the View/Elevation
pull-down menu and the 3D Views/Elevation menu in the Menu Window.
 To add the current elevation to the list of saved views:
1.

Choose Add View from the Elevation menu.

2.

Type the name of the new view (up to eight characters) and press (Enter). The view is added to
the list of saved views.

More About the New Elevation Indicator Cursor
This cursor has an arrow indicating the direction of the new zero plane position and a tail representing
the current Z-base and Z-height settings. (The end of the tail nearest the crosshair is Z-base and the end
furthest from the crosshair is Z-height.) If Z-base is set to 0, the tail meets the crosshair; if Z-height is set
to 0, the end of the tail won’t be displayed.

Figure 26.6: The New Elevation Indicator cursor with Z-base=0 and Z-height=8

Creating Perspective Views
DataCAD can generate one-, two-, and three-point perspectives. The differences between these
perspective types lie only in the location of the eye of the observer (Eye Point Z) and the point in the
model at which the observer is focusing (Focal Pnt. Z).
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You can use the Viewer Toolbar to work with your perspective view. Choose Viewer Toolbar from the
View pull-down menu. This toolbar will automatically change when you change your view to any
parallel view or to orthographic (plan) view.
For each perspective type, you must select an eye point for the observer and a focal point to mark the
point in the model where the observer is looking. When you select the first point, the cone of vision
appears. See “More About Changing the Eye Point for a View” earlier in this chapter for more
information on the view sphere.

Cone of Vision
Line of Sight

Picture Plane

Eye Point

View Center

Figure 26.7: Cone of vision for perspective view
The line that cuts across the cone of vision is the picture plane. Things in front of this plane (on the same
side as you, the observer) appear larger than normal; things behind the picture plane appear smaller.
The line that leads directly from the eye point to the view center is the line of sight. As with parallel
views, always place the view center somewhere inside the model so that the view sphere is stable and
predictable.

Establishing Perspective Settings
 To set the elevation of the observer’s eye point:
1.

Choose Eye Point Z from the Set Persp. menu. A list of perspective eye point values appears.

2.

Choose or type a value and press (Enter).

 To set the elevation of the center of the view:
1.

Choose Focal Pnt. Z from the Set Persp. menu. A list of values appears.

2.

Choose or type a value and press (Enter).

The Reset option in the Set Persp. menu returns you to a perspective view using the current settings in
this menu.
Use Hither Clip to reduce the fisheye distortion that can appear in close-up perspectives. You can also
increase the hither clip distance to partially cut your model shown in perspective view and then create a
shaded “sectional perspective” with the Quick Shader menu. The hither clip plane appears as a crosshair
on the cone of vision.
 To use Hither Clip:
1.

Choose Hither Clip from the Set Persp. menu. A list of values appears.

2.

Choose or type a value and press (Enter).
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Line of Sight

Picture Plane
View Center

Hither-clip distance

60°

Cone of Vision
Eye Point

Figure 26.8: Cone of vision with hither clip
Toggle Fixed Cone on in the Set Persp. menu to fix the width of the cone of vision. The width of the field
of vision in a fixed cone is set using either Cone Angle or Camera.
 To set the width of the field of vision to an angle using Cone Angle:
1.

Choose Cone Angle from the Set Persp. menu. A list of values appears.

2.

Choose or type a value between 1 and 179 degrees and press (Enter).

 To set the width of the field of vision using Camera:
1.

Choose Camera from the Set Persp. menu. A list of values appears.

2.

Choose or type a value and press (Enter). Camera sets the width of the field of vision by
expressing it as the length of a camera lens. The longer the lens, the narrower the cone of vision.

Creating a One-Point Perspective
Create one-point perspectives by choosing an eye point at the same elevation as the view center; the
observer is looking straight ahead, neither up nor down. A one-point perspective must have the picture
plane parallel to one of the frontal faces of the model.
 To create a one-point perspective:
1.

Choose Set Persp. from the 3D Views menu. When you choose Perspective from the 3D Views
menu for the first time in a drawing, the Set Persp. menu is automatically displayed so you can
set up the perspective view.

2.

Set Eye Point Z to a reasonable value. When an observer is standing on the ground, 5’ is a typical
height for the observer’s eye.

3.

Set Focal Pnt. Z to the same elevation you used in step 1.

4.

Select a point for the eye point.

5.

Select a point inside the model for the center point. Use ortho mode to make sure that the line of
sight is perpendicular to one of the faces of the model.

CREATING PERSPECTIVE VIEWS |

EyePntZ

Line of Sight at 90
degrees to the front
plane of the model
CentPntZ

Figure 26.9: One-point perspective

Creating a Two-Point Perspective
Use two-point perspectives to relax one of the two constraints that you placed on one-point perspectives.
You can either:


Set the eye point and center point at different elevations and keep the line of sight perpendicular to
one of the frontal faces of the model; or



Keep the eye point and center point Z the same and set the line of sight at an angle other than 90.

Figure 26.10: Two-point perspective

Creating a Three-Point Perspective
Three-point perspectives are generated when the eye point Z elevation is different from the center point Z
elevation and the line of sight is at an angle other than 90. With these constraints, set the eye point Z and
the center point Z appropriately and choose these points in your model.

Line of Sight not
perpendicular to
the front planes
of the model

EyePntZ = CentPntZ

Figure 26.11: Three-point perspective

511

512 | VIEWING YOUR MODEL

Perspective Navigation Controls
Hotkeys and Mouse Wheel controls automate perspective setup and navigation by using video gamestyle controls. For more detailed information about the navigation aids, see “Walking Through Your
Model” later in this chapter.

Creating Oblique Views
DataCAD can create both plan obliques (architectural axonometrics) and elevation obliques. Choose
Oblique from the 3D Views menu, then select Plan Oblique to create a plan oblique or Elev Oblique to
create an elevation oblique. If this is the first time you’ve chosen Elev Oblique, follow the directions for
selecting the New Elev. option in the Set Oblique menu. See “Creating Elevations” earlier in this chapter
for more information on the New Elev. option.

Establishing Oblique Settings
The Set Oblique option in the 3D Views menu (which is only available after you select Elev Oblique)
defines which elevation of the model you want to use as your frontal elevation in constructing the oblique
view. It works exactly the same way as the New Elev. option in the 3D Views/Elevation menu.
Obliq.Angle controls the angle of rotation before the plan oblique is taken. Angles are usually between
30 and 45. For elevation obliques, this setting controls the angle at which the lines sweep away from the
elevation.

Creating an Elevation Oblique View
 To create an elevation oblique view:
1.

Select Set Oblique from the 3D Views menu.

2.

Choose Elev Oblique from the Oblique menu.

Oblq Ang
45 degrees

Oblq Ang
30 degrees

Figure 26.12: Elevation oblique

Creating a Plan Oblique View
 To create a plan oblique view:
1.

Select Set Oblique from the 3D Views menu.

2.

Choose Plan Oblique from the Oblique menu.
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Oblq Ang
30 degrees

Oblq Ang
45 degrees

Figure 26.13: Plan oblique

Creating a Hidden Line Removal
Use 3D Menus/Hide to perform hidden line removals in DataCAD. DataCAD’s hidden line removal
system is a two-pass system with an additional initialization step. The initialization step performs a few
simple and quick operations: allocating memory, calculating the limits of your model for a specified view,
and initializing the temporary hidden line removal database.
The hidden line removal process does not recognize text and associative dimensions; therefore, they do
not appear after a Hide. To display these entities after a Hide, convert them into 3D lines with the 3D
Edit, Explode command.
Pass one (the calculating pass of the hidden line removal system) scans through the entire model and
temporarily separates it into a series of polygonal faces or free lines, as follows:


DataCAD breaks entities like 2D lines (having height), polygons, slabs, blocks, cylinders, etc., into a
series of polygons that the hidden line removal system can understand and interpret.



DataCAD breaks entities like 3D lines, contour curves, 3D arcs, etc., into a series of free line segments.
Free line segments are assumed to be infinitely thin.



DataCAD also recognizes voids in polygons.

Pass two of the hidden line removal process is where most of the work takes place; consequently, it
usually takes longer. Each line segment that is potentially a visible edge or a free line is compared with
each polygonal face. DataCAD uses the tests to determine if the line segment lies completely in front of,
completely behind, straddles, or pierces a given polygon.
Depending on the results of these tests, the line is either eliminated from consideration, split into one or
more pieces, or left intact to be tested later against the remaining polygons. If, after having been
compared against all of the possible polygons, some portion of the line segment remains, DataCAD
displays the segment and optionally adds it to a temporary database for the saved image.
DataCAD uses a number of optimization techniques for reducing the computing time of the display pass
to a minimum.
 To perform a hidden line removal:
1.

Choose Hide from 3D Menus or choose Hidden Line Removal from the View pull-down menu.
Set the following options as necessary:
Begin

Starts the hidden line removal process and displays operation’s progress in the Message
Window; press (Delete) or (End) to cancel the hide at any time
Save Image Save the image produced by a hidden line removal
Crop Image Performs a hidden line removal only on the portion of the model that is visible on the screen
HLR Partial Divides the Drawing Window into smaller sub-areas for faster hides
Pierce
Performs piercing calculations during hide, causing slower hidden line removals; to speed up
a hide, toggle Pierce off whenever piercing calculations are not necessary
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Pierce Off

Pierce On

Clip Cube

Hides the portion of the model that is contained within the previously defined Clip Cube;
available only for parallel views of your model; to create a similar clipping effect for
perspective hidden line images, use Hither Clip in the 3D Views/Set Persp. menu
All
Performs hidden line removals on entities on all layers toggled on
Active Layer Performs a hidden line removal only on the entities on the active layer
Sel. Set
Performs a hidden line removal only on the entities in the active selection set
Options
Settings to perform different functions within a hidden line removal
3D Views
Sets the view for the model prior to the hidden line removal; since the image created by the
hidden line removal process contains only 2D lines, the image is best viewed in an
orthographic view

2.

Choose 3D Views from the Hide menu and orient the model so that you can see the image.

3.

Choose Exit to return to the Hide menu.

4.

Choose Begin to start the hidden line removal process.

Tips on Maximizing Performance


Use lines rather than polygons whenever possible. For example, if you want to draw some rectangles
on the faces of a slab block to schematically represent windows, use 3D lines instead of polygons to
outline the windows to increase performance. Since the rectangles are simply inscribed on the face of
the slab, polygons are not needed; there is nothing to hide.



Use three-dimensional entities like blocks, cylinders, and slabs instead of collections of 2D lines and
simple polygons.



Keep models as simple as possible. As the size of the model increases, the time required to compute a
given image increases at a faster rate. You may consider placing some of the detail for a given model
on separate layers so that you can temporarily toggle some layers off for preliminary runs of the
hidden line removal system. After you complete the modeling process, you can then toggle on all
applicable layers and perform this more complicated hidden line removal analysis on the complete
model.

Saving the Hide Image
If you toggle Save Image on before you choose Begin, DataCAD saves the hidden line removal image for
later use; if Save Image is toggled off, DataCAD does not save the image and only displays it on the
screen.
Once the hidden line removal process is complete, the Save Image menu appears:
Active Layer
New Layer
Layer File
Offset

 To add a retained image to the active layer:
1.

Use (Tab) and (Shift) + (Tab) to scan through the available layers to select the layer to add the new
image to. DataCAD saves the image to the active layer.
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2.

Choose Active Layer after the hidden line removal process is complete. DataCAD adds the image
to the active layer; you return to the Hide menu.

 To add the retained image to a new layer in the drawing:
1.

Choose New Layer at the completion of the hidden line removal process to create a new layer for
the drawing.

2.

Enter a name for the new layer.

3.

Indicate whether you want the new layer On or Off. If you plan to create a series of images, leave
the layer off to return directly to the Hide menu and create a new image.

 To add the retained image to a layer file:
1.

Choose Layer File at the completion of the hidden line removal process.

2.

Enter the name of the layer file you want to create. DataCAD lists the layer files in the current
layer folder in a dialog box.

If you click Cancel in the dialog box without specifying a layer file, DataCAD deletes the image.
The image created by the hidden line removal process contains only 2D lines; you can use all of the
normal DataCAD editing operations on the resulting image such as erasing, trimming, enlarging,
moving, rotating, stretching, and hatching. Since the image contains 2D lines, an orthographic view is the
best.
Before you choose Active Layer or New Layer, you can offset the image in the XY-plane by some distance.
This helps you to create a composition of views by arranging them on the screen apart from each other.
 To offset an image:
1.

Choose Offset after completion of the hidden line removal process.

2.

Select the first point of a distance to offset the image in the plane of the screen.

3.

Select the second point of a distance to offset the image in the plane of the screen.

4.

Choose either Active Layer or New Layer and proceed with the instructions listed above for
adding the image to the drawing.

Choose Cancel to delete the retained image and return to the Hide menu. Remember that after the hidden
line removal process, if you toggle Save Image on, DataCAD saves the image before you select a
destination for it. If you choose Cancel, DataCAD deletes the previously saved image from the drawing
and makes this space available.

Increasing Hide Speed
Use HLR Partial to partition the Drawing Window into smaller sections, allowing for faster hides. Hide
treats each section separately, resulting in continuous lines being divided. It also allows you to see
sections in their entirety as the hidden line removal progresses.
 To change Drawing Window partitions:
1.

Choose HLR Partial from the Hide menu.

2.

Choose X Segments.

3.

Type a new value and press (Enter).

4.

Choose Y Segments.

5.

Type a new value and press (Enter).
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Hide Options
Use Options in the Hide menu to perform different functions within a hidden line removal.
Editing Hidden Line Removal Images
If you use HLR Partial to partition your hidden line removal image, continuous lines will be broken
wherever they cross a partition. While these breaks aren’t visible, they can make editing that image timeconsuming, if not difficult. Using the Join option allows you to more easily edit the hidden line removal
image after it is complete. When you perform a hidden line removal with HLR Partial on, toggle Join on
in the Hide/Options menu to weld (reattach) lines on a model.
Deleting Double Lines
The Delete Dbl. option in the Hide/Options menu deletes any double lines in the model that were created
as a result of performing a hide with Join and HLR Partial on.
Drawing Hidden Lines
If the Draw Hidden option in the Hide/Options menu is on before you choose Begin, DataCAD draws
hidden lines using the line color, line type, and line spacing you set by the Hidden Color, Hidden Style,
and Hidden Spac. options. If you toggle Draw Hidden off, DataCAD does not draw the hidden lines.

Figure 26.14: Draw Hidden with a dashed line type
Disregarding Backfaces
Use the Backface option in the Hide/Options menu for a faster Hide performance. DataCAD calls all
polygonal faces facing away from the viewer backfaces. With this toggle on, DataCAD ignores the
backfaces for a hidden line removal. This decreases the amount of area to hide and the time it takes to
complete the hidden line removal.
Hidden Line Colors
Use the Hidden Color option in the Hide/Options menu to change the color used to draw the hidden
lines. This color menu works exactly like its 2D counterpart. See “Color Menus” in “The Drawing Board”
chapter for more information on the 2D options.
Hidden Line types
Use Hidden Style to change the line type used to draw the hidden lines. When you toggle Draw Hidden
off, Hidden Style is ignored. When you toggle Draw Hidden off, Hidden Color is ignored.
 To change the hidden line type:
1.

Choose Hidden Style from the Options menu. A list of line types appears.

2.

Select a new line type for hidden lines.
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Hidden Line Spacing
Use Hidden Space to change the line spacing used to draw hidden lines. When you toggle Draw Hidden
off, Hidden Spac. is ignored.
 To change the hidden line spacing:
1.

Choose Hidden Spac. from the Hide/Options/Hide menu. A list of spacing values appears.

2.

Choose or type a new spacing value and press (Enter).

Closing 2D Arcs
Unlike 3D arcs and 3D cylinders, ordinary 2D arcs do not have an option for being treated as closed
objects. If you toggle Close 2D Arc on in the Hide/Options menu, DataCAD treats 2D arcs as closed,
which makes them opaque to the hidden line removal process. 2D arcs that have a Z-height work like
cylinders with closed ends and sides. If you toggle Close 2D Arc off, during the hidden line removal
process, DataCAD treats 2D arcs as ordinary curved lines (arcs with no Z-height) or open-ended
cylinders (arcs having Z-height).
CloAr2 On

CloAr2 Off

These are 2D circles, not cylinders.

Figure 26.15: 2D circles
Closing 2D Ellipses
If you toggle Close Ellip. on in the Hide/Options menu, DataCAD treats 2D ellipses as closed, solid
objects during the hidden line removal process. If you toggle Close Ellip. off, DataCAD treats ellipses as
ordinary curved lines (no height) or curved surfaces (having height) with no top or bottom.
Displaying Outlines Only
Toggle No Prim Edge on in the Hide/Options menu to display the outline of tori and cylinders. No Prim
Edge does not display any other divisions of these entities.
2D Arc Divisions
During the hidden line removal process, DataCAD uses the current value of the circle divisions setting.
This Divisions option is duplicated on the Hide/Options menu for convenience in adjusting the current
value of this variable. Choose Divisions from the Hide/Options menu and set it to an integer value from 4
to 36.
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Creating a Shaded Image
DataCAD’s Shader creates a shaded image of your model by temporarily breaking it down into 3- and 4sided polygons and then shading the surfaces according to light source and shader settings. You can
define and place up to seven light sources in your model and use ambient light as well. These light
sources are specific points that radiate light out in all directions and can be toggled on or off to create
different lighting effects. Each surface of your model is illuminated independently of the others, so one
surface will not cast a shadow on its neighbor. The only factor that affects the light on a surface is the
distance of the light source from it. The Shader supports all 256 colors in the DataCAD palette as well as a
rendering palette of 16.8 million colors.
 To create a shaded image of your model:
1.

Go to the 3D Menus.

2.

Click on Shader in 3D Menus. The Shader menu appears.

3.

Click on Settings in the Shader menu. The Shader Settings dialog box appears, allowing you to
change light source settings, the background color or image of the shader window, how edges are
shaded, and more. The settings in the Shader Settings dialog box are also available individually
in the Shader menu. You can use either the dialog box or the menu to change settings; all changes
will be reflected both in the dialog box and the menu options.

Figure 26.16: The Shader Settings dialog box
4.

Change the Light Settings by choosing the light source whose settings you want to change from
the Light Source list box. Then, follow the instructions below. Repeat this for each light source
you want to customize.


The light sources are named LtName1, LtName2, etc., by default. To rename the light source,
click in the Name input box and type a new name. The name will be updated in the Light
Source list box when you either click in the list box or click OK to save the shader settings.

You can also position a light source by simply clicking anywhere in the Drawing Window. Click on
the light source name in the Shader menu, click On/Off in the menu if the light source has not yet
been toggled on, and then choose Position from the menu. A 3D cursor appears in the Drawing
Window; note the cursor’s coordinates displayed in the Coordinates/Hints toolbar. Click to place
the light source. Please note that you cannot use the light source settings in the Shader Settings
dialog box to position the light using this method.

CREATING A SHADED IMAGE |

5.

6.



The light source’s intensity is the percent of white used in the light, with percentage values
ranging from 0 to 100. To set the intensity of the light source, use the up and down arrows to
increase or decrease the percent value, respectively.



To enter specific coordinates for a light source, click in the X, Y, Z Coordinate input boxes
and type new coordinates. (The left input box is the X coordinate, the middle input box is the
Y coordinate, and the right input box is the Z coordinate.)



To toggle a light source on or off, click in the On/Off checkbox.



To give the light source the ability to cast shadows, toggle Cast Shadows on. Note that
shadows are not actually cast in the shaded image unless Cast Shadows in the bottom right
corner of the dialog is checked.



The intensity of ambient light can be adjusted just as light source intensity was. To set the
ambient light intensity, use the up and down arrows to increase or decrease the percent
value, respectively.

Customize the sun light source settings.


Turn the sun light source on by clicking in the On/Off box.



Select the brightness by using the up and down arrows in the Intensity box.



Click one of the eight buttons to show the sun’s position in relation to your drawing.

Customize the background color of the Shader window, change the size of the shaded image, and
change how you move from the shaded image back to your drawing:


To change the background color, click on the colored rectangle in the Background Color
section. Click on a new color in the Color Palette dialog box and then click on OK.



Click on the Right-Click to Exit checkbox to check this option; this will allow you to close the
shader window by simply right-clicking. Uncheck this option to use a pop-up menu to
quickly save your image, move between images and your drawing, or import your shaded
image into eZmeeting.



The shaded image is created as a bitmap (.BMP) file. You can adjust Shader window size by
using the up and down arrows to increase or decrease the percent value, respectively, with
100% being the full size of the Drawing Window. You can go as high as 1,000%, depending
on how much system memory you have available.

7.

Go to the Edge Type section. Click on No Edge to shade only the surfaces of your model, click on
Show Edge to shade both the edges and surfaces, or click on Edge Only to shade only the edges
(similar to a hidden line removal with lights). The default setting is No Edge.

8.

Add edge and overshoot lines to your shaded image.


To set the length of the overshoot, click in the Length input box and type a value. The default
length is 0.0.



To set the width of the lines used for edges and overshoots, use the up and down arrows to
enter a width in pixels. The default is 1.



To draw edge/overshoot lines in the same color as the entity’s surface, check the Use Entity
color checkbox. This is checked by default. If you’d like to use a different color, uncheck the
box, click on the color swatch to the right, and choose a new color. The Edge/Overshoot
properties section is only available when Show Edge is toggled on.
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9.

Use the Highlight setting to produce a visible area of light around a light source, much like a
lamp throws on a wall and ceiling. This setting is off by default, but you can set it to three
intensities, with Large being the most intense.

10. Choose a background image for your shaded image by clicking on the folder icon in the
Background Image section and choosing a supported file format (.BMP, .JPG, .GIF, .TIF, .TGA,
.PNG, .PCX, and .PCD). Leave Maintain Aspect checked to ensure the background image covers
the entire Shader window. You cannot customize the size of the background image.
11. Go to the bottom portion of the Shader Settings dialog box. Check Render both faces to render
both sides of a polygon, instead of rendering only the side with the positive normal. When this
option is unchecked, any negative normals of polygons that face you will not be rendered, unless
Normals toward viewer is checked in the following step.
12. Check Normals toward viewer to set the positive normals of all polygons so that they face you.
Uncheck this option to leave positive normals facing their original direction.
13. Cast shadows in your shaded image, according to the light sources you set for shadows in step 4,
by checking the Cast Shadows box in the lower portion of the dialog box. (Note that you must
still complete steps 19 – 21 to actually draw the shadows.)
14. Make sure the Show Lights checkbox is checked on. This option displays the light sources as
small symbols around your model, letting you see exactly where they are positioned. These
symbols do not print; they are only displayed for visual reference.
15. Click OK to save your new settings and close the Shader Settings dialog box.
16. Cast shadows in your shaded image by clicking on Shadow Plane in the Shader menu. Then,
toggle Recv. Shadow on. You are prompted to Select entity to receive shadow.
17. Select the entity on which the shadow will fall (for example, the polygon acting as the floor or
ground plane). Use the selection menu to select and highlight the entity. If you select the wrong
entity, toggle Recv. Shadow off and select that entity again. Repeat this step to select the correct
entity. An entity cannot cast a shadow and receive one (have a shadow fall on it) at the same time.
18. Right-click to return to the main Shader menu.
19. Click Shade in the Shader menu. Your model is shaded and the bitmap image appears in the
Drawing Area. You can now save the shaded image as a bitmap file or return to your drawing
file. You can save your settings and then use them later without having to change all the Shader
settings again. See “Saving and Using Shader Settings” later in this chapter.
More About Polygon Normals
A characteristic of a polygon surface is its orientation or normal. Think of a polygon as a sheet of paper
that only allows you to write on one side. This side is the positive normal, while the other side is the
negative normal. In a visual sense, polygons are one-dimensional because they may only be seen from
one side in a rendered view.
To quickly shade your model without changing any Shader settings, click on Shade in the View pulldown menu. Your model is shaded.
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You can’t see polygon normals in DataCAD. While a normal is a condition of the coordinate points that
describe a particular polygon, they really don't matter much in the DataCAD world. Whether you view,
quick-shade, or hide a polygon from either side, it will look and display exactly the same. The only way
to know which way a normal faces is to remember how it was created. Did you define the polygon right
to left (counter clockwise) or left to right (clockwise)? If you went counter clockwise, then the normal
faces toward you, out of the screen. If you went clockwise, then it faces away from you, into the screen.
This method of orientation is known as the right-hand rule. To further complicate things, if you mirror an
entity, all of its normals will reverse.

Saving and Using Shader Settings
You can save your settings and then use them later without having to change all the Shader settings
again.
 To save your shader settings:
1.

Customize the options in the Shader Settings dialog box. See “Creating a Shaded Image” earlier
in this chapter for more information on customizing shader settings.

2.

Click on the Save As button in the Shader Settings dialog box. A dialog box appears, prompting
you to Save light information to.

3.

Change to the folder where you want to save your .LIT file, if necessary, and type a name for the
file.

4.

Click on Save. The dialog box closes and your .LIT file is saved.

 To use a .LIT file:
1.

Click on Settings in the Shader menu. The Shader Settings dialog box appears.

2.

Click on Load. A dialog box appears, prompting you to Load light information from.

3.

Change to the folder where your .LIT file is stored if necessary. Then, click on the file.

4.

Click on Open. The dialog box closes and the light settings are loaded into the Shader Settings
dialog box.

Saving Your Shaded Image
You can save your shaded image or send the bitmap to an eZmeeting conference.
 To save your shaded image:
1.

Click on Save or Save As in the File menu or right-click in the bitmap window to display a popup menu and click on Save Bitmap or Save Bitmap As. (Keep in mind that if you use the Save
option, the bitmap is saved in the last folder you used.) The Right-Click to Exit option in the
Shader Settings dialog box must be unchecked for the pop-up menu to display when you rightclick in the Shader window.

2.

Determine if you used the Save As option in the previous step. If so, type a name for the bitmap
file and click Save.

Viewing Selected Entities in Your Model
Use Clip Cube in the 3D Views menu to restrict your view of the model so that only the entities inside a
rectangular region are visible. If an entity is only partially inside the clip cube, DataCAD clips it at the
point where it passes outside the cube. This reduces the visual clutter of a complex model as it develops.
You cannot edit entities outside of the clip cube.
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There are two clip cubes you can use: one for orthographic and one for parallel views. These cubes are
independent of one another. When you begin the clip cube operation from orthographic view, DataCAD
uses the orthographic clip cube. When you use Clip Cube while in a parallel view, the parallel clip cube is
used.
The clip cube status is one of the attributes stored with the Add View function in the GoTo View menu.
Restoring a saved view also restores the clip cube that was in use when you saved the view.
The Arc Factor setting controls the smoothness of clipped arcs that use a solid line type.
 To activate the clip cube:
1.

Select Clip Cube from the 3D Views menu. The Clip Cube menu appears.

2.

Toggle Clip On on.

 To create a new clip cube:
1.

Choose New Cube from the Clip Cube menu.

2.

Set Z-Min and Z-Max so that they enclose the part of the model you want. First set the height of
the floor of the clip cube by selecting Z-Min from the Clip Cube menu, choosing or typing a
value, and pressing (Enter).

3.

Set the height of the ceiling of the clip cube by selecting Z-Max from the Clip Cube menu, and
choosing or typing a value, and pressing (Enter).

4.

Select the area with a rubber band box.

5.

Right-click to exit or select two new corners to reset the rubber band box.

6.

Choose Clip On to toggle the cube on.

Drawing the
Clip cube

Clip On

Figure 26.18: Clip cube
Refresh updates the screen after you activate the clip cube. When Refresh is off, press (Esc) to refresh the
screen yourself to see the effects of the new clip cube.
You can insert an XREF into your drawing and define a clip cube within it. Either you can do this by
using the Insert pull-down menu or by selecting XREF Clip from the 3D Views menu.
 To define a clip cube in an XREF attached to your drawing with Reference File Management:
1.

Open a new drawing or select an existing file.

2.

Attach a reference file to it by selecting XREF from the Insert pull-down menu.

3.

Double-click on the name of the file you want to insert. Your cursor is now loaded with a
boundary box that represents the extents of the reference file. Toggle on By Center in the Insert
XREF menu. You are prompted to Position XREF on drawing. Click the left mouse button to place
the reference file by its center. The reference file appears in your Drawing Window.
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4.

Select Reference File Management from the Insert pull-down menu. Choose Clip Cubes from the
extended menu. You are prompted to Select XREF to modify ClipCube.

5.

Click on the reference file you placed in your Drawing Window. Notice that the reference file’s Zbase and Z-height appear in the Coordinates/Hints toolbar.

6.

Select Z-Min in the Identify menu, choose or type a value that is below the floor or Z-base of the
model, and press (Enter). Similarly, select Z-Max to set the Z-height above the roof of the model.

7.

Click on New Cube. You are prompted to Select the first corner of the clipping cube.

8.

Click where you want the clip cube to begin. Then, pull the rubber band out diagonally and click
when it encloses the area you want to display in the clip cube.

9.

Select Clip On. This toggles the clip cube on.

 To define a clip cube in an XREF attached to your drawing with XREF Clip:
1.

Open a new drawing or select an existing file.

2.

Attach a reference file to it by selecting XREF from the Insert pull-down menu.

3.

Double-click on the name of the file you want to insert. Your cursor is now loaded with a
boundary box that represents the extents of the reference file. Toggle on By Center in the Insert
XREF menu. You are prompted to Position XREF on drawing. Click the left mouse button to place
the reference file by its center. The reference file appears in your Drawing Window.

4.

Make sure you are in the 3D Views menu. Select Clip Cube from the 3D Views menu. The Clip
Cube menu appears.

5.

Select XREF Clip from the Clip Cube menu. You are prompted to Select XREF to modify ClipCube.

6.

Click on the XREF you placed in your drawing. The Identify menu appears.

7.

Set Z-Min and Z-Max values so that they are respectively below and above the model’s Z-base
and Z-height.

8.

Click on New Cube. You are prompted to Select the first corner of the clipping cube.

9.

Click where you want the clip cube to begin. Then, pull the rubber band out diagonally and click
when it encloses the area you want to display in the clip cube.

10. Select Clip On. This toggles the clip cube on.

Saving a View
Use Save Image in the 3D Views menu to create a snapshot of the current view. The snapshot consists of
2D lines and can be edited with normal 2D editing commands in orthographic view.
 To save an image:
1.

Choose Save Image from the 3D Views menu. The Save Image menu appears.

2.

Make decisions about the image you want to save:
Active Layer
New Layer
Layer File
Offset

3.

Save the image to the active layer
Save the image to an automatically created new active layer
Save the image to an automatically created layer file
Select the distance and direction to offset a saved image from the current geometry

Select the destination for the saved image.
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4.

Enter a name for the new destination layer (when you place the image on a new layer or in a
layer file). DataCAD generates the image. The image that this procedure creates is made entirely
of 2D lines with Z-base = 0 and Z-height = 0; therefore, DataCAD creates the image flat on the
ground plane and in orthographic view.

GoTo View
When you save a view using the GoTo View menu in the 3D Views menu, DataCAD stores information
about the current view including:


viewing scale



zoom location (what you have zoomed in on)



view type (orthographic, parallel, perspective, or oblique)



location and orientation of the zero plane



location of the view center



active and inactive layers



size, location, and status (on or off) of the clip cube

Restoring these saved views actually restores all of these stored settings to their previous state. However,
restoring a view does not restore the values of Z-base and Z-height. The Layers On/Off setting may or
may not be restored, depending on whether Layer Set is on or off. The Layer Set option in the GoTo View
menu restores layers to their last saved condition (on, off, active). When Layer Set is off, DataCAD uses
the current state of the layers but restores all the other parameters.
The top part of the GoTo View menu displays the names of any saved views in the drawing. If there are
more than ten views for this drawing, Scroll Fwrd and Scroll Back appear on the menu to let you scroll
through your views. Selecting a view from the menu restores that view to the Drawing Window.
 To add the current view to the list of saved views:
1.

Choose GoTo View from the View pull-down menu.

2.

Choose Add View from the GoTo View menu.

3.

Type the name of the new view (up to eight characters) and press (Enter). The view is added to
the list of saved views.

 To add any changes you made to the view without creating a new view:
1.

Choose GoTo View from the View pull-down menu.

2.

Choose Update View from the GoTo View menu.

3.

Choose the view that you want to update with the current settings. This update includes active or
inactive layers, scale, and location of the zero plane.

 To delete a selected view from the menu:
1.

Choose GoTo View from the View pull-down menu.

2.

Choose Del. View from the GoTo View menu.

3.

Choose the view that you want to delete. DataCAD deletes the view parameters only; the entities
in the drawing are not affected by this operation.

 To move a view from one position in the menu to another:
1.

Choose GoTo View from the View pull-down menu.
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2.

Choose Move View from the GoTo View menu.

3.

Choose the view that you want to move from the list of saved views.

4.

Choose the view you want to appear after the view selected in step 2. The moved view appears
before the view selected in step 3. This is useful for moving an often-used view into one of the
first ten positions on the menu so you can access it quickly and easily.

 To rename a saved view:
1.

Choose GoTo View from the View pull-down menu.

2.

Choose Rename View from the GoTo View menu.

3.

Choose the view that you want to rename.

4.

Type the new view name (up to eight characters) and press (Enter). The view is renamed.

 To toggle between the previous and current views respectively:
1.

Use (Ctrl) + Left Arrow.

2.

Use (Ctrl) + Right Arrow.

(Pro) Linking to a View
You can also link GoTo Views to any entity in your drawing. For instance, you could link a door in your
plan to a door schedule. Then simply pressing (Alt) and clicking on that door would display the go-toview of your door schedule. You can also use the linking shortcut (press (Alt) and click on an entity) to
select an entity and choose a view to link to. However, the following instructions offer greater flexibility
when choosing entities to link to.
 To link an entity to a go-to-view:
1.

Choose GoTo View from the View pull-down menu. The GoTo View menu appears.

2.

Choose Hyper View from the GoTo View menu. You are prompted to Select the view to link to an
entity.

3.

Choose a view from the list in the Menu Window. A selection menu appears.

4.

Choose a selection method.

5.

Select the entity or entities to link to. The link to the GoTo View you chose in step 3 is established.
Repeat steps 2 – 5 to continue linking entities to GoTo Views. If no GoTo View is linked to the
entity you select, you will be prompted to link one.

6.

Restore the linked view by pressing and holding down (Alt) while selecting the entity with your
left mouse button.

 To create hyperlinks between drawing entities and GoTo Views, Internet URLs, and programs:


Use (Ctrl) + Right-click while selecting an entity to access the hyperlink pop-up menu. You
can add a link between the entity and a GoTo View, a URL, or a file. In the extended menu,
use Add to create a new link, Delete to eliminate one, or Edit to change an existing link.



Use (Ctrl) + Right-click to recall a linked URL or file.



Select Hyperlinks from the View pull-down menu to display existing hyperlinks in your
drawing.
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Walking Through Your Model
With the Walk Through option in the 3D Views menu, DataCAD simulates an observer walking through
a perspective model. You can walk toward or away from the model, turn right or left, step up or down or
to one side, or look up or down or to one side. Before using the options that move you around the model,
you must set the distance or angle to control how far you will move with each option.
Before you can use Walk Through, you must set up a perspective view. After you’ve set up a perspective
view, you can toggle on the Viewer toolbar in the View pull-down menu. This toolbar contains the same
functions as the 3D Views/Walk Through menu.
Perspective Navigation Controls
Use hotkeys and Mouse Wheel controls to help you walk through your model. You can use these hotkeys
in any perspective view.
(PageUp)
(PageDn)
Mouse Wheel
(Up Arrow)
(Dn Arrow)
(Right Arrow)
(Left Arrow)
(Shift) + (Up Arrow)
(Shift) + (Dn Arrow)
(Shift) + (Right Arrow)
(Shift) + (Left Arrow)

Walk backward
Walk forward
Walk forward/backward
Walk forward
Walk backward
Step right
Step left
Look up
Look down
Turn right
Turn left

The Walk Through, Options menu lets you customize the way you navigate.
 To start a walk-through session, use one of these alternatives to set up a perspective view:


Select Set Perspective from the View pull-down menu; establish the eye point by clicking in the
drawing where you want to begin the walk-through; move your mouse until the cone is
positioned properly, then click. DataCAD remembers this eye point and uses it for subsequent
walk-throughs until you change it by selecting Set Perspective from the View pull-down menu or
choosing Set Persp. from the 3D Views menu.



Select Perspective from the View pull-down menu.



Click on



Click on Perspective in the 3D Views menu and use Set Persp. to define the eye point and cone.

in the Projection Pad toolbar.

 To customize walk-through options:
1.

Go to the 3D Views menu, toggle on Perspective, and select Walk Through.

2.

Select Options from the Walk Through menu.

3.

Click on Scroll Dist., indicate a value for the new vertical mouse scroll step distance, and press
(Enter).

4.

Set the three toggle switches, keeping the following in mind:


If Fixed Focal is toggled on, you will always look at the same point in your model while
navigating.



If Fixed Focal is toggled off, your focal point will move the same distance as your eye point
while navigating.
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If both Fixed Focal and Fixed Dist. are toggled on, you will navigate spherically around a
fixed focal point.



You cannot toggle off Fixed Focal and Fixed Dist. at the same time.



If Pan View is toggled on, the walk-through controls are disabled. This means you can pan
and zoom your perspective view as if it were a two-dimensional drawing.

Walking
Walk Dist. controls how far forward or backward the observer walks with Walk Forward and Walk Back.
 To change the walking distance:
1.

Choose Walk Dist. from the Walk Through menu. A list of values appears.

2.

Choose or type a value and press (Enter).

Now choose Walk Forward or Walk Back from the Walk Through menu. Walk Forward makes it look as if
the observer has stepped toward the model by a distance equal to the walk distance by shifting both the
eye point and the view center forward along the line of sight. Walk Back makes it look as if the observer
has stepped away from the model by a distance equal to the walk distance by shifting both the eye point
and the view center backwards along the line of sight.
Turning
Turn Angle controls how far the observer will turn with Turn Left and Turn Right.
 To change the turning distance:
1.

Choose Turn Angle from the Walk Through menu. A list of angles appears.

2.

Choose or type a value and press (Enter).

Choose Turn Right or Turn Left from the Walk Through menu. Turn Right turns the observer’s cone of
vision to the right (clockwise) by an angle equal to the Turn Angle. Turn Left turns the observer’s cone of
vision to the left (counterclockwise) by an angle equal to the Turn Angle.
Stepping
Step Dist. sets the step distance used with Step Up, Step Down, Step Left and Step Right.
 To change the stepping distance:
1.

Choose Step Dist. from the Walk Through menu. A list of values appears.

2.

Choose or type a step distance and press (Enter).

Step Up moves both the observer’s eye point and the view center upward, away from the ground plane.
Step Dist. controls the distance that the observer’s eye point is elevated. With StepDown, both the
observer’s eye point and the view center move downward, toward the ground plane. Step Dist. controls
the distance that the observer’s eye point is lowered.
Step Left shifts the view to the right, as if the observer took a step to the left. Technically, this option
causes both the observer’s eye point and view center to move to the left by a distance equal to the Step
Dist. In this context, left means the observer’s left, facing toward the view center. Step Right shifts the
view to the left, as if the observer took a step to the right by causing both the observer’s eye point and
view center to move to the right by a distance equal to the Step Dist. In this context, right means the
observer’s right, facing toward the view center.
Looking
Look Angle sets the angle that the line of sight changes using Look Up or Look Down.
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 To set the rotation angle of the observer’s line of sight:
1.

Choose Look Angle from the Walk Through menu. A list of values appears.

2.

Choose or type a value and press (Enter).

Look Up changes the view to simulate looking up, away from the ground plane. The eye point remains
fixed while the view center moves up, away from the ground plane by an angle equal to the Look Angle.
Look Down changes the view to simulate looking down, toward the ground plane. The eye point remains
fixed while the view center moves down, toward the ground plane by an angle equal to the Look Angle.
Saving a View
 To add the current perspective view to the list of saved views:
1.

Choose Add View from the Walk Through menu.

2.

Type the name of the new view (up to eight characters) and press (Enter). The view is added to
the list of saved views.

Using the o2c-based Object Viewer
The Object Viewer lets you see your model and enhance the image by controlling the rendered colors and
textures.
Hint: You can set interior (or positional) light sources by using the lights you named in the 3D Shader
menu.
 To use the Object Viewer:
1.

Select Object Viewer from the View pull-down menu. The o2c-based Object Viewer window
appears.
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Figure 26.19: The Object Viewer
2.

3.

Use the toolbar icons to control the view:


Sun – toggles sunlight on and off



Ambient lights 1, 2, and 3 – toggles ambient lighting on and off



Lamp – toggles interior lighting on and off



Sun/moon – switches between day and night



Parallel/perspective – switches between views



Clockwise rotation – hold down to move around the Z axis



Counter clockwise rotation – hold down to move around the Z axis



Decrease field of view



Increase field of view



Plan view



Elevation views – left, right, front, and back



Isometric view



Oblique or axonometric view

Depress and hold the left mouse button while you move the cursor to dynamically adjust the
view.
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4.

Depress and hold the right mouse button while you draw the cursor toward you or away from
you to zoom in and out. Alternatively, use the + and – buttons at the bottom right corner of the
Object Viewer to zoom in (+) and out (-).

5.

Right-click to open the o2c pop-up menu. From here, you can further control the view or save it
to a file.


Show all - makes the entire model fit in the screen. Or click on the “a” button at the junction
of the scroll bars.

When DataCAD calculates the extents of the model for the Object Viewer, it takes into account
the position of each light source you defined in the 3D Shader menu. If one of these lights is far
away from the model center, the model will be small and will not appear to rotate around its
center. To correct this problem, either turn off the lights in the 3D Shader menu or position them
closer to the center of your model.

Figure 26.20: The Save bitmap dialog box


Start raytrace - renders the model. Or click on the R button at the right edge of the horizontal
scroll bar of the Object Viewer to raytrace the model.



Save image - creates a permanent high-quality rendering. The Save bitmap dialog box lets
you control the quality of the file while you save the view as a bitmap image. In the Quality
section, high produces the best results, but it takes longer to process. Set the Width in pixels
(try 320 for thumbnails, 640 for presentations, and 1024 for printing); DataCAD uses the
width to automatically calculate the Height in pixels. Check Raytrace if you want shadows
and reflections in your saved image; however, this takes a long time to process. Type the File
name and select the appropriate folder (shown in the Save in box). Click on the Save button
when you are finished and want to return to the Object Viewer.

Figure 26.21: The Background dialog box
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Background – controls what is behind the model in the Object Viewer. Use Load image to access
lists of available bitmap files; use Select color to choose from the Color dialog box. If you selected
Load image, you can also check “Tiled background picture” to put many copies of the bitmap
behind your model and further control the X and Y offset. If you clicked Select color, all options
except Monochrome are unavailable (greyed).

6.

Exit the Object Viewer by clicking on the X in the right corner of the title bar.

Rendering Settings
Selecting Rendering Settings from the View pull-down menu lets you define materials for rendering and
assign them to specific colors in the DataCAD palette. Mapping entity colors to material definitions
controls rendered output. The material settings for a given drawing are stored in a .DMF (DataCAD
Material File) file. You can save custom material files for use in other drawings. Also, you can save
individual material definitions and load them one at a time. These definitions are compatible with other
o2c-based programs such as DCvis, ArCon, and o2c Composer.
DataCAD lets you choose from a standard set of matte, glossy, and glass materials. By adjusting the
various settings and experimenting a bit, you'll be able create your own materials to produce artistic,
photo-realistic renderings of DataCAD models.

Figure 22.21: The decisions you make affect the Preview model.
 To use the Rendering Settings by Layer dialog box:
1.

Access material settings for a given color by using (Ctrl)-right-click on an entity in the DataCAD
Drawing Window. A small pop-up menu appears. For this example, just the STUCCO layer is
active.

2.

Select Rendering Settings from the pop-up menu. This opens the Rendering Settings by Layer
dialog box that lets you precisely define the materials. The name of the active material file
appears in the title of the Layer portion of the dialog box.

3.

Look at the Preview window to see the results of your choices in the rest of this dialog box.

4.

Use the slider bars, input boxes, and check boxes in the various sections of the dialog box to
define the material.
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Layer – click on Color in the Layer portion and click on the rectangle to make your selection
from the Color Palette. Alternatively, click on the arrows on the right and left sides of the
color box to scroll through options in the palette. All entities that have the same color will
also have the same material properties. The first 15 colors shown on the Color Palette are
most frequently used in DataCAD and are the most popular; however, you can define up to
255 unique materials per drawing by using custom colors (beyond yellow). If you click on
Layer, select the layer name from the drop-down list.

Note: The upper left box in the Rendering Settings dialog box contains two mutually exclusive
options: Color and Layer. If you select Color, your choices apply to the current drawing only. If you
select Layer, the material properties are stored on a particular layer.
The title of the dialog box is dependent on whether you select Color or Layer. If you select Color,
the title of the dialog box is Rendering Settings File – DcadWin.dmf. If you select Layer, the title of
the dialog box is Rendering Settings by Layer.


Rendered Color – click on the rectangle to make your selection from the Color Palette. Use
the slider bars to further determine the proportion of diffuse and ambient lighting properties
of materials. A high diffuse proportion will cause the light from defined light sources to
reflect strongly into various nonspecific directions. Use low diffuse values to simulate lightabsorbing materials such as velvet. If the ambient proportion is too high, the object will
appear relatively pale (like plastic) because it will very strongly reflect the environment’s
light. Rendered Color is the material color for all entities that are the current Layer Color. For
example, if you choose white in the Layer Color section, the Rendered Color you select for all
white entities could be Dahlia Purple or any other color in the Color Palette, including a
custom-mixed color that you define with the Color Picker dialog box.



Reflection - defines both the color and the proportional degree for reflections. In principle,
the color defines the highlight on the objects. Higher reflection proportion values simulate
glossy surfaces, such as chrome.



Highlight Size – determines the size of reflected highlights from light sources. Adjustments to
this value can only be seen in the o2c Player when using the raytrace option; they are not
shown in the Preview window. You must use a relatively high reflective proportion to see the
effect of changing this value. In principle, this value measures the intensity of a highlight as a
function of the angle. The higher the value is, the smaller the highlight becomes. For matteshining materials (such as unpolished gold or anodized aluminum), use small values around
3; for high gloss materials (such as polished gold or polished plastic), use large values.



Opacity – the top slider bar determines the degree to which the material is opaque or
transparent. A value of 50% means that when examining an object with this material, 50% of
the color behind the object shows through it and 50% of the object’s color is visible. The
bottom slider bar affects how refractive (or hard) the transparent material is. To simulate
glass, use a refractive index of 12; to simulate something like bubbles in water, use a
refractive index smaller than 10. To see how your selections affect the material, you have to
raytrace the object in the Preview window.



Material File – mutually exclusive buttons apply preset Matte, Glossy, or Glass properties to
the material. When you first work with the color map, you may rely on the presets; however,
you will soon feel more confident about applying your own definitions via the slider bars
and other options in this dialog box to produce photo-realistic materials. These presets affect
the slider bars throughout the dialog box that keep the current rendered color, but change its
reflective properties. Load lets you select an o2c color that will appear in the rectangle in the
Rendered Color section; Save As lets you name and store your material definitions.
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Figure 22.22: The Load Material File dialog box
When simulating real-world elements using computer graphics, the surface properties of a
material are based on various parameters. The level of realism depends partly on how the
parameters are set. The o2c Player uses a standard computer material model known as PHIGS
PLUS. This model simulates real-world material properties, but real-time renderers such as the
o2c Player have limitations on how accurately they can be depicted in final rendered output.
The way an object (or surface) appears is affected by both the material properties and the lighting
(including all sources which light the object). A rendered material is made up of a layering of
different lighting properties (the diffuse portion simulates matte properties; the ambient portion
reflects light in the environment; the reflective portion simulates polished material properties; and
the opacity portion simulates transparent material properties.
By using bitmaps, you can also apply textures to enhance the material definition to simulate realworld surfaces such as carpet, tile, wallpaper, and brick. The preview window lets you see how a
material will look before you apply it to your model.


Miscellaneous – check the boxes that apply: self-illuminate, render backface, and allow
smoothing. Select self-illuminate to see the material even without lights. This causes an object
to simulate a light source, but it will not illuminate its surroundings. This material setting is
ideal for neon and other low-level lighting that is normally used in dark settings. Render
backface forces the o2c Player to render both sides of a surface. By default, render backface is
on for all colors. Smoothing blends a material across adjacent, non-coplanar polygons (such
as a mesh surface). Otherwise, each polygon will be rendered independently, revealing the
creases between adjacent polygons. This option is especially useful for rendering reflective
and transparent objects that are made up of many polygons (such as a sphere or a cylinder).
Without this option, shiny objects will reflect a fragmented view of the surrounding
environment.



Texture – controls the interaction of textures and the defined material. Check Apply Texture
to activate other options. Experiment until you get the results you want in the Preview
window.

In some cases, you may want to mix the colors of the texture with the diffuse color. This makes it
possible to tint (or lighten or darken) a texture without modifying the original bitmap.
If you check Apply texture as reflection map, textures appear to be reflected from, rather than
mapped onto, a given surface. This simulates optimum mirror images, where the object’s texture,
not its environment, is reflected in the object.
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Figure 22.23: Select the background image for the o2c viewer.


Rendering Settings File – affects your settings, saved in a .DMF (DataCAD Material File). The
Load button lets you access material assignments you created for other models. Save As lets
you give the current definition a unique name.



Preview Object – lets you apply your material definitions to different shapes: sphere, cube,
cylinder, or teapot. One object may give you a better idea of how the material definition will
affect the entities in your drawing than another. For example, if you wanted a velvety
material, you probably would steer away from displaying it on the teapot.



Background – controls the color behind the image. This is a global setting, independent from
the material file. When you click on the rectangle, the Color Palette appears so that you can
select a color.

Figure 22.24: Select the background image for the object viewer.


5.

Preview window – lets you see your material assignments. This is a mini o2c object viewer.
Click on “R” to raytrace the material. Some material settings can only be seen in a raytraced
view. Although the default object is a sphere, you could change this to a cube, cylinder, or
teapot to give you a better idea of how the material will look in your model.

Click on OK when you are satisfied with all the settings in the color mapping dialog box.
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6.

Select Object Viewer from the View menu. The Object Viewer appears. The decisions that affect
the STUCCO layer (see Figure 22.21) appear in the Object Viewer. If you are unhappy with the
way the material looks, you can return to step 1 and go through the process again.

Figure 22.25: The results of decisions shown in Figure 22.21
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Chapter 27 Framing Your
Model
FrameIt is a utility that helps you frame 3D floors, walls, and
roofs. The RoofIt macro is used to create the outer portion of the
3D roof.
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In this chapter:





Framing floors
Framing walls
Framing roofs
Saving and using
framing settings
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Framing Floors
Framing is easy when you use the FrameIt macro from your Toolbox pull-down menu. If the FrameIt
macro is not available, select Configure from the Toolbox pull-down menu and add it to your list of active
macros. For more information on adding FrameIt to your list, go to “Customizing the Macros Menu” and
“Customizing DataCAD” in “The Drawing Board” chapter.
 To frame a floor:
1.

Choose Floors from the FrameIt menu.

2.

Verify settings for Plate, Joist, and SubFloor. See “Sill Plate, Joist, and Sub-Floor Settings” in this
chapter for more information.

3.

Choose either Center or Sides to define the floor boundary from the center line of the vertical
member or from one side of the floor to the other.

4.

Define the floor to frame by defining a floor boundary or by choosing Select and selecting an
existing floor boundary. To define the floor boundary, object snap to each point of the floor
boundary, tracing the floor. If you make a mistake, use the Backup button to erase the last point
you selected.

5.

Choose Opening to define floor openings, such as chimneys or stairs. Select the first point of the
floor opening, move the mouse to stretch the rubber band box around the opening, and select the
second point of the rubber band box to define the floor opening.

6.

Choose Beam to define beam style and location. Set the following options as necessary:
Single
Double
Custom
Color
Size
Flush
Below
Change
FileI/O

Models single beams
Models double beams
Customizes the number of entities that make up a beam
Assigns a beam color. See “Color Menus” in “The Drawing Board” chapter for more
information about how to choose a color.
Sets a beam size (choose Change to change a standard lumber size in the menu)
Positions the top of the beam flush or equal to the top of the joist
Positions the top of the beam equal to the bottom of the joist
Changes the current framing member attributes (those attributes set when you selected or
defined the floor boundary)
Accesses file options to save the current framing settings in a file, load saved settings, or delete
or rename framing settings files

7.

Make any changes before choosing Build. Choose Edit or Change to access DataCAD editing
options (including Move, Copy, Rotate, Mirror, Stretch, Enlarge, Erase, and Layers) or to globally
change any floor member attributes. If you choose Edit or Change, you must choose Build again
for those changes to take effect.

8.

Save floor settings to a file by choosing Save File from the FileI/O menu.

9.

Choose Build and select the boundary on which to generate a floor system. Build generates a
framing system based on the settings you defined above. See the “The Drawing Board” chapter
for more information on using the selection menu to choose the boundary to frame.
Use the following toggles before you select the boundary to frame for added control over the
Build process:
SchemLyr
ActvLyr
FlrsOnly

Builds framing members on the schematic layer
Builds framing members on the active layer
Builds only floors with the current settings; otherwise, DataCAD builds all members; only
available in the Floors/Build menu
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WalsOnly
RfsOnly

Builds only walls with the current settings; otherwise, DataCAD builds all members; only
available in the Walls/Build menu
Build only roofs with the current settings; otherwise, DataCAD builds all members; only
available in the Roofs/Build menu

10. Finish framing. When framing is complete, you have access to the following DataCAD options: 3D
Views, Hide, and Layers. See the “Viewing Your Model” and “Before You Draw” chapters for
more information on 3D Views, Hide, and Layers.
11. Choose Exit to return to the Floors menu.
Sill Plate, Joist, and Subfloor Settings
Use Plate to set the following sill plate options:
DoPlate
Single
Double
Custom
Color

Models sill plates
Models single plates
Models double plates
Customizes the number of entities that make up the plate
Assigns a plate color. See “Color Menus” in “The Drawing Board” chapter for more information about
how to choose a color.
Sets a plate size; choose Change to change a standard lumber size in the menu

Size

Use Joist to set the following joist options:
DoJoist
Size

Models the joists
Assigns a joist size, or defines a custom joist size; choose Change to change a standard lumber size in
the menu
Assigns joist spacing (measure spacing from the center line of one joist to the center line of the next
joist)
Assigns a joist color. See “Color Menus” in “The Drawing Board” chapter for more information about
how to choose a color.
Changes the angle in which your joist member will be modeled within the schematic

Spacing
Color
Angle

Use SubFloor to set the following subfloor options:
DoSubflr
Single
Double
Custom
Color
Thickness

Models the subflooring
Models single layer subfloors
Models double layer subfloors
Customizes the number of entities that make up a subfloor
Assigns a subfloor color. See “Color Menus” in “The Drawing Board” chapter for more information
about how to choose a color.
Sets the subfloor thickness for each layer

Framing Walls
 To frame a wall:
1.

Choose Walls from the FrameIt menu.

2.

Verify the settings for WallHght, Plate, and Stud. See “Wall Height, Plate, and Stud Settings” later
in this chapter for more information.

3.

Choose either Center or Sides to define the wall boundary from the center line of the vertical
member or from one side of the wall to the other.

4.

Choose either Exterior or Interior. Use Exterior to create outside wall systems; DataCAD assumes
this will be a closed boundary. Use Interior to create inside wall systems; DataCAD toggles
Closed off and you are drawing a single or string-line wall that does not close itself.
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5.

Define the wall to frame by defining a wall boundary or by choosing Select and selecting an
existing floor or wall boundary. If defining the wall by the boundary, object snap to the first point
of the wall boundary to frame and continue tracing the boundary from that point. If you make a
mistake, use the Backup button to erase the last point you selected.

6.

Choose Opening to define wall openings. Choose either Window or Door (for Exterior) or
PassThru or Door (for Interior). If you choose Window or PassThru, verify the settings for Sill
Height, HeadHght, and HeadStyl. For Door, define only HeadHght and HeadStyl.
Window
Door
SillHght
HeadHght
HeadStyl
Cripple
Boxed
Change
FileI/O

Defines window openings in the wall
Defines door openings in the wall
Defines the sill height; available only when Window is toggled on
Defines the header height of the door
Defines the header style:
Member with smaller studs that run from the top of the header to the bottom of the lower top
plate; maintains stud spacing
Solid member that runs from the top of the header to the bottom of lower top plate
Changes any opening attributes
Accesses file options to save the current framing settings in a file, load saved settings, or delete
or rename framing settings files

7.

Make any changes before choosing Build. Choose Edit or Change to access DataCAD editing
options, including Move, Copy, Rotate, Mirror, Stretch, Enlarge, Erase, and Layers, or to globally
change any wall member attributes. If you choose Edit or Change, you must choose Build again
for those changes to take effect.

8.

Save wall settings to a file by choosing Save File from the FileI/O menu.

9.

Choose Build and select the boundary on which to generate a wall system. Build generates a
framing system based on the settings you defined above. See “The Drawing Board” chapter for
more information on using the selection menu to choose the boundary to frame.
Use the following toggles before you select the boundary to frame for added control over the
Build process:
SchemLyr
ActvLyr
FlrsOnly
WalsOnly
RfsOnly

Builds framing members on the schematic layer
Builds framing members on the active layer
Builds only floors with the current settings; otherwise, DataCAD builds all members; only
available in the Floors/Build menu
Builds only walls with the current settings; otherwise, DataCAD builds all members; only
available in the Walls/Build menu
Build only roofs with the current settings; otherwise, DataCAD builds all members; only
available in the Roofs/Build menu

10. Choose Exit when framing is complete to return to the Walls menu.
Wall Height, Plate, and Stud Settings
Use WallHght to set wall height options. Choose a wall height from the list or type a wall height and
press (Enter).
Use Plate to set the following top and bottom plate options:
DoTop
Single
Double
Custom
Color
DoBottom

Models top plates
Models single top plates
Models double top plates
Customizes the number of entities that make up a top plate
Assigns a top plate color. See “Color Menus” in “The Drawing Board” chapter for more information
about how to choose a color.
Models bottom plates
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Single
Double
Custom
Color

Models single bottom plates
Models double bottom plates
Customizes the number of entities that make up a bottom plate
Assigns a bottom plate color. See “Color Menus” in “The Drawing Board” chapter for more information
about how to choose a color.

Use Stud to set vertical framing member options:
DoStud
Size
Spacing
Color

Models the vertical stud member
Assigns a stud size or defines a custom stud size
Assigns stud spacing (measure spacing from the center line of one stud to the center line of the next
stud)
Assigns a stud color. See “Color Menus” in “The Drawing Board” chapter for more information about
how to choose a color.

Framing Roofs
Use Roof Framing to create three-dimensional roof framing systems. You can frame the following roof
types: Shed, Gable, Hip, and Gambrel. See “3D Roofs” later in this chapter for more information on roof
types
 To frame a roof:
1.

Choose Roofs from the FrameIt menu.

2.

Choose the roof type to frame: Shed, Gable, Hip, or Gambrel.

3.

Choose Settings to set the options for roof settings, including pitch, purlin height, rafters,
sheathing, and overhang. See “Settings” later in this section for more information.

4.

Define the roof by defining a roof boundary or by choosing Select and selecting an existing wall
or roof boundary. To define the roof with an existing boundary, choose that boundary and
continue with step 6. To define the roof by a boundary, object snap to the first and second corners
of the roof boundary to define the length of the roof parallel to the ridge. Make sure that you
define the roof boundary at a Z-base set to the plate height of the wall.
The following options appear on the menu:
Closed
Backup
Cancel
Close/Exit

Models a closed roof boundary
Backs up one roof corner so you can enter a new position
Returns you to the FrameIt menu without defining a roof perimeter
Stops defining the roof perimeter

5.

Choose the third corner of the roof perimeter to define the width of the roof perpendicular to the
ridge if you define the roof by the boundary. The roof boundary is calculated and closed.

6.

Choose Opening to define roof openings, such as chimneys. Select the first point of the roof
opening, move the mouse to stretch the rubber band box around the opening, and select the
second point of the rubber band box to define the roof opening.

7.

Make any changes before choosing Build. Choose Edit or Change to access DataCAD editing
options (including Move, Copy, Rotate, Mirror, Stretch, Enlarge, Erase, and Layers) or to globally
change any roof framing member attributes. If you choose Edit or Change, you must choose
Build again for those changes to take effect.

8.

Save roof settings to a file by choosing Save File from the FileI/O menu.
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9.

Choose Build and select the boundary on which to generate a roof system. Build generates a
framing system based on the settings you defined above. When you define a roof boundary,
FrameIt bases the plate height on the current Z-Base setting. When you use Select to select an
existing wall boundary, FrameIt uses the plate height of the wall. FrameIt always centers ridge
boards when framing roofs

10. Choose Exit when framing is complete to return to the Roofs menu.
Settings
Use Pitch to set a pitch for Shed, Gable, and Hip roofs. Pitch is defined by rise and run; choose a pitch
from the menu, or choose Custom, type a pitch, and press (Enter). Use UprPitch and LwrPitch to set the
pitch for the upper and lower sections, respectively, of a Gambrel roof.
Use MidRdgHt to set the height for purlins for Gambrel roofs. Choose a height from the menu, or choose
Custom, type a height, and press (Enter).
Use Rafters to set the following rafter options:
DoRafter
Size
Spacing
Color
EaveSqr
EavePlmb
BrdMouth

Models rafters; models collar ties every four feet
Sets a rafter size from the list, or defines a custom rafter size
Sets rafter spacing or defines custom rafter spacing (measure spacing from the center line of one rafter
to the center line of the next rafter)
Sets a ridge board and rafter color. See “Color Menus” in “The Drawing Board” chapter for more
information about how to choose a color.
Models fascia square to the angle of the rafter
Models fascia parallel to the wall
Assigns a Bird’s Mouth dimension; choose a dimension from the menu, or choose Custom, type a
dimension, and press (Enter)

Use Sheathng to set the following roof sheathing options:
DoSheath
Single
Double
Custom
Color
Thickness

Models roof sheathing
Models single layer roof sheathing
Models double layer roof sheathing
Models a custom number of roof sheathing layers
Assigns a roof sheathing color. See “Color Menus” in “The Drawing Board” chapter for more
information about how to choose a color.
Assigns the thickness of the roof sheathing material or defines a custom thickness

Use the following OverHang options to set the overhang distance. Measure OverHang from the outside
face of the sheathing to the outside face of the rafter.
EaveOhng
RakeOhng

Assigns an overhang distance at the eave
Assigns an overhang distance on the gable end

RoofIt automates the construction of 3D roof models. You define the roof boundary and RoofIt
automatically calculates and constructs a roof based on your settings.
The standard roof types available with RoofIt are Gable, Hip, Boston, Gambrel, Mansard, and Shed. You
can also create your own customized roof shape. You can vary the pitch, overhang, and plate height
settings, and specify the type of soffit and fascia you want to model. RoofIt also lets you join a new roof to
an existing roof. You can create dormers or other complex roof shapes using this feature. A complete roof
model is composed entirely of 3D polygons. Because of this, you can easily process the model with
DataCAD’s hidden line removal feature, Hide.
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Figure 27.1: Standard roof types
 To create a roof model:
1.

Choose RoofIt from the Toolbox menu. The following options appear:
RectRoof

PolyRoof
Gable
Hip
Boston
Gambrel
Mansard
Shed
Join
Settings
PlatHgt

Pitch

Overhng

Layers
Hide
3D Views

3DEntity

2.

Constructs an orthogonal (rectangular) roof with no variation in settings; RectRoof is the
easiest way to model a rectangular roof. RectRoof and PolyRoof are mutually exclusive; only
one option will be displayed in the menu at any given time. If RectRoof appears in the RoofIt
menu, clicking on it will change it to PolyRoof, putting DataCAD in polygonal roof drawing
mode; you can begin drawing polygonal roofs. To change back to rectangular roof drawing
mode, click on the PolyRoof option to change it to RectRoof.
Constructs a polygonal roof that is not orthogonal or a roof that has varied pitch, overhang, or
plate height settings
Available roof type
Available roof type
Available roof type
Available roof type
Available roof type
Available roof type
Defines a Gable, Hip, or Shed roof that connects to an existing roof plane; the roof that you join
onto may be any roof type you create using RoofIt
Sets roof options depending on the type of roof you’re drawing. See “Setting Options” later in
this section.
Sets different plate height values for each roof line than what’s currently set in
Settings/PlatHgt during PolyRoof creation; when PlatHgt is on, RoofIt prompts you for the
plate height of each roof; only changes with Gable and Gambrel roofs
Sets different pitch values for each roof line than what’s currently set in Settings/Pitch during
PolyRoof creation; when Pitch is on, RoofIt prompts you for the pitch of each roof side; only
changes with Gable and Gambrel roofs
Sets different overhang values for each roof line than what’s currently set in Settings/Overhng
during PolyRoof creation; when Overhng is on, RoofIt prompts you for the overhang of each
roof side; only changes with Gable, Gambrel, and Shed roofs
Shortcut to the Utility/Layers menu without exiting RoofIt. See “Layers” in the “Before You
Draw” chapter.
Shortcut to the 3DEdit/Hide menu without exiting Roof It. See the “Viewing Your Model”
chapter for more information about Hide, 3D Views, and 3D Entity.
Shortcut to the 3D Views menu and look at your 3D model in different orientations without
exiting RoofIt. See the “Viewing Your Model” chapter for more information about Hide, 3D
Views, and 3D Entity.
Shortcut to the 3DEntity menu without exiting RoofIt. See the “Viewing Your Model” chapter
for more information about Hide, 3D Views, and 3D Entity.

Choose RectRoof or PolyRoof to define a rectangular or polygonal roof. See “Defining the Roof
Boundary” later in this chapter for more information.
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3.

Choose one of the six standard roof types: Gable, Hip, Boston, Gambrel, Mansard, or Shed.

4.

Choose Join if you are defining a roof to join with an existing Gable, Hip, or Shed roof plane.

5.

Choose Settings to set roof options (if you don’t need to vary any values, skip to step 6). Choose
the option to set. These options vary depending on which roof type you selected in step 3. See
“Settings Options” later in this chapter for more information

6.

Choose PlatHgt, Pitch, or Overhng from the RoofIt menu if you are creating a Gable, Gambrel, or
Shed polygonal roof. This lets you change that setting for each roof edge you draw. Once you
select the first point of the roof boundary, you can’t move the control from one parameter to
another. You can only change the value of one parameter as you define the roof boundary.

7.

Define a roof boundary by entering length and width values for a rectangular roof or by entering
a series of four points for a polygonal roof. See “Defining the Roof Boundary” later in this chapter
for more information.

8.

Choose the roof plane to join to when prompted if you are defining a roof to join.

Defining the Roof Boundary
The method you use to define the roof boundary depends on whether the RectRoof or PolyRoof option
appears in the RoofIt menu. (The option that appears is the type of roof you’ll draw.)
Rectangular Roofs
When you model a rectangular roof, you define the roof shape by selecting points (in a clockwise
direction) that define its length and width. This results in an orthogonal roof shape.
 To define a rectangular roof boundary:
1.

Choose PolyRoof if RectRoof is not displayed in the RoofIt menu. Then, toggle RectRoof on.

2.

Select the first point of the roof boundary; this point is the first point of the roof length, which
runs parallel to the ridge of the roof.

3.

Select the second point of roof length.

4.

Select the third point of the roof boundary to define the roof width. The roof width is the distance
from one side of the building to the other; this is perpendicular to the roof length and roof ridge.
On a Shed roof, this point locates the ridge (minus the overhang).

Figure 27.2: Defining a rectangular roof boundary
Polygonal Roofs
To model a non-orthogonal roof or one with varying parameters (PlatHgt, Pitch, or Overhng), use
PolyRoof.
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When you define a polygonal roof, you enter a series of four points. These points trace the edges of the
roof boundary in a clockwise direction. The first and third edges of the boundary run parallel to the
ridge; and the ridge bisects the second and fourth edges. Because the roof shape may be either orthogonal
or non-orthogonal, the edges of the roof don’t have to be parallel and perpendicular to the ridge.
 To define a polygonal roof boundary:
1.

Choose RectRoof if PolyRoof is not displayed in the RoofIt menu. Then, toggle PolyRoof on.

2.

Select the first point of the roof boundary. This is the first point of the roof length.

3.

Enter the appropriate value if you’re drawing a Gable, Gambrel, or Shed roof and you toggled
PlatHgt, Pitch, or OverHng on in the RoofIt menu. RoofIt applies this value to the first edge of the
roof.

4.

Select the second point of the first roof edge.

5.

Enter a value if you’re drawing a Gable, Gambrel, or Shed roof and you toggled Overhng on in
the RoofIt menu. RoofIt applies this value to the second edge of the roof.

6.

Select the third point of the roof boundary. The second edge of the roof boundary is bisected by,
but not necessarily perpendicular to, the ridge. The Shed roof is an exception; on a Shed roof, this
point locates the ridge (minus the overhang).

7.

Enter a value if you’re drawing a Gable, Gambrel, or Shed roof and you toggled PlatHgt, Pitch, or
OverHng on in the RoofIt menu. RoofIt applies this value to the third edge of the roof.

8.

Select the fourth point of the roof; unless you toggled OverHng on in the RoofIt menu, the
boundary closes and the roof model is constructed.

9.

Enter a value if you toggled Overhng on. RoofIt applies this value to the fourth edge of the roof.
After you enter the value, the boundary closes and the roof model is constructed.

Figure 27.3: Defining an orthogonal PolyRoof boundary
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Figure 27.4: Defining a nonorthogonal PolyRoof boundary

Joining Roofs
Use Join to define a Gable, Hip, or Shed roof that connects to any one existing roof plane. The roof that
you join onto may be any roof type created with RoofIt.
The following example shows how to use RectRoof to join a Hip roof; you can also use PolyRoof. Define
the roof boundary in a clockwise manner regardless of which input mode you use: RectRoof or PolyRoof.
 To join two roofs:
1.

Model the first roof using the steps outlined at the beginning of this section.

Figure 27.5: Defining the first boundary

Figure 27.6: First boundary defined (plan view and perspective hidden-line image)
2.

Toggle Join on in the RoofIt menu. This tells RoofIt that the next roof you define will join onto an
existing roof.

3.

Define the boundary of the second roof. RoofIt prompts you to select the roof plane to join onto.
When defining the joining roof, if you selected any parameters to vary, RoofIt prompts you for
values as outlined in the previous sections.
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Figure 27.7: Join: Defining the second boundary
4.

Select a point within the perimeter of the roof plane to join to. RoofIt highlights the roof plane
and starts the join operation. The roof you defined extends to and clips at the selected roof plane.

Figure 27.8: Selecting roof plane to join

Figure 27.9: Result of join (plan view and perspective hidden-line image)

Settings Options
The options that appear in the RoofIt/Settings menu depend on the type of roof you’re drawing. The
following table illustrates which settings appear for each roof type:
PlatHgt
Pitch
MidRidge
2ndPitch
RoofThck
Overhng
GblOffst
WallThck
Fascia
EndWall

Gable
X
X

Hip
X
X

Boston
X
X

X
X

X
X

X
X
X

X
X

X
X
X
X
X

Gambrel
X
X
X
X
X
X

Mansard
X
X
X
X
X
X

Shed
X
X

X
X
X

X
X

X

X
X

X
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Settings options include:
PlatHgt
Pitch
MidRidge
2ndPitch
RoofThck
Overhng
GblOffst

WallThck
Fascia

SoffHorz/SoffIncl

FaciaPlb/FaciaSqr

EndWall

Sets the roof plate height; this value is an absolute Z-value and is not relative to the current Zbase and Z-height settings
Sets the roof pitch in rise and run values (4:12, 5:12, 6:12, etc.); or enter a Custom pitch
Sets the purlin height on a Gambrel or Mansard roof; mid-ridge is a Z distance relative to the
current PlatHgt setting
Sets the second pitch on a Gambrel or a Mansard roof in rise and run values (4:12, 5:12, 6:12, etc.);
or enter a Custom pitch
Sets the plate thickness of the roof
Sets the roof overhang; measure overhang in the X, Y plane, from the roof definition boundary to
the outermost point on the fascia
Sets the gable offset on a Boston roof; this distance is measured in the X, Y plane from the roof
definition boundary to the exterior face of the gable end wall; only available when you choose to
draw a Boston roof
Sets the exterior wall thickness; controls the distance in the X, Y plane from the roof definition
boundary to the intersection of the plate and the bottom plane of the roof
Sets the width of the fascia on roofs with plumb fascia and horizontal soffits; does not affect the
roof thickness (controlled by RoofThck); fascia width cannot exceed the plumb distance through
the roof thickness; only available when SoffHorz and FaciaPlb are toggled on
Toggles between SoffHorz and SoffIncl to define the shape of the soffit; toggle SoffHorz on to
draw the underside of the overhang (the soffit) horizontal, or parallel to the ground; toggle
SoffIncl on to draw the soffit inclined, or parallel to the roof plane
Toggles between FaciaPlb and FaciaSqr to define the shape of the fascia; toggle FaciaPlb on to
draw the outside of the overhang (the fascia) plumb, or perpendicular to the ground; toggle
FaciaSqr on to draw the fascia is square, or perpendicular to the roof plane
Toggles the construction of end walls as part of the roof model (end walls fill in the gaps between
the plate and the underside of the roof); when you toggle EndWall on, RoofIt prompts you to
enter the color of the end walls. EndWall only appears when you select a Gable, Boston,
Gambrel, or Shed roof type. RoofIt determines the thickness of the end wall by using WallThck.

Figure 27.10: Roof parameters

Figure 27.11: 2ndPitch and MidRidge settings
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Figure 27.12: Gable offset

Figure 27.13: Types of soffit and fascia

Saving and Using Framing Settings
Use FileI/O to access file options:
Load File
Save File
DelFile
Rename

Loads a previously saved file of floor, wall, or roof framing settings
Saves the current framing settings in a file
Deletes an existing file of framing settings
Renames an existing file of framing settings
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Chapter 28 Modeling Concrete
Forms
With the Concrete tool, you can add six different types of preconstructed concrete forms to your model: columns, inverted
tee, single tee, double tee, standard, and I-beam forms. These
forms are actually slabs and can be edited the same way you’d
change regular DataCAD slabs, using the editing options in the
3D Menus.
With the exception of columns, all forms are drawn based on a
defining line, which is the line connecting the two points you
enter that represent the two ends of the form. In plan view, this
line can define the right, left, or center of the form and can lie at
Z-base or Z-height. This line can also be defined in the Z
direction. In addition, the form’s top, bottom, or center can
intersect the defining line in the Z direction. These options give
you 18 possible positions for every form you draw.
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In this chapter:

 Drawing columns
 Drawing inverted,

single and double
tee forms

 Drawing standard
forms

 Drawing I-beam
forms
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Drawing Columns
Columns begin as rectangular boxes. You can chamfer the vertical edges of the column and add up to
four seats to the column to support the girders and beams. The location of a column is defined by two
points, at opposite corners of a box, indicating the overall dimensions of the column. The column extends
vertically from the current value of Z-base to the current value of Z-height.
 To draw columns:
1.

Choose Column from the Toolbox menu’s Concrete submenu. The following options appear:
Width
Depth
Rotate
LoLeft
Center
UpRight
TopSeat/
BotSeat/
LftSeat/
RhtSeat

SeatOnly

SeatWdth
SeatHght
Chamfer
ChamSize

Sets the column width
Sets the column height
Enters columns that rotate about the entry point; you are prompted for the rotation angle of
the column
Specifies the location of the column by its lower left corner
Specifies the location of the column by its center point
Specifies the location of the column by its upper right corner

These four options indicate the side of the column where the column seat is. You are prompted
for the height of the column seat from the current value of Z-base (when a toggle is off, column
seats are not added for that particular side)
Adds column seats to an existing column or multiple sets of column seats to a single column in
a multiple-story structure with monolithic concrete columns. When this toggle is on, you can
add seats to a column, but you cannot add actual columns.
Sets the distance from the face of the column to the outside of the column seat
Sets the distance from the top face of the column seat to the bottom edge of the column seat
Chamfers the edges of the column; otherwise, the column is angular in cross section (the size
of the column seats automatically adjusts)
Sets the size of the column chamfers

2.

Choose any options you want to set. When you choose Width, Depth, Rotate, TopSeat, BotSeat,
LftSeat, RhtSeat, SeatWdth, and SeatHght a list of values appears.

3.

Choose or type a value and press (Enter).

4.

Select a point in the Drawing Window to place the column’s location.

Drawing Inverted, Single and Double Tee Forms
Inverted tees, or girders, are typically used for supporting single or double tees across a long span such as
a parking garage bay. Because they are in the shape of an inverted T, the beam portion of a single, double,
or quad tee can be placed on a tee’s shelf. You have a variety of options for changing the overall
dimensions of the beam and for its placement in your model.
 To draw an inverted tee:
1.

Choose InvrtTee from the Concrete menu. The following options appear:
OvrlHght
OvrlWdth
NtchDpth
BeamThck
Left

Sets the overall height of the inverted tee; choose OvrlHght and then choose or type a value
and press (Enter)
Changes the overall width of the inverted tee; choose OvrlWdth and then choose or type a
value and press (Enter)
Changes the depth of the notch in the inverted tee; choose NtchDpth and then choose or type a
value and press (Enter)
Changes the thickness of the narrow portion of the inverted tee; choose BeamThck and then
choose or type a value and press (Enter)
Draws the form to the left of the defining line in the X-Y plane
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Center
Right
Top
Center
Bottom
Z-Base
Z-Height
Single
Double

Draws the form centered about the defining line in the X-Y plane
Draws the form to the right of the defining line in the X-Y plane
Draws the form with its top aligned with the defining line
Draws the form with its center aligned to the defining line
Draws the form with its bottom aligned to the defining line
Sets the defining line at the Z-base
Sets the defining line at the Z-height
Places a shelf on only one side of the inverted tee (to the left of the defining line) on the end of
the first inverted tee that is entered
Places shelves of identical size on both sides of the inverted tee

2.

Select the first end of the defining line.

3.

Select a second point that is the opposite end of the defining line.

Single tee concrete forms are used as combination beams and floor slabs. In applications where the
primary function is creating floors, a double tee form is generally used. Industrial buildings and parking
structures use double tees for upper floors that must support large floor loads. A double tee form is easier
to position and place because of the stability provided by having two beam sections. Single tees are used
in special cases, where spans are exceptionally long or floor loads are exceptionally high. In these cases,
the weight and size of double tee forms can make them too large and heavy for practical fabrication,
shipment, or placement.
 To draw a single tee:
1.

Choose SnglTee from the Concrete menu. The following options appear:
Width
Depth
WebThck
BeamThck
Left
Center
Right
Top
Center
Bottom
Z-Base
Z-Hght

Sets the overall width of the single tee form (the location of the beam flanges of the form are
automatically adjusted); choose Width and then choose or type a width and press (Enter)
Sets the overall depth of the single tee form; choose Depth and then choose or type a depth
and press (Enter)
Sets the thickness of the floor slab portion of the single tee form; choose WebThck and then
choose or type a thickness and press (Enter)
Sets the thickness of the two support beams for the single tee slab
Draws the form to the left of the defining line in the X-Y plane
Draws the form centered about the defining line in the X-Y plane
Draws the form to the right of the defining line in the X-Y plane
Draws the form with its top aligned to the defining line
Draws the form with its center aligned to the defining line
Draws the form with its bottom aligned to the defining line
Places the defining line at Z-base
Places the defining line at Z-height

2.

Set the size of cross-sectional dimensions of the single tee form.

3.

Select the first endpoint of the defining line.

4.

Select the second endpoint of the defining line.

 To draw a double tee:
1.

Choose DbleTee from the Concrete menu. The following options appear:
Width
Depth
WebThck
BeamThck

Sets the overall width of the double tee form (the location of the beam flanges of the form are
automatically adjusted); choose Width and then choose or type a width and press (Enter)
Sets the overall depth of the double tee form; choose Depth and then choose or type a depth
and press (Enter)
Sets the thickness of the floor slab portion of the double tee form; choose WebThck and then
choose or type a thickness and press (Enter)
Sets the thickness of the two support beams for the double tee slab; choose BeamThck and then
choose or type a thickness and press (Enter)
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Left
Center
Right
Top
Center
Bottom
Z-Base
Z-Hght

Draws the form to the left of the defining line in the X-Y plane
Draws the form centered about the defining line in the X-Y plane
Draws the form to the right of the defining line in the X-Y plane
Draws the form with its top aligned to the defining line
Draws the form with its center aligned to the defining line
Draws the form with its bottom aligned to the defining line
Places the defining line at Z-base
Places the defining line at Z-height

2.

Set the size of the cross-sectional dimensions of the double tee form.

3.

Select the first endpoint of the defining line.

4.

Select the second endpoint of the defining line.

Drawing Standard Beam Forms
Standard beams have a simple rectangular cross section, but they can also have chamfers along the four
edges of the beam. You can vary the height and width of the beam. There are 18 possible ways to position
the beam relative to a defining line that extends from the first point entered to the second point entered.
 To draw a standard beam:
1.

Choose Std Beam from the Concrete menu. The following options appear:
Width
Depth
Chamfer
Left
Center
Right
Top
Center
Bottom
Z-Base
Z-Hght

Sets the beam width
Sets the beam depth
Chamfers the beam on all edges; otherwise, the beam is rectangular in the cross section. When
Chamfer is on, you must enter the chamfer size.
Draws the form to the left of the defining line in the X-Y plane
Draws the form centered about the defining line in the X-Y plane
Draws the form to the right of the defining line in the X-Y plane
Draws the form with its top aligned to the defining line
Draws the form with its center aligned to the defining line
Draws the form with its bottom aligned to the defining line
Sets the beam’s defining line at the Z-base
Sets the beam’s defining line at the Z-height

2.

Choose any options you want to set. When you choose Width, Depth, and Chamfer, a list of
values appears. Choose or type a value and press (Enter).

3.

Select the first end of the defining line.

4.

Select the second end of the defining line.

Drawing I-Beam Forms
I-beams are similar to standard beams, except that the beam is narrower at the middle of the cross section
than it is at either end of the cross section. For a typical application, the stresses in the concrete are much
higher at the top or bottom of the beam; therefore, an I-beam can be more economical to use than a
standard rectangular beam.
 To draw an I-beam:
1.

Choose I-Beam from the Concrete menu. The following options appear:
Width
Depth
WebThick
FlngDpth

Sets the overall horizontal measurement of the cross section of the I-beam
Sets the overall vertical measurement of the cross section of the I-beam
Sets the thickness of the narrower portion of the beam independently of the overall width of
the I-beam
Sets the vertical dimensions of the I-beam flange independently of all other I-beam cross
section dimensions
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Left
Center
Right
Top
Center
Bottom
Z-Base
Z-Height

Draws the form to the left of the defining line in the X-Y plane
Draws the form centered about the defining line in the X-Y plane
Draws the form to the right of the defining line in the X-Y plane
Draws the form with its top aligned with the defining line
Draws the form with its center aligned with the defining line
Draws the form with its bottom aligned with the defining line
Sets the beam’s defining line at the Z-base
Sets the beam’s defining line at the Z-height

2.

Choose any options you want to set. When you choose Width, Depth, WebThick, or FlngDpth, a
list of values appears. Choose or type a value and press (Enter).

3.

Select the first end of the defining line.

4.

Select the second end of the defining line.
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Chapter 29 Modeling Stairs
The 3D Stairs tool gives you everything you need to create any
of seven predefined 3D stairs, including single-run, straight-run,
double-back, L-shaped, open-well, curved, and spiral stairs.
For each stair type, you can customize settings for treads, risers,
landings, stringers, handrails, balusters, and more. These
settings can then be reviewed on screen and even saved to a stair
(.STR) file that will allow you to quickly load customized
settings for drawing additional stairs.

In this chapter:

 Drawing 3D stairs
 Customizing stair
settings

 Saving and using
stair settings
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Drawing 3D Stairs
The 3DStairs macro provides everything you need to create a set of three-dimensional stairs. 3DStairs
creates real stairs, not stacked slabs, making this representation of stairs more accurate than ever before.
The 3DStairs macro has these main features:


seven predefined stair types -- single-run, straight-run, double-back, L-shaped, open-well, curved,
and spiral



a stair calculator, which makes it easy for you to calculate the values of stair settings and then
readjust the Settings menu values

With the stair forms and other settings, you can customize the shape and placement of stair components.
There are three ways to define the settings for the type of stairs you want to model:


use the 3DStairs/Settings menu to select options and enter individual values for the various stair
components



use StrForm to display the settings on the screen for reference and/or customization



save your stair settings to a file through the StrFile menu; when you want to model that specific stair
type again, you can recall the file

Because of the interactive nature of stair components, changing one option can cause other options to
change automatically. For example, when you close stringers, you can’t have tread extensions.
The sections that follow describe how to create each stair type. You can only use the Stair Calculator for
single-run stairs. See the “More About Drawing Single-Run Stairs” later in this chapter for more
information.
 To draw 3D stairs:
1.

Choose 3DStairs from the Toolbox pull-down menu.

2.

Choose a stair type.

Single

Double Back

Straight

Spiral

Open Well

Figure 30.1: Stair types

L-Shaped

Curved
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3.

Set the options for the stair style you want. You can use either the Settings menu, the Stair Form,
or load a stair file. When you model single-run stairs, you can use the Stair Calculator to
determine the settings. See “More About Drawing Single-Run Stairs” later in this chapter for
more information.

4.

Choose Begin to place the stairs. The tool automatically changes to a plan view and a boundary
box appears representing the run of stairs. When Ortho mode is on, the boundary box does not
track with the cursor. Press (O) to toggle Ortho mode off.

5.

Drag the stairs by the lower outside corner of the first run to the new stair position. The boundary
box rotates as you move your cursor.

6.

Rotate the stairs to the angle you want. The box rotates as you move the cursor.

7.

Click to place the stairs. The stair model appears in the selected location with the settings you
chose.

8.

Change the results by erasing the last group by pressing (Shift) + (<) and repeat steps 2 through 6.

More About Drawing Single-Run Stairs
The Stair Calculator (Calculat) is available only when you create single-run stairs. Use it to calculate one
of six possible values: total rise, number of risers, riser height, total run, number of treads, or tread depth.
Use the Stair Calculator as you would use a desktop calculator; prompts appear in the Message toolbar at
the bottom of the screen. Save the answers to automatically update the 3DStairs/Settings menu for singlerun stairs.
 To use the stair calculator:
1.

Choose Calculat from the 3DStairs menu.

2.

Select an option from the Calculat menu to calculate and modify:
TotlRise
# Risers
RiserHgt
TotalRun

# Treads

TreadDth
LandBtm
LandTop
Reset
Update
Begin
Template
Hide

The number of risers times the riser height; same value regardless of whether LandTop is on or
off
The total rise divided by the riser height, including the rise of the top landing; changing the
number of risers automatically changes the number of treads and vice versa
The vertical distance from the top of one tread to the top of the next tread; the total rise
divided by the number of risers
The horizontal distance from the top of the run of stairs to the bottom of the stairs; the number
of treads times the tread depth (the distance can include landing depth for the top and bottom
landings when those toggles are turned on)
The number of treads in the stair run; changing the number of treads automatically changes
the number of risers and vice versa (you can set TreadDth from this menu to recalculate the
number of treads)
The horizontal distance from the face of one riser to the face of the next riser; the total run
divided by the number of treads (you can change # Treads in this menu)
When LandBtm is on, the total run value includes the bottom landing depth
When LandTop is on, the total run value includes the top landing depth
Resets your calculator settings to the default values
Overwrite the old settings in the Setting menu with new settings; saves your calculated values
Use Begin to start modeling stairs. Follow the steps in the “Using Stairs” section for
information on using Begin.
Shortcut to the Template menu; select a template from the menu, or type a template name, and
press (Enter)
Perform hidden line removals; see “Hide” in the “3D Editing” chapter for more information.
See the “Viewing Your Model” chapter for more information on templates, hidden line
removals, and the 3D Views menu.
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3D Views

Shortcut to the 3D Views menu; see the “3D Viewing” chapter for more information

3.

Look at the submenu that appears after some Calculat menu options. If this occurs, choose an
option to modify; if not, skip to step 5.

4.

Choose a new value from the menu or type a different value. As you change the values of a
setting, the results are automatically calculated and displayed. The stair calculator only accepts a
whole number of treads or risers as a result. If the values you enter in a calculation result in a
fractional solution, the stair calculator modifies the values.

5.

Modify other options by repeating steps 3 and 4.

6.

Choose Update to update the settings in the 3DStairs/Settings menu.
7

Top Landing

6
Total
Rise

Riser
Height

5
4
3
2

Number of Risers = 7

1
Bottom Landing

Figure 30.2: Total rise, riser height, and number of risers

Figure 30.3: Total run, tread depth, and number of treads
For example, to calculate the number of risers through changing RiserHgt:
TotlRise
RiserHgt
#Risers

Initial Settings
12’0”
6”
24

Modified Settings
12’0”
7”
20.57

Stair Calculator Results
12’3”
7”
21

Because #Risers is a fractional number, the Stair Calculator automatically adjusts the TotlRise so that the
results are whole numbers. If you change TotlRise, Stair Calculator adjusts RiserHgt to find a whole
number solution.

Customizing Stair Settings
Use the Settings menu to change the settings for 3DStairs. Different options appear depending on the
stair type you selected from the 3DStairs menu.
The options in the top half of the menu are global settings that apply to all stair types. The bottom half of
the menu are stair component submenus. Each of these submenus contains the various settings for that
particular component.
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When you choose any of the Settings options, a list of values appears. Choose a value or press (Enter) to
accept the given value.
Base Elevation
Use BaseElev to change the base elevation of a flight of stairs. Base elevation is the height, or elevation, at
which the flight of stairs begins.
Tread Depth

Top Landing
Riser
Height
Total
Rise

Base Elevation

Figure 30.4: Base Elevation
Treads
Use TrdLngth to change the tread length. The tread length is the horizontal distance from one side of the
tread to the other side. It does not include tread extension values. Any tread extensions are added to the
tread length and only apply to stairs modeled with open stringers.
Tread
Length

Open Stringer

Tread
Length

Closed Stringer

Figure 30.5: Tread length
Use Trd/Run1 to change the number of treads in the first run of stairs. This applies to all stair types. The
number of treads does not include the landing at the top of the run and is equal to one less than the
number of risers.
Use Trd/Run2 to change the number of treads in the second run of stairs. Trd/Run2 is only available for
straight, double-back, open-well, and L-shaped stairs.
Use Trd/Run3 to change the number of treads in the third run of stairs. Trd/Run3 is only available for
open-well stairs.
Radius of Curved Stairs
Use Radius to change the inner radius of curved and spiral stairs. Measure Radius from the exact center
point to the inside face of the stringer for curved stairs and the radius of the center pole for spiral stairs.
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Tread
Depth

Radius

Figure 30.6: Radius on a curved flight of stairs
Clockwise
Clockwise applies to all stair types except single and straight. You can place the stairs clockwise or
counterclockwise depending on your needs.
Chases
Use Chase to control the horizontal distance between the runs of a double-back flight of stairs. This
setting affects the width of the intermediate landing and the tread length.
Double Back Stairs,
Plan View

Intermediate Landing

Chase

Figure 30.7: Chase
Landings
The top, bottom, and in some cases, intermediate landings all have depth and thickness settings. You can
change the specific settings for each landing you create by using the Landing menu in the
3DStairs/Settings menu. (Changing the settings on the top landing does not affect the settings of the
bottom landing and vice versa.)
Toggle DoLndTp on to model a landing at the top of the flight of stairs; toggle DoLndBt on to model a
landing at the bottom of a flight of stairs.
The Depth option sets the landing depth. The landing depth is the horizontal distance from the front of the
landing to the rear of the landing. When you model L-shaped or open-well stairs, you cannot set a
landing depth on the intermediate landing. The landing depth equals the width of the run of stairs.
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Figure 30.8: Landing depth
Thickness shows the current thickness of a landing. Measure the landing thickness vertically from the
underside to the top side. Thickness sets the top, intermediate, and bottom landing thicknesses.
For stair types that have intermediate landings, IntrLand is always on. It is available for straight, doubleback, open-well, or L-shaped stairs only. For rectangular or curved intermediate landings, use the
Rectangle/Curved option; this is available for L-shaped, double-back, or open-well stairs only.

Double Back

Open Well

L-Shaped

Figure 30.9: Rectangular / curved intermediate landings
Use Color to set the landing color. All landings in a single flight of stairs are modeled using the same
color. See “Color Menus” in “The Drawing Board” chapter for more information about how to choose a
color.
Risers
Use the Riser menu to set options that create risers and determine riser height, thickness, and color.
Toggle DoRiser on to model risers on your flight of stairs.
RiserHgt displays the current riser height in the Message toolbar and lets you reset it. The riser height is
the vertical distance from the top of one tread to the top of the next.
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Tread Depth

Top Landing
Riser
Height
Total
Rise

Base Elevation

Figure 30.10: Riser height, total rise, and tread depth
The Thickness option displays the current riser thickness in the Message toolbar and lets you reset it. The
riser thickness is the horizontal distance from the front side of the riser to the backside of the riser when
you choose Thickness.
Use Color to set the landing color. All landings in a single flight of stairs are modeled using the same
color. See “Color Menus” in “The Drawing Board” chapter for more information about how to choose a
color.
Treads
Use Tread to set options that model treads and determine the depth, thickness, and nosing of the treads.
Toggle DoTread on to automatically calculate and model treads on a flight of stairs.
Depth displays the current tread depth in the Message toolbar and lets you reset it. The tread depth is the
horizontal distance from the front of one tread to the front of the next tread. When you select a spiral
stair, TredDegs (tread degrees) appears in the menu in place of depth. Tread degrees displays the
inclusive angle of the treads on spiral stairs in the Message toolbar and lets you reset it.
Tread Depth

Top Landing

Riser
Height

Total
Rise

Base Elevation

Figure 30.11: Tread depth
Thickness displays the current tread thickness in the Message toolbar and lets you reset it. The tread
thickness is the vertical distance from the top side of the tread to the bottom side of the tread.
LeftExtn and RghtExtn display the current left and right extension, respectively, of the tread in the
Message toolbar and lets you reset it. Left extension includes tread length, the distance from one stringer
to the next. LeftExtn controls the distance that the tread extends beyond the outside of the stringer.
LeftExtn is available only for stairs with open stringers.
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Left Tread
Extension

Figure 30.12: Tread extension
When Nosing is toggled on, you can set the nosing length and type for treads. 3DStairs prompts you for
an overhang value when you toggle nosing on. Nosing controls the distance that the front of the tread
extends beyond the front of the riser.
To set the nosing type to square or round, click on the RndNosng/SqrNosng toggle. This Nosing option
changes between round and square just by clicking on it. If RndNosng appears in the Nosing menu,
round nosing will be drawn on the stair treads; if SqrNosng appears in the Nosing menu, square nosing
will be drawn on the stair treads.
Square
Nosing

Round
Nosing

Figure 30.13: Nosing
Use Color to set the color for the treads. All treads in a flight of stairs are the same color. See “Color
Menus” in “The Drawing Board” chapter for more information about how to choose a color.
Stringers
Stringer allows you to set options that create stringers and determine where and what kind you want to
use. Toggle DoLeft on to model a stringer on the left side of the run of stairs, toggle DoCtr on to model a
stringer in the center of a run of stairs, or toggle DoRght on to model a stringer on the right side of the
stairs. When using DoCtr, the stringer is always modeled as an open stringer.
Use the ClosdStr/OpenStr toggle to set the stringer type to open or closed. When ClosdStr appears in the
Stringer menu, stringers will be modeled as closed; when OpenStr appears in the Stringer menu, stringers
will be modeled as open. Choose ClosdStr or OpenStr to toggle between the two options.
Width displays the current width of the stringer in the Message toolbar and lets you reset it. Measure the
width from the top edge of the stringer to the bottom edge of the stringer.
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Stringer Width,
Closed Stringer

Stringer Width,
Open Stringer

Figure 30.14: Stringer width (open or closed)
The stringer thickness is the horizontal distance from the inside of the stringer to the outside of the same
stringer. Choose Thickness from the Stringer menu and then choose or type a new thickness value and
press (Enter).
Stringer
Thickness

Figure 30.15: Stringer thickness
Use Color to set the color for the stringer. All stringers in a flight of stairs are modeled using the same
color. See “Color Menus” in “The Drawing Board” chapter for more information about how to choose a
color.
Handrails
Toggle DoLeft on to model a handrail on the left side of the flight of stairs. Toggle DoRght on to model a
handrail on the right side of a flight of stairs. When either of these options is toggled off, 3DStairs does
not model the handrails on that side of the stairs.
The Rectangle/Cylinder toggle lets you choose between modeling a cylindrical or rectangular handrail.
When you select Cylinder, the Radius and Division options appear for you to enter settings. When you
select Rectangle, the Width and Depth options appear for you to set.
The Radius/Width toggle displays the current radius or width of the handrail in the Message toolbar,
depending on whether you selected cylindrical or rectangular handrails. When you model a cylindrical
handrail, you can adjust the radius of the cylinder. When you model a rectangular handrail, you can
adjust the width of the rectangle. Measure the width from the top of the handrail to the bottom of the
handrail.
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Figure 30.16: Handrail width and depth
The Depth/Division toggle displays the current depth or number of divisions in the handrail in the
Message toolbar, depending on whether you select cylindrical or rectangular handrails. When you model
a cylindrical handrail, you can adjust the division of the cylinder, or the number of sides in the cylinder.
When you model a rectangular handrail, you can adjust the depth of the rectangle. Measure the depth
from one side of the handrail to the other side. You can use up to 36 divisions, but the more divisions you
have, the longer it takes DataCAD to redraw.
Use Height to see or reset the current height of the handrail. Measure the handrail height from the top
surface of the handrail to the top of the tread.

Handrail
Height

Figure 30. 17: Handrail height
Use Color to set the color for the handrails. All handrails in a flight of stairs are modeled using the same
color. See “Color Menus” in “The Drawing Board” chapter for more information about how to choose a
color.
Balusters
Use the Baluster menu in the 3DStairs/Settings menu to choose what kind of balusters, if any, to use for
your stairs. Toggle DoBalus in the Baluster menu on to model balusters on your flight of stairs.
The Baluster menu has three options for baluster placement. OnSide models balusters on the sides of the
stringers, OnTread models balusters on the treads, and OnStrng models balusters on the center of the
stringer. OnStrng is available only when you model a closed stringer.
Depending on whether you choose OnSide, OnTread, or OnStrngr for baluster placement, either the
Bal/Tred or Bal/Run1 option appears in the Baluster menu. The Bal/Tred option displays the number of
balusters per tread in the Message Window and lets you change the value. Bal/Tred is only available
when you use OnTread. The Bal/Run1 option displays the current number of balusters in the first run of
the stairs in the Message toolbar and lets you change that value. Bal/Run1 is available only when you
place the balusters on the side of the stringer (OnSide) or on the stringer (OnStrng).
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The Bal/Run2 option displays the current number of balusters in the second run of the stairs in the
Message toolbar and lets you change that value. Bal/Run2 is available only when you place the balusters
on the side of the stringer (OnSide) or on the stringer (OnStrng) on straight, double-back, open-well, and
L-shaped stairs.
The Bal/Run3 option displays the current number of balusters in the third run of the stairs in the Message
toolbar and lets you change that value. Bal/Run3 is available only when you place the balusters on the
side of the stringer (OnSide) or on the stringer (OnStrng) on open-well stairs.
Use Cylinder/Rectangle to choose between modeling a cylindrical or rectangular baluster. When you
select Cylinder, the Radius and Division options appear. When you select Rectangle, the Width and
Depth options appear.
The Radius/Width toggle displays the current radius or width of the baluster in the Message toolbar,
depending on whether you selected cylindrical or rectangular balusters. When you model a cylindrical
baluster, you can adjust the radius of the cylinder. When you model a rectangular baluster, you can
adjust the width of the rectangle. Measure the width from one side to the other of one baluster.
The Depth/Division toggle displays the current depth or number of divisions in the baluster in the
Message toolbar, depending on whether you selected cylindrical or rectangular balusters. When you
model a cylindrical baluster, you can adjust the division of the cylinder, or the number of sides in the
cylinder. When you model a rectangular baluster, you can adjust the depth of the rectangle. Measure the
depth from the front to the back of the baluster. You can use up to 36 divisions, but the more divisions
you have, the longer it takes DataCAD to redraw

Width
Depth

Figure 30.18: Baluster width and depth
Use Symbol to model balusters as symbols. When balusters are symbols, you can replace the balusters
produced by 3DStairs with different, more detailed baluster symbols that you create.
 To use custom balusters in stairs:
1.

Create your detailed baluster in the DataCAD drawing window and save it as a symbol. See
“Creating and Editing Symbols” in the “Symbols, Images, and Objects” chapter for more
information

2.

Choose 3DStairs from the Toolbox pull-down menu.

3.

Set the baluster options as necessary.

4.

Toggle Symbol on to draw the balusters as symbols.

5.

Create your run of stairs.

6.

Replace the existing balusters with the symbol you created in step 1 using the Replace option in
the Template menu. See “Replacing Symbols in Your Drawing” in the “Symbols, Images, and
Objects” chapter for more information.
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Balusters on Stringer

Balusters on Side

Balusters on Tread

Figure 30.19: Baluster placement
VertOfst shows the current vertical offset of the baluster. Vertical is the distance that the bottom end of
the balusters extends below the treads. Vertical offset appears only when you select OnSide.

Baluster
offset

Figure 30.20: Baluster vertical offset
HorzOfst shows the current horizontal offset of the baluster. When you model balusters on the treads,
measure the offset from the side edge of the tread to the middle of the baluster. HorzOfst only appears
when you select OnTread.

Baluster offset,
Closed stringer

Baluster offset,
Open stringer

Figure 30.21: Baluster horizontal offset
Use Color to set the color for the balusters. All balusters in a flight of stairs are modeled using the same
color. See “Color Menus” in “The Drawing Board” chapter for more information about how to choose a
color.
Newel Posts
Use NewelPst to model newel posts on the stairs. Toggle DoNlPst on to model newel posts on a flight of
stairs. When DoNlPst is toggled off, 3DStairs models balusters in place of newel posts.
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On

Off

Figure 30.22: Newel posts on/off
Use Cylinder/Rectangle to choose between modeling a cylindrical or rectangular newel post. When you
select Cylinder, the Radius and Division options appear. When you select Rectangle, the Width and
Depth options appear.
The Radius/Width toggle displays the current radius or width of the newel post, depending on whether
you selected cylindrical or rectangular newel posts, in the Message toolbar. When you model a cylindrical
newel post, you can adjust the radius of the cylinder. When you model a rectangular newel post, you can
adjust the width of the rectangle. Measure width from one edge, near a baluster, to the other edge, facing
out, of the same newel post
The Depth/Division toggle displays the current depth or number of divisions in the newel post,
depending on which of the previous options you selected, in the Message toolbar. When you model a
cylindrical newel post, you can adjust the division of the cylinder, or the number of sides in the cylinder.
When you model a rectangular newel post, you can adjust the depth of the rectangle. Measure the depth
from the edge of the newel post near the handrail to the open edge. You can use up to 36 divisions, but
the more divisions you have, the longer it takes DataCAD to redraw.

Depth

Width

Figure 30.23: Newel post width and depth
Use Symbol to model newel posts as symbols. When newel posts are symbols, you can replace the newel
posts produced by 3DStairs with custom newel post symbols that you create.
 To use custom newel posts in stairs:
1.

Create your detailed newel post in the DataCAD drawing window and save it as a symbol. See
“Creating and Editing Symbols” in the “Symbols, Images, and Objects” chapter for more
information.

2.

Choose 3DStairs from the Toolbox pull-down menu.

3.

Set the newel post options as necessary.

4.

Toggle Symbol on to draw the newel posts as symbols.

5.

Create your run of stairs.
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6.

Replace the existing newel posts with the symbol you created in step 1 using the Replace option
in the Template menu. See “Replacing Symbols in Your Drawing” in the “Symbols, Images, and
Objects” chapter for more information.

Use Color to set the color for the newel posts. All newel posts in a flight of stairs are modeled using the
same color. See “Color Menus” in “The Drawing Board” chapter for more information about how to
choose a color.

Stair Form
 To display values and settings for all stair types:
1.

Choose StrForm from the 3DStairs menu.

2.

Press (Tab) to move forward or (Shift) + (Tab) to move backward through each line of the stair
form.

3.

Scroll through the two-page form by selecting Scroll Fwrd or Scroll Back from the menu.

4.

Press (Esc) to save settings and exit the StrForm menu or choose Exit to leave the StrForm menu
without saving any changes. For settings with options, you can scroll through them using
(Spacebar).

Saving and Using Stair Settings
Use the StrFile option in the 3DStairs menu to save stair settings for future use, as well as load, save,
delete, and rename stair setting files:
LoadStr
SaveStr
DelStr
Rename
StrForm

Loads a stair settings file; choose LoadStr from the StrFile menu and type the name of the file to load
Saves your current stair settings to a file; choose SaveStr from the StrFile menu and type the name of the
file to save
Deletes a stair settings file; choose DelStr from the StrFile menu and type the name of the file to delete
Renames an existing stair file; choose Rename from the StrFile menu, choose the file to rename, and
type a new name
Shortcut to the Stair Form menu. See “Stair Form” earlier in this chapter for more information on using
this menu.
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Chapter 30 Appendix
This appendix contains additional information for advanced
users as well as tables defining such things as DataCAD’s
standard line types, hatch patterns, and keyboard shortcuts.

In this chapter:

 INI Settings
 DWG/DXF translation
tables

 Creating custom
toolbars

 Creating line types
 Standard hatch
patterns

 Creating keyboard
shortcuts

 Standard keyboard
shortcuts

 Standard fonts
 Extended characters
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INI Settings
[General]
PurgeDrawingsOnExit=1

Enables or disables the automatic
purging of unused drawing data upon
exiting and saving a drawing.

[General]
Aspect Ratio=1

Sets the aspect ratio (X/Y) for
DataCAD’s drawing area. You can
adjust this value to compensate for
non-4:3 ratio screen resolutions.

[General]
USER_NAME=John Doe
USER_COMPANY=John Doe Architects,
Inc.
USER_SERIAL=DCXIW00000
[General]
CAVWALL=FALSE

Identifies the user, company, and serial
number for the current DataCAD
version.

[General]
CoplanarCheck=FALSE

If TRUE, this forces the vertices on 3D
polygons with more than three sides to
be coplanar, based on the first three
non-collinear vertices.

[General]
ShowWinCursor=FALSE

If TRUE, it would activate the
Windows system cross-hair cursor
along with the DataCAD cursor. This
is useful for screen capture programs
that record the movement of the
Windows system cursor.

[General]
OldHelp=FALSE

If TRUE, accessing help from the pulldown menu or with [Ctrl]+[F1] opens
the old DCADWIN.HLP instead of the
new DataCAD11_Manual.PDF.

[General]
MinusKeyTogglesOvershoot=TRUE

If FALSE, the minus key will invoke
direct distance input.

[General]
CommaKeyErasesLastEntity=TRUE

If FALSE, the comma key will invoke
direct distance input.

[General]
PeriodKeyRestoresLastEntity=TRUE

If FALSE, the period key will invoke
direct distance input.

[General]
CapsLock=FALSE

If TRUE, the AllCaps toggle operates
like CapsLock instead of forcing all
uppercase letters.

[General]
FixFont=FALSE

If TRUE, corrects fonts with zero width
character definitions.

If TRUE, inserting doors and windows
into cavity (4-line) walls trims the
outer jamb lines to the cavity lines.
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[General]
HYPERVIEW=ALT

If ALT, access hyperlinked views using
[Alt]+Left-click.
If ALT+SHIFT, access hyperlinked
views via [Alt]+[Shift]+Left-click.

[General]
SymbolCacheSize=2

Size (in whole numbers) of Symbol
Browser cache in megabytes.

[General]
NoGridLnSelect=TRUE

If FALSE, DataCAD will not automatically disable grid snapping during
selection and Window In.

[Paths]
INSTALL_DIR=c:\Program
Files\DataCAD\
PATH_SWAP=Temporary Files\
PATH_SUPPORT=Support Files\
PATH_DEFAULTS=Support Files\
PATH_ICON=Support Files\Toolbars\
PATH_BMP=Support Files\Toolbars\
PATH_MSG=Support Files\
PATH_HELP=Help\
PATH_RECOVERY=Recover Archive\
PATH_PENTABLE=Support Files\
[PaletteFile]
DoCustomColors=TRUE

If TRUE, DataCAD will save the 16
custom colors that can be defined
using the Windows Color Picker from
the Pen Table dialog.

[o2cViewer]
SmoothDistance=0

Distance between adjacent polygons to
be considered for smoothing.

[o2cViewer]
SmoothAngle=30

Angle between adjacent polygons to be
considered for smoothing.

[Printer]
FitToAdjustment=0

Percentage (positive or negative whole
number) to add or subtract from
DataCAD’s automatic FitTo
calculation.

[Printer]
NewFitTo=TRUE

If TRUE, DataCAD uses a more
accurate method to determine the
available print area which may be
incompatible with some drivers. If
FALSE, DataCAD uses the original
method to determine the available
print area.

[Alias]
PopupWidth=300

Width of command line alias popup
window in pixels.

[Alias]
PopupLines=4

Number of lines displayed in
command line alias window.
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[MenuBtn]
BTN_SPACING=2
BTN_WIDTH=0

Set the number of pixels between
menu buttons vertically; alternatively,
set the number of pixels to add or
subtract from the width of menu
buttons.

[StatusArea]
DropDownWidth=0

Width in pixels to add or subtract from
Status Panel.

[Mask]
UseGlobalMask=TRUE

Use Mask instead of Selection Sets
when editing (TRUE) or Selection Sets
instead of Mask when editing (FALSE).

[Undo]
Disabled=FALSE
[TemplateWindow]
WIDTH=

If TRUE, undo/redo system is disabled.

[Clipboard]
CopyBitmap=TRUE

If TRUE, entities copied to the
Windows clipboard will maintain a
corresponding bitmap representation
to paste into bitmap applications.

Value in pixels to set the width of the
template window.

DXF/DWG Translation Tables
Importing data from a DXF or DWG file to a DataCAD (AEC) file is not always a one-to-one translation.
There are a few instances where data is handled differently in DataCAD. For instance, entities in
AutoCAD with a color-by-block attribute will be read into DataCAD as white.
Dimension arrowheads must also be changed in order to display in DataCAD. AutoCAD arrowheads,
which are blocks (symbols), will be replaced globally with the arrowhead style set with the Arrow Style
option of the Dimensions menu. When exported back to a DXG/DWG file, all arrowheads will be set to
the AutoCAD default. Dimension text and extension lines will remain the same color, but dimension lines
will be changed to the same color as the extension lines.
Text, in some cases, is also treated differently in DataCAD. A single instance of vertical text in a
DWG/DXF file will be translated to horizontal text.
DataCAD Symbol Text Attributes appear as Block Attributes in a DWG file.
The Importing and Exporting sections that follow provide translation tables showing how entities are
treated in “round-trip” scenarios, where a file would begin and end in AutoCAD or DataCAD.

Importing
AUTOCAD

DATACAD

AUTOCAD

2D Polyline
(parallel to X,Y plane)

Polyline

2D Polyline (rel.13 or 14)
Polyline (rel.12)

2D Polyline
(not parallel to X,Y
plane)

Polyline Symbol‡

2D Polyline (rel.13 or 14)
Polyline (rel.12)

2D Polyline

Polyline†

2D Polyline (rel.13 or 14)

DXF/DWG TRANSLATION TABLES |
(with width assigned to
any vertices)
3DFace

Polyline (rel.12)

Polygon

3DFace

3D Polyline
(with varying Z values)

3D Line

Line

3D Polyline
(planar--no varying Z values)

Polyline
(parallel to X,Y plane)
Polyline Symbol‡

2D Polyline

Arc
(parallel to X,Y plane)

Arc

Arc

Arc
(not parallel to X,Y plane;
thickness= 0)

3D Arc

Arc

Arc
(not parallel to X,Y plane;
thickness 0)

Cylinder†

Arc

Attribute Definition

Text† (constant data is saved
as attributes; variable data is
lost)

Attribute Definition

Block

Symbol

Block

Circle
(parallel to X,Y plane)

Circle

Circle

Circle
(not parallel to X,Y plane;
thickness = 0)

3D Arc†

Circle

Circle
(not parallel to X,Y plane;
thickness  0)

Cylinder†

Circle

Dimensions

Associative Dimensions

Dimensions

Dimensions
(angular, radius, or diameter
dimensions and leaders)

Lines and text

Lines and text

Donut
(parallel to X,Y plane)

Polyline†

Donut

Donut

Polyline Symbol†‡

Donut
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(not parallel to X,Y plane)
Ellipse
(parallel to X,Y plane)

Ellipse

Ellipse (rel.13 or 14)
Lines (rel.12)

Ellipse
(not parallel to X,Y plane)

Ellipse Symbol‡

Ellipse (rel.13 or 14)
Lines (rel.12)

Hatch

Associative Hatch (if hatch
boundary is LW polyline)
Associative Hatch Symbol‡ (if
hatch boundary is LW polyline
but not parallel to X,Y plane)
Lines (if hatch boundary
includes any other boundary
type besides LW polyline)

Lines

Leaders

Lines and Text

Lines and Text

Light-Weight Polyline

(See 2D Polyline above)

Line
(parallel to X,Y plane)

Line

Line

Line
(not parallel to X,Y
plane;
thickness = 0)

3D Line

Line

Line
(not parallel to X,Y
plane;
thickness  0)

Polygon†

Line (if coordinates
unchanged)
Line, with changed thickness
(if polygon stretched along the
axis of thickness)
Polygon (if coordinates
changed in directions other
than axis of thickness)

MText

Text

Text

Mesh

Polygons

Polygons

Point
(with no thickness)

Point₤

Point

Point
(with thickness)

3D Line†₤

Point

Polyface Mesh

Polygons

Polygons
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Spline

Point†

Spline (rel.13 or 14)

Solid

Polygons, triangulated

3D Faces

Text, single line or multiline

Text

Text

† AutoCAD entity is imported into DataCAD as an entity with attributes. If the entity is edited in
DataCAD, upon export it will return to its original (AutoCAD) entity type, incorporating the changes you
made in DataCAD. Exceptions to this are exploding an entity, which permanently changes the entity
type, or deleting an entity.
‡ AutoCAD entity is imported into DataCAD as a symbol. These symbols are like any other in DataCAD;
they cannot be edited unless they are first exploded. If you explode an entity in 3D space, however, it will
flatten to the X,Y plane. For instance, a Donut in a DWG file that is not parallel to the X,Y plane will be
imported into DataCAD as a Polyline Symbol. If this symbol is not exploded, it will maintain its position
when exported back to a DWG file. If the symbol is exploded, however, it will flatten to the X,Y plane,
even when exported back to a DWG file.
₤ Point shape is lost in translation.
 A block comprised of entities on different layers will be imported into DataCAD as a symbol on the
layer where the block was inserted; that is, all entities for that Block will be moved to the insertion layer.
These entities will remain on this layer when exported back to a DXF or DWG file. Also, anonymous
(unnamed) blocks in AutoCAD will be given a unique, numeric name when imported into DataCAD; this
name will be saved with the block when exported.
There are a few AutoCAD entities that cannot be read, displayed, or otherwise saved during translation.
These include: Viewports, ACIS data (Body), Rays (XLines), Ole Frames, Ole2 Frames, Tolerances,
Images, Regions, Proxies, and named views.

Exporting
DATACAD
3D Arc

AUTOCAD
Arc

DATACAD
3D Arc

3D Line

Line

3D Line (if not parallel to
X,Y plane)
Line (if parallel to X,Y
plane)

Arc

Arc

Arc

B-spline

Polyline

Polyline

Bezier

Polyline

Polyline

Circle

Circle

Circle

Cone

Polyface Mesh
3D Faces (if Decompose in
Options dialog is on
during export)

Polygons
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Contour

Polyline

Polyline

Cylinder

Polyface Mesh
3D Faces (if Decompose in
Options dialog is on
during export)

Polygons

Dimensions (Associative)

Dimensions

Dimensions (Associative)

Ellipse

Ellipse (rel.13 or 14)
Lines (rel.12)

Ellipse

Hatch (Associative)

Lines

Lines

Line

Line

Line

Mesh Surface

Polyface Mesh
3D Faces (if Decompose in
Options dialog is on
during export)

Polygons

Point

Point

Point

Polygon
(with 3-4 vertices and no
voids)

3D Face

Polygon

Polygon
(with 5 or more vertices
and/or voids)

Triangulated into multiple
3D Faces

Multiple 3-sided polygons

Polyline

Lightweight Polyline
(rel.14)
Polyline (<rel.14)

Polyline

Sphere

Polyface Mesh
3D Faces (if Decompose in
Options dialog is on
during export)

Polygons

Surface of Revolution

Polyface Mesh
3D Faces (if Decompose in
Options dialog is on
during export)

Polygons

Symbol

Block

Symbol

Text

Text

Text

Torus

Polyface Mesh

Polygons
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3D Faces (if Decompose in
Options dialog is on
during export)
Truncated Cone

Polyface Mesh
3D Faces (if Decompose in
Options dialog is on
during export)

Polygons

Creating Custom Toolbars
In versions prior to DataCAD 11, creating custom toolbars involved using complicated and cumbersome
.KEY files. Beginning with DataCAD 11, the former .KEY files were automatically converted to the new
DTB, INI-based DataCAD Toolbar format. The following examples show the differences between the
former KEY file and new DTB toolbar formats.
KEY File Format
!| |
*|01|
L| |
L| |
L| |
L| |
L| |
A| |
A| |
A| |
A| |

|
|
|
|
|undo
|119
|redo
|120
|LAYERS_S|23
|LINTYP_S|15
|ARCTCT_S|11
|2DWALL_S|^·^È^;^S3^F1^¸^É
|2LWALL_S|^·^È^;^S3^F2^¸^É
|3LWALL_S|^·^È^;^S3^F3^¸^É
|4LWALL_S|^·^È^;^S3^F4^¸^É

|
|
|
|
|
|
|
|
|
|
|

UNDO last action
REDO previous action
Layers menu
Line Type menu
Architect menu
Toggle Walls on/off Select 2 line walls Select 3 line walls Select 4 line walls -

DTB File Format
[undo]
Hint=UNDO last action
Icon=undo
L=119
[redo]
Hint=REDO previous action
Icon=redo
L=120
[LAYERS_S]
Hint=Layers menu
Icon=LAYERS_S
L=23
[LINTYP_S]
Hint=Line Type menu
Icon=LINTYP_S
L=15
[ARCTCT_S]
Hint=Architect menu
Icon=ARCTCT_S
L=11
[2DWALL_S]
Hint=Toggle Walls on/off - Architect menu
Icon=2DWALL_S
A=^·^È^;^S3^F1^¸^É
[2LWALL_S]
Hint=Select 2 line walls - Architect menu
Icon=2LWALL_S
A=^·^È^;^S3^F2^¸^É

|
|
|
|
|
Architect
Architect
Architect
Architect

menu
menu
menu
menu

|
|
|
|
|
|
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[3LWALL_S]
Hint=Select 3 line walls - Architect menu
Icon=3LWALL_S
A=^·^È^;^S3^F3^¸^É
[4LWALL_S]
Hint=Select 4 line walls - Architect menu
Icon=4LWALL_S
A=^·^È^;^S3^F4^¸^É

Creating New Icons
1.

Create a 16-color, square bitmap in bitmap (.BMP) format.

2.

Save it with a filename in the \DataCAD\Support Files\Toolbars\ directory.

Toolbar Icon Button Size
The default size of icon buttons used in toolbars is 16x16 pixels. However, if you'd like to use larger icon
buttons, you can select another size by using the Configure DataCAD for Windows Settings dialog box.
 To change icon button size:
1.

Select Program Preferences from the Tools pull-down menu to display the Configure DataCAD
for Windows Settings dialog box.

2.

Click on the Toolbars tab.

3.

Choose a different value in the Icon Size portion. Valid values are 16, 24, 32, and 48. An
Information dialog box states that the changed icon size will not take effect until you restart
DataCAD.
This setting only changes the available button area for icon bitmaps. It does not make small icons
larger or large icons smaller.

4.

Click on OK to close the Information dialog box. Then click on OK to close the Configure
DataCAD for Windows Settings dialog box.

5.

Exit from DataCAD; then restart the program.

Drop-Down Toolbar Items

You can add drop-down items to your own toolbars. To add a drop-down section to a toolbar use the
following format in the INI file.
[SECTION]
Icon= (insert the bitmap filename)
Hint= (insert the tool tip)
A= (insert the action form; e.g., Alt-???)
DropDownCount=3 (change the number if more or less than 3 new icons)
Icon00=
Hint00=
A00=
Icon01=
Hint01=
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A01=
Icon02=
Hint02=
A02=

Selecting the parent icon will perform the action if one is defined or will drop down the child icons if no
action is defined. Hints for child icons will be used as menu labels.
Action Codes for Toolbars
The following action codes have been added for use in Toolbars:
Code
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L

#
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44

Action
2D Edit, Move
2D Edit, Copy
2D Edit, Rotate
2D Edit, Mirror
2D Edit, Stretch
2D Edit, Enlarge
2D Edit, Identify
2D Edit, Change
2D Edit, Erase
2D Edit, Cleanup
2D Edit, Architect
2D Edit, Polygons
2D Edit, Curves
2D Edit, Text
2D Edit, Line Type
2D Utility, Hatching
3D Edit
2D Utility, Zoom
2D Utility, Display Scale
2D Utility, Geometry
2D Utility, GoTo View
2D Utility, Grids
2D Utility, Layers
2D Utility, Templates
2D Utility, Settings
2D Utility, Measures
2D Utility, Print/Plot
2D Utility, Dimensions
2D Utility, Display
2D Utility, Object Snap
2D Utility, Freehand
2D Edit, Group
File I/O
2D Utility, Info
2D Curves, 2-Point Arc
2D Curves, 3-Point Arc
2D Curves, Central Angle Arc
2D Curves, Central Length Arc
2D Curves, Central Chord Arc
2D Curves, Tangent Arc
2D Curves, Ellipse
2D Curves, Radius Circle
2D Curves, Diameter Circle
2D Curves, 3-Point Circle
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L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L

45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100

2D Move, Drag
2D Copy, Rectangular Array
2D Copy, Circular Array
2D Cleanup, Fillets
2D Cleanup, Chamfer
2D Cleanup, 1-Line Trim
2D Cleanup, 2-Line Trim
2D Cleanup, Weld Line
2D Cleanup, T-Intersection
2D Cleanup, L-Intersection
2D Architect, Door Swing
2D Architect, Windows
2D Architect, Cut Wall
2D Geometry, Divide
2D Geometry, Intersection
2D Geometry, Tangents
2D Selection Sets
3D Views
3D Views, Elevation
3D Views, Controls
3D Views, Edit Plane
3D Views, Plane Snap
3D Views, Set Perspective
3D Views, Walk Through
3D Views, Set Oblique
3D Views, GoTo View
3D Views, Save Image
3D Views, Clip Cube
3D Edit, Hide
3D Entity, 3D Lines
3D Edit, Settings
3D Entity, Blocks
3D Entity, Vertical Cylinders
3D Entity, Horizontal Cylinders
3D Entity, Cones
3D Entity, Truncated Cones
3D Entity, Spheres
3D Entity, Tori
3D Entity, Mesh Surfaces
3D Entity, Revolved Surfaces
3D Entity, Markers
3D Entity, Polygons
3D Entity, Slabs
3D Entity, Polygons, Horizontal
3D Entity, Slabs, Horizontal
3D Entity, Polygons, Rectangular
3D Entity, Slabs, Rectangular
3D Entity, Polygons, Vertical
3D Entity, Slabs, Vertical
3D Entity, Polygons, Inclined
3D Entity, Slabs, Inclined
3D Polygons/Slabs, Voids
Obsolete
3D Edit, Move
3D Edit, Copy
3D Edit, Rotate
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L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L

101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
152
154
155
156

3D Edit, Enlarge
3D Edit, Erase
3D Edit, Stretch
3D Edit, Change
3D Edit, Explode
3D Menus
3D Entity
Quick Shader
Linear Dimension
Layer On/Off
Layer Name
Layer Delete
File/Import
File/Export
Obsolete
Toolbox
RenderStar
Template Menu
Undo
Redo
Insert, XREF
Paste from Clipboard
Cut to Clipboard
Copy to Clipboard
Selection Sets
Paste Text from Clipboard
Estimator - Obsolete
Estimator – Obsolete
Estimator – Obsolete
Estimator - Obsolete
Paste Metafile from Clipboard
Tools, Spelling
Obsolete
Obsolete
Unused
Unused
Unused
Unused
Paste Bitmap from Clipboard
Insert, Bitmap from File
Layer Manager
Wall Style Manager
XClip
Insert, Stamp
Unused
Unused
Unused
Unused
Unused
Unused
Unused
Unused
Unused
Unused
Unused
Unused
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L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L
L

157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
188
190
192
194
195
196
197
198
199

Unused
Unused
Unused
Unused
Edit Symbol Fields
Save Symbol
Toggle Symbol Rotation On/Off
Replace Symbol
Save Symbol
Enlarge Symbol
Symbol Reports
Create Symbol Attribute
Hyperlink
Edit Symbol Attribute
2D Edit, Erase, Partial
2D Edit, Polygons, Rectangle
2D Edit, Text, Arrows
3D Entity, Drop Mesh
3D Entity, Polygons, Ruled Surface
3D Entity, Polygons, TIN Surface
3D Edit, Mirror
XClip
Insert Self-XREF
SClip
Insert Excel XLS
Insert SketchUp SKP
Extract 2D/3D
Set Object Snap Offset Distance
Polygons
Doors
Windows
Paste
Paste As Symbol
XREF Hide

A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A

1000#
1001#
1002#
1003#
1004#
1005#
1006#
1007#
1008#
1009#
1010#
1011#
1012#
1013#
1014#
1015#
1016#
1017#
1018#
1019#
1020#

2D Polygon Vertex On
2D Polygon Vertex Off
2D Polygon Diameter On
2D Polygon Diameter Off
2D Polygon Inscribe On
2D Polygon Inscribe Off
2D Polygon Rectangle On
2D Polygon Rectangle Off
Polyline Rectangle On
Polyline Rectangle Off
Symbol Browser On
Symbol Browser Off
Jamb In On
Jamb In Off
Clip Cube Ignore Z On
Clip Cube Ignore Z Off
One Line Trim by Entity On
One Line Trim by Entity Off
Offset Snap On
Offset Snap Off
Enter new Offset Snap distance
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A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A

1021#
1022#
1023#
1024#
1025#
1026#
1027#
1028#
1029#
1030#
1031#
1032#
1033#
1034#
1035#
1036#
1037#
1038#
1039#
1040#
1041#
1042#
1043#
1044#
1045#
1046#
1047#
1048#
1049#
1050#
1051#
1052#
1053#
1054#
1055#
1056#
1057#
1058#
1059#
1060#
1061#
1062#
1063#
1064#
1065#
1066#
1067#
1068#
1069#
1070#
1071#
1072#
1073#
1074#
1075#
1076#

Go to Polygon menu and do not change Rectangle status
Isometric
Assign Material (formerly Rendering Settings)
Auto3D ( Smart Walls ) On
Auto3D ( Smart Walls ) Off
Clears the command stack
Sets the current Solid Pattern Fill active
Sets Bitmap Fill active (if specified file exists)
Edit Materials
o2c Rendering Preferences
Material by Color
Material by Layer
Set the current wall type's control line to Outside
Set the current wall type's control line to Center
Set the current wall type's control line to Inside
Load material
Render by Layer open Material Assign. dialog
Render by Color open Material Assign. dialog
Launch Object Viewer
Turn Absolute Zero Indicator On
Turn Absolute Zero Indicator Off
View-dependency On
View-dependency Off
Suppress witness line 1 = TRUE
Suppress witness line 1 = FALSE
Suppress witness line 2 = TRUE
Suppress witness line 2 = FALSE
Text: Lock Size On
Text: Lock Size Off
Orthomode On
Orthomode Off
Set Texture Origin
Launch Sun Shader
Smart Arrows On
Smart Arrows Off
KnockOut On
KnockOut Off
KnockOut Border On
KnockOut Border Off
Display KnockOuts On
Display KnockOuts Off
Turn display of Smart wall hatch on
Turn display of Smart wall hatch Off
Turn display of Smart wall fill On
Turn display of Smart wall fill Off
Pen Sort On
Pen Sort Off
WYSIWYG On
WYSIWYG Off
Polyline Curves
KnockOut for Curves On
KnockOut for Curves OFF
KnockOut Border for Curves On
KnockOut Border for Curves OFF
KnockOut for Polygons and Slabs On
KnockOut for Polygons and Slabs Off

589

590 | APPENDIX
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A
A

1077#
1078#
1079#
1080#
1081#
1082#
1083#
1084#
1085#
1086#
1087#
1088#
1089#
1090#
1091#
1092#
1093#
1094#
1095#
1096#
1097#
1098#
1099#
1100#
1101#
1102#
1103#
1104#
1105#
1106#
1107#
1108#
1109#
1110#
3000#
3001#
3002#
3003#
3015#
3017#
3018#
3019#
3022#
3023#
3024#
3025#
3026#
3027#
3028#
3029#
3030#
3031#
3032#

KnockOut Border for Polygons and Slabs On
KnockOut Border for Polygons and Slabs Of
Hatch On
Hatch Off
Fill On
Fill Off
Bitmaps On
Bitmaps Off
Enable XClips On
Enable XClips Off
Enable SClips On
Enable SClips Off
Underline On
Underline Off
Overline On
Overline Off
Rendering Settings
3D Settings/DrawMarks On
3D Settings/DrawMarks Off
PText/MText Boundary On
PText/MText Boundary Off
Purge Unused Symbols
Reload All Symbols
Reserved
Wall Highlight On
Wall Highlight Off
Copy Multiple On
Copy Multiple Off
Dimension Auto Style "No Points" On
Dimension Auto Style "No Points" Off
Dimension Auto Style "Points Only" On
Dimension Auto Style "Points Only" Off
Inference Snapping On
Inference Snapping Off
Set Symbol X Enlargement Factor
Set Symbol Y Enlargement Factor
Set Symbol Z Enlargement Factor
Set Symbol X, Y, and Z Enlargement Factor
Launch Sun Shader
DWG Export, All Layers
DWG Export, On Layers
Command-line Alias
Save File
Save As
File Purge
Refresh Drawing
Regen Display List
Insert Symbol
Save Symbol
Pak-N-Go Create
Pak-N-Go Extract
Pak-N-Go Open
Pak-N-Go Settings
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(Pro) Creating Line Types
DataCAD allows you to use four standard line types and up to 256 user-defined line types. The
definitions for line types provided with DataCAD are located at the end of this section. These definitions
are located in \DATACAD\Support Files\Hatch Patterns\.
Anything you draw can be converted into a new line type. The line type creator lets you select entities (up
to 65,536) in your drawing to define one segment of a custom line type. After you create the new line
type, you can begin using it immediately.
 To create a new line type:
1.

Draw a line or pattern that you want to use as a new line type.

2.

Select Line Type from the Edit menu.

3.

Click on Create Line in the Line Type menu.

4.

Supply a name for the new line in the input box in the Message toolbar and press (Enter). You are
prompted to Select start point of line definition.

5.

Click in the Drawing Window. The Create Line menu expands to contain more options and you
are prompted to Select entity to be part of line definition. (Alternatively, you could use one of the
other selection types, such as group or area.)
Hint: DataCAD line types are created from left to right, so you should click in the Drawing
Window to the left of the line to indicate the start point of the definition.

6.

Click Finish when you are done selecting entities for your line definition. DataCAD provides a
suggested endpoint that is to the right of the start point. You are prompted to Select endpoint of
line definition.
Hint: The endpoint of the line type must be to the right of the start point, either at the exact end of
the line (if you want to reproduce that line/pattern without gaps) or slightly beyond the end of the
line (if you want a gap between repetitions of that pattern).

7.

Indicate the endpoint:


Click on the suggested endpoint if you do not want gaps between repetitions of that
line/pattern.



Pull the arrow beyond the end of the line/pattern if you want a gap between repetitions. Then
click.

8.

Select the line you created from the Line Type menu. Right-click to exit the Line Type menu.

9.

Draw with the line you created in your Drawing Window.
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Standard Line types

User-definable lines, 50 maximum

Standard

Name

Pattern

Line spacing values

Defined by:

Solid

N/A

Center

Dotted

1 = 1'-0" on center dots

Center

Dashed

1 = 1'-0" on center dashes

Center

Dot-Dash

1 = 1'-0" on center dot to dot

Center

ElecLine

1 = 1'-0" on center E to E

Center

TelLine

1 = 1'-0" on center T to T

Center

Box

1 = 1'-0" on center box to box

Center

PropLine

1 = 1'-0" on center double dashes

Center

Insul

0.3 = 6" width insulation

Center

Plywood1

0.0.3/4 = 3/4" width plywood

Left edge at line angle of 90°

Plywood2

0.0.1/2 = 1/2" wide plywood

Left edge at line angle of 90°

Hedge

1 = 4" wide line pattern

Center

CentrLin

1 = 1'-0" dash to dash

Center

Section

1 = 1'-0" on center breaks

Center

ShingleR

0.8 = 4" to the weather

Left edge at line angle of 270°

(for line length divisable by set spacing)

LapSidR

0.4 = 4" to the weather

Left edge at line angle of 270°

(for line length divisable by set spacing)

ShipLap

0.4 = 4" to the weather

Left edge at line angle of 270°

(for line length divisable by set spacing)

Brick

0.8 = 4" nominal brick width

Left edge at line angle of 90°

4Block

0.8 = 4" nominal brick width

Left edge at line angle of 90°

8Block

0.8 = 8" nominal block width

Left edge at line angle of 90°

12Block

0.8 = 12" nominal block width

Left edge at line angle of 90°

RigidIns

0.2 = 2" thickness

Left edge at line angle of 90°

Grass

0.5 = 3" high grass

Lower edge at line angle of 90°

GroundLn

1 = 6" between pattern breaks

Lower edge at line angle of 90°

ShingleL

0.8 = 4" to the weather

Right edge at line angle of 270°

(for line length divisable by set spacing)

LapSidL

0.4 = 4" to the weather
(for line length divisable by set spacing)

Right edge at line angle of 270°
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Standard Hatch Patterns
Hatch patterns included with DataCAD are pictured below.

Angle

31

32

33

34

35

36

37

38

Box

Brass

Brick
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(Pro) Creating Keyboard Shortcuts
You can use keyboard shortcuts for quick navigation or to perform functions. Shortcuts have also been
called keyboard macros, keyboard interrupts, accelerator keys, hot keys, and immediate mode
commands. To set up your own shortcuts, see "Defining Shortcuts" below.
In this manual, all keyboard shortcuts are described exactly how they should be executed. If a shortcut
requires a lowercase letter, you will be instructed to press only that letter. If a shortcut requires an
uppercase letter, you will be instructed to press (Shift) and that letter. (If Caps Lock is on, you can just
press the letter.) In some cases, both the uppercase and lowercase letter perform the same function.
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In the following table, the Mnemonic column provides an easy way to remember some of the shortcuts.
Some shortcuts, like Copy, are noted as being “2D/3D.” In this case, when you use the shortcut from a 2D
menu, you'll open the 2D Copy menu. Similarly, using the shortcut while in a 3D menu takes you to the
3D Copy menu.

(Pro) Defining Shortcuts
To define your own shortcuts, edit the file DCADWIN.MCR in the \DATACAD\Support Files\ folder
using a text editor. You can only define shortcuts that use a letter in combination with (Alt). You cannot
define shortcuts that are accessed by a single letter or those that use a letter in combination with (Shift).
You may have some older keyboard shortcuts that include (Alt) + 183 near the beginning of the line and
end with (Alt) + 184. This was used to turn off menu display to increase the speed of shortcut execution in
DataCAD for DOS. It is no longer needed in DataCAD for Windows, although these shortcuts will still
function normally in DataCAD for Windows.
Define each shortcut key on a separate line. The following line defines a shortcut to Enlarge:
E^;^f6


The first character E, indicates the key that will start the shortcut. Pressing the character E will call the
shortcut. This will also supersede the command that E currently does.



The semicolon indicates that the command is in the Edit menu; a colon would indicate the Utility
menu.



The caret (^) separates each step through the menu structure.



F6 indicates the function key that loads the Enlarge option on the Edit menu.



If the function were on a menu under Enlarge, you would follow the F6 with an additional caret,
followed by the appropriate function key on the next menu.

See “Using the Command Line Alias” in “The Drawing Board” chapter for more information on
keyboard shortcuts.
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Standard Keyboard Shortcuts
FUNCTION/MENU
2 Line Trim menu
3D Menus
3D Entity menu
3D Views menu
Active layer, scroll
backward to set
Active layer, scroll forward
to set
Append selection set toggle
Architect menu
Cap wall ends toggle
Center screen to cursor
location
Change menu
Colors, scroll backward
Colors, scroll forward
Coordinate entry
Copy to clipboard
Copy menu (2D/3D)
Cursor size toggle (big vs.
regular)
Curves menu
Cut to clipboard
Digitizer
Dimensions menu
Dimensions, Linear menu
Directory of current
drawing dialog box
Display list, regenerate
Display associated saved
view
Edit menu
Sel. Sets menu
Elevation, back
Elevation, front
Elevation, left
Elevation, right
Enlarge menu
Erase last entity
Erase last group
Erase menu (2D/3D)
Exit
Fillets menu
Freehand menu
Geometry menu
GoTo View menu
Grids menu

MNEMONIC
Join

Views

KEY(S)
(Alt) + (J)
(J)
(J) or (Alt) + (U)
(Y) or (Shift) + (V) or (Alt) +
(V)
(Shift) + (Tab)
(Tab)

Append
architect

(Shift) + (A)
(A)
(|)
(Home)

Change
Kolors
kolors

(Alt) + (C)
(Shift) + (K)
(K)
(SpaceBar)
(Ctrl) + (C)
(C) or (Shift) + (C)
(+)

Copy
Copy

Arcs
digitIzer
Dimension
Dimension
directorY

(Alt) + (A)
(Ctrl) + (X)
(I)
(D) or (Shift) + (D)
(Alt) + (D)
(Alt) + (Y)
(U) or (Shift) + (U)
(Shift) + (1) to (0)

Selection sets

Enlarge

Erase
Fillets
freeHand
Geometry
View
Grids

(;)
(Shift) + (S)
(Ctrl) + (PgUp)
(Alt) + (=)
(F11)
(F12)
(Alt) + (E)
(,)
(<)
(E) or (Shift) + (E)
(Ctrl) + (F4)
(Alt) + (F)
(Alt) + (H)
(Alt) + (G)
(V)
(G) or (Shift) + (G)
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Hatching menu
Help
Hide menu
Identify
Input mode:
1 : Relative Polar (distance,
angle)
2 : Absolute Polar (distance,
angle)
3 : Relative Cartesian (x, y
coordinates)
4 : Absolute Cartesian (x, y
coordinates)
Layer search toggle
Layers menu
Line overshoot amount
Line overshoot toggle
Line spacing, set
Line Type menu
Line types, scroll backward
in the Status Panel toolbar
Line types, scroll forward in
the Status Panel toolbar
Line weight, decrement
Line weight, increment
Group menu
Measures menu
Mirror menu (2D)
Move menu (2D/3D)
Multi-view windows
New drawing, create
Object snap
Object Snap menu
Object Snap perpendicular
toggle
Online Help
Open Files
Ortho mode toggle
Orthographic View
Pan
Parallel View, most recent
Paste from clipboard
Perspective View, most
recent
Plotter menu
Polygons menu
Previous view, restore
Print
Quit

Hatch

Identify

Layers

Line type

(H) or (Shift) + (H)
(Ctrl) + (F1)
(Shift) + (Y)
(Shift) + (I) or (Alt) + (I)
(Insert)

(')
(L) or (Shift) + (L)
(_)
(-)
(F)
(Alt) + (L)
(Shift) + (Q)
(Q)

BIG Weight to small
little Weight to big
linK
Mirror
Move
multi-view Windows
New
sNap
Object snap

Open
Orthogonal
orthographic

Plotter
Rectangle
Previous
Print
Quit

(Shift) + (W)
(W)
(Alt) + (K)
(Alt) + (X)
(Alt) + (M)
(M)
(Ctrl) + (W)
(Ctrl) + (N) or (Alt) + (N)
(N) or (Shift) + (N)
(Shift) + (X)
(Alt) + (O)
(Ctrl) + (F1)
(Ctrl) + (O)
(O) or (Shift) + (O)
(Alt) + (0)
Arrow keys (up, down,
right, and left)
(Alt) + (9)
(Ctrl) + (V)
(Alt) + (-)
(Alt) + (P)
(Alt) + (R)
(P) or (Shift) + (P)
(Ctrl) + (P)
(Alt) + (Q)
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Redo
Reference point entry
Restore last erased entity
Restore last erased group
Rotate menu (2D/3D)
Save current drawing
Screen refresh
Screen refresh by layer, stop
Screen refresh, stop
Select
Selection set, change active
Snap grid spacing, set
Snap grid toggle
Snapping point entry
Stretch menu
Symbol, insert by name
Tangents menu
Templates menu
Text menu
Toolbox menu
Disp. Scale menu
Undo
Utility menu
Wall T intersection clean-up
toggle
Walls toggle and set new
wall thickness
Weld Line menu
Zoom menu
World coordinate identify
Z-base or Z-height attribute
entry
Zoom Extents
Zoom In
Zoom Out

Rotate
Save File

sElect
spacing

Stretch

Template
Text
Macros
Zoom

(Ctrl) + (Y)
(`)
(.)
(>)
(R) or (Shift) + (R)
(Ctrl) + (S) or (Shift) + (F)
(Esc)
(End)
(Del)
(Ctrl) + (E)
(Alt) + (1) to (8)
(S)
(X)
(~)
(Alt) + (S)
(")
(B) or (Shift) + (B)
(T) or (Shift) + (T) or (Alt) +
(B)
(Alt) + (T)
(Shift) + (M)
(Alt) + (Z)
(Ctrl) + (Z)
(:)
(\)
(=)

Weld

Z-base/Z-height

(Alt) + (W)
(/)
(?)
(Z) or (Shift) + (Z)
(Ctrl) + (-)
(PgDn)
(PgUp)

Creating Keyboard Shortcuts for Pull-down Menu Options
You can create keyboard shortcuts for any of the 250+ pull-down menu selections by editing the
DCADWIN.MNU file. The format of the menu file is Label|Shortcut|Hint. Any shortcut you add to the
MNU file will supersede any existing DataCAD shortcut if they are the same. The following key
sequences are supported.
(0-9)
Example: Open|5|Open Existing File
(A-Z)
Example: Open|E|Open Existing File
(F1-F12)
Example: Open|F5|Open Existing File
([CTRL] + (0-9), (A-Z), (F1-F12))
Example: Open|CTRL+5|Open Existing File
Example: Open|CTRL+E|Open Existing File
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Example: Open|CTRL+F5|Open Existing File
([CTRL] + [SHIFT] + (0-9), (A-Z), (F1-F12))
Example: Open|CTRL+SHIFT+5|Open Existing File
Example: Open|CTRL+SHIFT+E|Open Existing File
Example: Open|CTRL+SHIFT+F5|Open Existing File
([CTRL] + [ALT] + (0-9), (A-Z), (F1-F12))
Example: Open|CTRL+ALT+5|Open Existing File
Example: Open|CTRL+ALT+E|Open Existing File
Example: Open|CTRL+ALT+F5|Open Existing File
([SHIFT]
Example:
Example:
Example:

+ (0-9), (A-Z), (F1-F12))
Open|SHIFT+5|Open Existing File
Open|SHIFT+E|Open Existing File
Open|SHIFT+F5|Open Existing File

([ALT] +
Example:
Example:
Example:

(0-9), (A-Z), (F1-F12))
Open|ALT+5|Open Existing File
Open|ALT+E|Open Existing File
Open|ALT+F5|Open Existing File

([ALT] +
Example:
Example:
Example:

[SHIFT] + (0-9), (A-Z), (F1-F12))
Open|ALT+SHIFT+5|Open Existing File
Open|ALT+SHIFT+E|Open Existing File
Open|ALT+SHIFT+F5|Open Existing File

([CTRL] + [ALT] + [SHIFT] + (0-9), (A-Z), (F1-F12))
Example: Open|CTRL+ALT+SHIFT+5|Open Existing File
Example: Open|CTRL+ALT+SHIFT+E|Open Existing File
Example: Open|CTRL+ALT+SHIFT+F5|Open Existing File
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Standard Fonts
DataCAD includes the following fonts; the first column lists the font name, while the second column
provides examples of upper- and lowercase characters.
ARCDR2GP

The quick brown fox jumps over a lazy dog.

ARCWY2FW

The quick brown fox jumps over a lazy dog.

ARCWY2GP

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ARCWY2HC

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ARCWY2LC

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ARCWY2TX

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

BLOCK

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

COMPLEX

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

HLV_BP

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

HLV_LP

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

HLV_MP

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

HLV_TM

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

HLV_TP

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

HLV_TPX

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

MCG_TP

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ORIG

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ORIG2

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ROMAN

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ROMAN2

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ROMANC

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

ROMANS

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

SIMPLEX

THE QUICK BROWN FOX JUMPS OVER A LAZY DOG.

Extended characters
Five DataCAD fonts feature extended characters. This allows you to include common drafting symbols,
fractions, and exponents in your text:
ARCDR2GP
ARCWY2GP
ARCWY2HC
ARCWY2LC
HLV_TPX

ArcDraft General Purpose
ArcWyde General Purpose
ArcWyde Heavy Chisel
ArcWyde Light Chisel
Helvetica Thin Proportional with extended characters

The following chart shows the drafting symbols, exponents and fractions you can include in your text.
 To create drafting symbols and exponents:
1.

Toggle NumLock on. The indicator light on your keyboard will be green if NumLock is on. If
NumLock is not toggled on, you will not be able to create the drafting symbols and exponents.

2.

Press (Alt) and hold it down while you type the corresponding four-digit number using the
numeric keypad. The four-digit number always begins with zero. Do not use the number keys
above the letters on your keyboard.
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If you'd like to change your font but you've used extended characters in your text, make sure the new
font also includes the extended characters. If you choose a font that does not include the extended
characters, the content of your text may be changed.
To create fractions, use the Exponent/Numerator column of the chart to enter the numerator of your
fraction; use the Denominator column to draw the denominator and the division sign. For example, to
draw a fraction of 5/16 in your text, hold down (Alt) and type 0135 using the numeric keypad. When you
release (Alt), the 5 will appear. Depress (Alt) again and type 0153 on the numeric keypad. The fraction is
completed when you release (Alt).
Drafting Symbol

Diameter

Exponent /
Numerator

Square Feet

01
14
40
40
1
01
14
41

Property Line

01
142

Center Line

01
14
43

With

01
14
44

Denominator

01
13
30

01
15
50

01
13
31

01
15
51

01
13
32

01
15
52

01
13
33

01
15
53

01
13
34
01
13
35
01
13
36

Degree

01
14
45
01
13
37

Plus-or-minus

01
14
46

Angle

01
16
60

01
13
38
01
13
39

Inserting Symbols in Drawings without the Symbol Browser
You can use two other symbol insertion methods; these existed prior to DataCAD 11. Using the Insert
pull-down menu is faster, but using the Utility/Templates menu offers you more options for working
with your symbols.
If you prefer to use this old-fashioned method, you should close your Symbol Browser to avoid
confusion. Just click on the “X” in the upper right corner of the Symbol Browser to make it disappear.
 To insert a symbol into your drawing using the Insert menu:
1.

Click on Symbol in the Insert pull-down menu. A dialog box appears, listing all symbol folders in
your DataCAD\Symbols folder.
Shortcut: Press (“) (the double quotation key) to insert a symbol.

2.

Double-click on a symbol folder to open it and display those symbols.
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3.

Click on the name of the symbol you want to use; if Show Preview is checked, a preview of the
selected symbol appears in the preview window on the right side of the dialog box. The symbol
preview displays in either orthographic (plan) or isometric view, depending on the Isometric
View checkbox in the Insert Symbol dialog box.

4.

Click on Open or press (Enter). The dialog box closes and the left menu offers options for editing
the symbol. Notice that a box representing the extents of the symbol is now attached to your
cursor at the symbol’s insertion point.

5.

Change the symbol’s size if necessary. Before you place the symbol in your drawing, you can
increase or decrease the size of an entity by entering specific enlargement values for the X, Y, and
Z axes:

6.



To resize the symbol while maintaining its original scale, increase the X Enlargmnt., Y
Enlargmnt., and Z Enlargmnt. values equally



To adjust the size of the symbol along the X axis, click on X Enlargmnt. Use the value menu
or type an enlargement factor and press (Enter).



To adjust the size of the symbol along the Y axis, click on Y Enlargmnt. Use the value menu
or type an enlargement factor and press (Enter).



To adjust the size of the symbol along the Z axis, click on Z Enlargmnt. Use the value menu
or type an enlargement factor and press (Enter).

Rotate the symbol either by dynamically positioning it or by setting a specific rotation angle for
the symbol. The symbol is rotated around the insertion point, the point where the symbol is
attached to your cursor.


To dynamically rotate the symbol into position when you place it in your drawing, toggle
Dyn. Rotate on.



To set a specific rotation angle, toggle Dyn. Rotate off. Use the value menu or type an angle
and press (Enter).

7.

Convert the symbol into standard and separate lines and arcs when you place it in your drawing
by toggling Explode on.

8.

Place the symbol by clicking in the Drawing Area, using coordinate entry, or object snapping to a
point in your drawing. The symbol is inserted into your drawing. For details on coordinate entry,
see “Drawing Using Coordinate Entry” in “The Drawing Board” chapter. For details on object
snapping, see “Object Snapping” in the “Drawing Tools” chapter.

9.

Repeat the previous step to continue placing the symbol in your drawing or right-click to exit the
menu.

Finding and Using Older Template and Symbol Files
Before using Templates, you need to configure DataCAD 18 to look into your previous version’s
installation folder to find the template and symbol files.
 To configure DataCAD version 11 and higher to find template and symbol files from older versions:
1.

Select Program Preferences from the Tools pull-down menu and click on the Pathnames tab.

2.

Set the path for Templates to C:\DataCAD\TPL\, assuming that is the folder in which the earlier
version is installed.

3.

Set the path for Symbols to C:\DataCAD\, leaving the SYM part off because it is already
included in the symbol paths for each of the files associated with the template.
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 To insert a symbol into your drawing using the Templates menu:
1.

Right-click until the Utility menu appears.

2.

Click on Templates in the Utility menu. A dialog box appears.
Shortcut: Press (T) to open the Template menu.

3.

Locate the template you’d like to use and click on it to select it. The templates that come with
DataCAD are in your DataCAD\Templates folder.

4.

Click on Open or press (Enter). The template appears on the right side of the Drawing Area and
the Templates menu appears.

5.

Rotate the symbol into position either dynamically or by setting a specific rotation angle. The
symbol is rotated around the insertion point, the point where the symbol is attached to your
cursor.

6.



To dynamically rotate the symbol into position when you place it in your drawing, toggle
Dyn. Rotate on.



To set a specific rotation angle, toggle Dyn. Rotate off. Use the value menu or type an angle
and press (Enter).

Change the symbol size if necessary by clicking on Enlarge in the Templates menu. Before you
place a symbol in your drawing, you can increase or decrease the size of an entity by entering
specific enlargement values for the X, Y, and Z axes:


To enlarge entities along the X axis, click on X Enlargmnt. Use the value menu or type an
enlargement factor and press (Enter).



To enlarge entities along the Y axis, click on Y Enlargmnt. Use the value menu or type an
enlargement factor and press (Enter).



To enlarge entities along the Z axis, click on Z Enlargmnt. Use the value menu or type an
enlargement factor and press (Enter).



To set the line spacing enlargement factor for nonsolid line types, click on Line Factor. Use
the value menu or type a line factor and press (Enter). The Line Factor setting affects how
line types like Dashed are enlarged. A setting matching those of the X, Y, and Z enlargement
factors will maintain the line type’s spacing.



To set all of these options to the same setting and enlarge the entity equally in all directions,
click on Set All. Use the value menu or type an enlargement factor and press (Enter).

7.

Decide if you need to place symbols above or below the current Z-base. For example, when
placing tree symbols on a 3D site plan, you can change the Z Offset option to enter the trees at the
proper elevation. To set the vertical distance above or below the correct Z-base where you’d like
to insert your symbols, click on Z Offset. Use the value menu or type an offset value and press
(Enter). Enter a positive value to place the symbol above the current Z-base; enter a negative
value to place the symbol below the current Z-base.

8.

Decide if you want to change the symbol. Normally, symbols are placed in your drawing as a
single entity, so DataCAD doesn’t recognize the individual lines and arcs that make up the
symbol. To be able to edit a symbol in your drawing, you must explode (or convert) the symbol
into separate lines and arcs. To convert the symbol into separate lines and arcs when you place it
in your drawing, toggle Explode on.
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Note: This will only explode those symbols entered into your drawing after Explode is toggled on.
Exploded symbols appear the same as standard symbols, but DataCAD recognizes only the
individual lines and arcs that make up the symbol and not necessarily their relationship to each
other.
9.

Select a symbol from the template by moving your cursor over the symbol you want to use and
clicking. A box, representing the extents of the symbol, is attached to your cursor at the symbol’s
insertion point. The symbol’s insertion point is marked by a small “x” once you place the symbol
in your drawing.
You can object snap to any point on a symbol to select an insertion point other than the one
associated with the symbol definition. This is especially useful if you want to align a symbol with
another entity in your drawing. Simply snap to the symbol in the template and then snap to the
entity in your drawing to place the symbol.

10. Place the symbol in your drawing by clicking in the Drawing Area, using coordinate entry, or
object snapping to a point in your drawing. The symbol is inserted into your drawing.
11. Repeat the previous step to continue placing the symbol in your drawing or right-click to detach
from the symbol.
12. Open a different template if necessary by clicking on New File and selecting another template file
from the dialog box.
13. Close the template window by clicking on Template Off.
More About Templates and Symbols
Each template is a graphic representation of the template (.TPL) file and appears with a number of
divisions, each containing a symbol. The template file itself is a simple text file containing the name of the
file, the number of rows and columns in the template, and the paths to the symbols associated with that
template. When you select a template, the symbols associated with that template file appear in the
template window.

Creating and Editing Templates
Templates are a very effective way to organize a library of pre-drawn items, which you can use in many
different projects. You can create a template with symbols that you use frequently or one that supports
office standards. See “More About Creating Templates” for details on defining information fields.
Each template has information fields defined specifically for that template. Whenever you add a symbol
to that template, you can enter information describing that symbol in each field. There are six standard
information fields that are defined for every template, but you can define an unlimited number of
additional fields.
 To create a template:
1.

Click on Templates in the Utility menu; or if you’re already in the Template menu, click on New
File. A dialog box appears.
Type a name for your new template and click on Open or press (Enter). The dialog box closes and
you are prompted with Create new file?

3.

Click on Yes to create the template. The Field 7 menu appears and you are prompted with Field
name. All templates have six standard fields automatically defined for them.
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4.

Decide whether you want to define additional information fields or simply create the template
with only the standard six fields. To use only the standard fields, right-click and skip to step 7. To
enter an additional field, type a name for the field (up to 20 characters) and press (Enter). A list of
field data types appears and you are prompted to Select field type.

5.

Notice that there are three field types available: Text, Number, and Dollar. To create a field that
you can enter letters and numbers into, click on Text. To create a field that you can enter an
integer into, click on Number. To create a field that you can enter a real number with two fixed
decimal places, click on Dollar. Numbers entered in a text field cannot be used in any
calculations.

6.

Repeat steps 4 and 5 to continue entering information fields.

7.

Right-click when you’ve completed entering fields. The template is created and displayed at the
right side of the DataCAD window and the Templates menu appears. For information on how to
add symbols to your new template, see “Creating and Editing Symbols” later in this chapter.

More About Creating Templates
When you create a template, DataCAD automatically defines six information fields:
Field Name
Item nam
Manufact
Model No
Remark 1
Remark 2
Cost

Field Type
Text
Text
Text
Text
Text
Dollar

You can create an unlimited number of additional information fields when you create a template. This is
the only time you can define information fields; once the template is created, you can’t add another field
or delete a field, nor can you change the field’s name or type.
While you can’t change the fields themselves, you can always edit any information you’ve entered into a
field. All fields you create can accept up to 80 characters of information.

Editing Templates
Templates you create in DataCAD have a standard number of divisions: three columns and 12 rows. Once
you’ve created a template, you can change the number of divisions to suit your needs.
The number of divisions in a template doesn’t have to equal the number of symbols associated with that
template. You can have more divisions than symbols, in which case some of the divisions in your
template will be empty. You can also have fewer divisions than symbols, so that not all symbols
associated with that template will be displayed at once. Displaying fewer symbols will also increase
refresh times.
 To change the number of divisions in a template:
1.

Create your template. Then click on Divisions in the Templates menu. You are prompted to Enter
number of columns.

2.

Use the value menu or type the number of columns for your template and press (Enter). You are
prompted to Enter number of rows.

3.

Use the value menu or type the number of rows for your template and press (Enter). The
template is updated with the new divisions and you are returned to the Templates menu.
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Creating and Editing Symbols
Creating and editing symbols is a very effective way to build a library of pre-drawn items that you can
use in many different projects. You can draw a lighting fixture, create a symbol from the fixture geometry
and add it to a template, and then very quickly place several instances of that fixture in your drawing.
To quickly determine the exact path and folder name of a symbol, click on Symbol Name in the
Templates menu and then click on the symbol.
You can also enter descriptive information about each symbol and then edit that information. You can
even replace symbols in your drawing with others in your symbol library.
 To create a symbol and add it to a template:
1.

Click on Templates in the Utility menu. The Templates menu appears.
Shortcut: Press (T) to display the Templates menu.

2.

Click on Save Symbol. If the Attention toolbar informs you that a file doesn’t exist and asks if you
want to Create it?, click on Yes. A dialog box appears, prompting you to Enter name of symbol file to
be saved. Symbol folders are stored in your DataCAD\Symbols folder.

3.

Make sure the folder that’s open in the dialog box is the one you want to save the symbol in. If it’s
not, change to the proper folder.

4.

Type a name for your symbol and click on Save or press (Enter). The Save Symbol menu appears.
Use Save Symbol to select either symbols already in your drawing or geometry you want to make
into a symbol; both types of selection will be added to the currently displayed template.

5.

Choose a selection method and then select the parts of your drawing you want to make into a
symbol. When you are finished selecting the entities to add to the symbol, click on Continue. You
are prompted to Select an insertion point for symbol.

6.

Select the reference or insertion. You can click in the Drawing Area, use coordinate entry, or
object snap to a point in your drawing. The entities you selected are copied into the first open
space in the template; if there are no open spaces in the currently displayed template, the symbol
can’t be displayed in that template until you increase the number of template divisions. A dialog
box appears.

7.

Enter a name for your symbol in the Item name field. Supply information for additional fields.
You can use the New button to add more fields; you can use the Delete button to eliminate
existing fields.

8.

Click on OK when you are finished supplying information about the symbol. A dialog box
appears and you are asked to Enter name of symbol file to be saved.

9.

Supply a name in the File name field and click on Save or press (Enter).

10. Continue with step 3 above to save additional symbols.

Editing Symbols
To edit symbols, you must first explode or convert them into individual lines and arcs. You can do this
when you insert the symbol into your drawing or after the symbol has been inserted. Once the symbol
has been edited, you can reform the symbol lines and arcs into a single symbol entity, copy it back into
the template, and then update the symbols already in your drawing.
 To explode a symbol when you place it in your drawing and edit it:
1.

Click on Templates in the Utility menu. Then click on New File in the Templates menu. A dialog
box appears, allowing you to choose a template to open.
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2.

Click on the template you want to use and click on Open. The template appears on the right side
of the Drawing Area.

3.

Toggle Explode on in the Templates menu.

4.

Click on the symbol in the template that you want to insert into your drawing.

5.

Place the symbol in your drawing. You can click in the Drawing Area, use coordinate entry, or
object snap to an entity in your drawing. The symbol is copied to your drawing and
automatically exploded into separate entities.

6.

Edit the symbol geometry as necessary. For more information on editing lines and arcs, see the
“Editing Drawings” chapter.

7.

Copy your changes back to the template. Click on Redefine in the Templates menu. You are
prompted to Select symbol in template to redefine.

8.

Click on the symbol in the template that you just edited in the Drawing Area. A selection menu
appears and you are prompted to select the geometry you want to be your new symbol.

9.

Choose a selection method and then select the geometry for the symbol. Your selection is
highlighted with dashed lines. If necessary, continue selecting geometry until all entities that you
want to be included in the new symbol are highlighted.

10. Click on Continue to go on with the symbol definition process. You are prompted to Select an
insertion point for symbol.
11. Click in the Drawing Area or use coordinate entry to select the point that will be used to insert
the symbols in drawings. The edits to the symbol are copied to the template.
12. Update all instances of that symbol in your drawing. Click on Reload in the Templates menu. You
are prompted to Select symbol in template to reload.
13. Click on the symbol in the template that you want to reload or click on All in the Reload menu to
reload all symbols in your drawing.

Editing Information Fields
You can edit information associated with symbols by selecting a symbol in a template or one that’s
already in your drawing. Use the Reports option in the Templates menu to extract symbol information for
all symbols used in your drawing and create specification reports or cost estimates.
 To edit symbol information:
1.

Open the template that the symbol (whose information you want to edit) is associated with.

2.

Click on Edit Fields in the Templates menu.

3.

Click on the symbol, either in the template or in your drawing, whose information you want to
edit. The fields for that symbol appear in the dialog box.

4.

Click on the field you want to edit.

5.

Type the new information for that field and press (Enter).

6.

Repeat steps 4 –5 to continue changing field information as necessary.

7.

Edit information for another symbol by right-clicking and continuing with step 3 above. Rightclick twice to exit back to the Templates menu.
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 To edit symbol information:
1.

Click on FormAtr in the Toolbox pull-down menu. The FormAtr menu appears. If FormAtr is not
listed in your Toolbox menu, click Configure in the Macros menu and add it to the Macros in
Menu list.

2.

Click on Symbols in the FormAtr menu. You are prompted to Select symbol to edit attribute fields.

3.

Click on the symbol. The symbol’s information appears in the Drawing Area.

4.

Press (Tab) to move the edit box to the text you want to change.

5.

Type the new text and press (Enter). The information is changed.

6.

Repeat steps 4 – 5 to continue editing.

7.

Press (Esc) to exit editing and return to your drawing. You are prompted with Do you wish to
update symbol file [symbol path and filename]?

8.

Click on Yes to update the symbol information; click on No to cancel the changes.

Replacing Symbols in Your Drawing
You can replace one symbol in your drawing with another and choose whether to replace one instance of
that symbol or all instances throughout your drawing. This is useful if you’ve entered one type of
bathroom sink throughout your drawing and you need to replace it with another type.
 To replace one symbol with another symbol:
1.

Click on Templates in the Utility menu. The Templates menu appears.

2.

Click on Replace in the Templates menu. The Replace menu appears and you are prompted to
Select symbol to replace.

3.

Click on the symbol in your drawing that you want to replace. You are prompted to Select symbol
to replace with.

4.

Choose the new symbol that will replace the original by clicking on a symbol in a template or on
one that’s already in your drawing. A selection menu appears.

5.

Replace only particular instances of the symbol you selected in step 3 or replace all instances of
that symbol. To choose particular instances of the symbol, choose a selection method from the
menu and continue with the next step. To replace all instances of the symbol, click on All; all
instances of the symbol are immediately replaced and you can skip to step 7.

6.

Select each instance of the symbol that you want to replace. Each symbol is replaced as you select
it.

7.

Finish replacing symbols. Right-click to return to the Templates menu.

 To replace several different symbols with another symbol:
1.

Click on Templates in the Utility menu. The Templates menu appears.

2.

Click on Replace in the Templates menu. The Replace menu appears and you are prompted to
Select symbol to replace.

3.

Click on Any Symbol in the Replace menu. You are prompted to Select symbol to replace with.

4.

Choose the new symbol that will replace the original by clicking on a symbol in a template or on
one that’s already in your drawing. A selection menu appears.
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5.

Select each symbol you want to replace or replace every symbol in your drawing. To choose each
symbol, choose a selection method from the menu and continue with the next step. To replace all
symbols, click on All; all symbols in your drawing are immediately replaced.

6.

Select the symbols to be replaced. Each symbol is replaced as you select it.

7.

Finish replacing symbols. Right-click to exit the Replace menu and return to the Templates menu.

Deleting Symbols
You can erase symbols from your drawing or delete them from a template.
 To erase a symbol:
1.

Click on Erase in the Edit menu. The Erase menu appears.

2.

Toggle Layer Search on if the symbols you want to erase are on a layer other than the active layer.

3.

Click on a selection method in the menu. You are prompted to select the entities you want to
erase.

4.

Select the symbols; they are erased from the drawing. You can continue selecting symbols to erase
them. Avoid selecting a symbol where it crosses another entity because it may be difficult for
DataCAD to know which entity you want to select. Zoom in on your drawing or change your
view to select symbols more precisely.

5.

Finish erasing symbols. Right-click to exit the Erase menu.

 To delete a symbol from a template:
1.

Click on Templates in the Utility menu. A dialog box appears, allowing you to choose a template
to open.

2.

Click on the template with the symbol you want to delete and click on Open. The template
appears on the right side of the Drawing Area and the Templates menu appears.

3.

Click on Del. Symbol in the Templates menu. You are prompted to Select symbol to delete from this
template file.

4.

Click on the symbol you want to delete from the template. You are asked to confirm your
selection.

5.

Click on Yes to delete the symbol; click on No to cancel the function.

6.

Continue selecting symbols to delete them from the template or right-click to exit the Del. Symbol
menu.

More About Erasing Symbols
When you erase symbols from your drawing, it’s important to purge the symbol from your drawing as
well. When you add a symbol to your drawing, DataCAD associates that symbol with your drawing. This
association is not deleted when you erase the symbol and continues to take up drawing file space. To
delete the association as well, you must use the Purge Symbol option in the Templates menu.
 To purge symbol associations from your drawing:
1.

Click on Purge Symbol in the Templates menu. You are asked Are you sure you want to purge
unused symbols?

2.

Click on Yes to purge the associations with symbols that have been deleted; click on No to cancel
the function.
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3D face
The surface of a solid specified with 3D points.
3D mesh
A polygon mesh composed of vertices connected by lines.
3D polyline
Polylines with segments oriented in 3D space.
arc
A continuous section of a curved line.
area
Any part of a drawing within a rectangular window that is temporarily drawn during the selection
process. All entities and groups enclosed completely within this rectangular window are included in
the area. All entities and groups partially enclosed or not enclosed within the rectangular window are
not included in the area.
Attention toolbar
A toolbar that supplies helpful information and/or hints pertaining to the DataCAD function you are
using. You can move this toolbar anywhere in the DataCAD screen or onto your desktop.
attribute
A single value or characteristic associated with an entity.
bulge
A curved portion of a polyline.
center marks
Small marks displayed to define the exact center of arcs and circles. You can also use center marks
with object snapping.
click
To position the cursor over a selection and press and release a mouse button (usually the left button).
This command usually refers to selecting or deselecting an option.
choose
To select a command or option from the Menu Window.
command
An instruction from the user to the computer to perform a function. A command is usually selected
from the Menu Window or the Menu Bar.
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Context-sensitive toolbar
A toolbar that appears when you perform various functions. For example, it could provide icons for
Cleanup, Architect, Door swing, Window, Polyline, and Model options. You can also create your own
context-sensitive toolbar. You can move this toolbar anywhere in the DataCAD screen or onto your
desktop.
Coordinates/Hints toolbar
A toolbar that supplies helpful information and/or hints pertaining to the DataCAD function you are
using. The hints usually mirror the tooltips for DataCAD menu items. When it isn’t displaying hints,
this toolbar shows the coordinates that describe your cursor’s current position. Additionally, this
toolbar provides the Z-base and Z-height. You can move this toolbar anywhere in the DataCAD
screen or onto your desktop.
cursor
A graphic symbol displayed on the screen to show the location of the mouse.
default
Any setting or value that is preset by DataCAD.
Default toolbars
Two default user-definable toolbars can be active simultaneously. You can move these toolbars
anywhere in the DataCAD screen or onto your desktop.
dimension line
Also called the string line, the dimension line consists of a straight line parallel to the points to
dimension. The dimension line also contains text showing distance information and termination
marks, consisting of arrows or tick marks drawn at a 45 angle.
division
A graphical aid used in cylindrical balusters, newel posts, or hand rails to help you better visualize
the cylinder.
doughnut (donut)
A circular object with hole in the center, composed of two concentric circles and a filled center.
Drawing Window
The area of the screen that is reserved for your drawing.
elevation
The height of an object. It defines the object's position in the direction of the Z-axis.
Also, an orthographic view that shows the front, back, right, or left sides of an object.
entity
A straight or curved geometric element defined by two endpoints. A circle, ellipse, or arc is an entity,
as is a B-spline or Bezier curve. A line of text is also considered an entity in editing operations. Edit
entities alone or when linked as a group.
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extension line
Extension lines typically run from the object you dimension to the line where the dimension appears.
Extension lines are used only for linear and angular dimensioning. You can control the length of the
extension line. DataCAD typically draws one extension line at each end of a dimension line, but you
can suppress the line.
extents
The outer-most edges of a drawing. To “display a drawing at its extents” means to adjust the view so
that the drawing fills the Drawing Window as much as possible while still displaying it in its entirety;
the outer-most edges of the drawing will fit just inside the frame of the Drawing Window. Clicking
the E in the Navigation Pad does this automatically.
fence
Similar to an area but allowing more flexibility, a fence is any portion of a drawing within a closed
polygon that you draw during the selection process. You can select using a concave or convex
polygon having up to 36 sides.
fit
Specified fixed height of text that expands or contracts to the character width between designated
points only.
function keys
Function keys, (F1) through (F12), are located on the keyboard and are used to enter commands. In
DataCAD, they are associated with the commands that appear in the Menu Window. You can select
these commands by pressing the associated function key on the keyboard.
(S1) through (S0) provide access to ten additional commands, selected on the keyboard by holding
down (Shift) while pressing the appropriate function key.
grids
Use display and snap grids to make cursor movement and positioning more accurate. The flexibility
and control of grids are critical to computer-aided design.
group
A group is a set of entities linked together logically but not necessarily graphically. Entities that do
not touch may be part of the same group, and entities that are contiguous may be part of different
groups. A group may contain any number of entities - as many as hundreds or only one.
Entities are linked as a group in a number of ways. A group of entities drawn in succession without
disconnecting the cursor are linked as one group. Similarly a series of lines of text entered at the same
time are linked as one group. You can link any group of entities or groups using the Group
command. Entities are also linked or associated as one group when they are created at the same time
with the Copy command. When an existing entity is edited, with the Change or Move commands, for
example, it retains the same group associations.
The grouping together of entities in DataCAD facilitates editing many related items without affecting
other entities in the same portion of a drawing. Because they are also easily redefined, groups allow
the designer to organize a drawing as a series of elements composed of logically related pieces or
entities.
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keyboard shortcuts
These key combinations perform an operation or select a setting in the middle of another command
by interrupting the original command. Once the interrupt function is complete, DataCAD
automatically returns to the original function.
layers
In computer-aided design layers are the electronic equivalent of overlaid pieces of tracing paper, each
containing a small part of the drawing information. Each layer can also be saved and loaded for use
in other drawing files.
limits
The maximum and minimum sizes indicated by a toleranced dimension.
line
The most fundamental drawing entity; defined by two endpoints.
Menu Bar
An area of the screen, located along the top of the DataCAD screen, that contains pull-down menus to
give you quick access to many of DataCAD’s most used functions.
Menu toolbar
A toolbar that displays DataCAD’s primary menu structure. You can position this toolbar anywhere
on your DataCAD screen or on your desktop.
Message toolbar
This toolbar provides prompts and messages. The Message toolbar also provides an input portion
that supplies prompts and displays the information you are entering via the keyboard.
Multi-view Windows toolbar
A toolbar that lets you display up to 10 GoTo View windows that you can tear off, reposition, and
resize.
Navigation toolbar
This toolbar displays buttons to pan around (left, right, up, and down), zoom in or out, zoom to an
area, view the drawing at its extents, and identify the properties of an entity.
ortho mode
Used to draw entities at any angle. Press (O) to toggle Ortho mode off. To draw entities orthogonal to
one another, press (O) again to toggle ortho mode back on. Modify this snap angle by setting the
number of divisions under the Snap Angle option of the Grids menu.
orthographic view
A parallel view whose lines of sight are parallel to each other and perpendicular to the plane of
projection. Orthographic views include plan views and elevations.
pan
Move observer's view of a drawing by using the arrow keys to the right of the keyboard. Set the pan
distance by using Scroll Dist. in the Settings menu.
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point
Use the mouse to point to objects on the screen. Move the mouse to move the cursor to the
appropriate location on the screen.
Also, a point in space represented on the monitor as a dot, without width or height.
polyface
3D vertices connected in a specified order.
polyline
A connected sequence of lines and arc segments.
Projection toolbar
This toolbar controls the type of view (parallel, perspective, plan, isometric, oblique, and elevations)
that appears in your Drawing Window. You can place this toolbar anywhere on your DataCAD
screen or on your desktop.
prompt
A message that appears on the screen in the Message toolbar, providing information or requesting a
command or user action.
radius
The measurement used for a cylindrical baluster, newel post, or hand rail. The radius is the distance
from the center point of the cylinder to the side of the cylinder.
raster printing
The rendering of a graphic as an image composed of dots rather that of vectors, or lines.
reference point
An arbitrary point in the Drawing Window from which the next point entered will be referenced.
right-click
To press and release the right mouse button.
right-hand rule
A rule that indicates the direction of angles. Point the thumb of your right hand in the direction of the
axis in question. Your fingers curl in the direction of positive rotation. The Y axis goes up, so when
you point your thumb up, your fingers curl toward you in the left to right direction. Negative angles,
therefore, go from right to left.
screen refresh
Updates or redraws the screen from the drawing file in order to display the current status of your
drawing. This is particularly useful to monitor your progress during editing operations.
scroll back
Use Scroll Back to view a previously-displayed portion of a list.
scroll forward
Use Scroll Forward to view more options when the list of available choices is too long to fit on a
menu.
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select
To highlight or otherwise mark an entity, icon, or text.
selection set
A user-defined set of entities and/or groups that contains any number of entities or groups. Selection
sets provide increased efficiency during editing by reducing the time required to select entities,
groups, or define areas or fences.
setting
An option that is set to a particular value. You can change settings at any time, and they remain in
that state until you change them again.
solid
Solid filled figures, composed of quadrilateral (four-sided) or triangular (three-sided) polygons.
SPB fills
A solid, pattern, or bitmap can be used to fill an area instead of the standard vector-based hatch
patterns.
Standard toolbar
A toolbar that provides access to common Windows-based functions (such as file open, save, print,
copy, paste, etc.) and some frequently used DataCAD ones (such as select a reference file or bitmap).
You can move this toolbar anywhere in the DataCAD screen or onto your desktop.
Status toolbar
This toolbar is reserved for status information such as the current layer, layer color, line type, scale,
selection sets, go-to views, and input mode. You can more this toolbar anywhere in the DataCAD
screen or onto your desktop.
string
A series of characters.
swap file
A temporary file created when you enter DataCAD. It is the working file that constrains your
drawing during a work session. This working file is transferred to your drawing (.AEC) file when
you exit DataCAD.
SWOTHLUDFB toolbar
The Snap, Walls, Ortho, Text, Hatch, Line weight, User-line, Dimension, Fills, and Bitmap toggles are
located on this toolbar. You can move this toolbar anywhere in the DataCAD screen or onto your
desktop.
text
The alphabet, numerals, and special characters added to a drawing. It is created using fonts.
text leaders
Short, sometimes angled lines that are automatically drawn back to a point on the circumference of
the object when a dimension distance is too short to contain dimension text.
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thickness
The projection of a surface into 3D space.
toggle
An option switch that you can turn on or off. When a toggle is on, the button label appears in green;
when a toggle is off, the button label appears in red.
tolerance
The total amount a specific dimension is allowed to vary, the difference between maximum and
minimum limits.
trace
A solid line with a specified width.
undo
An option that cancels the latest operation or command performed. It appears on the menu only after
an action has taken place.
vector printing
Line-based drawings produced with commands that are either native to or added to a laser printer.
view center
The point in space at which the observer is looking. DataCAD places the view center in the middle of
the extents, halfway between Z-base and Z-height.
Viewer toolbar
This toolbar changes based on the type of view you select in the Projection toolbar. You can move this
toolbar anywhere in the DataCAD screen or onto your desktop.
void
An opening or hole created in a slab.
zoom
Displays objects at different scales for drawing tasks. To quickly focus on a portion of a drawing for
detailed work, press (/) to expand that section.
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.INI settings ............................................................. 88, 576
1 Line Trim................ See Cleanup, trimming to one line
2 Line Trim................ See Cleanup, trimming to one line
2 Line Walls ............................................. See Walls, 2-line
2 Pt. Arc ............................................ See Curves, drawing
2-point arcs, tracing ...................................................... 287
3 Edge Bot....... See Inclined polygons and slabs, 3-edged
bottom
3 Edge Poly ..... See Inclined polygons and slabs, 3-edged
vertical
3 Edge Top See Inclined polygons and slabs, 3-edged top
3 Line Walls ............................................. See Walls, 3-line
3 Pt. Arc ............................................ See Curves, drawing
3 Pt. Circ ....... See Curves, drawing , See Circles, using 3
points
3D arcs
divisions of ................................................................. 445
dog-leg ....................................................................... 445
drawing....................................................................... 444
tangent ........................................................................ 444
vertical ........................................................................ 445
3D copying ............................................................... 494–95
3D cursor ....................................................................... 471
3D Cursor ............................. See Cursor, world snapping
3D drawing .................................................................... 424
3D entities
changing attributes of ................................................. 499
copying ....................................................................... 494
editing rules ................................................................ 492
enlarging ............................................................... 497–98
exploding .................................................................... 498
exporting ...................................................................... 52
mirroring .................................................................... 496
moving ....................................................................... 492
rotating ................................................................. 495–96
rules for editing .......................................................... 492
selecting curved .......................................................... 422
stretching .................................................................... 497
3D framing............................................................... 538–49
floor ...................................................................... 538–39
roof ....................................................................... 541–49
saving settings ............................................................ 549
using settings .............................................................. 549
wall ....................................................................... 539–41
3D Knife
cutting boundary edge with ........................................ 482
cutting polygons from TIN model .............................. 481
indenting with............................................................. 482
raising cut polygons with............................................ 482
removing polygons with ............................................. 482
settings for .................................................................. 481
used with ruled surface ............................................... 486
3D lines
chaining ...................................................................... 424
curved, as contours ..................................................... 470
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drawing ...................................................................... 423
from Z-base to Z-height ............................................. 424
3D marker
placing on polygon..................................................... 482
using drop point with ................................................. 482
3D menus, selection ........................................................ 59
3D models
adding to web page .............................................. See o2c
as e-mail attachment ............................................ See o2c
walking through ................................................. 526, 527
3D moving ................................................................. 305–9
3D polygons
adding vertices to ....................................................... 439
creating drop mesh ..................................................... 464
deleting vertices from ................................................ 440
editing ........................................................................ 439
horizontal ................................................................... 430
moving vertices in ...................................................... 440
rectangular ................................................................. 430
vertical ....................................................................... 431
3D roofs
creating with inclined polygons ................................. 434
creating with inclined slabs ........................................ 434
defining boundaries for .............................................. 544
joining ........................................................................ 546
modeling .................................................................... 543
polygonal ................................................................... 544
rectangular ................................................................. 544
settings for ................................................................. 547
types of ...................................................................... 542
3D sectioning tool ......................................................... 487
3D settings ..................................................................... 423
3D snapping
normal ........................................................................ 424
world .......................................................................... 425
3D stairs .................................................................. 254–56
balusters for ............................................................... 569
base elevation of ........................................................ 563
calculator ................................................................... 561
chases of .................................................................... 564
curved, radius of ........................................................ 563
drawing ...................................................................... 560
form ........................................................................... 573
handrails for ............................................................... 568
landings of ................................................................. 564
newel posts for ........................................................... 571
placement of............................................................... 564
risers of ...................................................................... 565
settings ....................................................................... 562
stringers of ................................................................. 567
tread length of ............................................................ 563
treads in first run of .................................................... 563
treads in second run of ............................................... 563
treads in third run of................................................... 563
treads of ............................................................. 563, 566
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3D viewing (tutorial) ..................................................... 155
3D views ....................................................... 503–8, 512–13
changing center of ...................................................... 504
changing center of parallel ......................................... 504
changing to parallel view............................................ 421
elevations.................................................................... 503
isometrics ................................................................... 503
oblique .................................................................. 512–13
perspective............................................................ 508–11
pespective (tutorial) .................................................... 167
rotation angles in ........................................................ 503
saving an image .......................................................... 523
shaded image ........................................................ 518–21
using GoTo View ....................................................... 524
using o2c player with ................................................... 99
3D world snapping cursor ............................................ 425
3-point arcs, tracing ...................................................... 287
4 Edge Gen ..... See Inclined polygons and slabs, 4-edged
general
4 Edge Para .... See Inclined polygons and slabs, 4-edged
parallelograms
4 Edge Vert ..... See Inclined polygons and slabs, 4-edged
vertical
4 Line Walls ............................................. See Walls, 4-line
4EdgTrap........ See Inclined polygons and slabs, 4-edged
trapezoid
Abs. Zero ................................. See Reference point, fixed
Absolute Cartesian entry ................................................ 68
drawing line with .......................................................... 69
Absolute polar entry ....................................................... 68
drawing line with .......................................................... 69
Absolute zero, moving entities to ................................. 305
Active Only ......................... See Layers, setting the active
Add Vertex ...... See Vertex, adding, See Polylines, editing
vertices
Add View ............................. See Elevations, saving views
A-frame roofs ................................................................ 434
All On...................................... See Layers, toggling all on
And Copy ......................................... See Mirror, and copy
Angles
calculating .............................................................. 60, 61
dimension of between two lines ................................. 356
measure excluded between two lines .......................... 284
measure included between two lines .......................... 284
of cone of vision ......................................................... 510
of door openings ......................................................... 218
of rotation ................................................................... 496
rise .............................................................. 423, 454, 458
roll ...................................................................... 423, 456
setting types of ........................................................... 199
sweep .......................................................................... 447
using right-hand rule .................................................. 503
Aperture, of miss distance ............................................ 274
Append, adding entities to active selection set
automatically............................................................. 320
Application, launching external in DataCAD ............... 99
Arc factor....................................................................... 206
Arc of curve
measuring length of .................................................... 284
Arc To Edge .................................... See Polylines, editing
Arch ............................................. See Scales, setting types
Architectural scales....................................................... 202
Arcs
2-point ........................................................................ 232
3-point ............................................. See Curves, drawing
center angle of ............................................................ 234

changing radius of ...................................................... 236
closed ......................................................................... 499
closing 2D, for hide ................................................... 517
connecting two lines with .................................. 252, 294
dividing ...................................................................... 288
divisions, for hide ...................................................... 517
drawing based on chord length .................................. 235
drawing based on included angle ............................... 236
drawing based on length ............................................ 234
drawing based on radius............................................. 236
drawing with tangent line........................................... 237
editing in a polyline ................................................... 249
measuring chord length of ......................................... 283
tracing tangent ........................................................... 287
Area
measuring circle or polyline ....................................... 285
of surface of polygons................................................ 483
selection, 2D ................................................................ 57
selection, 3D ................................................................ 59
Area selection.................................................................. 58
matching cursor angle .................................................. 58
matching grid angle ..................................................... 58
Arrays
copy rectangular................................................. 265, 266
copying circular ......................................................... 267
copying with ...................................................... 263, 495
creating 3D rectangular .............................................. 495
rectangular ................................................................. 495
using Z elevations in rectangular ............................... 268
Arrows
arrowhead style .......................................................... 338
drawing as text ........................................................... 338
drawing with Arrows macro ...................................... 383
on dimension line ....................................................... 354
style for dimensions ........................................... 349, 350
style options for angle and curve dimensions .... 356, 358
style options for linear dimensions ............................ 353
text, drawing (tutorial) ............................................... 131
AS1100 ........................................ See Scales, setting types
Attributes
3D entities,changing .................................................. 499
added with macro, displaying visible ......................... 206
changing text .............................................................. 302
editing for symbols .................................................... 343
for cavity in 4-line wall .............................................. 212
for center line of 3-line wall....................................... 212
for exterior distance in 4-line wall ............................. 212
for interior distance in 4-line wall .............................. 212
of text added to symbols .................................... 341, 380
of text defined for symbols ........................................ 341
of text for symbols ..................................................... 341
wall, setting ................................................................ 212
with wall styles .......................................................... 213
Automatic, style for dimensions .................................. 350
Auto-recover files ......................................................... 204
Axonometrics
isometric views .......................................................... 503
plan obliques .............................................................. 512
Backface ... See Hidden line removal, increasing speed of
Background color, changing Drawing Window ........... 45
Backing up files ........................................................ 91–93
Backup
auto-recover file (.ARB) .............................................. 90
drawing files ................................................................ 91
drawing files (.DBK) ................................................... 90
drawing sessions .......................................................... 93

saving drawing sessions ............................................... 90
Bal/Run1 ....................................See Balusters, number of
Bal/Run2 ....................................See Balusters, number of
Bal/Run3 ....................................See Balusters, number of
Bal/Tred .....................................See Balusters, number of
Balusters ........................................................................ 569
as symbols .................................................................. 570
color of ....................................................................... 571
cylindrical ................................................................... 570
depth of ...................................................................... 570
divisions of ................................................................. 570
horizontal offset of ..................................................... 571
modeling ..................................................................... 569
number of ........................................................... 569, 570
placement of ............................................................... 569
radius of...................................................................... 570
rectangular .................................................................. 570
vertical offset of ......................................................... 571
width of ...................................................................... 570
Base/Height.. See Z-base, to Z-height, See 3D lines, from
Z-base to Z-height
Base+Thk ..................................... See Z-base, to thickness
BaseElev........................... See 3D stairs, base elevation of
Batch plotting .......................................................... 414–17
customized with scripting language............................ 417
from a single drawing ................................................. 415
from multiple drawings .............................................. 416
to PDF format ............................................................. 417
Beams, standard ............................................................ 556
Bearing................................... See Angles, setting types of
Bezier curves ................................................................. 241
Bi-fold doors .................................................................. 217
Big Cursor ........................... See Cursor, large displaying
Bitmap
displaying ................................................................... 206
inserting files into drawings ......................................... 82
resolving orphaned ....................................................... 83
saving image as ............................................................ 86
Bitmap Fills .................................................. See SPB Fills
Blocks
drawing....................................................................... 441
parallelogram.............................................................. 442
rectangular .................................................................. 442
Border
adding center snapping point ...................................... 387
creating (tutorial) ........................................................ 146
drawing............................................................... 386, 387
moving (tutorial) ........................................................ 147
size of ......................................................................... 386
Boundaries, hatch
defining ...................................................................... 363
defining rectangular .................................................... 363
including arcs ............................................................. 364
including curves ......................................................... 364
using contour search to define .................................... 363
Box Color ................................ See Colors, displaying box
B-spline curves .............................................................. 241
Cab ....... See Elevators:drawing 2D with DataCAD AEC
Calculating
angles ..................................................................... 60, 61
distances ....................................................................... 60
Calculator, online ............................................................ 60
Calibrate
distance....................................................................... 382
enlargement of imported graphics .............................. 382
X/Y enlargement options ............................................ 382

Camera .......................................................................... 510
Cancel
hidden line removal ................................................... 513
roof framing ............................................................... 541
saved hide image........................................................ 515
Capacity ........See Elevators, drawing 2D with DataCAD
AEC
Cent. Angle ...................................... See Curves, drawing
Cent. Chord ..................................... See Curves, drawing
Center Cav .............. See Walls, defining by cavity center
Center Line ............................ See Walls, 3-line attributes
Center Point
polygons, drawing ...................................................... 231
Center points of 2D curves, displaying ....................... 206
Center Wall ........................ See Walls, defining by center
Center Z .................................. See Center, of 3D rotation
Center, of 3D rotation .................................................. 496
CentiMtr ..................................... See Scales, setting types
Chain ...............................................See 3D lines, chaining
creating vertical polygons in succession .................... 432
Chamfer ................................................................ 252, 294
Changing ................................................................... 301–3
attributes of 3D entities .............................................. 499
attributes to match another entity ............................... 302
entity attributes .......................................................... 301
line overshoot............................................................... 73
text attributes ............................................................. 302
text attributes to match another text block ................. 303
Characters, extended ................................................... 602
Check for spelling errors ............................................. 328
Check plot ..................................................................... 407
Chord
drawing arc based on length of .................................. 235
measuring length of arc.............................................. 283
Circ. Array ................................. See Copy, circular array
Circles
3-point........................................................................ 444
dividing ...................................................................... 288
measuring circumference of ....................................... 284
using 3 points ............................................................. 240
using diameter .................................................... 239, 444
using radius ........................................................ 238, 444
Circumference, measuring circle ................................ 284
CircWndw .......................... See Windows, curved bays of
Clean.............................................................................. 211
walls ........................................................................... 213
Cleanup
chamfers..................................................................... 294
connecting two lines with a line ................................. 294
fillets .......................................................................... 294
trimming to nearest .................................................... 296
trimming to one line ........................................... 295, 296
wall intersections ....................................................... 213
wall intersections (tutorial) ........................................ 111
Clear Layer ..................... See Layers, erasing contents of
Clip Cube
activating ................................................................... 522
creating ...................................................................... 522
defining in XREF with Reference File Management . 522
defining in XREF with XREF Clip ............................ 523
display boundary of ..................................................... 56
rotated, adding to a multi-scale plot ........................... 410
using with XREFs ........................................ 76, 522, 523
viewing selected entities in 3D model with ............... 521
Clockwise ........ See Curves, drawing, See Angles, setting
types of
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ClosdStr ............................................ See Stringers, closed
Close 2D Arc....................... See Arcs, closing 2D for hide
Close Ellip............................ See Ellipses, closing for hide
Closed............................................................................. 499
Color .. See Stairs, drawing 2D with DataCAD AEC, See
Layers, changing color
changing on display grids ........................................... 176
Color mapping
define materials for rendering with............................. 531
using Viewer/Shader color map ................................. 531
Color slice
controlling color of levels in TIN model .................... 477
cutting TIN model ...................................................... 477
for TIN model............................................................. 477
Colors
changing ....................................................................... 61
changing background of Drawing Window .................. 45
changing for entities ..................................................... 61
Color Palette ........................................................... 45, 61
copying entities to clipboard ........................................ 55
custom .................................................................. 61, 207
displaying box ............................................................ 206
exporting with Translation toggle................................. 52
matching ....................................................................... 62
menu ............................................................................. 61
of 3D stairs ......................................... 565, 566, 567, 568
of balusters ................................................................. 571
of handrails ................................................................. 569
of hidden lines ............................................................ 516
of newel posts ............................................................. 573
standard 15 DataCAD .................................................. 62
Columns, drawing ......................................................... 554
Command Line Alias ...................................................... 40
Compass................................. See Angles, setting types of
Computer crash, recovering lost work after ........... 91–93
Concrete forms ........................................................ 554–57
drawing column .......................................................... 554
drawing double tee ..................................................... 555
drawing I-beam .......................................................... 556
drawing inverted tee ................................................... 554
drawing single tee....................................................... 555
drawing standard beam ............................................... 556
Cone of vision ........................................................ 509, 510
width of ...................................................................... 510
Cones
closed ......................................................................... 499
drawing....................................................................... 449
radius of...................................................................... 450
truncated ..................................................................... 450
Cont. Search ... See Polylines, converting closed shape to,
See Contours, search closed polyline to create outline
Contours
based on 3D points or polygons ................................. 483
concentric steadily rising lines for TIN model ........... 472
control points for ........................................................ 471
creating for TIN model ............................................... 472
creating topographical map with ................................ 470
cyclic .......................................................................... 470
divisions of ................................................................. 471
drawing....................................................................... 470
elevation of ................................................................. 471
generating TIN model from ........................................ 472
making topological map ............................................. 483
natural......................................................................... 470
search closed polyline to create outline ...................... 245
smoothing surface ...................................................... 464

steadily rising ............................................................. 471
stiffness of.................................................. 464, 470, 499
tangent ....................................................................... 470
tangent point .............................................................. 471
Control points
displaying for associative dimensions ........................ 206
for contours ........................................................ 470, 471
for mesh surfaces ....................................................... 459
Convert
lines to walls .............................................................. 304
walls to lines .............................................................. 304
Convert Void ................ See Voids, converting, See Voids,
converting to polygon
Coordinate entry
absolute Cartesian .................................................. 68, 69
absolute polar ......................................................... 68, 69
choosing a method ....................................................... 68
distance direction ................................................... 68, 69
drawing with ................................................................ 68
placing dimensions with ............................................ 349
relative Cartesian ......................................................... 68
relative polar .......................................................... 68, 69
Coordinates
screen ......................................................................... 506
world .......................................................................... 506
Copy ................................................................................ 73
3D entities ............................................................ 494–95
and rotate entities ....................................................... 311
circular array .............................................................. 267
entities.................................................................. 260–68
new distance....................................................... 261, 262
one-dimensional array................................................ 264
perpendicular to original ............................................ 262
rectangular array ................................................ 265, 266
specified distance and angle....................................... 260
to another layer .......................................................... 262
to clipboard, setting...................................................... 56
using arrays ........................................................ 263, 495
Copy to Clipboard
entity color ................................................................... 55
line weight ................................................................... 55
Cover
adding to closed polyline ........................................... 251
removing from closed polyline .................................. 251
Crossing selection ..................................................... 57, 58
Cursor
3D .............................................................................. 471
changes to New Elevation Indicator .......................... 421
changing to New Elevation Indicator ......................... 507
large displaying .......................................................... 203
setting accuracy of ..................................................... 203
text ............................................................................. 324
with o2c object attached............................................. 381
world snapping........................................... 425, 493, 495
Curve Center See Center points of 2D curves, displaying
Curve Data ..... See Curves, drawing based on surveyor's
data
Curves
Bezier ................................................................. 241, 459
B-spline ...................................................................... 241
drawing ................................................................ 232–42
drawing based on surveyor's data............................... 242
drawing with control points ....................................... 240
measuring arc length of .............................................. 284
measuring diameter of................................................ 283
measuring radius of .................................................... 283

Customizing
colors .......................................................................... 207
display settings ........................................................... 205
drawing settings.......................................................... 198
macros .......................................................................... 53
miscellaneous settings .................................................. 54
toolbars ......................................................................... 29
walk-through options .................................................. 526
Customizing DataCAD ................................................... 42
DXF/DWG file translation ........................................... 50
interface settings ..................................................... 43, 49
macros .......................................................................... 53
menu buttons ................................................................ 44
menu labels................................................................... 44
miscellaneous settings .................................................. 54
pathnames ..................................................................... 42
screen calibration.......................................................... 43
Cut.................................................................................... 73
Cut Wall ............................................... See Walls, cutting
Cutout ........ See Windows, drawing, See Doors, drawing
Cyclic contours .............................................................. 470
Cylinder ....... See Newel posts, cylindrical, See Balusters,
cylindrical, See Handrails, cylindrical
Cylinders
closed ......................................................................... 499
horizontal.................................................................... 447
setting number of divisions for ................................... 449
sweep angles............................................................... 447
vertical ........................................................................ 446
vertical, divisions of ................................................... 446
vertical, thickness of ................................................... 446
DataCAD AEC
2D elevators ......................................................... 256–58
2D stairs ............................................................... 254–56
drawing curved bays of windows with ....................... 225
drawing linear bays of windows with ......................... 223
drawing room labels with ........................................... 345
Ddrawing
windows ............................................................... 220–27
Dec. Degrees .......................... See Angles, setting types of
Decimal ........................................ See Scales, setting types
place setting ................................................................ 199
place, setting ............................................................... 200
point, floating ..................................................... 199, 200
Default
drawing......................................................................... 55
font ............................................................................... 55
Definition list
adding a value to ........................................................ 200
angle ........................................................................... 200
changing a definition .................................................. 201
deleting a value to ...................................................... 201
distance....................................................................... 200
editing......................................................................... 200
loading a customized .................................................. 201
scale ............................................................................ 200
Del. Edge ........................... See Polylines, deleting an edge
Del. Vertex .... See Vertex, deleting, See Polylines, editing
vertices
Delete
double lines after hide ................................................ 516
edge from a polyline using ......................................... 250
framing settings files .................................. 538, 540, 549
go-to-view .................................................................. 524
layer sets ..................................................................... 187
layers .......................................................................... 183

reference file ................................................................ 78
saved hide image........................................................ 515
stair settings files ....................................................... 573
text styles ................................................................... 337
vertices ....................................................................... 440
wall styles .................................................................. 215
Delete Dbl ....... See Hidden line removal, deleting double
lines with
Delete Layer ...................................... See Layers, deleting
Depth
of balusters ................................................................. 570
of handrails ................................................................ 569
of landings ................................................................. 564
of newel posts ............................................................ 572
of treads ..................................................................... 566
Desktop
classic .......................................................................... 36
Dia. Circ .................................See Circles, using diameter
Dialog boxes .................................................................... 37
Diameter
curve, dimension of.................................................... 356
of circles ............................................................ 239, 444
of curve, measuring.................................................... 283
of polygons when drawing ......................................... 231
Dictionary
adding word to user.................................................... 331
changing language of main ........................................ 331
checking for spelling .................................................. 328
selecting a new user ................................................... 334
Dim. Points .................. See Control points, displaying for
associative dimensions
Dimensions .............................................................. 348–58
aligned ....................................................................... 348
angle between lines .................................................... 356
angle style for angle and curve .................................. 358
angular ....................................................................... 348
arrow style for ............................................................ 353
arrows ................................................................ 349, 350
associative .......................................................... 348, 350
automatic ................................................................... 349
automatic (tutorial) .................................................... 135
automatic style for ..................................................... 354
automatic, style options for ........................................ 350
baseline ...................................................... 351, 353, 354
center points ............................................................... 354
changing linear........................................................... 354
curve diameter ........................................................... 356
curve radius................................................................ 357
DIN Standard ............................................................. 353
displaying associative ................................................ 205
dots for ....................................................................... 354
drawing string of (tutorial) ......................................... 133
editing linear .............................................................. 354
exploding linear associative ....................................... 355
fixed distance of ......................................................... 353
geometric tolerances for ............................................. 353
horizontal ................................................................... 348
increment offset of ..................................................... 353
limits for .................................................................... 353
line offset ................................................................... 352
line style for ............................................... 349, 350, 352
line style for angle and curve ..................................... 358
linear .......................................................................... 348
minimum distance ...................................................... 354
miss distance .............................................................. 354
moving linear ............................................................. 355
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object snapping and .................................................... 349
overall......................................................................... 351
overrun of extension lines .......................................... 353
parallel to entity .......................................................... 348
rotated......................................................................... 348
rounding ..................................................................... 353
settings (tutorial) ........................................................ 133
stretching (tutorial) ..................................................... 136
stringline..................................................... 349, 351, 354
text offset for .............................................................. 352
text style for................................................ 348, 350, 351
text style for angle and curve ...................................... 357
tick marks for ............................................................. 354
vertical ........................................................................ 348
DIN ............................................... See Scales, setting types
Direction distance, using with reference point ........... 273
Directories, changing ...................................................... 42
Disp. Grid 1 ........................................... See Display, grids
Disp. Grid 2 ........................................... See Display, grids
Display
associative hatch origin ...................................... 206, 367
customizing ................................................................ 205
external hatch patterns .................................................. 57
external line types......................................................... 57
grid, changing color .................................................... 176
grids ............................................................................ 175
negative coordinates ................................................... 204
options, setting ........................................................... 203
synchronizing distances .............................................. 205
Dist. Sync .............. See Distances, display, synchronizing
Distance
copy ............................................................................ 262
direction entry .............................................................. 68
direction entry, drawing line with................................. 69
new, copy ................................................................... 261
Distances
calculating .................................................................... 60
display, synchronizing ................................................ 205
increment .................................................................... 462
measuring between two points ................................... 283
new, 3D move ............................................................ 493
previous stretch .......................................................... 497
previous, 3D move ..................................................... 493
stretch, in Z direction.................................................. 497
Divide entities .......................................................... 288–89
Divisions
contour control to generate TIN model ...................... 479
of 2D arcs ................................................................... 517
of balusters ................................................................. 570
of contours .................................................................. 471
of handrails ................................................................. 569
of mesh surfaces ......................................................... 461
of newel posts ............................................................. 572
primary ....................................................................... 499
secondary.................................................................... 499
setting number for cylinders ....................................... 449
setting primary and secondary .................................... 423
Dn Only...... See Stairs:drawing 2D with DataCAD AEC
Do Float ................................ See Decimal, point, floating
DoCtr ........................................ See 3D stairs, stringers of
DoFloat ........................................ See Scales, setting types
Dog-leg ............................................... See 3D arcs, dog-leg
DoLeftSee Handrails, on left side of stairs, See 3D stairs,
stringers of
DoLndBt ..................................... See 3D stairs, landing of
DoLndTp .................................... See 3D stairs, landing of

Domes
primary divisions of ................................................... 455
secondary divisions of ............................................... 455
DoNlPst ................................... See Newel posts, modeling
Door Style........................................... See Doors, drawing
Door Swing......................................... See Doors, drawing
Doors
adding 3D (tutorial) ................................................... 161
drawing ................................................................ 216–20
drawing (tutorial) ....................................................... 116
labels for .................................................................... 346
match swing color to .................................................. 219
opening angle ............................................................. 218
removing .................................................................... 219
styles of ...................................................................... 217
swing color of ............................................................ 219
swing styles of ........................................................... 219
DoRght ......See Handrails, on right side of stairs, See 3D
stairs, stringers of
DoRiser........................................... See 3D stairs, risers of
Dormers, drawing......................................................... 436
DoTread ........................................ See 3D stairs, treads of
Double doors ................................................................. 217
Double tee concrete forms, drawing ........................... 555
Drafting symbols, creating........................................... 602
Drag
copy entities using ..................................................... 261
moving polyline using ............................................... 250
moving using ............................................................. 307
moving using (tutorial) .............................................. 147
Drag Arc................................... See Polylines, editing arcs
Drag Edge ............................. See Polylines, repositioning
Drag Vertex ....................... See Polylines, editing vertices
Draw Hidden See Hidden line removal, drawing hidden
lines in
Draw Jamb. See Windows, drawing, See Doors, drawing
Draw Marks .................... See Drawing, marks displaying
Drawing
and editing basic skills ........................................... 67–74
cabinet elevations ............................................... 397, 398
creating a new .............................................................. 23
creating new default ..................................................... 25
curves ................................................................... 232–42
default .................................................................... 25, 55
door elevations ........................................................... 392
doors .................................................................... 216–20
doors (tutorial) ........................................................... 116
elevators, 2D ........................................................ 256–58
exterior elevations with EZ Tools macro ................... 390
line by selecting two points.......................................... 68
marks displaying .................................203, 219, 222, 272
naming ......................................................................... 23
opening an existing ...................................................... 22
polygons............................................................... 230–31
polylines............................................................... 243–54
rectangles ................................................................... 231
set origin of .................................................................. 56
sketching freehand ..................................................... 270
stairs, 2D .............................................................. 254–56
using default to create new .......................................... 24
using same default for each new .................................. 24
walls ..................................................................... 210–16
walls (tutorial) ............................................................ 105
window elevations ............................................. 394, 396
windows ..................................................................... 220
windows (tutorial) ...................................................... 121

with coordinate entry .................................................... 68
with line types .............................................................. 70
with the mouse ............................................................. 68
Drawing Area .................................................................. 41
increasing size of .......................................................... 62
using two monitors for ................................................. 62
Drawing session
backup procedure ......................................................... 93
saving ........................................................................... 55
Drawing Window, changing partitions in ................... 515
Drawings
border for .................................................................... 386
border, moving (tutorial) ............................................ 147
changing entities in....................................................... 65
copying parts of ............................................................ 65
creating PDF file of .................................................... 406
customizing settings ................................................... 198
laying out plot sheets for ............................................ 410
linking .......................................................................... 74
mirroring parts of ......................................................... 65
moving entities in ......................................................... 65
plotting ....................................................................... 402
printing ....................................................................... 402
purging unused data...................................................... 94
referencing.............................................................. 74–81
saving ........................................................................... 86
stretching entities in...................................................... 65
unused data in ............................................................... 94
viewing ......................................................................... 84
Drop mesh ............................................................... 464–70
controlling file size ..................................................... 464
created from survey data file ...................................... 464
creating ....................................................................... 464
importing survey data for ........................................... 465
increases file size ........................................................ 464
over selected geometry ............................................... 465
removing unused entities from ................................... 464
Drop point, placing 3D marker on polygon ................ 482
DWF, exporting files ....................................................... 96
DWG
block attributes in ....................................................... 344
DataCAD symbol attributes in ................................... 344
exporting files ............................................................... 96
files, customizing translation ........................................ 50
importing drawing file .................................................. 25
saving entity assignments when importing ................... 27
DWG Translator, translation tables ............................ 578
DwgSheet .......................................... See Border, drawing
DXF
exporting files ............................................................... 96
files, customizing translation ........................................ 50
importing drawing file .................................................. 25
DXF Translator, translation tables ............................. 578
Dynamic
curves, drawing .................................................. 232, 233
polygons, drawing ...................................................... 230
tangent curves, drawing .............................................. 238
Edge factor, for smoother TIN model ......................... 477
Edit Defs ............................. See Editing, value definitions
Edit Defs. ................................. See Definition list, editing
Edit menu .................................................................. 65, 73
Edit Plane
changing zero plane orientation .................................. 420
positioning zero plane with ........................................ 421
Editing
and drawing basic skills ......................................... 67–74

drawings....................................................................... 73
linear dimensions ....................................................... 354
symbols ...................................................................... 377
value definitions......................................................... 200
Elevations ................................................................ 390–98
cabinet settings for ..................................................... 397
cabinet styles for ................................................ 397, 398
creating (tutorial) ....................................................... 169
creating 3D views of .................................................. 507
creating new ............................................................... 507
door ............................................................................ 392
door settings for ......................................................... 393
door styles for .................................................... 393, 394
drawing cabinets ................................................ 397, 398
drawing doors .................................................... 392, 394
drawing exterior ......................................................... 390
drawing windows ............................................... 394, 396
exterior ....................................................................... 390
exterior roof settings .................................................. 391
saving views............................................................... 508
window settings for .................................................... 395
window styles for ............................................... 395, 396
Elevators
drawing 2D with DataCAD AEC......................... 256–58
Ellipses .......................................................................... 240
closing, for hide ......................................................... 517
End Point ....... See Object snapping, to nearest endpoint
End Pt. Ang ...................................... See Curves, drawing
End Pt. Rad ...................................... See Curves, drawing
Engineering scales ........................................................ 202
Engr ............................................. See Scales, setting types
Enlarge .......................................................................... 313
3D entities ............................................................ 497–98
enlargement factor ..................................................... 314
imported graphics ...................................................... 382
in X direction ............................................................. 498
in Y direction ............................................................. 498
in Z direction.............................................................. 498
Identify .......................................................................... 281
Entities
adding to a selection set ............................................. 317
attributes of ................................................................ 282
clipping with ClipIt .................................................... 321
copying .......................................................... 74, 260–68
copying color of ........................................................... 55
copying line weight of ................................................. 55
copying perpendicular to original .............................. 262
cropping with ClipIt ................................................... 321
deleting from a selection set....................................... 318
dividing ................................................................ 288–89
editing attributes ........................................................ 304
enlarging .................................................................... 313
erasing........................................................................ 315
erasing partial............................................................. 315
grouping ............................................................... 57, 316
identifying .................................................................. 281
in a selection set using Show ..................................... 317
linking .......................................................................... 57
linking to a go-to-view ............................................... 525
measuring............................................................. 282–87
mirroring .............................................................. 268–69
moving ......................................................................... 74
moving specified distance and angle.......................... 306
moving to absolute zero ............................................. 305
offsetting and copying ............................................... 262
rotating ....................................................................... 310
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rotating dynamically ................................................... 311
selecting........................................................................ 57
stretching .................................................................... 312
trimming ............................................................. 295, 296
ungrouping ................................................................. 316
EqBays ...... See Windows, curved bays of, See Windows,
linear bays of
Erase .............................................................................. 315
contents of layers ........................................................ 182
partial ......................................................................... 315
Erase Void See Voids, erasing, See Voids, erasing from a
polyline
Explode
3D entities .................................................................. 498
converting TrueType fonts to 3D ............................... 340
linear associative dimensions ..................................... 355
polyline....................................................................... 246
symbols ...................................................................... 604
Export
3D entity ....................................................................... 52
DWF files ..................................................................... 96
DWG files .................................................................... 96
DXF files ...................................................................... 96
files ....................................................................... 51, 581
files using Color Translation toggle ............................. 52
o2c objects .................................................................... 98
RAY or DC Render files .............................................. 98
reference files ............................................................... 53
STL files ....................................................................... 98
text.............................................................................. 336
using Line types toggle................................................. 52
VRML files .................................................................. 97
XREF files .................................................................... 53
Export Layer ........................................See Layers, saving
Extended characters ..................................................... 602
Extension
left, of stair treads ....................................................... 566
right, of stair treads ..................................................... 566
Extents, viewing ............................................................ 182
Eye point, changing ...................................................... 504
Fast 3D ..... See Object snapping, to center of 3D circular
entities
Fast 3D snapping........................................................... 426
Fast Symbol .... See Object snapping, to symbol insertion
point
Fence selection........................................................... 57, 58
3D ................................................................................. 59
Files
auto-recover (.ARF) ............................................. 90, 204
auto-recover backup (.ARB)......................................... 90
backing up work ..................................................... 91–93
backup process ............................................................. 91
compressed format of ................................................... 88
converting to .AEC from .DC3 or .DC5 ....................... 22
customizing DXF/DWG translation ............................. 50
DataCAD User (.U$R) ................................................. 90
drawing (.AEC) ............................................................ 22
Drawing Backup (.DBK) .............................................. 90
drawing recover (.DRF)................................................ 91
drawing swap (.$WP) ................................................... 90
exporting ........................................................ 51, 96, 581
exporting XREF ........................................................... 53
icons used for DataCAD............................................... 88
importing .................................................................... 578
naming conventions ...................................................... 87
project set ................................................................... 417

purging ......................................................................... 94
recover process ............................................................ 91
recovering lost work .............................................. 91–93
referencing ............................................................. 74–81
size reduction of ........................................................... 88
swap ............................................................................. 88
using archive to recover ............................................... 93
Fillets ..................................................................... 252, 294
Filter .................................................. See Layers, filtering
layers.......................................................................... 494
Filter Back .......................................................... See Filter
Filter Fwd............................................................ See Filter
FitBays ...... See Windows, curved bays of, See Windows,
linear bays of
Fix Text ...................................... See Mirror, text position
Fixed Ref ..................................See Reference point, fixed
Flip valley, controlling TIN model with...................... 481
Floor framing.......................................................... 538–39
joist settings for.......................................................... 539
sill plate settings for ................................................... 539
subfloor settings for ................................................... 539
Fonts
changing menu button .................................................. 46
converting TrueType fonts to 3D ............................... 340
setting default............................................................... 55
setting text parameters for TrueType fonts ................ 339
standard...................................................................... 602
supplied by DataCAD ................................................ 324
TrueType (TTF) ................................................. 324, 339
FormAtr ............................See Entities, editing attributes
Fractions ....................................................................... 199
stacked ....................................................................... 200
Framing, 3D ............................................................ 538–49
roof ...................................................................... 541–49
wall ...................................................................... 539–41
Free Trim .................... See Cleanup, trimming to nearest
Free Zooms, remembering............................................. 56
Freehand, using to sketch ............................................ 270
Gable roofs .................................................................... 434
Geometry....................................................................... 262
Get-Snap ...............................................279, See Snapping
Girders, drawing .......................................................... 554
Glass
for 3D windows ................................................. 224, 226
Glass Thk ........................... See Windows, glass thickness
Golden Mean ................................................................ 288
dividing a line with .................................................... 289
GoTo Views
displayed in toolbar ...................................................... 35
Go-to-views ................................................................... 524
adding current view to the list .................................... 524
adding to multi-scale plot........................................... 412
batch plotting of ......................................................... 415
changing an existing .................................................. 524
deleting a view ........................................................... 524
linking an entity to ..................................................... 525
moving a view............................................................ 524
renaming a view ......................................................... 525
saving current plot scale with....................................... 56
using hyperlinks with ................................................. 525
using multi-scale plotting with ................................... 410
Grads ...................................... See Angles, setting types of
Grid Origin ............................ See Grids, setting origin of
GridColr........................ See Display grid, changing color
Grids
changing size of ......................................................... 175

changing the angle in .................................................. 177
display, changing color of .......................................... 176
display, using.............................................................. 175
matching an entity’s angle .......................................... 177
rotating ....................................................................... 177
rotating with cursor .................................................... 205
setting origin of .................................................. 177, 504
setting snap angle of ................................................... 176
snap, setting angle of .................................................. 176
snap, using .................................................................. 174
GridSize ..................................See Grids, changing size of
Group .............................................. See Entities, grouping
Group selection ....................................................... 57, 316
Handrails
color of ....................................................................... 569
cylindrical ................................................................... 568
depth of ...................................................................... 569
divisions of ................................................................. 569
height of ..................................................................... 569
on left side of stairs .................................................... 568
on right side of stairs .................................................. 568
radius of...................................................................... 568
rectangular .................................................................. 568
width of ...................................................................... 568
Hatch........................................................................ 360–68
angle ........................................................................... 361
associative .................................................................. 367
boundaries .......................................................... 361, 363
boundaries with curves and/or arcs............................. 364
contour search ............................................................ 363
defining a rectangular boundary ................................. 363
displaying pattern ....................................................... 205
drawing (tutorial)........................................................ 138
drawing associative .................................................... 367
drawing standard patterns ........................................... 360
master polyline with voids.................................. 254, 365
origin of ...................................................................... 361
patterns ............................................................... 360, 361
scale ............................................................................ 361
standard patterns ......................................................... 593
type of ........................................................................ 360
using SPB fills instead of ........................................... 365
Hatch Pattern Manager.......................................... 361–63
changing embedded hatch patterns ............................. 362
converting .PAT files to .DHP format ........................ 362
embedded hatch patterns ............................................ 362
external hatch patterns ................................................ 362
reloading embedded hatch patterns ............................ 362
saving embedded hatch patterns ................................. 362
Head height
of doors ...................................................................... 219
of windows ................................................................. 222
Height.......................................... See Handrails, height of
Height+Thk .............................. See Z-height, to thickness
Help, online...................................................................... 18
Hidden Color .See Hidden line removal, colors of hidden
lines
Hidden line removal
adding retained image to active layer ......................... 514
adding retained image to layer file ............................. 515
adding retained image to new layer ............................ 515
arc divisions for .......................................................... 517
closing 2D arcs for ..................................................... 517
closing ellipses for ...................................................... 517
colors of hidden lines ................................................. 516
deleting double lines with ........................................... 516

displaying outlines in ................................................. 517
drawing hidden lines in .............................................. 516
hidden line types for .................................................. 516
increasing speed of............................................. 515, 516
joining lines during .................................................... 516
line spacing for hidden lines ...................................... 517
maximizing performance of ....................................... 514
offsetting an image..................................................... 515
performing ................................................................. 513
saving image of .......................................................... 514
tutorial........................................................................ 168
Hidden Space .............. See Line spacing, for hidden lines
Hidden Style.................... See Line types, for hidden lines
Highlight .......................... See Walls, setting attributes of
Hip roofs................................................................ 435, 436
Hither clip ..................................................................... 509
Horizontal 3D polygons ............................................... 430
Horizontal cylinders
bottom half of ............................................................ 448
closed ......................................................................... 449
divisions of ................................................................ 449
full.............................................................................. 448
radius of ..................................................................... 448
sweep angle for .......................................................... 447
sweep angles to draw half of ...................................... 448
top half of................................................................... 448
Horizontal slabs ............................................................ 431
HorzOfst ...................... See Balusters, horizontal offset of
Hotkeys, for walk-through........................................... 526
Hotspots .......................................................................... 34
Hyperlinks
with files .................................................................... 525
with GoTo Views ....................................................... 525
with internet URLs..................................................... 525
I-beams .......................................................................... 556
Identify
Set All ........................................................................ 281
Images
calibrating enlargement of ......................................... 382
calibrating enlargement of imported .................. 313, 382
enlarging .................................................................... 382
importing files into drawing....................................... 381
inserting into drawings ................................................. 82
preserving original dimensions of imported............... 382
printing controls for .BMP and .JPG files with Pen Table
............................................................................... 382
saving in a different file format.................................... 86
Import
and calibrate enlargement of imported graphics 313, 382
default settings for ....................................................... 51
DWG or DXF file ........................................................ 25
entity assignments for ............................................ 26, 51
files ...................................................................... 51, 578
image ......................................................................... 381
o2c object ................................................................... 381
supported file formats ................................................ 381
text ............................................................................. 336
Import Layer ..................................... See Layers, loading
In Order ....... See Layers, refreshing in order of creation
In Sill ............................................. See Windows, drawing
In Wall........ See Windows, drawing, See Doors, drawing
Inch/Dec ...................................... See Scales, setting types
Inch/Frc ....................................... See Scales, setting types
Inclined polygons and slabs
3-edged bottom .......................................................... 436
3-edged top ................................................................ 436
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3-edged vertical .......................................................... 438
4-edged general .......................................................... 436
4-edged parallelograms .............................................. 434
4-edged trapezoid ....................................................... 435
4-edged vertical .......................................................... 437
Ins. Point .............................................. See Insertion point
Inscribe .......................................................... See Polygons
Inserting
o2c objects .................................................................. 381
self-XREF .................................................................... 75
stamps......................................................................... 381
symbols ...................................................................... 373
Insertion point ................................................................. 74
Installation of DataCAD ................................................. 18
Interface
customizing settings for................................................ 49
Interface, customizing settings for ................................. 43
Intersect ..... See Object snapping, to nearest intersection
point
Intersections
cleaning L ................................................................... 300
cleaning T ................................................................... 299
cleaning wall .............................................................. 213
cleaning X .................................................................. 300
marking ...................................................................... 289
IntrLand ............. See 3D stairs, intermediate landings of
Inverted tee concrete forms, drawing.......................... 554
Isometric views .............................................................. 506
Jamb Depth See Windows, drawing, See Doors, drawing
Jamb In ...... See Windows, drawing, See Doors, drawing
Jamb Width ..... See Windows, width of jamb, See Doors,
drawing
Join ........... See Hidden line removal, joining lines during
Keyboard shortcuts......................................................... 39
creating ....................................................................... 596
creating for pull-down menu options .......................... 600
defining ...................................................................... 597
standard ...................................................................... 598
L Intersect ...........................See Intersections, cleaning L
Labels ....................................................................... 344–46
customizing ................................................................ 345
door ............................................................................ 346
inserting symbol into .................................................. 346
placing in drawing ...................................................... 346
room ........................................................................... 345
window ....................................................................... 346
Landings
color of ....................................................................... 565
depth of ...................................................................... 564
intermediate ................................................................ 565
modeling ..................................................................... 564
thickness of................................................................. 565
Layer Manager........................................................ 189–98
adding layers with ...................................................... 195
changing a layer’s color with...................................... 193
changing a layer’s name with ..................................... 194
changing a layer’s number with.................................. 190
changing layer settings with ....................................... 191
changing on/off layer settings with............................. 191
deleting layer(s) with .................................................. 196
designating the active layer with ................................ 192
erasing entities from a layer with ............................... 196
exiting from ................................................................ 197
locking/unlocking layers with .................................... 192
moving layers with ..................................................... 190
opening ....................................................................... 189

reverting to previous layer settings with .................... 197
sorting layers with ...................................................... 190
turning all layers on with ........................................... 192
using Cancel in .......................................................... 197
using Undo to restore old layer settings ..................... 197
Layer Ref .......................................See Layers, refreshing
Layer search ............................................58, 217, 221, 422
selection ....................................................................... 57
status of ........................................................................ 59
status toggle ................................................................. 34
Layer Sets
creating ...................................................................... 186
deleting ...................................................................... 187
loading ....................................................................... 187
Layer Snap See Snapping, on layers, See Obect snapping,
on layers
Layers
active............................................................................ 34
adding (tutorial) ......................................................... 102
assigning colors (tutorial) .......................................... 103
changing active (tutorial) ........................................... 103
changing color ........................................................... 181
changing the active .............................................. 34, 179
creating ...................................................................... 179
creating layer sets....................................................... 186
customizing settings for symbols ............................... 380
defining materials for each......................................... 188
deleting ...................................................................... 183
deleting with Layer Sets............................................. 187
displaying................................................................... 179
erasing contents of ..................................................... 182
filtering .............................................................. 184, 494
including in PDF of drawing...................................... 406
loading ....................................................................... 185
loading with Layer Sets ............................................. 187
locking ....................................................................... 181
moving 3D entity to ................................................... 493
moving entities to another .................................. 183, 308
moving SPB-filled entities on same layer .................. 309
naming convention for ............................................... 186
order of ...................................................................... 206
planning ....................................................................... 63
refreshing ................................................................... 180
refreshing in order of creation .................................... 206
renaming .................................................................... 181
renaming (tutorial) ..................................................... 102
saving ......................................................................... 184
searching for ...................................................... 183, 184
seed ............................................................................ 179
setting the active ................................................ 179, 183
setting Z base and height for ...................................... 189
setting Z base for current layer only .......................... 420
setting Z height for current layer only ........................ 420
swapping SPB-filled entities on same layer ............... 310
toggling all on ............................................................ 180
toggling on and off ..................................................... 180
unlocking ................................................................... 181
using Z By Layer ....................................................... 420
viewing ...................................................................... 182
Z By Layer ................................................................. 189
Layout ..................................................................... 410–14
multi-scale ........................................................... 410–14
multi-scale plot .......................................................... 410
plots ..................................................................... 410–14
single-scale ................................................................ 410
using Quick Layout .................................................... 410

LeftExtn ........................................ See 3D stairs, treads of
Line spacing, for hidden lines ...................................... 517
Line Type Manager .................................................. 70–72
adding embedded line types ......................................... 71
changing line spacing with ........................................... 71
customizing embedded line types ................................. 71
enabling end correction with ........................................ 71
selecting external line types.......................................... 71
standard line types ........................................................ 70
using ............................................................................. 70
Line types ........................................................................ 70
creating ................................................................. 70, 591
displaying ................................................................... 206
exporting ...................................................................... 52
for hidden lines ........................................................... 516
menu ............................................................................. 70
settings ......................................................................... 72
using ............................................................................. 65
Line weight ...................................................................... 72
copying ......................................................................... 55
displaying ................................................................... 206
Lines
connecting two lines with ................................... 252, 294
dividing ...................................................................... 288
dividing with Golden Mean ........................................ 289
marking intersection of ............................................... 289
maximum.................................................................... 307
measure angle excluded between two......................... 284
measure angle included between two ......................... 284
measuring angle of ..................................................... 283
measuring length of .................................................... 282
measuring total length of ............................................ 285
style for dimensions............................................ 349, 350
style options for angle and curve dimensions ..... 356, 358
style options for linear dimensions ............................. 352
welding ....................................................................... 297
LineWgt .................................................... See Line weight
Link ............................................................ See Hyperlinks
entity to go-to-view .................................................... 525
LinrWndw ........................... See Windows, linear bays of
Load
layer sets ..................................................................... 187
text styles .................................................................... 337
wall styles ................................................................... 214
Lock .................................................... See Layers, locking
Macros
2D DataCAD AEC, 2D elevators ......................... 256–58
Arrows ........................................................................ 383
ClipIt .......................................................................... 320
customizing menu in Program Preferences .................. 53
DataCAD AEC ........................................................... 386
DataCAD AEC, 2D stairs ..................................... 254–56
EZ Tools ..................................... 390, 392, 394, 397, 399
FormAtr .............................................................. 304, 610
FrameIt ............................................................... 538, 541
Lin2Wall .................................................................... 304
RoofIt ......................................................................... 542
Mansard roofs ............................................................... 435
Marker ........................................................................... 427
generating points for TIN model ................................ 473
Marking, intersection of two lines ............................... 289
Mask................................................................................. 58
adding entity attributes with ....................................... 317
deleting entity attributes with ..................................... 318
Match
changing entities using ............................................... 302

changing text attributes using .................................... 303
colors ........................................................................... 62
moving 3D entities to another layer ........................... 493
moving entities to another layer with ......................... 183
setting active layer using ............................................ 183
snap grid to an entity .................................................. 290
Match Door ................... See Doors, match swing color to
Match Wall See Windows, drawing, See Doors, drawing
Materials
defining for each layer ............................................... 188
Max. Lines.. See Lines, maximum, See Drag:copy entities
using
Measure ................................................................... 282–87
Menu Bar ........................................................................ 28
Menu buttons
changing fonts of ......................................................... 46
customizing .................................................................. 44
Menu labels
customizing .................................................................. 44
Menu Window ................................................................ 37
classic .......................................................................... 38
Edit and Utility ............................................................ 38
label options ................................................................. 38
locking ......................................................................... 29
moving ......................................................................... 29
tool tips ........................................................................ 38
unlocking ..................................................................... 29
Menus
3D Menus .................................................................. 422
3D Views ................................................... 420, 422, 503
Angle Type ................................................................ 200
Architect .................................................................... 210
Change ....................................................... 301, 302, 303
Cleanup .............................................................. 252, 294
Color ............................................................................ 61
Copy .......................................................................... 260
Curves .................................................................. 232–42
Drag ........................................................................... 261
Edit .............................................................................. 73
Enlarge ....................................................................... 313
Erase .......................................................................... 315
Freehand .................................................................... 270
GoTo View ................................................................ 524
Grids .......................................................................... 175
Group ................................................................... 57, 316
Hatching...................................... 360, 363, 364, 365, 367
Identify....................................................................... 281
Insert .......................................................................... 603
Insert XREF ................................................................. 75
Layers ........................................................................ 179
Line type ...................................................................... 70
Measures .................................................................... 274
Object Snap................................. 274, 275, 276, 277, 278
Plotter ........................................................................ 153
Print/Plot .................................................................... 402
Ref. Point ................................................................... 272
Rotate ......................................................................... 310
Sel. Sets ..............................................317, 318, 319, 320
selection (entity, group, area) ....................................... 57
Settings ...................................................................... 198
Stretch ........................................................................ 312
Takeoffs ..................................................................... 285
Templates............................................605, 606, 608, 610
Text ............................................................................ 324
Text Style ........................................................... 336, 337
Toolbox.............................................................. 543, 554
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value ............................................................................. 59
Walk Through ............................................................ 527
Zoom ............................................................................ 84
Mesh surfaces ................................................................ 459
control points .............................................................. 462
creating with varying Z elevations ............................. 462
divisions of ................................................................. 461
drawing manually ....................................................... 460
rectangular .................................................................. 460
setting values for Z-User 1 and Z-User 2 ................... 462
vertical ........................................................................ 461
Mesh, drop ............................................................... 464–70
Meters .......................................... See Scales, setting types
Metric........................................... See Scales, setting types
Metric scales .................................................................. 202
Mid Point ... See Object snapping, to nearest midpoint of
line
MilliMtr ....................................... See Scales, setting types
Mirror
3D entities .................................................................. 496
and copy ..................................................................... 269
defining reflection line ............................................... 269
entities .................................................................. 268–69
text position ................................................................ 269
Miss Dist ......................... See Cursor, setting accuracy of
Miss Dist. ... See Object snapping, defining miss distance
for
MltLyout ............................... See Printing, multiple views
Monitor, working with two ............................................ 62
Mouse, snapping with middle button .......................... 275
MouseWheel, using for walk-through ......................... 526
Move Vertex ... See Vertex, moving, See Polylines, editing
vertices
MoveZ ..................................... See Moving, in Z direction
Moving
3D entities ...................................................... 493, 305–9
3D entities to another layer......................................... 493
dragging to ................................................................. 307
dragging to (tutorial) .................................................. 147
entities to absolute zero .............................................. 305
in Z direction .............................................................. 306
linear dimensions........................................................ 355
new angle ................................................................... 308
new distance ....................................................... 306, 308
previous distance ........................................................ 306
SPB-filled entities on same layer................................ 309
specified distance and angle ....................................... 306
to another layer ........................................................... 308
using Match on 3D entities ......................................... 493
view sphere................................................................. 505
Mullions
for windows ................................................................ 226
Mullions, for windows .................................................. 224
Multi-scale plotting ................................................. 410–14
adding go-to-views ..................................................... 412
renaming sheets for .................................................... 411
rotated clip cube and................................................... 410
used with go-to-views ................................................ 410
Multi-view windows, displayed in toolbar .................... 35
Natural contours ........................................................... 470
Navigation pad, toolbar .................................................. 31
Navigation toolbar, viewing with ................................... 86
Nearest .................. See Obejct snapping, to nearest point
Neg. Dist................. See Negative coordinates, displaying
Negative coordinates, displaying ................................. 204
Nested XREF ................................................................... 79

globally controlling display of ..................................... 80
using pop-up menu to control ...................................... 79
New Distance ............................... See Copy, new distance
New Elevation Indicator ...................................... 507, 508
and Z-base and Z-height settings ............................... 508
and zero plane ............................................................ 508
cursor changes to ....................................................... 421
NewDist ........................................ See Copy, new distance
Newel posts
as symbols.................................................................. 572
color of....................................................................... 573
cylindrical .................................................................. 572
depth of ...................................................................... 572
divisions of ................................................................ 572
modeling .................................................................... 571
radius of ..................................................................... 572
rectangular ................................................................. 572
width of ...................................................................... 572
NewelPst ............................. See 3D stairs, newel posts for
NewLayer .......................................... See Layers, creating
NewLine ....................... See Tangents, drawing curves as
No Change .............................................. See Color, menus
No Prim Edge.......... See Hidden line removal, displaying
outlines in
No. of Sides.................................................... See Polygons
No. Points ............ See Object snapping, to dividing point
Normal ................................... See Angles, setting types of
Nosing ........ See Stairs, drawing 2D with DataCAD AEC
for stair treads ............................................................ 567
round .......................................................................... 567
square ......................................................................... 567
NumCab ........See Elevators, drawing 2D with DataCAD
AEC
NumRiser ... See Stairs:drawing 2D with DataCAD AEC
o2c
adding 3D models as e-mail attachment ...................... 99
adding 3D models to web page .................................... 99
exporting objects .......................................................... 98
inserting object into drawing........................................ 82
inserting objects ......................................................... 381
Objects to See .............................................................. 99
Object snapping ............................................................ 274
defining miss distance for .......................................... 274
drawing line perpendicular to entity .......................... 278
increasing speed of............................................. 274, 275
on layers ..................................................................... 274
placing dimensions with ............................................ 349
show point.................................................................... 56
tangent to arc.............................................................. 279
to center of 3D circular entities .................................. 274
to dividing point ......................................................... 276
to entities in active selection set ................................. 274
to hatch lines .............................................................. 274
to nearest center point ................................................ 277
to nearest endpoint ..................................................... 276
to nearest intersection point ....................................... 278
to nearest midpoint of line ......................................... 277
to nearest point ........................................................... 275
to nearest quadrant point ............................................ 277
to symbol insertion point ........................................... 274
Object Viewer
checking Z offset of symbols with ............................. 375
raytracing with ........................................................... 530
selecting from View menu ......................................... 528
using toolbar icons ..................................................... 529
using with Symbol Browser ....................................... 372

Oblique views .......................................................... 512–13
axonometrics .............................................................. 512
creating elevation ....................................................... 512
creating plan ............................................................... 512
elevation ..................................................................... 512
plan ............................................................................. 512
rotation angle for ........................................................ 512
settings for .................................................................. 512
Offset.................. See Entities,offsetting and copying, See
Stairs:drawing 2D with DataCAD AEC
OnSide ...................................See Balusters, placement of
OnStrng .................................See Balusters, placement of
OnTread ................................See Balusters, placement of
OpenStr .............................................. See Stringers, open
Orphaned Bitmap Manager, using to resolve ............... 83
Orphans
using Reference File Manager with .............................. 80
XREF, resolving ........................................................... 80
Out Sill .......................................... See Windows, drawing
Overhead doors ............................................................. 217
Overshoot ................................................................ 72, 206
adding to existing line .................................................. 73
displaying ..................................................................... 73
setting ........................................................................... 72
Palettes, using customized colors ................................. 207
Pan
with keyboard ............................................................... 85
with mouse ................................................................... 85
Pan/Scrolls, remembering .............................................. 56
Parallel views............................................................. 503–8
elevations.................................................................... 507
isometric ..................................................................... 506
new view center as new grid origin for snapping ....... 504
using view sphere for ................................................. 504
Password, setting........................................................... 198
Paste ........................................................................... 73, 74
Paste Special .............................................................. 73, 74
Pattern Fills .................................................. See SPB Fills
PDF
batch plotting to .......................................................... 417
create drawing file as .................................................. 406
saving layers with ....................................................... 406
saving MSP details as layers with .............................. 406
Pen Table ................................................................. 408–10
map to color................................................................ 409
save settings in .DPF file ............................................ 409
set pen colors .............................................................. 408
set pen density ............................................................ 408
set pen width .............................................................. 408
settings for .BMP and .JPG images ............................ 382
settings for SPB fills ................................................... 367
use settings saved in .DPF file .................................... 410
Pen width ..................................... See Printing, pen width
Perimeter, measuring circle or polyline ...................... 285
Perp ... See Object snapping, drawing line perpendicular
to entity
Perspective views .................................................... 508–11
1-point ........................................................................ 510
2-point ........................................................................ 511
3-point ........................................................................ 511
camera settings for...................................................... 510
cone of vision ..................................................... 509, 510
eyepoint of .......................................................... 508, 509
focal point of ...................................................... 508, 509
hither clip in ............................................................... 509
tutorial ........................................................................ 167

using view sphere for ................................................. 504
Picture plane ................................................................. 509
Plane snap ..................................................................... 421
changing zero plane orientation ................................. 420
positioning zero plane with ........................................ 422
Plane Snap ................................................. See Plane snap
Plotting .............................................. 402–17, See Printing
check plot ................................................................... 407
multi-scale ........................................................... 410–14
multi-scale layout ....................................................... 410
scale ........................................................................... 404
single-scale ................................................................ 410
tutorial.................................................................. 152–57
Plotting scale .................... See Printing, plotting scale for
Pocket doors.................................................................. 217
Point to Point, measuring ............................................ 283
Polygons .................................................................. 230–31
converting from closed polyline to ............................ 247
hide edge of................................................................ 441
normals ...................................................................... 520
show edge of .............................................................. 441
surface area of ............................................................ 483
Polylines
adding cover to closed ............................................... 251
adding voids to ................................................... 254, 365
closed ......................................................................... 247
connecting two edges with chamfer ........................... 252
connecting two edges with fillets ............................... 252
converting closed shape to ......................................... 247
converting lines and arcs into..................................... 246
converting to lines and arcs........................................ 246
converting to polygon ................................................ 247
converting to slab ....................................................... 247
converting voids to polygon....................................... 254
covered....................................................................... 245
deleting an edge ......................................................... 250
drawing ................................................................ 243–54
drawing by segments ................................................. 244
editing ........................................................................ 246
editing arcs ................................................................. 249
editing vertices ....................................247, 248, 249, 251
erasing voids from ..................................................... 254
finding centroid of closed .......................................... 253
hatching master containing voids ....................... 254, 365
measuring area of closed ............................................ 252
measuring perimeter of closed ................................... 252
rectangular ................................................................. 243
removing cover of closed ........................................... 251
repositioning .............................................................. 250
tracing ........................................................................ 287
tracing 2-point arcs .................................................... 287
tracing 3-point arcs .................................................... 287
tracing tangent arcs .................................................... 287
PrevDist ..........................................See Distance, previous
Preview
plot saved as PDF ...................................................... 406
plots ................................................................... 405, 406
Primary divisions
of spheres ................................................................... 455
of surfaces of revolution ............................................ 458
of torus ....................................................................... 456
Printing ................................................................... 402–17
batch plotting ....................................................... 414–17
changing view to match a detail ................................. 413
check plot ........................................................... 404, 407
color ........................................................................... 409
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copying all details from one sheet to another ............. 414
copying one detail from one sheet to another ............. 413
editing details ............................................................. 412
editing sheets .............................................................. 412
effective plotting area for paper size .......................... 403
erasing all details on a sheet ....................................... 412
erasing selected details on a sheet .............................. 412
gray scale .................................................................... 409
laying out your drawing for ................................ 405, 410
layout orientation ....................................................... 404
loading pen table settings for ...................................... 410
moving a detail from one sheet to another .................. 414
moving a detail on a sheet .......................................... 413
multiple views .................................................... 405, 410
multi-scale plots ......................................................... 410
multi-scale plotting ............................................... 410–14
multi-scale plotting (tutorial) ...................................... 155
paper orientation ......................................................... 403
paper size for .............................................................. 403
Pen Table ...................................................... 405, 408–10
in tutorial ................................................................ 153
Pen Table settings for .BMP and .JPG images ........... 382
Pen Table settings for SPB fills .................................. 367
pen width .................................................................... 404
plotting scale .............................................................. 404
preview of plot ................................................... 405, 406
quick layouts for ......................................... 405, 410, 415
renaming sheets .......................................................... 412
rotating plot for........................................................... 405
saving pen table settings for ....................................... 409
selecting printer for .................................................... 403
sheets in batches ......................................................... 415
toggling layers on in a detail ...................................... 413
tutorial .................................................................. 152–57
updating a detail on a sheet with layer settings........... 413
using pen table settings............................................... 410
widths of pen passes ................................................... 409
Program Preferences
background color .......................................................... 45
creating new drawing with default ............................... 24
DXF/DWG import........................................................ 50
menu button font .......................................................... 46
pathnames ..................................................................... 42
Program, launching external in DataCAD ................... 99
Project
drawing efficiently ....................................................... 65
managing .................................................................... 174
planning entire .............................................................. 63
planning layers ............................................................. 63
Project Directory ........................................................ 174
sample .......................................................................... 65
set files ....................................................................... 417
Projection pad, toolbar ................................................... 31
Purging, with Purge Drawing dialog ............................. 94
Quadrant ....... See Object snapping, to nearest quadrant
point
Quick............... See Object snapping, increasing speed of
Quick Layout................... See Printing, quick layouts for
Quick Search ................. See 3D entities, selecting curved
Quick snapping ..................................................... 422, 426
Radians .................................. See Angles, setting types of
Radius
curve, dimension of .................................................... 357
draw circle based on ................................................... 238
of 3D stair handrails ................................................... 568
of arc, changing .......................................................... 236

of balusters ................................................................. 570
of circles .................................................................... 444
of cones ...................................................................... 450
of curve, measuring.................................................... 283
of curved stairs ........................................................... 563
of horizontal cylinders ....................................... 447, 448
of newel posts ............................................................ 572
of torus ....................................................................... 456
Rafters, drawing ........................................................... 437
Rails ........... See Stairs, drawing 2D with DataCAD AEC
RAY files
exporting ...................................................................... 98
light sources in ............................................................. 98
Raytrace, with Object Viewer ..................................... 530
Recovering
lost drawing, process for .............................................. 91
lost files.................................................................. 91–93
Recovering lost drawing
process for.................................................................... 92
Rect. Array ......................... See Copy, rectangular array
Rectangl .... See Newel posts, rectangular, See Balusters,
rectangular, See Handrails, rectangular
Rectangle ........... See Polylines, drawing rectangular, See
Drawing, rectangles
drawing ...................................................................... 231
drawing 3D polygons ................................................. 430
drawing slabs ............................................................. 430
Rectangular arrays....................................................... 495
Redo ................................................................................. 73
Ref. Point............................. See Reference point, floating
Reference File Manager
accessing with pop-up menu ........................................ 81
binding reference files with.......................................... 78
deleting reference files with ......................................... 78
disabling nested XREF display .................................... 79
displaying nested XREF with ...................................... 79
displaying selected layers with .................................... 77
highlighting XREF entities from.................................. 79
inserting reference files ................................................ 75
refreshing files with ..................................................... 77
reloading reference files with ....................................... 77
using ............................................................................ 76
Reference point ....................................................... 272–74
fixed ........................................................................... 272
floating ....................................................................... 272
show current................................................................. 56
using with direction distance...................................... 273
Referencing
files ........................................................................ 74–81
image files.................................................................. 381
Referencing drawings .............................................. 74–81
and binding .................................................................. 78
and displaying layers in ............................................... 77
and refreshing .............................................................. 77
and reloading ............................................................... 77
context-sensitive pop-up menu for ............................... 81
deleting ........................................................................ 78
disabling nested ........................................................... 56
highlighting .................................................................. 79
orphaned ...................................................................... 80
resolving orphaned ....................................................... 80
retaining highlight settings ........................................... 56
self-referencing XREFs ............................................... 75
using Reference File Manager ..................................... 76
using stamps............................................................... 381
with unique clipping boundaries .................................. 76

Reflection line, defining ................................................ 269
Relative Cartesian entry ................................................. 68
Relative polar entry ........................................................ 68
drawing line with .......................................................... 69
Remove
cutouts in walls ........................................................... 215
doors ........................................................................... 219
windows ..................................................................... 222
Rename ........................................... See Layers, renaming
Rendering
by color ...................................................................... 532
by layer ....................................................................... 531
settings for ............................................................ 531–35
Rendering, defining materials for each layer ............. 188
Reports
about symbols ............................................................. 378
generating for symbols ............................................... 378
symbol text attribute data ........................................... 344
using Report Forms dialog ......................................... 378
Rev. Surface ............................ See Surfaces of revolution
RghtExtn ...................................... See 3D stairs, treads of
Right-hand rule ............................................................. 503
Rise angles ............................................................. 454, 458
RiserHgt............................... See 3D stairs, riser height of
Risers ............................................................................. 565
color of ....................................................................... 566
height of ..................................................................... 565
thickness of................................................................. 566
RndNosng .............................. See Nosing, for stair treads
Roll angles ..................................................................... 456
Roof framing ........................................................... 541–49
overhang for ............................................................... 542
pitch for ...................................................................... 542
purlin height for .......................................................... 542
rafters for .................................................................... 542
sheathing for ............................................................... 542
with FrameIt ............................................................... 541
with RoofIt ................................................................. 542
Roofs
A-frame ...................................................................... 434
dormer ........................................................................ 436
exterior elevations of .................................................. 391
framing ................................................................. 541–49
gable ........................................................................... 434
hip ...................................................................... 435, 436
mansard ...................................................................... 435
rafters for .................................................................... 437
shed ............................................................................ 434
Roofs, 3D
adding (tutorial) .......................................................... 163
boundaries for............................................................. 544
joining ........................................................................ 546
modeling ..................................................................... 543
polygonal .................................................................... 544
rectangular .................................................................. 544
settings for .................................................................. 547
types of ....................................................................... 542
Rooms, labels for ........................................................... 345
Rotate
3D entities ............................................................ 495–96
and copy entities ......................................................... 311
area selection toggle ..................................................... 58
center of 3D ................................................................ 496
dynamically ................................................................ 311
entities ........................................................................ 310
setting new angle of .................................................... 312

Rotation angles
in 3D views ................................................................ 503
setting ........................................................................ 506
Ruled surface ................................................................ 484
between two closed concentric polylines ................... 485
between two contour lines ......................................... 484
treated as TIN model.................................................. 486
using 3D Knife with ................................................... 486
Save All ............................................See Drawings, saving
Save As .............................................See Drawings, saving
Save Delay ...... See Saving drawings, delay for automatic
saves
Save Image ..... See Hidden line removal, saving image of
Saving
automatic ................................................................... 204
drawing sessions .......................................................... 55
drawings....................................................................... 86
drawings, delay for automatic saves .......................... 204
layers.......................................................................... 184
Scale .................................. See Printing, plotting scale for
drawing ........................................................................ 56
plot, saving current ...................................................... 56
plotting ......................................................................... 56
Scales
architectural ............................................................... 202
engineering ................................................................ 202
metric ......................................................................... 202
setting types ....................................................... 199, 200
Screen calibration........................................................... 43
Screen coordinates........................................................ 506
Scroll distance ................................................... 31, 85, 204
Search Hatch ........... See Object snapping, to hatch lines
Search, contour of closed polyline ............................... 245
Secondary divisions
of spheres ................................................................... 455
of surfaces of revolution ............................................ 458
of torus ....................................................................... 456
Sectioning tool, 3D ........................................................ 487
Sections.................................................................... 398–99
cabinet........................................................................ 399
cabinet styles for ........................................................ 399
creating 2D sections from 3D model ......................... 487
SectnLin .... See Stairs, drawing 2D with DataCAD AEC
Sel. Set ............. See Object snapping, to entities in active
selection set, See Selection, by selection set
Select Fill Color/Pattern .............................................. 365
Selection
3D, by area ................................................................... 59
3D, by fence ................................................................. 59
by area.................................................................... 57, 58
by crossing ............................................................. 57, 58
by entity ....................................................................... 57
by fence.................................................................. 57, 58
by group ....................................................................... 57
by layer search ............................................................. 57
by point ........................................................................ 57
by selection set ............................................................. 57
Selection sets ..................................................... 58, 316–20
adding entities automatically to ................................. 320
adding entities to ........................................................ 317
clearing ...................................................................... 319
deleting entities from ................................................. 318
displaying entities in .................................................. 317
naming ....................................................................... 319
replaced by Mask ......................................................... 58
Self-XREF, inserting ...................................................... 75
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Set Active ....... See Layers, setting the active, See Layers,
changing the active
Set All............................................................................. 281
Set Index, creating series of concentric contours with
.................................................................................... 471
Set Snap ..................................See Grids, changing size of
Set Z User 2 ............. See Z alternative elevations, setting
SetBays...... See Windows, curved bays of, See Windows,
linear bays of
Settings
add value definitions .................................................. 200
angle type ................................................................... 199
change value definitions ............................................. 201
changing 3D ............................................................... 423
cursor miss distance.................................................... 203
delete value definitions ............................................... 201
display big cursor ....................................................... 203
display draw marks ..................................................... 203
display negative coordinates....................................... 204
edit angle definitions .................................................. 200
edit distance definitions .............................................. 200
edit scale definitions ................................................... 200
for drawings ............................................................... 198
load custom definitions .............................................. 201
number of primary divisions ...................................... 423
number of secondary divisions ................................... 423
panning distance ......................................................... 204
password ..................................................................... 198
save custom definitions .............................................. 201
scale type .................................................................... 199
scroll distance ............................................................. 204
smallest grid ............................................................... 203
Z-elevations ................................................................ 423
Setup program .................... See Installation of DataCAD
Shaded image .......................................................... 518–21
creating ....................................................................... 518
saving ......................................................................... 521
saving shader settings ................................................. 521
settings for .................................................................. 518
using a .LIT file .......................................................... 521
Shader
background color of.................................................... 519
background image ...................................................... 520
cast shadows ............................................................... 520
checking normals of polygons .................................... 520
creating shaded image with ........................................ 518
draw edge lines ........................................................... 519
edge type .................................................................... 519
entity receiving shadow .............................................. 520
highlight ..................................................................... 520
light settings ............................................................... 518
loading light information ............................................ 521
overshoot lines............................................................ 519
rendering .................................................................... 520
saving settings ............................................................ 521
settings for .................................................................. 518
shadow plane .............................................................. 520
show lights ................................................................. 520
sun light source settings.............................................. 519
Shading .................................................................... 518–21
Shed roofs ...................................................................... 434
Shortcuts
creating keyboard ....................................................... 596
creating keyboard for pull-down menu options .......... 600
defining keyboard ....................................................... 597
standard keyboard ...................................................... 598

ShowVals ............................... See Walls, displaying styles
ShowZ.. See Z-base, displaying, See Z-height, displaying
Sig. Digits ................................. See Decimal, place setting
SigDigit ........................................ See Scales, setting types
Sill Height...................................... See Windows, drawing
Single doors ................................................................... 217
Single tee concrete forms, drawing ............................. 555
Site model with drop mesh .................................... 464–70
Sketch, using Freehand to............................................ 270
Slab Refs...................... See Slabs, reference face markers
Slabs
adding vertices to ....................................................... 439
converting from closed polyline to ............................ 247
deleting vertices from ................................................ 440
editing ........................................................................ 439
hide edge of................................................................ 441
horizontal ................................................................... 431
moving vertices in ...................................................... 440
rectangular ................................................................. 430
reference face markers ............................................... 433
show edge of .............................................................. 441
thickness of ........................................................ 430, 434
vertical ....................................................................... 432
Sliding doors ................................................................. 217
Small Grid ............................ See Display, options, setting
Small Symbol ............. See Symbols, smallest display size
Small Text .................... See Text, displaying smallest size
Smooth Pass ................. See Contours, smoothing surface
Snap grid
changing size of ......................................................... 175
matching to an entity.................................................. 290
new view center becomes new grid origin ................. 504
setting (tutorial) ......................................................... 102
setting angle of ........................................................... 176
using .......................................................................... 174
Snap Point ............................. See Snapping, point adding
SnapAngle ........................ See Snap grid, setting angle of
Snapping ................................................................. 274–81
3D point ..................................................................... 427
adding to Get X distance ............................................ 279
grid origin for............................................................. 504
object ......................................................................... 274
on layers ..................................................................... 422
plane .......................................................................... 421
point, adding .............................................................. 274
quick .................................................................. 422, 426
subtracting from Get X distance ................................ 279
to add to or subtract from defined angle .................... 280
to define an angle ....................................................... 280
to enter horizontal distance ........................................ 279
to enter vertical distance ............................................ 279
using middle mouse button for................................... 275
virtual ......................................................................... 280
with Get-Snap ............................................................ 279
Solid Fills....................................................... See SPB Fills
Sorting
layers, alphabetically ................................................. 191
layers, by color........................................................... 191
layers, by layer number .............................................. 191
layers, by lock status .................................................. 191
layers, by number of entities in .................................. 191
layers, by on/off status ............................................... 191
using Layer Manager for ............................................ 190
SPB Fills ........................................................................ 365
choosing colors for fill and pattern ............................ 366
choosing pattern ......................................................... 366

controlling X/Y aspect of bitmap fills ........................ 366
moving entities on same layer .................................... 309
moving filled entities .................................................. 367
printing controls with Pen Table ................................ 367
selecting .BMP or .JPG image .................................... 366
swapping entities on same layer ................................. 310
using instead of hatch patterns.................................... 365
using Select Fill Color/Pattern dialog ......................... 365
Spelling
adding word to user dictionary ................................... 331
checking for and correcting errors .............................. 328
modify checking criteria ............................................. 329
Spheres........................................................................... 455
beginning rise angle for .............................................. 454
drawing....................................................................... 454
ending rise angle for ................................................... 455
SqrNosng ............................... See Nosing, for stair treads
Stack Frac..................................................... See Fractions
Stairs
3D ......................................................................... 254–56
creating 3D with Z-elevations in rectangular arrays ... 268
drawing 2D with DataCAD AEC ......................... 254–56
Stamps
format exported ............................................................ 56
inserting in drawing .................................................... 381
values updated automatically ..................................... 381
Start Ang .......................................... See Curves, drawing
Start Angle............................. See Angles, setting types of
Status panel
active layer ................................................................... 34
layer search toggle ........................................................ 34
toolbar .......................................................................... 33
Stiffness ..................................... See Contours, stiffness of
STL files
exporting ...................................................................... 98
inserting into drawing ................................................... 82
Stretch ............................................................................ 312
3D entities .................................................................. 497
changing arc radius with ............................................. 236
StrForm ...............................................See 3D stairs, form
Stringers
closed ......................................................................... 567
color of ....................................................................... 568
in center of stairs ........................................................ 567
on left side of stairs .................................................... 567
on right side of stairs .................................................. 567
open ............................................................................ 567
thickness of................................................................. 568
width of ...................................................................... 567
StrWell ....... See Stairs, drawing 2D with DataCAD AEC
StrWidth .... See Stairs, drawing 2D with DataCAD AEC
Styles
arrow options for angle and curve dimensions ... 356, 358
for automatic linear dimension ................................... 350
for automatic linear dimensions ................................. 354
for linear dimension arrows ........................ 349, 350, 353
for linear dimension lines ........................... 349, 350, 352
for linear dimension text ............................. 348, 350, 351
for walls...................................................................... 213
line options for angle and curve dimensions ...... 356, 358
text options for angle and curve dimensions ...... 356, 357
Surfaces of revolution ................................................... 457
drawing....................................................................... 458
Survey data file
creating drop mesh from ..................................... 464, 465
creating TIN model from ............................................ 474

deleting duplicate points from.................................... 475
Swapping, SPB-filled entities on same layer .............. 310
Swing Color .............................. See Doors, swing color of
Swng Style .................................. See Doors, swing style of
SWOTHLUDFB ............................................................. 34
Symbol Browser
deactivating Explode in.............................................. 376
deleting symbol from ................................................. 377
docking ...................................................................... 371
editing symbols with .......................................... 375, 377
exploding symbol with............................................... 376
opening symbol collection ......................................... 371
placing symbols using ................................................ 373
reloading symbol definitions with .............................. 378
replacing symbols with .............................................. 377
retaining settings for .................................................. 380
selecting symbols from .............................................. 373
undocking .................................................................. 370
using Object Viewer with .......................................... 372
viewing symbols with ................................................ 372
X and Y divisions for ................................................. 371
Symbols
adding text attributes to...................................... 341, 380
angle of rotation ................................................. 374, 376
attributes in DWG file.................................................. 25
balusters as ................................................................. 570
changing size of ......................................................... 604
changing Z offset ....................................................... 375
converting to lines and arcs........................................ 604
copying (tutorial) ....................................................... 145
creating .............................................................. 376, 608
creating a handle for new ........................................... 376
creating text attributes for .......................................... 341
customizing layer settings for .................................... 380
defining new .............................................................. 376
defining text attributes for .......................................... 341
definition of ............................................................... 378
deleting from drawing ................................................ 611
deleting from template ............................................... 611
deleting unused from drawing.................................... 379
dragging to position ................................................... 373
editing ................................................................ 375, 608
editing information about ........................................... 377
editing information fields of ...................................... 609
editing information fields with FormAtr macro ......... 610
editing text attributes of ............................................. 343
enlarging ............................................................ 375, 605
erasing........................................................................ 611
exploding ........................................................... 375, 604
exploding and editing while placing in your drawing 608
files, finding and using older...................................... 604
fixed rotation .............................................................. 374
generating report on text attribute data ...................... 344
inserting ............................................................. 373, 603
inserting in drawing without Symbol Browser........... 603
inserting into labels .................................................... 346
inserting with Template ............................................. 605
inserting with Z offset ................................................ 605
insertion points displaying ......................................... 206
layer settings for ........................................................ 380
mirroring ............................................................ 373, 375
naming ....................................................................... 608
newel posts as ............................................................ 572
offsetting insertion height of ...................................... 375
opening (tutorial) ....................................................... 141
opening another (tutorial) .......................................... 144
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opening collection of .................................................. 371
placing .................................................................. 371–73
placing (tutorial) ......................................................... 142
placing in drawing ...................................................... 373
previewing .................................................................. 604
purging from drawing ................................................. 611
purging unused from drawing..................................... 379
reducing .............................................................. 373, 375
replacing ..................................................................... 610
replacing several ......................................................... 610
reports about ............................................................... 378
rotating ....................................................................... 604
rotating dynamically ................................................... 374
saving ................................................................. 376, 608
selecting................................................................ 371–73
selecting (tutorial) ...................................................... 142
setting angle of rotation .............................................. 375
settings shown in Attention toolbar ............................ 374
smallest display size ................................................... 206
text attributes for ................................................ 341, 380
using stamps ............................................................... 381
System requirements ...................................................... 18
T Intersect ...........................See Intersections, cleaning T
Takeoffs ......................................................................... 285
Tangent arcs, tracing .................................................... 287
Tangents .................. See Obejct snapping, tangent to arc
contours ...................................................................... 470
drawing 3D arcs as ..................................................... 444
temporary line, drawing arc using .............................. 237
Template files, finding and using older ....................... 604
Templates .................................................................. 606–7
changing number of divisions in ................................ 607
creating ....................................................................... 606
creating additional information fields for ................... 607
divisions ..................................................................... 606
editing......................................................................... 607
fields ........................................................................... 606
naming ........................................................................ 606
opening another .......................................................... 606
selecting symbols from ............................................... 606
Text .......................................................................... 324–46
adding attributes to symbols ............................... 341, 380
adding to drawing ....................................................... 324
adding word to user dictionary ................................... 331
adjusting to fit in area ................................................. 327
aligning....................................................................... 327
arrows, drawing (tutorial) ........................................... 131
attribute, generating report on .................................... 344
attributes for symbols ......................................... 341, 380
changing angle of ....................................................... 325
changing appearance of .............................................. 324
changing aspect ratio of .............................................. 325
changing attributes of ................................................. 302
changing properties of TrueType font ................ 325, 339
changing scale of ........................................................ 325
changing size of .......................................................... 325
changing style of TrueType font ........................ 325, 339
changing weight of ..................................................... 325
checking and correcting spelling ................................ 328
creating attributes for symbols ................................... 341
deleting styles ............................................................. 337
displaying ................................................................... 205
displaying smallest size .............................................. 206
drawing arrows ........................................................... 338
editing (tutorial).......................................................... 132
editing symbol attributes ............................................ 343

entering directly into drawing .................................... 325
exporting .................................................................... 336
importing ................................................................... 336
inserting ..................................................................... 326
inserting notes (tutorial) ............................................. 130
inserting room names (tutorial) .................................. 129
inserting TrueType text in drawing ............................ 340
justifying ............................................................ 325, 326
loading styles ............................................................. 337
menu ............................................................................ 56
modifying spelling criteria ......................................... 329
scale ............................................................................. 56
setting attributes (tutorial) .......................................... 128
setting parameters for TrueType fonts ....................... 339
style for dimensions ........................................... 348, 350
style options for angle and curve dimensions .... 356, 357
styles of ...................................................................... 336
using TrueType (TTF) fonts for ................................. 339
Thickness
of 3D stair landings .................................................... 565
of 3D stair risers......................................................... 566
of 3D stair stringers.................................................... 568
of 3D stair treads ........................................................ 566
of doors ...................................................................... 219
of slabs ............................................................... 430, 434
of vertical cylinders ................................................... 446
TIN Model
concentric steadily rising contour lines for ................ 472
controlling contour divisions ..................................... 479
creating contour lines for ........................................... 472
cutting polygons from ................................................ 481
deleting duplicate surveyor’s points........................... 475
flip valley between two triangles ............................... 481
generating from contour lines .................................... 472
generating from Marker points .................................. 474
generating from surveyor’s points ............................. 474
generating points with Marker for.............................. 473
generating with smoother edges ................................. 477
using 3D knife............................................................ 481
using color slice ......................................................... 477
using edge factor for .................................................. 477
TIN Modeler ........................................................... 471–82
Title block
boxes in ...................................................................... 386
creating (tutorial) ....................................................... 148
defining ...................................................................... 386
detail blocks in ........................................................... 386
drawing ...................................................................... 387
location of .................................................................. 386
size of......................................................................... 386
To Layer ............ See Copy, to another layer, See Layers,
moving entities to another
Tool tip ............................................................................ 29
Toolbars .......................................................................... 29
action codes for .......................................................... 585
Architect context-sensitive......................................... 210
attention ....................................................................... 35
context-sensitive .......................................................... 32
coordinates ................................................................... 35
creating custom .......................................................... 583
creating icons for ....................................................... 584
customizing .................................................................. 29
dialog box .................................................................... 29
Draw ............................................................................ 49
drop-down items ........................................................ 584
Edit .............................................................................. 49

hints .............................................................................. 35
hotspots in status panel ................................................. 34
icon button size........................................................... 584
icons access menu functions ......................................... 29
locking .......................................................................... 29
message ........................................................................ 35
moving ......................................................................... 29
multiview windows ...................................................... 35
navigation pad .............................................................. 31
projection pad ............................................................... 31
selecting default............................................................ 48
standard ........................................................................ 30
status panel ................................................................... 33
SWOTHLUDFB........................................................... 34
unlocking ...................................................................... 29
viewer ........................................................................... 31
viewing with Navigation icons ..................................... 86
view-sensitive ............................................................... 31
Toolbox
3DStairs ................................................................ 254–56
Concrete ..................................................................... 554
Torus .............................................................................. 455
beginning roll angle for .............................................. 456
ending roll angle for ................................................... 456
primary divisions of.................................................... 456
radius of...................................................................... 456
secondary divisions of ................................................ 456
Tracing
2-point arcs ................................................................. 287
3-point arcs ................................................................. 287
polylines ..................................................................... 287
tangent arcs................................................................. 287
Translator
default settings for DXF/DWG files ............................. 51
DWG/DXF ................................................................. 578
importing DWG and DXF files with ............................ 25
Trd/Run1 ................... See 3D stairs, treads in first run of
Trd/Run2 .............. See 3D stairs, treads in second run of
Trd/Run3 ................. See 3D stairs, treads in third run of
TrdLngth ............................ See 3D stairs, tread length of
TrdWidth... See Stairs, drawing 2D with DataCAD AEC
Treads ............................................................................ 566
color of ....................................................................... 567
depth of ...................................................................... 566
extensions of............................................................... 566
nosing for ................................................................... 567
thickness of................................................................. 566
Trimming................................................................. 294–97
entities ................................................................ 295, 296
entities to end at a specified line ................................. 295
entities to intersection of two lines ............................. 296
entities, specified ........................................................ 296
TrueType fonts ..................... See Fonts, TrueType (TTF)
converting to 3D ......................................................... 340
inserting text in drawing ............................................. 340
setting text parameters for .......................................... 339
using instead of CHR fonts......................................... 339
TrueType fonts (TTF) .....339, See Text, using TrueType
(TTF) fonts for
TTF ..................................................... See TrueType fonts
Tutorial
3D viewing ................................................................. 155
adding layers .............................................................. 102
assigning layer colors ................................................. 103
automated 3D modeling ....................................... 160–65
border, creating........................................................... 146

border, moving ........................................................... 147
changing active layer ................................................. 103
cleaning wall intersections ......................................... 111
dimensions, automatic ............................................... 135
dimensions, drawing string of .................................... 133
dimensions, setting..................................................... 133
dimensions, stretching ............................................... 136
drawing
doors ...................................................................... 116
windows ................................................................ 121
drawing text arrows ................................................... 131
drawing walls ............................................................. 105
editing text ................................................................. 132
hatching ..................................................................... 138
inserting notes ............................................................ 130
inserting room names ................................................. 129
multi-scale plotting .................................................... 155
printing, pen table ...................................................... 153
renaming layers .......................................................... 102
setting snap grid for ................................................... 102
setting text attributes .................................................. 128
symbols, copying ....................................................... 145
symbols, opening ....................................................... 141
title block, creating .................................................... 148
viewing 3D model ................................................ 166–71
Undo ................................................................................ 73
Ungroup ..................................... See Entities, ungrouping
Units ............................................ See Scales, setting types
Up Left ....... See Stairs:drawing 2D with DataCAD AEC
Up Only ...... See Stairs:drawing 2D with DataCAD AEC
Up Rght ...... See Stairs:drawing 2D with DataCAD AEC
UpAndDn ... See Stairs:drawing 2D with DataCAD AEC
Vertex
adding ................................................................ 247, 439
deleting .............................................................. 248, 440
moving ....................................................... 247, 248, 440
moving while keeping angle .............................. 247, 249
of polygons ................................................................ 231
Vertical 3D polygons .................................................... 431
Vertical cylinders
divisions of ................................................................ 446
thickness of ................................................................ 446
Vertical slabs ................................................................ 432
VertOfst............................See Balusters, vertical offset of
View center
changing with Edit Plane ........................................... 504
changing with New Elev. ........................................... 504
repositioning .............................................................. 504
View Layer ......................................... See Layers, viewing
View sphere ................................................................... 504
changing eye point for view ....................................... 504
formerly "globe" ........................................................ 504
moving ....................................................................... 505
operating .................................................................... 505
repositioning in Drawing Window ............................. 505
using for parallel views .............................................. 504
using for perspective views ........................................ 504
Viewer/Shader
defining materials with .............................................. 531
saving material assignments in .DMF file .................. 534
using for color mapping ............................................. 531
Viewing
3D models (tutorial) ................................................... 162
advanced 3D (tutorial) ............................................... 166
changing..................................................................... 166
layers.......................................................................... 182
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selected entities in 3D model ...................................... 521
using arrow keys for ..................................................... 85
using Clip Cube for .................................................... 521
using Navigation toolbar for ......................................... 86
Views
3D oblique ............................................................ 512–13
3D perspective ...................................................... 508–11
adding current to GoTo View list ............................... 524
changing ..................................................................... 166
changing an existing GoTo View ............................... 524
changing center of ...................................................... 504
deleting an existing GoTo View ................................. 524
isometric ..................................................................... 506
linking an entity to a GoTo View ............................... 525
moving an existing GoTo View.................................. 524
parallel .................................................................... 503–8
perspective (tutorial)................................................... 167
remembering previous .................................................. 56
renaming an existing GoTo View ............................... 525
shaded image ........................................................ 518–21
Virtual snapping ........................................................... 280
Visibility
hide edge of polygon or slab ...................................... 441
show edge of polygon or slab ..................................... 441
Voids
adding ......................................................................... 438
adding to polyline ............................................... 254, 365
converting ................................................................... 438
converting to polygon ................................................. 254
erasing ........................................................................ 439
erasing from a polyline ............................................... 254
hatching polyline that contains ................................... 365
Volume, measuring circle or polyline .......................... 286
VRML files, exporting 3D models to ............................. 97
Walk through a model
customizing options for .............................................. 526
looking ....................................................................... 527
perspective navigation controls .................................. 526
perspective view ......................................................... 526
saving a view of.......................................................... 528
stepping ...................................................................... 527
turning ........................................................................ 527
using hotkeys .............................................................. 526
using MouseWheel ..................................................... 526
Viewer toolbar ............................................................ 526
walking ....................................................................... 527
Wall framing ........................................................... 539–41
plate settings for ......................................................... 540
stud settings for .......................................................... 541
wall height for ............................................................ 540
Wall Style Manager ...................................................... 213
deleting wall styles with ............................................. 215
displaying wall style settings ...................................... 215
saving changes............................................................ 214
specifying options ...................................................... 214
using wall styles ......................................................... 214
Walls
2-line .................................................................. 210, 211
3-line .................................................................. 210, 211
3-line attributes ................................................... 211, 212
4-line .................................................................. 210, 211
4-line attributes ........................................................... 212
attributes ..................................................................... 212
capping ............................................................... 211, 213
cleaning ...................................................................... 213
cleaning (tutorial) ....................................................... 111

cleaning intersections ................................................. 211
cutting ........................................................................ 215
defining by cavity center ............................................ 211
defining by center ...................................................... 211
deleting styles ............................................................ 215
displaying styles......................................................... 215
drawing ................................................................ 210–16
drawing (tutorial) ....................................................... 105
finishing for models (tutorial) .................................... 164
framing................................................................. 539–41
loading styles ............................................................. 214
removing opening from.............................................. 215
setting attributes of............................................. 211, 212
styles .......................................................................... 213
welding .............................................................. 219, 297
width of ...................................................................... 211
WallStyl .................................................... See Walls, styles
Welding ......................................................................... 297
Width
of 3D stair handrails ................................................... 568
of balusters ................................................................. 570
of newel posts ............................................................ 572
of stair stringers ......................................................... 567
of walls ...................................................................... 211
Windows
adding 3D (tutorial) ................................................... 160
curved bays of ............................................................ 225
drawing ................................................................ 220–27
drawing (tutorial) ....................................................... 121
drawing in elevations ................................................. 394
labels for .................................................................... 346
linear bays of.............................................................. 223
mullions ............................................................. 224, 226
removing .................................................................... 222
width of jamb ............................................................. 221
World coordintates....................................................... 506
X Enlargmnt .......................... See Enlarge, in X direction
X Intersect ........................... See Intersections, cleaning X
XREF ........................................See Referencing drawings
circular ......................................................................... 75
highlight settings, retain ............................................... 56
inserting into drawing .................................................. 75
inserting self-XREF ..................................................... 75
nested, disable .............................................................. 56
resolving orphaned ....................................................... 80
self-referencing ............................................................ 75
with Clip Cube ............................................................. 76
working with nested ..................................................... 79
XREF Clip .......... See Clip Cube, defining in XREF with
XREF Clip
Y Enlargmnt .......................... See Enlarge, in Y direction
Z alternative elevations, setting ................................... 424
Z By Layer .................................................................... 189
settings for current layer only .................................... 420
Z Enlargmnt .......................... See Enlarge, in Z direction
Z Inc. X ... See Arrays, using Z elevations in rectangular
Z Inc. Y ... See Arrays, using Z elevations in rectangular
Z offset, for symbols ..................................................... 375
Z-base
displaying................................................................... 204
for 3D lines ........................................................ 420, 424
setting for each layer .................................................. 189
to thickness ................................................................ 430
to Z-height ................................................................. 430
Z-Dist ........................ See Distance, stretch in Z direction
Z-elevations

changing ..................................................................... 423
using in rectangular arrays.......................................... 268
Zero plane ........................................................ 420–22, 424
and New Elevation Indicator ...................................... 508
Z-height
displaying ................................................................... 204
for 3D lines ......................................................... 420, 424
setting for each layer .................................................. 189
to thickness ................................................................. 430

Zoom................................................................................ 84
free zoom using menu .................................................. 85
to extents of drawing.................................................... 85
with Navigation toolbar ............................................... 86
Zoom options .................................................................. 41
scroll wheel and ........................................................... 56
Z-User 1................................. See Z alternative elevations
Z-User 2.........See Z alternative elevations, setting, See Z
alternative elevations
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